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Technical Support
Altair provides comprehensive software support via web FAQs, tutorials, training classes, telephone, and
e-mail.

Altair One Customer Portal
Altair One (https://altairone.com/) is Altair’s customer portal giving you access to product downloads, a
Knowledge Base, and customer support. We recommend that all users create an Altair One account and
use it as their primary portal for everything Altair.

When your Altair One account is set up, you can access the Altair support page via this link:
www.altair.com/customer-support/

Altair Community
Participate in an online community where you can share insights, collaborate with colleagues and peers,
and find more ways to take full advantage of Altair’s products.

Visit the Altair Community (https://community.altair.com/community) where you can access online
discussions, a knowledge base of product information, and an online form to contact Support. These
valuable resources help you discover, learn and grow, all while having the opportunity to network with
fellow explorers like yourself.

Altair Training Classes
Altair’s in-person, online, and self-paced trainings provide hands-on introduction to our products,
focusing on overall functionality. Trainings are conducted at our corporate and regional offices or at your
facility.

For more information visit: https://learn.altair.com/

If you are interested in training at your facility, contact your account manager for more details. If you
do not know who your account manager is, contact your local support office and they will connect you
with your account manager.

Telephone and E-mail
If you are unable to contact Altair support via the customer portal, you may reach out to technical
support via phone or e-mail. Use the following table as a reference to locate the support office for your
region.

When contacting Altair support, specify the product and version number you are using along with
a detailed description of the problem. It is beneficial for the support engineer to know what type
of workstation, operating system, RAM, and graphics board you have, so include that in your
communication.

Location Telephone E-mail

Australia +61 3 9866 5557 anzsupport@altair.com

Brazil +55 113 884 0414 br_support@altair.com

https://altairone.com/dashboard
https://www.altair.com/customer-support/
https://community.altair.com/community
https://learn.altair.com/
mailto:anzsupport@altair.com
mailto:br_support@altair.com
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Location Telephone E-mail

Canada +1 416 447 6463 support@altairengineering.ca

China +86 400 619 6186 support@altair.com.cn

France +33 141 33 0992 francesupport@altair.com

Germany +49 703 162 0822 hwsupport@altair.de

Greece +30 231 047 3311 eesupport@altair.com

India +91 806 629 4500

+1 800 425 0234 (toll free)

support@india.altair.com

Israel israelsupport@altair.com

Italy +39 800 905 595 support@altairengineering.it

Japan +81 3 6225 5830 support@altairjp.co.jp
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Mexico +52 55 5658 6808 mx-support@altair.com

New Zealand +64 9 413 7981 anzsupport@altair.com

South Africa +27 21 831 1500 support@altair.co.za

South Korea +82 704 050 9200 support@altair.co.kr

Spain +34 910 810 080 support-spain@altair.com

Sweden +46 46 460 2828 support@altair.se

United Kingdom +44 192 646 8600 support@uk.altair.com

United States +1 248 614 2425 hwsupport@altair.com

If your company is being serviced by an Altair partner, you can find that information on our web site at
https://www.altair.com/PartnerSearch/.

See www.altair.com for complete information on Altair, our team, and our products.
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Introduction to WinProp 1

1 Introduction to WinProp

WinProp is a complete suite of tools in the domain of wireless propagation and radio network planning.
With applications ranging from satellite to terrestrial, from rural via urban to indoor radio links,
WinProp’s innovative wave propagation models combine accuracy with short computation time.

This chapter covers the following:

• 1.1 WinProp Overview  (p. 15)

• 1.2 WinProp Applications  (p. 18)

• 1.3 WinProp Components  (p. 23)

• 1.4 How to Get Started  (p. 27)

• 1.5 About This Manual  (p. 28)
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1.1 WinProp Overview
WinProp is a comprehensive and leading simulation tool in the domain of wireless propagation and radio
network planning.

Figure 1: Applications range from satellite to terrestrial, from rural via urban to indoor radio links.

Propagation Models
WinProp's powerful simulation methods are all high-frequency methods, valid when the geometrical
features are much larger than the wavelength of the signal. Several methods are fully three-
dimensional, consider 3D object data and compute all rays in 3D. Other focus on the vertical plane only.

For example, the following empirical models, semi-empirical models (calibration with measurements
possible) and ray optical propagation models are supported for urban scenarios:

• COST 231 extended Walfisch-Ikegami model

• Empirical vertical plane model with knife edge diffraction

• Urban dominant path model (DPM)

• 3D ray-tracing model

Besides the prediction of the path loss, the delay and angular spread can be computed as well as LOS /
NLOS, directional channel impulse response, angular profile and propagation paths.

Databases
WinProp supports the following databases to describe geometry:

• Pixel database

◦ Typically used for rural/suburban scenarios. Elevations and optionally land usage are stored on
a pixel by pixel basis.

• 2.5D Vector database

Proprietary Information of Altair Engineering
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◦ Typically used for urban scenarios. Each building or vegetation object is described by a
polygonal ground plane and an individual height above street level using polygonal cylinders. If
the urban area is not flat, the topography can be included.

• 3D Vector database

◦ Typically used for indoor scenarios or small outdoor scenarios. Each building or other object
is described by flat polygons with arbitrary orientations. This allows maximum geometrical
freedom.

Computation and Simulation
WinProp allows the planning of coverage and capacity as well as network simulations (for example, the
performance of algorithms, analysis of delays). Depending on the application, WinProp offers static,
Monte-Carlo, and dynamic network simulators. You can define the (location dependent) traffic for circuit
and for packet switched services (for example, statistical distributions and mobility).

Coverage
Different transmission modes can be defined (with parameters including bandwidth, coding schemes,
required signal-to-noise-and-interference ratio, signal threshold, transmit power) upon which the
coverage maps (for example, cell assignment, best server, active set, channel quality, received power
in downlink and uplink, signal-to-noise-and-interference ratio) are computed individually for each
transmission mode. Link adaptation is considered and depends on the channel quality predicted with the
propagation models. Maximum received power as well as maximum achievable data rates, are predicted
accurately for each location in the coverage area.

Capacity
WinProp calculates the capacity (for example, throughput, maximum data rates, packet delays,
QoS) of the different radio links and cells in the network based on the coverage analysis and the
traffic assumptions. Capacity limitations and overloaded cells are detected easily and networks are
optimized to provide both high capacity and throughput. Capacity improvements due to MIMO and / or
beamforming are modeled accurately due to the sophisticated deterministic propagation models.

Arbitrary antenna configurations (linear, circular) are possible and their impact on the radio channel is
determined during the propagation analysis.

WinProp API
The WinProp API enables flexible integration into other software tools.

A description of the API interface is available in the installation directory, together with C/C++ sample
project for MS Visual Studio.

WinProp and Feko Interaction
Design the antenna and calculate the radiation characteristic in terms of a 3D antenna pattern using
Feko. Then superimpose the far field on the 3D radio channels calculated with WinProp.

WinProp supports the import of antenna patterns from several sources, including Feko. You can
design the antennas and calculate the radiation patterns in Feko, and use those patterns to represent
transmitting and receiving antennas in the radio channel analysis in WinProp.
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WinProp also supports the import and processing of radar cross section patterns calculated by Feko. To
accelerate certain simulations in WinProp, for example, for automotive RADAR, complex vehicles can be
substituted by their radar cross sections.

Updater
WinProp has an updater utility that allows you the flexibility to install an update containing new
features, minor software enhancements and bug fixes on top of an existing base installation. Use the
Launcher utility to launch the Updater.

Altair Units
WinProp is part of the Altair Units based licensing system which allows metered usage of the entire
Altair suite of products. This value-based licensing model has been extended to Altair's extensive
partner network, providing the most comprehensive and dynamic set of solutions to the market.
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1.2 WinProp Applications
WinProp is used in, but not limited to, the following applications:

Automotive - antenna evaluation
Analysis of car-antenna performance along a trajectory using a virtual drive test or a simulation
with explicit time variance. In a virtual drive test, one evaluates wireless connectivity along a
trajectory, for example, a trajectory of several kilometers length near an LTE base station in a
(sub)urban scenario. While the antenna moves, the geometry is stationary. In a simulation with
explicit time variance (usually on a smaller scale), car traffic is explicitly present and moving as
well.

Telecommunication - radio network planning for urban scenario
Analysis of a radio network in an urban scenario. For example, you can optimize the network
coverage of a cellular network while taking into account the effects of buildings, vegetation and
topography.

Telecommunication - indoor radio network planning
Analysis of a radio network indoor. An example includes optimizing a WiFi network to give the best
coverage inside an office building.

Wireless Sensors - planning of sensor networks
Connectivity analysis of wireless sensor networks that monitors physical or environmental
conditions. An example includes the placement of a sensor network inside an industrial
environment to automate assembly lines.

Railway - in-cabin radio coverage
Connectivity analysis of the transmit antennas in a train. An example includes optimizing the WiFi
network in-cabin and also taking into account the seats and a separate room.

Aerospace - airport radio coverage
Analysis of radio coverage at airports between the terminals and aeroplanes. An example includes
the coverage of an aeroplane that as it moves away from the terminal to the runway.

1.2.1 Automotive
Evaluate antenna performance using a virtual-drive test in WinProp. Evaluate different car antenna
configurations regarding receiving power and MIMO throughput.

Define the topography, building, cars, test route and air interface (for example, LTE). Superimpose
three-dimensional car antenna patterns (calculated with Feko) and analyze the radio waves impinging
on the car antenna along the test route as well as possible antenna configurations based on
performance indicators.

The following configurations are supported:

• Car-to-car communication

• Car-to-infrastructure communication

• Radar channel (collision avoidance)
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Figure 2: Examples of car-to-car communication (top) and collision avoidance (bottom).

1.2.2 Telecommunication
WinProp's technologies make the tool applicable to the planing of both urban and indoor radio networks.

Indoor Radio Network Planning
Process 3D building vector data that includes outer and inner walls, subdivisions like doors and widows.
Specify the construction materials and their electrical properties or import from a database containing
industry standard materials. Analyze the receiving coverage and throughput (data rate) for WiFi
planning or an indoor site for a cellular network.

Figure 3: An example of an indoor radio network planning.
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Urban Scenario Radio Network Planning
Process 3D building vector data superimposed to terrain layer using highly accurate wave propagation
models for macro-cells and micro-cells.

Figure 4: An example of an urban radio network planning.

1.2.3 Wireless Sensors
Wireless sensor networks consist of spatially distributed autonomous sensors to cooperatively monitor
physical or environmental conditions (for example, temperature, sound, vibration, pressure, motion or
pollutants).

Applications for wireless sensor networks are varied, typically involving some kind of monitoring,
tracking, or controlling using, for example, WirelessHart, ZigBee and LoRa. Specific applications include
habitat monitoring, object tracking, nuclear reactor control, fire detection, and traffic monitoring.

WinProp covers the following simulation aspects:

• Connectivity between the sensor nodes of the wireless network.

• Channel assignment in a self-organizing sensor network.

• Determination of optimum paths between sensor and gateway nodes taking into account different
criteria, such as best SNIR, minimum path delay.

1.2.4 Railway
WinProp can be used to evaluate the in-cabin radio coverage.

In the world of ubiquitous networking, people want to have continuous connectivity even when
travelling. Using WinProp you can evaluate and plan different transmitting antennas and leaky feeders
to ensure strong in-cabin radio coverage on trains.
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Figure 5: An example of in-cabin radio coverage analysis.

1.2.5 Aerospace
WinProp is well suited to the analysis of airport radio coverage.

At airports, communication between aeroplanes and terminals are paramount to ensure the safety of
people. WinProp is the leading tool to analyze the radio coverage within terminals and aeroplanes. It
allows for the evaluation of different transmitter options and the resulting coverage situation as well as
considering aeroplanes as obstacles when determining radio coverage.
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Figure 6: Ray tracing between communication tower (on the left) and
aeroplane and the radio coverage at the airport terminal (to the right).
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1.3 WinProp Components
ProMan
The central tool in the WinProp suite is ProMan (propagation manager). ProMan is where you define and
edit the simulation project settings, the simulator for all scenarios and where you display and evaluate
results.

Figure 7: A detailed multi-floor indoor building in an urban surrounding.

WallMan
WallMan is the graphical editor for vector building databases. It is used to prepare a geometry database
that can become part of the ProMan project. Preparing such geometries in WallMan, or even just
converting them from other sources in WallMan, is a common step in indoor and urban scenarios.

In rural scenarios, WallMan is often not needed, since databases such as elevation maps and land-usage
maps can be imported directly into ProMan.

WallMan is also instrumental in preparing hybrid urban / indoor scenarios, where some buildings are
described with interior detail while others are not.
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Figure 8: The graphical database editor for WallMan.

TuMan
TuMan (tunnel manager) is a graphical editor to prepare tunnel and stadium geometries efficiently.
Geometries from TuMan can be exported to WallMan to add further detail if needed.

Figure 9: The tunnel propagation models included in ProMan's
tunnel module can predict the propagation inside the tunnel.

AMan
AMan (antenna manager) is the graphical editor for antenna patterns that are used to prepare antenna
patterns for use in ProMan. It is not an antenna simulator but can convert antenna patterns from other
sources to the correct format. It can also generate an approximate 3D antenna pattern in cases where
only two 2D pattern cuts are available. Furthermore, when antennas are combined on masts, AMan will
generate the combined pattern, taking all necessary effects into account.
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Figure 10: An 3D antenna pattern.

CoMan
CoMan (connectivity manager) is the connectivity simulator for sensor and MESH networks used to
simulate wireless sensor networks.

Figure 11: Point to multipoint prediction on multiple height levels.

CompoMan
CompoMan is the editor for components used in wireless indoor network installations.
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Figure 12: The CompoMan editor.
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1.4 How to Get Started
If you are new to WinProp, take the following steps to learn about WinProp.

1. The WinProp Getting Started Guide contains step by step instructions on how to use WinProp.

2. The WinProp Example Guide contains examples that show the application of features as
discussed in the WinProp User Guide. The example projects assumes you are familiar with the
interface and focusses on solving more realistic problems. Find an example close to a problem of
interest and follow the steps to solve the problem. These tutorials are available in the installation
directory.

3. The WinProp User Guide contains information regarding WinProp and its features.

4. The Altair web site[2], provides additional resources as well as online training (self-paced
training).

5. The Altair Community[3] allows you to post a question or view answers from previous posts. Join
the active forum community to get email notifications of new content.

2. https://www.altair.com/feko-applications

3. https://community.altair.com
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1.5 About This Manual
The WinProp User Guide is part of the WinProp documentation and is an extensive reference guide to
using WinProp.

If you are a beginner user, you are recommended to view the WinProp Example Guide.

1.5.1 Purpose of This User Guide
The WinProp User Guide provides guidance, best practices and comprehensive technical information
regarding the key concepts in WinProp.

1.5.2 Document Conventions
The WinProp User Guide makes use of a number of conventions to help you quickly learn about Feko.

• Hyperlinks are indicated in blue.

• Text cited from the GUI interface, are written in bold text, for example, Default Settings.

• A combination of keystrokes is joined with the “+” sign, for example, Alt+Shift+O.

• To draw your attention to important information, the information is marked as a note, tip or
warning, for example:

Note:  This is a note to draw your attention to critical information.

1.5.3 Feedback
We value your feedback regarding the WinProp components and the documentation.

If you have comments or suggestions regarding the WinProp component and the documentation, please
contact your local Altair representative.
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2 Typical Workflow in WinProp

View the typical workflows when working with propagation simulations in specific scenarios, how to
add a network planning to a propagation simulation, include a receiver pattern, set up a time-variant
scenario, include multiple-input multiple-output (MIMO) at both the base station and the mobile station,
connectivity analysis of sensor networks and optimization.

This chapter covers the following:

• 2.1 Indoor Propagation  (p. 30)

• 2.2 Urban Propagation  (p. 33)

• 2.3 Combined Urban / Indoor Propagation  (p. 36)

• 2.4 Rural / Suburban Propagation  (p. 38)

• 2.5 Propagation in Tunnels  (p. 41)

• 2.6 Network Planning  (p. 42)

• 2.7 Inclusion of the Receiver Antenna Pattern  (p. 44)

• 2.8 Time-Variant Scenarios  (p. 46)

• 2.9 MIMO in Network Planning  (p. 48)

• 2.10 MIMO Through Post-Processing  (p. 49)

• 2.11 Connectivity Analysis for Sensor Networks  (p. 50)

• 2.12 Optimization Manager  (p. 51)

• 2.13 Interaction With Other Tools   (p. 53)
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2.1 Indoor Propagation
The workflow for a typical indoor propagation simulation is to use WallMan to create the geometry, Feko
or AMan to produce the antenna pattern and ProMan to simulate the model and view the results.

For a typical indoor propagation simulation, the steps are as follows:

1. Use WallMan to produce the geometry database.

This can be done by creating it from scratch (possibly by drawing it with the aid of an existing
bitmap) or by converting it from another source, making modifications if needed, and saving it in
WinProp format.

Optionally, an indoor database can be pre-processed in WallMan to establish visibility relations for
ray-tracing, to avoid repetitive work during the actual ray-tracing later in ProMan.

Note:  File extensions for WallMan indoor databases are .idb[4].

Figure 13: Office building being drawn in WallMan with the aid of a bitmap.

2. Use Feko or AMan to produce the antenna pattern.

For actual antenna design and simulation, Feko (part of the Altair Simulation Products) can be
used. Feko can export antenna patterns in the correct format to be used by ProMan.

Note:  Files with 3D antenna patterns have extension .ffe, .apa[5] or .apb[6].

AMan is not an antenna simulator. Instead, it is a tool that enables you to produce an antenna
pattern in WinProp format. The pattern may be converted from another source. AMan can also

4. indoor database binary

5. antenna pattern ASCII

6. antenna pattern binary
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generate an approximate 3D antenna pattern in cases where only two 2D pattern cuts are
available.

Figure 14: Antenna pattern of a WLAN router exported from Feko and displayed in AMan.

3. Start a new indoor propagation project in ProMan based on the database produced in WallMan.
The key menu in ProMan is Project > Edit Project Parameter. This brings up a window with
multiple tabs, specific to the simulation of interest, where many simulation parameters are
specified.

Figure 15: The key menu in ProMan is Project > Edit Project Parameter ....

In this menu, you also select the simulation method. The multi-wall method is fast, but may
under-estimate power levels far from the transmitter, after the signal has travelled through
many walls. Of the more-rigorous methods, the dominant path model is recommended for pure
coverage studies without multipath effects, while standard ray-tracing or intelligent ray-tracing is
recommended in case the temporal or angular properties of the radio channel are of interest.

4. Run the simulation in ProMan through the Computation menu or click the RUN PRO button.

Figure 16: Click the RUN PRO button to run the simulation.

5. Inspect the results in the same ProMan interface. Expand the tree on the left if necessary to
access the results.
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Figure 17: Example of indoor propagation results.
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2.2 Urban Propagation
The workflow for a typical urban propagation simulation is to use WallMan to create the geometry, Feko
or AMan to produce the antenna pattern and ProMan to simulate the model and view the results.

For a typical urban propagation simulation, the steps are as follows:

1. Use WallMan to produce the geometry database.

This can be done by creating it from scratch (possibly by drawing it with the aid of an existing
bitmap) but is usually done by importing and converting it from a third-party source, making
modifications if needed, and saving it in WinProp format.

Optionally, an urban database can be pre-processed in WallMan to establish visibility relations for
ray-tracing, to avoid repetitive work during the actual ray-tracing later in ProMan. In an urban
database, the objects are polygonal cylinders with individual heights. Vegetation can be included
as well. For more detail in the buildings, use indoor (even if the scenario is really outdoor) or
hybrid urban / indoor.

Note:  File extensions for WallMan urban databases are .odb [7].

Figure 18: Example urban database in WallMan. Buildings are polygonal objects.

2. Use Feko or AMan to produce the antenna pattern.

For actual antenna design and simulation, Feko (part of the Altair Simulation Products) can be
used. Feko can export antenna patterns in the correct format to be used by ProMan.

7. outdoor database binary
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Note:  Files with 3D antenna patterns have extension .ffe, .apa [8] or .apb[9].

AMan is not an antenna simulator. Instead, it is a tool that enables you to produce an antenna
pattern in WinProp format. The pattern may be converted from another source. AMan can
generate an approximate 3D antenna pattern in cases where only two 2D pattern cuts are
available and can combine antenna patterns to produce that of a base station.

Figure 19:  Base station patterns produced in AMan by combining individual antenna patterns
with the geometrical and material specifications of the base station mounting structure.

3. Start a new urban propagation project in ProMan based on the database produced by WallMan.

Elevation data can be included at the time of importing the urban database. The key menu in
ProMan is Project > Edit Parameter. This brings up a window with multiple tabs, specific to the
simulation of interest, where many simulation parameters are specified.

Figure 20: The key menu in ProMan is Project > Edit Project Parameter.

In this menu, you also select the simulation method. Several empirical models are fast but may
be less accurate than rigorous methods. Of the more-rigorous methods, the dominant path model
is recommended for pure coverage studies without multipath effects, while standard ray-tracing
or intelligent ray-tracing is recommended in case the temporal or angular properties of the radio
channel are of interest.

4. Run the simulation in ProMan through the Computation menu or by clicking the RUN PRO
button.

8. antenna pattern ASCII

9. antenna pattern binary
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Figure 21: Click the RUN PRO button to run the simulation.

5. Inspect the results in the same ProMan interface. Expand the tree on the left if necessary to
access the results.

Figure 22: Example of urban propagation results.

Fields can optionally penetrate into the buildings, but interior details of the buildings are not included.
While fields can travel into an urban building, they cannot travel through an urban building and come
out on the other side.
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2.3 Combined Urban / Indoor Propagation
The workflow for a combined urban and indoor propagation simulation is to import the geometry and
save it in WallMan, use Feko or AMan to produce the antenna pattern and ProMan to simulate the model
and view the results.

The typical workflow for combined urban / indoor simulations is close to that for urban simulations.
The difference lies in the model preparation in WallMan. There, you import an existing indoor database
(.idb file) into an urban database. After importing the indoor database, you can move and rotate it to
give it the correct position and orientation among the other buildings.

Note:  The combined database is saved as an urban .odb file.

Figure 23: Combined urban/indoor database.

The rest of the process is identical to a regular urban simulation. A few more simulation options appear
when defining parameters in ProMan. For example, the resolutions of the indoor and outdoor results can
be chosen to differ.
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Figure 24: Combined urban / indoor solution.

Fields can optionally travel through the outer walls of urban buildings from outside to inside, but for
those buildings, no interior detail is included. Also, fields that penetrate such buildings do not exit on
the other side. For the indoor part of the database, interior walls, doors, windows, and any other details
that were defined are included. Fields travelling from the exterior to the interior of such buildings and
vice versa are automatically included in the results.
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2.4 Rural / Suburban Propagation
The workflow for a typical rural or suburban simulation is to import the terrain profile into ProMan,
AMan to produce the antenna pattern and ProMan to simulate the model and view the results.

For a typical rural or suburban propagation simulation, the work flow is as follows:

1. WallMan is usually not needed since a terrain profile is usually generated by a third party and
imported directly into ProMan. However, a terrain profile can be imported into WallMan in special
cases.

2. Use Feko or AMan to produce the antenna pattern.

For antenna design and simulation, Feko can be used. Feko can export antenna patterns in .ffe
format, which ProMan can import.

AMan is not an antenna simulator. Instead, it is a tool that enables you to produce an antenna
pattern in WinProp format. The pattern may be converted from another source. AMan can
generate an approximate 3D antenna pattern in cases where only two 2D pattern cuts are
available and can combine antenna patterns to produce that of a base station.

Figure 25: Base station patterns produced in AMan by combining individual antenna patterns
with the geometrical and material specifications of the base station mounting structure.

3. Start a new rural / suburban database in ProMan. Along with the topology (elevation) database, a
land-usage (clutter) database can be loaded. A topology database specifies the hills while a land-
usage database specifies the kind of surface the signals encounter, for example, forest, fields,
water, sub-urban and buildings.
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Figure 26: Example land-usage database, used in addition to an elevation.

The key menu in ProMan is Project > Edit Project Parameter. This brings up a window with
multiple tabs, specific to the simulation of interest, where many simulation parameters are
specified.

Figure 27: The key menu in ProMan is Project > Edit Project Parameter.

In this menu, you also select the simulation method. Several empirical models are fast but may
be less suited for hilly terrain. Basic topological models take the topology into account. The
deterministic two-ray model includes vertical multipath. The 3D Dominant Path Model is the most
rigorous method for pure coverage studies without multipath effects.

4. Run the simulation in ProMan through the Computation menu or by clicking the RUN PRO
button.

Figure 28: Click the RUN PRO button to run the simulation.

5. Inspect the results in the same ProMan interface. Expand the tree on the left if necessary to
access the results.
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Figure 29: Example coverage results for the Grand Canyon, computed with
the dominant path model. Transmitter power 40 dBm, frequency 948 MHz.
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2.5 Propagation in Tunnels
The workflow for a typical propagation simulation in a tunnel is to use TuMan to create the tunnel
geometries, use Feko or AMan to produce the antenna pattern and use ProMan to simulate the model
and view the results.

For a typical propagation simulation in a tunnel, the workflow starts with TuMan (Tunnel Manager).

TuMan is a specialized module to create tunnel geometries. In TuMan, you define tunnel trajectories and
tunnel cross sections. Junctions are possible as well. Prediction planes are also defined in TuMan.

Figure 30: Defining a tunnel cross section and a prediction plane in TuMan.

Once the tunnel was defined, export the geometry as an indoor database. From here, the workflow is
the same as for a regular indoor propagation simulation. This indoor database can be further elaborated
in WallMan if needed or be brought directly into ProMan.
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2.6 Network Planning
Whether the scenario is indoor, urban or rural, a network planning simulation can be regarded as post-
processing of a propagation simulation.

The preparations in WallMan and AMan are exactly the same as for a regular propagation simulation.

The first difference occurs in ProMan when defining a new project: you specify that the project is a
network-planning project instead of a propagation analysis without network planning.

Figure 31: Specify a network-planning project.

For network planning, the air interface (for example, CDMA, OFDM) are to be defined with parameters
related to carriers (number, bandwidth, separation), transmission modes, coding, required signal-to-
noise-and-interference ratio at the receiver. This information may be loaded from a file with extension
.wst or defined manually.

In ProMan, most of the simulation setup is done under Project > Edit Project Parameter.

Figure 32: The key menu in ProMan is Project > Edit Project Parameter.

This menu item brings up a window with several tabs: those from the regular propagation analysis,
and additional ones that are specific to network planning. If you have loaded an existing .wst file, then
most or all information necessary for the network-planning part of the simulation has already been filled
in under the relevant tabs.

A network-planning analysis starts with a regular propagation analysis, launched through the RUN PRO
button or the Computation menu. This provides results like received power over the area of interest.
The network-planning post-processing is launched through the RUN NET button or the Computation
menu.

Figure 33: Launch the network-planning processing by either clicking the RUN
NET button or click Network Simulation from the Computation menu.
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The network-planning simulation adds results like signal-to-noise-and-interference ratio (SNIR), cell
assignment, maximum data rate, maximum throughput, coverage probability. At every location in the
area of interest, whether one can communicate with a particular air interface and data rate depends on
the minimum required received power and minimum required SNIR.

Figure 34: Example signal-to-noise-and-interference plot. Two transmitters
are using the same carrier and interfere strongly in the lower-left area.
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2.7 Inclusion of the Receiver Antenna Pattern
The inclusion of the receiver antenna pattern is a post-processing step.

When no receiver antenna pattern is specified, the received-power plots in the areas of interest are
based on a hypothetical isotropic (omni-directional) receiver antenna, and only the transmitter antenna
is specified. This is sufficient for some mobile-communication scenarios in which the base stations have
directional antennas while the hand-held mobile stations have very broad antenna patterns and may be
held in any orientation.

To include a directional receiver antenna pattern and obtain the actual received power, click Project >
Edit Project Parameter > Propagation tab. Under Consideration of Antenna Properties at
Mobile Station, select the Consider Antenna of MS check box. Here, MS stands for mobile station,
but it can be any receiving antenna.

Note that the Propagation Paths check box is also selected to save the propagation paths during the
regular propagation part of the simulation. This is automatic when you select the Consider Antenna
of MS check box because the algorithm has to know, at every potential receiver location (at every pixel
in the result plot), from which directions the signals are arriving. Only then can the receiver antenna
pattern be included properly.

Click Edit Parameters to specify the receiving antenna pattern and other mobile station settings.

Figure 35: The Edit Project Parameters dialog where you can request the consideration of the receiving antenna.

The orientation of the receiving antenna depends on whether the simulations are performed for an area
(area mode) or along a trajectory (trajectory mode).

In area mode, the phi (azimuth) = 0° direction of the antenna pattern points in the X direction (east) of
the model, and the phi (azimuth) = 90° direction points in the Y direction (north) of the model.

In trajectory mode, the receiving antenna is thought to be moved along a trajectory, for example, on a
vehicle, and will make turns.
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Figure 36: The Prediction Trajectories button is used to define a trajectory or you
can use the menu: Project > Prediction Area > Prediction Trajectories:: Draw.

As mentioned, in area mode, phi = 0° points in the X direction (to the right). In trajectory mode, phi =
0° also points to the east, but now to the right of the direction of movement. Phi = 90° points forward
in the direction of movement.

Whether in area mode or in trajectory mode, the post-processing step of including the receiver antenna
pattern is launched through the menu Computation > Propagation incl. Mobile Station, or click the

 button, after the regular propagation simulation was completed.

The result is, among other quantities, the actual received power for the receiving antenna. In trajectory
mode, the result might look like Figure 37.

Figure 37: Example result of a virtual drive test.

This type of simulation is called a virtual drive test, since it is as if the receiving antenna were being
driven along the trajectory. It is not a time-variant simulation, however, since no geometrical objects in
the model move with time.
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2.8 Time-Variant Scenarios
In a time-variant scenario, objects or groups of objects are moving as a function of time. This time
variance is specified in WallMan.

The type of database is typically an indoor database since it allows more freedom in geometrical
complexity, even if the geometry that is being modeled is outdoors, such as the intersection with cars,
see Figure 39.

Figure 38: Launch the time-variance interface in WallMan to specify how groups of objects move.

Figure 39: Example of a time-variant scenario: several vehicles are moving.

Figure 40: When starting a new project in ProMan, specify Time-
Variant Scenarios (3D vector data with non-stationary objects).

When the transmitting antenna is specified in ProMan, it can either be stationary or be defined as
moving with a particular moving object (of which the movement had been defined in WallMan).

The rest of the workflow is similar to the regular propagation simulations. You can specify the time
samples of interest from the menu Project >  Edit Project Parameter > Simulation tab.
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Figure 41: Specifying the time samples of interest in ProMan for the movement that had been defined in WallMan.
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2.9 MIMO in Network Planning
Simulate multiple-input multiple-output (MIMO) systems in a network-planning project in ProMan.

The parameters are defined under Project > Edit Project Parameter > Air Interface tab.

Figure 42: Example of MIMO settings at the base station in a network planning
project. Note the MIMO Technology drop-down list and the Settings button.

In this kind of simulation, every base-station antenna element is explicitly defined in the project. For
every base-station antenna element, you have to specify which carrier it will use, which signal group
it will transmit, and, in case of MIMO, which MIMO stream it will transmit. At the receiver side, it is
assumed that the number of receiver antenna elements is at least as high as the number of MIMO
streams. The simulation results will include network-planning quantities like data rate.
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2.10 MIMO Through Post-Processing
Simulate multiple-input multiple-output systems through post processing in ProMan without network
planning.

The first stage in the workflow is to perform a regular propagation simulation in which the transmitter is
an isotropic (omni-directional) antenna. When setting up the simulation under Project > Edit Project
Parameter > Propagation tab, request the propagation paths to be saved. This is necessary to enable
the tool to include the effects of the antenna patterns later.

In the second stage in this workflow the actual antenna arrays on the transmitter and receiver side are
defined as a post-processing step through the menu: Computation > Propagation Postprocessing
incl. Tx and Rx.

This brings up a dialog where one can, through the Edit Parameters button, define the actual
antennas or antenna arrays on the base station and the mobile station and request results. The
simulation is launched through the Start Computation button.

Figure 43: The Postprocessing of Mobile Station dialog.

Results include quantities like channel capacity in bits/s/Hz. The fact that this is a post-processing
operation enables you to compare different antenna patterns and antenna arrays efficiently.
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2.11 Connectivity Analysis for Sensor Networks
The CoMan component is used to simulate the connectivity analysis of wireless sensor networks, where
sensors pass information from one to another.

There are three stages in a wireless sensor networks connectivity analysis:

1. Distribution
The sensors are distributed in their environment. For example, the sensors are deployed
in a deterministic way in an industrial area or in a deterministic or stochastic way in a
mountainous area.

2. Propagation
The path losses between pairs of sensors are determined.

3. Connectivity
The best routes from every sensor via other sensors to the central information gateway.

Results include a matrix of point-to-point predictions and a map of optimum information flow.

Figure 44: Example: map of optimum information flow for sensors in a petrochemical plant.
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2.12 Optimization Manager
The OptMan component included in the WinProp software suite allows you to optimize radio networks
designed with WinProp

Existing networks, containing transmitters with directional antennas, can be optimised regarding
azimuth and tilt adjustment of the antennas. Beyond this, the tool is able to assist during the planning
process of new radio networks by extracting a subset of specified antennas required to fulfill a user-
defined set of thresholds.

For the optimization of the adjustment of directional antennas in azimuth and tilt, the user can define
a range and increment for each antenna separately. The azimuth for one antenna can be changed,
for example, between 10° and 50° with an increment of 10°, whereas the tilt of the same or another
antenna can be specified to vary between 5° and 15° with an increment of 5°, for example. Individual
antennas can also be excluded from the optimization process and considered as fixed, or can be
disabled.

Since an optimization target has to be defined, the user has to select a result (for example, SNIR)
which shall be used for optimization. For this result, at least one target threshold has to be specified.

The tool computes all combinations of azimuth and tilt angles automatically and displays the
performance of each combination. After the simulation, the combination which provides the best
performance can be assigned and saved in the project file.

Depending on the number of combinations the computation time can be high. However, the OptMan tool
implements a time efficient approach, so that each potential sector orientation is only computed once
(regarding the propagation part). Furthermore, the user can influence the number of combinations to
be examined, and therefore the required simulation time, by using larger increments for the angles.
After a coarse tuning, a fine tuning with reduced ranges but finer increments can be done.

During the installation of new radio networks, it is often quite difficult to find the optimum location of
new transmitter antennas.

OptMan offers the possibility to find the best suitable subset of a larger set of possible, user-defined
transmitters / cells within a radio network. You first define more transmitters than you expect to
need. Based on any specified result type, for example, data rate, signal level, interference level and
corresponding optimization target definitions, OptMan finds the best subset of transmitters or cells to
fulfill these specified targets or approach the defined targets as close as possible.

The tool automatically computes the wave propagation and network planning predictions. It adds a first
transmitter or cell to the configuration from the list of available predefined transmitters or cells. Then
the next transmitter or cell is added to the network if a minimum cell area is additionally provided by
this transmitter, and so on until all user-defined thresholds are achieved.
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Figure 45: Example of a distribution of sites in Paris before and after optimization.
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2.13 Interaction With Other Tools
An application programming interface (API), written in C, is available for easy integration of WinProp in
other simulation or post-processing tools.
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3 WallMan

The WallMan component offers a convenient facility to generate and edit vector building databases.

This chapter covers the following:

• 3.1 Introduction to WallMan  (p. 55)

• 3.2 Introduction to the Interface  (p. 72)

• 3.3 Using WallMan  (p. 90)

• 3.4 Materials  (p. 178)
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3.1 Introduction to WallMan

3.1.1 Databases

General

Pixel Databases
Besides vector databases, WallMan can also handle pixel databases. They are mostly used for
topographical maps but sometimes for building databases, too. Some database providers offer urban
building databases in pixel and vector format whereas the vector format is normally more expensive.

Figure 46: Pixel databases – buildings (left) and topography (right).

WallMan can convert a building pixel database to a vector database, this is mandatory to use the
database for computations with WinProp. Topographical databases can be used in combination with an
urban vector database.

Indoor and Urban Vector Databases
If the area is not very large and if the number of buildings is small, also indoor databases can be used
to model an urban environment. Indoor and urban databases are similar – except for the orientation
of the objects. In urban databases, the basic element is a polygonal cylinder which is built with many
planar objects. Only the roof of the cylinder is defined and used. All walls are generated during the
propagation analysis when they are needed. They consist always of four corners and are vertical. This
limitation of the data format saves a lot of memory and is therefore very efficient for large databases
with several thousands of buildings.
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In indoor databases the orientation of objects is arbitrary - this is the basic difference to the urban
databases. To model a simple building with four walls and a flat roof, five objects are needed and each
object has four corners. Therefore, indoor databases are limited to smaller areas with fewer objects. But
the environment can be as arbitrary as possible – ranging from a small campus down to a single room.

Table 1:  WallMan can handle two-dimensional databases as well as three-dimensional ones.

Indoor Database Urban Database

Basic element Planar wall with polygonal shape Polygonal cylinder with uniform height

Object definition By corners By shape and height

Object orientation Arbitrary Vertical to ground

Number of corners Arbitrary (limited to 256 for some
propagation models)

Arbitrary (limited to 256 for some
propagation models)

Material Individual for each wall Individual for each building

Additional objects Subdivisions like doors and windows Vegetation and virtual buildings

A 2D indoor database consists of one floor with all walls vertical and in the same height. Opposed to
that a 3D indoor database can have objects with an arbitrary height and orientation.

Similar to that 2D outdoor databases contain buildings with equal heights and 3D outdoor databases
contain buildings with different heights.
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Indoor Databases

Figure 47: 3D View of an indoor building database.

Basic Elements: Planar Walls with Polygonal Shape
Indoor vector databases allow the description of each arbitrary object. To limit the complexity of the file
and data format, WinProp supports only planar objects. In the indoor database, they are called walls –
but such planar elements are obviously not limited to walls.

Also, tables, cupboards and all further indoor objects can be modeled with these planar elements. The
elements can have an arbitrary number of corners. Round objects must be approximated with planar
objects, see Figure 48. The more planar objects the better the approximation – but also the longer the
computation times during the propagation analysis.

Figure 48: Approximation of round objects with planar objects.

Indoor Display Concept
To allow entering and editing of walls in three-dimensional space using a two-dimensional computer
screen, you can change the view on the database that you get through your screen. Just imagine your
screen being a thin slice of the whole three-dimensional database. You can define the position of this
slice – called the view plane - in space. Everything that crosses this slice or lies exactly in the same
plane is then visible on your screen, see Figure 49.
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Figure 49: Indoor display.

When you enter a new wall, it is always placed in your current view plane. Walls crossing the view plane
appear as lines (intersection between the wall and the view plane).

Subdivisions
With indoor databases, there is sometimes the problem that a wall may contain a section with
properties other than those of the wall itself. This could be a door, a window, or even a hole. Adding
these elements as an additional wall would increase the computation time. To deal with this problem,
WallMan allows you to create subdivisions inside a wall.

Figure 50: Insertion of subdivisions.

Generally, a subdivision behaves very much like any other wall, except for the fact that it is assigned
to a specific wall and is not allowed to be located outside this wall. The subdivision may be moved or
resized inside its wall just like any other wall and its properties can be changed independently from the
properties of the assigned wall.
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Figure 51: Wall with subdivisions.

Each wall can have an arbitrary number of subdivisions. The only constraints are:

• subdivisions must be totally inside their walls and parallel to the plane of the wall

• subdivisions cannot intersect each other

Apart from holes, each subdivision can have different and individual material properties. This gives a
maximum flexibility to model the local environment as accurate as possible. Holes in a wall do not have
material properties.

Furniture
Indoor scenarios often contain areas which are difficult to model like crowds or furniture. These factors
influence the wave propagation but not in a way as walls or floors do. Therefore, WallMan provides
furniture and people objects. These objects do not interact with propagation rays (they don’t reflect
or diffract them) but they add an additional attenuation to them. Furniture objects are automatically
grouped and cannot be modified.

Prediction Planes
WinProp can handle not only vertical and horizontal prediction planes, but also arbitrary defined
polygonal prediction planes. It is also possible to simulate wave propagation predictions on the surface
of walls. Therefore, WallMan provides the possibility to easily create and edit prediction planes just like
ordinary wall objects.

Conversion of Indoor Databases
With WallMan it is possible to convert databases from many common database formats to the WinProp
format.

The following file formats are supported:

• WinProp indoor building data ASCII (.ida)

• AutoCAD file format (.dwg, .dxf)

• Autodesk 3ds Max File Format (.3ds)

• Autodesk Filmbox File format (.fbx)

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
3 WallMan p.60

• Blender File Format (.blend)

• COLLADA (.dae)

• Facet file format (.fac)

• Geography Markup Language (.gml)

• GL Transmission Format (.gltf, .glb)

• Nastran file format (.nas)

• Stereolithography file format (.stl) (Binary)

• Stereolithography file format (.stl) (ASCII)

• Stereolithography file format (.stl) (ASCII/Binary)

• Wavefront file format (.obj)

Tip:  In case imported polygons are not perfectly flat, use Objects > Triangulate selected
objects to fix this.

Urban Databases

Figure 52: 3D View of urban building database (Stockholm, Sweden).

Basic Elements: Cylinders with Polygonal Ground Plane
Urban vector databases contain a description of all buildings and vegetation areas in an urban
environment. The buildings are described by polygonal cylinders, buildings with arbitrary shapes can be
used. The building database offers the following features:
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• Each polygon can have an arbitrary number of corners (for some propagation models this is limited
to a maximum of 256 corners).

• At least 3 corners are required to define a valid polygon (building).

• Each building has a uniform height (polygonal cylinder). The height is either relative to the ground
or absolute above sea level. Absolute height values require additionally a topographical database.

• Flat rooftops are used (horizontal planes).

• Only vertical walls (parallel to the z-axis) are allowed.

• Each building has a single set of material properties which are used for the whole building.

• The polygon of a building must not intersect itself.

• The polygon of a building might intersect other polygons (buildings).

If angular roofs must be modeled, the indoor database format and prediction tools must be used.

Buildings totally inside other buildings are removed because they do not influence the wave propagation
at all. If the inner building is taller than the surrounding building it will be kept and considered as.

Up to now, the databases must be in UTM coordinates (meter) and the building ground-planes are
therefore defined in an orthogonal 2D coordinate system (x is longitude, y is latitude).

The topography itself is not included in the vector database of the buildings (only the height values can
be absolute above sea level – but no additional data about topography is included). But an arbitrary
topographical database can be considered.

Types of Buildings
Four different types of buildings are possible. The different types of buildings are:

• Standard buildings
Standard buildings can be used to model a building in an urban environment.

• Horizontal Plates
Horizontal plates can be used to model horizontal objects in an urban environment that have
a certain thickness but do not reach the ground (for example, bridges).

• Courtyards & Towers
This type of building is used to define a building which is totally inside another building. If the
inner building is higher this is called a tower and if it is lower it is called a court.

• Vegetation buildings
This type of building is used to model vegetation (for example, parks, trees). The building
is transparent (the rays have no interactions like reflection or diffraction at the vegetation
building).

• Virtual buildings
With this type of building only pixels are excluded from the prediction (all pixels inside
virtual buildings are not computed to accelerate the prediction and reduce the memory
requirements). The virtual buildings are transparent for all prediction models. So, the rays
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can pass the building without any additional loss. Only pixels inside the virtual buildings will
not be predicted to save computation time.

Table 2: Types of Buildings in Urban Databases

Type Standard Horizontal
Plate

Tower Vegetation Virtual

Interactions
with rays (refl.,
diff.)

Yes Yes Yes No, transparent No, transparent

Prediction of
pixels inside

Only with
special indoor
models

No Only with
special indoor
models

Yes, but
with add.
attenuation
[dB]

No

Rays through
the building

No No No Yes, with add.
attenuation[dB/
m]

Yes, no add.
attenuation

Material
properties

Standard Set
(Permittivity,
Permeability,
Conductance,
Reflection Loss,
Transmission
Loss,
Diffraction
Loss)

Standard Set
(Permittivity,
Permeability,
Conductance,
Reflection Loss,
Transmission
Loss,
Diffraction
Loss)

Standard Set
(Permittivity,
Permeability,
Conductance,
Reflection Loss,
Transmission
Loss,
Diffraction
Loss)

Additional
attenuation for
pixels [dB]

Additional
attenuation of
rays [dB/m]

Properties not
relevant

Building Type
ID

0 31 3 2 1

Intersection and Priority of Buildings
Buildings can intersect each other (if the polygonal groundplanes intersect). Therefore, priorities must
be defined to get a unique definition of an assignment of a given point to a building. The following
priorities are defined:

1. Courtyards (Towers)

Tallest courtyard (tower)

…….

2. Standard Buildings / Plates

Tallest standard building / plate
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…….

Standard building / plate with the lowest height

3. Vegetation Buildings

Tallest vegetation building

…….

Vegetation building with the lowest height

4. Virtual Buildings

This means that a courtyard has always a higher priority and if a courtyard is defined, all other objects
at this location are not relevant. Standard buildings completely inside other standard buildings are not
considered at all because the priority is according to the height of the building.

Display Concept
In urban mode, there is mainly the XY view plane activated. What you see is the footprint of each
building. Hereby the Z-coordinates of the corners of the building represents the height of this building.

The 3rd coordinate value (Z-coordinate) predetermines the height of new buildings. So, before you
enter a new building, adjust the Z-coordinate to the desired.

By default, all buildings in the database are visible in this view. In the settings, you can choose whether
only the buildings that are equal to or higher than the current Z-coordinate value should be displayed.

Courtyards and Towers
WallMan allows complex building structures like courtyards or towers inside a building in a very
convenient way. Additionally, overlapping buildings are allowed, which means that such building
structures will not lead to errors within the building check-in WallMan.

For this purpose, a special object type called “Courtyard or Tower Object” is available: It is a special
building object which can be completely inside another building. Normal building objects which are
completely inside another building and which are not defined as those special objects will be erased.

These objects will be referred to as included objects in the following. This object type is displayed in
beige color. It is entered as normal building objects by using the command Enter Courtyards or Towers
from the Object menu (comparable to virtual buildings and vegetation blocks).

This allows the user to model two different situations, depending on the height that is chosen for the
included object:

• A tower that is located inside a building

• A courtyard that is located inside a building
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Figure 53: Tower modeled by an included object in 3D and 2D view.

Figure 54: Courtyard modeled by an included object in 3D and 2D view.

You assign material properties to the included objects just like to normal building objects.

If partial overlapping occurs, the higher building always has higher priority. If there are two overlapping
buildings with different heights, the larger height is considered in the overlapping section, except if
there is a courtyard. Courtyards have a higher priority than normal buildings.
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Figure 55: Partly overlapping building objects with a courtyard in 3D and 2D view.

In this case, the courtyard would be considered and overrides the two buildings that are higher.

Vegetation and Time-Variant Objects
To model the influence of trees, parks on the wave propagation, vegetation blocks can be defined.
When computing a prediction in ProMan, the vegetation blocks are considered. Vegetation blocks are
characterised by two properties:

• The additional loss of pixels in vegetation blocks specifies an offset to the path loss predicted inside
vegetation blocks.

• The additional attenuation of rays in the vegetation describes the leakage of ray energy due to
scattering effects while passing through vegetation blocks.

Figure 56: Urban database with vegetation objects.

Similar to material properties of buildings, different properties can be assigned to the vegetation blocks.
The handling is identical to the handling of normal building object properties. The only difference is that
a different dialog comes up:
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Figure 57: The Frequency Dependent Material Properties dialog.

Coordinate Systems
WallMan requires all databases to be in a metric system (for example, UTM). This is important for
different computations like the free space losses. When a topographical database should be used
together with the building database both databases must be in UTM format.

Conversion of Urban Databases
With WallMan it is possible to convert databases from many common database formats to the WinProp
format.

The following file formats are supported:

• WinProp urban buildings ASCII (.oda)

• Vector data ASCII format (.vda)

• Arcview Shapefile (.shp)

• Open Street Map (.osm)

• AutoCAD (.dwg, .dxf)

• MapInfo File (.mif, .tab)

• Aircom Asset / NSN NetAct (single file)

• Aircom Asset / NSN NetAct (index file)

• MSI Planet Building Data (single file)

• Geography Markup Language (.gml)
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Hybrid Urban / Indoor (CNP) Databases

Combination of Urban and Indoor Vector Databases
The WinProp suite offers a powerful way to model the coverage of transmitters in an urban environment
in single buildings. Indoor databases with their higher grade of detail can be imported in an urban
database. These indoor databases must contain a shape around the building.

When reaching the shape of the building, the urban propagation model switches to an indoor model and
when a propagation ray leaves the building it switches back to the urban model.

Figure 58: Hybrid database with indoor database in urban database.

Topographical Databases

Pixel-Based Databases
The consideration of topography might be of importance within urban environments depending on the
terrain profile. The topographical databases are very often also called terrain databases and are based
on pixel matrices. Each pixel defines the topographical height for a given location (the centre of the
pixel). The finer the grid the more accurate the database. Today resolutions (grids) of 20 m and better
are used.
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Figure 59: Topographical database (height/elevation).

Currently, WallMan supports only height values (elevations) in metre. Other height units (for example,
feet) must be converted to meter and the WinProp format.

In the current version of WallMan the pixels are always squares (and not rectangles), the resolutions in
longitude and latitude are always equal. If the original data use different resolutions for longitude and
latitude, the smaller value of the grid is taken during the conversion for both (longitude and latitude)
and the undefined values are interpolated (bi-linear interpolation based on neighbour pixels).

Index Versus Single Files
To save resources, often index files are used. The area is split into a grid of small databases (see
Figure 60) and an index file is used as a reference pointer to the individual data files. This accelerates
the handling of the data because not always the large file must be read – only the small portion of some
small data files. Therefore, we recommend using always index data files.

For topographical databases, the single database file has the extension .tdb (topo data binary). The
index file has the extension .tdi (topo data index) and it includes the pointers to the individual .tdb
files.
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Figure 60: Single database and index database.

The names of the small .tdb files of the index database are arbitrary - but if they are generated
automatically during the conversion they have (as default) the same name as the .tdi file but the index
is added to the name (if the index file is xy.tdi, then the data files are named xy_column_line.tdb,
see Figure 60).

Coordinate Systems
Topographical databases that should be used together with urban building databases must be in UTM
format. It is possible to convert databases from other coordinate systems to UTM.

Conversion of Topographical Databases
The topographical database can be converted from many file formats to the WinProp format.

The following file formats are supported:

• WinProp format (.tdb)

• WinProp format index file (.tdi)

• ASCII line format

• ASCII grid format (.asc)

• ASCII grid format index file (.txt)

• Binary grid format (.bin)

• Aircom ASSET / NSN NetAct

• MSI Planet / Siemens Tornado (single data file)

• MSI Planet / Siemens Tornado (index data file)

• Nokia NPS/X (single data file)
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• Nokia NPS/X (index data file)

• USGS DEM

• USGS BIL

• HGT (3 ARC)

• HGT (1 ARC)

• Digital Terrain Elevation Data

• GeoTIFF

Conversion of Topo and Clutter Databases to Vector Data
For usage with the rural ray-tracing model topo and clutter map data can be converted into the binary
WinProp file format (.tdv). Additionally, vector buildings can be added during the conversion. The
additional vector buildings must be available in the regular WinProp indoor vector file format (.idb).

The resulting vector databases in .tdv file format cannot be visualised and modified in WallMan but can
be displayed and used in ProMan.

The conversion can be started by selecting File > Convert Topo & Clutter to Vector in the WallMan
GUI. In the dialog the topographical database in a supported file format must be selected. After starting
the conversion, the following dialog appears and allows the selection of an additional clutter map and
additional indoor vector data.

Figure 61: The Topography Conversion Settings dialog.

If the Create Cylinders check box is selected, clutter heights are taken into account for the creation of
the vector data.
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Figure 62: An example for the consideration of different clutter heights
and additional vector (one tall building) data during the conversion.
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3.2 Introduction to the Interface

3.2.1 Database Editor

General

Figure 63: WallMan main screen with indoor database.

Handling

Control 2D and 3D Views
In WallMan there are different views on a database. There are 2D views and a 3D view. The 3D view is
meant to give an overview of the database in all its dimensions and thereby gives a better idea of the
structure than in 2D. However in 3D, it is not possible to make any changes to the database, this is only
feasible in 2D.

When an indoor database is opened, there are four views: XY, XZ, YZ and 3D. Outdoor databases
provide only an XY and a 3D view because the side views would be rather useless. Both types of
databases also provide a “Single Object View” which can be activated by double-clicking on an object in
a 2D view.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
3 WallMan p.73

Changing the Views
To change the view in a part of the window just click on the part to activate it and then click on the icon
of the view that should appear in that part of the window. For example, if the 3D view should appear in
the (upper) left part of the window, click on the (upper) left part and then on 3D.

It is not possible to have two views of the same kind. When the 3D view is activated in the (upper) left
part, the view that was in that part prior (for example, XY) will appear in the part where the 3D view
was before. In other words: WallMan just swaps the views.

Navigating in 2D Views
The 2D views in WallMan show the database as a cross-section with a certain plane. The plane moves
along the third axis (for example, the “Z” axis in the “X / Y” view) and its position is called “3rd
coordinate”. The content of a 2D view can be changed with the following tools.

 Zoom in and zoom out and draw a zoom rectangle. The zoom rectangle defines the area that

will be visible in the view.

 The Mouse pan-and-zoom tool allows an intuitive change of the view. Pressing (and holding) the left

mouse button while moving the mouse will move the view. Pressing the right mouse button will zoom it.

 Clicking the button restores the default view settings.

 The “New” button redraws the current view.

 The 3rd coordinate can be changed by using the 3rd Coord Settings dialog. By default, this

window is visible whenever a 2D view is activated (it is not visible when the 3D view is active). The
display state of this dialog can be toggled by clicking on the icon in the toolbar.

Figure 64: The 3rd Coordinate Settings dialog.

Moving the slider at the left side of the window up and down changes the third coordinate. The current
value is displayed right below the slider.

To ease navigation in large databases it is possible to define “Marks” which are some kind of bookmarks
for the third coordinate. These marks are very useful in multi-floor indoor databases. A mark can be
defined for each floor and the view can be brought to that floor with one click.

A bookmark to a particular value can be set by clicking on Add Mark. The new mark will appear in the
Marks list. Clicking on a mark in the list sets the third coordinate according to that mark. A mark can
be removed by selecting it and clicking on Delete Mark.
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WallMan can also display the current cross-section plane in the 3D view when Show 3rd Coord in 3D
is enabled. Enabling Show Marks in 3D shows the marked planes.

Single Wall View
The single wall view enables the user to view all objects located in the plane of a selected wall. To enter
this view, a wall has to be selected by double-clicking the left mouse button using the edit tool in any
2D view window. To leave the single wall view just click on the icon of the view that should appear in
that part of the window. This option is available for indoor databases only.

 Clockwise 90-degree rotation of the single wall view.

 Enter a user-defined rotation angle for the single wall view.

 Flip the single wall view, view the back side of the selected wall.

Navigating in the 3D View
The 3D view can be freely shifted, rotated and zoomed. All operations are performed with the mouse.
The following graphic explains the different functions.

Shifting
Move the mouse while pressing the left mouse button to shift the view in a
certain direction.

Rotating
Move the mouse while pressing the right mouse button to rotate the view.

Zooming
Scroll the mouse wheel up / down to zoom in / out.

Besides the mouse operations, the 3D view window offers the possibility to reset the view perspective
by pressing the Total View button. Arbitrary camera perspectives can be stored, deleted and reloaded
using the corresponding buttons as well as the drop-down box.
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Figure 65: The 3D view window.

Stored camera perspectives are automatically saved to a file for later usage after closing the document
or the 3D View, respectively.

Create Screenshots
WallMan provides a convenient way to export images for further usage. Images can either be stored in
a file or in the clipboard. WallMan exports the view that is currently active. A view can be activated by
clicking on it.

Once a view is activated it can either be exported to the clipboard by selecting Edit > Copy Image to
Clipboard from the menu or it can be stored in a file by selecting File > Export > Bitmap from the
menu. When storing in a file a dialog comes up that lets the user select an output location for the file
and an extension. The file format is determined through the file extension (for example, .bmp creates a
Windows Bitmap File).

Statistics
WallMan provides some general statistical information about the currently opened database. The dialog
can be activated from the Edit > Statistics menu.
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Figure 66: The Statistics dialog.

Settings of Display
The Local Settings in the Settings menu allows customisation of the display settings.
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Figure 67: The Settings dialog.

Grid
With this option, the drawing grid can be switched on and off and the grid size (in meters) can
be entered. Alternatively, the drawing grid can also be activated with the Grid command or the
corresponding toolbar command.

Catch Points
By enabling this option, corner points of already existing objects, located in the same drawing
plane and within the specified range, can be caught during drawing operations in the 2D views.
The catch range in pixels can be entered here as well. This mode can also be activated with the
Catch Points command or with the corresponding toolbar command.

UnDo
With this option, the size of the UnDo buffer can be chosen. A high number results in a large
memory amount which makes the program handling in some cases very slow.

Acceleration of Display

In order to accelerate the display, some features of WallMan can be disabled:

• Permanent Auto-Refresh of Display
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• Immediate Check of New Objects

• Auto-Detection of Courtyards/Towers (urban) or Subdivisions (Indoor)

• Undo Function

Especially for large databases, the display refresh takes a considerable amount of time which
reduces the speed of the program significantly.

The immediate check of new objects verifies whether new objects or modified objects overlap
other objects.

Figure 68: Complete and partial overlapping.

We have to distinguish between indoor and urban databases:

Indoor databases

By default, partly or completely overlapping objects are not allowed in indoor databases.
However, in special cases, this might be needed. Therefore the automatic check can be
disabled. If the option remains on (default), the creation of a partly overlapping object will
be rejected.

If a fully overlapping object is created, the user will be prompted whether he wants this
object to become a subdivision. If the user answers No, the object is rejected, if he answers
Yes, the object becomes a subdivision.

Urban databases

By default, overlapping objects are allowed in urban databases. This is useful to speed up
editing of very large and complex databases, as the overlap check algorithm uses more
resources if many objects are present.

In smaller databases, it is sensible to switch the check on. In this case, partly overlapping
buildings are still accepted. If a completely overlapping object is created, the user is asked,
whether he wants to define the object as a courtyard. If the user answers No, the object will
become a normal object, if he answers Yes, the object will become an included object.

Fill Objects

When this option is enabled, all objects in the 2D views are filled with grey color. In indoor mode,
only the objects that are parallel to the current view plane are filled. This is very convenient to
distinguish between vertical and horizontal objects. In urban mode, the filled mode is the better
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view for printouts. However, some information might be lost, for example, courtyards are not
displayed any more.

Figure 69: Filled mode off (urban example) .

Figure 70: Filled mode on (urban example).

Show Object Numbers
With this option enabled, the object index number (like shown in the objects properties dialog) is
displayed along with every object on the screen.

Mark Origin
When this option is selected, the coordinate system’s origin (0,0,0) is marked by a circled cross.

Auto Scroll
Normally, while a line is drawn or an object is moved on the screen, the screen scrolls
automatically as soon as the mouse cursor hits the window border. This feature can be turned off
by deactivating this checkbox.
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Show 3D View

Using this check box, the 3D view can be disabled. This is useful for very large databases to
accelerate the update time on the screen.

Tip:  Set the environment variable WINPROP_3D_VIEW_DISABLED to disable the 3D
view. If the environment variable is set, the 3D View cannot be activated via the
WallMan GUI.

Settings Applying to Urban Mode Only
Display Relative Coordinates

When an urban database is stored, the coordinates of the lower-left corner of the built-up area
are stored as an offset. This offset is also separately stored in the ASCII .oda file.

The coordinates in the database are processed as coordinates relative to this point. Normally, the
absolute coordinates are displayed in the WallMan status bar. If the user wants to see the relative
coordinates, he can use this option.

Display Walls of Imported Buildings
In the urban mode, buildings can be imported from indoor databases using the Import Indoor
Database command. This option specifies whether the walls inside these imported buildings are
displayed.

Display Roofs and Ground Planes of Urban Buildings in 3D View

Normally, a building should be viewed with roofs displayed. However, if roofs are displayed,
defined courtyards are not visible anymore. Therefore, the default value is that the roofs and the
ground plans are not displayed, as this display type shows more information.

For printout purposes, it is recommended to activate the function.

Figure 71: Display with and without roofs and ground planes.

Display Buildings only if Higher than Current Z-Coordinate
In the urban mode, the current Z-coordinate represents the height that is assigned to new
objects. If the option is selected in the settings, only the buildings that have at least the same
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height as the current Z-coordinate are displayed. Horizontal plates are displayed in this mode only
if they are located within the current Z-plane considering their thickness.

Background Images in 2D and 3D Views

Figure 72: Urban database (Stuttgart, Germany) with background Image on X / Y plane.

WallMan can display image files together with a database. This is very useful to draw databases
manually or to get additional information about the database. WallMan supports all common graphics
file formats like .bmp, .png, .jpg, .gif and .tiff.

 To configure background images select Images > Configuration from the menu or click on the

corresponding icon in the toolbar.
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Figure 73: The Image Configuration dialog.

In order to add an image to the current project, first, click on Add and select an image file in one of
the supported formats. The next step is to define the image position and its size. Therefore enter the
coordinates of its lower-left corner in the Lower-left X/Y/Z fields. Fill the Width and Height fields
with the according to values. Finally, select the plane the image should appear in from the drop-down
list. Clearing the Visible box hides an image from the views. In case a georeference is available for the
image, the georeference file can be loaded by pressing the Load button in order to adjust the image
correctly. The image properties will be assigned according to the content of the georeference file. It
is also possible to create a georeference file by pressing the Save button if the image was scaled and
adjusted manually.

Note:  Georeferencing of a background image is only possible in the X/Y plane and for UTM
coordinate system.

Scale and Move the Images with the Mouse
If no information about the position and size of the image are available it is also possible to position
and scale it manually by mouse. The according tools can either be selected from the menu or from
the toolbar. It is important that the view (for example, (X / Y)) in which the image should be moved /
scaled is activated before selecting the tool. The active view is indicated by a red font instead of a black
font for non-active views.
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Figure 74: Non-active (left) and active (right) view.

Move Image (Images > Move Image from the menu): When the left mouse
button is pressed the image is moved with each mouse movement.

Scale Image (Images >  Scale Image from the menu): Pressing the left mouse
button and moving the mouse resizes the image. Depending on where the mouse
pointer was when the left mouse button was pressed the image is scaled in
different directions. For example, clicking on the upper-left corner of the image and
moving the mouse will shrink or enlarge the image at the upper-left corner (the
lower-right corner remains where it was).

In case that more than one image lies in the same plane as the active view (for example, X / Y)
WallMan displays a dialog where the user can select the image that should be modified.

Figure 75: The Select an Image dialog.

Edit Images
Images can be edited in WallMan as well. After selecting Edit Image from the Images menu, a dialog
opens, where different edit tools can be selected.
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Figure 76: The Image Edit dialog.

The Polyline Rubber tool offers the possibility to erase contents of the image by defining a polyline.
The individual points of the polyline can be specified with a left mouse click. A right click will close the
polyline and erase the image data which is located within the polyline.

The second option to delete image data is to use the Rectangular Rubber tool. In case the fixed pixel
size is set to zero, the user can define an arbitrary rectangle with the mouse. Otherwise, the user-
defined fixed rectangle size will be used for the rubber rectangle.

The Pipette tool can be used to obtain the color of a certain pixel. If this tool is active and the user
clicks with the left mouse button, the corresponding color will be displayed in the lower part of the
Image Edit dialog.

The color of pixels can be changed using the Pen tool. The color to be set has to be selected in the color
section in the lower part of the dialog by clicking on the coloured rectangle.

Images can be rotated at an arbitrary angle using the Rotation tool. After defining the angle and
pressing the button, the image will be rotated clockwise.

The Trim tool cuts the overlaying background of an image.

Marker Points
Marker points in WallMan can be used to highlight points of special interest or to reference database
objects. Marker points can be set in all 2D views using the mouse after selecting the marker points tool

 from the View toolbar.
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Figure 77: Properties of the marker points.

The properties dialog offers the possibility to change the name, the color and the location of a marker
point.

Geo-Referencing with Marker Points
Geo-referencing, positioning of database objects can be done with marker points. WallMan, therefore,
offers the possibility to either assign an arbitrary coordinate to a marker or to assign a marker point
to the location of another marker point. The database objects which shall be moved together with the
marker can be selected in the “Data” section of the Referencing dialog.

Besides this, database objects can also be fitted, adjusted by rotation, translation and scaling.
Therefore at least four different marker points are required. Two markers indicate the destination
location and the other two markers specify the starting point of the operations. After the marker points
have been placed, an arbitrary one can be selected in order to open the Marker Point Referencing
dialog via the context menu. Afterwards the mode Adjust two markers to the position of two other
markers' has to be selected. In the section Position Adjustment', you can choose two marker points
to be used as a reference position and two marker points which shall be transformed in order to be
located on top of their corresponding reference later. Database objects which shall be transformed
together with the marker points can be selected in the lower part of the dialog.
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Figure 78: The Marker Point Referencing dialog.

Floor Levels
Floor levels are horizontal planes which can be defined via menu Edit > Floors or the corresponding
toolbar icon. They can be used for easy navigation in multi-floor indoor databases as well as to assign
additional data, such as clutter maps or images of pixel databases. For urban databases, only a single
floor level can be defined.

Figure 79: Definition of floor levels.

All defined floor levels are listed in a selection box which is located within the View toolbar.
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Figure 80: Selection of floor levels.

Floor levels can be changed via selection box or by pressing Ctrl+Alt+Arrow up or Ctrl+Alt+Arrow
down, respectively.

The floor levels defined in WallMan can be used to navigate through the floors of the building database
in ProMan, as well.

Additional Clutter Data
Besides a height and a name, floor levels can also contain clutter information. Clutter data is required to
define location dependent traffic for radio network planning.

Figure 81: The Properties of current floor level dialog.

A clutter map can be created for each of the floors using the properties dialog of a selected floor. This
makes it possible to define an individual clutter map for each building floor.

A clutter map will be created or deleted if the option Create clutter map for this floor is selected
or unselected, respectively. Location, extension and resolution parameters of this map are initialized
according to the current maximum database extension. However, these values can be changed using
the corresponding edit fields in the lower part of the Clutter Map section.
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In case clutter classes have been defined earlier, the created map can be initialized with one of the
defined clutter classes which can be selected in the drop-down box on the right side. If the option
Initialize with selected clutter class considering building(s) is selected, the initialisation will be
done only within the bounding of the building(s) whereas the outdoor areas remain undefined.

For urban databases, clutter classes can be created also automatically by using the fourth option,
Initialize with clutter class depending on building height, to initialize the clutter map. In this
case, a clutter class will be created for each building height, taking into account the specified floor
height. This option makes it possible to easily create a clutter map based on building heights which can
be used directly for traffic definition, for example, according to the principle “the higher the building the
higher the expected traffic”, in ProMan later.

The Mouse Meter Tool
The mouse meter tool offers the possibility to determine distances in an existing database in a graphical

way. The tool is either activated by using the toolbar symbol  or using the mouse meter tool hotkey,

Alt+G. Unlike the other tools, the mouse meter tool can be activated at any time, even when processing
templates or other database objects.

When the reference point selection is done and the mouse is moved, a blue dotted circle and a blue
dotted line will appear. The line shows the direct connection of the reference point to the currently
selected viewpoint. The circle shows the location of all points that are equidistant to the selected
reference point. The line can be activated or deactivated pressing the “L” key on the keyboard. In the
same way, the circle can be activated or deactivated by the “C” key. Beneath the mouse cursor position,
a textual information will show the coordinates of the current mouse cursor position and the distance to
the selected reference points in meters.

Figure 82: Mouse meter tool for distance measurement in WallMan.

The mouse meter tool is left by clicking the right mouse button, using the toolbar symbol or using the
hotkey, Alt+G once again. If the mouse meter tool was entered while working with another tool, the
latter will be reactivated when the mouse meter tool is left and the editing process can be continued.
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Table 3: Short Command Overview for the Mouse Meter Tool.

Key / Mouse Button Function

Alt+G Activates and deactivates the mouse meter tool.

L Activates and deactivates the mouse meter line display.

C Activates and deactivates the mouse meter circle display.

Left mouse button click Sets new reference (centre) point.

Right mouse button click Closes the mouse meter tool.

Esc Closes the mouse meter tool.
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3.3 Using WallMan

3.3.1 Database Editor

Database Creation: Indoor
WallMan offers different ways to create an indoor database. Normally the most convenient one is to
convert a CAD data file supplied by the architect. If that way does not work a database can be created
upon a floor plan. Either by automatic conversion or by drawing it manually with the floor plan in the
background. For automatic conversion, the image of the floor plan must fulfil some prerequisites.

Create an Empty Indoor Database
A new indoor database can be created by selecting File > New Database from the menu. WallMan
opens a dialog where the user can choose from different creation modes. For an empty database
Indoor Database and Draw manually must be chosen.

Figure 83: The Select type of new database dialog.

The next dialog sets some default values for the new database.
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Figure 84: The Default Values for New Objects dialog.

Geometrical Parameters for Orthogonal Drawing Mode
Only relevant if the orthogonal drawing tool should be used. Object relative to current plane
creates new orthogonal objects with a fixed height and a position that is relative to the current
projection plane. Upper and lower coordinate defined individually creates new orthogonal objects
with a fixed height and at an absolute position.

Material Properties
The default materials for new objects in the database.

Convert Indoor Database from CAD Data File
WallMan includes several import filters for the conversion of indoor building data given in other formats.
Database conversion is based on a modular concept.
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Figure 85: Converters for indoor building data.

WallMan also offers the possibility to export the currently displayed database as a .dwg or .dxf file by
clicking on the menu, File > Export > DWG / DXF. Depending on the selected file format and the
specified file version in the file save dialog, the database will be exported to a 3D DWG or DXF file.

The database can also be exported to NATRAN (.nas) file by clicking on the menu File > Export >
NASTRAN.

Create Indoor Database with Scanned Bitmap in Background
One of the most common ways to create an indoor vector database is to draw it manually with a
scanned floor plan in the background. With WallMan this can be done by creating an empty indoor
database and loading a bitmap of the floor plan.

Create Indoor Database with LEGO
The Lego tool provides a couple of easy to use functions for indoor database creation. The main idea
is the generation of basic wall combinations (the so-called “templates”) describing typical database
elements such as rectangular rooms, staircases and roofs The user-friendly graphical interface offers
dialog based entry of fundamental template parameters (dimensions), post-creation editing possibilities
(moving, scaling, rotating), the definition of any combination of database walls as a template,
recombination possibilities for known templates and a program toolbar for fast selection of the tool to
be used.

The LEGO toolbar can be found by default at the top side of the WallMan window.

Table 4: LEGO Tools

Rectangular room Roof

L-shaped room Stairs
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T-shaped room Cylinder

U-shaped room Sphere

S-shaped room Staircase

To create a LEGO element, select a type from the LEGO toolbar and edit the values in the appearing
dialog.

Figure 86: The Settings for room type L-Room dialog.

After closing the dialog with OK, WallMan shows the new element in the active 2D view. Double-clicking
on the element changes between move and rotate mode. The element can be moved and rotated by
clicking on it and moving the mouse.

Create Indoor Database
Besides the LEGO functionality, WallMan offers additional tools to enter objects in the database. Select a
tool to create a new object.

 Add Polygonal Object

Use this tool to add a plane with an arbitrary number of corners. After selecting the tool each mouse
click in the 2D view adds a corner. To finish the object, click the right mouse button.

 Add Rectangular Object

To create a rectangular plane, select this tool and click on the position in the 2D view where the first
corner of the plane should appear. Then move the mouse to span the rectangle and click again to finish
the object.
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 Add Objects Orthogonal

This tool creates a rectangular plane that is right-angled to the current projection plane. Thereby it
looks like a line in the 2D view. To create this object, select the tool and click on the first point of the
line and then on the second.

 Add Pipe Object

To create cylindrical pipes, select this tool and click on the position in the 2D view where the beginning
of the pipe should appear. A dialog opens, where the radius, the corner approximation and further
settings can be specified. Then move the mouse to the end of the pipe and click again to finish the
object.

 Connect Two Walls

Select this option to insert a wall which connects two already existing walls. First, mark the corners
which are located on the first wall and afterwards mark the corners on the second wall. After selecting
at least three corners, click the right mouse button to insert the new wall. In the 3D view, the shift key
must be pressed while selecting corners with the left mouse button and to insert the new wall with the
right mouse button.

 Add Furniture Objects

Select this option to create furniture objects with the drawing tools described above. An additional
attenuation is added to rays that penetrate this object. The attenuation values for furniture objects can
be assigned in the material properties dialog.

 Add Prediction Planes

Select this option to insert prediction planes, arbitrary polygonal planes where ProMan calculates the
computation results.

Create Doors, Windows and Other Subdivisions
In WallMan subdivisions allow the modeling of elements in walls (doors, windows, holes). A subdivision
can be created by simply creating a new wall element inside the wall which should contain the
subdivision.

WallMan will ask the user whether he wants the new element to become a subdivision with own material
properties or if he wants the subdivision to become a hole in the surrounding wall. Responding with No
will discard the new element.
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Figure 87: The Insert Subdivision dialog.

Create Multi-Floor Indoor Database
The WinProp propagation models allow the computation of multiple floors in a building. Creating such
a multi-floor database is very easy when all floors have the same layout. In such a case just one
floor must be modeled and saved to a file. To add floors, select File > Import > WinProp Binary
Database from the menu and select the file that contains the already modeled floor.

Figure 88: The Move Objects dialog.

WallMan asks for the values by which the additional floor should be shifted. Enter the height of one floor
in the Z field and click OK. For additional floors, the Z value must be increased for each floor.

Figure 89: Indoor database with four floors.

Fit Imported Database
In case the imported database does not fit on top of the already existing building floors, due to
the wrong location, scaling or rotation, it can be adjusted automatically by selecting Objects > Fit
Imported database from the menu.
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Figure 90: Fit imported indoor database on top of an existing database.

First, two corners of the existing database (1 and 2) must be selected.

Ground plates can be either standard walls or graphical objects. Defined as standard walls, they have
material properties and therefore an impact on the prediction (interactions at the plane) like normal
walls. In case ground plates are defined as graphical objects, they have no impact on the prediction, no
interactions (for example, reflection/diffraction) of rays/paths at these objects will occur. Besides the
type of the ground plates, their z-position (height) can be specified in the upper part of the dialog.

The material properties assigned to ground plates of type “Standard Wall” can be changed in the section
“Material”. The thickness of the database objects can be considered during the determination of the
ground plates, optionally. Therefore, the user can either specify an arbitrary common thickness value
for all database objects or use the thickness values defined for the individual material properties.

Ground plates are considered during the determination of the shape around the building which is
required for CNP import. With a manually defined ground plate, the user can influence the result of
the shape determination. During the shape determination, the “footprint” of the indoor database is
determined. Available ground plates or any other horizontal objects influence this footprint.
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Conversion of Indoor Databases
Convert an indoor database (.idb file) to an outdoor database (.odb file).

If an urban database is desired, for example, if the database consists mainly of buildings, then you can
use File > Save As to save the geometry to a .odb file, WinProp's format for urban databases. Then,
the buildings will be approximated by extruded polygons and be suited for an urban simulation, which
can be faster.

Database Creation: Urban

Create an Empty Outdoor Database
Creating an empty database can be simply done by selecting File > New Database from the menu. In
the dialog Urban Building Database and Draw manually must be enabled.

Figure 91: The Select type of new database dialog.

In the next dialog, the coordinate system must be specified by the user:

Figure 92: The Coordinate System dialog.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
3 WallMan p.98

Finally, the default materials for new buildings and vegetation objects can be defined. After closing the
dialog by clicking on OK, WallMan creates a new urban database.

Figure 93: The Default Values for New Buildings dialog.

Convert Urban Database From CAD Data File
There are different file formats for the description of urban building databases. WallMan includes import
modules for most of the common database formats. Besides the common formats, there are several
company-specific file formats available, too.

The import functions can be activated by the Convert Urban Database option of the File menu. Then
the user must select the specific format of interest. For the import of ARCVIEW™ Shapefiles in .shp
format during the conversion, also the heights of the buildings in a .dbf file are required (located in the
same folder as the .shp file). Therefore, this data should be provided also in the corresponding folder
with the same file name before the suffix.

Figure 94: The Conversion of Urban Vector Database dialog.

For the conversion of MAPINFO™ files in .mif format, additional settings can be specified in a .mid file
(located in the same folder as the .mif file). The building heights can be read from a .tdb file.
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Figure 95: The Parameters for Mapinfo-Conversion dialog.

During the conversion process, several messages are written in the progress window, which takes a
significant amount of time. Consequently, this option can be switched off. After the conversion, the
imported database can be visualized for control purposes. Therefore, the corresponding check box must
be activated within the convert menu, see Figure 94.

During the conversion process the building database can be simplified according to the selected options,
see Figure 96. The simplification includes the erasing of buildings below a specific height, the reduction
of the number of corners for each building individually (simplification of the building shape) and the
combination of adjacent buildings. The same simplification process can also be applied for an already
converted database by using the corresponding option from the Edit menu.

In order to ensure a successful processing of the building databases within WallMan, the following
procedure is recommended:

• Conversion of database without simplification (use default settings) > Save database
• Load converted database into WallMan

• Load converted database into WallMan

• Simplification of the database by the corresponding feature in the Edit menu.

• Save simplified database

• Define pre-processing file based on the simplified database

• Computation of pre-processing
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Figure 96: The Options for simplification of urban building databases dialog.

WallMan also offers the possibility to export the currently displayed database, either as .dwg or .dxf file
by clicking on the menu, File > Export > DWG / DXF or in the MAPINFO file format by File > Save
Database As and then choosing the .mif-suffix. Depending on the chosen settings, the database will
be exported to a 3D .dwg or .dxf file or a MAPINFO .mif file, respectively.

The database can also be exported to NATRAN (.nas) file by clicking on the menu File > Export >
NASTRAN.

Create Urban Database with Scanned Bitmap in Background
Besides automatic conversion of scanned bitmaps in urban vector databases, it is also possible to create
the database by drawing the buildings with the map as a template in the background.

Therefore, an empty database must be created and the picture of the map must be loaded.

The buildings can now be entered with the Add Polygonal Object and Add Rectangular Object
tools.
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Figure 97: Map with manually drawn buildings.

Create Urban Database
WallMan provides two kinds of shapes for the creation of buildings. The rectangular and the polygonal
shape.

Table 5: Shapes for the creation of buildings.

Polygonal shape
Each click with the left mouse button creates an edge of the polygon. A click with
the right mouse button closes the polygon by connecting the last edge with the
first.

Rectangular shape
First click with the left mouse button starts the rectangle, a second click finishes
it.

With these tools four kinds of objects can be created:

Table 6: Objects created from the shapes for the creation of buildings.

Standard building
(no special type selected)
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Virtual building
Excludes areas from the computation. Useful if large areas which don’t have to
be computed lie inside a city (for example, lakes)

Vegetation object
Adds an additional attenuation to rays that go through it. Pixels inside these
objects will be computed (opposed to that in virtual buildings)

Courtyard / Tower
Buildings that lie inside other buildings have to be defined as courtyard (lower
than surrounding building) or tower (higher than surrounding building)

New objects automatically have the height the 3rd coordinate is currently set to.

The four steps for the creation of a new building / object are:

• Set the height by setting the 3rd coordinate

• Choose a building type

• Choose a shape

• Create the shape by clicking with the mouse

Include Topography in Urban Database
The topography can additionally be considered for urban environments. Either the building heights in
the vector database are defined inclusive topography or exclusive. This must be selected when pre-
processing the database in WallMan. WallMan determines the topographical height of the centre of the
building and then either the relative building height is obtained by subtracting the topographical height
from the absolute building height (if absolute heights are given inclusive topography in the building
database) or the absolute building height is determined by adding the topographical height to the
relative building height (if relative building heights are defined in the building database).

Arbitrary topographical databases can be used and converted with WinProp. As topographical databases
are pixel databases they are internally converted during the computation into a triangle approximation
of the terrain profile.
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Figure 98: Terrain approximation with triangles.

Add Vegetation to Urban Database
Vegetation objects define areas within an urban database that have a higher attenuation than the free
space but do not have the characteristics of buildings like reflection or diffraction.

Figure 99: Urban database with vegetation objects.

Add Courtyards and Towers to Urban Database
In WallMan buildings that are surrounded by other buildings are by default removed. To prevent
that it is possible to declare a building inside another one either as courtyard (if it is lower than the
surrounding) or as tower (if it is higher).
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Figure 100: Tower and courtyard in urban database.

Conversion of Urban Databases
Convert an urban database (.odb file) to an indoor database (.idb file).

If an indoor database is desired, for example, to add more geometrical details, then you can use File >
Save As to save the geometry to a .idb file, WinProp's format for indoor databases.

Database Creation: Hybrid Urban / Indoor (CNP)

Import Indoor Database into Urban Database
In urban mode, WallMan can import a building from an indoor-database. To do this, select the Import
Indoor Database from the Objects menu. WallMan shows a dialog to select the file name of the
indoor database. Only indoor databases which include at least one shape can be used. Besides this,
at least one floor level must be defined for the indoor database. The building’s shape is copied to the
clipboard from where it can be pasted to any place in the urban database.

If the Display indoor walls of imported buildings setting are active, the walls of the imported
building are also displayed. The Properties dialog of imported buildings shows the file name and
location of the indoor database. It is important that the imported file remains accessible for WallMan.

Note:  In urban mode the shape of an imported building cannot be changed. However,
imported buildings may be moved around on the map.
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Figure 101: Imported indoor database.

Create Indoor Walls in Urban Databases
Indoor walls and floors can be generated by the user manually by using the Create Interior feature.

First, a building must be selected for which indoor walls should be created. By clicking the button  ,

the following dialog appears on the screen:

Figure 102: The Add floors and walls dialog.

Floors and walls can be generated separately to the selected building by clicking on Add Floors and
Add Walls. Some parameters can be used to adjust the walls / floors as desired.

Database Creation: Topographical Database

Convert Topographical Database
Conversion of topographical data from different other file formats to the WinProp data format is possible
with the converters integrated into WallMan.

WallMan supports currently the following file formats:

• WinProp format (.tdb)
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• WinProp format index file (.tdi)

• ASCII line format

• ASCII grid format (.asc)

• ASCII grid format index file (.txt)

• Binary grid format (.bin)

• Aircom ASSET / NSN NetAct

• MSI Planet / Siemens Tornado (single data file)

• MSI Planet / Siemens Tornado (index data file)

• Nokia NPS/X (single data file)

• Nokia NPS/X (index data file)

• USGS DEM

• USGS BIL

• HGT (3 ARC)

• HGT (1 ARC)

• Digital Terrain Elevation Data

• GeoTIFF

Figure 103: The Data Conversion dialog.

The conversion of topographical databases is done via the menu File > Convert Topo Database.
Options for Conversion from Geodetic to UTM

Under Options for conversion the user can define the resolution of the database (if not already
defined in the original database) and a factor which is applied to all values in the file. WinProp expects
all topographical height values always in meter. So, if the original data is, for example, in feet, the
factor 0.30 should be applied to all values to convert the height values from feet to meter. The
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undefined pixels can be interpolated to obtain a totally filled database even if only a few reference
pixels were available in the original database.

If during the conversion WallMan detects that the database will become very large, a dialog appears.
The user is informed about the size of the database (number of columns and lines) and can select
whether he wants to produce a single database or an index database (additionally the size of the sub-
databases (tiles) can be specified as well).

Figure 104: The Handling of Database dialog.

Generate Topographical Database
The generation of topographical databases is possible by editing an ASCII file in the WinProp format
(.tda) and inserting the heights of reference points line by line (x y z). The user will be able to define
an arbitrary number of points with their heights and WallMan will interpolate the complete terrain based
on that information.

Database Editing (Mandatory)

Default Settings / Properties of New Objects
New buildings and vegetation objects always get the default material assigned. The default materials
can be set by selecting Edit > Default Values from the menu.

Figure 105: The Default Values for New Buildings dialog.
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Figure 106: The Material dialog.

Scale Database (All Objects)
With WallMan it is very easy to convert a database from units like inch to meters. Or to scale a database
generated with a bitmap in the background.

The required scale tool can be found in the Edit > Scale All Objects menu. After activating the
tool, the user is asked how the database should be scaled. It is possible to scale only in one direction
(coordinate axis) or in two directions (in a horizontal plane, not affecting the heights) or in all
directions. Even more, the scaling can be done by drawing a line with a certain length or by using a
fixed scaling factor.

Figure 107: The Scale Objects dialog.

Additionally, the user can select if the bitmap should also be scaled or not. Not scaling the bitmap is
especially important if the user wants to fit the database to the bitmap.

Lastly, the user can select if the stretching should be relative to the centre, origin or lower-left corner of
the database.

After the user confirms the selection of the options, he can select if he wants to scale the database
numerically (by entering a scaling factor) or by definition of a reference distance (drawn with mouse).

The reference distance mode is well suited if the user knows exactly how long a dedicated object or
distance is and by drawing a line along this distance, the user can define the length of this line (in
meters) afterwards. The line is defined by two points the user sets by clicking with the left mouse
button.
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Figure 108: The Scale dialog.

The dialog for the line length must be closed by clicking on OK. WallMan will ask for confirmation once
more before the whole database will be resized.

Scale Selected Objects
Similar to Scale Database it is possible to scale only the selected objects. The Scale Selected
Objects tool can be found in the Objects > Scale Selected Objects menu. All further handling is
similar to Scale Database.

Define Material Properties for Objects in the Database

Material Concept
The consideration of the different material properties of the buildings/walls has a significant influence to
the results of the wave propagation models. Therefore, for each object (building in urban databases and
wall/subdivision in indoor databases), the corresponding material properties should be assigned.

The handling of the different materials in a so-called material catalogue will be explained in the
following. The consideration of different materials is even more important for the indoor scenarios
(as there is a large spectrum of wall properties concerning thickness and material) while for urban
databases in most cases the same default material for all buildings is utilized (due to lack of information
concerning the individual building materials).

Material Catalogue
In order to allow an easy handling of the different materials used within an indoor or urban building
database the materials are organised is a so called material catalogue, which can be displayed by the

menu item Edit > Materials used in database or by clicking on the  button, see Figure 109.

In the  Material Catalogue dialog the different materials used in the loaded database are organised.
This means for indoor environments the materials of the walls, floors, ceilings, and also of the
subdivisions (doors, windows) must be entered, while for urban scenarios the materials of different
building types and for vegetation can be handled.

With the checkbox Show color of materials in table, the color of an each material is shown in the
table. By clicking on the column headers, the table will be sorted with respect to the selected column.
In the third column the type of material is shown (material, vegetation, and furniture) and in the last
column the number of objects with the corresponding material is displayed.
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Figure 109: The Material Catalogue dialog.

Material properties can be imported from other vector databases by using the button Import and can
be exported to user-defined material catalogues with the button Export. Using the button Replace
existing materials in the list can be replaced with material properties from another file.

In the following, the user is guided through the steps of specifying individual materials. By clicking
on Add material or Edit (if a material is already selected) the dialog for the definition of material
properties appears, see Figure 110. For each material the name and the corresponding thickness should
be defined. For urban scenarios the thickness has no influence at all, while for indoor environments the
thickness can be considered for the display of the database in 2D mode (if the corresponding option
within Edit > Settings is chosen). So for both scenarios the transmission properties of the walls are
not influenced by the thickness as the transmission loss is specified as a separate value (independent
of the thickness). Besides name and thickness, a color can be defined for each material which is used
for the graphical visualisation of the database within WallMan. Additionally, it can be chosen, whether
to have the whole object filled with this color (only possible when option Fill Objects is enabled in the
Settings > Local Settings menu item) or just the wire frame of the object. This might be important
when verifying the correct assignment of materials by using the 3D-view of the building database. It
is recommended not to utilize the red color, as this color is already used by WallMan to mark selected
objects.
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Figure 110: The Material Properties dialog.

When working with indoor databases it is possible to enable or disable propagation phenomena like
diffraction, reflection, transmission and scattering for each material. Additionally the user can decide by
using the corresponding check box if the current material can be calibrated or not.

Electrical Properties
Because the electrical properties of the materials depend on the frequency, individual electrical
properties for different frequency bands can be defined. For each material as many frequency bands
as required are possible. The definition/modification of the electrical properties is done by clicking on
Add/Edit in the Material Properties dialog, see Figure 110. Then the following window will appear
representing the Frequency Depending Material Properties, see Figure 111. The individual parameters of
the material properties for the defined frequency are entered here.

Before starting the propagation prediction in ProMan the user can decide which kind of interaction
model for the determination of the interaction losses due to reflection, diffraction, transmission
and scattering should be used. Different material properties are available for the empirical and the
deterministic (physical) interaction model. Not all propagation models are able to support all kinds of
propagation phenomena. More information about this can be found in the ProMan user manual, for
example, scattering is only supported by the 3D Intelligent Ray Tracing.
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Figure 111: The Frequency Dependent Material Properties dialog.

Among the WinProp examples in the installation directory, a Global Material Catalogue can be found. In
order to specify the values of the parameters for the selected material the Global Material Catalogue can
be imported.

Figure 112: The Import material from catalogue dialog.

From the Global Material Catalogue the required material can be selected. The Global Material
Catalogue includes materials commonly used with different thicknesses. For user convenience it is
possible to extend and modify this Global Material Catalogue either by adding new materials or by
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changing already existing ones. The user can also replace an existing material in his local Material
Catalogue by a material from the Global Material Catalogue.

After definition of the electrical properties of the selected material for a special frequency, this step
can be repeated for other frequencies (if required). In this context it is important to mention that for
the prediction within ProMan always the electrical properties of the nearest frequency band will be
considered automatically according to the defined frequency within ProMan.

It is not required to define the different materials at the very beginning before converting or entering
new objects. By just clicking OK in the window presented in Figure 113 at the very beginning all objects
are initialised with the default values. The individual material properties can be defined when the
different objects (for example, walls, subdivisions) are created. However, it is recommended to establish
the Material Catalogue at the beginning, because then the assignment of the material properties to the
different objects will be easier. Nevertheless it is also possible to extend / modify the Material Catalogue
at a later step during the generation of the building database.

Figure 113: The Default Values for New Objects dialog.
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Object Properties of Each Object in the Database
In WallMan every object has its own properties. They can be viewed and changed individually in the
Properties dialog. Depending on whether the type of the database is indoor or urban, the appropriate
dialog comes up.

To bring up these dialogs, select an object and click Objects > Edit Properties. Another way to get to
the Properties dialog for an object is to click on the object with the right mouse button and choose the
option Properties.

Note:  If multiple objects were marked, the Object Properties dialog cannot be launched.
The dialog only applies to one object.

Figure 114: The Object Properties (urban) dialog.

The text field in the upper-right corner of the Object Properties dialog provides some general
information about the object, for example, in indoor mode whether it is a subdivision or how many
subdivisions are parts of this object or in urban mode whether the object is, for example, a virtual
building. In the following, the other object properties are described in detail.

Object Number

WallMan assigns a unique number to each newly created object in a database. In the Settings
dialog you can choose whether WallMan displays the object numbers along with the objects.
Repeatedly deleting and entering objects can lead to a situation where it is useful to renumber the
database. The Edit > Renumber All Objects option assigns new numbers to all the objects in
the database.

Change Type

For indoor databases, the type of the selected wall can be changed.

In case the original wall is a subdivision of a wall the type can be changed so that the subdivision
becomes a hole and vice versa, only.

For urban databases, building types can be changed as well.
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Material Parameters
This section allows selecting a material from the Material Catalogue via a pull-down menu.

Clutter Class
This section replaces the Material Parameters section for Prediction Planes. In this case, it is
possible to assign a clutter class from the Clutter to a prediction plane. Using the Edit button, the
Clutter Table can be displayed and modified.

Comment Text

An optional comment text can be entered for each object to provide additional information about
the object.

CAUTION:  The ASCII database formats (IDA and ODA) are not capable of saving the
comments. This is only possible in the binary formats (IDB and ODB).

Corners

The Properties dialog contains a list of the object’s corners. To change a corner manually, it must
first be selected by clicking on its entry in the corner list. Then the corner’s coordinates can be
changed by clicking on the Edit button below the corner list. To delete the corner instead, click
on Delete. To add a new corner behind the currently selected corner, use the Add button. The
program will prompt you for the coordinates of the new corner.

Upon closing the Properties dialog, the changed corner coordinates are checked and the changed
wall is rejected in case it is invalid (for example, because of invalid geometry).

Note:  In urban mode, the Z-coordinate represents the height of the building. You
only need to change it for one corner to change the building height. The Z-coordinates
of the other corners is updated automatically.

Miscellaneous

Surface Prediction (indoor
databases)

Enable or disable prediction along the surface of a wall. The
distance between the wall element itself and the surface
prediction planes in front of and behind the wall has to be
specified as well.

Efficient assignment of this option to multiple objects is
possible. Click Objects > Surface Prediction from the
menu. Once defined, the surface prediction planes on both
sides of the walls will be displayed in purple.

Surface Prediction (urban
databases)

Enable or disable prediction along the surface of a building.
The distance between the building itself and the surface
prediction planes on the sides of the building has to be
specified as well.

Efficient assignment of this option to multiple objects is
possible. Click Objects > Surface Prediction from the
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menu. Buildings for which surface prediction planes were
defined will be displayed in purple.

Database Editing (Optional)

Simplification of Objects in an Urban Database
There are different features available to simplify urban building databases. This includes the erasing of
buildings below a specific height, the reduction of the number of corners for each building individually
and the combination of adjacent buildings. The simplification process can either be applied during the
conversion of the database or by using the corresponding option from the Edit menu.

Figure 115: The Options for the simplification of urban building databases dialog.

Erase buildings with height below threshold
By using this feature irrelevant information of the building database is deleted. The user can specify
a threshold in meters and all buildings with heights below this threshold will be erased (except the
corresponding building is defined as courtyard).

Simplification of an individual building (reducing the number of corners)
If multiple corners of a building are almost in a line, the redundant corners on the line can be removed.
This is done with a tolerance of 0.2 meters according to the feature “Delete redundant corners”.
Additionally, the reduction of building corners can be done in the same way using higher tolerances.
For this purpose, use the option Simplify shape of buildings (less corners) and the parameter
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level of simplification to define the degree of simplification. Positive integer values are accepted for this
parameter.

Figure 116: Simplification degree 10 and degree 20.

The simplification reduces the accuracy of the building database. Degrees of 10 and 20 are not critical.
Table 7 shows the effect on the accuracy. The predictions were averaged over the whole prediction area.

Table 7: Influence of the Simplification Degree on the Prediction Performance

Simplification Degree Corners per Building Computation Time [s] Average
Difference[dB]

0 13.8 330 0

10 10.3 220 2.59

20 9.1 190 3.25

30 8.1 170 3.87

40 6.9 90 4.05

The multiple runs of this simplification feature are also possible but this is not recommended. We rather
recommend doing one simplification run with a higher value for the “level of simplification”.

Due to the simplification, it is also possible that the walls of adjacent buildings (or included buildings)
intersect each other. As the overlapping of buildings is allowed within WallMan this will not lead to any
problems.
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Combination of adjacent buildings
Besides the simplification of the shape of individual buildings (reduction of the number of corners),
it is also possible to reduce the number of buildings by utilizing the feature “Combination of adjacent
buildings”.

The used algorithm scans the database for buildings which have walls in common or walls that are
very close to each other. The criterion for the combination of the considered buildings is their height
difference. Therefore, either an absolute value for the height difference (in meters) or a relative height
difference (percentage with respect to the tallest building) is evaluated. Typical values are 2 meters
concerning the maximal height difference or 5 % concerning the relative height difference. There are
also different ways how to determine the properties (height, material properties) of the combined
(resulting) building.

This combination method is an efficient approach to reduce the complexity of the building database
(and therefore to save pre-processing time) while preserving the general building structure. The next
Buildings before and after the combination of adjacent buildings

Figure 117: Buildings before and after the combination of adjacent buildings

Simplification of Objects in an Indoor Database
WallMan offers a menu item, Edit > Simplify Database. The Simplify Indoor Database dialog is
shown in Figure 118
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Figure 118: The Simplify Indoor Database dialog.

Several parameters are available to define the behaviour of this function: The Tolerance for
displacement describes the maximum value for the displacement between two polygons which will be
combined. A condition can be defined for cases where polygons should be combined. Further settings
can be defined with the check boxes.

When using very complex vector databases, for example, models of vehicles, the simplify function may
lead to problems or may need very long computation times.

Move Objects
Arbitrary objects can be moved along the x, y and z-axis. It works the same way in outdoor and indoor
databases. First, the objects that should be moved must be selected. Then select Objects > Move
selected objects from the menu.

In the appearing dialog enter the values for the vector along which the objects should be shifted. The
unit of the vector is meters and negative values are allowed.

Figure 119: The Move Objects dialog.

Click OK and the selected objects are moved.
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Rotate Objects
Objects (either walls or buildings) can be rotated with the 3D selection tool.

3D selection tool: Allows to define a box area by dragging a rectangle with the mouse
and entering the box height in the appearing dialog.

The tool copies all selected objects and lets the user enter them at a new position. A
click with the mouse sets the position, double-clicking with the left mouse button shifts
between rotation mode and movement mode. A click with the right mouse button finishes
the process.

Triangulate Objects in an Indoor Database
Repair or replace objects that would otherwise be considered invalid, such as non-planar ones by
triangulating objects.

Optionally, polygons in an indoor database can be triangulated via Objects > Triangulate selected
objects. This can be beneficial when imported polygons are not perfectly flat, to avoid problems later.

Modification of Corners of Objects
In outdoor and indoor databases, the corners of single objects can be modified. A list of all corners can
be reached by selecting an object, clicking with the right mouse button and selecting Properties.

Figure 120: Selected building in urban database with context menu.
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Besides a few other information, the Object Properties dialog contains a list with all corners of the
wall or building. Double-clicking an entry in the list opens a dialog which allows changing its three
coordinates (x, y and z).

Figure 121: The Object Properties dialog.

Figure 122: The Enter Coordinates dialog.

There are two limitations for changes to the coordinates. In indoor databases, the corners must
describe a planar flat if that is not the case all changes will be reverted. In outdoor databases, a change
to the z value of a corner will change the z value of all corners. All corners of a building always have the
same height.

Renumber Objects in Database
Sometimes multiple objects in the database have the same number. It is not possible to save such
a database. Therefore, the objects must be renumbered. This can be done by selecting Edit >
Renumber All Objects from the menu. The operation affects all objects in the database.

Add Virtual Buildings to Urban Database
Virtual buildings are used in WinProp to exclude certain areas in an urban database from calculations.
Often, it is desirable not to do a prediction in the whole rectangular area, which was defined at pre-
processing time. For example, this is suggested if large areas of waters are within an urban database
(for example, large rivers running through a town). Also, if parts of the database were not mapped,
large open areas occur. These areas lead to a longer pre-processing time (for the IRT-model because
visibility relations are computed for the open areas as well) although they are of no interest.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
3 WallMan p.122

Therefore, virtual buildings can be entered before the pre-processing of the database. They are
entered like normal buildings. In the pre-processing, no visibility relations to the pixels inside the
virtual buildings are computed and therefore no prediction is computed within the virtual buildings.
Additionally, no reflections, diffractions and transmissions are computed due to these buildings because
this would, of course, lead to errors. This approach reduces the pre-processing and prediction time as
well as the size of the pre-processed database.

To enter a virtual building, choose the Enter Virtual Buildings option from the Objects menu. This
will put WallMan in a special mode where all entered buildings become virtual buildings. A banner in the
upper-left corner of the window reminds you that WallMan is in virtual building mode. Just enter the
virtual buildings as you would do with any other building.

When finished, choose the Enter Virtual Buildings option again to exit the virtual building mode.
Virtual buildings appear in blue color making it easy to distinguish them from conventional buildings.

Figure 123: Virtual buildings.

You can open the object properties dialog of a virtual building. It looks like the same as for a normal
building only no material properties will be available. However, this procedure is convenient to change
the coordinates of the corner numerically.

Combine Objects
To reduce the number of objects in a database, it is possible to combine objects.

Combine tool (also accessible via the Objects menu). After activating it, the two objects
to be combined must be selected by clicking on them with the left mouse button. It is not
possible to combine more than two objects at a time.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
3 WallMan p.123

Group / Ungroup Selected Objects
WallMan offers a powerful group manager to handle especially large databases very easily. Groups are
simply a combination of several walls. Groups can have subgroups. The group manager can be opened
by selecting Objects > Group Manager.

Figure 124: The Group Manager dialog.

In the tree view on the left-hand side, all groups in the scenario are shown. If a group is selected in
this tree view, all objects belonging to this group are shown in the table on the right. The buttons in the
middle of the dialog are used to modify the groups.

Note:  Be aware of the delete function: Walls are not removed with the button Delete, only
the combination (grouping) of the objects is removed.

The Combine button is used to combine several groups (coequal groups, subgroups, parent groups) to
one new group. With the Rename button, the selected group will be renamed. The Create function is
used to generate a new group from all selected groups.

The button Group Walls by Material will create groups with respect to the material properties of the
walls.

There are also buttons on the toolbar available to use the grouping features:

First, you must select multiple objects by clicking on them in any of the three 2D-views
and holding the Ctrl key. When you have selected the objects, you want to become a
group, then click the group icon on the toolbar.

To disintegrate a group simply select one object of the group and click on the ungroup
icon on the toolbar.
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Specify Wall Type in Indoor Database

To specify the wall type of an object, select the object and click Objects > Set Type of selected
objects.

Tip:  Use Objects > Group Manager to select a large number of objects quickly.

Figure 125: The Wall Type dialog.

Standard Wall
Define the selected object as a standard wall.

Topography Triangles

Include vector topography data in an indoor database by setting the object to Topography
Triangles.

As an example, this can be convenient to model a traffic situation with elevation differences.
The traffic and other objects are in an “indoor” database (.idb file) purely to have geometrical
freedom to work with arbitrary object shapes. The ground, a collection of connected triangles
that approximate the elevation pattern, may be part of the imported geometry, or be converted
from another file and combined with the aforementioned database. The default setting for the
ground triangles, like any objects in WallMan, will be “standard wall”. That has a disadvantage if
the ground is not level: in ProMan it will not be possible to define a display height and a prediction
height at a constant distance from this ground. By changing the wall type of the ground triangles
to Topography Triangles, the disadvantage is removed: both the display height and prediction
height in ProMan can be defined relative to this ground, and will follow it up and down as needed.

For this assignment, all ground triangles need to be selected. If you have many, and if they have
a unique material, it is convenient to create a "group" of objects by material, select the group and
then change the wall type for all triangles at once.

If objects were grouped, the grouped objects must first be disintegrated before the .idb file can
be saved. Click Objects > Disintegrate selected group to disintegrate the group.

Graphical Wall (not considered in prediction)
Define the selected object as a wall that is not considered in predictions.

Prediction plane
Define the selected object as a prediction plane to be used to simulate wave propagation
predictions on the surface of the object. The object can be any arbitrary defined polygonal object.
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Add Time Variance to Objects
Time variance can only be used together with indoor databases (.idb), not with urban databases. Time
variant properties can only be assigned to groups of objects.

The button  is used to switch to the time variant mode. Alternatively, the menu item Edit > Launch

Time Variant Mode can be used. Editing and saving is not possible in this mode. To further edit or
save the database, the user has to return to the ordinary mode first (by clicking on Leave in the Time
Control window).

When the time variant mode is started the first time for the current database, the dialog of Figure 126
will appear to select the mode. There are two different time variant modes available.

Attention:  After a mode was selected for a database, the mode cannot be changed.

The following table shows a comparison of both modes:

Criterion ALD Mode RAC Mode

Definition of distance Absolute distance. Relative distance.

Duration of rotation Duration of rotation defined by
length of path.

Duration of rotation either
defined by length of path or by
rotation angle.

Orientation of rotation Orientation of rotation defined by
former direction of movement.

Orientation of rotation defined
by user (clockwise / counter-
clockwise).

Applications Vehicles (for example, on
streets, on rails)

Inside buildings (for example,
doors, elevators) Automation (for
example, robots)

As shown in the table above, the two modes are designed for different applications. For scenarios with
vehicles on streets or rails ALD mode should be preferred. For other time variant scenarios, the RAC
mode is the best solution. Depending on the selection, the definition of transformation/rotation differs.
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Figure 126: The Select Time Variant Mode dialog.

ALD Mode
In general there are two different time variant properties in ALD mode available:

Translation
This property moves an object along a direction vector. Thus, a direction vector has to be entered,
as well as the velocity for the translation.

Rotation
This property rotates an object with respect to the selected rotation axis. The rotation center has
to be defined, as well as the velocity.

The time variant transformations (translation and rotation) are defined with respect to the distance, the
selected object has already covered. The definition of several transformation properties for one object
with respect to different distances is of course possible. So it is possible to define arbitrary movements
for all objects in the scenario.

Between two time variant time stamps, the acceleration or deceleration of an object is done
automatically. The velocities for the time stamps have to be entered and with this information the
velocities for arbitrary positions between the two stamps are computed automatically. If the velocity for
time stamp 2 is larger than for time stamp 1, there will be a continuous acceleration. Otherwise there
will be a deceleration. All possible cases are shown in the following table:

Case Behaviour

Vn > Vn+1 The object will have steady deceleration between the two time stamps.

Vn < Vn+1 The object will have steady acceleration between the two time stamps.

Vn = Vn+1 The object will have constant velocity between the two time stamps.
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RAC Mode
In RAC mode the definition of translation and rotation differs a little bit from ALD mode. The definition
of the duration of a rotation is not only possible with respect to covered distance, but also with respect
to covered angle. This offers some other applications: As rotations around the own axis of objects are
not possible in ALD mode (as no distance is covered in this case), such rotations are possible in RAC
mode.

Translation
This property moves an object along a direction vector. Thus, a direction vector has to be entered,
as well as the velocity for the translation.

Rotation
This property rotates an object with respect to the selected rotation axis. The rotation center has
to be defined, as well as the velocity. The duration of the rotation is either defined in meters or in
degrees.

The definitions of covered distance/angle are relative in RAC mode. The behaviour of acceleration and
deceleration of objects differs also from the definition in ALD mode:

Former Movement Current Movement Behaviour

Translation Translation The object accelerates or decelerates, if velocities
of both points are different.

Translation Rotation with respect to
covered distance

The object accelerates or decelerates, if velocities
of both points are different.

Translation Rotation with respect to
covered angle

The object moves with constant velocity until it
reaches the point where the rotation starts. The
velocity is then set to the angular velocity defined
by the user.

Rotation with respect to
covered distance

Translation The object accelerates or decelerates, if velocities
of both points are different.

Rotation with respect to
covered angle

Translation The object rotates with constant velocity until the
object reaches the point, where the translation
starts. The velocity is then set to the value in m/s
defined by the user.

Assignment of Time Variance
After the time variant mode was started, the user can assign time variant behavior to each object
(group) in the current scenario. Therefore the group has to be selected in the dropdown box shown in
Figure 127. In this screenshot, the group “Blue Car” is selected and its time variant behaviour is shown
in the table.
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Figure 127: The Dynamic Behaviour (ALD-Mode) dialog.

Each time variant action corresponds with one line in the table. Symbols are used to indicate the type of
transformation:

Translation Defined by velocity and direction vector.

Rotation around x-axis Defined by velocity or angular velocity and rotation center. The
direction of the rotation is determined automatically.

Rotation around y-axis Defined by velocity or angular velocity and rotation center. The
direction of the rotation is determined automatically.

Rotation around z-axis Defined by velocity or angular velocity and rotation center. The
direction of the rotation is determined automatically.

Rotation around x-axis Defined by velocity or angular velocity and rotation center. The
direction of the rotation is manually defined (clockwise/counter
clockwise).

Rotation around y-axis Defined by velocity or angular velocity and rotation center. The
direction of the rotation is manually defined (clockwise/counter
clockwise).

Rotation around z-axis Defined by velocity or angular velocity and rotation center. The
direction of the rotation is manually defined (clockwise/counter
clockwise).

There are several buttons available to define the time variant behaviour for the selected object.

After pressing the button Add or Edit, a new window appears (see Figure 128) to define (resp.
change) the time variant properties for the selected group. First of all the type of transformation must
be selected with the radio buttons: Translation or rotation. Then the properties have to be entered.
Depending on the mode (RAC or ALD), there may be different edit boxes visible on the dialog. By
clicking OK, the changes will be applied.
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With the buttons Import / Export, time variant behaviour of an object can be loaded/stored from/into
a file. In RAC mode, the data is stored in .rac files, in the ALD mode, the data will be written to .ald
files.

Figure 128: The Add Transformation dialog.

The dialog window Time Control (see Figure 129) is always opened in the time variant mode. If it is
closed by the user, the time variant mode is closed and WallMan returns to the ordinary edit mode.
The time variant properties are not lost, they are stored in the database.

Figure 129: The Time Control (sec) dialog.

Several buttons are offered in the Time Control dialog to change the current time. With the buttons –
1s and –0.1s, the current time is decreased and with the buttons +0.1s and +1s, the time is increased.
The following hotkeys are also available to change the time:

Hotkey

Page Up Time +0.1s

Page Down Time –0.1s

Ctrl+Page Up Time +1.0s
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Hotkey

Ctrl+Page Up Time –1.0s

The Edit properties check box is used to open or close the window Dynamic Behaviour. When the
user presses the Leave button, WallMan returns to the ordinary edit mode.

As an alternative, trajectories can also be used for the definition of time variant movements. This
is often more convenient than using the dialog of Figure 127. Trajectories can be drawn with the
corresponding paint tool by selecting Objects > Enter Basic Objects > Enter Polyline Object. The
polylines are displayed with orange lines in WallMan.

Figure 130: Trajectories in WallMan

The assignment of a trajectory to an object (group) can be done with the dialog of Figure 127. By
clicking Trajectory, you can select one of the trajectories drawn before.

Figure 131: Selection of a trajectory for an object / group.

In the trajectory selection dialog the time variant behaviour can be defined for the selected trajectory.
It is possible to define one velocity for the complete polyline or an individual velocity for each section
of the polyline. The definition is automatically added to the table with the time variant information and
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indicated by a T. This means that the values cannot be modified manually, as the trajectory mode is
used. The link to the trajectory can be removed by clicking Remove.

Edit Clutter Properties
Clutter properties for urban and indoor databases can be defined optionally to specify location
dependent traffic definitions for radio network planning in ProMan.

All individual clutter classes available in the current vector database are listed in the Clutter Table,
which can be reached via menu Edit > Clutter Table.

Figure 132: The Clutter Classes dialog.

The clutter table can be used to manually add, modify or delete clutter classes.

Clutter class defined in the clutter table can be assigned to clutter maps of floor levels or to arbitrary
prediction planes using the Object Properties dialog.

Clutter maps can be modified graphically using the mouse tool Edit Clutter Database, which can be
selected in the Edit menu (Edit > Clutter Database) or via the corresponding toolbar icon. After
selecting the tool, a dialog opens where the modification to be done can be specified in detail.
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Figure 133: The clutter edit tool.

Using the drop-down box in the section Clutter Class, the clutter class to be assigned can be selected.
In the centre of the dialog the drawing mode, the clutter classes and floor planes to be considered, can
be specified.

Figure 134: Clutter classes to be considered.

If a clutter class is chosen to be not considered for a drawing operation, it will not be overwritten with
the selected new clutter class. This makes it possible to draw seamless. Beyond this, the user can select
which floor plane shall be affected by the drawing operation using the second drop-down box within the
Mode section. Therefore, it is easy to change the clutter maps of multiple building floors simultaneously
with a single operation.

In the lower part of the dialog, the paint tool to be used can be specified. The data can be changed
either using a rectangular, a polygonal or a line-shaped draw tool.

Further details about clutter maps for location dependent traffic definitions can be found in a separate
application note, which is available on the website.

Edit Single Wall in Indoor Database
If you want to edit a wall that is not parallel to one of the three predefined view planes, you can switch
to a view plane containing this wall. To do this, simply double-click on the wall. This way you can switch

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
3 WallMan p.133

to a view in which the selected wall is looked at from the top (note: it is always being looked at the wall
from the side closer to the coordinate system’s point of origin). In this view, you can double-click an
edge of the wall to look at this edge.

Note:  The edge is always viewed from outside the wall.

Determine and Show Shape of Buildings
Each building (in indoor databases) has a shape. The shape can be determined and shown in the views
of WallMan. To determine and show the shapes, the menu item Display > Determine and Show
Shape must be used.

Figure 135: Buildings without shape (left) and with shape (right)

The shape is automatically determined when the database (.idb) is stored on the hard disk. Sometimes
the determination of the shape leads to long computation times.

Therefore the determination of the shape can be disabled.

Figure 136: Save As dialog with check box to disable computation of shape.

At the bottom of the dialog, there is a check box to disable the computation of the shape. If the check
box is selected the shape will never be determined, even if quick save is used (Ctrl+S).
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The shape of a building is required if the building is imported to an urban database, for example, to
create a hybrid scenario (CNP).

The shape is always determined automatically based on all objects contained in the indoor database. A
horizontal ground plate or any other horizontal object influences the result of the shape determination
because the algorithm for the shape determination will consider this ground plate and will make sure
that the plate will be totally inside the shape. So, you do not have to define always a ground plate. If
you have already a large horizontal wall (for example, a floor or ceiling), this might be sufficient to get a
shape with only one polygon.

3.3.2 Database Pre-Processing

General

Why Pre-Processing?
Nearly all wave propagation predictions require a few computations that are different for each database
but the same for all transmitters. For example, the visibility relations between buildings never change,
no matter what kind of antenna pattern or how much output power the transmitter uses.

To decrease computation times WallMan performs such computations just once for each database so
that ProMan can use this computation for the actual predictions later.

Principle of Pre-Processing

Purpose
WallMan can pre-process urban and indoor databases. This is required to enable intelligent ray-tracing
in ProMan (faster than standard ray-tracing), and is optional for several other simulation methods. In
the pre-processing, the building data are prepared for the prediction. Also, errors in the database are
corrected.

The main advantage of pre-processing for ray-tracing is that the simulations will be faster. On the
other hand, depending on the settings, prediction height and discretization are specified before pre-
processing and cannot be changed later in ProMan.

Empirical Models
The pre-processing for the empirical prediction models consists of a check of the different objects within
the building database. Both the definition of every single object itself and the interaction between
different objects are verified. In the urban mode, the pre-processing for the vertical plane models
(COST 231 Walfisch-Ikegami, knife edge diffraction model) determines also the pixels which are located
inside the buildings. This means that the prediction grid is fixed (concerning lower-left corner and
resolution) after the pre-processing.
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Standard Ray Tracing
The pre-processing for the standard ray-tracing performs the same building check as for the empirical
models. Additionally, for the urban mode, the visibility relations between walls can be computed and
stored, which increases the computation time of the pre-processing slightly but reduces the time at the
prediction.

Intelligent Ray Tracing
The pre-processing for the intelligent ray-tracing requires a longer computation time because detailed
visibility relations are computed and stored in a file. This procedure reduces the computation time of the
prediction significantly.

Parameter Files
Multiple parameter files for one input database (IDB file for indoor and ODB file for urban) are possible.
This allows the user to compute different types of pre-processing (different parameters, different areas)
for the same database.

These parameter files (suffix PIN for indoor and suffix PRE for urban) can easily be generated with
WallMan using clear dialogs. The pre-processing itself is also performed in WallMan.

Coordinate System
In principle, WallMan can work with all Cartesian coordinate systems (for example, UTM or Gauss-
Krueger) for both urban and indoor applications. Although the coordinates are referred to as metric
unit, other units can be used.

When computing a pre-processing to do a prediction, the database must be converted to the metric unit
at first. This can be done with the function Scale all objects from the Objects menu.

This is important because the calculations of free space losses are calibrated to the metric unit.

Modification of Material Properties after Pre-Processing
It is possible to change the properties of the materials in a database after the pre-processing. It is not
possible to change the material type of a wall or building after the database has been pre-processed.
Such changes would require recomputing the pre-processing.

Any pre-processed database can be opened like a normal database. The difference is that most
functions are deactivated. The properties of the materials can be changed via the menu Edit >
Materials used in databases.

Spheric Zone
Another measure for the acceleration of the pre-processing and the prediction as well as for the
reduction of the size of the pre-processed file is the introduction of a so-called Spheric Zone. Only
visibility relations between such elements are investigated, that are within a certain maximum distance.
All other (possible) visibility relations are ignored.
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Figure 137: Spheric zone in an urban area.

Appropriate values are in the range of 400 – 800 meters for urban scenarios and 20 – 100 meters in
indoor scenarios. If the value is chosen too small, the prediction accuracy decreases, because not all
relevant visibility relations are then determined. Also, depending on the size of the buildings and their
distance to each other, parts of the prediction area might not be reached anymore by the IRT model,
because no visibility relations exist for that area.

Note:  The functionality in an indoor scenarios is analogous.

To activate the spheric zone, the parameter Spheric Radius must be set to the according to value (in
meters) when creating a prediction project.

Saving a Pre-Processing Project
Preprocessing projects, including indoor/urban databases as well as any associated secondary data such
as topography maps, can be exported from WallMan as a ZIP archive.

A pre-processing project can be saved using File > Save or File > Save As. These operations can
write absolute file paths, which is a disadvantage if you want to move or copy the project to a different
location. For such situations, the option File > Export > Export Project as ZIP Archive  should be
used. The zip file can be extracted in a different location.

Create Indoor Pre-Processing Project
The prerequisite for the creation of an indoor pre-processing project is a raw binary vector indoor
database file (.idb).

To create the project, select File > New Project from the menu. WallMan will ask for a .idb file that
contains the database to be pre-processed. Select the file and click OK to close the dialog. WallMan now
shows the database. Although this looks like the database edit mode it is not possible to change the
database.

The pre-processing parameters dialog can be opened via the button in the toolbar or via
Preprocessing > Edit Preprocessing Parameters in the menu.
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Start the pre-processing by clicking on the button in the toolbar or by selecting
Preprocessing > Compute Current Project in the menu. WallMan will ask for a name
for the project file before the pre-processing starts.

Project Parameters: Main Tab

Figure 138: The Indoor dialog, Main tab.

Output
This name defines the file name and folder of the files generated as the output of the pre-
processing.

CAUTION:  Do not use the same name as the input database file name, as it would be
overwritten.

Mode
Depending on which prediction model should be used in the predictions within ProMan, the
corresponding model must be chosen for the pre-processing.

Empirical models (Multi-Wall, Motley-Keenan,...)
For these wave propagation models (COST 231 Walfisch-Ikegami, Knife-Edge
Diffraction, ...) the pre-processing is not required, but can be used to combine the building
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and topographical layers and to compute the prediction grid (which pixels are outside and
which ones are inside the buildings) in advance.

3D Standard Ray Tracing (SRT)
The standard ray-tracing model (SRT) performs a rigorous 3D ray-tracing prediction which
results in a very high accuracy, but it is computationally expensive.

3D Intelligent Ray Tracing (IRT)
The 3D Intelligent Ray Tracing (IRT) technique computes the propagation path in three
dimensions including reflections at building walls and diffractions around building wedges
(horizontal and vertical). To accelerate the path finding the model is based on the pre-
processed building data.

Dominant Path Model (IDP, Indoor Dominant Path)
For the indoor dominant path model, the pre-processing is not required but can be used
to compute the prediction grid (which pixels are outside and which ones are inside the
buildings) in advance.

Prediction Area

The options Total, User defined rectangular area and User defined polygon prepare for
area-mode simulation in ProMan, meaning the results will be computed for an entire area. In this
mode, all visibility relations will be determined for maximum efficiency during simulation. The
prediction area and discretization will be fixed in the resulting file and cannot be changed later in
ProMan.

The option Point mode is recommended in preparation for ProMan simulations in point mode
(results will be computed for a set of individual points) and in trajectory mode (results will be
computed along a trajectory). Slightly less pre-processing will be done, and you will keep the
flexibility to specify prediction points or trajectories later, when setting up the simulation in
ProMan.

Project Parameters: Advanced Tab

Figure 139: The Indoor dialog, Advanced tab.
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Wedges

The minimum length of wedges to be considered for diffractions can be specified in meters.

If the indoor database contains additional objects defining ground, i.e. topography or clutter
objects, wedges at those objects can be taken into account optionally during pre-processing as
well.

Note:  This option is only available if topography or clutter objects are contained in
the database to be preprocessed.

Timevariant
If the database is a time-variant database, relevant options can be selected here. Since a
moving object changes visibility relations, this has to be taken into account appropriately during
preprocessing.

Project Parameters: IRT General Tab

Note:  These settings are only applicable to the 3D intelligent ray tracing (IRT) model.

Figure 140: The Indoor dialog, IRT General tab.

Resolution of grid / matrix

This value defines the basic resolution (in meters) the prediction will be computed with. If the
Adaptive Resolution Management (ARM, see below under “Acceleration”) is enabled, the resolution
is changed accordingly.
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Appropriate values are from 0.5 meters to 5 meters, 1 meter is typical. The smaller the
resolution, the higher the computation time and the higher the size of the IRT database, because
the visibility relations for more pixels must be computed.

In general, it is advisable to rather keep a smaller resolution but choose a higher value for the
reduced resolution. For example, it would be better to choose 1 meter with a reduced resolution
factor of 3 instead of 1.5 meters with a reduced resolution factor of 2.

The advantage would be that in critical parts of the prediction area (for example, narrow
corridors) the prediction is done in a smaller resolution, with the computation time and the
database size hardly increasing.

This setting does not influence the resolution the building geometry is processed with. The
building geometry is always processed at highest precision.

Height(s) of grid/matrix
This parameter defines the prediction height or heights as absolute z-coordinate values. A pre-
processing for multiple heights is possible. The individual heights must be separated by commas
then, for example, “1.2, 2.0, 4.5”. The usage of multiple heights in IRT pre-processing leads to
higher pre-processing times and larger IDI databases.

Additionally prediction of outdoor pixels
If this check box is selected, also the pixels of the database that are outside the building will be
pre-processed (a prediction in the outdoor vicinity of the building is also possible). If the check
box is not selected, the pre-processing is limited to the inner of the building. This option is only
available if a shape has been determined.

Width of tiles at standard walls

This option defines the maximum size of the tiles the walls are divided. If a wall is smaller than
the given value, it is not divided but handled as the whole wall. The smaller the value is chosen,
the longer the pre-processing and computation time and the larger database size get, because the
visibility relations for more tiles must be computed. On the other hand, the prediction accuracy is
higher.

Suggested values are 0.5 – 10 meters, typical is 2 meters.

Width of tiles at prediction surfaces

The resolution of prediction surfaces can differ from the resolution of standard walls. Each wall
can be enabled for a prediction on its surface separately. The user has the possibility to assign a
different resolution to walls with enabled surface predictions than to the other walls.

This option defines the maximum size of the tiles prediction surfaces are divided. If a prediction
surface object is smaller than the given value, it is not divided but handled as the whole object.
The smaller the value is chosen, the longer the pre-processing and computation time and the
larger database size get, because the visibility relations for more tiles must be computed. On the
other hand, the prediction accuracy is higher.

Suggested values are 0.5 – 10 meters, typical is 2 meters.

Length of segments at wedges
This option defines the maximum size of the horizontal and vertical segments the wedges are
divided into. If a wedge is smaller than the value given, it is not divided but handled as the
whole wedge. The smaller the value is chosen, the longer the pre-processing and computation
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time and the larger database size get, because the visibility relations for more segments must
be computed. On the other hand, the prediction accuracy is higher. Typical values are 0.5 – 10
meters, the default is 2 meters.

Only rays inside the building
Enabling this option causes rays to end at the outer wall of the building. This option should not be
enabled if the building has the shape of an “L” or something similar. If the building has the shape
of a rectangle this option can be enabled to save computation time. This option is only available if
a shape has been determined for the building.

Interactions

Consider multiple interactions between objects

Enabling this option causes multiple rays to be considered but the simulation time
increases.

If this option is disabled, ProMan computes only the direct ray plus the single reflection and
single diffraction.

Tip:  It is recommended to select the Consider multiple interactions
between objects check box.

Exclude Diffractions
This option excludes the computation of diffractions within the whole database.

Project Parameters: IRT Acceleration Tab

Note:  These settings are only applicable to the 3D intelligent ray tracing (IRT) model.
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Figure 141: The Indoor dialog, IRT Acceleration tab.

Reduced Resolution
This option defines the factor for the Adaptive Resolution Management. Suggested values are 2
or 3.

Searching of Possible Points of Interaction (Spheric Zone)

This option (if enabled) defines the maximum radius (distance) up to which the visibility relations
between the elements are considered. The value must be specified in meters.

Suggested values are 40 – 150 meters, depending on the building structure.

In Auto mode, values are selected automatically.

Excluding triangular objects
To accelerate pre-processing and prediction, interactions at selected objects can be excluded. The
shielding at these objects is still considered, only reflections, diffractions and transmissions are
not allowed at these objects.

Prediction Models and Their Pre-Processed Database Files
Depending on the mode you select for the run of the pre-processing, different output files are
generated. The different modes (and thus output files) are needed for the different prediction models.

The pre-processed database files are all in binary format.
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Table 8: Indoor Database Files

Extension Database Type

IDB Indoor Database Binary
Raw Indoor Database without any pre-processing computation done. Nevertheless,
this database can also be used directly for predictions with selected prediction
models.

IDC Indoor Database COST
Pre-processed database for a prediction with the empirical Multi-Wall (MW) model.

IDW Indoor Database Walls
This is a pre-processed database file for a prediction with the deterministic standard
ray-tracing (SRT) model.

IDI Indoor Database Intelligent Ray Tracing
Pre-processed database for a prediction with the deterministic intelligent ray-
tracing (IRT) model.

IDP Indoor Dominant Path
Pre-processed database for a prediction with the indoor dominant path prediction
(IDP) model.

Create Urban Pre-Processing Project
The prerequisite for the creation of an urban pre-processing project is an .odb file.

To create the project, select File > New Project from the menu. WallMan will ask for a .odb file that
contains the database to be pre-processed. Select the file and click OK to close the dialog. WallMan now
shows the database. Although this looks like the database edit mode it is not possible to change the
database.

The pre-processing parameters dialog can be opened via the button in the toolbar or via
Preprocessing > Edit Preprocessing Parameters in the menu.
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Start the pre-processing by clicking on the button in the toolbar or by selecting
Preprocessing > Compute Current Project in the menu. WallMan will ask for a name
for the project file before the pre-processing starts.

Project Parameters: Main Tab

Figure 142: The Urban dialog, Main tab.

Name of the Output File
This name defines the file name and folder of the files generated as the output of the pre-
processing.

CAUTION:  Do not use the same name as the input database file name, as it would be
overwritten.

Mode of Preprocessing
Depending on which prediction model should be used in the predictions within ProMan, the
corresponding model must be chosen for the pre-processing.

Empirical Vertical Plane Models
For these wave propagation models (COST 231 Walfisch-Ikegami, Knife-Edge
Diffraction, ...) the pre-processing is not required, but can be used to combine the building
and topographical layers and to compute the prediction grid (which pixels are outside and
which ones are inside the buildings) in advance.
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Intelligent Ray Tracing (IRT)

3D: Rigorous 3D IRT (Reflections + Diffractions)
The 3D Intelligent Ray Tracing technique computes the propagation path in three
dimensions including reflections at building walls and diffractions around building
wedges (horizontal and vertical). To accelerate the path finding the model is based on
the pre-processed building data. In addition to the rigorous 3D ray-tracing, there are
two different other ray-optical modes available.

2 x 2D: 2D-H IRT (Diffractions) + 2D-V IRT (Diffractions)

The pre-processing and as a follow-on also the determination of propagation
paths is done in two perpendicular planes: one horizontal plane (for the wave-
guiding, including the vertical wedges) and one vertical plane (for the over rooftop
propagation including the horizontal wedges). In both planes, the propagation paths
are determined similarly to the 3D-IRT method by using ray optical methods.

2 x 2D: 2D-H IRT (Diffractions) + 2D-V Knife Edge Diffraction
This model treats the propagation in the horizontal plane in the same way as the
previously described model, by using ray optical methods (for the wave-guiding,
including the vertical wedges). The over-rooftop propagation (vertical plane) is
considered by evaluating the knife edge diffraction model.

Dominant Path Model (UDP, Urban Dominant Paths)
For the urban dominant path model the pre-processing is not required but can be used to
combine the building and topographical layers and to compute the prediction grid (which
pixels are outside and which ones are inside the buildings) in advance.
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Project Parameters: General Tab

Figure 143: The Urban dialog, General tab.

Determination of Indoor Pixels
This option determines the indoor pixels within the area of interest and stores this information in
the pre-processing file. Herewith an acceleration of the afterwards predictions within ProMan is
achieved.

Pre-processing for Combined Network Planning (CNP)
The CNP approach allows combining urban and indoor building databases which require a specific
pre-processing.

Relative Building Height: Elevation Data
Generates a separate file representing the building heights in terms of a height matrix.

Absolute Building Height: Elevation Data
Generates a separate file representing the building plus terrain heights in terms of a height
matrix.

Morpho/Clutter Data
Generates a separate file representing the building information in terms of a clutter database
(either building / no building or depending on height interval an integer describing the number of
floors). This file can be used for detailed traffic modeling (for example, higher number of users in
taller buildings) with respect to capacity dimensioning.

Generate Logfile during Preprocessing
This option generates a log file that contains the same output as the pre-processing progress box.
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Project Parameters: Area Tab

Figure 144: The Urban dialog, Area tab.

Area of Pre-processing

If Total database is chosen, the whole database is pre-processed. If only a part of the database
should be considered, the User defined polygon option should be selected.

In this case, the pre-processing area can be defined with a mouse tool (either rectangular or
polygonal area). The definition of a polygonal area is extremely helpful for urban databases
where the built-up area has not the shape of a rectangle as this approach limits the number of
considered pixels.

The above options prepare for area-mode simulation in ProMan, meaning the results will be
computed for an entire area. In this mode, all visibility relations will be determined for maximum
efficiency during simulation. The prediction area and discretization will be fixed in the resulting file
and cannot be changed later in ProMan. The option Points only is recommended in preparation
for ProMan simulations in point mode (results will be computed for a set of individual points) and
in trajectory mode (results will be computed along a trajectory). Slightly less pre-processing will
be done, and you will keep the flexibility to specify prediction points or trajectories later, when
setting up the simulation in ProMan.
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Figure 145: Definition of a polygonal pre-processing area.

Height above ground

This value defines the prediction height relative to the ground (street or terrain level) or relative
to sea level. This fixes the prediction height for simulations in area mode.

Multiple heights can be entered in this field, separated by commas and blanks or just by blanks.

Resolution of grid

This value defines the basic resolution (in meters) with which the area-mode simulation will be
performed.

Appropriate values are from 2 meters to 50 meters, 10 meters is typical. The smaller the
resolution of the database. This is especially the case for the IRT mode, the higher the
computation time and the higher the size of the database. This is especially the case for the IRT
mode, because the visibility relations for more pixels must be computed.

In general, it is advisable to rather keep a smaller resolution but choose a higher value for the
reduced resolution. For example, it would be better to choose 10 meter with a reduced resolution
factor of 3 instead of 15 meters with a reduced resolution factor of 2. The advantage would be
that in critical parts of the prediction area (for example, narrow streets) the prediction is done in
a smaller resolution, with the computation time and the database size hardly increasing.

This setting does not influence the resolution with which the building geometry is processed.

Project Parameters: IRT Tab

Note:  These settings are only applicable to the 3D intelligent ray tracing (IRT) model.
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Figure 146: The Urban dialog, IRT tab.

Subdivision of Walls

This option defines the maximum size of the tiles the walls are divided into. The horizontal and
vertical value can be defined separately.

If a wall is smaller than the values given (in both horizontal and vertical direction) it is not divided
but handled as the whole wall.

The smaller the values are chosen, the longer the computation time and the larger the database
size gets, because the visibility relations for more tiles must be computed. Suggested values are
between 40 – 100 meters, a typical value is 60 meters.

Subdivision of Wedges

This option defines the maximum size of the horizontal and vertical segments the wedges are
divided into. The horizontal and vertical value can be defined separately. If in a scenario the
diffraction at the roof wedges is important (if the over-rooftop propagation is dominant), then a
smaller value for the horizontal segments should be used. If a wedge is smaller than the values
given it is not divided but handled as the whole wedge. The smaller the values are chosen, the
longer the computation time and the larger the database size gets, because the visibility relations
for more segments must be computed.

Suggested values are between 40 – 100 meters, a typical value is 60 meters.

Enhanced Resolution Management
This option defines the factor for the Adaptive Resolution Management. Suggested values are 2
or 3.

Selection of Possible Points of Interaction (Spheric Zone)

This option (if enabled) defines the maximum radius (distance) up to which the visibility relations
between the elements are considered. The value must be specified in meters.
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Suggested values are from 600 – 1000 meters, depending on the database structure. A typical
value is 800 meters for the fixed size. In “Auto” mode the size of the spheric zone depends on
the height of the individual element (tile or segment), for higher elements automatically a larger
radius is considered. Therefore, the maximum distance (= radius of the spheric zone) up to which
visibility relations are considered is determined according to the settings of the basic radius and
the radius increment.

This acceleration method puts only limitations on the range between the different interaction
points (reflection, diffraction) and the pixels of the prediction grid. There is no limitation for the
distance between the transmitter and the first interaction point by this procedure!

Multiple Interactions between objects included

This acceleration method can be combined with all three IRT modes included in WallMan, 3D-IRT,
2x2D (2D-H IRT + 2D-V IRT) and 2x2D (2D-H IRT + 2D-V Knife Edge Diffraction). The following
paragraphs describe the approach in more detail.

The pre-processing of the building data is a prerequisite for the ray-optical modeling of the wave
propagation based on the IRT algorithm. The IRT approach allows ray-optical predictions over
large urban areas which are not possible using conventional ray-optical algorithms.

In this pre-processing, in a first step, the building walls are subdivided into tiles and the building
wedges are subdivided into segments (vertical and horizontal ones). After this segmentation the
mutual visibility relations between the numerous elements (walls, segments and pixels) of the
building database are determined.

Multiple Interactions check box enabled
Usually the pre-processing in WallMan includes both the determination of visibility relations
between tiles and tiles (segments and segments) as well as between tiles and pixels
(segments and pixels). This allows then coverage predictions including multiple interactions
(reflections, diffractions) which guarantee a high accuracy. However, due to the high
number of visibility relations, which must be determined, the pre-processing of large urban
areas (larger than 10 km2) might take a long time.

Multiple Interactions check box disabled
The new “Interaction Control” feature implemented in the IRT algorithm provides a better
opportunity for such large urban areas. This approach focuses on the determination of the
visibilities between tiles and pixels (segments and pixels) and requires, therefore, a reduced
pre-processing time. So, it is possible to pre-process even larger areas. However, the ray-
optical prediction is limited to the computation of a single diffraction on the building wedges
and a single reflection on the building walls, while for the over rooftop propagation the
knife-edge diffraction model is used.

Pre-process additionally indoor pixels for IRT indoor coverage

The ray-optical wave propagation modeling is based on the building database (in vector format,
each building is described as a polygonal cylinder) and the underlying terrain data (if available).

The ray-tracing algorithm has been extended so that not only the rays to outdoor pixels are
calculated but also the rays to pixels inside the buildings. This has been achieved by subsequent
modifications to the algorithms which are in charge of the ray determination. However, the effort
for the pre-processing is increased (computation time as well as the size of the pre-processing
file) if this feature is activated.
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Indoor IRT check box enabled

Usually the pre-processing in WallMan includes only the pixels outside the buildings. If the
corresponding checkbox is activated also the indoor pixels are taken into account. This
allows then coverage predictions including multiple interactions (reflections, diffractions)
also for the points inside the buildings (on the defined prediction height) which guarantees a
high accuracy.

Indoor IRT check box disabled

If the Indoor IRT check box is not activated the visibility relations are only determined for
pixels outside buildings (default setting, similar to previous versions of WallMan), for the
coverage prediction into the buildings only an empirical model can be used in ProMan as the
ray-optical model is not available.

Project Parameters: Topo Tab

Figure 147: The Urban dialog, Topo tab.

Consideration of Topography
To consider an additional topographical database, this option must be selected. According to the terrain
profile, the buildings of the database are shifted in Z-direction which leads to modified obstructions.
Additionally, the height of the receiver pixels is adapted. This topography extension is applicable for all
different modes empirical vertical plane models, IRT and UDP.

Heights of Buildings in Database
There are two choices concerning the definition of the building heights with respect to the corresponding
terrain database. Either the building heights are given in relative coordinates, relative to street level or
the building heights are defined with respect to sea level in absolute coordinates. The user must select
the correct option according to the selected building database.
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Topographical Database
When this option is selected also the file name of the corresponding topographical database in the
WinProp format (.tdb file) must be specified. The Browse button allows the user to select the
corresponding file including the terrain data. Hereby it should be ensured that the whole building
database is covered by the terrain database, otherwise, there will be an error message.

Prediction Models and Corresponding Pre-Processed Database Files
Depending on the selected mode for the pre-processing run, different output files are generated.
The different modes (and thus output files) are required for the different prediction models. All files
produced during the pre-processing are stored in binary format.

For each mode, one different file is generated. This file contains the building data as well as the visibility
information and the considered parameters for this pre-processing, for example, area, resolution.

The building data of the whole area covered by the ODB file is checked and saved to the corresponding
pre-processing file in any case, even when creating database files for IRT prediction. This is because
WinProp allows a post-processing of the prediction using the knife edge diffraction model. Therefore,
the building information of the whole area is required for any prediction and thus always computed.

While the pre-processing for the COST and UDP models contains always the whole area (due to the
point mentioned above), the area for the IRT pre-processing can be selected by the user.

Table 9: Urban Output Files.

Extension Result File Type

ODB Outdoor Database Binary
Raw outdoor binary vector database. This database must be pre-processed first, to
be used for a computation.

OCB Outdoor COST Binary database
Pre-processed database for a prediction with one of the empirical vertical plane
models (for example, COST).

OIB Outdoor IRT Binary database
Pre-processed database for a prediction with the deterministic IRT (Intelligent Ray
Tracing) model.

OPB Outdoor UDP Binary database
Pre-processed database for a prediction with the UDP (urban dominant path)
model.
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If enabled by the option “Generate log-file during pre-processing”, a log file is written. The file name
is the same as the database output file name (.odb) with the .log suffix. The file contains all (error)
messages that are issued during the pre-processing as well as additional information.

Create Hybrid Urban / Indoor (CNP) Pre-Processing Project
Hybrid urban/indoor pre-processing projects allow the prediction of outdoor transmitters inside buildings
with consideration of the indoor walls and the urban buildings (transition urban to indoor) as well as the
outdoor prediction of indoor transmitters with consideration of the indoor walls and the urban buildings
(transition indoor to urban).

The prerequisite for the creation of a hybrid urban/indoor (CNP) pre-processing project is a .odb file
that contains an urban database and at least one imported indoor database.

To create the project, select File > New Project from the menu. WallMan will ask for a .odb file that
contains the database to be pre-processed. Select the file and click OK to close the dialog. WallMan now
shows the database. Although this looks like the database edit mode it is not possible to change the
database.

Table 10: Preprocessing icons.

The pre-processing parameters dialog can be opened via the button in the toolbar or via
Preprocessing > Edit Preprocessing Parameters in the menu.

Start the pre-processing by clicking on the button in the toolbar or by selecting
Preprocessing > Compute Current Project in the menu. WallMan will ask for a name
for the project file before the pre-processing starts.

Project Parameters
The parameters for a CNP project are mostly identical with those for an urban project. The only
difference is in the CNP section.

Project Parameters: CNP Tab
Tiles

This option defines the maximum size of the tiles the walls of the indoor building database are
divided into. The smaller the values are chosen, the longer the computation time and the larger
the database size gets, because the visibility relations for more tiles must be computed. This
parameter is only relevant for the transition from indoor to urban.

Suggested values are between 0.5 – 10 meters, a typical value is 2 meters.
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Segments

This option defines the maximum size of the segments the wedges of the indoor building database
are divided into. The smaller the values are chosen, the longer the computation time and
the larger the database size gets, because the visibility relations for more segments must be
computed. This parameter is only relevant for the transition from indoor to urban.

Suggested values are between 0.5 – 10 meters, a typical value is 2 meters.

Figure 148: The Urban dialog, CNP IRT tab.

Resolution

This value defines the resolution (in meters) the prediction will be computed with inside the
building of interest, the indoor building database. If the Adaptive Resolution Management (ARM,
see below under “Acceleration”) is enabled, the resolution is changed accordingly.

Appropriate values are from 0.5 meters to 5 meters, 1 meter is typical. The smaller the
resolution, the higher the computation time and the higher the size of the IRT database, because
the visibility relations for more pixels must be computed.

This setting does not influence the resolution the building geometry is processed with. The
building geometry is always processed at highest precision.

Urban Tile Size of CNP Buildings
This value corresponds to the maximum size of the tiles the walls of the CNP buildings are divided
into for the representation in the urban building database. This parameter should be chosen
according to the building structure, the floor height as a maximum. This parameter is only
relevant for the transition from urban to indoor.

Prediction Height
This parameter defines the prediction height or heights inside the building of interest, the indoor
building database, as absolute z-coordinate values. A pre-processing for multiple heights is
possible. The individual heights must be separated by commas then, for example, “1.2, 2.0, 4.5”.
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The usage of multiple heights in IRT pre-processing leads to higher pre-processing times and
larger databases. This parameter is only relevant for the transition from indoor to urban.

Reduced resolution
This option defines the factor for the Adaptive Resolution Management. Suggested values are 2 or
3. This parameter is only relevant for the transition from indoor to urban.

Spheric Zone

This option (if enabled) defines the maximum radius (distance) up to which the visibility
relations between the elements inside the building of interest, the indoor building database,
are considered. The value must be specified in meters. This parameter is only relevant for the
transition from indoor to urban.

Suggested values are 40 – 150 meters, depending on the building structure.

In Auto mode, values are selected automatically.

Prediction Models and Their Pre-Processed Database Files
Depending on the selected mode for the pre-processing run, different output files are generated.
The different modes (and thus output files) are required for the different prediction models. All files
produced during the pre-processing are stored in binary format.

For each mode, one different file is generated. This file contains the building data as well as the visibility
information and the considered parameters for this reprocessing, for example, area, resolution.

The building data of the whole area covered by the ODB file is checked and saved to the corresponding
pre-processing file in any case, even when creating database files for IRT prediction. This is because
WinProp allows a post-processing of the prediction using the empirical vertical plane models. Therefore,
the building information of the whole area is required for any prediction and thus always computed.

While the pre-processing for the empirical vertical plane models (for example, COST) contains always
the full area (due to the point mentioned above), the area for the IRT pre-processing can be selected by
the user.

Table 11: Urban CNP Output Files

Extension Result File Type

OCB + IDB “Outdoor COST Binary” database plus “Indoor Database Binary” database.

Pre-processed database for a prediction with the empirical vertical plane models (allowing
urban→indoor as well as indoor→urban transitions).

OIB + IDI “Outdoor IRT Binary” database plus “Indoor Database IRT” database.

Pre-processed database for a prediction with the deterministic IRT (Intelligent Ray
Tracing) model (allowing urban→indoor as well as indoor # urban transitions).
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3.3.3 Indoor LEGO Tool
The WallMan Indoor Lego Feature, the supplementary “Mouse Meter” and the “3D Selection and
Copy” tools provide a couple of “easy to use” functions for indoor database creation. The main idea
is the generation of basic wall combinations (the so-called “templates”) describing typical database
elements such as rectangular rooms, staircases and roofs. The user-friendly graphical interface
offers dialog based entry of fundamental template parameters (dimensions), post-creation editing
possibilities (moving, scaling, rotating), the definition of any combination of database walls as a
template, recombination possibilities for known templates and a program toolbar for fast selection of
the tool to be used.

The “Mouse Meter” tool simplifies the adaptation of newly created template objects to existing database
objects by the indication of distance information. The measured distances can be used as a base for the
dimension dialog entries.

The “3D Selection and Copy” tool enables database creators to construct templates from existing
database objects by the specification of a rectangular area and 3rd coordinate information. Using this
tool, whole building parts can be copied and processed as templates like mentioned above.

Overview

Templates
In WallMan, indoor walls are modeled as bordered, polygonal shaped areas which are characterised by
some electromagnetic parameters which are relevant for field strength calculations. The program offers
basic tools for wall creation in indoor scenarios, but without the new features, each building wall had to
be entered individually. The template functionality offers a solution for this problem.

Templates consist of a certain number of walls arbitrarily placed in the database area which are
combined by the template definition. A template is internally represented as a simple list of walls.
In 3D space, each wall list is bordered by a cuboid. The minimum point Pmin is used as the origin for
the template inherent coordinate system and will be called “template origin” in the following. If the
mentioned cuboid is mapped on a 2D surface, it disintegrates into a rectangular shape which can be
called the object’s “Bounding Box”.

Figure 149: Object surrounding cuboid in 3D space.
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The Indoor Lego Feature extends the WallMan indoor wall creation tools by a set of predefined
templates covering structures which are frequently found in indoor databases. “Lego” should be
understood as follows: Indoor Lego templates can be used to create whole buildings based on individual
components in almost the same manner as the known LEGO toy building blocks.

Template Toolbar
The WallMan main screen offers a toolbar for fast selection of template tools. The toolbar is active
whenever the current view is a 2D view (xy-, xz- or yz-view) and no template is currently edited. In
the 3D view, the modules described in this document cannot be used. The toolbar can be activated and
deactivated using the convenient menu entry in the WallMan “View” menu.

Figure 150: The template toolbar.

A mouse click on one of the toolbar symbols starts the selected tool and simultaneously ends the tool
which was selected before.

Operational Modes
In the template feature, three operational modes can be distinguished. Firstly, the Drag Mode which
allows a 3D displacement of the created template, secondly, the Track Mode which allows a 2D
displacement and scaling of the created template and thirdly, the Rotate Mode which allows the
template to be rotated about the current 3rd coordinate axis.

Common Commands – Inserting Templates and Cancelling
After the creation of a template and its editing, the template must be inserted into the WallMan
database. This insertion is possible at any time in each of the modes described in the following
paragraphs. A click on the right mouse button initiates the insertion. During the insertion process,
the template walls will be checked for intersections with existing database objects. If an insertion
is impossible because of intersections, an error message is displayed and the Drag Mode will be
reactivated.

Pressing the Esc key will stop the template editing without inserting the object into the database.

After the final insertion, the template is automatically bonded to a group. So, you can easily select the
whole template in your further editing (of course you can also disable the group).

Drag Mode
The Drag Mode is the first operational mode a template object must pass while being processed. In this
mode, objects can be moved freely in 3D space. As the current view always is a 2D view, the movement
in the current plane is done by using the mouse. Database scrolling is possible by moving the object
to one of the borders of the current view. The mouse arrow always points to the 2D projection of
the above-mentioned object origin and the object is “suspended” from the arrow position. So, if the
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mouse is moved, the object follows. 3rd coordinate changes can be done with the WallMan specific 3rd
coordinate hot keys. These are in detail:

• Shift +Cursor Up to increase/decrease the 3rd coordinate by 1 m,

• Shift+Cursor Down to decrease the 3rd coordinate by 1 m,

• Ctrl+Cursor Up to increase the 3rd coordinate by 10 m,

• Ctrl+Cursor Down to decrease the 3rd coordinate by 10 m,

• Shift+Ctrl+Cursor Up to increase the 3rd coordinate by 0.1 m,

• Shift+Ctrl+Cursor Down to decrease the 3rd coordinate by 0.1 m.

The reference point for the object position in the database is the (3D) object origin. This is important for
recombining template objects while the current view is not the ground plane view of the template. In
this case, the template will be recombined and displayed in the current plane and a modification of the
3rd coordinate will be made in relation to the former origin.

For example:

1. A template with a surrounding cuboid height of 2 meters is created in the xy-view and inserted
into the database at z = 0 m.

2. Afterwards, the current view plane is set to z = 1.5 m.

3. Then a template recombination is done. This activates the Drag Mode.

4. If the 3rd coordinate is modified now, this modification will be based on the former object origin
which is in the plane z = 0 m.

5. So, if the 3rd coordinate is increased by 1 m for instance, the object origin will be displaced to the
plane z = 1 m and not to the plane z = 2.5 m which is 1 m above the current view plane.

6. The Drag Mode is left by clicking the left mouse button once. This will automatically activate the
Track Mode.

Track Mode
The Track Mode provides template scaling and “tracking” (moving) in the current view plane. As soon as
the Track Mode is activated, a rectangular box surrounding the object projection will appear. This box is
called the “Bounding Box” of the object.

Note:  The Bounding Box is possibly larger than the visible object borders.

This is an effect depending on the selected view, the selected view plane and the rotation state of the
object. During the Track Mode, all object operations can only be initiated when the mouse cursor is
placed inside the borders of the Bounding Box.

Important:  The current release of the Indoor Lego Feature does not include an Undo /
Redo function, so all changes made to a template object are definite.

The object 2D displacement can be started by simply clicking and holding the left mouse button while
the mouse cursor is positioned somewhere inside the Bounding Box. A box (“forecast box”) will be
displayed which predicts the future position of the object. By moving the mouse, this position can be
altered. When the left mouse button is released, the object will be drawn at the new position and the
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tracking operation is done. Holding down the Ctrl and / or the Shift key while changing the position of
the forecast box will cause the following behaviour:

• Ctrl+mouse movement – object only moves horizontally

• Shift+mouse movement – object only moves vertically

• Ctrl+Shift> + mouse movement – object moves back to original position.

Note:  It is important that the above-mentioned keys are pressed while the object is already
being tracked. If the keys are pressed before the tracking operation is initiated, the scaling
mode will be activated.

The scaling operation for predefined templates allows isogonal scaling in the initial object coordinate
system. Here is a more detailed explanation: in the initial object state (object is not yet rotated) all
scaling operations are done with respect to the object origin. So, this point is a scaling operation fixed
point. In this state, a mouse movement to the right after initiating the scaling operation leads to a
broadening of the object, a mouse movement to the left leads to a curtailment. If the mouse is moved
upwards, the object becomes larger, moving the mouse downwards shortens the object. Now think of a
rotated object and notice that the object coordinate system is rotated as well. Imagine a 180 degrees
rotation about the z-axis, if the object coordinate system was not rotated together with the object, a
mouse movement to the right now would increase the size of the object on its left side. As this would
be an inconsistency in the user interface, a different concept is used. The object coordinate system is
rotated together with the object and the interpretation of the mouse movement is rotated accordingly.
Always consider the fact that the object origin is bound to the object, it does not change using the
rotation operation. Now, a rotated object shows the following behaviour: if the mouse is moved into the
direction which was the former “right side” of the object its width will increase. This concept offers a
more consistent way of handling rotated objects to be scaled.

The scaling operation itself is initiated by holding down the Ctrl and / or the Shift key and clicking and
holding the left mouse button. Moving the mouse will now permit scaling as explained above. The keys
provide the following functions:

• Ctrl key only allows scaling in the 1st object coordinate

• Shift key only allows scaling in the 2nd object coordinate

• Ctrl and Shift keys held down simultaneously allow free scaling in both object coordinates.

The scaling operation is finished when the left mouse button is released.

Tip:  Scaling is only allowed if the grid is not active.

Double-clicking the left mouse button leaves the Track Mode and switches to the Rotate Mode.

Note:  Non-predefined templates often cannot be scaled isogonal because of the missing
reference point (object origin) and coordinate system information.

Rotate Mode
The Rotate Mode offers the possibility to rotate the selected object graphically around the 3rd
coordinate axis of the current view. For example, a rotation in the xy-view will be around the z-axis.
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Important:  The Rotate Mode can only be activated if the database grid is not active.

The fixed point of any template rotation is the spatial centre of the surrounding cuboid. So, the rotation
is done about the above mentioned 3rd coordinate axis with respect to this fixed point.

The rotation operation is initiated by clicking and holding the left mouse button while the mouse cursor
is positioned inside the object’s Bounding Box. Moving the mouse to the left will rotate the object in a
mathematically positive sense, moving the mouse to the right will rotate in a mathematical negative
sense. The object will be rotated by 0.5 degrees per Pixel.

The Ctrl and the Shift key provide some “grid” functions here:

• Holding down the Shift key while rotating an object will cause the object to be rotated to the next
angle which is divisible by 2.5 without remainder and further rotation will be done in steps of 2.5
degrees.

• Holding down the Ctrl key while rotating an object will cause the object to be rotated to the next
angle which is divisible by 5 without remainder and further rotation will be done in steps of 5
degrees.

• Holding down the Shift key and the Ctrl key simultaneously while rotating an object will cause
the object to be rotated to the next angle which is divisible by 10 without remainder and further
rotation will be done in steps of 10 degrees.

Note:  This “grid” function is based on the primary object rotation state. Whenever a
template object is recombined or newly created, the rotation angle of the object is set to
zero even if the object has been rotated before.

Templates
The following paragraphs give a short description of the predefined templates in WallMan. The used
symbols show a certain view of the object but be aware that the object dimensions always refer to the
xy-view.

The relevant template parameters (dimensions and material parameters) can be set in a dialog which
is shown whenever a template symbol is chosen by clicking on it with the left mouse button. The
“Material” button in every template parameter dialog provides the selection of wall material properties.
The dialog for these properties which is displayed after clicking the button is already known from
WallMan, so confer the WallMan user manual for further explanation in this regard.

Rooms
The Indoor Lego Room templates provide some predefined room structures. In detail these structures
are:

• the rectangular room ,

• the L-shaped room ,
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• the T-shaped room ,

• the U-shaped room  and

• the S-shaped room .

Clicking on one of the corresponding toolbar symbols will open the template parameter dialog as
mentioned above. Each dialog brings up a figure showing the room shape and its parameters, so the
dialogs are self-explanatory. The option for roof and floor wall creation, which can be found at the
bottom of every room property dialog, is enabled by default. So if only the side walls of the room shall
be created, this option has to be disabled.

Figure 151: The Settings for room type T-Room dialog.

After the specification of the relevant parameters (which will be checked for validity) and after leaving
the properties dialog with the OK button, the room template is created. The current object view will be
displayed and the Drag Mode will be activated.

Roofs

The Indoor Lego roof template  produces different kinds of roofs depending on a roof type selection

in the properties dialog. The span roof which is the default dialog selection simply consists of two roof
walls arranged in a user-defined angle. Span roofs can be symmetrical or asymmetrical. Consequently,
the walls on either side might not have equal height.

Using the radio button in the properties dialog, the roof type can be switched to hipped roof. Hipped
roofs consist of four walls with opposing walls that are equally sized. Therefore, hipped roofs are always
axially symmetric. As a characteristic element hipped roofs contain front and rear walls which are
slightly inclined. The down-tilt of these walls may be specified in the dialog.
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Figure 152: The Settings for roofs dialog.

A mouse click on the OK button closes the dialog, creates the roof template and switches to the Drag
Mode if all user specifications are correct.

Note:  Hipped roofs must fulfil the following conditions:

•

•

•

Stairs and Staircase

The Indoor Lego stairs template  creates a user adjustable number of steps which comprise a flight

of stairs. Leaving the dialog with the OK button will create the stairs template and switch to the Drag
Mode.

Figure 153: The Settings for stairs dialog.
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The staircase template  describes a whole set of stairs building up a staircase. The stairs parameters

can be set using the left side of the staircase properties dialog. For the staircase itself, some additional
parameters are necessary. These parameters can be found on the right side of the properties dialog.
There is also an option for the creation of staircase surrounding walls. By default, no surrounding walls
are created.

Figure 154: The Settings for staircase dialog.

If the dialog is left by pressing the OK button, the staircase template creation process will start.

Note:  This process possibly takes a little time because of the number of walls to be created

After the template creation, the drag mode is activated.

Furnishing

The Indoor Lego Furnishing template  produces typical furniture objects. All these objects are

modeled as cuboids with a certain height, width and depth. The individual elements are automatically
grouped and cannot be modified later.
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Figure 155: The Settings for indoor furnishing dialog.

After leaving the dialog with the OK button, the template is created and the Drag Mode is activated.

Custom Templates
The WallMan indoor Lego feature offers the possibility to define custom templates. As this procedure
is different from the creation of predefined template objects, the handling was adapted. Consequently,
there is no toolbar symbol for custom template creation. The custom template creation process works
as follows:

• At least one wall in the current database must be marked using a corresponding tool.

• Press the right mouse button.

• From the appearing wall, context menu selects Copy to custom template or Cut to custom
template depending on the desired function.

• Process the created template.

Custom templates are treated the same way as all other templates, so they can be processed, inserted
and recombined.

Note:  Custom templates possibly show a deformation when a scaling and / or rotation
operation is applied because of the lacking definition of the template’s principal axes.

Template Recombinations
Templates created with the indoor Lego template feature can be recombined and re-edited if the
database is not closed. As soon as the program ends or the database is closed by the “File” menu, the
template information is lost because they are not saved with the database.

A template recombination is done in a similar manner compared to the custom template creation. If one
single wall or a couple of walls is selected which belongs to a template, the wall context menu enables
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two further options: Recombine Template and Recombine and Copy Template. Note that these
options are only available if each marked wall is a part of the template the first marked wall belongs to.

The Recombine Template option searches for all walls belonging to the selected template and creates
a custom template from these walls. The source walls are deleted. This is the difference between the
Recombine Template option and the Recombine and Copy Template option. The latter does not
delete the source walls but creates a copy as a custom template.

After the recombination of the template, the Drag Mode is activated. Be aware that in the Recombine
Template case the source template walls will be displayed until the recombined template is re-inserted
or the editing process is cancelled with the Esc button.

Short Command Overview

Common Commands

Key / Mouse Button Function

Right Mouse Button Click Inserts template objects into the database.

Esc Cancels template editing and deletes current
template.

Drag Mode Commands

Key / Mouse Button Function

Shift+Ctrl+Cursor Up Increases the 3rd coordinate of the template insertion point by 0.1
m.

Shift+Ctrl+Cursor Down Decreases the 3rd coordinate of the template insertion point by 0.1
m.

Shift+Cursor Up Increases the 3rd coordinate of the template insertion point by 1 m.

Shift+Cursor Down Decreases the 3rd coordinate of the template insertion point by 1 m.

Ctrl+Cursor Up Increases the 3rd coordinate of the template insertion point by 10
m.

Ctrl+Cursor Down Decreases the 3rd coordinate of the template insertion point by 10
m.

Left Mouse Button Click Leaves Drag Mode and switches to Track Mode.
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Track Mode Commands

Key / Mouse Button Function

Shift+Ctrl+Cursor Up Increases the 3rd coordinate of the current view by 0.1 m.

Shift+Ctrl+Cursor Down Decreases the 3rd coordinate of the current view by 0.1 m.

Shift+Cursor Up Increases the 3rd coordinate of the current view by 1 m.

Shift+Cursor Down Decreases the 3rd coordinate of the current view by 1 m.

Ctrl+Cursor Up Increases the 3rd coordinate of the current view by 10 m.

Ctrl+Cursor Down Decreases the 3rd coordinate of the current view by 10 m.

Left Mouse Button Click inside
Bounding Box

No key pressed
Initiates tracking operation.

Shift or Ctrl key pressed
Initiates scaling operation.

Left Mouse Button Double Click
inside Bounding Box

Leaves Track Mode and switches to Rotate Mode.

The following keys show a different behaviour depending on the particular time they are pressed. If at
least one of these keys is pressed BEFORE clicking the left mouse button inside the object’s Bounding
Box, the function explained underneath “Scaling Operation” will be processed. If at least one of these
keys is pressed AFTER clicking the left mouse button inside the Bounding Box, the function explained
underneath “Tracking Operation” is processed.

Key / Mouse Button Function

Ctrl Tracking operation
Only allows horizontal object movement.

Scaling operation
Scales in current object’s 1st coordinate only.

Shift Tracking operation
Only allows vertical object movement.

Scaling operation
Scales in current object’s 2nd coordinate only.
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Key / Mouse Button Function

Ctrl+Shift Tracking operation
Moves object back to primary position.

Scaling operation
Allows free scaling in both object coordinates.

The 3D Template Tool
The 3D Template Tool creates templates from existing database elements selected by “rubber-banding”
a certain area in a 2D view and specifying 3rd coordinate information. After the activation of the tool

by the toolbar symbol  , a rubber band selection can be done by clicking and holding the left mouse

button and moving the mouse. A rectangular box will appear which surrounds the selected area. When
the left mouse button is released, a dialog will be shown in which the 3rd coordinate settings can be
altered. The dialog also provides information about the current view name and the coordinates of the
selected view frame.

Figure 156: The 3D Selection Properties dialog.

The 3rd coordinate range can be altered in this dialog using the predefined settings From Current
Plane To Database Maximum Coordinate or From Current Plane To Database Minimum
Coordinate. These selections will calculate the database maximum 3rd coordinate or the database
minimum 3rd coordinate, respectively. The calculated coordinate values are entered in the
corresponding edit fields underneath the settings From Current Plane In Both Directions and
Custom Coordinates. Choosing one of the latter enables the edit fields and custom values can be
inserted.

When the 3rd coordinate selection is done and the dialog is left using the OK button, WallMan will check
all database walls whether they are positioned inside the selection box or not. Walls lying completely
inside the selection will be copied to a new Custom Template. Walls which show intersections with
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the 3D selection cuboid will be copied and afterwards cut at the cutting edges. These cut walls will be
inserted into the Custom Template mentioned above. This feature, for instance, can be used to copy
one single room including floor and roof walls from an existing database even if the floor or roof plane
covers more than the selected room itself. Another example of using this tool is the reproduction of
whole building parts.

It is important to be aware that the Create 3D Template Tool might cut off parts of the wall objects that
are copied if the area to be copied is not precisely selected.

3.3.4 Miscellaneous

Database Formats

Indoor ASCII Database Format (IDA)
The IDA database-files (Indoor Database ASCII) are in a simple ASCII format.

An IDA file starts with the following header:

* Indoor Database *
* Last changed on: 23. 9.2009  9:41:44 *

Arbitrary number of title or comment lines. The
“*” is optional, no special comment character
required.

BEGIN_MATERIAL
This keyword marks the beginning of the material
data.

* [MATERIAL]  [ID]  [GENERAL]  ["Name
 of Material"]  [Thickness (in cm)] 
  [Filled in Display]   [Color: Red] 
 [Color: Green]  [Color: Blue]

The structure of the material properties belonging
to the visualization settings.

* [MATERIAL]  [ID]  [FREQUENCY] 
 [Frequency (in MHz)]  [Dielectricity
 (relative)]   [Permeability
 (relative)]   [Conductivity (in S/
m)]  [Transmission Loss Vertical (in
 dB)]  [Transmission Loss Horizontal
 (in dB)]  [Reflection Loss (in dB)] 
 [Diffraction Loss incident min (in dB)]
   [Diffraction Loss incident max (in

The structure of the material properties belonging
to the electrical settings for each defined
frequency.
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 dB)]  [Diffraction Loss diffracted (in
 dB)]

MATERIAL 1 GENERAL "Material 1" 10.00000
 1 0 0 0

Sample Code.

MATERIAL 1 FREQUENCY 2000.000 4.000000
 1.000000 0.010000 10.000000 20.000000
 9.000000 8.000000 15.000000 5.000000

END_MATERIAL
This keyword marks the end of the material data

BEGIN_WALLS
This keyword marks the beginning of the building
data.

1
Total number of walls [integer value].

1 4    33.000,   25.500,    0.000   
 75.000,   25.500,    0.000    75.000,  
 57.500,    0.000    33.000,   57.500,  
  0.000  1 0

Sample Code.

END_WALLS

Contrary to the urban databases, no offset can be defined.

WallMan and ProMan return an error if the number of walls is incorrect when the file is processed.

Following the header, there is one line for each wall or subdivision of the described buildings. At the
beginning of the line, an optional comment may be inserted between “*” signs. Unlike in the header,
now the “*” signs are compulsory.

If no subdivisions are defined for a certain wall, then the {Number of Subdivisions} parameter is
set to zero. If there are subdivisions, the parameter {Number of Subdivisions} defines, how many
subdivisions exist for that individual wall.

The subdivisions are then defined exactly like the walls, with only one difference: The {Number of
Subdivisions} parameter is omitted (see example below).

The lines for the defined subdivisions must come directly after the corresponding wall.
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Each line is structured as follows:

* comment *

{Wall Index Number [integer]}
{Number of corners [integer]}
{x-coordinate of corner # 1 [float]} ,
{y-coordinate of corner # 1 [float]} ,
{z-coordinate of corner # 1 [float]}
{x-coordinate of corner # 2 [float]} ,
{y-coordinate of corner # 2 [float]} ,
{z-coordinate of corner # 2 [float]}
              .....
{x-coordinate of corner # n [float]} ,
{y-coordinate of corner # n [float]} ,
{z-coordinate of corner # n [float]}
{Material Index Number [integer]}
{Number of Subdivisions (float)}

At the end of the wall description, the keyword

END_WALLS

marks the end of the file.

This is a sample file containing only one wall with one subdivision:

* Indoor Database *
* Last changed on: 23. 9.2009 10:24:42 *

BEGIN_MATERIAL
* [MATERIAL]  [ID]  [GENERAL]  ["Name of Material"]  [Thickness (in cm)]   [Filled in
 Display]   [Color: Red]  [Color: Green]  [Color: Blue]
* [MATERIAL]  [ID]  [FREQUENCY]  [Frequency (in MHz)]  [Dielectrictity (relative)]
   [Permeability (relative)]   [Conductivity (in S/m)]  [Transmission Loss Vertical
 (in dB)]  [Transmission Loss Horizontal (in dB)]  [Reflection Loss (in dB)] 
 [Diffraction Loss incident min (in dB)]   [Diffraction Loss incident max (in dB)] 
 [Diffraction Loss diffracted (in dB)]

MATERIAL 1 GENERAL "Material 1" 10.00000 1 0 0 0
MATERIAL 1 FREQUENCY 2000.000 4.000000 1.000000 0.010000 10.000000 20.000000 9.000000
 8.000000 15.000000 5.000000
MATERIAL 2 GENERAL "Default Furniture" 1.00000 1 0 180 180
MATERIAL 2 FREQUENCY 2000.000 4.000000 1.000000 0.010000 2.000000 20.000000 0.020000
 8.000000 15.000000 5.000000
MATERIAL 0 GENERAL "Material 2" 10.00000 1 0 128 0
MATERIAL 0 FREQUENCY 2000.000 4.000000 1.000000 0.010000 10.000000 20.000000 9.000000
 8.000000 15.000000 5.000000
END_MATERIAL

 
BEGIN_SHAPE
1
1   12  124.000,   96.550,   10.050   -32.000,   96.550,   10.050   -32.000,  
 96.500,   10.050   -32.050,   96.500,   10.050   -32.050,  -12.500,   10.050   
-32.000,  -12.500,   10.050   -32.000,  -12.550,   10.050   124.000,  -12.550,  
 10.050   124.000,  -12.500,   10.050   124.050,  -12.500,   10.050   124.050,  
 96.500,   10.050   124.000,   96.500,   10.050 
END_SHAPE

BEGIN_WALLS
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6
7 4   -32.000,  -12.500,    0.000   124.000,  -12.500,    0.000   124.000,   96.500, 
   0.000   -32.000,   96.500,    0.000  1 1 
8 4    11.484,   28.452,    0.000    65.032,   28.452,    0.000    65.032,   64.581, 
   0.000    11.484,   64.581,    0.000  1
6 4   -32.000,   96.500,    0.000   -32.000,   96.500,   10.000   -32.000,  -12.500, 
  10.000   -32.000,  -12.500,    0.000  1 0 
5 4   -32.000,   96.500,    0.000   -32.000,   96.500,   10.000   124.000,   96.500, 
  10.000   124.000,   96.500,    0.000  1 2 
10 4    83.890,   96.500,    7.476   109.150,   96.500,    7.476   109.150,   96.500,
    3.514    83.890,   96.500,    3.514  -1
9 4    20.492,   96.500,    8.467    63.583,   96.500,    8.467    63.583,   96.500, 
   3.514    20.492,   96.500,    3.514  0
4 4   124.000,   96.500,    0.000   124.000,   96.500,   10.000   124.000,  -12.500, 
  10.000   124.000,  -12.500,    0.000  1 0 
3 4   -32.000,  -12.500,    0.000   -32.000,  -12.500,   10.000   124.000,  -12.500, 
  10.000   124.000,  -12.500,    0.000  1 0 
2 4   -32.000,  -12.500,   10.000   124.000,  -12.500,   10.000   124.000,   96.500, 
  10.000   -32.000,   96.500,   10.000  1 0 

END_WALLS

Urban ASCII Database Format (ODA)
The ODA database-files (Outdoor ASCII) are in a simple ASCII format. Such files can be generated by
loading an ODB database within WallMan and using the File > Export > ASCII option.

An ODA file starts with a header which is 6 lines long:

* Urban Database
* Last changed on: 11. 3.2013  9:20:26
* Database generated by WallMan
*
*

Five comment lines

SETTINGS 2087 0 5 2399.000 3392.000
 WallMan

General database settings

• Total number of buildings

• Database offset x direction

• Database offset y direction

• Database extension in x direction

• Database extension in y direction

• Info text

The database offset (x and y) is added to the coordinates of the individual buildings. The coordinates of
the individual buildings are thus relative to the given offset and must be positive. The coordinates of the
individual buildings should not exceed 106.
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The database extension is to be understood relatively to the lower-left corner of the database, it is not
the upper-right corner in absolute coordinates, but it is the vector pointing from the lower-left corner to
the upper-right corner.

It is not recommended to delete any line, no matter if this affects the pre-processing or not. WallMan
returns an error if the number of buildings is incorrect when processing the file.

Following the header, material definitions are listed as described below:

BEGIN_MATERIAL
This keyword marks the beginning of the material
data.

* [MATERIAL]  [ID]  [GENERAL]  ["Name
 of Material"]  [Thickness (in cm)] 
  [Filled in Display]   [Color: Red] 
 [Color: Green]  [Color: Blue]

The structure of the material properties belonging
to the visualization settings.

* [MATERIAL]  [ID]  [FREQUENCY] 
 [Frequency (in MHz)]  [Dielectricity
 (relative)]   [Permeability
 (relative)]   [Conductivity (in S/
m)]  [Transmission Loss Vertical (in
 dB)]  [Transmission Loss Horizontal
 (in dB)]  [Reflection Loss (in dB)] 
 [Diffraction Loss incident min (in dB)]
   [Diffraction Loss incident max (in

The structure of the material properties belonging
to the electrical settings for each defined
frequency.
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 dB)]  [Diffraction Loss diffracted (in
 dB)]

MATERIAL 1 GENERAL "Material 1" 10.00000
 1 0 0 0

Sample Code.

MATERIAL 1 FREQUENCY 2000.000 4.000000
 1.000000 0.010000 10.000000 20.000000
 9.000000 8.000000 15.000000 5.000000

END_MATERIAL
This keyword marks the end of the material data.

BEGIN_BUILDINGS
This keyword marks the start of the building data.

{Building Index Number [integer]}
{Number of corners [integer]}
{x-coordinate of corner # 1 [float]},
{y-coordinate of corner # 1 [float]}
{x-coordinate of corner # 2 [float]},
{y-coordinate of corner # 2 [float]}
              .....
{x-coordinate of corner # n [float]},
{y-coordinate of corner # n [float]}
{Building height [float]}
{Material identifier [integer]}
{Type of building [integer]}

Note:  Each building is described
by one line. In this description, the
line break has been inserted for
readability. Between two buildings,
there must be a line break, but there
must be none in one building line.

END_BUILDINGS
This keyword marks the end of the building data.

Description of the Building Parameters

Table 12: Building Parameters

Parameter Type Description

Building Index
Number

Index Number which allows to identify buildings, for
example, in a prediction.

Number of corners Index Number of corners of this building. Must be at
least 3.
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Parameter Type Description

x-coordinate of
corner # n

Geometric

y-coordinate of
corner # n

Geometric

Coordinates [m] of each individual corner of the
building.

The values must be positive. The offset has to be
chosen accordingly.

Note:  The orientation of the corners should be counter-clockwise.

Building height Geometric Uniform building height [m] (in z-direction).

Material identifier Index Code describing the material defined for this
building.

Type of building Index Code describing the type of this building
(standard, virtual, vegetation or courtyard/
tower).

Topographical ASCII Database Format (TDA)
Besides the binary format WallMan also supports an open ASCII data format. Each line of the ASCII file
describes a pixel of the elevation data with the following syntax :

East (Longitude) North (Latitude) Elevation (Meter)

Figure 157: Example of an ASCII topographical database.

East and North can be given either in UTM or geodetic coordinates. The elevation is always defined in
meters (or must be converted with a factor to meters). The sequence of the pixels is not relevant (can
be in random order).

Decimal values are possible for all values in the file. These ASCII databases can be converted to
WinProp’s data format via the menu File > Convert Topo Database > ASCII Line format.
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Figure 158: Conversion of ASCII topographical databases to the WinProp format.

AutoCAD® Drawing Databases (DWG / DXF)
AutoCAD® drawing databases in the .dwg and .dxf format can be converted to WinProp building
databases. However, not all object categories available in AutoCAD®, are supported by the converter.
The following list shows the AutoCAD® object categories supported by the converter module.

For the conversion of AutoCAD® databases to the WinProp format the following object categories are
supported:

Table 13: Supported object categories

AutoCAD® Object Categories Indoor Mode Urban Mode Overlay Mode

Proxy Objects 2)

2D Polyline -

2D Solid

3D Box - - -

3D Face -

3D Mesh - - -
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AutoCAD® Object Categories Indoor Mode Urban Mode Overlay Mode

3D Polyline

3D Solid

3D Sphere - - -

3D Surface - - -

Arc -

Arc aligned text - - -

Circle

Donut - - -

Ellipse

Hatch -

Line -

MLine - - -

MText - - -

MInsertBlock - - -

PolyFaceMesh -

Polygone

PolygonMesh - - -

Polyline

Text - -
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Note:

• The AutoCAD® objects must have a closed form, to be converted to urban buildings.

• The current version supports polyline and polygon proxy objects.

• The AutoCAD® objects must have a height value assigned for a correct conversion.
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3.4 Materials

3.4.1 Introduction
When entering buildings in an urban database or building objects (walls) in an indoor database using
the WallMan program from the WinProp software suite, material properties can be assigned to the
buildings walls.

The empirical reflection model and diffraction model, that can be used in the ray-tracing propagation
models within ProMan for the computation of the reflection and diffraction, uses empirical material
parameters, the reflection loss (attenuation of the reflected wave in comparison to the incident wave)
and the transmission loss (loss that an electromagnetic wave experiences when penetrating a wall).

Among the WinProp examples in the installation directory is a Microsoft Excel spreadsheet[10] with
material properties. This material table (the aforementioned Excel spreadsheet) contains a collection
of physical material properties,  and . It allows the computation of the mentioned empirical
parameters from the physical values, depending on the frequency, the thickness and the roughness of
the material.

The physical parameters were extracted from different sources. These sources are stated in the table.

3.4.2 Structure and Usage of the Material Table
At the left of the table, in the main sheet Values, the material names and their description are shown
in English and German.

Column E shows the source where the physical material parameters were extracted from. The physical
material values (  and ) are basically also frequency dependent. Therefore, column F shows at which
frequency the values in columns H and I (which were taken from the sources) were determined by the
sources.

The following values can be specified by the user in the table:

• Frequency [MHz]

• Thickness of the material / wall [m]

• Roughness of the surface

The frequency can be entered in cell G3 and will automatically be copied to column G. Alternatively,
the user can also enter specific values in the individual cells of column G, as for the computation the
frequency value is read from this column.

The thickness of the materials is set to reasonable default values. As the materials are completely
different, the thicknesses are defined for each material individually (unlike the frequency).

10. Altair\2022.1\help\winprop\examples\ExampleGuide_models\Example-A03-
Database_Materials.zip
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Also, the roughness of the material is defined individually. All values are set to 1.0 by default which
corresponds to a smooth surface.

After having entered the values, the attenuation of the reflected wave in comparison to the incident
wave (reflection loss) and the loss that an electromagnetic wave experiences when penetrating a wall
(transmission loss) can be read from columns M and R. All values are given in [dB].

These values can then be entered in the Edit Material dialog in WallMan.

3.4.3 Further Information

Figure 159: The different symbols that are used.

The physical parameters  and  correspond to the following equation, where represents the
conductivity of the material.

(1)

Definition of Roughness
The roughness  of the surface naturally influences the reflection loss in the aforementioned

Excel spreadsheet[11]. The parameter , derived from roughness, is used to correct the reflection

coefficient.[12][13]

11. Altair\2022.1\help\winprop\examples\ExampleGuide_models\Example-A03-
Database_Materials.zip

12. G. Wölfle: Adaptive Modelle für die Funknetzplanung und zur Berechnung der Empfangsqualität in
Gebäuden. (Adaptive Propagation Models for the Planning of Wireless Communication Networks and
for the Computation of the Reception Quality inside Buildings). PhD Thesis, University of Stuttgart,
published by Shaker Verlag, 2000.

13. K.A. Chamberlain and R. J. Leubbers: An Evaluation of Longley-Rice and GTD Propagation Models.
IEEE transactions on Antennas and Propagation, vol. 30, no. 6, pp. 1093-1098, Nov. 1982.
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The definition of the roughness of the surface is based on the standard deviation of the normally
distributed surface roughness :

(2)

with

(3)

Computation of the Empirical Values

Reflection Loss
The field strength  of the reflected wave is computed using the reflection factor  and the field

strength  of the incident wave[14]:

(4)

The reflection factor  is computed from the transmission factor :

(5)

Additionally, the roughness is considered by:

(6)

A smooth surface has a value of .

The value of  is shown in column L in the table.

The reflection loss is then computed as follows:

(7)

Transmission Loss
The field strength  of the transmitted wave is computed using the transmission factors and the field
strength  of the incident wave:

(8)

14. G. Wölfle: Adaptive Modelle für die Funknetzplanung und zur Berechnung der Empfangsqualität in
Gebäuden. (Adaptive Propagation Models for the Planning of Wireless Communication Networks and
for the Computation of the Reception Quality inside Buildings). PhD Thesis, University of Stuttgart,
published by Shaker Verlag, 2000.
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 and  are caused by the transition from air to the material and the other way round, whereas 
is caused when the wave penetrates through the material. The values are shown in columns N, O and P

in the table. Additionally, column Q shows the product , which is the contribution of the losses
due to the transition into the material and the transition back to air.

The values are computed as follows[15]:

(9)

(10)

(11)

The transmission loss is then computed as follows:

(12)

15. O. Michler and M. Strey: DAB- Indoor- Versorgung im L- Band. Eine Studie im Auftrag der
Sächsischen Landesanstalt für privaten Rundfunk und neue Medien (DAB Indoor Coverage in the L-
Band). April 1998
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4 TuMan

The TuMan tool enables you to generate and modify tunnel scenarios.

This chapter covers the following:

• 4.1 Introduction to TuMan  (p. 183)

• 4.2 File Types and Extensions  (p. 184)

• 4.3 Project Configuration  (p. 185)

• 4.4 Tunnel Geometry  (p. 187)

• 4.5 Modeling a Tunnel  (p. 192)

• 4.6 Toolbars  (p. 203)
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4.1 Introduction to TuMan
TuMan is a graphical user interface to enter the geometry of a tunnel. It also provides the verification
of a geometry. A valid tunnel geometry can be used to predict the electromagnetic wave propagation
inside the tunnel.

TuMan is very similar to other Windows-based computer-aided design programs. Therefore it offers all
standard editing operations like Copy, Cut, Paste, Undo and Redo. In addition, many special features for
the tunnel geometry are integrated. All tools and commands are available by selecting menu items or
clicking toolbar buttons. Frequently used functions can be accessed by pressing keyboard shortcuts.

Because of the complex architecture of tunnels, TuMan allows opening three different views of your
drawing. Top View, Side View and Cross Section View.

You can save your document and program configuration, using the TuMan specific file format, at any
time. After successful verification of the tunnel geometry, you can export this valid tunnel geometry
using the WinProp database file format.

TuMan is a multiple document interface application, which means that you can edit several documents
at the same time.
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4.2 File Types and Extensions
All file types and file extensions related to the TuMan application are listed in the table below.

File Extension File Content File Type

.bmp, .jpg, .png, .gif, .tif Image files binary

.csb Cross section geometry file binary

.idb WinProp indoor database (generated during binary
export of tunnel geometry)

binary

.mcb Global material database binary

.tub TuMan document file with tunnel geometry and
program configuration

binary

.ida WinProp indoor database (generated during ASCII
export of tunnel geometry)

ascii

.sla Shape list for import and export of tunnel track
elements

ascii

.txt Text document with additional information ascii
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4.3 Project Configuration

4.3.1 Auto Scroll
If this mode is active, the screen scrolls during dragging operations automatically as soon as the mouse
cursor is near the window border and displays the drawing contents beyond.

This feature can be turned on by activating the corresponding check box in the Edit > Settings dialog.

Availability
• Dragging

• Top and Side View Settings

• Cross Section View Settings

4.3.2 Catch Modes
TuMan offers various catch modes to find the position of construction points precisely. There are three
modes you can activate using either the Draw Toolbar or the Settings dialog of the corresponding
view:

Priority Mode

1 Catch Endpoint

2 Catch Intersection

3 Catch Grid Point

Availability
• Toolbar

• Dialog: View Settings

4.3.3 Drag Mode
Whenever you have not finished an editing operation the drag mode is active. For example, if you move
objects or if you have set the first point of a line and now moving the cursor to the second point. You
may abort the drag mode at any time by pressing the Esc key.

Various zoom functions (Zoom In, Zoom Out and Fit to Screen command) and the auto scroll mode
makes it easy to navigate through the drawing while drag mode is active.
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4.3.4 How to Use Background Images
TuMan offers a feature to display any image file (.bmp, .jpg, .png, .gif, .tif) on the screen while
entering a database. This is ideal when you have constructional plans of the tunnel you want to enter.
Just load the bitmap using the option Bitmap > Import Bitmap from Edit menu. 

Then you have to scale the bitmap in order to get the right dimensions as you draw your objects. This is
done by selecting the Scale Bitmap command.

You may also move your bitmap to the right place in your database by selecting the Move Bitmap
command. The modeled objects can be selected at any time by hiding the bitmap using the Show
Bitmap switch.

Background Images can only be used in Top View and Cross Section View.

4.3.5 Project Settings

Settings
The configuration of a TuMan tunnel project can be done via Settings dialog which can be opened from
the Edit menu.

Figure 160: The Settings dialog.

• Top and side view

• Cross section view

• Edit material database

• Geometry export

All settings can be set to their default values by pressing the Default button.
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4.4 Tunnel Geometry
The space curve of the tunnel axis consists of a sequence of track segments. In TuMan each track
segment is approximated either by a three-dimensional line or a three-dimensional spline. A line is
defined by two nodes (3D coordinates). At most four interpolation points (nodes) define a spline. This
method allows a handy and flexible input of the tunnel axis by positioning the interpolation points.

A tunnel often has several kinds of cross-sections. For example, a rectangular cross-section near the
portals and a mouth-shaped cross-section inside. With TuMan you can draw cross-section geometries
of arbitrary shape. To generate a valid tunnel, you must assign a cross-section geometry to every track
segment. 

A valid tunnel geometry of every single track must match the following conditions:

The space curve of the tunnel axis must be valid. Every interpolation point has to be connected by a
single non-closed curve without intersections.

A valid cross-section geometry has to be assigned to all track segments.

4.4.1 Input Track

Input of Tunnel Axis
The space curve of the tunnel axis is defined by nodes, which are connected with three-dimensional
lines or spline curves. A tunnel track consists of two portal nodes which define the beginning and the
end of the track and an arbitrary number of “standard” nodes in between. Therefore, it is convenient to
start the drawing by positioning the portal nodes and all further interpolation points with the Node tool
in the Top View of the document. The z-coordinate (height) of the nodes can be defined in the Side
View or by opening the Object Properties dialog, where the height can be entered directly. An ASCII
import functionality offers the possibility to import node positions from a list and automatically generate
the tunnel track by connecting the listed nodes with splines.

All nodes are connected with their neighbours by using either the Line tool or the Spline tool. This
defines the space curve of the tunnel axis as a sequence of track segments (lines or splines). The Edit
tool can be used to move a node if the interpolated curve does not fit the original course. While moving
a connected node, TuMan recalculates and displays the new course in real time. Better results can be
achieved if the nodes have approximately the same distance to both neighbours.

Finally, the command Assign Cross Section Geometries have to be used for all track segments. If
you have not drawn cross-section geometries yet, continue reading Input Cross Section Geometry.

TuMan offers the possibility to design multiple tunnel tracks within a single document. These tracks can
be modeled independently of each other as only one track is active at a time. Different tracks can be
connected to each other using the Junction tool. The Track List gives an overview of all tunnel tracks
within the current project and offers the possibility to mange the tracks of the project. 
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4.4.2 Track List
The Track List gives an overview of all available tunnel tracks within the current project.

The user has the possibility to manage the listed tracks by using the buttons on the right side of the
dialog:

Figure 161: The Available track geometries dialog.

Edit
Opens another dialog where the elements of the selected track are listed. These elements can
be edited by double-clicking on a list item. The user also has the possibility to import and export
tunnel tracks to an ASCII format here. 

Rename
Renames the selected tunnel track. A dialog appears to enter the new name, which must differ
from the existing ones.

New
Creates a new track geometry. A dialog appears to name the new track.

Delete
Removes the selected item from the list and deletes the tunnel track from the project, if you
confirm.

Warning:  You cannot undo this action.

Close
Closes the dialog.

To open the Track List dialog, use the Track List command in the Edit menu or press F9. 

4.4.3 Input Cross-Section
To create a new cross-section geometry, choose New from the Cross Section Selection box in the View
toolbar. After entering the cross-section's name, TuMan displays an empty drawing area in the Cross
Section View.
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You may first input the outline of the tunnel tube cross-section. Make sure the “Tunnel Wall” item is
selected in the Group Selection list box, which means, that the next objects you draw will belong to
the Tunnel Wall group. Then use the Line tool, Arc tool or Circle tool to input the outline of the
cross-section. The Catch modes may help you, to find the position of grid points, line endpoints or
intersections more precisely.

You can break, shorten or lengthen previously drawn lines with the Break tool, Trim tool or Stretch
tool. Right-clicking on an object provides access to the Properties command in the context menu.
Select this item to open the Object Properties dialog, where you can modify most of the object's
parameters (for example, material properties). Enable the Show Relative Position option in the View
Settings dialog, if you want TuMan to display the relative position to your previous mouse click while
dragging an object.

Select Prediction Plane from the Group Selection list box, if you want to define prediction planes in
the tunnel. These planes will be exported to the WinProp database and are needed for calculating wave
propagation and radio network planning on arbitrary prediction planes.

Further segment groups are available for modeling more details within a cross-section.

The Cross Section List can be used to save or load cross-section geometries independent of the tunnel
document. There you will find other commands for managing several cross-section geometries as well.

4.4.4 Cross-Section
The cross-section geometry contains the outline of the tunnel tube cross-section. Additionally, you can
define prediction planes inside the tunnel tube cross-section for wave propagation and radio network
planning predictions with ProMan. 

The cross-section geometry is valid if all outlines are valid.

4.4.5 Cross Section List
The cross section list gives an overview of all available cross section geometries within the current
project. The user has the possibility to manage the listed cross sections by using the buttons on the
right side of the dialog:
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Figure 162: The Available cross section geometries dialog.

Edit
Closes the dialog and activates the Cross Section View of the selected cross section geometry.

New
Creates a new cross section geometry. A dialog appears to name the new cross section.

Copy to
Copies the contents of the highlighted cross section geometry into another. TuMan displays a
Select Cross Section dialog to select the target.

Load
Loads a cross section geometry from disk.

Save
Saves the selected cross section geometry to disk. A Save As dialog will be displayed to name
the file.

Rename
Renames the selected cross section geometry. A dialog appears to enter the new name, which
must differ from the existing ones.

Delete
Removes the selected item from the list and deletes the cross section geometry, if you confirm.

Warning:  This action cannot be undone.

Close
Closes the dialog.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
4 TuMan p.191

To open the Cross Section List dialog, use the Cross Section List command in the Edit menu or
press F8 key.
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4.5 Modeling a Tunnel

4.5.1 Tunnel Track

Define Side View Tool
Use the Define side view tool to define the side view direction.

The Define side view tool is only available if the  Top view tool is enabled.

Set the X-Y-position of the left edge of the side view window with the first mouse click and the right
edge with the second click. TuMan calculates the zoom factor and displays the new projection of the
tunnel axis in the side view window. TuMan also plots a projection of the side view direction in the top
view window if the corresponding option in the View Settings dialog is set.

Node Tool
Use the Node tool to add new node objects to the database.

Once the  Node tool is selected, click with the left mouse button where you want the node to appear.
You can modify the Z-coordinate of the node in the Object Properties dialog or by moving the node in
the side view window using the Edit tool. There are two types of nodes in TuMan:

1. Portal nodes

2. Standard nodes

3D Line Tool
Use the 3D Line tool to connect two nodes with a straight line.

The 3D Line tool is only available if the  Top view tool is enabled.

Activate the tool and click with the left mouse button to define the starting point of the line. Drag the
line to the second node and save it by clicking once again. The new line belongs to the currently active
track. To modify the object parameters afterwards use the Object Properties dialog.

Spline Tool
Use the Spline tool to connect two nodes with a three-dimensional spline curve.

The Spline tool is only available in the  Top view tool or  Side view tool is enabled.

Click with the left mouse button on a node to make this node the starting point of the connection. Left-
clicking on another node determines the ending point of the connection. TuMan will calculate the spline
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curve between these nodes considering other connections to the specified nodes. The new spline curve
is a segment of the tunnel axis. See Cross-Section to assign a cross-section geometry to the segment.

Note:  A node can not have more than two connections to other nodes.

Junction Tool
Use the Junction tool to connect two tracks with a junction.

The Junction tool is only available if the  Top view tool is enabled.

Click with your left mouse button on a node to create the starting point of the junction. After the
definition of the first point, a dialog opens where the second track has to be chosen. By selecting the
second track from the list, TuMan deactivates the first track and activates the selected track. By left-
clicking on an arbitrary node of the second track, TuMan connects the selected tracks with a junction.

Note:  Tracks can be only connected if the geometry of all tracks has been validated.

4.5.2 Cross-Section

Line Tool
Use the Line tool to draw a straight line.

The Line tool is only available if the  Cross section view tool is enabled.

To draw a straight line, activate the tool and click with the left mouse button to define the starting point
of the line. Drag the line to the second point and save it by clicking once again. The new line belongs to
the group selected in the Select group drop-down list. To modify the object parameters afterwards use
the Object Properties dialog.

Arc Tool
Use the Arc tool to create a circular arc.

The Arc tool is only available if the  Cross section view tool is enabled.

Activate the tool then the first mouse click will define the centre point of the arc. Another click specifies
the radius of the arc and its starting point. Move the cursor counter-clockwise to draw the arc, then click
the mouse button to define the ending angle.

The new arc belongs to the group selected in the Select group drop-down list. To modify the object
parameters afterwards use the Object Properties dialog.
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Tip:  Various catch modes can help you get the exact position of line endpoints,
intersections and grid points while drawing objects.

Circle Tool
Use the circle tool to create a circle.

The Circle tool is only available if the  Cross section view tool is enabled.

The circle tool creates a circle by defining its centre and a point on its perimeter. To draw a circle
activate the tool, define a point for the centre of the circle by left-clicking on the mouse and finally
define a point on the perimeter of the circle. The new circle belongs to the group selected in the Select
group drop-down list. To modify the object parameters afterwards use the Object Properties dialog.

Tip:  Various catch modes can help you get the exact position of line endpoints,
intersections and grid points while drawing objects.

Break Tool
Use the break tool to break a segment out of a line object.

The Break tool is only available if the  Cross section view tool is enabled.

You can modify both straight and arched lines with this tool by following these steps:

1. Activate the Break tool.

2. Click on a line-object that you want to edit. TuMan marks this object and a cross-hair marking
appears on the line.

Figure 163: Breaking a line with the Break tool - cross-hair marking for the 1st break point.

3. Move the mouse to shift the marking on the line.

Note:  If another line object near the mouse cursor or its extension intersects the
marked line, then the cross-hair marking is positioned at the closest intersection point
of these two lines.

4. Click to define the first breaking point. TuMan now fixes the marking at this breaking point and
displays the second marking.
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Figure 164: Breaking a line with the Break tool - cross-hair marking for the 2nd break point.

Repeat step 4 to define the second breaking point. TuMan erases the line segment between the two
breaking points.

Note:  Circles are broken counter-clockwise, starting from the first breaking point to the
second.

Figure 165: Breaking a line with the Break tool - a section of line erased.

Trim Tool
Use the Trim tool to shorten a line.

The Trim tool is only available if the  Cross section view tool is enabled.

Both straight and arched lines can be shortened by following these steps:

1. Activate the trim tool.

2. Click on a line at a position near the endpoint that you want to modify. The line will be marked and
two cross-hair markings will appear. One is fixed at the end of the line, the other one shows the
perpendicular point of the mouse position on the line object.

Figure 166: Breaking a line with the trim tool - cross-hair markings showing the line section to be erased.

3. Moving the mouse lets the perpendicular point shift on the line. If another line object near the
mouse cursor or its extension intersects the marked line, the second cross-hair marking will be
positioned at the closest intersection point of these two lines which is not at the perpendicular
point. Click again to fix the second marking. TuMan erases the line segment between the two
markings.
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Figure 167: Breaking a line with the trim tool - section of line erased.

Stretch Tool
Use the Stretch tool to lengthen a line.

The Stretch tool is only available if the  Cross section view tool is enabled.

Both straight and arched lines can be stretched by following these steps:

1. Activate the stretch tool.

2. Click on a line at a position near the endpoint that you want to modify. The line will be marked and
two cross-hair markings will appear. One is fixed at the end of the line, the other one shows the
perpendicular point of the mouse position on the extension of the line object.

Figure 168: Stretching a line with the stretch tool - markings showing the intended extension of the line.

3. Move the mouse to shift the perpendicular point on the extension of the line.

Note:  If another line object near the mouse cursor or its extension intersects the
marked line, the second cross-hair marking is positioned at the closest intersection
point of these two lines not at the perpendicular point.

Figure 169: Stretching a line with the stretch tool - markings showing the intended extension of the line.

Segment Groups
Assign segments to cross-section segment groups.

Each cross-section in TuMan consists of one or more cross-section segments. A segment is a basic
geometry element, such as a line, an arc or a circle. Each segment has to be assigned to a cross-section
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segment group. This can be done either directly via the Select group drop-down list in the toolbar
before drawing the element or via the Object Properties dialog of a selected cross-section element.

Figure 170: Cross section segment groups.

Tunnel Wall
In order to define a valid cross-section, a single closed curve without intersections has to be
defined with the segment group Tunnel Wall.

Prediction Plane
Arbitrary prediction planes to be used for wave propagation and radio network planning
simulations with ProMan can be specified with this type.

Leaky Feeder Cable
The position of radiating cables within the cross-section can be modeled using the arc tool. During
the export of the tunnel database, TuMan generates an ASCII file for each defined leaky feeder
cable containing the coordinates of the cables along the tunnel. These files can be imported in
ProMan for the definition of corresponding transmitter cables.

Additional Data (Closed) / Additional Data
Additional objects within the cross-section (such as fans, traffic signs, and so forth) can be
modeled with additional segment groups. If “Additional Data x (Closed)” is assigned to an
element, TuMan creates a vertical completion wall at the beginning and at the end of the
tunnel track as well as at cross-section changes as far as the cross-section is assigned to the
corresponding tunnel track segments.

Drawing colours of the segment groups can be changed in the Settings dialog of the Cross section
view.

Tip:  Enable / disable the export of prediction planes, as well as the export of additional
data, on the Geometry Export Settings dialog.
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Outline
The cross-section of the tunnel tube and all vehicle areas are defined by their outline geometry.

You can use straight lines, circular arcs and circles to draw these outlines. A valid outline must consist
of a single closed curve without intersections. Various catch modes may help you drawing an unbroken
outline.

Figure 171: Examples of valid outlines (top row) and invalid outlines (bottom row).

4.5.3 Edit Tool
In the edit mode, you can mark objects by clicking on the object using the left mouse button.

If you press and hold down the Ctrl key while doing this, you can mark multiple objects without
unmarking the other objects.

With the Ctrl key held down, clicking on an object already marked lets you unmark this object.

To unmark all objects just click somewhere in the free space between objects.

With this tool, you can also mark all objects on the screen that are completely inside a specified
rectangle. Just click with your left mouse button where you want the rectangle's first corner to appear.
Then you can drag the rectangle to the desired size and save it by pressing the left mouse button again.
All objects appearing inside this rectangle in the current view plane will be marked.

Once you have marked one or a couple of objects, the cursor changes to a four-way arrow as soon as
it gets close to an object's line. With this cursor displayed you may press down the left mouse button
and drag all marked objects just where you want them to be and drop them there by pressing the left
mouse button again.

You can also cut, copy, paste and delete all marked objects by using the corresponding shortcuts or
commands in the Edit menu or by clicking the items in the Draw toolbar.

4.5.4 Mouse Pan and Zoom Tool
This tool is helpful when you need to navigate quickly through a database.

Once the tool is selected, you can hold down the left mouse button and scroll by moving your mouse.
Additionally, you can use this tool to change the zoom factor by holding down the right mouse button
and moving the mouse cursor up and down.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
4 TuMan p.199

4.5.5 Zoom Window Tool
The Zoom Window tool enables you to select a rectangular area of the screen and zoom into a view of
that area.

Click the left mouse button to specify one corner of the zoom window. Move the mouse cursor to
the point where you want to place the diagonally opposite corner of the zoom window so that the
zoom window encompasses the area that you want to view. Click to specify the opposite corner of the
window. TuMan will immediately zoom in on the area that the zoom window encloses.

Note:  As the dimensions of the zoom rectangle will not exactly be proportional to the
screen, TuMan selects the closest view based on the zoom rectangle you define.

4.5.6 Object Properties
In TuMan each object has its own properties. They can be viewed and changed individually in the
Object Properties dialog. To bring up this dialog move your cursor to the desired object, open the
right-click context menu and click Properties. The Object Properties dialog displays information
depending on the currently selected view.

• Top view and side view

Figure 172: The Object Properties dialog.

• Object
The object field contains the object type and its number. You cannot modify this items.
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• Parameter
The cross section assigned to the track segment can be changed here. In case the selected
object is a node, this field will be empty.

• Resolution of Exported Database
In case the tunnel database is exported to the WinProp database format, the elements will be
discretised. The maximum longitudinal and arc segment resolution of the exported database
can be specified here.

Note:  Specify the export resolutions for multiple track elements using the
context menu of the Top view and the Side view.

• Comment
The comment strings of splines, lines and portal nodes can not be changed. They always
show the name of the assigned cross section or the name of the tunnel portal, respectively.

• Geometry Parameter
The geometry parameter field provides access to the geometric object parameters. Select a
list item and click the Change button to modify the parameter.

Note:  Some parameters cannot be changed.

For example, you cannot modify the interpolation points of a spline. Change the
position of the nodes at the interpolation points instead. TuMan will recalculate the
spline.

• Cross section view
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Figure 173: The Object Properties dialog.

• Object
The object field contains the object type and its number. You cannot modify these items.

• Parameter
The group assigned to the cross section element can be changed here. An element can be
defined to be a hole by selecting the hole option. This is can be necessary for defining tunnel
with open sections or tunnel junctions.

• Material Properties
A material has to be assigned to each object of a cross section. The material properties
corresponding to a selected material can be displayed and edited via Show button. The
material catalogue used within the project can be displayed and edited via the Edit button.

• Comment
The geometry parameter field provides access to the geometric object parameters. Select a
list item and click Change to modify the parameter.

Note:

Some parameters cannot be changed. For example, you cannot modify the
interpolation points of a spline. (Change the position of the nodes at the
interpolation points instead. TuMan recalculates the spline.)
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• Geometry Parameter
The geometry parameter field provides access to the geometric object parameters. Select a
list item and click Change to modify the parameter.

Note:  Some parameters cannot be changed. For example, you cannot modify
the interpolation points of a spline. (Change the position of the nodes at the
interpolation points instead. TuMan recalculates the spline.)

4.5.7 Marked Objects
Objects can be marked with the Edit tool. Marked objects are displayed in red color. You can move, cut,
copy or delete marked objects.
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4.6 Toolbars
• View toolbar

• Draw toolbar

• Status bar

4.6.1 Draw Toolbar
Use this switch to display and hide the Draw Toolbar, which includes buttons for some of the most
common drawing commands in TuMan.

A check mark appears next to the menu item when the Draw Toolbar is displayed.

Availability
• Menu: View > Draw Toolbar

4.6.2 Status Bar
Use this command to display and hide the Status Bar, which describes the action to be executed by the
selected menu item or depressed toolbar button, and displays the coordinate positions.

A check mark appears next to the menu item when the Status Bar is displayed.

Availability
• Menu: View > Status Bar

4.6.3 View Toolbar
Use this switch to display and hide the View Toolbar, which includes buttons for some of the most
common commands in TuMan, such as New and Open.

A check mark appears next to the menu item when the View Toolbar is displayed.

Availability
• Menu: View > View Toolbar
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5 AMan

Use AMan to generate, edit and analyze a single antenna. Superimpose multiple antennas radiating
similar signals to determine the actual antenna pattern while taking into consideration the local
environment.

This chapter covers the following:

• 5.1 Introduction  (p. 205)

• 5.2 Multiple Antenna Scenario Configuration (MASC)  (p. 243)

• 5.3 Using AMan  (p. 284)
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5.1 Introduction
Radio network planning tools rely on accurate wave propagation models to predict the path loss
between two arbitrary points.

Besides the shielding of objects and multipath propagation (both considered in the propagation models)
the antenna patterns of the antennas used for the communication link influence the actual path loss.
Therefore, the antenna pattern must be described accurately within the radio network planning tool.

The tool AMan handles antenna patterns with a convenient Windows GUI. The most important features
of AMan are:

• Graphical display of antenna patterns (horizontal or vertical plane)

• 3D Display of antenna patterns

• Conversion of commercially available antenna file formats (for example, .msi, .pln)

• Conversion from 2x2D pattern (horizontal and vertical) to 3D pattern

• Graphical editor to define manually vertical and horizontal antenna patterns (drawn with a mouse
while having a scanned bitmap of the pattern as a background image)

Besides these important features, AMan contains the module MASC (multiple antenna scenario
configuration). This module is important if the influence of the local environment and the mounting
of the antenna are considered and / or if multiple antennas are combined to radiate the same signal,
and you want to see the radiation pattern of the configuration to include this actual pattern in the radio
network planning process and tool.

MASC allows you to:

• Compute the resulting antenna pattern if different single antennas are combined to multiple-
antenna configurations (including individual phase shifters and power splitters)

• Consider the influence of the mounting of the antenna (masts, arms, tubes, radomes) on the actual
antenna radiation pattern

As AMan can save the computed patterns in different file formats, it is not limited to the WinProp radio
network planning suite. It can also be used for many radio network planning tools as most of the tools
can read the .msi antenna pattern file format.

5.1.1 Antenna Pattern Basics
The radiation pattern of an antenna is a graphical representation or mathematical function that
indicates the angular dependence of radiation from the antenna.

Isotropic Radiator
An isotropic radiator is an ideal (theoretical) antenna operating without losses and having equal
radiation in all directions.

This antenna is not available in the real world – but is used as a reference for all real-world antenna
patterns.
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The power density  radiated from an isotropic radiator is homogeneously distributed over a spherical
surface (with the radiator in the center of the spherical surface). With the power  fed to the antenna,
this leads to the following power density  in a distance :

(13)

Directional Characteristic of Antennas
Commercial antennas do not radiate the same power density in all directions (in contrast to the
isotropic radiator). There are always directions with higher power density and others with smaller power
density.

The direction with the highest power density is called the main direction. The antenna pattern describes
the dependency of the radiation on the direction. It shows amplitude, phase and polarization assuming
far field conditions (far away from the antenna itself). Spherical coordinates ,  and  are used to
describe the antenna pattern. As the distance  is not relevant in the far field, the antenna pattern itself
is a function of the angles  and .

The pattern of real antennas depends additionally on the frequency. So, for different frequencies,
different patterns must be used.

Often the radiation of the antenna is only measured in the horizontal and in the vertical plane. This
reduces the effort and describes the antenna for most applications. Only accurate wave propagation
models (like ray-optical models) will benefit from 3D antenna patterns.

Table 14: Visualisation of antenna pattern (Kathrein K739856, www.kathrein.com).

Vertical Pattern Horizontal Pattern 3D Representation
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Table 15: Visualisation of antenna pattern (Kathrein K731620x7, www.kathrein.com).

Vertical Pattern Horizontal Pattern 3D Representation

As the power density is proportional to the electric field strength , often the electric field strength 
is used to describe the antenna pattern. Usually, the pattern is normalized to its maximum value, for
example:

(14)

Since, in the general case, elliptical polarization is present in the far field, both antenna patterns of

the orthogonal polarization,  and , are needed for the description of the directional

characteristics of the antenna.  and  is generally normalized on the maximum value 
of the highest component:

(15)

(16)

(17)
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Gain, Directivity and Other Parameters
Antenna patterns are described by parameters such as gain, directivity, pattern lobes, half-widths,
equivalent radiation angle, and effective area.

Directivity
Directivity is the ratio of the radiation intensity in a given direction from the antenna in relation to the
radiation intensity averaged over all directions.

If the main direction of radiation is known, the directivity  can be calculated for each antenna pattern
with the following equation:

(18)

 indicates the maximum radiated power density and  indicates the power density radiated by the
isotropic radiator.

Figure 174: Graphical representation of directivity.

It is also possible to determine  from the directional characteristic with:

(19)

If the antenna pattern consists of a discrete number of values, the integrals in the equations must be
substituted with a summation with increments  and  :

(20)

Often the directivity of an antenna is given in dB. The logarithmic value  in dB can be obtained from
the linear value  of the directivity with the following equation:

(21)
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Gain
In contrast to the directivity, the gain  of an antenna considers additionally the efficiency  of the
antenna (not the radiated power density is compared to the isotropic radiator but the power fed to the
antenna). So, losses in the antenna are included in the value of the gain – but not in the value of the
directivity:

(22)

Radiation Pattern Lobes
A radiation pattern lobe is a section of the radiation pattern surrounded by regions of relatively weak
radiation intensity.

Major lobe / main beam The lobe in the radiation pattern containing the direction of
maximum radiation.

Side lobe The lobe in any direction other than the intended lobe and usually
represent radiation in undesired directions.

Back lobe The lobe in the radiation pattern that is in the opposite direction of
the major lobe.

Figure 175: Characteristic values of an antenna, related to the field pattern.

Characteristic values:

Side lobe attenuation

Back lobe attenuation

3dB angle of main lobe
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3dB angle of side lobe

Half Power Beamwidth (HPBW)
A half power beamwidth is the angular separation between the half-power (-3dB) points on the opposite
side of the pattern maximum (major lobe).

The side lobe attenuation, back lobe attenuation, 3dB angle of the major lobe and 3dB angle of side
lobe are applied to the vertical and the horizontal pattern. In the case of a vertical pattern, the variable
 is used to describe the angles. For the horizontal pattern, the variable  is used to describe the

angles. The 3dB angles are also called half-widths.

Directivity is indicated in dB, and the lobe width 3dB values are more easily legible in degrees in a
directivity pattern. It results in the following, adapted dimensional equation (angles values are in
degree):

(23)

Equivalent Radiation Angle

Figure 176: Graphical representation of equivalent angle of radiation.

 is the equivalent angle which is calculated from both sides of the half-values of the angles,  and
 of the two planes.

(24)

The radiated power density within the equivalent angle is assumed to be equal to the maximum
radiated power density (in the main direction) and outside the equivalent angle, no power is emitted.

(25)
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Effective Area
Gain and directivity of an antenna in transmitter or receiver operation are equal (reciprocity).

The received power  is obtained from power density  (electromagnetic field).

Effective area of an antenna  is defined according to:

(26)

Isotropic antenna:

(27)

Real antenna with directivity, :

(28)
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Parameters of Typical Antennas

Figure 177: Parameters of typical antennas.
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Figure 178: Horizontal pattern of dipole antennas (depending on the length of the dipole).

Mathematical Description of Antenna Patterns

Types of Patterns
An antenna radiates in all directions. Therefore, 3D patterns are required to describe the gain
individually for each direction. For some applications the radiation in the horizontal plane and the
radiation in the vertical plane is sufficient. These patterns are called 2x2D patterns.

Figure 179: Horizontal pattern (left) and vertical pattern (right) of a half wave dipole.
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Figure 180: 3D view of the antenna pattern of (half wave) dipole.

It is obvious that accurate computations are only possible with 3D patterns. AMan includes, therefore, a
module to convert 2x2D patterns to 3D patterns.

Antenna patterns can be defined in any coordinate system. Spherical coordinate systems are most
commonly used to define antenna patterns.

3D Antenna Patterns
3D patterns can be defined in any coordinate system. Spherical coordinate systems are most commonly
used to define antenna patterns.

Figure 181: Coordinate system for 3D antenna patterns.

Figure 181 shows the coordinate system used in WinProp for the 3D display of antenna patterns. The
main direction of radiation is  = 0° and  = 0°.

Figure 182 to Figure 184 show the 3D pattern as well as the vertical and horizontal plane of a Kathrein
K739856 antenna together with the coordinate systems used for display in AMan.
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Figure 182: 3D display of K739856.

Figure 183: Vertical plane radiation pattern of K739856.
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Figure 184: Horizontal plane radiation pattern of K739856.

2x2D Antenna Patterns
The radiation patterns in the horizontal and in the vertical plane are available for nearly all commercial
antennas. Full 3D patterns are not always available as they are more complicated to be measured.

Figure 185: K7230211 antenna as given in Kathrein catalog.

The 2D antenna pattern is the graphical representation of the directional characteristic in a 2D plane.
A polar diagram is used to describe the antenna pattern. While the vertical pattern results from

, the horizontal pattern is formed from .

To get smaller values, the pattern is often displayed on a logarithmic scale (dB). AMan offers both
modes (linear or logarithmic).

The term radiation lobe is used for antennas whose radiation is concentrated in certain sectors. It is
defined as the part of the directional characteristic which is limited by the angle with minimum field
strength. If the considered lobe contains the main direction of transmission, it is called the main lobe,
otherwise, secondary lobe. The lobe width, for example, ϑ3dB, indicates the angular expansion of the
main lobe in a directivity pattern. The main direction of transmission is located in the main lobe.

The lobe width half value appears at the definition value of –3dB (dropping in the field strength of 

and / or dropping of the radiation to half of the maximum value).
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Figure 186 and Figure 187 show the coordinate systems used to display the patterns in the 2D view in
AMan.

Figure 186: A coordinate system of the horizontal pattern (if viewed from the top).

Figure 187: A coordinate system of the vertical pattern.

Conversion of 2x2D Patterns (Horizontal & Vertical) to 3D
Patterns
The 3D pattern of an antenna can be computed based on the pattern of the vertical and horizontal
plane. AMan offers four different conversion algorithms. The user can decide which algorithm should be
used.

Arithmetic Mean (AM) Algorithm
The simplest algorithm searches for the two angles  and  the gain  in the vertical ( ) and the gain

 in the horizontal ( ) plane.
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The arithmetic mean of  (horizontal pattern) and  (vertical pattern) represents the actual gain
.

(29)

Patterns generated by this algorithm are not very accurate. Therefore, this algorithm is not
recommended (it is only implemented for comparison with other tools).

Bilinear Interpolation (BI) Algorithm

Four gain values are determined in the horizontal and vertical patterns depending on the two angles 
and .

The gain values are weighted with their angle distances:

(30)

Figure 188: Angles and gains used for the bilinear interpolation.

Weighted Bilinear Interpolation (WBI) Algorithm

This algorithm[16] is almost identical to the arithmetic mean (AM) algorithm. The gains and angle
distances are also read from the vertical and horizontal pattern and are weighted according to their
distances.

In contrast to the bilinear interpolation (BI) algorithm, the vertical angles are additionally weighted with
the factor . Therefore, the gain values read from the vertical pattern are no longer relevant in
the horizontal plane (for  = 90°), and the horizontal pattern is, therefore, more accurate.

16. A 3D Interpolation Method for Base-Station-Antenna Radiation Patterns in IEEE Antennas and
Propagation Magazine, F. Gil, A. Claro, J. Ferriera, C. Pardelinha, and L. Correia, Vol. 43, No.2, April
2001.
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The mathematical equation for the computation of the weighted bilinear interpolation is:

(31)

An alternative method to describe the interpolation is given below:

Figure 189: Angles and gains used for the weighted bilinear interpolation.

(32)

The weighted bilinear interpolation leads to more accurate results compared to bilinear interpolation

(BI) algorithm. The mean error is approximate 1.3 dB and the standard deviation is 0.6 dB for a -

dipole.

The most accurate results can be obtained with this algorithm if the main radiation of the antenna is in
the horizontal plane.

Horizontal Projection Interpolation (HPI) Algorithm
If the main radiation is not in the horizontal plane (for example, if the antenna has an electrical or
mechanical down tilt), the pattern computed with the bilinear interpolation (BI) and weighted bilinear
interpolation (WBI) algorithms becomes less accurate. Especially in these cases, the HPI algorithm
should be used.
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The HPI algorithm takes the gain of the horizontal pattern  as a basis and considers a correction
term for the influence of the vertical pattern . Therefore, the gains  and  in the
horizontal and vertical pattern, respectively, are taken and processed by using the following equation:

(33)

Hereby it is assumed that the horizontal and vertical patterns are two sections of the 3D antenna
pattern. This means that the two following conditions are fulfilled:

•  and  and in the case without electrical tilt

•  and  in the case of electrical tilt .

Exponential Interpolation (EXP) Algorithm
An alternative algorithm for the extrapolation of 3D antenna radiation patterns based on the given
horizontal and vertical patterns is the exponential interpolation. In this method the horizontal diagram
is corrected according to the difference between the front-to-back ratio at elevation angle 0° and the
front-to-back ratio at the elevation angle theta by using the following equation:

(34)

This exponential interpolation provides accurate predictions especially for antennas with electrical down
tilt.

Comparison of Conversion Algorithms
Four interpolation algorithms are visually compared when looking at the resulting 3D patterns and
the other hand analytically when using the resulting 3D patterns for the path loss prediction. For the
comparison three different antennas from Kathrein are going to be evaluated with different values
concerning the horizontal and vertical half power beam width (HPBW):

Table 16: Antennas (and their characteristic values) taken into account for the comparison.

Name Type Frequency HPBW (H) HPBW (V) Max. gain Elect. tilt

741 794 X-Pol 2110 MHz 65° 7° 18.5 dBi 2°

741 984 X-Pol 1855 MHz 87° 26° 11.5 dBi 0°

742 211 X-Pol 1855 MHz 67° 14° 15.5 dBi 6°

As a reference for the comparisons always the measured 3D antenna pattern is available (in all three
examples). These measured 3D patterns are provided by the manufacturer of the antennas (Kathrein).
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In the following an individual subsection is dedicated to each antenna, comparing the results of the
different interpolation algorithms (on the one hand by the resulting 3D antenna patterns and on
the other hand by predictions of the received power when using the corresponding interpolated 3D
antenna).

Antenna 741 794

The antenna 741 794 is a sector antenna with 65° horizontal and 7° vertical half-power beam width
and 2° electrical downtilt. The horizontal and vertical patterns of this antenna are given in Figure 190
while the real, measured, 3D pattern is visualized in Figure 191. The sketch of the 3D pattern is taken
from a side view, the main lobe of the antenna characteristic is oriented towards the right. The views in
Figure 192 represent the interpolated 3D patterns for the four different interpolation algorithms. Similar
to the measured 3D antenna pattern also these figures show the side view of the antenna with the main
lobe oriented towards the right.

Figure 190: 2D antenna patterns in horizontal and vertical plane (logarithmic scale).
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Figure 191: Real (measured) 3D antenna pattern (linear scale).

Figure 192: Interpol. 3D patterns by AM (top left), BI (top right), WBI (bottom left), HPI (bottom right).
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Comparison of Wave Propagation Results for Tx Height of 20m

Figure 193: Prediction of received power if using the measured 3D antenna pattern (Tx height 20 m).

Figure 194: Prediction of received power using the interpolated 3D pattern (AM algorithm).

Figure 195: Prediction of received power using the interpolated 3D pattern (BI algorithm).
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Figure 196: Prediction of received power if using the interpolated 3D pattern (WBI algorithm).

Figure 197: Prediction of received power using the interpolated 3D pattern (HPI algorithm).

The plots of the predicted received power for the transmitter height of 20m show the influence of the
antenna pattern on the computation of the wave propagation. At the first view all the figures look very
similar, however, after detailed analysis, there are some differences visible.

Table 17: Numerical evaluation of the power predictions (measured 3D - interpolated 3D) for Tx height 20m.

Comparison Polarization +45° Polarization -45°

Measured 3D
Pattern

Mean Value [dB] Standard
Deviation [dB]

Mean Value [dB] Standard
Deviation [dB]

AM Algorithm 0.57 2.41 0.07 1.81

BI Algorithm -0.32 2.14 -1.03 2.41

WBI Algorithm -0.77 2.10 -1.28 2.00
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Comparison Polarization +45° Polarization -45°

Measured 3D
Pattern

Mean Value [dB] Standard
Deviation [dB]

Mean Value [dB] Standard
Deviation [dB]

HPI Algorithm 0.17 2.00 -0.20 1.42

The numerical evaluation of these differences is given in the table above. According to this evaluation,
the HPI has the best performance (the smallest error with respect to the measured 3D antenna
pattern). However, all the different interpolation algorithms are in the same range (at least concerning
the standard deviation).

Comparison of Wave Propagation Results for Tx Height of 10m

Figure 198: Prediction of received power using the measured 3D antenna pattern (Tx height 10 m).

Figure 199: Prediction of received power using the interpolated 3D pattern (AM algorithm).
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Figure 200: Prediction of received power using the interpolated 3D pattern (BI algorithm).

Figure 201: Prediction of received power using the interpolated 3D pattern (WBI algorithm).

Figure 202: Prediction of received power using the interpolated 3D pattern (HPI algorithm).

The plots of the predicted received power for the transmitter height of 10m show the influence of the
antenna pattern on the wave propagation computation. Also for this reduced transmitter height, all the
figures look very similar, however after detailed analysis, there are some differences visible.
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Table 18: Numerical evaluation of the power predictions (measured 3D - interpolated 3D) for Tx height 10m.

Comparison Polarization +45° Polarization -45°

Measured 3D
Pattern

Mean Value [dB] Standard
Deviation [dB]

Mean Value [dB] Standard
Deviation [dB]

AM algorithm 0.19 1.58 0.07 0.78

BI algorithm -0.72 1.71 -1.43 2.21

WBI algorithm -1.68 1.84 -2.06 1.85

HPI algorithm -0.23 1.41 -0.34 1.11

The numerical evaluation of these differences is listed in the table above. According to this evaluation,
the AM algorithm has the best performance (the smallest error with respect to the measured 3D
antenna pattern). However, the HPI algorithm achieves nearly the same performance.

Antenna 741 984

The antenna 741 984 is a sector antenna with 87° horizontal and 26° vertical half-power beamwidth
and no electrical downtilt. The horizontal and vertical patterns of this antenna are given in Figure 203
while the measured, 3D pattern is visualized in Figure 204. The sketch of the 3D pattern is taken from a
side view (the main lobe of the antenna characteristic is oriented towards the right).

The views in Figure 205 represent the interpolated 3D patterns for the four different interpolation
algorithms. Similar to the measured 3D antenna pattern also these figures show the side view of the
antenna with the main lobe oriented towards the right.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
5 AMan p.228

Figure 203: 2D antenna patterns in the horizontal and vertical plane (logarithmic scale).

Figure 204: Real (measured) 3D antenna pattern (linear scale).
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Figure 205: Interpol. 3D patterns by AM (top left), BI (top right), WBI (bottom left), HPI (bottom right).

Comparison of Wave Propagation Results for Tx Height of 20m

Figure 206: Prediction of received power using the measured 3D antenna pattern (Tx height 20 m).
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Figure 207: Prediction of received power using the interpolated 3D pattern (AM algorithm).

Figure 208: Prediction of received power using the interpolated 3D pattern (BI algorithm).

Figure 209: Prediction of received power using the interpolated 3D pattern (WBI algorithm).
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Figure 210: Prediction of received power using the interpolated 3D pattern (HPI algorithm).

The plots of the predicted received power for the transmitter height of 20m show the influence of the
antenna pattern on the wave propagation computation. When comparing the different power plots,
there are some differences visible concerning the main lobe and the side lobes.

Table 19: Numerical evaluation of the power predictions (measured 3D - interpolated 3D) for Tx height 20m.

Comparison Polarization +45° Polarization -45°

Measured 3D
Pattern

Mean value [dB] Standard
deviation [dB]

Mean value [dB] Standard
deviation [dB]

AM algorithm 0.07 1.07 0.21 1.09

BI algorithm 2.18 1.06 1.81 0.94

WBI algorithm 0.55 0.91 0.68 0.98

HPI algorithm -0.51 0.85 0.51 0.93

The numerical evaluation of these differences is listed in the table above. According to this evaluation
again the AM algorithm has the best performance (the smallest error with respect to the measured 3D
antenna pattern). However, both the HPI and the WBI algorithm achieve nearly the same performance.
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Comparison of Wave Propagation Results for Tx Height of 10m

Figure 211: Prediction of received power using the measured 3D antenna pattern (Tx height 10 m).

Figure 212: Prediction of received power using the interpolated 3D pattern (AM algorithm).

Figure 213: Prediction of received power using the interpolated 3D pattern (BI algorithm).

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
5 AMan p.233

Figure 214: Prediction of received power using the interpolated 3D pattern (WBI algorithm).

Figure 215: Prediction of received power using the interpolated 3D pattern (HPI algorithm).

The plots of the predicted received power for the reduced transmitter height of 10m show the influence
of the antenna patterns on the wave propagation results. When comparing the different plots, there are
some differences visible concerning the main lobe and the side lobes.

Table 20: Numerical evaluation of the power predictions (measured 3D - interpolated 3D) for Tx height 20m.

Comparison Polarization +45° Polarization -45°

Measured 3D
Pattern

Mean Value [dB] Standard
Deviation [dB]

Mean Value [dB] Standard
Deviation [dB]

AM Algorithm 0.05 0.64 0.14 0.63

BI Algorithm 2.48 1.08 1.96 0.86

WBI Algorithm 0.76 0.73 0.78 0.70
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Comparison Polarization +45° Polarization -45°

Measured 3D
Pattern

Mean Value [dB] Standard
Deviation [dB]

Mean Value [dB] Standard
Deviation [dB]

HPI Algorithm -0.32 0.63 0.29 0.72

The numerical evaluation of these differences is listed in the table above. According to this evaluation
again the AM algorithm has the best performance. However, the HPI algorithm achieves nearly the same
performance.

Antenna 742 211

The antenna 742 211 is a sector antenna with 67° horizontal and 14° vertical half-power beamwidth
and 6° electrical downtilt. The horizontal and vertical patterns of this antenna are given in Figure 216
while the measured, 3D pattern is visualized in Figure 217. The sketch of the 3D pattern is taken from a
side view (the main lobe of the antenna characteristic is oriented towards the right).

The views in Figure 218 represent the interpolated 3D patterns for the four different interpolation
algorithms. Similar to the measured 3D antenna pattern also these figures show the side view of the
antenna with the main lobe oriented towards the right.

Figure 216: 2D antenna patterns in the horizontal and vertical plane (logarithmic scale).
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Figure 217: Real (measured) 3D antenna pattern (linear scale).

Figure 218: Interpolated 3D patterns by AM (top left), BI (top right), WBI (bottom left), HPI (bottom right).
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Comparison of Wave Propagation Results for Tx Height of 20m

Figure 219: Prediction of received power if using the measured 3D antenna pattern (Tx height 20 m).

Figure 220: Prediction of received power using the interpolated 3D pattern (AM algorithm).
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Figure 221: Prediction of received power using the interpolated 3D pattern (BI algorithm).

Figure 222: Prediction of received power if using the interpolated 3D pattern (WBI algorithm).
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Figure 223: Prediction of received power using the interpolated 3D pattern (HPI algorithm).

The plots of the predicted received power for the transmitter height of 20m show the influence of the
antenna pattern on the wave propagation results. When comparing the different power plots there are
some differences visible, especially concerning the main lobe and the side lobes.

Table 21: Numerical evaluation of the power predictions (measured 3D - interpolated 3D) for Tx height 20m.

Comparison Polarization +45° Polarization -45°

Measured 3D
Pattern

Mean Value [dB] Standard
Deviation [dB]

Mean Value [dB] Standard
Deviation [dB]

AM Algorithm -0.26 1.84 -0.28 2.57

BI Algorithm -0.62 1.52 0.50 2.41

WBI Algorithm -0.71 2.10 0.91 2.04

HPI Algorithm -1.34 1.90 -1.12 2.05

The numerical evaluation of these differences is listed in the table above. According to this evaluation
again the HPI and the AM algorithm have the best performance (the smallest error with respect to the
measured 3D antenna pattern).
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Comparison of Wave Propagation Results for Tx Height of 10m

Figure 224: Prediction of received power using the measured 3D antenna pattern (Tx height 10 m).

Figure 225: Prediction of received power using the interpolated 3D pattern (AM algorithm).
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Figure 226: Prediction of received power using the interpolated 3D pattern (BI algorithm).

Figure 227: Prediction of received power using the interpolated 3D pattern (WBI algorithm).
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Figure 228: Prediction of received power using the interpolated 3D pattern (HPI algorithm).

The plots of the predicted received power for the reduced transmitter height of 10m show the influence
of the antenna patterns on the wave propagation results. When comparing the different plots there are
some differences visible concerning the main lobe and the side lobes.

Table 22: Numerical evaluation of the power predictions (measured 3D - interpolated 3D) for Tx height 10m.

Comparison Polarization +45° Polarization -45°

Measured 3D
Pattern

Mean Value [dB] Standard
Deviation [dB]

Mean Value [dB] Standard
Deviation [dB]

AM algorithm -0.73 1.73 -0.82 1.86

BI algorithm -0.98 1.78 0.08 1.56

WBI algorithm 0.16 2.44 0.36 1.57

HPI algorithm -2.27 2.04 -2.09 1.84

The numerical evaluation of these differences is listed in the table above. According to this evaluation,
the HPI has the best performance (the smallest error with respect to the measured 3D antenna
pattern).

Conclusions

In this section, the four different interpolation algorithms are compared to one another by analyzing the
predicted power plots which are computed considering the corresponding antenna pattern.

This comparison is performed for three typical antennas used in the wireless communications domain
(the antennas have different characteristics concerning the vertical and horizontal half-power beam
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width). Each of the antennas is used with two polarizations (+45°/-45°) and for two different heights
of the transmitting antenna (one location below rooftop level and one above rooftop level). Therefore,
general conclusions can be drawn.

Considering all the different cases the simple AM algorithm and the HPI algorithm has the best
performance concerning the numerical evaluation. As the latter method indicates the better agreement
of the interpolated 3D pattern to the measured 3D pattern when comparing the 3D views, this
algorithm is recommended as the default algorithm.

Additionally, the HPI is the more generalizing approach due to the higher number of considered
parameters (more information of the horizontal and vertical pattern is evaluated).

The bilinear interpolation methods (BI as well as WBI) produce good results concerning the agreement
of the 3D view (when comparing the measured 3D pattern to the interpolated 3D pattern). However,
the accuracy of these methods for the power prediction does not reach the accuracy of the HPI
algorithm.
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5.2 Multiple Antenna Scenario Configuration
(MASC)
Antenna patterns from the manufacturer of the antenna are always measured in anechoic chambers.
So the mounting of the antenna at a mast or in front of a wall is not considered in the pattern. But
obviously, mast and wall have a significant influence on the actual antenna pattern. MASC allows
considering mast / wall, arms, tubes, radomes and their influence on the actual radiation pattern of the
antenna.

Sometimes the same signal is radiated with multiple antennas (using power splitters and phase shifters)
to obtain special antenna patterns (for example, quasi-omni configurations). MASC can also compute
these antenna patterns based on the superposition of multiple single antennas fed with different powers
and phases.

Figure 229: Two sector antennas mounted at the same mast.

The actual antenna patterns (either 2x2D or real 3D) computed with MASC are saved in the standard
file formats of AMan and can be exported to many other file formats (for example, .msi, .pln). So, the
computed patterns can also be used together with other prediction models and radio network planning
tools.

The scenario including mast, arms, tubes, radomes is modeled in 3D and automatically generated based
on some parameters (distances, lengths, materials) defined by the user. MASC generates not only all
objects of the scenario automatically, but it also generates the coordinate system. So, you can focus on
what is important (the properties of the individual antennas mounted at the mast), and MASC organizes
the other things.

In the 2x2D mode, the vertical, as well as the horizontal pattern, contain the direction with the highest
gain (at this point vertical and horizontal pattern intersect). Especially if antennas with tilts are used,
this is complex because the horizontal pattern is shifted horizontally.

The vertical plane is defined with two vectors and one point:

• Vector from the point with the highest gain towards the center of the spheroid of the computation

• Vector of Z-axis

• Center of the spheroid of computation

The horizontal plane is defined with two vectors and one point:

• Horizontal vector (no z component)

• Normal vector of the vertical antenna pattern
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• Point with the highest gain

The computation can be scaled to obtain very fast first results and to get the highest achievable
accuracy (requiring longer computation time).

5.2.1 Limitations and Assumptions

Far Field and Near Field
From the theoretical point of view, ray optical algorithms can only be used in the far field of the antenna
and are only valid if the obstacles are large compared to the wavelength. Additionally, they do not
consider coupling between adjacent antennas.

If the near field must be computed, models based on the electromagnetic field theory are required,
for example, the method of moments (or something similar). But these models suffer from long
computation times.

MASC uses ray optical methods and not the method of moments (MoM) because of the computation
time. Short computation times are only achievable with ray optical models. And the error concerning the
accuracy is acceptable.

Concentration of Radiation in a Single Point
In MASC (and in most wave propagation models), an antenna is concentrated in a single point of
radiation, and the pattern (far field pattern) of the antenna (obtained from the manufacturer of the
antenna) will be used for the computation.

In reality, this is different. Antennas have a given mechanical size and are radiating not only from a
single point – but from the whole aperture.

MASC reduces the antennas to single point radiators. The antenna pattern of the individual antenna is
applied to the single point radiator. So, radiation is concentrated in a single point. But the mechanical
size of the antenna and its radome is also considered in MASC - for the interaction (transmission,
reflection, diffraction) with signals radiated from other antennas.

The concentration of the radiation into a single point is required because of the patterns of the single
antennas. All patterns of these commercial antennas are far field assuming the radiation from a single
point. So, considering the actual mechanical aperture would require new patterns which are not
available for most antennas. With the concentration of the radiation to a single point, the error, Error!
The reference source is not found, is included in the results.
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Figure 230: Comparison between single point radiation (on the left) and actual radiation (to the right).

The error shown in Figure 230 is big if the size of the antennas is large and the distance between them
is small. As soon as the distances between the antennas are multiples of the antenna size, the error can
be neglected.

Description / Definition of Materials
The materials of the mounting elements as well as walls, masts, for example, are assumed to be
isotropic and homogeneous (not different electrical properties depending on the direction of propagation
in the medium).

Materials are characterized by their electrical properties (transmission loss, reflection loss). WinProp
offers an EXCEL sheet where these properties for different frequency bands and materials are listed.
Also, the conversion from dielectric permittivity, permeability, and conductance to transmission and
reflection loss are given in this sheet.

The material properties of each element used for the mounting of the antenna (for example, mast, arm,
sub-arm, tube, radome, and wall) can be defined individually to describe the scenario as accurately as
possible. The software suggests reasonable default values.

MASC assumes that the radome of a single antenna is included in the pattern used for this antenna.
Therefore, the radome is not considered for this antenna. It is only considered as shielding and
reflecting element for all other antennas.

5.2.2 Configurations
MASC supports antennas mounted at masts as well as antennas mounted in front of walls:
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Figure 231: The Definition of local environment dialog.

The following configurations are supported:

• Quasi-omni (mast configuration)

• Skew (mast configuration)

• Side-mounted (mast configuration)

• Antenna in front of a wall (wall configuration)

The difference between the first three configurations (quasi-omni, skew, and side-mounted) is only
the angle between arm and antenna. But as you can define these angles, each configuration can be
described by the mast configuration.

The Antenna in front of a wall configuration is different as the antennas are mounted on a wall instead
of a mast.

Mast Configuration (For Example, Quasi-Omni, Skew, Side
Mounted)
The mast configuration allows the combination of multiple single antennas with a power splitter. So, for
example, a homogeneous 360-degree coverage can be achieved (if all antennas are fed with the same
signal and power).

With different settings in the power splitter or with non-equal angles between the antennas, the
radiation can be concentrated into dedicated directions.
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The example in Figure 232 shows a configuration with multiple antennas mounted around a mast. The
number of antennas, as well as their azimuth and elevation (tilt), can be defined by you.

Figure 232: Example for quasi-omni configuration.

Figure 233 shows additional sub-arms at the end of one arm. Each antenna can be mounted additionally
at such a sub-arm. The azimuth of this sub-arm can be defined arbitrarily, and it is independent of the
azimuth of the main arm. So, two antennas with different azimuth orientation can be mounted at the
same arm.

Figure 233: Example of quasi-omni with sub-arms.

The difference between quasi-omni, skew and side mounted is the value of the azimuth angle between
antenna/sub-arm and arm. In skew the init value should be 90° (main radiation is tangential to the
mast), while in quasi-omni as well as in side mounted the init value should be 0° (main radiation of
antenna is orthogonal to the mast).

Quasi-omni and skew configurations allow multiple antennas at one mast while side mounted is limited
to one antenna.

In MASC the azimuth angles between sub arms / antennas and arms can be defined individually, and
the number of antennas can also be defined by the user. Therefore, you do not have to specify explicitly
the configuration (quasi-omni, skew, side-mounted) to be used. Only the mast configuration must
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be selected. By defining the azimuth angles and the number of antennas, you select a configuration
implicitly.

Therefore, all three configurations quasi-omni, skew and side mounted can be modeled with the mast
configuration of MASC.

Figure 234: Example for skew configuration.

Figure 235: Example for side-mounted configuration.

For a mast configuration, the following parameters can be defined:

• Number of (single) antennas considered: arbitrary (depends on RAM)

• Antenna

◦ Antenna type: directional (sector) antennas or omnidirectional antennas

◦ Pattern of the single antenna can be loaded from a file

• Mast

◦ Diameter of mast

◦ Height of mast

◦ Material of mast (reflection and transmission loss)

• Arms at mast

◦ Diameter and length of each arm as well as height where the arm is mounted at mast
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◦ Material of arm (reflection and transmission loss)

◦ Azimuth of the arm [0°..360°]

◦ Azimuth of the antenna [0°.360°, relative to arm] (0° is equal to the direction of arm)

◦ Elevation (tilt) of antenna [-90°..90°]

• Radome

◦ Size and type (rectangular, circular) of the radome

◦ Material of radome (reflection and transmission loss)

• Electrical parameters

◦ Power splitter: relative split between antennas must be defined (for example, 1:1:2:1).

◦ Phase shifter: phase shift between antenna can be defined.

Side-mounted configurations are depending on the shadowing of the mast and arms and the reflections
at the mast and arms. Depending on the distance between the antenna and mast, different radiation
directions can be generated (see Figure 236).

Figure 236: Examples of side-mounted configurations. Distance antenna-mast:
lambda/4 (on the left) and distance antenna-mast: lambda/2 (to the right).
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Figure 237: Examples of horizontal antenna patterns (quasi-omni configurations).

Wall Configuration (For Example, Antenna in Front of a Wall)
The wall configuration can be used, if the antennas are mounted at or in front of a wall. Often only one
antenna is mounted – but in MASC the number is only limited by the RAM.

The wall configuration consists at least of an antenna, the arm to mount the antenna and a wall.
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Figure 238: Example for wall configuration.

The wall configuration considers shadowing of the wall as well as reflections on the wall. If the
transmission / penetration loss of the wall is very high, the radiation in the direction of the wall is
suppressed.

Important is the consideration of the reflection at the wall because the reflected rays are superposed to
the direct rays and depending on the phase difference between the two rays, the superposed signal can
be decreased or increased (see Figure 239).

In this configuration very often only one antenna is considered. Of course, the software itself can handle
an arbitrary number of antennas. In the case of multiple antennas, the orientation of the wall is defined
with the first antenna in the list of antennas.

The computation of one reflection is sufficient to obtain the required accuracy.

The size of the wall is assumed to be infinite, so diffractions at the wedges of the wall are neglected.
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Figure 239: Influence of wall on antenna pattern of a GSM 900 directional antenna. The distance between
antenna and wall is 100 mm for both figures in the upper row and 150 mm for both figures in the lower row.

The wall configuration considers the following parameters:

• Number of (single) antennas considered: arbitrary (depends on RAM)

• Antenna

◦ Antenna type: directional (sector) antennas or omnidirectional antennas

◦ Pattern of single antenna can be loaded from a file

• Wall

◦ Size of wall

◦ Material of wall (reflection and transmission loss)

• Arms at mast

◦ Diameter and length of each arm as well as height where the arm is mounted at mast

◦ Material of arm (reflection and transmission loss)

◦ Azimuth of the arm [0°..360°]

◦ Azimuth of the antenna [0°..360°, relative to arm] (0° is equal to the direction of arm)

◦ Elevation (tilt) of the antenna [-90°..90°]

• Radome

◦ Size and type (rectangular, circular) of the radome

◦ Material of radome (reflection and transmission loss)

• Electrical parameters

◦ Power splitter: relative split between antennas must be defined (for example, 1:1:2:1).

◦ Phase shifter: phase shift between antenna can be defined.
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5.2.3 Pattern of Single Antennas Used in MASC
For each antenna used in the configurations, a far field radiation pattern is available. This pattern is
measured in an anechoic chamber and does not include, usually, any masts, arms or walls. Only the
radome of the antenna is included. If the antenna consists of multiple dipoles, the pattern describes the
radiation of the superposed signal radiated from all dipoles. An isolated analysis of a single dipole is not
possible. The radiation is concentrated in a single point – even if multiple dipoles are used to build the
antenna.

The pattern is provided by the manufacturer of the antenna, and it is either 2x2D (horizontal and
vertical plane) or real 3D (see Figure 240 and Figure 241). It is possible to compute the 3D pattern
based on the vertical and horizontal 2D patterns. Figure 241 shows an example of such a 3D pattern
based on the patterns shown in Figure 240.

Figure 240: Vertical (left) and horizontal (right) antenna pattern (Antenna Kathrein K739856).

MASC always works with 3D patterns of every single antenna used in the configuration. If the 3D
pattern is not available, it is interpolated with the HPI algorithm.

The shielding of the radome of an antenna is obviously not considered in its radiation pattern – but
for all other antennas of the configuration. The influence of mast, arms on the radiation pattern is
considered for each antenna.

The gain of the antenna can either be relative to an isotropic radiator (values in dBi) or on a half-wave
dipole (values in dBd). The conversion between both values is possible with the gain of the half wave
dipole (2.1 dBi).
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Figure 241: Interpolated 3D Antenna Pattern (Antenna Kathrein K739856).

5.2.4 Computation of Wave Propagation in MASC

Antennas Concentrated in a Single Point
The antenna pattern is based on the assumption of radiation from a single point (therefore they
are only valid in larger distances (several wavelengths) to the antennas. In the near filed different
approaches are used to determine the radiated field (for example, FEM and MoM). Due to this single
point radiator concept, the propagation can be approximated with spherical waves (and different gains
in different directions).

If the distances to obstacles are several wavelengths (what is true for the frequencies in cellular
wireless (more than 800 MHz) and the configurations supported with MASC, the local wavefront is
nearly planar and the well-known equations to compute the reflection, penetration and diffraction losses
can be applied.

TX Power of Each Antenna
To compute the electric field strength radiated from an antenna, the transmitted signal power must
be known. In MASC the user does not have to specify the power because the resulting pattern is
always independent of the absolute power (only relative power ratios between different antennas are
important). Therefore, a reference TX power of 1 W is applied to each antenna.

If power splitters are used, the power is split between the antennas according to the settings of the
power splitter.
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Example
Four antennas fed with power splitter 1 : 1 : 5 : 5. The powers of the antennas are 0.2 W (antenna 1
and 2) and 1 W (antenna 3 and 4).

The isotropic radiator is also fed with the sum of all single antennas (in the example above this would
be 0.2 W + 0.2 W + 1 W + 1 W = 2.4 W) reference power.

Isotropic Radiator as a Reference
The isotropic radiator is used as a reference for the computation of the resulting antenna pattern. It
radiates the same power density in all directions.

As already mentioned, the isotropic radiator is a single point of radiation. The coordinates of this point
are determined based on the coordinates of the single antennas used in the configuration. In a first
step, the geometrical mean  of the single antennas (each of them concentrated in a single point)
is determined. Each antenna is weighted with its individual part of the Tx power (if power splitters are
used). So, in power splitter mode,  will be closer to the high power antennas.

The total Tx power  fed to the isotropic radiator is the sum of the powers fed to the individual
antennas. With this power, the received power  in a distance  can be computed with

(35)

For the computation of the resulting antenna pattern, the field strength and not the power is relevant.
Therefore, the power density  is computed with

. (36)

With

(37)

the power density  can be transformed to the effective electric field strength  (  is the free
space impedance, and its value is ).

General Concept
The geometrical mean  is used as the center of the computation spheroid. The radius of the
spheroid is  and can be large to ensure that all objects of the configuration (masts, walls, arms)
are inside the spheroid. The radius used is between 500 and 1000 m, depending on the objects of the
configuration but the actual value does not influence the accuracy of the results.
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Antenna in front of wallQasi omni

Figure 242: Spheroid used for computation.

If a 3D pattern is computed, each point on the spheroid is computed (angle resolution is 1 degree in the
horizontal plane and 1 degree in the vertical plane, leading to 360 x 180 values). If only a 2x2D result
is required, only 2 x 360 values are determined. The increment / resolution is not fixed to 1 degree. For
accelerated computations also 2-degree, and even 5-degree steps can be used.

For each value, the field strength  of the isotropic radiator is determined. As all points on the
spheroid have the same distance to the geometrical center point , it is sufficient to compute the
field strength  only once and use the same value for all pixels to be determined on the spheroid.

After this initial step, the (complex) field strength  of the actual configuration is computed as a
superposition of the contributions from all single antennas reaching the point under examination.

The quotient

(38)

represents the gain in the direction towards the point on the spheroid currently examined. Only the
magnitude of the complex field strength is used as the phase is not written in the result. After all points
on the spheroid are computed, the resulting pattern is available.

Rays Considered in the Computation

Rays

In the basic version, only the direct ray from the antenna (single point) to the examined point on the
spherical surface is considered. All transmissions of this ray are evaluated.

A consideration of reflections and diffractions makes no sense because of the assumption of a single
point radiation source. The reflection conditions (angle of incident ray = angle of reflected ray) are
seldom true (in contrast to a real antenna which is not concentrated in a single point) and therefore
nearly no reflected rays are found.
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If the antenna is reduced to a single point, many diffracted rays are neglected (especially if the distance
between antenna and objects is small). A real antenna (not reduced to a single point) would have
reflections on the object.

Transmitter
(Point source)

Transmitter
(Real)

ReceiverReceiver

Figure 243: Example of a wall configuration.

Since the reflection loss reduces the power of this ray, the error in the superposition of the reflected
and direct rays can be neglected (if 10 dB or more reflection loss is applied, the sum of both rays in
logarithmic scale is nearly identical to the direct ray alone).

The only exception is the reflection at the mast itself. As the mast is often built with metal, the
reflection loss is very low. So, reflections at the mast are not attenuated significantly, and therefore
they have a strong influence on the superposed signal power (they can destruct the radiated signal in
one direction). The same applies to the wall if the antenna is mounted in front of the wall. Therefore,
reflections at walls are also considered.

Direct Ray

The direct ray from the single antennas to the spherical computation surface is very important. They
have as many transmissions / penetrations as required.

The contribution of the direct rays to the total field strength is computed with the equations. If there are
additionally transmissions / penetrations, the additional loss due to these interactions is added to the
loss of the direct ray.

Transmission / Penetrations Along Rays

The number of transmissions / penetrations are not limited in the rays considered for the computation.
The transmission/penetration loss of an object intersecting any ray must be added to the free space loss
LFS of this ray:
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(39)

An object is defined as a planar polygon. The material properties of the objects can be defined
individually.

The determination of the intersection between a ray and an object is explained with a simple example.
If more objects must be considered, this analysis must be made for each object individually.

As all objects are planar, they can be represented by their normal vector nW.

nw Q

P2

P1

r

Object

Figure 244: Intersection of ray and objects.

Consider the transmission of the ray between the two points P1 and P2. The point Q is computed as the
intersection between the line represented by P1 and P2 and the object (described by the normal vector
nW and its distance to the origin of the coordinate system). If nW is parallel to the direction from P1 to
P2, no transmission / penetration is assumed.

If Q is between the points P1 and P2 and if Q is inside the polygon representing the object, a
transmission / penetration occurs and its transmission/penetration loss (material dependent) must be
added to the free space loss of the ray between P1 and P2. If Q is outside the polygon or not between P1
and P2, no additional loss due to transmission / penetration must be considered.
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Figure 245: Transmission/Penetration must be considered or can be neglected.

Reflected Rays

Due to the very small distances between the reflecting objects and the concentrated point of radiation,
the reflection is only considered correct if the object is significantly larger than the wavelength and
larger than the distance between object and center of radiation. This is not valid for most objects
(except the wall in the configuration “antenna in front of a wall”). So theoretically the reflections at
masts, arms and radomes should not be computed.

But to obtain good and accurate results, the reflections are important. And therefore, they are included
in the computation. Reflections at mast and wall are extremely important because the reflection
loss is not very high and the signal might have a phase shift of 180° to the direct signal in some
directions - which leads to destructive interference and therefore to an elimination of the radiation
into this direction. So, the reflections are important and must be considered. Reflections at radomes
can be neglected because their attenuation are high and so the superposition to direct paths (without
reflections) is nearly invisible in the resulting antenna pattern.

The computation of the reflected ray will be shown in the following example. The ray emitted from P1
will be received by P2, and the reflection at the wall is analyzed.

If more than only one object must be considered, then this step must be repeated for each object.

In a first step, the image of P1 relative to the wall is determined. The distance dPW of the point P1 from
the wall is computed with the normal vector nW of the wall.

The image P1A is determined by multiplying the normal vector of the wall with -2 * dPW and adding it to
P1:

(40)
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Wall
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Figure 246: Scenario for the reflection.
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Figure 247: Geometry to compute the reflection.
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P1

dPW

P1A

dPW

Figure 248: Image of the transmitter.

If the line from P1A to P2 is intersecting the polygon representing the wall, this point of intersection is
named Q and represents the point of reflection.
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Figure 249: Computation of reflection point Q.

The angle of reflection α between the ray and the wall is determined with the scalar product of the
normal vector nW and the vector q of the reflected ray (from Q to P2).

nw

P2

Wall

P1

P1A

Q

Figure 250: Computation of angle of reflection at point Q.

The angle of reflection α is determined with:

(41)

With the angle α and the material properties of the wall / object the reflection loss can be determined
accurately.

This reflection loss is then subtracted from the free space loss given by

(42)

with the path length r as a sum of the distance r1 from P1 to point Q and distance r2 from point Q to P2:

(43)
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Figure 251: Computation of angle of reflection.

For both parts of the reflected ray (from P1 to Q and from Q to P2), the transmissions / penetrations
must be determined additionally.

Diffracted Rays

The explanations for the reflected rays with the size of the objects and their distance to the radiator
is even more important for the diffractions. And the diffraction losses are high – compared to the
reflection losses.

So MASC does not consider any diffractions in the computation of the resulting patterns. Diffractions
would only be interesting if no reflecting or transmitting ray would reach the point currently examined.
But this can never be the case as an unlimited number of transmissions / penetrations are supported,
and therefore at least the direct ray is examined for each point examined.

Computation of Transmission / Penetration Loss
For each element, an individual transmission / penetration loss can be defined (in dB). If a ray is
penetrating the object, this loss is added to the propagation loss of the ray.

WinProp offers a table (MS EXCEL Sheet) with different materials and their specific losses, depending
on the thickness. You can enter the material, and the thickness and the sheet provide the appropriate
transmission/penetration loss to be used.

Transmission / penetration of dielectric objects does not lead to a phase shift. Therefore, no additional
phase offset is added to the phase of the ray at the receiver.

Computation of Reflection Loss
Similar to the reflection, described in the previous subsection, an individual transmission/ penetration
loss can be defined (in dB) for each element. If a ray is reflected at the object, this loss is added to
the propagation loss of the ray. WinProp offers a table (MS EXCEL sheet) with different materials and
their specific reflection losses. So, you can enter the material, and the sheet provides the appropriate
reflection loss to be used.

Reflections at dielectric surfaces do lead to a phase shift of 180°. Therefore, an additional phase offset
of 180° is added to the phase of the ray at the receiver and considered during the superposition.
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The angle dependency of the reflection loss is not considered in MASC as its influence is not so high
concerning the accuracy of the modeling of the scenario.

Polarization
The polarization of the electromagnetic wave has a strong influence on the resulting antenna pattern.
But to consider polarization in the resulting pattern, also the input patterns of the single antennas must
have information about the polarization. But this polarization data is not available for most patterns of
commercially available antennas.

So, if the input does not include the polarization, it makes no sense to consider polarization in the
result. Therefore, the result is independent of the polarization of the signals.

Superposition of Rays
The individual rays are superposed with consideration of the phase information. This leads to
constructive and destructive interference in the results.

Depending on the path length and frequency, the phase of the signal and the complex electric field
vector are computed. The phase φi  of ray i depends on the path length r and the wavelength λ of the
signal (c0 is the velocity of light and f the carrier frequency):

(44)

For each reflection in the ray, an additional phase shift of 180° is considered.

The total field strength Etot is the coherent (including phase) superposition of the electric field strengths
of the different paths:

(45)

The generated output file does not contain any information concerning the phase (because all radio
network planning tools would not consider this information). Therefore, in the generated results only
the magnitude of the electric field strength relative to the isotropic radiator is considered:

(46)

5.2.5 Mathematical Modeling of the Elements in MASC
In this subsection, the mathematical modeling of the objects (for example, masts, walls, and arms) to
describe the scenario is given. Only the objects relevant for the computation are modeled. Small objects
like skews and nuts are not modeled because their influence is quite small.
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Mast
The mast is used for many configurations and is described with:

• Cylinder with a circular cross-section

• Diameter of the cross-section (user defined)

• Height of the mast (user defined)

• Material properties (reflection and transmission loss) (user defined)

• Smooth surface (only specular reflection, no scattering)

As the mast is a cylinder with a circular cross-section, the information related to circular objects also
applies to the mast.

Wall
In the configuration “antenna in front of a wall” the wall is important and must, therefore, be modeled
accurately with the following parameters:

• Planar object with a rectangular shape (quadrate).

• Length of the side of the quadrate (user defined).

• Material properties (reflection and transmission loss) (user defined).

• Smooth surface (only specular reflection, no scattering).

Arms, Tubes and Sub-Arms (to Mount Antennas)
Antennas are mounted on arms. They are orthogonal to the surface (mast or wall) and always consist of
a pair of two arms, one above the other. At these arms, a tube is mounted vertically. At the tube, there
are at least two sub-arms to mount the antennas on the tube.

All elements of the arms and sub-arms are geometrically centered. The cross-section of the tubes is
always circular. The tube is open at its ends, see Figure 252.

Sometimes the antenna is mounted at the tube without sub-arms, see Figure 253. Therefore, you can
enable or disable the sub-arms for each antenna individually in MASC.
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Figure 252: Side-view (a) and top view (b) of the arms (A) mounted at the mast (M).
The antenna (R) is mounted with sub-arms (C) at the vertically oriented tube (B).

Figure 253: Side-view of the arms (A) mounted at the mast (M). The
antenna (R) is mounted without sub-arms at the vertically oriented tube (B).
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For each arm, the azimuth can be defined individually. North means 0° with increasing values towards
East (90° means East). So multiple arms and antennas can be arranged around a single mast.

Figure 254: Top view on a configuration with six arms with different azimuth angles

Antennas can be rotated in azimuth relative to the arm, see Figure 255. The rotation axis is the
vertically mounted tube, and the sub-arms are also rotated together with the antenna. As this azimuth
value is relative to the orientation of the arm, an azimuth of 0° is equal to the direction of the arm.
Positive values for the azimuth are describing a rotation clock-wise (from top-view).

Figure 255: Top view of a 45° azimuth rotated antenna. Antenna (R) and sub-arm (C) are rotated in
the horizontal plane around the tube (B). The location of the arms (A) and tube (B) is not influenced.

It is also possible to mount multiple antennas with different azimuth at one tube/arm. The number of
antennas to be mounted on the same arm is not limited by MASC.
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Figure 256: Top view on a configuration with two antennas (R),
mounted at one tube/arm. The azimuth of the antennas is ±60°.

Radome (of Antennas)
The radome of the antenna is a protection of the radiating elements. The influence of the radome on the
radiation of the antenna is included in the pattern of the antenna – but in MASC the influence (mainly
shielding) of the radome on other antennas mounted at the same mast is considered.

The cross-section of radomes are either circular cylinders (for omnidirectional antennas) or rectangular
(for sector antennas). Of course, you can select the cross section of the radomes individually for each
antenna.
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Figure 257: Example for the radome of an omnidirectional antenna (a) and a sector antenna (b).

Tilts (of Antennas)
Antennas can have a tilt (up tilt or down tilt). Theoretically tilts with a maximum of ±90° are possible.
Positive values describe up tilts, and negative values are used for down tilts. Practically tilts are most
often negative (down tilts) and are in the region between 0 and –20°.

A down tilt leads to a rotation at the lower end (bottom) of the antenna while an up tilt leads to a
rotation at the upper end (top) of the antenna.
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Figure 258: Example for an antenna (R) with a tilt of -5° (down tilt).

Figure 259: Example of an antenna (R) with a tilt of +5° (up tilt).

The sub-arms should be longer in case of a tilt – but in MASC this effect is not modeled as its influence
on the accuracy is not visible in the output pattern.
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Objects with Circular Cross Sections (Cylinders)
As already mentioned several times, objects with circular cross-sections can be approximated with
multiple planar rectangles without a big influence on the accuracy of the results.

For the mast, this approximation is only used for the determination of the transmissions / penetrations
(for example, for the determination of the shielding of the mast. For the reflections at the mast, the
ideal circular cross-section is used to obtain high accuracy in the results.

At least 6 (better 10) planar rectangles should be used to approximate the cylinder accurately.

Figure 260: Modeling of a circular cylinder with multiple planar rectangles.

Parameters for the cylinder are:

• height of cylinder

• diameter of cylinder

• number of corners (for polygon approximating the cross section)

• location of ground plane center

The bottom and ceiling of the cylinder are not modeled because their influence can be neglected.

Objects with Rectangular Cross Sections (Cuboid)
Objects like arms or tubes can also have a rectangular cross-section, and therefore you can also model
these cuboids with the following parameters:

• width

• depth
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• height

• position (X, Y and Z coordinates)

Each cuboid consists of a bottom, ceiling and four walls. But bottom and ceiling of the cuboid are not
modeled as their influence on the resulting pattern can be neglected.

The radomes of sector antennas can be approximated with cuboids. The cross-section of sub-arms is
always a quadratic (width and depth are identical).

Positioning of Elements
The objects describing the scenario must be positioned relative to one another. This can be defined
via x-y-z-coordinates in the coordinate system. As this can be complicated, MASC generates the
coordinates automatically after requesting some simple parameters from the user. All user entered
values are values relative to the border of the wall, mast or arm.

Arms (At Masts)
The arms are starting inside the mast (inner circle of the polygon) to guarantee that there are no gaps
between mast and arm which would have a significant influence on the accuracy of the pattern.

Figure 261: Top view of real and modeled mast including the inner circle of the modeled mast (and four arms).

Both arms are horizontal and are oriented radial towards the center of the mast. The distance a
between the two arms as well as the height h at the mast can be defined.
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Figure 262: Vertical positioning of arms at the mast.

Arms (At Walls)
Both arms are horizontal and orthogonal to the wall. You can define the distance between the arms and
the distance of the arms from the borders of the wall.

Origin of the coordinate system is the lower-left corner of the wall.

Figure 263: Positioning of the arms on the wall.

Tube (Vertical)
The vertical tube is always fixed in front of the two arms. Its vertical center is on the height exactly
between the two arms.
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Sub-Arms
Sub-arms are optional. If they are used, they are always fixed at the tube. Similar to the arms, the
distance between the sub-arms is also user defined. The sub-arms are vertically centered to the tube.
Their azimuth orientation is defined by the user and is similar to the azimuth of the antenna itself.

Radome
Omni, as well as sector radomes (for example, circular and rectangular cross-section), are mounted
directly at the sub-arms (if used) or at the tube (if no sub-arms are used).

Consideration of Material Properties
The material properties of each object can be defined individually. To have a simple interface for fast
computations the user has to defined “only.”

• reflection loss (in dB)

• transmission/penetration loss (in dB)

A table with electrical properties of different materials can be obtained from WinProp support engineers.

5.2.6 Example: Computation of a Quasi-Omni
Configuration
An algorithm is presented for calculating the resulting antenna diagram. Since the configurations
(quasi-omni, skew and side-mounted) can be converted into a configuration, only one example is
presented for all three configurations.

Step 1: Definition of Configuration
The following configuration is examined (these parameters must be defined):

• Quasi-Omni configuration

• Number of antennas: N = 3

◦ 1 Antenna at first arm

◦ 2 Antennas together at second arm

• Diameter of the mast: 500 mm

• Height of mast: 10 m

• Material of mast: Steel

• Power splitter: Antenna 1-1 - Antenna 2-1 - Antenna 2-2 : 2:1:1
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Figure 264: Example of a mast with quasi-omni configuration

Properties of Arms and Antennas

Arm1
• Height (mounted): 9 m

• Material: Steel

• Length of both arms: 300 mm

• Distance between both arms: 500 mm

• Vertical tube:

◦ Cross section: Rectangular

◦ Length (Height): 1000 mm

◦ Width (cross-section): 50 mm

• Azimuth of arm: 180°

• Antenna 1-1:

◦ Azimuth: 0° (relative to arm)

◦ Elevation: 0°

◦ Phase offset: 0°

◦ Radome

∙ Type: Cuboid

∙ Dimension: (W x D X H): 150 mm x 50 mm x 800 mm

∙ Material: Steel

Arm 2
• Height (mounted): 9 m
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• Material: Steel

• Length of both arms: 450 mm

• Distance between both arms: 500 mm

• Vertical tube:

◦ Cross section: Rectangular

◦ Length (Height): 1000 mm

◦ Width (cross-section): 50 mm

• Azimuth of arm: 0°

• Antenna 2-1:

◦ Azimuth: 45° (relative to arm)

◦ Elevation: 0°

◦ Phase offset: 0°

◦ Sub-arm:

∙ Width: 40 mm

∙ Distance between mounting points: 100 mm

∙ Length: 50 mm

◦ Radome

∙ Type: Cuboid

∙ Dimensions: (W x D x H): 150 mm x 50 mm x 800 mm

∙ Material: Steel

• Antenna 2-2:

◦ Azimuth: 315° (relative to arm)

◦ Elevation: 0°

◦ Phase offset: 0°

◦ Sub arm:

∙ Width: 40 mm

∙ Distance between mounting points: 100 mm

∙ Length of sub-arms: 50 mm

◦ Radome

∙ Type: Cuboid

∙ Dimensions (W x D x H): 150 mm x 50 mm x 800 mm

∙ Material: Steel

Step 2: 3D Model of the Scenario (Including Coordinate System)
The 3D model of the scenario is computed automatically by MASC. Depending on the approximation
of the circle by polygons, different objects are generated. If a polygon with six corners is used for the
mast, the following 64 objects are generated to describe the scenario:

(All coordinates in meter. One line describes one object. Each object has four corners.
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Syntax: Number Corner 1.x, Corner 1.y, Corner 1.z Corner 2.x, Corner 2.y, Corner 2.z,…)

Mast:
1 0.217, 0.125, 0.000 0.000, 0.250, 0.000 0.000, 0.250, 10.000 0.217, 0.125, 10.000
2 0.217, -0.125, 0.000 0.217, 0.125, 0.000 0.217, 0.125, 10.000 0.217, -0.125, 10.000
3 0.217, -0.125, 0.000 -0.000, -0.250, 0.000 -0.000, -0.250, 10.000 0.217, -0.125,
 10.000
4 -0.000, -0.250, 0.000 -0.217, -0.125, 0.000 -0.217, -0.125, 10.000 -0.000, -0.250,
 10.000
5 -0.217, -0.125, 0.000 -0.217, 0.125, 0.000 -0.217, 0.125, 10.000 -0.217, -0.125,
 10.000
6 0.000, 0.250, 0.000 -0.217, 0.125, 0.000 -0.217, 0.125, 10.000 0.000, 0.250, 10.000

Arm 1, lower part:
7 0.025, -0.550, 8.700 0.025, -0.215, 8.700 -0.025, -0.215, 8.700 -0.025, -0.550,
 8.700
8 0.025, -0.550, 8.750 0.025, -0.215, 8.750 -0.025, -0.215, 8.750 -0.025, -0.550,
 8.750
9 -0.025, -0.550, 8.700 -0.025, -0.215, 8.700 -0.025, -0.215, 8.750 -0.025, -0.550,
 8.750
10 0.025, -0.550, 8.700 0.025, -0.215, 8.700 0.025, -0.215, 8.750 0.025, -0.550,
 8.750

Arm 1, upper part:
11 0.025, -0.550, 9.250 0.025, -0.215, 9.250 -0.025, -0.215, 9.250 -0.025, -0.550,
 9.250
12 0.025, -0.550, 9.300 0.025, -0.215, 9.300 -0.025, -0.215, 9.300 -0.025, -0.550,
 9.300
13 -0.025, -0.550, 9.250 -0.025, -0.215, 9.250 -0.025, -0.215, 9.300 -0.025, -0.550,
 9.300
14 0.025, -0.550, 9.250 0.025, -0.215, 9.250 0.025, -0.215, 9.300 0.025, -0.550,
 9.300

Arm 1, vertical tube:
15 0.025, -0.600, 8.500 -0.025, -0.600, 8.500 -0.025, -0.600, 9.500 0.025, -0.600,
 9.500
16 0.025, -0.550, 8.500 -0.025, -0.550, 8.500 -0.025, -0.550, 9.500 0.025, -0.550,
 9.500
17 -0.025, -0.600, 8.500 -0.025, -0.550, 8.500 -0.025, -0.550, 9.500 -0.025, -0.600,
 9.500
18 0.025, -0.600, 8.500 0.025, -0.550, 8.500 0.025, -0.550, 9.500 0.025, -0.600,
 9.500

Arm 1, Antenna 1-1, Radome :
19 -0.075, -0.600, 8.600 -0.075, -0.650, 8.600 0.075, -0.650, 8.600 0.075, -0.600,
 8.600
20 -0.075, -0.600, 9.400 -0.075, -0.650, 9.400 0.075, -0.650, 9.400 0.075, -0.600,
 9.400
21 0.075, -0.650, 8.600 0.075, -0.600, 8.600 0.075, -0.600, 9.400 0.075, -0.650,
 9.400
22 -0.075, -0.650, 8.600 -0.075, -0.600, 8.600 -0.075, -0.600, 9.400 -0.075, -0.650,
 9.400
23 0.075, -0.600, 8.600 -0.075, -0.600, 8.600 -0.075, -0.600, 9.400 0.075, -0.600,
 9.400
24 0.075, -0.650, 8.600 -0.075, -0.650, 8.600 -0.075, -0.650, 9.400 0.075, -0.650,
 9.400

Arm 2, lower part:
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25 -0.025, 0.700, 8.700 -0.025, 0.215, 8.700 0.025, 0.215, 8.700 0.025, 0.700, 8.700
26 -0.025, 0.700, 8.750 -0.025, 0.215, 8.750 0.025, 0.215, 8.750 0.025, 0.700, 8.750
27 0.025, 0.215, 8.700 0.025, 0.700, 8.700 0.025, 0.700, 8.750 0.025, 0.215, 8.750
28 -0.025, 0.215, 8.700 -0.025, 0.700, 8.700 -0.025, 0.700, 8.750 -0.025, 0.215,
 8.750

Arm 2, upper part:
29 -0.025, 0.700, 9.250 -0.025, 0.215, 9.250 0.025, 0.215, 9.250 0.025, 0.700, 9.250
30 -0.025, 0.700, 9.300 -0.025, 0.215, 9.300 0.025, 0.215, 9.300 0.025, 0.700, 9.300
31 0.025, 0.215, 9.250 0.025, 0.700, 9.250 0.025, 0.700, 9.300 0.025, 0.215, 9.300
32 -0.025, 0.215, 9.250 -0.025, 0.700, 9.250 -0.025, 0.700, 9.300 -0.025, 0.215,
 9.300

Arm 2, vertical tube:
33 0.025, 0.750, 8.500 -0.025, 0.750, 8.500 -0.025, 0.750, 9.500 0.025, 0.750, 9.500
34 0.025, 0.700, 8.500 -0.025, 0.700, 8.500 -0.025, 0.700, 9.500 0.025, 0.700, 9.500
35 0.025, 0.700, 8.500 0.025, 0.750, 8.500 0.025, 0.750, 9.500 0.025, 0.700, 9.500
36 -0.025, 0.700, 8.500 -0.025, 0.750, 8.500 -0.025, 0.750, 9.500 -0.025, 0.700,
 9.500

Arm 2, Antenna 2-1, Sub-arm (lower part):
37 -0.032, 0.729, 8.910 -0.004, 0.757, 8.910 -0.039, 0.792, 8.910 -0.067, 0.764,
 8.910
38 -0.032, 0.729, 8.950 -0.004, 0.757, 8.950 -0.039, 0.792, 8.950 -0.067, 0.764,
 8.950
39 -0.004, 0.757, 8.910 -0.039, 0.792, 8.910 -0.039, 0.792, 8.950 -0.004, 0.757,
 8.950
40 -0.032, 0.729, 8.910 -0.067, 0.764, 8.910 -0.067, 0.764, 8.950 -0.032, 0.729,
 8.950

Arm 2, Antenna 2-1, Sub-arm (upper part):
41 -0.032, 0.729, 9.050 -0.004, 0.757, 9.050 -0.039, 0.792, 9.050 -0.067, 0.764,
 9.050
42 -0.032, 0.729, 9.090 -0.004, 0.757, 9.090 -0.039, 0.792, 9.090 -0.067, 0.764,
 9.090
43 -0.004, 0.757, 9.050 -0.039, 0.792, 9.050 -0.039, 0.792, 9.090 -0.004, 0.757,
 9.090
44 -0.032, 0.729, 9.050 -0.067, 0.764, 9.050 -0.067, 0.764, 9.090 -0.032, 0.729,
 9.090

Arm 2, Antenna 2-1, Radome:
45 0.000, 0.831, 8.600 -0.035, 0.866, 8.600 -0.141, 0.760, 8.600 -0.106, 0.725, 8.600
46 0.000, 0.831, 9.400 -0.035, 0.866, 9.400 -0.141, 0.760, 9.400 -0.106, 0.725, 9.400
47 -0.106, 0.725, 8.600 -0.141, 0.760, 8.600 -0.141, 0.760, 9.400 -0.106, 0.725,
 9.400
48 0.000, 0.831, 8.600 -0.035, 0.866, 8.600 -0.035, 0.866, 9.400 0.000, 0.831, 9.400
49 0.000, 0.831, 8.600 -0.106, 0.725, 8.600 -0.106, 0.725, 9.400 0.000, 0.831, 9.400
50 -0.035, 0.866, 9.400 -0.141, 0.760, 9.400 -0.141, 0.760, 8.600 -0.035, 0.866,
 8.600

Arm 2, Antenna 2-2, Sub-arm (lower part):
51 0.004, 0.757, 8.910 0.032, 0.729, 8.910 0.067, 0.764, 8.910 0.039, 0.792, 8.910
52 0.004, 0.757, 8.950 0.032, 0.729, 8.950 0.067, 0.764, 8.950 0.039, 0.792, 8.950
53 0.032, 0.729, 8.950 0.067, 0.764, 8.950 0.067, 0.764, 8.910 0.032, 0.729, 8.910
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54 0.004, 0.757, 8.910 0.039, 0.792, 8.910 0.039, 0.792, 8.950 0.004, 0.757, 8.950

Arm 2, Antenna 2-2, Sub-arm (upper part):
55 0.004, 0.757, 9.050 0.032, 0.729, 9.050 0.067, 0.764, 9.050 0.039, 0.792, 9.050
56 0.004, 0.757, 9.090 0.032, 0.729, 9.090 0.067, 0.764, 9.090 0.039, 0.792, 9.090
57 0.032, 0.729, 9.090 0.067, 0.764, 9.090 0.067, 0.764, 9.050 0.032, 0.729, 9.050
58 0.004, 0.757, 9.050 0.039, 0.792, 9.050 0.039, 0.792, 9.090 0.004, 0.757, 9.090

Arm 2, Antenna 2-2, Radome:
59 0.106, 0.725, 8.600 0.141, 0.760, 8.600 0.035, 0.866, 8.600 0.000, 0.831, 8.600
60 0.106, 0.725, 9.400 0.141, 0.760, 9.400 0.035, 0.866, 9.400 0.000, 0.831, 9.400
61 0.000, 0.831, 9.400 0.035, 0.866, 9.400 0.035, 0.866, 8.600 0.000, 0.831, 8.600
62 0.106, 0.725, 9.400 0.141, 0.760, 9.400 0.141, 0.760, 8.600 0.106, 0.725, 8.600
63 0.106, 0.725, 8.600 0.000, 0.831, 8.600 0.000, 0.831, 9.400 0.106, 0.725, 9.400
64 0.141, 0.760, 8.600 0.035, 0.866, 8.600 0.035, 0.866, 9.400 0.141, 0.760, 9.400

(The origin of the coordinate system is the center of the mast ground plane. The center can be defined
arbitrarily – important is only the relative location of the elements to one another).

The coordinates of all three antennas (each concentrated in a single point) in the above-mentioned
coordinate system:

Antenna 1-1: x = 0.0 mm      y = -725.0 mm  z = 9000.0 mm
Antenna 2-1: x = -141.42 mm  y = 866.42 mm  z = 9000.0 mm
Antenna 2-2: x = 141.42 mm   y = 866.42 mm  z = 9000.0 mm

The coordinates of the (geometrical) point of radiation Mgeo in the above-mentioned coordinate system
is:

xgeo = (2 × 0.0 + 1× (-141.42) + 1 × 141.42) / 4 = 0.00 mm

ygeo = (2 × (-725.0)+ 1× 866.42 + 1 × 866.42) / 4 = 70.71 mm

zgeo = (2 × 9000.0 + 1× 9000.0 + 1 × 9000.0) / 4 = 9000.00 mm
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Figure 265: 3D view of the 64 objects describing the scenario listed before.

Step 3: Computation of the Electrical Parameters
The spheroid for the computation has a radius of 1000 m. All points to be computed and all objects are
inside the spheroid. The center of the spheroid is the point Mgeo.

The transmitter power of the single antennas is according to the power splitter defined as:

• Antenna 1-1: 1.0 Watt

• Antenna 2-1: 0.5 Watt

• Antenna 2-2: 0.5 Watt

The transmitter power of isotropic radiator (used as a reference to determine the gain of the actual
antenna configuration):

(47)

The antenna patterns of antenna 1-1, 2-1 and 2-2 are already in 3D, or they must be interpolated from
2x2D to 3D.

Step 4: Computation of the Antenna Gain for Selected Directions
Only points of the spheroid are computed. In 3D mode all points on the spheroid are examined while in
the 2x2D mode the computation is done the following way:
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1. The points in the horizontal plane (including Mgeo) are computed.

2. The maximum gain in the horizontal plane is determined.

3. The points on the vertical plane, defined with Mgeo the vector of the z-axis and the vector from
Mgeo to the point with maximum gain, are computed.

4. The point with a maximum gain in the vertical pattern is determined. If this point is not in the
horizontal plane, the horizontal plane is parallel moved from Mgeo to this point with maximum
gain, and the horizontal pattern is recomputed in this plane.

The computation is made in the coordinate system defined in step 2.

An arbitrary point P has the coordinates (xP,yP, zP) and is on the spheroid used for the computation. The
difference vector δ between P and Mgeo is defined as:

(48)

Standardized to a length of 1 m this leads to the vector Δ

(49)

Point P and vector  described in the 3D antenna pattern the following azimuth α and tilt ϑ:

(50)

(assuming the x-axis is equal to 0°, and the y-axis is equal to 90°).

(51)

(assuming 0° is equal to the positive z-axis and 90° is horizontal plane)

For the computation of the first horizontal pattern, ϑ is equal to 90° and α is incremented between 0°
and 360°. For the computation of the vertical pattern, α is equal to 0° and ϑ is incremented between 0°
and 180°. In 3D computation mode, both angles must be incremented to sample all directions.

Step 4-A: Field Strength of Isotropic Radiator (Reference Value)
The field strength of the isotropic radiator at the point P is used as a reference. The isotropic radiator is
located at Mgeo and has the coordinates (xgeo, ygeo, zgeo).

To get the field strength, the following steps are required:
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• Distance d between P and Mgeo (using Pythagoras)

(52)

• Computation of power density Siso at point P

(53)

with Pt0 describing the sum of all transmitted antenna powers.

• Computation of the effective electric field strength Eiso at the pixel P based on the power density
Siso and the impedance of the free space ZF0 = 120 πΩ

(54)

Step 4-B: Field Strength of the Configuration (Actual Value)
For each antenna, the measured field strength in the point P is determined. The computation is similar
to the computation for the isotropic radiator.

• Distance d between P and radiation center of the antenna (xant, yant, zant)

(55)

• Computation of power density Sant of the direct ray at point P

(56)

with Ptant representing the Tx power of the antenna.

• Computation of effective electrical field strength Ean-FSt at P based on power density Sant and
impedance of free space ZF0 = 120 πΩ

(57)

• Computation of penetration / transmission loss LT .

• Subtraction of penetration / transmission loss LT leads to actual received electric field strength at
point P (based on direct ray):

(58)

Depending on the path length d and the frequency f, the phase φ of the signal is determined (with
wavelength λ and velocity of light c0):

(59)

• Additionally, the computation of reflected rays is possible.

For the computation of reflected rays, each object is examined whether a reflection is possible or
not.
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Additionally, the penetration / transmission must be considered if the reflected ray intersects
further.

If the reflected rays exist (point of reflection Q is inside the object), this leads to the power density

(60)

with Ptant representing the transmitter power of the antenna.

P2

Wall

P1

Q
r1

r2

Figure 266: Computation of the angle of reflection.

• Computation of the effective electric field strength Ean-FSt at point P based on power density Sant
and impedance of free space ZF0 = 120 πΩ:

(61)

• The contributions of the direct and reflected rays are superposed considering their phases:

(62)

• Computation of the reflection loss LR of the reflected ray.

• Computation of the transmission/penetration loss  LT of the reflected ray.

• Subtracting the transmission loss LT and the reflection loss LR leads to the received field strength at
point P (on the basis of the reflected ray):

(63)

Depending on the path length d of the reflected ray and the frequency f (and wavelength λ), the
phase j of the reflected ray is determined by the velocity of light c0:

(64)

For each reflection (nR reflections are in the ray), an additional phase shift of 180° is added.

These rays are determined for each antenna, and all rays are superposed with the equation above. The
total field strength  EAnt is the magnitude of the coherent (including phase) superposed field strengths
of the rays of the individual antennas.
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Step 4-C: Computation of the Gain for a Single Direction
The antenna gain GP at point P is the quotient of the actual field strength and the field strength of the
isotropic radiator at point P:

(65)
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5.3 Using AMan

5.3.1 Overview
The program is based on the document / view architecture which separates program data from their
representation. Different views are used to represent the different antenna patterns.

A document represents the entity that the user opens with the instruction Open from the menu File
and stores with the instruction Save from the same menu. However, a view is assigned to a document
and works between the document and the user as an interface. The view represents an image of the
document on display and interprets the inputs of the user as processes for the document. The view also
creates figures for printing and the preview.

This program is considered an MDI-application (multiple document interface). It means that several
documents can be opened and each document appears in its child window. A new item of the document
class is generated for each new document opened.

The main window presents the window framework, a header with the title and a menu and a symbol
bar. It contains no views windows rather than it only frames the work area. The view window of the
respective documents is displayed in the child window frameworks.

Figure 267: AMan: Documents and Views

1. Main frame

2. Symbol bar

3. Status bar
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4. View window

5. Child window

5.3.2 2D Antenna Patterns

Types of Antenna Patterns
Two types of 2D antenna patterns can be visualized in 2 modes with AMan:

• Horizontal Patterns

◦ Logarithmic display scale

◦ Linear display scale

• Vertical Patterns

◦ Logarithmic display scale

◦ Linear display scale

Antenna patterns are represented with many (sample) points representing the gain in different
directions.

Horizontal Antenna Patterns
The 2D horizontal pattern is displayed with top view. The angle stretches from 0 to 360° and is oriented
counter-clockwise.

The direction of 0° is describing the direction with maximum gain. But this is not mandatory. Also, other
directions can be used. But as the direction of 0° is often visualized in radio planning tools, it helps the
network planner if the main energy is also radiated in this direction.

Table 23: File extensions of the horizontal antenna patterns.

Extension Meaning

.ahb Antenna pattern horizontal binary

.aha Antenna pattern horizontal ASCII

Vertical Antenna Patterns
In the 2D vertical pattern, the angle stretches from 0 to 360° and is oriented clockwise. 0° is to the sky,
and 180° is down to the bottom. 90° (and 270°) represents the horizontal plane.
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Table 24: File extensions of the vertical antenna patterns.

Extension Meaning

.avb Antenna pattern vertical binary

.ava Antenna pattern vertical ASCII

Display Settings of Antenna Patterns
Patterns are represented with many points defined in spherical coordinates.

The user can open a 2D antenna pattern via the menu File and item Open Antenna Pattern.... It is
displayed directly after loading.

Creating a New Antenna Pattern From a Scanned Data Sheet
Scan the graphical representation of a measured radiation pattern (for example, pattern given in a
datasheet) to .bmp format to create a new antenna pattern.

Step 1: Loading the Background Bitmap
Create a new antenna pattern based on a graphical representation of the measured radiation pattern.

Figure 268: An example of a 2D antenna pattern (measured or from a data sheet).

To generate this pattern fast, the figures of the patterns should be scanned. The scanned bitmap should
be saved in .bmp format (standard bitmap).
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Then you have to generate a new pattern via the menu File and the item New 2D Antenna Pattern.

Using Bitmap > Import Bitmap, you have to select the scanned bitmap of the measured radiation
pattern.

Figure 269: Generating a new 2D pattern.

Now the bitmap is displayed on the screen and the pattern can be drawn onto the bitmap after
adjusting the coordinate system of AMan to the system of the scanned bitmap.

An example of such a bitmap is distributed together with the AMan software package.

Figure 270: Loading the bitmap.

Figure 271 shows the display after importing the bitmap. Note that the coordinate systems do not
match.
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Figure 271: Display after bitmap was imported.

The bitmap can be processed with different operations to adapt it to the display of AMan.

First, the bitmap can be moved via the menu Bitmap > Move Bitmap or by using the  icon in the

toolbar. The bitmap can then be moved by clicking with the left button of the mouse on the point of the
bitmap (for example, the center of the pattern) and then (while the button is still pressed) moving the
mouse pointer to the corresponding point of coordinate system of AMan.

Figure 272: Display after bitmap was moved (center of coordinate systems match).
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The bitmap can be scaled to enlarge it (if it was very small) or to resize it in any direction. This is done

using Bitmap > Zoom factor for bitmap or the  icon can be clicked in the toolbar.

After this selection, the following dialog opens:

Figure 273: Scale / zoom factor for display of bitmaps.

You can enter the scale / zoom factor and can resize the bitmap. After entering a new factor of 150%
the display changes from Figure 272 to Figure 274.

Figure 274: Display of bitmaps after scaling the bitmap.

Of course, the bitmap can be restored to its original size with the icon  from the tool-bar or via the

menu Bitmap > Original size of bitmap.

The bitmap can be hidden via the icon  from the toolbar or via the menu Bitmap > Display

bitmap.

Step 2: Adaptation of the Coordinate System of AMan to the
Background Bitmap

To adapt the coordinate system to the bitmap, several steps are required:

• Move the center of the pattern on the bitmap to the center of the coordinate system (as described
in step 1).
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• Select either linear or logarithmic representation of the diagram with the settings.

• Define the maximum and minimum gains of the display of the pattern.

Figure 275: Display of bitmap and AMan matched.

• An exact adjustment enables a stretching and compression of the diagram. By clicking with the left
mouse button on the outermost circle of the coordinate system, the system can be moved while the
key is pressed. Further scaling can be made by shifting the most inner circle in the same way.

• Finally, the coordinate system can be rotated (if required). This is enabled by clicking with the left
mouse button on one of the diagram axes. If the key is pressed , the coordinate system is rotated

according to the mouse movements. Rotations with 90° can be done using the  tool.

Now the coordinate system is defined properly, and the pattern can be drawn.

Graphical Input of a New 2D Antenna Pattern
After a new pattern is created (with or without bitmap), you must first decide if it is a vertical or a
horizontal pattern. This is asked after clicking with the mouse button anywhere in the display.

Figure 276: The Select type of antenna pattern dialog.

You can define the gains in different directions by clicking with the right mouse button on the screen.
This action inserts points with defined angle / gain relation (see Figure 277 and Figure 278).
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If the mouse cursor is located on a point already defined and if the right mouse button is clicked, a
context menu appears to ask if the already defined value should be deleted (as it is not possible to
define to different gains for the same angle).

With the left mouse button points already defined can be moved (while the button is pressed). The
point currently selected is automatically changed to the current mouse position if the limitation of the
angle in the settings is not enabled. If it is enabled, only the selected point is modified.

A higher drawing accuracy enables an increase of the zoom factor or the use of the zoom window. All
tools related to zoom operations can be found in the menu View or the zoom toolbar:

In the Edit menu an UNDO function is available. If a point is drawn incorrectly, you have the option to
remove it from the list via the UNDO command.

Especially if patterns are generated by the user (either drawn manually or entered numerically), many
points are not defined. To increase the accuracy (especially for 2x2D to 3D interpolation), you can
interpolate the pattern. The angle increment after the interpolation between the pixels can be defined in
a dialog.

Figure 277: Inserting sample points to describe the antenna pattern (display with bitmap).
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Figure 278: Inserting sample points to describe the antenna pattern (display without bitmap).

Table Based Input of a New 2D Antenna Pattern
After a new pattern is created (with or without bitmap), you must first decide if it is a vertical or a
horizontal pattern. This is asked after clicking with the mouse button anywhere in the display.

Figure 279: The Select type of antenna pattern dialog.

Figure 280: Insert a new gain / angle combination.

If the pattern is available in a table, the angles and gains can be numerically defined via a dialog. The
gain can be defined in different directions via the menu Edit and the item Insert new points.
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Avoid a multiple definitions of different gains for the same angle. This could lead to misinterpretation of
your data. Within the dialog, the last inserted point can also be removed again.

Figure 281: The Insert new point dialog.

Often user defined patterns (drawn manually or entered numerically) have many points that are not
defined. To increase the accuracy (especially for 2x2D to 3D interpolation), you can interpolate the
pattern. The angle increment after the interpolation between the pixels can be defined in a dialog.

Edit and Modify Points in 2D Antenna Patterns

Move Points
Points can be moved after clicking with the left mouse button on a point and while the button is
pressed, the mouse is moved to the new location of the point. After the button has released, the point
is moved to this location.

During the mouse movement, the angle can either be limited to the sector between the two adjacent
points or the point can be substituted with the neighboring one if the angle sector of the neighboring
point is reached. The current setting is defined with the Limitation for Angle check box in the
Settings dialog.

UNDO for movements is possible and is available in the menu Edit > Undo move point.

Insert New / Additional Points
Points can either be inserted graphically by clicking on the corresponding area in the display with the
right mouse button or numerically in a dialog.

Delete Points
To delete a point it must be selected with the right mouse button by clicking on it. A context menu will
appear and ask if the points should be deleted or not.

Edit and Modify 2D Antenna Patterns

Rotate Pattern
The values in the pattern can be rotated via the menu Edit > Rotate pattern. After selecting this
menu item, the following dialog appears:
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Figure 282: Settings for rotation.

You can now rotate the values in the pattern. This is especially important if non-WinProp file formats are
imported and their coordinate systems have a different orientation (for example, in the vertical pattern
the 0° is in the horizontal plane and 90° are towards the ground. Then the whole pattern can be rotated
with –90° to have it in the WinProp format).

Figure 283: A vertical antenna pattern before it was rotated.
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Figure 284: Rotating a vertical antenna pattern with +90°. The values are rotated and coordinate system was kept.

Interpolate Pattern
Often when patterns are user generated (drawn manually or entered numerically), many points are not
defined. To increase accuracy (especially for 2x2D to 3D interpolation), the pattern can be interpolated.
The angle increment after the interpolation between the pixels can be defined in a dialog.

Figure 285: Options for the interpolation of an antenna pattern.

An example of interpolation:
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Figure 286: No interpolation of antenna pattern.

Figure 287: Interpolation of an antenna pattern.

5.3.3 2x2D Antenna Patterns

Types of Antenna Patterns
2x2D antenna patterns contain the vertical and the horizontal pattern in the same file. This is often
used in commercial file formats of the antenna manufacturers.

The file extensions of the 2x2D antenna patterns are:

Extension Meaning

.msi MSI Planet file format
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Extension Meaning

.pln PLANET file format (identical to .msi)

Working with 2x2D Antenna Patterns
If 2x2D antenna patterns are opened via the menu File > Open Antenna Pattern, AMan opens two
documents / windows. One window displays the 2D horizontal view, and one window displays the 2D
vertical view.

All operations for the 2D view can be applied to the documents. The antenna patterns can also be saved
after the modifications.

But it must be mentioned, that each pattern (either vertical or horizontal) is saved separately in a file in
the 2D antenna file format of WinProp.

2x2D antenna patterns can also be loaded and directly displayed as a 3D pattern.

In the File menu, the Convert MSI to 3D (for .msi and .pln) command loads the 2x2D pattern and
compute the 2x2D to 3D interpolation. So the pattern will be displayed in the 3D view.

5.3.4 3D Antenna Patterns

3D antenna patterns describe the radiation of the electromagnetic wave in all directions. 3D patterns
are often available from the manufacturer of the antenna. If not, it can be interpolated based on the
horizontal and vertical 2D patterns.

Hardware and Software Requirements: OpenGL
Microsoft Windows 7 and 10 contain special drivers for fast drawing three-dimensional graphics. This
interface is called OpenGL and is a standard for 3D data representation.

OpenGL is itself a programming language which describes objects in the three- dimensional space
with their graphic primitives (point, line, triangle). More complex bodies can be realized from those
primitives.

AMan uses OpenGL. So the computer must have installed OpenGL to be able to show the 3D patterns.
If problems with the 3D display occur, all (hardware) accelerations of the graphics adapter should be
disabled in the system control section (display adapter settings).

Load Patterns From a File
Loading a pattern from a file is possible using the menu File > Open Antenna Pattern.

The file extensions of the 3D antenna patterns are:
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Table 25: File extensions of 3D antenna patterns.

Extension Meaning File Format Description

.apb Antenna pattern binary not published

.apa Antenna pattern ASCII See ASCII File Format for 3D
Patterns.

.ffe Antenna pattern ASCII See the Feko User Guide for

more information[17].

Display of 3D Patterns
After the 3D antenna pattern is read, you must define the settings for the display.

The same dialog is shown after clicking the Scale button on the control panel. So the settings can also
be adjusted later.

First, the coordinate system must be selected used for the display. This is similar to the 2D pattern
mode.

The second radio button selects if the pattern is displayed relative to the maximum gain of the pattern
or if absolute gain values (in dBi) are displayed.

The scale can be defined in the third section. Maximum and minimum gain can either be auto-scaled or
manually defined. For information, the maximum and minimum gain in the file is also displayed, so you
can see which range is required to get a correct impression of the pattern.

17. View the appendix in the Feko User Guide - Summary of Files > Far Fields (.FFE).
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Figure 288: 3D antenna pattern.
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Functions of the Control Panel

Figure 289: 3D control panel.

With the help of the control panel the display of the antenna pattern can be controlled:

• The selection of the color to lighten the object is important to emphasize details. Dark colors should
be selected. Since the standard color of the surface of the objects is red, the result on the display
will not correspond exactly to the selected color (it is a mix of red and the selected color).
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Figure 290: Different colors.

• The background color used is always identical to the color selected (no color mix). While for the
printing of the graph, a white background is reasonable, a more impressive result can be obtained
with dark backgrounds.

Figure 291: Different background colors.

• To draw the antenna pattern with a wire frame, check the Wireframe check box.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
5 AMan p.302

Figure 292: Same colors – but wire frame enabled (left) and disabled (right).

• To draw the antenna pattern with filled surfaces instead of a wire frame, check the Surface check
box.

Note:  If filled objects are selected, the computing time increases.

Figure 293: Same colors – but filled surfaces enabled (left) and disabled (right).

• The program displays the type of scale selected (logarithmic or linear).
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Figure 294: Everything identical except the linear (left) and the logarithmic scale (right).

• All scale settings can be defined by clicking on the Scale button.

• Resolution of the display. The finer the value, the slower the display. A value below 1° makes no
sense as the finest resolution in the pattern itself is 1°. To accelerate the display the values can be
set to 5°. This has no influence on the data itself and its accuracy saved in the file.

Figure 295: Everything identical except the angle increment: 1° (left) and 5° (right).

• The pattern can be displayed either in 3D mode, or the vertical and horizontal planes can be
displayed. The user has to select the view with the radio button.
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Figure 296: Vertical plane.

Figure 297: Horizontal plane.
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Figure 298: 3D view

• The user can select if the pattern and the coordinate system should be displayed or not. This is
especially important for the MASC module.

• You can export the display to a bitmap.

Conversion From 2x2D Pattern Data to 3D Pattern
A 3D antenna pattern can be loaded from a file and displayed (see sections before), or it can be
interpolated from a vertical and a horizontal pattern.

All four algorithms presented in this section are included in AMan and can be selected by the user.

Figure 299: The Selection of conversion algorithm dialog.

For such a conversion the increments between the values to be interpolated can be defined to control
the accuracy, the file size and the computation time.

The conversion is possible with:
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• WinProp 2D antenna patterns

File > Convert 2x2D to 3D. Only binary files with the extensions .ahb (horizontal) and .avb
(vertical) can be used.

• MSI / PLN antenna patterns: File > Convert MSI to 3D.

• Customer-defined antenna patterns: File > Convert Customer to 3D. This file format supports
special formats of the customer (only if desired).

After selecting the settings of the conversion, the file(s) to be converted must be selected. Then the file
is read, the conversion is computed, and the pattern is displayed in the 3D view.

Figure 300: Converting 2x2D pattern in the 3D view.

2x2D antenna patterns can be loaded as well as 3D patterns. But the pattern will always be displayed in
3D view.

Generation of Antenna Patterns for 5G
Import antenna patterns and combine the patterns to use in 5G network planning.

Beamforming in 5G
In 5G wireless communication, base-station antennas may be antenna arrays that can form beams that
point at specific mobile stations. Depending on the beamforming technology, these antenna arrays may
have a limited set of directions in which a beam can point. Figure 301 shows an example of two possible
beams out of a finite set.
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Figure 301: Examples of beam patterns achieved with phased arrays at a base station (top view).

In 5G network analysis, other than simulating with isotropic antennas and correcting for gain, two
strategies exist to include the antenna patterns in the simulation.

1. Strategy one is to avoid the problem of specifying which beams are active and to work instead
with the envelope pattern of all possible beams. This assumes that the base station’s beam
switching logic is working well, so any mobile station is served with the best beam for its location.
An example of an envelope pattern is shown in Figure 302.

Figure 302: Envelope antenna pattern for a set of four beams (usually the set would be larger).

2. Strategy two is to specify the individual beams. This is usually combined with a Monte-Carlo
analysis in which the positions of individual mobile stations are varied.

The specification of envelope patterns and individual beams is accommodated in AMan by two
features:

a. Convert to beams and envelope patterns

File > Convert to beams and envelope patterns is useful when the antenna patterns of
the individual beams are available in individual antenna-pattern files, for example, from a
simulation or a measurement. The Convert to envelope and individual beam patterns
dialog enables you to select the files that contain the patterns of the control beams and data
beams. The contents of the files are combined into larger files with the appropriate formats.
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Figure 303: The Convert to envelope and individual beam patterns dialog.

b. Generate beams and envelope patterns

File > Generate beams and envelope patterns is useful when the patterns of individual
beams are not readily available. The Generate envelope and individual beam patterns
dialog requires input data as shown in Figure 304.

Figure 304: The Generate envelope and individual beam patterns dialog.

User-defined beams can be specified using the following options (applicable to both Control
Beams and Data Beams):

• In the fields for gain and beamwidth, specify a single value per field which will be
applied to all beams.
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Figure 305: Example 1: for the Control Beams, a single value is applied
to both the azimuth and elevation beams (similar for Data Beams).

• Specify multiple values in the azimuth domain.

Note:

◦ The number of values for gain and horizontal beamwidth must equal the
number of azimuth beams.

◦ The same values are applied to the elevation domain.

Figure 306: Example 2: for the Control Beams and Data Beams, three values are entered for
the gains and three for the horizontal beamwidths. These govern the horizontal distributions.

• Specify multiple values in the azimuth and elevation domain.

Note:

◦ The number of values must equal the total number of beams
(elevation*azimuth).
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Figure 307: Example 3: for the Control Beams, four values are entered
for the four beams (two beams in azimuth and two in elevation).

In both cases, .ffe files with 5G-specific antenna pattern information are written to disk and can
be used by ProMan.

Generation of Antenna-Array Radiation Patterns
Define the array elements with optional amplitude tapering, and generate the radiation pattern to use in
any ProMan project, for example, for a 5G base station or for a radar.

Array Tool Options
Choose File > Antenna Array Tool to bring up the Antenna Array Tool dialog (see Figure 308).
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Figure 308: The Antenna Array Tool dialog.

The antenna array is rectangular.

Base Element

Isotropic and Dipole
These options enable you to add a reflecting plate at a quarter-wavelength distance, as is
commonly used, to produce a beam in one direction and avoid a backlobe of equal strength.

External
This option enables you to select a unit-cell antenna patterns from Feko in .ffe format.

Amplitude Taper
Uniform, Triangular, Cosine-shaped, Dolph-Chebyshev

Triangular and Cosine-shaped tapering will reduce the side-lobe level relative to Uniform
excitation. These three cases have in common that side lobes far from the main beam will be
lower than those close to the main lobe. With Dolph-Chebyshev tapering you can choose the side-
lobe level, upon which all side lobes will obtain that level.

Antenna Array Plane
XY Plane (the array is horizontal and radiates in vertical directions) or XZ Plane (the array is
vertical and radiates mainly in horizontal directions).

When you assign this pattern later in ProMan to a transmitter or receiver, in the Cell dialog under
the Sites definition, you can adjust its azimuth and elevation.
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Tip:  The relation between beam scan angle θ and antenna element phase shift ϕ is:

(66)

where λ is the wavelength and d is the element spacing. In case d = λ/2, as is often the
case in arrays, this simplifies to:

(67)

For a scan angle of 30° off boresight in one of the principal planes, the phase shift along the
corresponding axis has to be 90°.

Array Tool Calculation
The calculation is based on the product of a single-element antenna pattern and an array factor.

The single-element isotropic pattern has uniform directivity in all directions. For the single-element
dipole pattern, analytical equations are used. This has two consequences:

1. the neighbor-cell coupling is not included in the single-element dipole pattern

2. if the dipole length equals the element spacing, the dipole won’t physically touch a neighbor

As for the external base element, if you use a unit-cell antenna element pattern from a Feko project
with periodic boundary conditions, then neighbor-cell coupling will be included.

The array factor is based on number of elements, element spacing, phase shift, and amplitude taper.
No distinction is made between antenna elements near the center and near an edge of the array. This is
customary in this type of calculation where the full-wave analysis of the complete array is avoided.

When clicking OK, you are prompted for a name and a location for the resulting .ffe file. The file is
written to disk; the pattern is not automatically displayed. Use File > Open in the main AMan menu to
load the file and inspect the pattern.

5.3.5 MASC Module
MASC (multiple antenna scenario configuration) module allows for realistic antenna patterns to be
generated using superpositioning of multiple antenna that radiates the same signal. The module also
considers the local environment (for example, masts, arms, walls, tubes, and sub-arms) in the solution.

General Concept
MASC is fully integrated into AMan.

Project File Versus Antenna Pattern
You have to define the scenario and the antennas used in the configuration together with all other
parameters. All these settings are saved in a project file with the extension, .ank.

The menu File > New Multiple Antenna Config allows the user to initiate a new MASC project.

With File > Save and Save as allows you to save the project in a, .ank file.
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A MASC project can be loaded using the menu File > Open Multiple Antenna Config.

Figure 309: Handling of MASC projects.

The MASC project (.ank) and the resulting antenna pattern are different files.

In the MASC project, only the configuration is described. The resulting antenna pattern is independent
of the project settings and must be saved separately by means of the menu Multiple Antenna
Config > Save Antenna Pattern.

In the menu, Multiple Antenna Config the item Save Scenario (3D Indoor Data) is also available.
With this item, the generated objects (masts, walls, arms, radomes) are exported in WallMan data
format to be further processed and analyzed with WallMan.

Figure 310: Saving antenna patterns.

Main Settings
After the project is initiated or loaded, the general 3D view appears with two additional control
elements, see Figure 311.

View  group, Objects check box
The drawing of the objects (wall, mast, arms, radomes) can be enabled or disabled. If displayed
this helps to understand the configuration and if not displayed it helps to analyze the details of
the pattern computed by MASC.

Configuration button
With this button, the dialog to define the configuration is called.
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Figure 311: Control panel in MASC mode.
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Figure 312: Main settings of MASC configuration.

The main settings contain the following blocks:

Scenario
Here you can select if a mast configuration or a configuration in front of a wall is computed.

Basic Geometry
Here the geometrical properties of the mast or the wall (depending on the scenario, see above) must be
defined:

• Mast
The height of the mast and its diameter must be defined. And the number of corners to be
used to approximate the circular cross-section with a polygon.

• Wall

The length of the wall must be defined (Wall is squared. The length applies therefore to all
wedges). And the rotation of the wall. 0° means the wall is parallel to a vector from west to
east and perpendicular to a vector from north to south. As the north is always assumed to be
0°, the wall can be rotated against the arms.
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Arms
In this area, the user can add arms to the mast or wall (depending on the scenario). Or arms can be
deleted if they are no longer required.

Of course, it is also possible to edit the properties of an arm.

The number of arms supported is only limited by the RAM of the PC.

Output (Computed Pattern)
The type of output pattern can be defined. Either the very fast computed 2x2D pattern or the full 3D
pattern can be computed.

Additionally, a filter can be enabled to smooth the resulting pattern. The order of the filter can also be
defined.

For debugging purposes, a log file can be enabled.

The resolution of the resulting pattern can also be defined. The finer the resolution, the longer the
computation time and the more accurate the result. Resolutions below 1° are not possible.

Computation Parameters
To consider the phase correctly when superposing the signals), the frequency must be defined here.

Additionally, the consideration of reflections for the mast configurations can be enabled. This extends
the computation time – but improves the accuracy. In the wall configuration, the reflections are always
determined.
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Properties of Arms
Define the properties of the antenna arm.

Figure 313: Settings of an arm in the MASC configuration (red part only visible if the arm is mounted at a wall).

Geometry of Arms
The arm is not a single arm. It is doubled, and the two parts (both marked with A in the figure) are
vertically mounted above each other.

The distance between the two mounting points can be defined in the Geometry section of the dialog
together with the length of the arms.
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Figure 314: Arms (A) mounted at a mast (M).

The height parameter is used for relative vertical adjustment of the antennas at the mast or wall.
Especially the differences between the heights of the arms are more important than the absolute
values.

The azimuth of the arm must be specified. 0° is north, 90° is east. Orientation is clockwise.

In wall configurations, you must specify the distance between the antenna and the wedge of the wall
additionally.

Geometry of Tube
The tube can either have a rectangular cross-section or circular cross-section (to be approximated with
a polygon with a user-defined number of corners).

The length of the tube must also be specified. The tube is always vertically centered between the two
arms.

Material Properties
The material properties of the arms and the tube are assumed to be identical and can be defined via the
Material button in the Material Properties section.

Figure 315: Material properties of arms and tube.
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Figure 316: Material properties to be defined for arms and tube.

Antennas
In the antenna section, different antennas can be added to the arm / tube. Or they can be deleted and
removed from this arm. And of course, it is possible to edit the properties of the antenna.

Properties of Antennas, Sub-Arms, Radomes
For each antenna, define the antenna pattern, orientation, electrical properties, sub-arm properties en
radome properties.

Figure 317: Properties to be defined for each antenna.

Antenna Pattern
Here you can select the antenna pattern of the antenna as provided by the manufacturer (measured
including radome but without masts or tubes). Multiple antenna scenario configuration (MASC) supports
only the 3D WinProp binary antenna format. Many different formats (for example, .msi, .pln, .dat)
can be converted into WinProp’s binary format with AMan.
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Orientation
You must specify the azimuth or the antenna relative to the arm. An angle of 0° means the antenna’s
main radiation is radial to the arm. An azimuth of 90° must be used for skew configurations.

Additionally, the down tilt of the antenna must be defined. Positive values mean down tilt, negative
values lead to up tilt.

Electrical Properties
The phase offset of the antenna relative to other antennas must be defined here as well as the relative
power. The absolute magnitude of the relative power is not relevant. Only the relation to the power
values of the other antennas used in this configuration. If a power value of 2 is assigned to the first
antenna and a value of 10 to the second antenna, this means that a power splitter of 1:5 is used for
feeding the antennas.

Figure 318: Different azimuths for antennas (left: 0°, right: +90°).

Figure 319: Different azimuths for antennas and their influence on the
pattern (both configurations have power splitter 1:1 and phase offset 0°).
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Figure 320: Different downtilts for antennas (left: 0°, center 5°, right: +10°) and
their pattern (both configurations have power splitter 1:1 and phase offset 0°).

Figure 321: Different sets of power splitters and phase shifters for the same antenna configuration and
their influence on the resulting antenna pattern. On the left: 0° phase shifter 1:1 power splitter; in

the middle: 0° phase shifter, 1:3 power splitter and to the right: 90° phase shifter, 1:1 power splitter.

Sub-Arm Properties
The user can decide if the two sub-arms between the tube and the antenna itself are modeled or not.

Figure 322: Modeling with (left) and without (right) sub-arms.

The length and the diameter of the sub-arms can be defined. And the vertical separation of the sub-
arms (for example, the distance between the mounting points) can be defined. Of course, the material
properties can be defined.

Radome Properties
The radomes must be specified. Two different types of radomes are supported:
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• Cylinders with a circular ground plane

• Cuboids with a rectangular ground plane

Figure 323: Example for the radome of an omnidirectional antenna (a) and a sector antenna (b).

The type of the radome (circular versus rectangular) must be selected. And the height as well as the
geometry of the radome (for example, diameter, width). For circular radomes, the number of corners
to approximate the circle can be defined (the higher, the more accurate – but also the longer the
computation times).

Of course, the material properties of the radome can also be defined (as already known from the arms
and sub-arms. The shielding of the radome is not considered for this antenna – as it is already included
in the antenna pattern of this antenna. But its shielding is considered for all other antennas.

Computation
The antenna pattern is automatically calculated by the multiple antenna scenario configuration (MASC)
module once antenna patterns are added.

If the main dialog of the MASC settings is confirmed with OK, the computation starts.

Once the computation is done, the result is displayed.

Note:  Depending on the scenario and computation mode, the calculation could take some
time
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Display Options
The display of 2x2D antenna patterns is similar to the display of the 3D antenna patterns.

If only 2x2D instead of 3D is computed, the horizontal and vertical pattern can be displayed. The 3D
pattern is not displayed. This 3D pattern view is only possible if the 3D computation is available.

File Commands (Save, Load, Export)
MASC project settings can be saved, loaded and exported.

The MASC project settings are saved with the File > Save menu and loaded with the File > Open
Multiple Antenna Config.

The MASC project (.ank) and the resulting antenna pattern are different files. In the MASC project, only
the configuration is saved and described.

The resulting (computed) antenna pattern (.apb) is independent of the project settings (.ank) and
must be saved separately via the menu Multiple Antenna Config > Save Antenna Pattern to be
used in other radio network planning tools.

Figure 324: Saving antenna patterns.

In the menu, Multiple Antenna Config the item Save Scenario (3D Indoor Data) is also available.
With this item, the generated objects (for example, masts, walls, arms, radomes) are exported in
WallMan data format to be further processed and analyzed with WallMan. This might be interesting
when the material properties must be selected or if further analysis with ray-tracing tools is required.

5.3.6 File Formats
2D patterns (horizontal or vertical) and 3D patterns can be described using ASCII file formats.

ASCII File Formats for 2D Patterns
Describe a horizontal or vertical antenna pattern using an ASCII file format.

ASCII files describing either the horizontal or vertical antenna pattern can be read with any ASCII text
editor and with AMan. These files are therefore ideally suited to exchange information about antenna
patterns with any other software package.

Two file types are supported:
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Table 26: File extensions for a 2D antenna pattern in ASCII format.

Extension Meaning

.aha Antenna pattern horizontal ASCII

.ava Antenna pattern vertical ASCII

Table 27: Example of a 2D antenna pattern in ASCII file format.

.ava .aha

* Comments
* The number of pairs
16
*  Theta  Attenuation
   0.00     -18.00
   15.00    -20.00
   30.00    -22.80
   50.00    -27.00
   55.00    -32.00
   90.00    -37.00
   120.00   -32.00
   150.00   -27.00
   180.00   -30.00
   190.00   -40.00
   245.00   -30.00
   255.00   -28.00
   270.00   -24.50
   285.00   -22.00
   300.00   -20.50
   330.00   -18.00

* Comments
* The number of pairs
16
*   Phi   Attenuation
   0.00     -18.00
   15.00    -26.12
   30.00    -32.72
   45.00    -37.23
   55.00    -39.12
   90.00    -39.72
   110.00    39.12
   140.00   -37.23
   180.00   -38.48
   210.00   -39.86
   240.00   -38.61
   250.00   -37.80
   270.00   -35.07
   285.00   -31.24
   300.00   -27.63
   330.00   -18.00

In .ava and .aha files, the first value after the comment lines, which may begin either with * or #, is
the number of the following pairs of values.

The pairs must be in one line and always consist of an angle and a gain information. No information
about phases is stored. A new pair must be in a new line.

The pairs must neither be ordered specially nor they must have a constant angle increment. All
undefined angles are interpolated (if required during computation).

Angle information is stored in degrees and the gain/attenuation in dB. The gain/attenuation is relative
to the isotropic radiator, and positive values indicate higher gain (compared to iso) and negative values
indicate attenuation (compared to iso).
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ASCII File Format for 3D Patterns
Describe a 3D antenna pattern using an ASCII file format.

The ASCII files can be read with any ASCII text editor and with AMan. Therefore, these files are ideally
suited to exchange information about antenna patterns with any other software package.

The following file is supported:

Table 28: File extensions for a 3D antenna pattern in ASCII format.

Extension Meaning Further
Information

.apa Antenna pattern ASCII See 3D
Antenna
Patterns.

The first character in a line defines comments. If a line starts either with “# ”or “*”, AMan assumes a
comment line.

The triples must be in one line and always consist of two angles (horizontal and vertical) and one gain
information. No information about phases is stored. A new triple must always be in a new line (one line
can only contain one triple).

The triple must neither be ordered nor must they have a constant angle increment. All undefined angles
are interpolated (if required during computation).

Angle information is stored in degrees and the gain / attenuation in dB. The gain/attenuation is relative
to the isotropic radiator, and positive values indicate higher gain (compared to iso) and negative values
indicate attenuation (compared to iso).
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Figure 325: Example for ASCII antenna patterns (3D).

Example for ASCII antenna patterns (3D):

* Comments
* Comments
*
*  Theta       Phi                  Attenuation
*  Vertical     Horizontal           relative to iso

   0.00        0.00                  -17.9900
   0.00       40.00                    -17.9900
   0.00       80.00                    -17.9900
   0.00      120.00                    -17.9900
   0.00      160.00                    -17.9900
   0.00      200.00                    -17.9900
   0.00      240.00                    -17.9900
   0.00      280.00                    -17.9900
   0.00      320.00                    -17.9900
   40.00       0.00                  -19.3000
   40.00      40.00                    -20.4500
   40.00      80.00                    -20.3400
   40.00     120.00                    -20.0000
   40.00     160.00                    -19.5600
   40.00     200.00                    -19.7600
   40.00     240.00                    -19.9600
   40.00     280.00                    -19.7100
   40.00     320.00                    -19.0300
   70.00       0.00               `  -23.8800
   70.00      40.00                    -24.5100
    ……
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6 ProMan

The ProMan component includes wave propagation models for different scenarios and network planning
simulators for various air interfaces.

This chapter covers the following:

• 6.1 Introduction to Propagation Manager (ProMan)  (p. 328)

• 6.2 Propagation Projects  (p. 434)

• 6.3 Network and Base Station Planning Projects  (p. 621)

• 6.4 MIMO Analysis Through Post-Processing  (p. 700)

• 6.5 Results  (p. 709)

• 6.6 Addenda  (p. 761)
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6.1 Introduction to Propagation Manager (ProMan)
Predict path loss between transmitter and receiver with ProMan. Perform network planning including
the wireless standards (the air interfaces) and including multiple transmitters/receivers (multiple base
stations).

The ProMan software package is designed to predict the path loss accurately between transmitter
and receiver including all important parameters of the mobile radio channel. Propagation models for
rural, urban, and indoor scenarios are available as well as the unique CNP mode for hybrid scenarios.
Terrestrial, as well as satellite transmitters, can be considered.

The ProMan software also offers network planning modules for 2G/2.5G, 3G/B3G, WLAN, WiMAX
networks and more. Static network planning modules, as well as dynamic network simulators, are
included. Besides these cellular network planning features, ProMan also supports the planning of
broadcasting networks (terrestrial and satellite).

Figure 326: The ProMan user interface.
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6.1.1 User Interface
The ProMan (Propagation) software package is designed to predict path loss accurately between
transmitter and receiver. The ProMan (network) software offers network planning modules.

ProMan's graphical user interface window consists of three main parts, the Tree view on the left, the
2D View in the middle and the Legend on the right side. The 3D View can be selected using the Display
menu or by clicking on the corresponding toolbar icon. The 3D view replaces the tree view and the 2D
view window.

Besides this, ProMan offers four toolbars for quick access to all frequently needed functionalities. The
status bar on the bottom of the window gives information about the current mouse position in the 2D
view.

Figure 327: ProMan user interface.

1. Standard toolbar

2. Project toolbar

3. Component toolbar

4. Status bar

5. Utility toolbar

6. Edit toolbar

7. Tree view

8. 2D view

9. Legend
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Standard Toolbar

Table 29: The standard toolbar and the icons it contains.

New project

Open project

Open result

Open recent file

Save

Export Bitmap

Show version information for ProMan

Project Toolbar

Table 30: The project toolbar and the icons it contains.

Edit project parameter

Edit mobile station parameter

Set site

Erase site

Edit site

Move site

Set transmitter

Enable / disable transmitter

Erase transmitter

Edit transmitter

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.331

Move the transmitter. Depending on the selected propagation model, this option may
be not available).

Change transmitter's horizontal orientation

Define a general-purpose trajectory, for example for a moving transmitting antenna
or a moving prediction point.

Define prediction points. Depending on the selected propagation model, this option
may be not available.

Define prediction rectangle (horizontal)

Define prediction trajectories

Define a database area (polygon) to limit the number of objects that will be
considered in the simulation.

Compute propagation for all antennas

Compute mobile station prediction.

Run network simulation

Compute wave propagation, followed by mobile station prediction (if enabled) and
network prediction.

Component Toolbar

Table 31: The component toolbar and the icons it contains.

Add component

Delete component

Edit component

Move component

Rotate antenna

Add cable
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Add antenna

Add transceiver

Edit Toolbar

Table 32: The edit toolbar and the icons it contains.

Reset zoom window

Repaint view

Zoom to prediction area (only in project mode available)

Zoom to result (only available if result loaded)

Zoom out

Zoom in

Zoom window

Selection box for display plane in 2D-View

Save current view area (2D-View)

Remove selected view area (2D-View)

Presentation plot

Threshold color mode

Edit data

Change edit-value

Additional data layers

3D view

Settings

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.333

Information

Utility Toolbar

Table 33: The utility toolbar and the icons it contains.

Display of ray paths

Single display of rays

Delete all rays

Impulse response

Show prediction planes in a separate dialog

Show / hide info dialog

Line plot

Line plot (from transmitter)

Probability density function (relative, total area)

Cumulative density function

100% - Cumulative density function (total area)

Show tooltip

Show distance

Tree View

Table 34: The tree and the main icons it contains.

Network configuration.

Databases used in the project.
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Propagation results.

Network results.

Human exposure to electromagnetic fields (EMF) results/

Electromagnetic compatibility (EMC) results.

6.1.2 Run From Command Line
ProMan can be started with additional arguments passed in the command line to load and execute
existing projects automatically.

The first required parameter, which has to be passed to the command line is the path and the name
of the ProMan project file to be loaded. Afterwards, the prediction mode has to be specified. Further
parameters are optional and can be passed in an arbitrary order.

The basic syntax of the command line mode:

ProMan.exe “C:\SampleProject.net” 

Table 35: Mandatory parameters to include when using the command line.

Mandatory Parameter Description

-p Compute wave propagation prediction

-m Compute mobile station prediction using RunMS.

-n Compute network prediction

-a Compute wave propagation, followed by RunMS (if enabled) and
network prediction.

Note:  Only one computation mode can be considered at a time. If none or several are
selected, wave propagation prediction is selected automatically.

The following parameters can be added optionally:
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Table 36: Optional parameters to include when using the command line.

Optional Parameters Description

-fa Filter prediction results during computation based on arithmetic mean.

-d20 Limit dynamic in antenna patterns of base stations, for example, to 20
dB.

-l Write computation log file.

-c Close application after the task(s) are completed successfully.

-t Post-process the mobile station using RunMS and include additional
transmitter settings in a .mic file.

Note:  This option requires propagation results to be
available.

• If no .mic file is specified, the existing .mic file is used. The
default .mic file has the same file name as the project. For
example:

-t ProjectFile.net

• Specify a .mic file if you want to apply customised settings that
are different from the default settings of the project. For example:

-t ProjectFile.net ConfigurationFile.mic

6.1.3 WinProp Command Line Interface
The WinProp command line interface (WinPropCLI) executable enables you to run WinProp projects
in batch mode without launching the graphical user interface (GUI). It is available on both Microsoft
Windows and Linux. Internally, the WinPropCLI executable calls the WinProp API. The WinPropCLI can
be used within queuing systems such as Altair PBS, Torque, LSF, GridEngine and more.

The general syntax for computing ProMan projects is:

WinPropCLI -F file [options]

for example:

WinPropCLI -F C:\MyProject.net -A
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The syntax for computing a preprocessing is:

WinPropCLI -I file

for example:

WinPropCLI -I C:\MyProject.pin

WinPropCLI -I C:\MyProject.pre

Note:  Find the executable WinPropCLI in the Altair installation directory, for example:
Altair\2022.1\feko\bin\WinPropCLI.exe.

Options
--help

Print help messages.

-F [ --file-project ] arg
Project file to compute.

--dynamic-limit arg (=-1)
Limit the dynamic of base station antenna patterns.

--filter-results arg (=-1)
Use arithmetic filter for prediction results during computation.

--multi-threading arg (=-1)
Use multiple threads for computation.

-P [ --run-pro ]
Compute the propagation.

-M [ --run-ms ]
Compute mobile station post processing.

-N [ --run-net ]
Compute the network planning.

-A [ --run-all ]
Compute all in the project enabled modes (same as ---run-pro --run-ms --run-net).

--results-pro arg
Results directory for propagation, if empty, results directory from project is taken. Absolute or
relative to project file. Used for output of --run-pro and as input of --run-ms and --run-net.

--results-ms arg
Results directory for postprocessing, if empty, results directory from project is taken. Absolute or
relative to project file. Used for output of --run-ms and as input of --run-net.

-results-net arg
Results directory for network planning, if empty, results directory from project is taken. Absolute
or relative to project file.
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--disable-project-update
Disable updating ProMan project files after computation.

-I [ --process-db ] arg
Database preprocessing. The expected argument is the path (including file extension) of a .pin or
.pre file for indoor or urban preprocessing, respectively.

-D [ --db-out ] arg
Name of resulting database, without extension. Using name of input file in case this parameter is
omitted.

-R [ --convert-res ] arg

Convert the binary result into WinProp ASCII format. The expected argument is the path
(including file extension) of the binary result file.

--res-out arg
Name of resulting ASCII file, without extension. If this parameter is not specified, the input file
name is used.

-S [ --show-progress ] arg
Show progress information mode (detailed, global, or auto).

The options are:

--show-progress d
Display detailed progress information for each individual thread.

--show-progress g
Display global progress information (good for performance when there are many threads).

--show-progress a
Select the optimum progress display mode (detailed or global) according to the number of
threads and transmitters. This is the default.

-V [ --version ]
Print the Altair WinProp version.

Occasionally, a feature or option that is available in the GUI may not be included in the API yet. Over
time, this will be increasingly rare. If a feature or option is not yet included in the API, WinPropCLI
returns an error message to the command line. In case a network planning feature is not supported by
WinPropCLI, it is still possible to compute the time consuming propagation using WinPropCLI, and then
later on, compute the network planning within ProMan.

6.1.4 Global Settings
Global settings are settings that are not relevant to a specific project or database.

Click Settings > Global Settings (Directories, Options) to modify the default settings.

These settings are stored in the Windows Registry if ProMan is closed. If several instances of ProMan are
running at the same time, the global settings of the ProMan instance which was closed last, are saved
to the Windows Registry.
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Directories and Files
The Directories and Files tab is used to specify the paths of the default directories and default
selections. Default directory paths are used to find items (for example, antenna patterns and wireless
standards) if they are not available in the current directory or the directory specified in the current
project.

Figure 328: The Default Settings dialog - Directories and Files tab.

Default directories are specified for the following:

• Antenna Patterns
• Air Interfaces
• EMC Specifications
• GPS Satellite Defs
• Components Catalogue

Names
The Names tab is used to specify the default descriptions used for new objects placed in the scenario.
Descriptions can be changed afterwards. You can specify the default descriptions of the following items:

• Sites
• Antennas / Cells
• LMUs
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Figure 329: The Default Settings dialog - Names tab.

Display
The Display tab is used to specify the default settings for screen visualization.

Figure 330: The Default Settings dialog - Display tab.

Filter results when displayed
Results are filtered with a median filter when they are displayed on the screen. This option does
not affect the result files on the hard disk in contrast to Filter results when computed.

Use auto scale for results when initially displayed
The legend is scaled automatically if a result is loaded from the hard disk.

Path loss values with positive sign (instead of negative)
Path loss values are shown with a positive sign instead of a negative sign.

Extend file names after mathematical operation with files (e.g. add)
File names of results are extended with the name of a mathematical operation, for example, “diff”
is added to the file name if a differential operation was done.
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For continuous scale: Use colors of max (min) value for all values beyond max (min)
The colors for minimum / maximum values are used for all result values below / above the
thresholds. If this option is unselected, result values below / above the minimum / maximum
value are not displayed on the screen.

Draw also unpredicted pixels
Unpredicted pixels are drawn with white colored. Otherwise, they are transparent.

Load rays also for unpredicted pixels (if available)
Rays are also loaded from hard disk for not computed pixels if they are available.

Show link to site/cell in cell area and site area maps
Shows a link to the site / cell for the network planning results cell area and site area maps.

3D
The 3D tab is used to specify the default settings for the 3D view.

Figure 331: The Default Settings dialog - 3D tab.

3D Display Settings
Light coming from north: Locations are on the southern hemisphere. Disable view for topo /
clutter databases with more than X mega pixels: To limit the memory usage, the 3D view can be
disabled for very large files.

Prediction on surfaces and non-horizontal planes
As predictions on surfaces of walls cannot be shown in the 2D view, there is a message box
available to remind you to launch the 3D view to see the computed results on the screen.

Legend
The Legend tab is used to specify the default settings for the legend.
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Figure 332: The Default Settings dialog - Legend tab.

Size of font (discrete scale)
A minimum and maximum font size can be defined for the discrete scale. In case of the
continuous scale, an automatic scaling of the font size is done.

User defined color palette
A user-defined color palette can be specified. If the option User defined palette as default for
all results check box is selected, the specified palette is automatically applied to all results. As
long as this option is enabled, it is not possible to select a color palette in the local settings.

Computation
The Computation tab is used to specify the default settings for computations.

Figure 333: The Default Settings dialog - Computation tab.
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Ask before former results are overwritten during re-computation of project
If this option is enabled, you will be asked if available prediction results can be overwritten during
re-computation.

Generate log file during computations (saved in result directory)
A log file is generated during predictions. The file contains all the lines which are displayed during
predictions on the screen.

Save prediction results additionally in customer defined file format
If a customer file format is available in your version of WinProp, the results are additionally stored
in this format.

Save prediction result of each antenna/cell in individual sub-directory
Results of each antenna are stored in an individual sub directories.

Filter propagation results when computed
Prediction results are filtered after prediction. This affects accuracy. In contrast to Filter results
when displayed this item does lead to modifications of the results on the hard disk.

Limit dynamic in antenna pattern

(Base station)
The dynamic range in antenna patterns at base stations can be limited to a user-defined
dynamic range.

(Mobile station)
The dynamic in antenna patterns at mobile stations can be limited to a user-defined
dynamic range. Currently, this option affects point-to-point predictions only.

This option can be used to avoid deep notches in the antenna pattern. The value defined by you
describes the threshold for the maximum attenuation with respect to the maximum gain.

For example, if the maximum gain of the antenna is 10 dBi and the gain in a certain direction
is -5 dBi, then normally this gain is applied. But if the dynamic range feature is set to 8 dB, the
effective gain in the aforesaid direction is 10 dBi (maximum gain) – 8 dB (dynamic range) = 2 dBi
and not -5 dBi. This means the gain values cannot be smaller than the maximum gain minus the
dynamic range value, for example, if the dynamic range value is set to 0 dB the result is isotropic
radiation.

Note:  A user-defined dynamic range affects the accuracy of results.

Individual indoor results for each CNP building

Indoor results of CNP buildings[18] can be stored in separate result files (optional).

Number of concurrent computations
In case of multi-core / multi CPU machines, the maximum number of parallel computations can be
specified. By default, this parameter is set to the number of available cores / CPUs.

18. Buildings, which have been modeled as indoor databases and imported to the urban environment
database.
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6.1.5 Antenna Patterns
The correct format for antenna patterns is required to ensure accurate propagation modeling.

Antenna patterns are important for accurate propagation modeling. WinProp is flexible and supports
open ASCII formats for antenna patterns. Antenna patterns considered for computations in ProMan are
always full 3D patterns.

At least (measured or computed) vertical and horizontal patterns are available from antenna
manufacturers (in most cases also a 3D pattern) describing the radiation of the antenna in ideal
environments.

AMan software offers a convenient facility to generate and edit antenna patterns and offers several
import filters, to convert the most popular file formats to the WinProp antenna pattern format. Popular
formats are as follows:

• Antenna patterns in .msi or .pln format.

◦ Many antenna manufacturers (for example, Kathrein) offer digital patterns of their antennas in
the .msi and .pln data format. These patterns can directly be used with all WinProp modules.

• Antenna patterns in an open ASCII pattern format.

◦ WinProp also uses an open ASCII data format for antenna patterns that allows you to define
your data format for the antenna patterns. Convert the user-defined ASCII pattern format to
WinProp ASCII import format using a script.

Generation of Antenna Patterns

The antenna patterns used in ProMan are either in a binary format (.apb) or an ASCII format (.apa).

Antenna pattern files can also be converted and created using the tool AMan, which features a graphical
user interface (GUI) and a 3D view of the antenna pattern including different converters for well-known
file formats (for example, MSI).
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Figure 334: Generating antenna patterns in AMan.

3D Patterns
Further information about 3D antenna patterns, see AMan.

2D Antenna Patterns
Further information about 2D antenna patterns, see AMan.

Generation of 2D vertical and horizontal antenna patterns
For further information, see AMan.

Conversion of 2x2D pattern to 3D pattern
Conversion of a horizontal and a vertical antenna pattern to a full 3D antenna pattern (with four
different conversion algorithms), see AMan.

Conversion

3D Antenna Patterns
In contrast to the proprietary binary files, the ASCII antenna pattern file (.apa) can also be edited using
a simple ASCII editor.

The ASCII format allows comment lines which must start with “#” as the first character. All lines
starting with a “#” are ignored when reading the patterns. The values of the pattern are organized in
lines, one value per line. The theta angle values run from 0° to 180°; the phi angle values cover the
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range between 0° and 360°. The sequence of pairs in the ASCII file and the increment of the angles can
be chosen arbitrary – ProMan sorts them in the correct order and interpolates missing values based on
the neighboring values.

A sample of an ASCII antenna file (.apa, 3D antenna pattern):
# Theta         Phi         gain (Theta, Phi) [dB]
 
0 90 -7.0 
0 180 -12.0 
0 270 -7.0 
0 360 -2.0 
90 0 5.0 
90 90 0.0 
90 180 -5.0 
90 270 -7.0 
90 360 5.0 
180 0 -2.0 
180 90 -7.0 
180 180 12.0 
180 270 -7.0 
180 360 -2.0 

The main direction of radiation of the antenna (as defined within ProMan) is in the direction of theta =
90 degrees and phi = 0 degrees.

Figure 335: The main direction of radiation of the antenna as defined in ProMan.

2D Antenna Patterns
3D patterns can also be interpolated based on 2D patterns. If only the vertical and the horizontal plane
are available, both planes can be defined in ASCII files: .aha for horizontal patterns (antenna horizontal
ASCII) .ava for vertical patterns (antenna horizontal ASCII).

The coordinate systems of the 2D patterns are defined as follows:
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Figure 336: Top view of a horizontal pattern (on the left) and side view of a vertical pattern (to the right).

The file formats are similar to the format of the 3D pattern, but only one angle value per line is allowed.
Also the number of values in the file is required in the first data line.

Figure 337: Sample of a .aha file.

6.1.6 Map Data
Different types of map data which can be used with ProMan. In general, data can be distinguished into
the following categories:

• Raster data

• Vector data

• Photos

Raster Data
A raster data type is, in essence, any type of digital image represented in grids. Anyone who is
familiar with digital photography will recognize the pixel as the smallest individual unit of an image. A
combination of these pixels creates an image, distinct from the commonly used scalable vector graphics
which are the basis of the vector model.

Raster data type consists of rows and columns of cells, with each cell storing a single value. Raster
data can be images (raster images) with each pixel (or cell) containing a color value. Additional
values recorded for each cell may be a discrete value, such as land use, a continuous value, such as
topography, or a not-computed-value if no data is available.

Vector Data
In a GIS, geographical features are often expressed as vectors, by considering those features as
geometrical shapes. Different geographical features are expressed by different types of geometry:
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Lines
One-dimensional lines or polylines are used for linear features such as rivers, roads, railroads,
trails, and topographic lines.

Polygons
Two-dimensional polygons are used for geographical features that cover a particular area of the
earth's surface. Such features may include lakes, park boundaries, buildings, city boundaries, or
land uses. Polygons convey the most amount of information on the file types. Polygon features
can measure perimeter and area.

Photos
Photos, for example, aerial pictures, can be used as background images or can be converted into vector
data.

Raster Data
Raster data is a digital image consisting of rows and columns of cells storing color data. Different types
of data are given to build a map.

Topography
Topographical databases are the most important databases used for propagation analysis because the
topography has a significant influence on the propagation of electromagnetic waves. The topographical
databases are often also called terrain databases and are based on pixel matrices. Each pixel defines
the topographical height for a given location (for example, the center of the pixel). The finer the grid,
the more accurate the database. Currently, ProMan supports only height values (elevations) in meter.

Clutter / Land Usage
Clutter databases are sometimes called morpho databases or land usage databases. They contain
information about the land usage at a given location. In the following, they are called clutter databases.
Clutter databases are based on pixel matrices.

Each pixel defines the class of land usage for a given location (for example, the center of the pixel). The
finer the grid, the more accurate the database. Depending on the vendor of the database, the classes
of the land usage are defined individually, for example, class 1 can mean water if the database comes
from vendor A and class 1 can mean forest if the database comes from vendor B.

To handle this data in ProMan an additional table must be defined. In the table, the assignment of
the class ID (for example, 1) and the properties of this class (for example, name or electromagnetic
properties) are made.

Vegetation
Vegetation databases are also supported in ProMan. Each pixel defines the height of the vegetation for a
given location (for example, the center of the pixel). The finer the grid, the more accurate the database.
Currently, ProMan supports only height values (elevations) in meter.
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Results
Planar result databases created in ProMan during simulation are also raster database. Their content
depends on the type of the result.

Coordinate Systems

WinProp supports a wide range of geodetic datum. During the conversion of the database from the
original format to the WinProp data format the datum of the database must be defined by the user (if
not included in the original data format), click Data > Topography Database > Convert.

Figure 338: The Data conversion dialog.

WinProp computes internally with UTM data, and therefore the database is converted to UTM
coordinates during the computation. UTM zone is selected automatically based on the center pixel of
the simulation area. Pixels and coordinates are then transformed to the UTM zone of the center pixel.
After the simulation is completed, the data is transformed back to the original datum. In the case your
required coordinate system is not listed, contact Altair support.

Table 37: Supported ellipsoids.

Abbreviation Name of Ellipsoid Equatorial Radius [m] Square of Eccentricity

WE WGS-84 (World Geodetic
System)

6378137.000 0.006694379990

WD WGS-72 (World Geodetic
System)

6378135.000 0.006694317778

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.349

Abbreviation Name of Ellipsoid Equatorial Radius [m] Square of Eccentricity

WC WGS 66 (World Geodetic
System)

6378145.000 0.006694542

WB WGS 60 (World Geodetic
System)

6378165.000 0.006693422

SA South American 1969 6378160.000 0.006694542

KA Krassovsky 6378245.000 0.006693422

HO Hough 6378270.000 0.00672267

HE Helmert 1906 6378200.000 0.006693422

AN Australian National 6378160.000 0.006694542

AA Airy 6377563.000 0.00667054

AM Airy Modified 6377340.000 0.00667054

BR Bessel 1841 6377397.000 0.006674372

BN Bessel 1841 (Namibia) 6377484.000 0.006674372

CC Clarke 1866 6378206.000 0.006768658

CD Clarke 1880 6378249.000 0.006803511

FM Fischer 1960 (Mercury) 6378166.000 0.006693422

FB Fischer 1968 6378150.000 0.006693422

FA Mod. Fischer 1960 (South
Asia)

6378155.000 0.006693421774

RE GRS 1967 6378160.000 0.006694605

RF GRS 1980 6378137.000 0.006694380023

IN International 1924 6378388.000 0.006722670022

EA Everest 6377276.000 0.006637847

EB Everest (E. Malasia, Brunei) 6377298.556 0.006637846724

EC Everest 1956 (India) 6377301.243 0.006637846745

ED Everest 1969 (West Malasia) 6377295.664 0.006637846604
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Abbreviation Name of Ellipsoid Equatorial Radius [m] Square of Eccentricity

EE Everest 1948 (West Malasia &
Sing.)

6377304.063 0.006637846628

EF Everest (Pakistan) 6377309.613 0.006637533918

ID Indonesian 1974 6378160.000 0.006694609107

Table 38: Supported coordinate datum.

Abbreviation Coordinate Datum Ellipsoid

ADI-A ADINDAN Ethiopia CD

ADI-B ADINDAN Sudan CD

ADI-C ADINDAN Mali CD

ADI-D ADINDAN Senegal CD

ADI-E ADINDAN Burkina Faso CD

ADI-F ADINDAN Cameroon CD

ADI-M ADINDAN Mean CD

AFG AFGOOYE Somalia KA

AIA ANTIGUA ISLAND ASTRO 1943 CD

AIN-A AIN EL ABD 1970 Bahrain IN

AIN-B AIN EL ABD 1970 Saudi Arabia IN

AMA AMERICAN SAMOA 1962 CC

ANO ANNA 1 ASTRO 1965 Cocos Is. AN

ARF-A ARC 1950 Botswana CD

ARF-B ARC 1950 Lesotho CD

ARF-C ARC 1950 Malawi CD

ARF-D ARC 1950 Swaziland CD

ARF-E ARC 1950 Zaire CD
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Abbreviation Coordinate Datum Ellipsoid

ARF-F ARC 1950 Zambia CD

ARF-G ARC 1950 Zimbabwe        CD

ARF-H ARC 1950 Burundi              CD

ARF-M ARC 1950 Mean              CD

ARS-A ARC 1960 Kenya CD

ARS-B ARC 1960 Tanzania CD

ARS-M ARC 1960 Kenya & Tanzania CD

ASC ASCENSION ISLAND 1958 IN

ASM MONTSERRAT ISLAND ASTRO 1958 CD

ASQ ASTRO STATION 1952 Marcus Is. IN

ATF ASTRO BEACON E 1845 Iwo Jima IN

AUA AUSTRALIAN GEODETIC 1966 (AGD66) AN

AUG AUSTRALIAN GEODETIC 1984 (AGD84) AN

BAT DJAKARTA INDONESIA BR

BER BERMUDA 1957 Bermuda Islands CC

BID BISSAU Guinea-Bissau IN

BOO BOGOTA OBSERVATORY Columbia IN

BUR BUKIT RIMPAH Banka & Belitung BR

CAC CAPE CANAVERAL Fla & Bahamas CC

CAI CAMPO INCHAUSPE 1969 Arg. IN

CAO CANTON ASTRO 1966 Phoenix Is. IN

CAP CAPE South Africa CD

CAZ CAMP AREA ASTRO Camp McMurdo IN

CCD S-JTSK Czech Republic BR

CGE CARTHAGE Tunisia CD
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Abbreviation Coordinate Datum Ellipsoid

CHI CHATHAM ISLAND ASTRO 1971 NZ IN

CHU CHUA ASTRO Paraguay IN

COA CORREGO ALEGRE Brazil IN

DAL DABOLA Guinea CD

DID DECEPTION ISLAND CD

DOB GUX 1 ASTRO Guadalcanal Is. IN

EAS EASTER ISLAND 1967 IN

ENW WAKE-ENIWETOK 1960 HO

EST ESTONIA 1937 BR

EUR-A EUROPEAN 1950 Western Europe IN

EUR-B EUROPEAN 1950 Greece       IN

EUR-C EUROPEAN 1950 Norway & Finland IN

EUR-D EUROPEAN 1950 Portugal & Spain IN

EUR-E EUROPEAN 1950 Cyprus IN

EUR-F EUROPEAN 1950 Egypt IN

EUR-G EUROPEAN 1950 England Channel IN

EUR-H EUROPEAN 1950 Iran IN

EUR-I EUROPEAN 1950 Sardinia(Italy) IN

EUR-J EUROPEAN 1950 Sicily(Italy) IN

EUR-K EUROPEAN 1950 England Ireland IN

EUR-L EUROPEAN 1950 Malta IN

EUR-M EUROPEAN 1950 Mean (3 Param) IN

EUR-S EUROPEAN 1950 Iraq Israel    IN

EUR-T EUROPEAN 1950 Tunisia IN

EUS EUROPEAN 1979 IN
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Abbreviation Coordinate Datum Ellipsoid

FAH OMAN CD

FLO OBSERVATORIO MET. 1939 Flores IN

FOT FORT THOMAS 1955 Leeward Is. CD

GAA GAN 1970 Rep. of Maldives IN

GEO GEODETIC DATUM 1949 NZ IN

GIZ DOS 1968 Gizo Island IN

GRA GRACIOSA BASE SW 1948 Azores IN

GSE GUNUNG SEGARA Indonesia BR

GUA GUAM 1963 CC

HEN HERAT NORTH Afghanistan IN

HER HERMANNSKOGEL old Yugoslavia BR

HIT PROVISIONAL SOUTH CHILEAN 1963 IN

HJO HJORSEY 1955 Iceland IN

HKD HONG KONG 1963 IN

HTN HU-TZU-SHAN Taiwan IN

IBE BELLEVUE (IGN) Efate Is. IN

IDN INDONESIAN 1974 ID

IND-B INDIAN Bangladesh EA

IND-I INDIAN India & Nepal EC

IND-P INDIAN Pakistan EF

INF-A INDIAN 1954 Thailand EA

ING-A INDIAN 1960 Vietnam 16N EA

ING-B INDIAN 1960 Con Son Island EA

INH-A INDIAN 1975 Thailand EA

INH-A1 INDIAN 1975 Thailand EA
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Abbreviation Coordinate Datum Ellipsoid

IRL IRELAND 1965 AM

ISG ISTS 061 ASTRO 1968 S Georgia IN

IST ISTS 073 ASTRO 1969 Diego Garc IN

JOH JOHNSTON ISLAND 1961 IN

KAN KANDAWALA Sri Lanka EA

KEA KERTAU 1948 W Malaysia & Sing. EE

KEG KERGUELEN ISLAND 1949 IN

KGS KOREAN GEO DATUM 1995 S Korea WE

KUS KUSAIE ASTRO 1951 Caroline Is. IN

LCF L.C. 5 ASTRO 1961 Cayman Brac CC

LEH LEIGON Ghana CD

LIB LIBERIA 1964 CD

LUZ-A LUZON Philippines CC

LUZ-B LUZON Mindanao Island CC

MAS MASSAWA Ethiopia BR

MER MERCHICH Morocco CD

MID MIDWAY ASTRO 1961 Midway Is. IN

MIK MAHE 1971 Mahe Is. CD

MIN-A MINNA Cameroon CD

MIN-B MINNA Nigeria CD

MOD ROME 1940 Sardinia IN

MPO M'PORALOKO Gabon CD

MVS VITI LEVU 1916 Viti Levu Is. CD

NAH-A NAHRWAN Masirah Island (Oman) CD

NAH-B NAHRWAN United Arab Emirates CD
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Abbreviation Coordinate Datum Ellipsoid

NAH-C NAHRWAN Saudi Arabia CD

NAP NAPARIMA Trinidad & Tobago IN

NAR-A NORTH AMERICAN 1983 Alaska RF

NAR-B NORTH AMERICAN 1983 Canada RF

NAR-C NORTH AMERICAN 1983 CONUS RF

NAR-D NORTH AMERICAN 1983 Mexico RF

NAR-E NORTH AMERICAN 1983 Aleutian RF

NAR-H NORTH AMERICAN 1983 Hawai'i RF

NAS-A NORTH AMERICAN 1927 Eastern US CC

NAS-B NORTH AMERICAN 1927 Western US CC

NAS-C NORTH AMERICAN 1927 CONUS CC

NAS-D NORTH AMERICAN 1927 Alaska CC

NAS-E NORTH AMERICAN 1927 Canada CC

NAS-F NORTH AMERICAN 1927 Alberta/BC CC

NAS-G NORTH AMERICAN 1927 E. Canada CC

NAS-H NORTH AMERICAN 1927 Man/Ont CC

NAS-I NORTH AMERICAN 1927 NW Terr. CC

NAS-J NORTH AMERICAN 1927 Yukon CC

NAS-L NORTH AMERICAN 1927 Mexico  CC

NAS-N NORTH AMERICAN 1927 C. America CC

NAS-O NORTH AMERICAN 1927 Canal Zone CC

NAS-P NORTH AMERICAN 1927 Caribbean CC

NAS-Q NORTH AMERICAN 1927 Bahamas CC

NAS-R NORTH AMERICAN 1927 San Salv. CC

NAS-T NORTH AMERICAN 1927 Cuba CC
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Abbreviation Coordinate Datum Ellipsoid

NAS-U NORTH AMERICAN 1927 Greenland CC

NAS-V NORTH AMERICAN 1927 Aleutian E CC

NAS-W NORTH AMERICAN 1927 Aleutian W CC

NSD NORTH SAHARA 1959 Algeria CD

OEG OLD EGYPTIAN 1907 HE

OGB-A ORDNANCE GB 1936 England     AA

OGB-B ORDNANCE GB 1936 Eng. Wales AA

OGB-C ORDNANCE GB 1936 Scotland     AA

OGB-D ORDNANCE GB 1936 Wales       AA

OGB-M ORDNANCE GB 1936 Mean (3 Para) AA

OHA-A OLD HAWAI'IAN (CC) Hawai'i   CC

OHA-B OLD HAWAI'IAN (CC) Kauai     CC

OHA-C OLD HAWAI'IAN (CC) Maui     CC

OHA-D OLD HAWAI'IAN (CC) Oahu       CC

OHA-M OLD HAWAI'IAN (CC) Mean     CC

OHI-A OLD HAWAI'IAN (IN) Hawai'i IN

OHI-B OLD HAWAI'IAN (IN) Kauai IN

OHI-C OLD HAWAI'IAN (IN) Maui IN

OHI-D OLD HAWAI'IAN (IN) Oahu IN

OHI-M OLD HAWAI'IAN (IN) Mean       IN

PHA AYABELLA LIGHTHOUSE Bjibouti CD

PIT PITCAIRN ASTRO 1967 IN

PLN PICO DE LAS NIEVES Canary Is. IN

POS PORTO SANTO 1936 Madeira Is. IN

PRP-A PROV. S AMERICAN 1956 Bolivia IN
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Abbreviation Coordinate Datum Ellipsoid

PRP-B PROV. S AMERICAN 1956 N Chile IN

PRP-C PROV. S AMERICAN 1956 S Chile IN

PRP-D PROV. S AMERICAN 1956 Colombia IN

PRP-E PROV. S AMERICAN 1956 Ecuador IN

PRP-F PROV. S AMERICAN 1956 Guyana IN

PRP-G PROV. S AMERICAN 1956 Peru   IN

PRP-H PROV. S AMERICAN 1956 Venez  IN

PRP-M PROV. S AMERICAN 1956 Mean IN

PTB POINT 58 Burkina Faso & Niger CD

PTN POINT NOIRE 1948 CD

PUK PULKOVO 1942 Russia KA

PUR PUERTO RICO & Virgin Is. CC

QAT QATAR NATIONAL IN

QUO QORNOQ South Greenland IN

REU REUNION Mascarene Is. IN

SAE SANTO (DOS) 1965 IN

SAN-A SOUTH AMERICAN 1969 Argentina SA

SAN-B SOUTH AMERICAN 1969 Bolivia   SA

SAN-C SOUTH AMERICAN 1969 Brazil   SA

SAN-D SOUTH AMERICAN 1969 Chile   SA

SAN-E SOUTH AMERICAN 1969 Colombia  SA

SAN-F SOUTH AMERICAN 1969 Ecuador   SA

SAN-G SOUTH AMERICAN 1969 Guyana    SA

SAN-H SOUTH AMERICAN 1969 Paraguay  SA

SAN-I SOUTH AMERICAN 1969 Peru     SA
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Abbreviation Coordinate Datum Ellipsoid

SAN-J SOUTH AMERICAN 1969 Baltra SA

SAN-K SOUTH AMERICAN 1969 Trinidad  SA

SAN-L SOUTH AMERICAN 1969 Venezuela SA

SAN-M SOUTH AMERICAN 1969 Mean     SA

SAO SAO BRAZ Santa Maria Is. IN

SAP SAPPER HILL 1943 E Falkland Is IN

SCK SCHWARZECK Namibia         BN

SGM SELVAGEM GRADE 1938 Salvage Is IN

SHB ASTRO DOS 71/4 St. Helena Is. IN

SIR SIRGAS South America RF

SOA SOUTH ASIA Singapore FA

SPK-A S-42 (PULKOVO 1942) Hungary   KA

SPK-B S-42 (PULKOVO 1942) Poland   KA

SPK-C S-42 (PK42) Former Czechoslov. KA

SPK-D S-42 (PULKOVO 1942) Latvia    KA

SPK-E S-42 (PK 1942) Kazakhstan     KA

SPK-F S-42 (PULKOVO 1942) Albania  KA

SPK-G S-42 (PULKOVO 1942) Romania  KA

SRL SIERRA LEONE 1960 CD

TAN TANANARIVE OBSERVATORY 1925 IN

TDC TRISTAN ASTRO 1968 IN

TIL TIMBALAI 1948 Brunei & E Malay EB

TOY-A TOKYO Japan BR

TOY-B TOKYO South Korea BR

TOY-B1 TOKYO South Korea        BR
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Abbreviation Coordinate Datum Ellipsoid

TOY-C TOKYO Okinawa               BR

TOY-M TOKYO Mean                 BR

TRN ASTRO TERN ISLAND (FRIG) 1961 IN

VOI VOIROL 1874 Algeria CD

VOR VOIROL 1960 Algeria CD

WAK WAKE ISLAND ASTRO 1952 IN

WGA WGS 60 (World Geodetic System) WB

WGB WGS 66 (World Geodetic System) WC

WGC WGS 72 (World Geodetic System) WD

WGE WGS 84 (World Geodetic System) WE

YAC YACARE Uruguay IN

ZAN ZANDERIJ Suriname IN

Coordinate and Datum Conversion of Selected Points
ProMan offers the possibility to convert coordinates and datum of single points or a list of points. This
is useful if coordinates of measurement routes or site locations are to be converted to be used within
ProMan. Click Data > Convert Coordinate Datum to specify the options.
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Figure 339: Coordinate and Datum Conversion dialog.

Modification of the Area Geometry

Modify Geometry of Area
The geometry of a raster database, for example, the database bounds (lower-left corner and upper-
right corner), as well as the resolution, can be changed by clicking Edit > Modify Geometry of Area).
The following options are available:

Extract Data
This option offers the possibility to extract data of a specified sub-area. This can be useful if a
large topography database is resized to keep only the relevant part of the database.

Figure 340: The Database Aperture dialog.

Database Bounds
Lower-left and upper-right corner of the database. These coordinates can be changed to
obtain a smaller area. Press Reset to reset the coordinates to their original values.
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Further Settings
The number of columns and lines of the database can be changed. A change of these
parameters influence the coordinates of the upper right corner in the upper section.
Resolution and covered area are displayed for information only and cannot be changed.

Increase number of columns and lines
The raster database can be enlarged by increasing the number of columns and / or lines.

Figure 341: The Enlarge Prediction Area dialog.

Change resolution
The resolution of the database can be increased or decreased by an arbitrary factor.

Figure 342: The Change resolution dialog.

Move lower-left corner (move data)
The entire raster database can be shifted to another location by changing the lower-left corner.
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Figure 343: The Move lower-left corner dialog.

Modify Data in Area
To modify data in an area, click Edit > Modify Data in Area. The following options are available:

Interpolate data
Missing pixel values can be interpolated from the values of the surrounding pixels.

Filter data
Raster data can be filtered with arithmetic or median filter. The order of the filter can be specified.

Figure 344: The Filter dialog.

Smooth data
Pixel data can be beautified by increasing the resolution and applying a filter afterward. This can
be useful for presentation plots. You can specify the raster factor for increasing the resolution and
the filter order.
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Figure 345: The Smooth dialog.

Delete data
Selecting this option erases all data contained in the raster database. This means all pixels are set
to “not compute”.

Assign values to pixels to borders
Pixels at the border of the raster database, which are “not computed” can be padded with the
value of the next available pixel value of the same column (for pixels at the top or the bottom) or
line (for pixels at the left or right side). This is especially useful if a topography database needs to
be extended and no additional data is available.

Topography
Topography data defines the propagation terrain. It is the most important databases due to its
significant influence on propagation.

Topographical Databases
For large scale simulations, topographical databases (DEM = digital elevation models) are the
most important databases as the topography has a significant influence on the propagation of
electromagnetic waves. The topographical databases are also called terrain databases and are based on
pixel matrices. Each pixel defines the topographical height for a given location (for example, the center
of the pixel).

As ProMan uses a metric system for the computation, only height values (elevations) in meter are
allowed. Other height units (for example feet) must be scaled or converted to meters. In the current
version of ProMan the pixels are always squares (and not rectangles), for example, the resolution (grid)
in longitude and latitude are always equal. If the original data use different resolutions for longitude and
latitude, the smaller value of the grid is taken during the conversion for both (longitude and latitude),
and the undefined values are interpolated.

For topographical databases, a single database file has the extension .tdb (topo data binary). The index
file has the extension .tdi (topo data index), and it includes the pointers to the small .tdb files. The
tdi file is optional. Often .tdb files are used without the corresponding .tdi files.
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Figure 346: Example of a topographical database - part of the Grand
Canyon (USA). Different colors are used to indicate different heights.

Conversion of Topographical Data
Built-in converters in ProMan convert several file formats to the WinProp format. The supported file
formats and selection of parameters are provided.

ProMan supports the following file formats:

• NPS/X data format (defined by Nokia)

• ASC data format (ASCII grid matrix)

• Binary grid format

• Wizard data format (defined by Agilent)

• MSI Planet data format (defined by MSI)

• MSI Tornada data format (defined by MSI and used by Siemens)

• Aircom Enterprise data format (defined by Aircom)

• Nokia NetAct data format (defined by Aircom and used by Nokia)

• Ericsson ASSET data format (defined by Aircom and used by Ericsson)

• USGS DEM

• USGS BIL

• HGT

• Digital terrain elevation data

Step 1: Selection of Parameters
Databases can be converted by clicking Data > Convert topographical database.
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Figure 347: The Data Conversion dialog.

There are several parameters available:

Format of original database
Select the format of the original database for the conversion.

Coordinates of original database
Select the coordinate datum of the original database. Depending on the type of format, this
selection is not available, for example, HGT format only allows WGS 84 coordinates. Depending on
the database format, you have to define the coordinates of the original database as well.

Options for conversion
Specify the resolution and the value by which the heights in the file can be scaled. This is useful
if the source format is given in feet or inches. Additionally, depending on the file format, the
resolution of the destination file can be defined.

Coordinates of converted database
Select the coordinates of the converted database (depending on the input format).

Save database additionally in indoor database format
Save the database to the indoor database format (.idb). This is useful if a detailed terrain profile
is necessary for investigation of the radio channel with indoor wave propagation models (for
example, ray tracing).

Handling of undefined pixels
Specify the handling of undefined pixels.
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Step 2: Selection of Files and Conversion
After the parameters are defined, the files (source and destination) are selected, and the conversion is
done. The topographic database is created in the .tdb file format. Depending on the topography, it can
be split into several .tdb files.

Generating Topographical Data
Generate topographical data by using drawing tools and creating a matrix.

Topography is drawn in ProMan by using the pixel modification tool.

1. Click Data > Topography Database > New

This creates a new empty matrix.

Figure 348: The Coordinate System dialog.

2. In the Datum of coordinates drop-down list, select one of the listed items.

3. In the UTM or Geodetic group, select an option.

4. Click OK to continue.

5. On the Properties dialog, specify the matrix dimensions.

Figure 349: The Properties dialog.
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Note:

The next dialog offers the selection of a background image. If no background image is
required, the dialog can be canceled.

6. Specify the minimum and maximum elevation of the topography.

Figure 350: The Range of elevation values dialog.

7. Draw the topography.

Note:  Use the drawing tools to fill the matrix.

Figure 351: Example of a topography.

Clutter / Land Usage
Clutter databases are pixel matrices and contain information about the land usage at a given location.
These are also called morpho databases or land usage databases.

Clutter databases are based on pixel matrices. Each pixel defines the class of land usage for a given
location (for example the center of the pixel). The finer the grid, the more accurate the database.
Today, resolutions (grids) of approximate 5 m to 20 m are used.

Depending on the vendor of the database, the classes of the land usage are defined individually.
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For example, class 1 can mean water if the database comes from vendor A. Class 1 can mean forest if
the database comes from vendor B.

To handle this data in WinProp an additional table must be defined. In the table, the assignment of
the class ID (for example, 1) and the properties of this class (for example, name or electromagnetic
properties) are made.

In WinProp, the pixels are always squares (and not rectangles). For example, the resolution (grid) in
longitude and latitude are always equal. If the original data use different resolutions for longitude and
latitude, the smaller value of the grid is taken during the conversion for both (longitude and latitude),
and the undefined values are interpolated (bi-linear interpolation based on neighbor pixels).

Figure 352: A clutter database of the coast of Rimini (Italy).
Different colors are used to indicate different land usage classes.

Conversion of Clutter Data
Built-in converters in ProMan convert several file formats to the WinProp format. The supported file
formats and selection of parameters are provided.

ProMan supports the following file formats:

• NPS/X data format (defined by Nokia)

• ASC data format (ASCII grid matrix)

• Binary grid format
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• Wizard data format (defined by Agilent)

• MSI Planet data format (defined by MSI)

• MSI Tornada data format (defined by MSI and used by Siemens)

• Aircom Enterprise data format (defined by Aircom)

• Nokia NetAct data format (defined by Aircom and used by Nokia)

• Ericsson ASSET data format (defined by Aircom and used by Ericsson)

Step 1: Selection of Parameters
Databases can be converted by clicking Data > Clutter (Morpho) Database > Convert.

Figure 353: The Data Conversion dialog.

There are several parameters available on the dialog:

Format of original database
Select the format of the original database for the conversion.

Coordinates of original database
Select the coordinate datum of the original database. Depending on the type of format, this
selection is not available, for example, HGT format only allows WGS 84 coordinates. Depending on
the database format, you have to define the coordinates of the original database as well.

Options for conversion
Specify the resolution and the value by which the heights in the file can be scaled. This is useful
if the source format is given in feet or inches. Additionally, depending on the file format, the
resolution of the destination file can be defined.

Coordinates of converted database
Select the coordinates of the converted database (depending on the input format).
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Save database additionally in indoor database format
Save the database to the indoor database format (.idb). This is useful if a detailed terrain
profile is necessary for investigation the radio channel with indoor wave propagation models (for
example, ray tracing).

Handling of undefined pixels
Specify the handling of undefined pixels.

Step 2: Selection of Files and Conversion
After the parameters are defined, the files (source and destination) are selected, and the conversion is
done. The clutter database will be created in the .mdb file format. Depending on the topography, it can
be split into several .mdb files.

Generation of Clutter / Land Usage Data
A clutter table specifies the height and attenuation for the clutter database.

Clutter Tables
Clutter databases contain only class IDs for each pixel. Clutter tables are not provided by the database
vendor. They must be defined by you depending on the clutter classes.

Tip:  Click Data > Clutter (Morpho) Definition Table > Edit Clutter/Morpho Data
Table.

The clutter database contains only information about the class ID. But the assignment of properties to
this class ID must be made in a separate table.

Figure 354: The Morpho/Clutter Classes dialog.
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Table 39: A clutter table - defining the properties of each clutter class.

Class ID Name Additional Attenuation [dB] Mean
Height [m]

...

1 Water 5 0 ...

2 Street 3 0 ...

3 Forest 7 7 ...

... ... ... ... ...

To edit the properties of the class, open the Morpho/Clutter Class Properties dialog (click Data >
Clutter (Morpho) Definition Table > Edit Clutter/Morpho Data Table.

Figure 355: The Morpho/Clutter Classes Properties dialog.

The Morpho/Clutter Class Properties dialog allows you to edit properties of the class. The meanings
of ID (number) and name are obvious. The color definition is used to display the class with the defined
color on the display. The height of objects (for example, forest, buildings) can be defined for each
clutter class separately either as a fixed value, which applies for the whole clutter class or as a mean
value with an additional standard deviation. In the second case, the clutter heights are statistically
distributed to obtain a more realistic database.
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Figure 356: Individual height for each clutter class.
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Figure 357: Individual statistical distribution of height for each clutter class.

The clearance, for example, the distance between the objects, can be defined individually for each
clutter class. This value can be specified either as a fixed number or as a statistically distributed
parameter.

While the clutter height describes the average height of the obstacles (such as buildings), the clearance
describes for instance the street width in an urban area. For the clearance radius definition, the
following four parameters can be defined:

• Min. Radius

• Max. Radius

• Free (Ratio)

• Free (Radius)

If the parameter Free (Ratio) is set to 0% then the clearance radius is randomly distributed between
the minimum and the maximum radius.

In the example of buildings in an urban area, this leaves something to be desired: when looking down a
street one observes, in that direction, a much larger clearance value. This can be considered by defining
a nonzero Free (Ratio), for example, 25% and the corresponding Free (Radius), for example, 200m.
In this case with a probability of 25% a clearance of 200m is considered, while in the other 75% the
clearance is equally distributed between the defined min. and max. values.
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Figure 358: The distance between the objects can be defined individually for each clutter class.

Depending on the clearance radii of the clutter classes some rays between transmitter and receiver
location are diffracted at obstacles, whereas others hit the prediction plane without being diffracted.
These diffraction losses, which attenuate the propagation paths additionally, can be considered by using
the knife edge diffraction extension on top of the selected wave propagation model.

Most propagation tools only consider the class at the receiver pixel for the influence on the wave
propagation. But this means, that if 90% of the distance between transmitter and receiver is, for
example, in the clutter class urban and only the receiver pixel is in the class forest, the properties of
the class forest would be used. This is not correct if 90% of the area between transmitter and receiver
are urban. WinProp offers optionally the determination of the dominant class between transmitter and
receiver and this class is then used for the evaluation of the receiver pixel. But some classes have a
greater influence on the propagation than others. Each class can be assigned a weight factor. The higher
the weight factor, the stronger the influence of the class on the propagation.

For example, if the following classes are between a transmitter and receiver:

• If one urban class has a weight of one (1 class * 1 weight = 1) and the three water classes also
have a weight of one (3 classes * 1 weight = 3), the dominant class is water.

• If one urban class has a weight of five (1 class * 5 weight = 5 ) and the three water classes have a
weight of one (3 classes * 1 weight = 3), the dominant class is urban.

If using the Hata-Okumura propagation model, four different sub-models are available:

• dense urban

• medium urban
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• suburban

• open area

The same sub-model can be used for the whole prediction area, although this is not always a good
solution when the area is not homogeneous.

WinProp offers the option, to use for each clutter class a different sub-model of the Hata-Okumura
model. For example, for the clutter class “agricultural area” the sub-model Open Area could be used
while for the clutter class “city center” the sub-model Dense Urban could be used. This increases the
accuracy of the prediction.

For the 3D scattering module, the standard deviation of the heights and the correlation length can be
defined for each sub-class because these values influence the reflection / scattering loss. The effects of
the class properties on the propagation models can be defined in the left part of the dialog.

Note:  Class properties must be defined for each frequency band individually, due to the
properties not being homogeneous over the full frequency band.

Several frequency bands can be defined for one clutter class. The propagation model selects the
appropriate frequency band depending on the transmitter settings.

Rules for the definition of different frequency bands:

• The frequency bands defined for a clutter class must not overlap.

• The frequency bands can be defined individually for each clutter class

◦ For class 1, the frequency bands can be 300 MHz to 1000 MHz and 1000 MHz to 2000 MHz.

◦ For class 2, the frequency bands can be 300 MHz to 700 MHz, 700 MHz to 1200 MHz and 1200
MHz to 2000 MHz.

• If a frequency used for a transmitter is not included in one of the frequency bands of the clutter
class, the propagation is not computed for this pixel. Frequency bands can be added, deleted or
edited with the three buttons below the list of frequency bands.

The properties of a frequency band can be defined with the following dialog:
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Figure 359: The Properties dialog of a frequency band.

The band of frequencies is defined in the upper part of the dialog. For all propagation models, except
Hata-Okumura (for example, two-ray model, parabolic equations), an additional attenuation can be
defined which is added to all receiver pixels at this location. The Hata-Okumura model contains four
sub-models, and therefore the additional attenuation can be defined for each sub-model individually.
Depending on the model which is currently selected, the appropriate loss is selected.

For the parabolic equation model (PE) and the 3D scatting option, the electromagnetic properties of the
ground can be defined. These values are used to determine the reflection/scattering loss of the waves
reflected/scattered at the ground (the relative permeability is always assumed to be 1.0). 
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Vegetation
Vegetation databases contain information about the height at a given location. The databases are based
on pixel matrices. Each pixel defines the height for a given location (for example, the center of the
pixel).

Figure 360: Example of a vegetation database.

Vegetation objects which should be considered during the computation must contain a height value
bigger than zero.

The following types of vegetation objects are supported:

Vector format
The WallMan application provides the feature to place vegetation objects in the form of vector
orientated objects. The disadvantage of this format type results in the missing information of the
topographical surface over large areas.

Pixel format
The databases are based on pixel matrices. Each pixel defines the height for a given location (for
example, the center of the pixel). The height information must be given as a relative height.
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Conversion of Vegetation Objects
Vector-based vegetation objects can be converted into the pixel format. You have to pre-process the
urban vector database format (.odb) with the WallMan application.

Computation Settings
If an urban database contains vector based vegetation objects, then there is no possibility to consider
pixel based vegetation objects. You have to select during the database generation which type of
vegetation database should be used during the propagation.

Vector Data
In a GIS, geographical features are often expressed as vectors, by considering those features as
geometrical shapes.

Different geographical features are expressed by different types of geometry:

Lines

One-dimensional lines or polylines are used for linear features such as rivers, roads, railroads,
trails, and topographic lines.

Polygons
Two-dimensional polygons are used for geographical features that cover a particular area of the
earth's surface. Such features may include lakes, park boundaries, buildings, city boundaries, or
land uses. Polygons convey the most amount of information of the file types. Polygon features can
measure perimeter and area.

Rural Topography, Clutter and Building Data
Rural vector databases allow the description of topography, land usage (clutter / morpho data) and
building data based on 3D vector elements. Such databases are required for deterministic multi-
path propagation models, such as the rural ray-tracing model, considering phenomena like multiple
reflections and wave guiding effects in canyons. Rural vector databases offer the following features:

• 3D vector oriented database

• Walls as planar objects with polygonal shape

• Arbitrary location and orientation in space

• Individual material properties

Urban Buildings
Urban vector databases contain a description of all buildings and vegetation areas in an urban
environment. The buildings are described by polygonal cylinders, for example, buildings with arbitrary
shapes can be used. Building databases offer the following features:

• Each polygon can have an arbitrary number of corners.

• Each polygon must have at least three corners to define a valid polygon (building).

• Each building has a uniform height (polygonal cylinder). The height is either relative to the ground
or absolute above sea level. Absolute height values require a topographical database additionally.

• Each building has a single set of material properties which are used for the entire building.
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• Flat rooftops are used (horizontal planes).

• Only vertical walls (parallel to the z-axis) are allowed.

• The polygon of a building must not intersect itself.

• The polygon of a building might intersect other polygons (buildings).

Indoor 3D Objects
Indoor vector databases allow the description of each arbitrary object. To limit the complexity of the
file and data format, WinProp supports only planar objects. In the indoor database, they are called
walls – but such planar elements are not limited to walls. Also, tables, cupboards and all further indoor
objects can be modeled with these planar elements. The elements can have an arbitrary number of
corners. Round objects must be approximated with planar objects. The more planar objects, the better
the approximation – but also the longer the computation times during the propagation analysis. Indoor
databases offer the following features:

• 3D vector oriented database

• Walls as planar objects with polygonal shape

• Arbitrary location and orientation in space

• Individual material properties

• Subdivisions with different material properties to model doors and windows

Time-Variant
Time variance does influence the wave propagation significantly. Because of that WinProp offers a
module to consider time-variant effects in the wave propagation computation. The time-variant vector
databases are based on indoor vector databases, but extend these files with time-variant properties.
Each ordinary indoor database can be transformed into a time-variant database. In addition to indoor
databases time-variant databases offer the following features:

• Motion can be assigned to all objects.

• Translation and rotation are possible.

Tunnels
Tunnel databases have a special layout and can also be used in ProMan. These databases are generated
with the TuMan component.

Rural Vector Objects
Rural vector databases describe the simulation environment based vector topography and clutter
databases.

To limit the complexity of the file and data format, WinProp supports only planar objects. The elements
can have an arbitrary number of corners. The more planar objects, the better the approximation – but
also the longer the computation times during the propagation analysis. Rural vector databases offer the
following features:

• 3D vector oriented database

• Topography, clutter and building data as planar objects with polygonal shape

• Arbitrary location and orientation in space
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• Individual material properties

Figure 361: Topography database based on 3D vector objects.

Similar to the topographical data, clutter maps are also converted from raster data to 3D vector data
taking account the clutter heights and the electrical properties of the materials defined for each clutter
class individually. This approach allows a real 3D representation of the land usage maps.

Figure 362: Different clutter classes.

Besides topography and clutter data, vector data of building can be considered optionally.
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Figure 363: Vector data of buildings.

Generation and Conversion
Rural vector databases can be generated and converted with the WallMan software.

Urban Buildings
Urban vector databases contain a description of all buildings and vegetation areas in an urban
environment

The buildings are described by polygonal cylinders, for example, buildings with arbitrary shapes can be
used. Building databases offer the following features:

• Each polygon can have an arbitrary number of corners.

• At least three corners are required to define a valid polygon (building)s.

• Each building has a uniform height (polygonal cylinder). The height is either relative to the ground
or absolute above sea level. Absolute height values require a topographical database additionally.

• Flat rooftops are used (horizontal planes).

• Only vertical walls (parallel to the z-axis) are allowed.

• Each building has a single set of material properties which are used for the whole building.

• The polygon of a building must not intersect itself.

• The polygon of a building might intersect other polygons (buildings).

• The polygon of a building might intersect other polygons (buildings).

The following picture shows a part of New York:
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Figure 364: Example of a Vector database: New York.

Generation and Conversion
Urban vector buildings can be generated and converted with the WallMan software.

Indoor 3D Objects
Indoor vector databases describe each arbitrary object.

To limit the complexity of the file and data format, WinProp supports only planar objects. In the indoor
database, they are called walls – but such planar elements are not limited to walls. Also, tables,
cupboards and all further indoor objects can be modeled with these planar elements. The elements can
have an arbitrary number of corners. Round objects must be approximated with planar objects. The
more planar objects, the better the approximation – but also the longer the computation times during
the propagation analysis. Indoor databases offer the following features:

• 3D vector oriented database

• Walls as planar objects with polygonal shape

• Arbitrary location ad orientation in space

• Individual material properties

• Subdivisions with different material properties to model doors and windows

The following picture shows a 3D database of a large office building.
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Figure 365: Example of a 3D database of a large office building.

Figure 366: Example of a scenario with cars.

Generation and Conversion
Indoor vector buildings can be generated and converted with the WallMan software.

Time-Variant
Time variance influences the wave propagation significantly.

Because of time variance effects, WinProp offers a module to consider time-variant effects in the wave
propagation computation. The time-variant vector databases are based on indoor vector databases,
but extend these files with time-variant properties. Each ordinary indoor database can be transformed
into a time-variant database. In addition to indoor databases time-variant databases offer the following
features:

• Motion can be assigned to all objects

• Translation and rotation are possible
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Figure 367: Animation of a time-variant vector database.

Generation
Time-variant vector databases can be generated with the WallMan component.

Tunnels
Tunnel databases have a special layout and can be included.

Generation
Tunnel databases can be generated with the standalone tool TuMan. This component is included in the
WinProp software package.

Figure 368: A tunnel database with a train in the 3D view.
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Photos
Photos are used as background images.

Photos, for example, aerial pictures, can be used as background images or can be converted to vector
data.

6.1.7 Sites and Transmitters
A site represents a base transceiver station (BTS) that allows wireless communication between user
equipment and a network.

The network can be any of the wireless communication technologies like GSM, CDMA, WiFi, and WiMAX.
Multiple transmitters (antennas) can be defined for each site. The propagation will be computed
individually for each transmitter and saved in separate files. The names of the transmitters are added to
the output file name to separate the files. The Sites tab of the Edit Project Parameter dialog gives an
overview of the currently considered sites.

Terrestrial Transmitters
Tools for adding terrestrial transmitters are given.

The WinProp radio network planning tool allows you to define a specific network configuration
comprising the terrestrial transmitter segment. Based on the accurate prediction of the terrestrial
transmitter radio channels by using a deterministic ray-optical (or an empirical) wave propagation
model the coverage performance of the individual transmitter or the defined network is evaluated.

The following tools can be used in the project toolbar:

• Add a new transmitter with the symbol .

• Enable / Disable a transmitter with the symbol .

• Delete a transmitter with the symbol .

• Edit a transmitter with the symbol . 

• Move a transmitter with the symbol .

• Change horizontal orientation of a transmitter with the symbol .

Isotropic Transmitters
Isotropic transmitters are used for cellular networks in indoor scenarios and broadcasting applications in
rural /suburban scenarios.

These transmitters have the following settings:
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Figure 369: The Cell dialog to adjust isotropic transmitter settings.

Number (Nr)
The number of the transmitter is the internal ID and used by ProMan to separate the transmitters
of one project. This is not relevant for the project settings.

Name
The name of the antenna/transmitter is important because it is added to the basic output file
name. If the basic output file name is xy and the antenna name is TRX 1 the results will be
saved in files xy_TRX 1.*. Concerning the name of the antenna the following rules must be
considered:  

• Only characters which are allowed in file names can be used.

• The name must be unique within the project to avoid collisions with other transmitters.

Status of Cell/Transmitter in Project

The transmitter can be enabled or disabled. Only enabled transmitters will be computed. If no
modifications were made, the transmitter can be disabled to save computation time and so
only the modified (and enabled) transmitters are computed when starting the computation. The

transmitter status can also be changed via the project toolbar using the  icon and by clicking

with the mouse on the transmitter. The individual cells within the project can be included or
excluded from the network optimization process.
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The transmitter can be defined as a repeater by selecting the Set as Repeater check box. Upon
selecting this check box, a pull-down menu appears to define the mode of operation. Two modes
of operation are available for a repeater, Reconfigurable Mode and Transparent Mode.

• A reconfigurable repeater will retransmit the signal it receives from the gateway after
amplifying it to a certain user-defined power. Its transmission may be at a different
frequency, but doesn’t have to be.

• A transparent repeater will retransmit the signal it receives from the gateway after amplifying
it by a certain user-defined gain. Its transmission will be at the same frequency.

A few rules apply:

• A repeater has to be a member of a site that includes at least one transmitter that is not a
repeater. This can be the Gateway.

• In network planning, for the calculation of interference, the signal from a repeater always
belongs to the same Signal Group as the signal from the Gateway. Hence, the repeater will
not cause undue interference with the gateway and other repeaters in the same site.

Transmitter and Receiver Settings
The frequency is defined in this section as well as the output power (which is required for the
determination of the received power or field strength). The output power can either be defined in
Watt or dBm and the output power can be defined either as the output power of the PA (power
amplifier), as ERP (equivalent radiated power, for example, relative to dipole antenna), or as EIRP
(equivalent isotropic radiated power, for example, relative to isotropic antenna). If G is the gain of
the antenna (in dBi), the values can be determined via the following equation:

Prediction Area (Cell / Transmitter)

• Default Prediction Area

• Individual Prediction Area

Measurement
This option can be switched on if measurement data is available for the transmitters included in
the project for calibration. This feature allows to automatically calibrate the wave propagation
model based on imported measurement data. Supported measurement files are power results
(.fpp), field strength results (.fpf) and path loss results (.fpl). The files are generated during
the propagation prediction and not during the network computation. These files can then be
processed with a separate stand-alone tool to derive the calibrated settings for the propagation
exponents (before / after the breakpoint for LOS/NLOS conditions).

Polarization
When using GTD/UTD and Fresnel coefficients for the calculation of diffractions or reflections
and transmissions, respectively, arbitrary linear polarizations (between +90° and –90°) can be
considered for the ray-tracing models (SRT & IRT), the dominant path model and the empirical
multi-wall model. The corresponding polarization can be defined for each Tx antenna individually.
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Figure 370: The Polarization dialog.

Tip:  Specify polarization for cells in indoor prediction projects and cells of network projects.

Rural and urban wave propagation simulations do not consider individual polarizations, except if
the IRT model is used. If the urban IRT model is not used, vertical polarization is assumed for all
transmitters. For rural and urban network planning projects, polarization is only taken into account for
the computation of co-channel interference and is not considered during wave propagation prediction.

Location of antenna
Location coordinates of the antenna. The same coordinate system as used for the database must
be used. The coordinates can be entered in the dialog, or the transmitter can also be moved/
placed with the mouse via the menu Project > Transmitter > Transmitter: Move or via the

toolbar using the  icon.

Type of antenna
Select between an isotropic antenna or a directional / sector antenna. An antenna pattern must
only be defined if the directional antenna is enabled. If omnidirectional antennas should be
considered, an isotropic antenna can be selected, and the gain of the omnidirectional antenna can
be added to the EIRP value of the output power.

Tip:  As soon as the horizontal orientation is changed with the mouse via the
corresponding function in the Edit > Transmitter > Transmitter: Azimuth menu,
Directional antenna is set. If directional antenna is chosen, an antenna file has to be
specified.
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Antenna Pattern
Not available.

Vertical Orientation
Not available.

Horizontal Orientation
Not available.

Directional Transmitters
Directional transmitters are used for cellular networks and point-to-point wireless links.

If a directional transmitter/sector antenna is selected (instead of isotropic/omnidirectional), a 3D
antenna pattern file must be selected.

These transmitters have the following settings:

Figure 371: The Cell dialog to adjust directional transmitter settings.

Number (Nr)
The number of transmitters is the internal ID and used by ProMan to separate the transmitters of
one project. This is not relevant for the project settings.

Name
The name of the antenna/transmitter is important because it is added to the basic output file
name. If the basic output file name is xy and the antenna name is TRX 1 the results will be
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saved in files xy_TRX 1.*. Concerning the name of the antenna the following rules must be
considered:  

• Only characters can be used which are allowed in file names.

• The name must be unique within the project to avoid collisions with other transmitters.

Status of Cell / Transmitter in Project

The transmitter can be enabled or disabled. Only enabled transmitters will be computed. If no
modifications were made, the transmitter can be disabled to save computation time and so only
the modified (and enabled) transmitters

The transmitter can be defined as a repeater by selecting the Set as Repeater check box. Upon
selecting this check box, a pull-down menu appears to define the mode of operation. Two modes
of operation are available for a repeater, Reconfigurable Mode and Transparent Mode.

• A reconfigurable repeater will retransmit the signal it receives from the gateway after
amplifying it to a certain user-defined power. Its transmission may be at a different
frequency, but doesn’t have to be.

• A transparent repeater will retransmit the signal it receives from the gateway after amplifying
it by a certain user-defined gain. Its transmission will be at the same frequency.

A few rules apply:

• A repeater has to be a member of a site that includes at least one transmitter that is not a
repeater. This can be the Gateway.

• In network planning, for the calculation of interference, the signal from a repeater always
belongs to the same Signal Group as the signal from the Gateway. Hence, the repeater will
not cause undue interference with the gateway and other repeaters in the same site.

are computed when starting the computation. The transmitter status can also be changed via

the project toolbar using the  icon and by clicking with the mouse on the transmitter. The

individual cells within the project can be included or excluded from the network optimization
process.

Transmitter Settings
The frequency is defined in this section as well as the output power (which is required for the
determination of the received power or field strength). The output power can either be defined in
Watt or dBm. And the output power can be defined as one of the following:

• the output power of the PA (power amplifier)

• as effective radiated power (ERP) - for example, relative to dipole antenna

• equivalent isotropic radiated power (EIRP) - for example, relative to an isotropic antenna

If G is the gain of the antenna (in dBi), the values can be determined via the following equation:

Prediction Area (Cell)

• default prediction area

• individual prediction area
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Measurements
This option can be switched on if measurement data is available for the transmitters included in
the project for calibration. This feature allows to automatically calibrate the wave propagation
model based on imported measurement data. Supported measurement files are power results
(.fpp), field strength results (.fpf) and path loss results (.fpl). The files are generated during
the propagation prediction and not during the network computation. These files can then be
processed with a separate stand-alone tool to derive the calibrated settings for the propagation
exponents (before/after the breakpoint for LOS/NLOS conditions).

Polarization
When using GTD/UTD and Fresnel coefficients for the calculation of diffractions or reflections
and transmissions, respectively, arbitrary linear polarizations (between +90° and –90°) can be
considered for the ray-tracing models (SRT & IRT), the Dominant Path model and the empirical
Multi-Wall model. The corresponding polarization can be defined for each Tx antenna individually.

Tip:  Polarization can be specified for cells in indoor prediction projects and cells of network
projects.

Rural and urban wave propagation simulations do not consider individual polarizations, except if
the IRT model is used. If the urban IRT model is not used, vertical polarization is assumed for all
transmitters. For rural and urban network planning projects, polarization is only taken into account for
the computation of co-channel interference and is not considered during wave propagation prediction.

Location of antenna
Location coordinates of the antenna. The same coordinate system as used for the database must
be used. The coordinates can be entered in the dialog or the transmitter can also be moved/
placed with the mouse via the menu Project > Transmitter > Transmitter: Move or via the

toolbar using the  icon.

Type of antenna
A selection between isotropic antenna and directional /sector antenna. An antenna pattern
must only be defined if the sector antenna is enabled. If omnidirectional antennas should be
considered, an isotropic antenna can be selected, and the gain of the omnidirectional antenna can
be added to the EIRP value of the output power.

Tip:  As soon as the horizontal orientation is changed with the mouse via the
corresponding function in the Project > Transmitter > Transmitter: Azimuth
menu, sector antenna is set. If sector antenna is chosen, an antenna file has to be
specified.

Antenna Pattern
If a sector antenna is selected (instead of isotropic/omnidirectional), a 3D antenna pattern file
must be selected. A relative or absolute path can be added. The antenna pattern file can either be

in a binary format (.apb) or ASCII format (.apa, .msi, .pln or .ffe)[19].

19. Angle-dependant polarization information is obtained from antenna pattern (both Tx and Rx) in the
Feko .ffe file or an .ffe file created in AMan.
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Vertical Orientation
You can specify a mechanical down-tilt (positive values) or a mechanical up tilt (negative values).
An electrical down tilt must be considered in the selected antenna pattern (the pattern is different
depending on the electrical down tilt).

Horizontal Orientation
It can be specified more easily with the option Change horizontal orientation in the Edit ->
Transmitter menu. The direction of the y-axis is 0 degree, the orientation is clockwise (North over
East).

Switch between omnidirectional and directional antennas and changing the horizontal orientation

is done with the function Project > Transmitter > Transmitter: Azimuth or with the  icon in

the project toolbar.

• Click on a transmitter and then draw a line in the desired direction while holding the mouse
button. Then release the mouse button.

• To switch back to an omnidirectional antenna, click on the transmitter and immediately
release the mouse button.

Tip:  If you have defined a directional antenna you must specify an antenna file
using the function Project > Edit Project Parameters and switch or with the

 icon in the project toolbar.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.393

MIMO Site
For network planning projects with MIMO, projects can be defined based on “regular” sites with
transmitters, but that involves repetitive work. Reduce the amount of repetitive work by using MIMO
sites.

Figure 372: The Transmitter Type dialog.

Clicking OK on the Transmitter Type dialog, a site with two or four antennas is created according to
the selected settings (the number of created antenna matches the specified number of MIMO streams).
This is more efficient and less error-prone than creating them one by one and adjusting their individual
properties. All that remains is to adjust the individual positions of the antennas (if needed).

Leaky Feeder Cable
A leaky feeder cable consists of a coaxial cable running along drivages which emits and receives radio
waves.

The cable is leaky in that it has gaps or slots in its outer sheath to allow the signal to leak into or out
of the cable along its entire length. Because of this leakage of the signal, line amplifiers are required
to be inserted at regular intervals, typically every 350 to 500 meters, to boost the signal back up to
acceptable levels.

The system has a limited range, and because of the high frequency it uses, transmissions cannot pass
through solid rock, which limits the system to a line-of-sight application. It does, however, allow two-
way mobile communication.
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Creation
Leaky feeder cables can be created using the mouse tool or by importing the coordinates of the cable
from an ASCII file. New cables can be inserted by choosing Project > Site > Site: New or by selecting

the  icon. Afterward, a dialog opens, where the type of the new transmitter can be selected.

Figure 373: The Transmitter Type dialog.

Note:  The mouse tool can only be used if the Edit Project Parameter dialog is not
displayed. If the Edit Project Parameter dialog is displayed, new transmitters can only be
entered via the Transmitter tab.

In case the cable is drawn with the mouse, the z-coordinates can be defined right after the mouse tool
is closed with the right mouse button. The z-coordinates of all definition points are initialized with the
same height, which can be specified in the following dialog. However, all points can also be edited later.

Figure 374: The Height dialog.

The selected height can be chosen to be an absolute value or to be relative to the contained floor levels
or the topography, respectively.
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Tip:  The definition of the height relative to floor levels or topography is only possible if
the database contains floor levels or topography, respectively. If neither floor levels nor
topography is contained, the specified height is absolute.

Modification of Parameters
Parameters of leaky feeder cables can be modified by selecting the site to be edited on the Sites tab of
the Project dialog or by using the corresponding toolbar icon.

Figure 375: The Site dialog.

Note:  Each site can contain only a single leaky feeder cable. There is no possibility to
define multiple cables within one site.

After selecting the cable, the following dialog is displayed:
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Figure 376: The Cell dialog.

The left part of the dialog shows settings and parameters, which are common for all types of
transmitters. Additional leaky feeder cable specific properties on the right are as follows:

Location of Cable
The coordinates of the cable definition points can be edited, imported or exported from or to an
ASCII file using the following dialog.
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Figure 377: The Coordinates dialog.

Note:  The z-coordinates displayed in this dialog are always absolute coordinates.

Cable Loss [dB/100m]
The cable loss is based on resistance (Ohm) and frequency dependent losses of a cable. The value
must be specified in dB per 100 meters. Reasonable values are between 1 and 30 dB per 100
meters. This parameter is used to determine the loss along the whole cable. Depending on the
length of the cable an additional loss will be determined

Coupling loss (Begin of cable) [dB]
The coupling loss is the attenuation applied at a specific distance (distance coupling loss)
perpendicular to the radiating cable. A coupling loss of 20 dB combined with a distance of 2
meters leads to a path loss value of 20 dB at a distance of 2 meters from the feeding point
(source) of the cable. 

Coupling loss (Gradient) [dB/100m]
The coupling loss can be reduced by defining a (positive) coupling loss gradient. If the coupling
loss at the begin of the cable is 10 dB for example and the coupling loss gradient is 2 dB/100m,
then the coupling loss at the end of a 100-meter long cable is 8 dB. Along the cable, there is a
linear decrease in the coupling loss.

Distance coupling loss [m]
This parameter is the distance used to determine the path loss based on the coupling loss. It must
always be seen in relation to the coupling loss

Note:  For the wave propagation prediction of leaky feeder cables, special leaky feeder cable
models are used, which can be specified and parameterized on the Computation tab.
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Satellites
Satellite transmitters of the geostationary or low earth orbit types can be considered.

Transmitters in ProMan must not be terrestrial. Also, satellite transmitters can be considered.
Geostationary satellites are defined by their height (for example, 36,000 km) and their longitude.
All LEOs (low earth orbit constellations) and navigation satellites are described either by the two line
element method or for the GPS satellites by the data provided in the Almanac data sets. Antenna gains
for the satellite transmitters are considered in the path loss predictions.

The satellite radio transmission to the mobile terminal is strongly affected by the variation of the
received signal power because of the presence of fading phenomena (slow fading due to obstacles
and fast fading due to multipath propagation). Multipath propagation arises from signal reflection and
diffraction on obstacles. In satellite communications, the received signal is usually the superposition of
two components: the main path and a summation of time-delayed scattered paths.

Geostationary
Geostationary satellites are defined by their height and longitude.

Note:  Non-stationary satellites are defined by their height (for example 200 km - 36,000
km), their longitude and their latitude.

Creation
New satellites can be added as follows:

• Click the Add button on the Sites tab of the Edit Project Parameters dialog.

• Use the mouse tool to activate via:

◦ the menu Project > Site > Site: New
◦ the  icon in the project toolbar

Note:  The mouse can only be used if the project dialog is not displayed. If the
Edit Project Parameters dialog is displayed, new transmitters can only be
entered using the Transmitter tab.

• Select the type of transmitter.

• Set the satellite position.
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Figure 378: The Transmitter type dialog set to Geostationary Satellite.

Figure 379: The Satellite Location dialog.

GPS Satellites: Time-Dependent Transmitter Locations
GPS satellites are time-dependent satellites. These satellites should be analyzed over time.

ProMan offers the possibility to define time (UTC time) and a location on the globe (coordinates of a
location in an arbitrary UTM zone, based on WGS 84 coordinate datum) - and then the location of the
satellites relative to this location is computed by ProMan automatically.

In contrary to geostationary satellites for moving satellites, their position cannot be given by longitude
and height over equator but have to compute for a given time based on their ephemeris data (orbital
data). You have to provide the GPS orbit data information. This can be done through one of the
following methods:
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Almanac datasets

The data can be downloaded either from USCG or Celestrak[20] and is weekly updated.

TLE datasets
Data is updated weekly.

After downloading the dataset for the week of interest, you can compute the time-dependent locations
of the GPS satellites for all locations on the globe.

Creation
Click Project > Edit Project Parameter and click the Sites tab to get an overview of the currently
considered sites.

Figure 380: The Edit Project Parameter dialog, Sites tab.

New satellites can be added as follows:

• Clicking on the Add button on the Sites tab of the Edit Project Parameters dialog

• Using a mouse tool which can be activated via

◦ the menu Project > Sites > Site: New
◦ The  icon in the Project toolbar.

Note:  The mouse tool can only be used if the project dialog is not displayed.
If the Project dialog is displayed, new transmitters can only be entered via the
Transmitter tab of the Edit Project Parameter dialog.

• Select the type of transmitter by one of the following methods:

◦ Specify the name of the Almanac or TLE file.

20. http://www.celestrak.com/GPS/almanac/Yuma/
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◦ Select the file by clicking on the Change button.

Figure 381: The Transmitter type dialog, set to GPS Satellites (Almanac Definitions).

Based on the orbit data (for example, given in the TLE-set) and the given time instance the satellite
location(s) relative to the UTM zone (in which the geographic database used for the simulation is
defined) will be computed. Accordingly, two new dimensions have been incorporated in the radio
planning tool: satellite dimension and time dimension. Each defined time instance will lead to a specific
site including the available satellites for the given time and location (for example, above the horizon or
a defined minimum elevation angle).

Based on this moving satellite extension it is possible to compute the LOS areas and the received signal
power for the defined satellites over time, which will be for example useful for the analysis of GPS
performance.

In the next dialog, the reference point and the reference time (GMT) can be defined. By default, the
center of the loaded (building) database is taken as a reference point (including the UTM zone which
can be defined with the WallMan application). On the right side of this dialog, the time instance (GMT)
and a minimum elevation angle can be specified (satellites below this elevation will not be converted).
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Figure 382: The GPS Satellites dialog - Almanac properties.

Figure 383: The GPS Satellites dialog - TLE properties.

All the converted satellites are displayed together with their coordinates in the Sites tab of the Edit
Project Parameters dialog. By adding further sites, it is also possible to simulate various time
instances and therefore to investigate the system availability over time. Each defined time instance will
lead to an individual site (including the available satellites). All defined sites are listed on the Sites tab.

For each defined satellite object the wave propagation can be predicted, for example, the LOS / NLOS
areas, received power, path loss, field strength, and channel profiles.
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Figure 384: The Edit Project Parameter dialog - Sites tab.

Figure 385: The Site dialog for time instances.

Application
To simulate various time instances and, therefore, to investigate the system availability over time the
user has to define multiple sites with individual time settings. Each defined time instance will lead to an
individual site (including the available satellites).
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External Site (Prediction Result)
For network planning projects, interference from external sites can be included in the considerations for
cell assignment and transmission modes.

On the Transmitter Type dialog, select External Site (Prediction Result) and click OK to display
the External Interference dialog (see Figure 386).

Figure 386: The External interference dialog.

As shown in Figure 386, two pairs of options exist, Strength of Signal and Type of Signal.

Strength of Signal

Constant signal power
When this options is selected, you are asked to provide a power level in dBm. For instance,
a transmitter outside the prediction area may produce a power level in the prediction area
of -70 dBm. As an approximation, for example, because the transmitter is far outside
the prediction area, the power level is assumed to be independent of location within the
prediction area.

Signal power defined in result file
An actual propagation simulation result was obtained in another WinProp project. You can
point to the .fpp file in which that result is stored. The prediction areas do not need to be
identical. This can be useful in co-existence studies, for example, when a Bluetooth network
interferes with a Wi-Fi network. Each network has its ProMan project (one air interface per
project), but interference between networks can be included with this option.
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Type of Signal

In-band Interference
The drop-down list is a list of carrier frequencies in the network of interest. When the
interfering transmitter operates at one of those carrier frequencies, it will affect the
transmitters in the network of interest that also operate at that specific carrier frequency.

Out-of-band Interference
An interfering signal that is not at any of the carrier frequencies used by the network of
interest, is considered out of band. That means that its interfering power, whether constant
or from a .fpp file, can be suppressed with a band-pass filter. When this option is selected,
you are asked to specify the additional attenuation produces by the filter, for example,
30 dB.

Automatic Distribution
Sites and transmitters can be automatically distributed based on topography and land usage (optional)
data in rural environments. Four different distribution modes are given.

Sites and transmitters can be automatically distributed based on topography and land usage (optional)
data in rural environments. ProMan offers four different distribution modes, which make it easy to
distribute a large number of sites within a given area. The configuration of the site to be distributed
can be specified arbitrarily by adjusting the parameters of the default site on the Sites tab of the Edit
Project Parameters dialog.

Figure 387: The Initial Properties of New Objects dialog.

The generation and distribution of the preconfigured site can be started by clicking Project > Sites >
Generate automatically.
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Figure 388: The Site Distribution dialog.

Site Distribution Mode

The specified default site can be distributed using four different modes.

• The hexagonal raster option will place the sites according to a hexagonal grid starting at
the lower-left corner of the topography database. The radius of the hexagons, as well as the
distance to the lower-left and the upper-right corner of the database, can be specified by
clicking on the Settings button.

• The homogeneous mode will distribute the sites randomly with a predefined, homogeneous
density of sites per square kilometer. The site density to be used can be specified by clicking
on the Settings button.

• If additional land usage (clutter) data is available, the “land usage” mode makes it possible to
define an arbitrary density of sites per square kilometer for each clutter class separately. As
an example, it is therefore easy to omit areas declared as water or forest.

• The option Fixed number of sites will randomly distribute a given, fixed number of sites.
The number of sites to be generated can be specified by clicking on the Settings button.

Basic Name of Sites
Name of the sites to be generated. This name is appended with a successive number. A change of
the name will not affect the name of the default site, for example, the name will be used only for
the current distribution.

Height of Sites
The height of the sites to be generated. The initial value corresponds to the height specified for
the default site. A change of this value will not affect the value given for the default site, for
example, it will be used for the current distribution only.

Databases
File paths and file names of the available databases.
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Distribution Table
Load, create or edit a site distribution table, which is used for the site distribution mode “land
usage”.

Use Land Usage Data for Distribution of Sites and Transmitters
If additional land usage (clutter) data is available, the distribution mode “land usage” makes it possible
to define an arbitrary density of sites per square kilometer for each clutter class separately. Therefore,
a distribution table has to be defined to map the specified distribution classes to the IDs of the clutter
classes where the given distribution shall be applied.

The following sample shows a distribution table with three distribution classes. For the land usage
classes “open”, “sea”, “forest”, no sites shall be generated. Therefore, a distribution class “No Site” was
created with a site density of 0 sites per square kilometer. Three clutter classes have been assigned to
the “Low Density” distribution class, where only one site within two square kilometers shall be created.
For the distribution class “High Density”, two sites per square kilometer will be distributed randomly. 

Figure 389: The Distribution table dialog.

The following dialog shows the properties of the distribution for a selected distribution class. In the
lower part clutter IDs of the regions, where the specified distribution shall be applied, can be assigned.
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Figure 390: The Distribution dialog for a selected distribution class.

Figure 391: Example of a distribution site with three transmitters.
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Power Definitions
Power for transmitters determine the EIRP and can be specified.

Downlink

Figure 392: Example of a transmitter and receiver downlink scenario with relevant powers specified.

(68)

(69)

For specification of the Tx power in EIRP or ERP mode, you have to define PE (including cable loss and
BS antenna gain). PR1 is the received power including the MS antenna gain.

Note:  For propagation results (PR2, field strength, and path loss) and the propagation
settings (path loss thresholds for ray selection) the MS antenna gain is not considered.

For example, the path loss is computed as PE - PR2 and includes therefore only the BS antenna gain.
Accordingly, the path loss is independent of the selected power mode (OPA, EIRP, ERP) and independent
of the defined cable loss.

In the network planning results both the BS and MS antenna gain is included, for example, they have
the reference to PR1 (maximum received MS power) and PA (minimum required BS transmit power)
in the downlink. For the uplink, they have the reference to PB (maximum received BS power) and PM
(minimum required MS transmit power).
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Uplink

Figure 393: Example of a transmitter and receiver uplink scenario with relevant powers specified.

6.1.8 Components
Model complex radio networks in indoor environments using predefined components from a component
database.

Components are stored in component catalogues, which can be edited and extended with a separate
Component Manager tool called CompoMan.

Figure 394: The CompoMan dialog.

Add Components to Project

Components can be added to the current project using either the  icon from the toolbar or click

Project > Edit Project Parameter. After selecting the type of the new component, the parameters
can be specified.
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Figure 395: The Properties of Components dialog.

ID and Name of Component in Project
The ID of the component is assigned automatically and can not be changed. The name of the
component in the current project can be specified arbitrarily.

Component Filter
Possibility to filter components contained in the global component catalogue according to defined
frequency bands. If a filter is selected, only components, which are specified for this frequency
band are listed for selection in the 'Component' section below.

Component

All components contained in the global components catalogue, which belong to the specified
component type, are listed in the drop-down box. The selected one will be added to the project.

In case the option keep reference to global catalogue is enabled, the component to be
added is referenced to the specification in the global database, for example, if the parameters
of the component in the global catalogue change, the parameters in the project will change
automatically.

If the option is disabled, the parameters of the component will be stored in a locale component
catalogue and are not changed in case the corresponding component of the global catalogue is
modified.

Location
The coordinates of the component.

Carrier
In case of a radiating component, the carrier to be used by this component can be assigned and
edited using the corresponding buttons.
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Cabling of Components

Components can be connected with cables. To draw cables with the mouse, the  icon has to be

selected from the Components toolbar, first. After that, the cabling can be started by clicking on a
component with the left mouse button. Further left-clicks insert cable inflection points. If the cable is
connected to the second component, the right mouse button has to be pressed in the vicinity of this
component.

The cable component can be specified using the Connect Components dialog. In case a component
has multiple inputs or outputs, for example, there are several possibilities to connect the cable, you
need to specify the correct port to connect the current cable.

Figure 396: The Connect Components dialog.

Cables can be deleted individually using the  toolbar icon. If a component, such as a transmitter,

for example, is deleted, connected cables are removed, as well. Moving components also move the
associated cables.

Signal Level Plan
ProMan offers the possibility to visualize a signal level plan of the defined components independent of
their actual position and the database of the scenario. The Signal Level View can be displayed by
clicking Computation > Components: Compute Signal Levels.

The signal level plan shows the following:

• Tx antenna input power

• TX antenna output power

• Cable ID, cable length and attenuation

• Input and output ports
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Figure 397: Components and their signal levels.

Tip:  Turn the mouse wheel to zoom in or zoom out on the signal level plan.

The signal level plan can be exported to .dxf file by clicking File > Export > Export Signal Level
Plan (DXF).

6.1.9 Import and Export
ProMan offers the possibility to import and export data from and to various formats. Besides project
data generated with other prediction or network planning (RNP) tools, measurement and prediction data
can be imported into ProMan as well. All results generated with ProMan can be exported to several data
formats. Wave propagation and radio network planning projects created with ProMan can be exported to
ASCII files. All currently available import and export filters of ProMan are listed below.

Import Filters
• Project data:

◦ MSI Planet (and Siemens Tornado)

◦ Agilent Wizard

• Site and transmitter data:

◦ CSV (comma-separated values) file

◦ TRX or a NET file

• Measurement data:

◦ ASCII file

• Prediction data:

◦ ASCII file

Export Filters
• Project as ZIP archive

• Air interface properties:

◦ Wireless standard file

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.414

• Site and transmitter data:

◦ CSV (comma-separated values) file

◦ TRX file

• Prediction data:

◦ Bitmap (screenshot)

◦ Geo-referenced bitmap

◦ Google Earth™ overlay data

◦ Drawing interchange format

◦ Extensible markup language (XML)

◦ ASCII file

◦ ASC grid

◦ Export prediction data along a polyline

All filters support the export of the whole predicted simulation area as well as the export of an arbitrary
zoomed area.

Besides exporting prediction data of a user-defined simulation area with the export filters listed above,
it is also possible to export prediction results along with an arbitrary defined polygonal line.

Network Configuration

Import Project Data

ProMan offers import filters for project data generated with other prediction or network planning (RNP)
tools. Currently, the following tools are supported:

• MSI Planet (and Siemens Tornado)

• Agilent Wizard

Projects and network data generated and obtained with these network planning tools can be imported
directly into a WinProp project. The location and properties of the sites, the carrier settings, and all
further parameters will be converted into a ProMan network project.
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Figure 398: The Import Sites, Transmitters & Antennas dialog.

Export Project as ZIP Archive
Export a project along with its antenna patterns and geometry database to an archive using relative file
paths. This feature allows you to exchange project files between different machines and users.

A WinProp project can be exported to zip archive by clicking File > Export > Export Project as ZIP
Archive. This option is only available if the project view is currently active.

Figure 399: The Export project including all required data dialog.

Export results
Select this option to include the propagation results when exporting the project to a zipped
archive.

Export display settings
Select this option to include the current display settings when exporting the project to a zipped
archive.
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Export Air Interface Data
Settings and parameters of an air interface can be exported to a wireless standard file (.wst) file.

This makes it possible to store the complicated collection of parameters to re-use them for the creation
of a new network planning project. Click File > Export > Export Air Interface Properties (*.wst).
This option is only available if the current project is a network planning project, for example, if an air
interface has been defined for the project.

Site and Transmitter Data

Sites and antennas in ProMan have many properties, such as position, name, antenna pattern, azimuth,
downtilt, frequency, power, and more. When you have defined a number of sites, antennas and their
properties in one project and need to use a similar configuration in another project, it can be convenient
to export the relevant information to a suitable file and import it into another project. This saves time
when setting up new projects that are similar to existing ones, and reduces the chance of errors.

The following options are available to import or export site and transmitter data:

• Use a .csv file to import/export only selected or all properties of the sites and antennas.

• Use a .net file to import all properties of the sites and antennas.

• Use a .trx file to import/export all properties of the sites and antennas.

Import Sites and Transmitter Data

Import Data From a CSV File
The CSV file format is used to save tabular data such as numbers and text in a textual form, for
example, in ASCII format, so that it can be read with a text editor. Lines are similar to the rows of a
table and commas separate each horizontal neighbor fields. The ProMan implementation of CSV allows
you to import data with other separators, for example, semi-colon.

The content of the CSV file should represent a list of sites. ProMan interprets each column as a property
of a site, for example, power, frequency or name.

Click File > Import > Import Sites/TRX/Cells > CSV File (*.csv) to import data from a CSV file.
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Figure 400: The Import of antennas from CSV files dialog.

The following settings can be adjusted:

File
Full path of the .csv file. The second line gives a preview of the first line in the .csv file.

Note:  This first line can be used as a help to understand, which column represents
which property.

Input Format
Defines the separator of the columns as well as the separator of decimal numbers. The First line
is heading check box enables or disables the interpretation of the first line as declaration line.

Column Selection
Defines the interpretation for each column. Items, which have been chosen from the selection
box on the right can be inserted with the Insert button. Use the Insert all button to select and
import all transmitter quantities in the .csv file. The Information box below the column list
provides additional information about the different import options, such as supported formats.

Import Data From a TRX or NET File
The TRX file format is used to import all properties of the sites and antennas.

Click File > Import > Import Sites/TRX/Cells > ProMan Project File (*.trx, *.net) to import
data from a .trx file or from a project (.net) file.

If you select to import the site and transmitter properties from a .net file, ProMan extracts the relevant
data automatically from the project (.net) file.
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Export Sites and Transmitter Data

Export Data to a CSV File
Lines are similar to the rows of a table and commas separate each horizontal neighbor fields. The
ProMan implementation of CSV allows you to import data with other separators, for example, semi-
colon.

The content of the CSV file should represent a list of sites. ProMan interprets each column as a property
of a site, for example, power, frequency or name.

Click File > Export > Export Sites/TRX/Cells > CSV File (*.csv) to export data to a CSV file.

Figure 401: The Export of antennas from CSV files dialog.

The following settings can be adjusted:

File
Full path of the .csv file.

Output Format

Defines the separator of the columns as well as the separator of decimal numbers.

Export headline check box enables the export of the first line of the CSV file, which represents
the title for each column. It can be used as a help to understand, which column represents
which property. By enabling Export Power Mode and Export Power Unit the power mode (for
example, Output PA) and the unit (for example, dBm) can be exported additionally.

Column Selection
Defines the interpretation for each column. Selected items can be inserted with the Insert
button. An item in the list defines a property of the sites to be exported. Under Information, you
can view additional information about the different export options, such as supported formats.
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Export Data to a TRX File
The TRX file format is used to export all properties of the sites and antennas.

Click File > Export > Export Sites/TRX/Cells > ProMan File (*.trx) to export data to a TRX file.

Data and Results

Export Along a Polygonal Line
Results can be exported along a polygonal line.

WinProp's result data can be exported along an arbitrary polygonal line. Click File > Export > Export
Data (Polyline). This polygonal route has to be defined in ProMan with the mouse. from the sub menu,
you can either select to export the currently active result directly or to create a polygonal mask for
multiple exports.

For the second case, the defined polyline is stored in an ASCII file which can be applied for several
results. To draw the polyline press the left mouse button at the starting point and keep it pressed until
the last point of the polyline is reached. To insert further points in-between click the right mouse button.

Figure 402: Example of a polyline created for export of data.

The result values are extracted along the route after the user has defined the sampling distance
between two adjacent points and saved in an ASCII file. This file contains longitude, latitude and height
information corresponding to each result value as well as the distance to the starting point.

Based on this feature, virtual drive tests are feasible. In contrast to the usage of real measurements,
the drive test emulator will provide reproducible results along the defined routes. The shown evaluation
of the best server map gives an impression of the required cell changes (hand over) during the drive
test.
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Figure 403: Example of the best server map.

Figure 404: Example of a virtual drive test.

Export to ASCII
Export prediction results to ASCII file.

Prediction results can be exported to ASCII files. Click File > Export Data (Area) > Export ASCII.
During the export operation, the Export of Measurement Data dialog opens, which gives further
possibilities to specify the format of the file to be created.
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You have the option to specify the header section of the ASCII file as well as the format of the
prediction values (table or matrix format). Unpredicted pixels can be excluded from the export or
highlighted with a user-defined expression. The data block can be indicated with special keywords to
make further processing of the data easier. 

Figure 405: The Export of Measurement Data dialog.
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Figure 406: An exported ASCII file in tabular format.

Export to ASC Grid
Export prediction results to ASCII file.

Prediction results can be exported to ASC Grid files, click File > Export > Export Data (Area) >
Export ASC Grid.

The first six lines indicate the reference of the grid, followed by the values listed in the order they would
naturally appear (left-right, top-down).

• ncols and nrows are the numbers of rows and columns, respectively (represented as integers)

• xllcorner and yllcorner are the eastern / longitude (left) x-coordinate and northern / latitude
(bottom) y-coordinates (represented as real numbers with an optional decimal point)

• cellsize refers to the resolution of the grid

• NODATA_value is the value that is regarded as “missing” or “not applicable”

• The remainder of the file lists the raster values for each cell, starting at the upper-left corner. These
are real numbers and are delimited using a single space character or a tab.

The following example shows an ASC Grid export in tabular format:

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.423

Figure 407: Example of an ASC grid export in tabular format.

Export to Bitmap
The current view can be exported to bitmap.

The bitmap export creates a bitmap on the hard disk based on the current view. Click File > Export
Data > Export Bitmap (Screenshot) or with the  icon in the toolbar.
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Figure 408: The Export to image file dialog.

Map view
The aspect ratio of the map view is fixed and cannot be modified. You can either adapt the
resolution or define a scale for the resulting bitmap. When using the scaled export, the resolution
in dpi is set to the resolution of the screen (for example, 96 dpi). Additionally, the scale in the
map view can be exported to the bitmap.

Note:  Incorrect scale sizes may result in large bitmap files.

Legend view
The legend view can also be exported. The legend can either be saved to a separate file or in the
same file as the map view. The height in pixels of the exported legend will be the same height as
of the main bitmap.

The following file formats are supported:

• bitmap (.bmp)

• joint photographic experts group / JPEG (.jpg)

• portable network graphics / PNG (.png)

• graphics interchange format / GIF (.gif)
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Export to DXF
The prediction results can be exported to .dxf.

Prediction results can be exported to the common data interchange format (.dxf). Click File > Export
Data (Area) > Export DXF. This option makes it possible to visualize WinProp prediction results with
arbitrary CAD tools.

Figure 409: Wave propagation predictions for a building floor.

Figure 410: Wave propagation predictions inside a railway tunnel.

Export to Geo-Referenced Bitmap

Geo-Referenced Bitmap
Export the geo-referenced data by clicking File > Export > Export data (Area) > Export Geo
Bitmap.

The geo-referenced bitmap export of ProMan creates a bitmap where each pixel of the prediction
area becomes a pixel of the resulting bitmap. Additionally, an ASCII file containing the geographical
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information is created. This export option can be used to visualize WinProp prediction data in third-party
GIS tools.

The following images formats are supported:

• .bmp

• .jpg

• .pcx

• .png

• .tga

• .tif

Figure 411: Example of a geo-referenced map.

Figure 412: The ASCII file containing the pixel size, rotation about axes and the X and Y coordinates.

The ASCII file contains the following information:

• Line 1: Pixel size in the x-direction in map units per pixel.

• Line 2: Rotation about the y-axis.

• Line 3: Rotation about the x-axis.

• Line 4: Pixel size in the y-direction in map units per pixel.

• Line 5: X-coordinate in meter of the center of the upper-left pixel.
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• Line 6: Y-coordinate in meter of the center of the upper-left pixel.

Export to Google Earth

Google Earth™ Overlay Data
ProMan offers the possibility to export prediction data to Google Earth™. Click File menu File > Export
Data (Area) > Export Google Earth.

The following images formats are supported:

• .bmp

• .jpg

• .pcx

• .png

• .tga

.tif

Besides the image file, the export functionality automatically generates a .kml file, which can be loaded
with Google Earth™ to visualize the prediction result as an overlay.

Figure 413: Example of Google Earth overlay data (top view).
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Figure 414: Example of Google Earth overlay data (side view).

Export to Extensible Markup Language (XML)
The prediction data can be exported to XML.

ProMan offers the possibility to export prediction data to a .xml file. Click File > Export Data
(Area) > Export XML.

Import Prediction Data
The prediction results can be imported from other tools in ASCII format.

To import prediction results from an ASCII file, an already existing ProMan result file of the same value
type has to be opened.

Click Import > Import Data. As the coordinates used in the ASCII file must match the ones of
the result file, you can convert and adjust the coordinates of the ASCII file during import. The data
contained in the currently active result view can be deleted before importing the new data by selecting
the option in the lower-left part of the dialog.

In the right part of the dialog, the format of the data contained in the ASCII file can be specified.
The data to be imported has to be in a tabular format with longitude / latitude coordinates and a
corresponding value for the prediction. The columns to be imported can be specified within the import
dialog. In case the ASCII file contains a header section, keywords indicating the data section to be
imported have to be entitled in the lower-right part of the dialog.
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Figure 415: The Measurement Import dialog.

The following example shows an ASCII import file with a header section and a keyword for the
indication of the data section. The value “N.C.” stands for not computed, for example, this point is left
white in the graphical display.
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Figure 416: An example of an ASCII import file.

6.1.10 Component Database
WinProp features a component database with manufacturer information. Components such as
combiners, splitters, amplifiers can be added for modeling of the propagation environment.

WinProp supports the modeling of complex RF networks in indoor settings through its component
system. Cable losses and similar factors are taken into account and antenna outputs adjusted
accordingly.
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Figure 417: A complex RF network scenario in ProMan.

Every project that contains components needs a component database that contains information about
all available components, for example, manufacturer and model.

Component databases are created and altered with the tool CompoMan.

Figure 418: The CompoMan tool.

To create a new component, click the corresponding button in the toolbar or select it from the main
menu. The edit dialog displays all relevant information for the specific component type.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.432

Figure 419: The Antenna dialog.

Besides the technical details, each component can be assigned a number of frequency bands. These
frequency bands are useful when adding components to network projects, as the list of available
components can be limited to a single band, making the list more comprehensible.

The list of available frequency bands can be edited by clicking Settings > Frequency Bands from the
main menu in CompoMan.

Figure 420: The Frequency Bands dialog.

Components are available in indoor network projects. To create new components, click the Component
button from the components toolbar.

Most components can be placed freely in the building. The exception is cables of all kind, which always
need to be connected to existing components (for example, transceivers or antennas). After placing a
new component, its properties can be edited in the next step.
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Figure 421: The Properties of component dialog.

Selecting a value in the Band field limits the selection of components to those available in the specified
band.

Component attributes can be edited at any time by clicking Edit Carrier.

When adding cables, it is necessary that they always start and end at another component (that is not
a cable). Click with the left mouse button to place the starting point of a cable. All subsequent clicks
define additional corner points for the cable. With a right-click on an existing component, a cable is
defined and connected to the components at its start and end automatically.

Note:  When deleting a component, all cables attached to it are deleted as well.
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6.2 Propagation Projects

6.2.1 Set Up a New Project
Learn how to set up a new project.

Set Up a Wave Propagation Project
To start a new wave propagation project in ProMan click File > New Project.

After selecting New Project, a new dialog is launched, where you have to specify the scenario and the
database to be used for the new simulation project.

You will be asked to specify the display height (z-coordinate) for the 2D display later. The selected
height can be changed later via Display > Change Height in Display.

Figure 422: The New Project dialog.

Wireless Technology
For a pure wave propagation project select Propagation Analysis (without network
planning).

Note:  No network predictions are possible if Propagation only mode is selected.

Scenario
Selection of the environment (rural, urban, indoor, tunnel, time-variant) for the propagation
project, depending on the available database.
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Databases
Selection of the database file which shall be used for the simulations. Depending on the chosen
scenario, one or multiple database files can be specified here.

For rural or suburban scenarios, topography and clutter databases can be either pixel or vector
based databases. Vector-based topography and clutter databases are required for the rural ray-
tracing model and can be selected after selecting the corresponding check box in the upper
section.

Note:  For simulations with the intelligent ray-tracing (IRT) wave propagation model
a preprocessed database is required. This preprocessing has to be done with WallMan
before the database is selected here.  

Polarimetric Analysis

Standard (suitable for all scenarios and propagation models)
The antenna pattern (both for Tx and Rx) can come from a Feko .ffe file (which contains
polarization information but the standard option will only extract the total gain) or
from other file formats such as .apa file, .apb file or a .msi file (which do not contain
polarization information). When this Standard option is used, the polarization information
is defined when antenna patterns are assigned to individual transmitters. The selected
polarization direction and cross-polarization level (Figure 423) apply uniformly to all
directions in the radiation pattern.

Figure 423: The Polarization dialog.

Full (limited selection of scenarios and propagation models)

Angle-dependent (direction-dependent) polarization information is obtained from the
antenna pattern (both Tx and Rx) in the Feko .ffe file or an .ffe file created in AMan.
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The .ffe file contains the polarimetric information (gain and polarization) where separate
patterns for theta and phi polarization are included in the file.

Due to the level of detail, this option can only be selected in conjunction with non-empirical
prediction models that take the polarization accurately into account. These are standard ray
tracing, intelligent ray tracing, and the multi-wall model with the use of Fresnel coefficients/
UTD for transmission, reflection and diffraction. Figure 424 shows the dialog in case of an
indoor scenario.

Figure 424: The Edit Project Parameter dialog - Computation tab. Available prediction
models (scenario dependent) and selection of Fresnel/UTD for the full polarimetric analysis.

Configuration of a Propagation Project
After setting up a propagation project, further configurations have to be done to do simulations.
Parameters related to the simulation project can be edited by clicking Edit Project Parameter... from

the Edit menu or the corresponding toolbar icon . On the different tabs of this dialog, the following

configurations have to be done, before predictions can be calculated:

Simulation tab
The simulation area can be changed here by editing the lower-left and upper-right corner
coordinates. By default, the full area of the database will be predicted. The resolution grid of the
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result matrix as well as the heights of horizontal prediction planes can be changed (only if the
database was not preprocessed in area mode).

Figure 425: The Area of Planning / Simulation tab of the Edit Project Parameter dialog.

Propagation tab
On this tab, you have to specify a directory where the computed propagation results shall
be saved. Besides this, all simulation results which can be computed with the selected wave
propagation model are listed here. You can select available result types by selecting the related
check box.
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Figure 426: The Propagation tab of the Edit Project Parameter dialog.

Database tab
No changes are required here, as the databases have been loaded during setup of the network
project.

Computation tab
The wave propagation model and the settings have to be specified on the Computation tab.
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Figure 427: The Computation tab of the Edit Project Parameter dialog.

After the configuration of the project (including definition of sites / transmitters), the simulation process
can be started by selecting either Propagation: Compute All from the Computation menu or the
corresponding toolbar icon. Besides the computation of all transmitters, it is also possible to compute
only selected transmitters or transmitters which have been modified during the planning process by
selecting the corresponding menu item form the Computation menu.

Note:  If propagation results are already available in the specified output directory, you will
be asked if the existing results shall be overwritten. In case yes is chosen, ProMan will erase
all already existing results for the transmitter to be re-computed before the computation is
started.
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6.2.2 Selection of Scenarios
Different wave propagation models (computational methods) exist to simulate the propagation
environment. These models are necessary to determine propagation characteristics for any arbitrary
configuration.

For the installation of mobile radio systems, wave propagation models are necessary to determine
propagation characteristics for any arbitrary configuration. The predictions are required for a
proper coverage planning, the determination of multipath effects as well as for interference and cell
calculations, which are the basis for the high-level network planning process. In a GSM/DCS-system,
this planning process includes for example the prediction of the received power to determine the
parameter sets of the base stations. Since the introduction of wireless broadband services in third-
generation systems (UMTS) or in Wireless Local Area Networks (W-LAN) the wideband properties
(for example, delay spread, angular spread, and impulse response) of the mobile radio channel has
become more and more important for the planning process. The environments where these systems
are intended to be installed, are ranging from indoor up to large rural areas. Hence wave propagation
prediction methods are required covering the whole range of macro-, micro- and pico-cells including
indoor scenarios and situations in special environments like tunnels or along highways.

Figure 428: Example of a propagation environment scenario.

Rural and Suburban
In macro-cellular prediction models, forward propagation including multiple diffractions over terrain
and buildings is applied. Scattering and reflection from hills, mountains, and buildings can generally
be neglected because the base station is located above the surrounding obstacles to cover a large
area. Possible applications are, for example, broadcasting transmitters or base stations in very low
populated areas. The predictions are based on the knowledge of topography, land usage and in few
models additionally building height information.

Urban
The design and implementation of personal communication systems require the prediction of wave
propagation relating to signal-to-noise and signal-to-interference calculation in a cellular system.
Small cell network configurations – especially micro and pico cell types – are of major interest in
urban environments because of the increasing capacity demands. The commonly used criterion for the
definition of a micro cell is related to the height of the base station antenna. For a typical micro cell, the
base station antenna height is below the average rooftop level of the surrounding buildings or about
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the same height. Thus the resulting cell radius is in the range of 250-500m. A further characteristic is
the low transmitting power. However, a prediction range up to several kilometers has to be regarded
for inter-cellular interference calculations. A pico cell base station is usually installed inside a building
providing coverage also outside around the building.

Indoor
Predicting the propagation characteristics between two antennas inside a building is important
especially for the design of cordless telephones and Wireless Local Area Networks (WLAN). Also, the
installation of cellular systems with indoor base stations involves the usage of indoor propagation
models. The indoor propagation channel differs considerably from the outdoor one. The distance
between transmitter and receiver is shorter due to high attenuation caused by internal walls and
furniture and often also because of the lower transmitter power. The short distance implies a shorter
delay of echoes and consequently lower delay spread. The temporal variations of the channel are slower
compared to mobile antennas moving with a car. As it is the case in outdoor systems, there are several
important propagation parameters to be predicted. The path loss and the statistical characteristics of
the received signal envelope are most important for coverage planning applications. The wide-band and
time variation characteristics are essential for evaluation of the system performance.

Rural and Suburban

Propagation Models

For the prediction, topographical databases (digital elevation model, DEM) are needed. They consist of
binary stored pixel data with an arbitrary resolution, for example, 50m x 50 m. However, the resolution
in one database must be constant. Also morphological data can be considered by empirical correction
values to improve the accuracy of the model. This data is also stored as binary data. The different
morphological properties are coded, for example:

• urban

• suburban

• forest

• water

• acre

Propagation Models
WinProp offers various wave propagation models for rural and suburban environments.

• Empirical models without consideration of the terrain profile between transmitter and receiver

◦ Hata-Okumura model

◦ Empirical two ray model

◦ ITU P.1546 model

• Basic topographical profile prediction models (2D vertical plane models)

◦ Deterministic two ray model

◦ Longley-Rice model
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◦ Parabolic equation method

◦ Knife edge diffraction model

• Deterministic 3D models (3D topography)

◦ Rural dominant path model

◦ Rural ray-tracing model

Okumura-Hata Propagation Model
The Okumura-Hata propagation model is a simple empirical model with short computation time.

With this model, only the transmitter and receiver height are processed. The terrain profile between
transmitter and receiver is not considered. If, for example, a hill is located between transmitter and
receiver, its shadowing effect is not taken into account.

Click Project > Edit Project Parameter and click the Computation tab.

Parameters
Because of the calibration with measurement data, the Okumura-Hata-model is restricted to the
following ranges for the different parameters:

• frequency f (150...1500 MHz)

• distance between transmitter and receiver d (1...20 km)

• antenna height of the transmitter  (30...200 m)

• antenna height of the receiver  (1...10 m)

As the height of the transmitter and the receiver is measured relative to the ground, an effective 
antenna height ( ) is determined to account for the topographical impact. The transmitter antenna
height above ground Hb, used in both the formulas of the Okumura-Hata propagation model and in the
formulas of the Extended Hata model, is equal to  if  ≤ , and is equal to  if  > . This
improves the accuracy of the prediction.

htxheff

d
hrx

Tx

Rx

Figure 429: Effective antenna height for the Okumura-Hata propagation model.

Settings
ProMan offers two variations for the computation:

• Homogenous environment: For the full prediction area, a homogeneous environment is considered
without the settings in the morpho / clutter database.

• Individual environment: As defined in morpho / clutter database.
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Figure 430: The Parameters of Okumura Hata dialog.

Computation
The following equations show the computation of the basic path loss (in dB) with the model of Hata-
Okumura.

(70)

Where,

• L = path loss (dB)

• f = frequency (MHz)

• Hb = transmitter antenna height above ground (m)

• Hm = receiver antenna height above ground (m)

• d = distance between transmitter and receiver (km)

• a(Hm) = antenna height correction factor

defined as follows:

For medium urban area (medium, small city):

(71)

For dense urban area (large city):

(72)

(73)
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For the suburban or open environment, a correction factor is taken into account as in the following
formulas:

(74)

(75)

with the following model restrictions:

• f: 150 MHz to 1500 MHz

• Hb: 30 m to 200 m

• Hm: 1 m to 10 m

• d: 1 km to 20 km

Extended Hata Model

The Okumura-Hata model was extended to the frequency bands from 30 MHz to 3000 MHz[21]. This
combination is denoted as the “Extended Hata model”.

Activate the extended Hata model on the Parameters of Okumura Hata dialog, under Frequency,
select the Use extended Hata model (covers the frequency range 30 MHz - 3 GHz) check box
(see Figure 430).

Urban
30 MHz < f ≤ 150 MHz:

(76)

150 MHz < f ≤ 1500 MHz:

(77)

1500 MHz < f ≤ 2000 MHz:

(78)

2000 MHz < f ≤ 3000 MHz:

21. Report ITU-R SM.2028-2 “Monte Carlo simulation methodology for the use in sharing and
compatibility studies between different radio services or systems”, section 6.1, published June
2017.
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(79)

Suburban

(80)

Open Area

(81)

Where,

• L = path loss (dB)

• f = frequency (MHz)

• Hb = transmitter antenna height above ground (m)

• Hm = receiver antenna height above ground (m)

• d = distance between transmitter and receiver (km)

• a(Hm), b(Hb) = antenna height correction factors, defined as follows:

(82)

The exponent  is a distance correction factor for distances > 20 km, defined as follows:

(83)

with the following model restrictions:

• f: 30MHz to 3000 MHz

• Hb: 30m to 200 m

• Hm: 1 m to 10 m

• d: 0.1 km to 100 km, but in practice, it is recommended to use it up to 40 km.

Empirical Two-Ray Model
The empirical two-ray model (ETR) model computes the path loss to each pixel based on the
assumption that the direct ray and the ground-reflected ray would exist.

There is no check if the rays do exist or if they are shadowed. The visibility check is only made in the
deterministic two ray model (DTR) which considers rays only if they are not shadowed.

Click Project > Edit Project Parameter and click the Computation tab.
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Figure 431: Example of the power obtained with an empirical two-ray model.

The figure shows a prediction with the ETR model in a hilly scenario. The received power is predicted
for all pixels independent of the visibility status between transmitter and receiver. The predicted values
for the path loss do not depend on the LOS or NLOS status. To include an additional loss for all pixels
which have no LOS to the transmitter, the ETR must be combined with the knife edge diffraction model
to include the diffractions at the topographical obstacles.

Settings

Figure 432: The Parameters of Two Ray Model dialog.

The Breakpoint describes the physical phenomenon that further than a certain distance the received

power decreases with  instead of  which is valid for the free space
propagation. This is due to the superposition of the direct ray with a ground reflected contribution.

The following parameters influence the consideration of the breakpoint effect.

Exponent before breakpoint / Exponent after breakpoint
These two exponents influence the calculation of the distance-dependent attenuation. The default
values are 2 for the exponent before the breakpoint and 4 for the exponent after the breakpoint.
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(Additional) breakpoint offset
The breakpoint distance depends on the height of the transmitter and receiver as well as the

wavelength (the initial value is calculated according to ). This value can be modified

by setting an additional offset (in meters).

Tip:  Use the default values. Changes are only required for tuning purposes in comparison to
measurements.

ITU P.1546 Model
This model is used for point-to-area radio propagation predictions for terrestrial services in the
frequency range 30 MHz to 3 000 MHz.

The model is intended for use on tropospheric radio circuits over land paths, sea paths and mixed land-
sea paths between 1-1000 km length for effective transmitting antenna heights less than 3000 m.
The method is based on interpolation / extrapolation from empirically derived field-strength curves as
functions of distance, antenna height, frequency and percentage time. The calculation procedure also
includes corrections to the results obtained from this interpolation/extrapolation to account for terrain
clearance and terminal clutter obstructions.

Click Project > Edit Project Parameter and click the Computation tab.

The propagation curves represent field-strength values for 1 kW effective radiated power (ERP) at
nominal frequencies of 100 MHz, 600 MHz and 2 000 MHz, respectively, as a function of various
parameters; some curves refer to land paths, others refer to sea paths.

Figure 433: An example of field strength values for the ITU P.1546 propagation model.

The curves are based on measurement data mainly relating to mean climatic conditions in temperate
regions containing warm seas, for example, the Mediterranean Sea. The land-path curves were
prepared from data obtained mainly from temperate climates as encountered in Europe and North
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America. The sea-path curves were prepared from data obtained mainly from the Mediterranean Sea
regions.

The model takes account of the effective height of the transmitting/base antenna, which is the height of
the antenna above terrain height averaged between distances of 3 km to 15 km in the direction of the
receiving / mobile antenna.

Settings

Figure 434: The Parameters of ITU P.1546 Propagation Model dialog.

Location probability
Location propability refers to the spatial statistics of local ground cover variations. Thus for a land
receiving / mobile antenna location the field strength E which will be exceeded for q% of locations
is given by:

(84)

where:

is the inverse complementary cumulative normal distribution as a function of probability.

is the standard deviation of the Gaussian distribution of the local means in the study area.
Values of standard deviation are dependent on frequency and environment, and empirical
studies have shown a considerable spread.

Time variability
The propagation curves represent the field-strength values exceeded for 50%, 10% and 1% of
time. Other values will be interpolated. This model is not valid for field strengths exceeded for
percentage times outside the range from 1% to 50%.

Special settings for receivers in urban scenarios (clutters)
The ITU-1546 model distinguishes urban, non-urban, and sea areas. For low receiver heights (for
example, 1.5m) the computed signal levels are partly higher in urban areas than in non-urban
areas (if Rx height below the urban reference height). With this additional parameter it is possible
to avoid this case and to always assume that the Rx height is above the urban reference height.
Based on this the predicted urban signal levels are below the non-urban signal levels as expected.
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Deterministic Two Ray Model
The deterministic two-ray (DTR) model computes the direct ray and the ground reflected ray with ray
optical algorithms.

If the rays are shadowed by obstacles, they are not considered. This is the difference to the empirical
two ray model (ETR) which considers both rays independent of their existence (that is if they are
shadowed or not).

Click Project > Edit Project Parameter and click the Computation tab.

Figure 435: Example of the power obtained with the deterministic two ray (DTR) model in a hilly scenario.

As explained above, received power is only predicted for pixels which can be reached by the direct ray
and the ground reflected ray. All pixels in areas without LOS to the transmitter are not predicted. To get
a prediction also for these pixels, the DTR must be combined with the knife edge diffraction model to
include the diffractions at the topographical obstacles.

For the specular reflection the incident angle of the ray and the reflected angle must be identical. The
material properties of the ground can be defined and the reflection loss is computed depending on the
angle of incidence and the material properties.
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Settings

Figure 436: The Parameters of Ray Optical Prediction dialog.

The following types of rays can be computed:

• direct ray

• reflected ray with the following settings:

◦ tolerance for specular reflections

◦ default ground properties with electrical properties

◦ ground properties as defined in clutter / morpho table

Longley-Rice Model
The Longley-Rice (or irregular terrain) model predicts long-term median transmission loss over irregular
terrain relative to free-space transmission loss.

The model was designed for frequencies between 20 MHz and 40 GHz and for path lengths between 1

km and 2000 km and was intended for frequency planning; mainly in television broadcasting[22]

The Longley-Rice model has two prediction modes:

• point-to-point mode

• area mode

The two modes are distinguished mostly by the amount of input data that is required. The point-to-
point mode must provide terrain profile details of the link that the area prediction mode estimates using
empirical medians.

22. The basic algorithm was created in 1968 by A. G. Longley and P. L. Rice from the Environmental
Science Services Administration Research Laboratories, Tropospheric Telecommunications Labs in
Boulder, Colorado, USA.
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Click Project > Edit Project Parameter and click the Computation tab.

Point-to-Point Mode
The point-to-point mode takes into account the terrain elevation profile between transmitter and
receiver.

Figure 437: The Parameters of ITM (Irregular Terrain Model) dialog.

General

Radio Climate
One out of seven predefined climate regions can be specified here.

Earth Curvature
This parameter will be used to determine the surface refractivity.

Note:  Disable the Consideration of curvature of earth surface check box
for simulations with this propagation model. Click Project > Edit Project
Parameter and click the Pixel Databases tab.

Electrical Properties

Use Default Values
A single value for dielectric permittivity and conductivity of the ground can be specified
for the full simulation scenario. The drop-down boxes offer predefined values for typical
environments. User defined values can be specified by selecting Arbitrary Value from the
drop-down list and editing the field accordingly.
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Use Values Defined in Clutter Table
In case the simulation project contains a clutter database, dielectric permittivity and
conductivity parameters can be assigned automatically according to the specification of the
clutter classes. This makes it possible to specify these parameters as location dependent.

Statistics

Reliability
Level of reliability. Reliability refers to a measure of the variability that a radio system
observes during its use.

Confidence
Level of confidence. Confidence refers to the variability that remains after specifying
reliability, measurable in the aggregate of a large number of radio systems.

Area Mode
The area mode does not consider the terrain elevation database specified for the simulation project. The
area prediction mode estimates the terrain profile using empirical medians. Therefore, some additional
parameters have to be defined.

Figure 438: The Parameters of ITM (Irregular Terrain Model) dialog set to Area Mode.

General

Radio Climate
One out of seven predefined climate regions can be specified.
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Earth Curvature
This parameter determines the surface refractivity.

Note:  Disable the Consideration of curvature of earth surface check box
for simulations with this propagation model. Click Project > Edit Project
Parameter and click the Pixel Databases tab.

Terrain Irregularity
This parameter describes the roughness of the terrain, which is defined as the inter decile
value computed from the range of all terrain elevations for the area.

Site Criteria

Criteria describing the care taken at each terminal to assure good propagation conditions.
This is expressed qualitatively in three steps: random, careful, and very careful.

When the terminals of a system are usually sited on high ground and some effort is made
to locate them at sites, where the signals appear to be particularly strong, the siting is very
careful.

When most of the terminals are located at elevated sites, but with no attempts to select
points where signals are strong, the siting is careful.

Finally, when the choice of antenna sites is dictated by factors other than radio reception,
the siting is assumed to be random.

Electrical Properties

Use Default Values
A single value for dielectric permittivity and conductivity of the ground can be specified
for the full simulation scenario. The drop-down boxes offer predefined values for typical
environments. User defined values can be specified by selecting Arbitrary Value from the
drop-down list and editing the field accordingly.

Use Values Defined in Clutter Table
In case the simulation project contains a clutter database, dielectric permittivity and
conductivity parameters can be assigned automatically according to the specification of the
clutter classes. This makes it possible to specify these parameters as location dependent.

Statistics

Time
Represents the fraction of time during which the losses are less than the calculated loss.

Locations
Represents the fraction of locations at which the losses are less than the calculated loss.

Confidence
Level of confidence. Confidence refers to the variability that remains after specifying
reliability, measurable in the aggregate of a large number of radio systems.

Variability Mode
There are four different ways of handling the subject of variability:
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Single
This mode combines all three types of variability. Typical use may be a single-
use communication link, where confidence would be a measure of the combined
variability, or it could be a mobile-to-mobile system, where the statistics would be
reliability.

Individual
Time variability and combined situation/location variability. Typical user would be
the individual receiver of a broadcast station for whom reliability means the time
availability and confidence measures the combined situation/location variability.

Mobile
Situation variability and combined time / location variability. Typical user is a mobile
system with a single base station. Reliability would refer to the combined time /
location variability and confidence means the situation variability.

Broadcast
Time, location and situation variability are treated separately. Typical user would
be the broadcaster for whom reliability would measure both location and time and
confidence would measure situation variability.

Parabolic Equations (PE) Model
The parabolic equations model employs numerical evaluation of the parabolic equation (PE) to compute
the field strength in a macro-cellular area based on terrain data.

The different propagation mechanisms (free space propagation, reflection and diffraction) are implicitly
considered for the PE model resulting in an accurate model. Due to the sophisticated algorithm, the
computation time is quite long in comparison to the empirical models.

Figure 439: Parabolic equations model parameters.

Consideration of Propagation Phenomena
As the parabolic equations uses numerical algorithms to consider propagation phenomena like reflection
and diffraction, it requires a long computation time, but it is an accurate model.
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The PE model takes the following effects into consideration:

• reflection

• diffraction

• forward-scattering

It accounts for the properties of the ground by the following parameters:

• conductivity of the ground

• dielectric permittivity of the ground

The standard parabolic equation (SPE) is a partial differential equation and is derived from the Maxwell
equations, neglecting backward propagation and assuming a rotation symmetrical problem.

(85)

 is the field strength related to field of a linear source. In the far field the vertical component of the
electrical field can be assumed as

(86)

and k0 denotes the wave number in free space while k is the complex waver number in an
inhomogeneous lossy atmosphere.

The results of the PE are only valid, if the propagation angle in respect to the horizon lies within -15° up
to +15°. This is reason why the computation starts at the distance rini.

Some of the upper layers of the atmosphere have the effect like a reflector. As the reflected waves
increase the computation time, an absorbing medium below these layers is assumed. The height of the
absorbing medium is about dA = 150 wavelengths.

PE has three possibilities to consider the conductivity and the dielectric permittivity of the ground soil;

• discrete terrain approximation

• continuous terrain approximation

• terrain profile approximation with coordinate transformation

With an extension of the SPE, the disadvantage of the rather small propagation angle can be avoided.
The so-called wide angle parabolic equation (WAPE) model leads to valid results for propagation angles
between -40° up to +40°. As this extension is not noticeable in the computation time, the WAPE should
be preferred.
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Settings

Figure 440: The Parameters for Parabolic Equations (PE) dialog.

ProMan offers five variations of the parabolic equation model. They differ in the underlying parabolic
equation type and the implementation of the impedance boundary at the ground. The standard choice is
the wide angle PE (discrete terrain approximation) which leads to good results for all types of terrain.

Standard PE (Discrete terrain approx.)
This variation applies the standard PE and does a discrete approximation of the height profile. For
decreasing heights the iteration step size is reduced in an adaptive way to avoid prediction errors
caused by the imperfect boundary condition for down-sloping grounds.

Standard PE (Continuous terrain approx.)
This variation is based on variation 1. However, the impedance boundary is replaced by a
continuous modeling of the height profile, which does not improve the prediction quality but the
stability of the iteration algorithm.

Standard PE (Terrain profile approx. with coordinate transformation)
A transformation of the vertical coordinate is used to get a rectangular computational domain for
the PE discretization grid. No additional efforts had to be taken to handle the trouble at down-
sloping ground. Thus, the iteration step size is constant. This model should only be used for slight
hilly terrains. The transformation results in a computation time that is about 50% higher than that
of all other variations.
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Wide Angle PE (Discrete terrain approx.)
The standard PE is extended to a wide-angle form, allowing larger propagation angles with
respect to the horizon. Having nearly the same computation time as variation 1, this option
should be preferred.

Wide Angle PE (Continuous terrain approx.)
This variation is the wide-angle extension of 2.

User Defined Settings
If the following options are left cleared, ProMan sets the appropriate values at run-time
(recommended).

Min. distance to upper boundary
Defines the distance between the highest terrain point (includes the transmitting antenna)
and the upper boundary of the regular computation domain in the vertical terrain section.

Factor for increased resolution of r (decreasing height)
This factor influences the radial iteration step size at down-sloping ground. Greater values
lead to smaller iteration steps. Recommended values are 3 for hilly and 1 - 2 for mostly flat
terrain

Maximum distance between two subsequent point
Sets the radial iteration step size for flat and rising ground. The PE variation 3 uses this step
size for all slopes.

Factor for vertical resolution of computation grid
Sets the vertical grid size of the computation grid in relation to the wavelength. Appropriate
values are from 0.1 to 0.5.

Additional Parameters for PE Predictions

Figure 441: The Postprocessing of PE Predictions dialog.

All PE models use a forward iteration algorithm. Therefore, backward orientated effects (such as
reflections at the opposite hillside) are not considered. This leads to pessimistic predictions above
down-sloping ground. To avoid unrealistic high path loss values, two post-processing modes has been
integrated which can be configured by clicking Settings.
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Mode for Post-processing of PE Predictions
The first option lets you turn the post-processing off. Activate the option Max. increase of path
loss or decrease of path loss per meter, if you want to limit the path loss alterations by
setting maximal values for the derivation path loss by range. Having selected the option Upper
boundary for path loss values, extreme values of the path loss will be cut down on a value
relative to that of the adjacent pixels.

Parameter for Post-Processing of PE Predictions
You can customize the PE post-processing parameters with the edit controls.

Figure 442: The Parameters for PE Contour Plots dialog.

For test or illustration purposes it might be helpful to output the electromagnetic field above a vertical
terrain section. This can be done by activating the 2D Vertical Profile for Point Mode of the PE
check box. Furthermore, one single prediction point must be set, which defines the endpoint of the
vertical section. ProMan then saves the field strength, power and pass loss (depending on your selection
in the Output dialog) to a file denoted with the suffix “c-plot”.

Mode for Vertical Contour Plot
The PE model appends an absorption medium at the top of the computation area to avoid
reflections from the upper boundary. Here you can specify, if you want to output the contour plot
with or without the absorption medium.

Parameters for Vertical Contour Plot
The pixel resolution and stretch factor of the contour plot can either be defined automatically or
by the user. A stretch factor > 1 will show the vertical structure of the predicted field more clearly
by scaling the z-axis. Using the automatically defined option, ProMan sets the values as shown in
table:
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Table 40:  Vertical contour plot settings.

Range of the Vertical Plot r_max [m]

Bigger or Equal Smaller

Resolution [m] Stretch Factor
For Z-Axis

r_max 350 1 1

350 r_max 750 1 5

750 r_max 1500 1 5

1500 r_max 3000 2 10

3000 r_max 7500 5 10

7500 r_max 15000 10 10

15000 r_max 30000 20 20

30000 r_max 75000 50 20

75000 r_max 100 20

Knife Edge Model
This model takes the effect of the actual environment into account by using 3D vector building data
(plus terrain profile).

Deterministic models utilize physical phenomena to describe the propagation of radio waves. Herewith
the effect of the actual environment is taken into account by using 3D vector building data (plus
terrain profile). Generally deterministic propagation models are based on ray-optical techniques.
A radio ray is assumed to propagate along a straight line influenced only by the present obstacles
which lead to reflection, diffraction and the penetration of these objects. However, for large distances
between transmitter and receiver, especially for satellite transmitters, the computational demand
is still challenging. For some scenarios there is no 3D vector data of the environment available but
clutter height information describing the building heights in pixel format. In both cases the knife edge
diffraction model provides an efficient approach for the coverage prediction based on either vector or
pixel data (including building and topographical data).
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Parameters

Figure 443: The Parameters for Additional Knife Edge Diffraction dialog.

Model for computation of additional diffraction loss
Model for determination of knife edges and resulting additional diffraction losses.

Maximum number of diffractions considered for prediction
Possibility to limit the number of diffractions (knife edges) which will be considered during the
prediction computations.

Diffractions at clutter objects
If a clutter database including clutter heights is used for the simulation, additional diffractions at
the defined clutter objects are considered as well. This parameters is set automatically by ProMan
and is visualized for information only.
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Computation

Figure 444: Transmitter and receiver scenario in knife edge model.

The transmitter is located at (-dT, 0, 0) and the receiver at (dR, 0, 0). A diffracting knife edge (semi
plane) is located at x = 0 and has the height z = H. According to the principle of Huygens every point
in the semi plane z > H can be considered as individual point source. The transmitter as point source
provides a field strength F in the semi plane x = 0 according to the following formula:

(87)

to compute the field strength at the receiver location the principle of Huygens can be applied and
accordingly every point above the absorbing semi plane can be considered as point source. The field
strength at the receiver is computed as superposition of all fields provided by the point sources:

(88)

There are different modeling approaches for the determination of the knife edges between the
transmitter and the receiver.

Approach According to Epstein and Peterson
There are different modeling approaches for the determination of the knife edges between the
transmitter and the receiver. According to Epstein and Peterson the distance between transmitter and
receiver is separated in different parts. The diffraction loss is then computed in subsequent steps by
applying the formula between the transmitter and Q2 and between Q1 and the receiver. The parameters
H1 and H2 hereby represent the heights of the knife edge obstacles Q1 and Q2.
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Figure 445: Knife edge model according to Epstein and Peterson.

Approach According to Deygout
For the Deygout model, first the main obstacle in the vertical profile is determined. This obstacle (Q1)
is identified by the point with the highest value for the Fresnel parameter between transmitter and
receiver. For this obstacle the diffraction loss is computed without consideration of the remaining
ones. In the next steps further obstacles are determined, both before and after the main obstacle Q1.
This procedure is repeated up to a certain value for the Fresnel parameter, that is until no significant
obstacle is remaining. Finally all diffraction losses are added. However, as this approach overestimates
the diffraction loss a correction term must be considered for compensation.

Figure 446: Knife edge model according to Deygout.

Rural Dominant Path Model
The Dominant Path Model uses a full 3D approach for the path searching, which leads to realistic and
accurate results.

Ordinary rural or suburban wave propagation models are based on empirical approaches. They compute
only the direct ray between transmitter and receiver location. This leads often to too pessimistic results,
as these models are based on the assumption that most part of the energy is transmitted with the
direct path. Depending on the scenario, for example, if the terrain is very hilly, this approach does not
match the reality. The following picture shows a comparison between the results of the ordinary Hata-
Okumura model, a knife-edge diffraction model and the dominant path model.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.463

Figure 447:  Comparison of results between the Hata-Okumura (on the left),
knife-edge diffraction (middle) and dominant path models (to the right).

The simple approach of the Hata-Okumura Model is clearly visible in the left image. Topography
between transmitter and receiver is not considered. In contrast to this case, the Knife-Edge Diffraction
Model considers topography, but the effects are too dominant. The shadows behind the hills are too
hard, because always the direct ray is considered. This leads to too pessimistic results. The Dominant
Path Model uses a full 3D approach for the path searching, which leads to realistic and accurate results.

Advantages of the Dominant Path Model
As a consequence of the properties and restrictions of the available prediction models mentioned above,
the dominant path prediction model (DPM) has been developed. The main characteristics of this model
are as follows:

• The most important propagation path is computed by using a full 3D approach

• Short computation times

• Accuracy exceeds the accuracy of empirical models

Algorithm of the Dominant Path Model
The DPM determines the dominant path between transmitter and each receiver pixel. The computation
of the path loss is based on the following equation:

(89)

L is the path loss computed for a specific receiver location. The following parameters are considered by
the model:

• Distance from transmitter to receiver (l)

• Path loss exponent (p)

• Wave length (lambda)

• Individual interaction losses due to diffractions (f)

• Empirically determined loss reduction due to wave guiding ( )

• Gain of transmitting antenna (gt)

As described above, l is length of the path between transmitter and current receiver location. p is
the path loss exponent. The value of p depends on the current propagation situation. In areas with
vegetation (which is not modeled in the project) p = 2.4 is suggested, whereas in open areas p = 2.0 is
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reasonable. In addition p depends on the breakpoint distance. After the breakpoint, increased path loss
exponents are common due to distortions of the propagating wave. The function f yields the loss (in dB)
which is caused by diffractions. The diffraction losses are accumulated along one propagation path. The
directional gain of the antenna (in direction of the propagation path) is also considered.

Configuration of the Dominant Path Model
The following screenshot shows the configuration dialog of the DPM.

Figure 448: The Configuration of Dominant Path Model dialog.

Path Loss Exponents
The path loss exponents influence the propagation result computed by the DPM significantly.
The path loss exponents describe the attenuation with distance. A higher path loss exponent
leads to a higher attenuation in same distance. The following figure shows a comparison of three
predictions with different path loss values for the LOS area.
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Figure 449: Comparison of path loss predictions with different path loss values. LOS
exponent 2.0 (on the left), LOS exponent 2.3 (middle) and LOS exponent 2.6 (to the right).

The following table shows recommended path loss exponents, depending on the height of the
transmitter. The density of obstacles in the real scenario which are not modeled in the vector
database do also influence the path loss exponent. The more objects that are missing in the
vector database, the higher the path loss exponent should be.

Table 41: Recommended path loss exponents according to height of the transmitter.

Environment High Transmitter Low Transmitter

LOS before breakpoint 2.0 2.2

LOS after breakpoint 3.0 3.8

OLOS before breakpoint 2.2 2.3

OLOS after breakpoint 3.2 4.0

Note:

• A high transmitter is mounted above obstacles in the vicinity (typically several
meters or tens of meters).

• A low transmitter is mounted between obstacles in the vicinity.

Losses
Each change in the direction of propagation due to an interaction (diffraction, transmission/
penetration) along a propagation path causes an additional attenuation. The maximum
attenuation can be defined. The effective interaction loss depends on the angle of the diffraction.
It is recommended to leave the default value.

Adaptive Resolution Management
For acceleration purposes, the DPM offers an adaptive resolution. In close streets a fine resolution
is used for the prediction and on large places or open areas DPM switches automatically to a
coarse resolution. The prediction time and the memory demand are positively influenced by the
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adaptive resolution but the accuracy is limited - especially if the highest level for the adaptive
resolution is selected by the user.

Additional Features
The DPM supports additional features:

• Consideration of clutter in rural/suburban environment: Clutter databases describe the land usage
of scenarios and can be considered by the DPM.

• Auto calibration of model parameters.

Auto Calibration
The model can be calibrated automatically.

Rural Ray Tracing Model
The rural ray-tracing model is a (deterministic) multipath propagation model, considering phenomena
like multiple reflections and wave guiding effects in canyons is required to obtain accurate predictions of
the signal level and the spatial channel impulse response.

The wave propagation in rural and suburban scenarios is often characterized by multi path propagation
due to interactions (reflections, diffractions, scattering) at various obstacles (hills, buildings, towers).
Simple empirical propagation models for these scenarios do either ignore the topography between
transmitter and receiver (Hata-Okumura model, empirical two ray model) or they consider only the
shadowing due to obstacles in the vertical plane (deterministic two ray model).

More sophisticated approaches include multiple diffractions in the vertical plane (knife edge diffraction
models) or they compute the wave guiding around obstacles in 3D (dominant path model). All these
prediction models listed above are focusing only on a single propagation path. But in reality there are
very often more propagation paths between transmitter and receiver. And only the superposition of
all these paths leads to an accurate prediction. Therefore, ray-tracing models are available for rural
scenarios.

WinProp offers rural ray tracing (RRT), which analyzes rays and interactions only in the vertical plane
between transmitter and receiver, and standard ray tracing (SRT), which performs full 3D ray tracing.
Rural ray tracing takes a limited number of interactions into account, and may not reach all prediction
points by itself. Therefore, it has been enhanced with additional knife edge diffraction to predict
propagation results for remaining locations.

Requirements
The approach of the rural ray-tracing model requires the conversion of the topography data (in pixel
format) to a 3D vector data format. This step has to be made once for each scenario and can be done
using the conversion functions included in WallMan. After conversion is done, the rural vector database
is written to a file with the extension .tdv. This file has to be used to set up the rural simulation project
if the rural ray-tracing should be used as propagation model.

The following data can be considered by the RRT model:

• Topography: Topo maps must be converted from raster data to vector data using WallMan

• Clutter/land usage: Clutter maps must be converted from raster data to vector data using WallMan
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• Vector objects: Additional vector objects (.idb files) can be added during the conversion using
WallMan

Figure 450: Topography database in raster format (on the
left) and topography database in vector format (to the right).

Consideration of Land Usage (Clutter) Data
The additional consideration of land usage (clutter) maps is of course also possible. Similar to the
topographical data, the clutter maps are also converted from raster data to 3D vector data taking
account the clutter heights and the electrical properties of the materials defined for each clutter class
individually. This approach allows a real 3D representation of the land usage maps.

Figure 451: Raster topography without display of land usage (on the left)
and raster topography with land usage in vector format (to the right).

Additional Obstacles
Beyond topography and land usage also arbitrary 3D vector objects can be defined in the scenario to
model buildings, towers. These obstacles can either be converted from CAD data or they can be drawn
in 3D with WinProp's CAD tool WallMan into the vector database. Of course the material properties of
each 3D obstacle can be defined individually. The vector objects have to be saved in a regular indoor
database file (.idb) and can be additionally considered during the conversion of topo and clutter data
into the WinProp file format.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.468

Figure 452: Predicted propagation paths in time-variant environment (on the
left) and predicted propagation paths with wire frame topography (to the right).

Working with Rural Projects (Pixel Databases)
Propagation of electromagnetic waves in areas with a low density of buildings depends mainly on the
topography and the land usage (clutter). The vector data of the buildings must not be considered in
such scenarios.

For predictions based on pixel databases the DEM data is mandatory. Therefore, the user must select a
topographical database. WinProp's topographical databases describe the topographical elevation of all
pixels within the area of interest. They are binary pixel matrices. The extensions of the databases are
.tdb (if single database) or .tdi (if index databases).

Figure 453: Comparison between topographical databases in 3D (on the left) and 2D (to the right).

Simulation Settings
The simulation can be configured by specifying the area of planning, the resolution of prediction results,
prediction height and whether additional prediction planes are defined in the database.

Click Project > Edit Project Parameter to open the Edit Project Parameter dialog. The simulation
settings are available on the Simulation tab.
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Area of Planning / Simulation

Figure 454: The Area of Planning / Simulation group on the Edit Project Parameter dialog , Simulation tab.

Prediction (simulation area)

Individual for each transmitter
The simulation area can be defined as a superposition of individual prediction areas defined
separately for each transmitter/cell. These individual prediction areas can be defined on the
Transmitter definition tab of the corresponding transmitter.

Identical for all transmitters

Rectangular area (Horizontal planes)
The rectangular simulation area can be specified by defining the lower-left and upper-

right corner coordinates. Another option is to use the  Prediction Rectangle

(Rectangle) icon on the Project toolbar, which allows you to draw a rectangle with
the mouse.

Multiple Points (Arbitrary Heights)

Specify the individual prediction or receiver points. The points can be added, deleted,
edited, imported or exported from or to a .txt file. The prediction points can be
moved by specifying a translation vector.
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Figure 455: The Prediction Point dialog.

Multiple Trajectories

Specify a prediction trajectory / receiver trajectory. A trajectory can be added,
deleted, edited, imported or exported from or to a .txt file. For each trajectory,

specify the name, x (Longitude), y (Latitude), z (Height), Velocity, Yaw[23],

Pitch[24] and Roll[25].

Figure 456: The Trajectory dialog.

Another option to specify a trajectory is to use the  Prediction Trajectories icon

on the Project toolbar, which allows you to specify the points for the trajectory using
the mouse.

23. Yaw is the rotation around the vertical axis.

24. Pitch is the rotation around the side-to-side axis.

25. Roll is the rotation around the front-to-back axis.
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Resolution of prediction results
The resolution grid of the result matrix can be changed only if the database was not preprocessed
in area mode.

Prediction Height

The height of horizontal prediction planes can be defined relative to the ground level, absolute to
sea level or relative to defined floor levels.

For prediction heights relative to ground, the height of interest is location-dependent. A typical
example is where a person is walking in a hilly area with a cell phone.

For prediction heights absolute to sea level, the height of interest is fixed and does not follow the
terrain. A typical example is where an aircraft flies at 1500 m.

Trajectory sampling

The height of a prediction trajectory can be defined relative to the ground level or absolute to
sea level.

For a prediction trajectory relative to ground, the height of interest is location-dependent. A
typical example is where a person is walking in a hilly area with a cell phone.

For prediction heights absolute to sea level, the height of interest is fixed and does not follow the
terrain. A typical example is where an aircraft flies at 1500 m.

Settings related to radio network planning simulations are only available for network projects. Some of
the general simulation parameters depend on the selected air interface.

Traffic Settings

There are different approaches for modeling cell loads in ProMan.

If no explicit traffic is defined, the cell load used for interference calculations can be specified in terms
of the assumed mean transmit power in downlink (in percent of the maximum available transmit power
of the cell together with the definition of the assumed mean noise rise) and the power backoff for the
cell assignment channel. These definitions can be specified either for all cells of the network or for each
cell individually.

In case clutter maps are available for location dependent traffic definitions, cell loads can be determined
based on traffic generated during static or Monte Carlo network simulations.

Cell Load Defined by User
If the traffic is defined independent of the location, a traffic map is not required because it is assumed
that the traffic is homogeneously distributed over the complete prediction area.
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Figure 457: The Edit project parameter dialog - Traffic tab.

The cell load used for interference calculations can be specified in terms of the assumed mean transmit
power in downlink in percent of the maximum available transmit power of the cell.

Note:  This value is only related to the power assigned for data transmission. The power
specified for the pilot signals is not influenced. In case of OFDM air interface the cell load can
either influence transmit power in downlink or the number of used subcarriers, depending on
the settings.

For interference computation in uplink, an assumed mean noise rise, caused by active mobile stations,
can be specified.

The default values for cell load, noise rise and power backoff can be defined in the upper section of the
Edit project parameter dialog. In the lower part all transmitters of the current project are listed and
the settings for each transmitter are displayed in the table. The text default indicates that a default
values defined in the upper section of the dialog is used for the corresponding transmitter. If individual
settings for a transmitter is to be defined, the transmitter has to be selected in the table and the check
boxes and edit boxes at the bottom of the dialog can be used to define individual values for cell load,
noise rise and power backoff.

Location Dependent Traffic Definitions
For the definition of location dependent traffic a traffic map is necessary.
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Figure 458: Settings on the Traffic tab with speech settings.

Applications
Location dependent traffic requires the specification of at least one application. Reasonable
applications are for example Voice Calls, Video Calls and WWW Downloads.

Figure 459: The Edit Application dialog.

Name
Description of application.

Position
Priority of the application during cell assignment. 0 means highest priority.

Color
Color of mobile stations generated for this application in display.
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Definition of traffic / users
Either arrival rate in 1/sec/m² and hold time in sec or traffic in Erlang/m² can be defined.

Activity (occupation of resources over time)
Activity of users using this application (occupation of network resources over time) in %.

Transmission modes
At least one transmission mode must be assigned to each application. If an application is selected
with the mouse, the assigned transmission modes are displayed in the upper-right part of the
Edit project parameter dialog. If another application is selected by the user, the display of the
transmission modes is refreshed automatically. Transmission modes can be added or removed
with the corresponding buttons. The parameter Position specifies again the priority (0 means
highest priority) with which the transmission mode is considered during cell assignment.

Clutter classes
Clutter classes contained in the database of the project which are assigned to the selected
application. At least one clutter class is required to generate traffic for the defined application. If
another application is selected by you, the display of the clutter classes is refreshed automatically.
Clutter classes can be added or removed with the buttons in the lower-left section.

Traffic definition
When a clutter class is selected with the mouse the traffic values are displayed in the lower-right
area. You can modify the values and thus assign them to the selected clutter class. Depending on
the traffic mode specified for the current application, either two values (arrival rate in 1/sec/m²
and hold time in sec) or one value (traffic in Erlang/m²) must be defined. The unit for the area
definition (either m² or km²) can be modified with the drop-down list at the top of the dialog.

Project Settings

Besides the topography also the land usage has an influence on the wave propagation. Therefore, land
usage data (called either clutter data or morpho data) and building data can be used additionally to the
topographical data with the prediction models. Clutter databases and building pixel databases can be
used optional. They are not mandatory for the simulations / predictions.

Land usage data is based on different classes and the database defines the number of the class for the
pixel at a given location. The assignment of class numbers to actual land usage is free and depends
on the manufacturer of the database. Therefore ProMan offers the possibility to define a table with the
assignment of class number and corresponding land usage properties.
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Settings

Figure 460: Settings on the Pixel Databases tab.

Topographical (elevation) database (DTM/DEM)
You can change the database file and its path. The database display is not updated after a change
of the database, therefore you should save the project after a change of the database and open it
again.

Warning:  If you change to a completely different database, your settings (for
example, base station position) may not be valid any more.

Consideration of curvature of earth surface
The earth curvature can be considered during the simulations. This is optional because it requires
more memory and increases the computation times significantly. For small areas (several
kilometers) the influence is very limited and therefore the earth curvature can be neglected. The
earth radius (6370 km) is multiplied with the correction factor. Depending on the location on
the earth (close to the equator or not) the correction factor varies. For Europe, values of 4/3 =
1.33333 are typically used.
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Note:  Consideration of Earth curvature is not possible for satellite transmitters. If
this option is enabled for satellite transmitters, ProMan automatically disables it during
prediction To consider the Earth curvature anyway, satellite transmitters have to be
defined as standard transmitters and have to be positioned well above the prediction
area (the topography database).

Clutter (morpho) properties
Morphological properties of the area can be considered during the prediction. For this purpose,
an additional morphological database is needed. This is optional and can therefore be disabled.
The clutter database does only contain a class ID for each pixel. The properties of the class are
defined in a clutter table. This clutter table must be additionally specified when working with
clutter databases.

Properties of clutter classes

For each clutter class a frequency dependent attenuation can be defined in the clutter table.
You can select if this additional attenuation is considered during the prediction or if the
value is neglected. If no properties for a class ID are found in the clutter table, you can
decide if the software should cancel all further prediction steps or if only this pixel is not
predicted.

Most propagation tools only consider the class at the receiver pixel for the influence on the
wave propagation. But this means, that if 90% of the distance between transmitter and
receiver are, for example, in the clutter class urban and only the receiver pixel is in the
class forest, the properties of the class forest would be used. This is obviously not correct
if 90% of the area between transmitter and receiver are urban. Therefore, WinProp offers
optionally the determination of the dominant class between transmitter and receiver and
this class is then used for the evaluation of the receiver pixel. But some classes have a
greater influence on the propagation than others. Therefore, each class can be assigned a
weight factor. The higher the weight factor the stronger the influence of the class on the
propagation.

Example: If 1 urban and 3 water classes are between transmitter and receiver and all
classes would have the same weight (for example 1), the dominant class would be water.
If the weight factor of urban would be 5 and the weight factor of water would be 1, the
dominant class would be urban, because the total weight of urban would be 5 (1 class * 5
weights) compared to the total weight of water which would be 3 (3 classes * 1 weight).

Building pixel database
Building data in pixel format can be considered during the prediction additionally. The raster
database containing the building data can be specified here. ProMan determines the shape and
the height of the buildings depending on the values contained in the specified building pixel
database (absolute or relative building heights) and the topographical database (digital terrain
model without building heights or digital elevation model including building heights). The height
tolerance value thereby defines the height difference between the values of the building pixel
database and the topography data for which ProMan starts to detect buildings.
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Calibration of Rural Models
WinProp allows the automatic calibration of nearly all available propagation models based on
measurement data.

Some propagation models support the calibration of material properties and of clutter/land usage
databases. The following table shows an overview of the models and the features.

Table 42: Overview of propagation models and features.

Scenario Model Material Calibration Clutter Calibration

One slope model no not applicable

Motley-Keenan model no not applicable

COST 231 model yes not applicable

Dominant path model no not applicable

Standard ray-tracing yes not applicable

Indoor

Intelligent ray-tracing yes not applicable

Knife edge model no not applicable

Dominant path model no not applicable

Urban

Intelligent ray-tracing no not applicable

Empirical two way Model not applicable yes

Deterministic two ray model not applicable yes

Rural

Dominant path model not applicable no

The following picture shows the procedure for the calibration of the propagation models:
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Figure 461: Flow diagram illustrating the procedure for calibration of propagation models.

As shown in the picture, during the prediction calibration files are written to the hard disk. The
calibration is done afterwards based on the calibration files (.cal). The steps for the calibration are
explained in the following sections.

Generation of WinProp Measurement Files
Measurement files in WinProp file format (.fpp, .fpl, .fpf) have to be created prior to the calibration.
This means the raw measurement data has to be imported from simple ASCII files into the WinProp
software. See Import Prediction Data for more information.

Assignment of Measurement Files to Transmitters
To retrieve a calibration file (.cal) after the prediction, a measurement file has to be assigned to the
corresponding transmitter. Only one measurement route can be assigned to one transmitter. In the
image below it is shown how a measurement file can be assigned to a transmitter.
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Figure 462: Assigning a measurement file to a transmitter.

The Measurements button is used to assign a measurement file (.fpp, .fpl, .fpf files are supported)
to the selected transmitter. The measurement file must contain measured data from the selected
transmitter only. Superposed measurement data from several transmitters is not supported. When the
measurement data is in path loss format (.fpl) cable loss must not be included. In contrast to this,
cable loss is expected as “included” when measurement data is available in field strength or power file
format. Antenna gain is always expected as “included”.

Computation of Propagation Prediction
After the assignment of the measurement files to the transmitters is completed, the wave propagation
prediction can be launched as usual. The propagation paths output needs to be activated, otherwise no
.cal files will be generated.

For each transmitter (with measurement data assigned) a calibration file (.cal) is written to the hard
disk. If the files are missing, click the Prediction tab, under Additional Prediction Data... and select
the Propagation Paths check box.

Calibration Computation
The calibration tool can be started from the Computation menu (Computation > Auto Calibration
(Models & Materials)). The calibration files generated during the wave propagation prediction have to
be added to the list. This is shown in the image below.
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Figure 463: Adding calibration files for wave propagation prediction.

Files can be added by clicking on Add files. They can be deleted by clicking on Remove file.

The settings can be adapted to the users needs by selecting General settings. This allows you to
influence the selection of the measurement points, only points in a given power (dBm), path loss (dB)
or distance (m) range will be considered.

Figure 464: The Settings dialog.

Additionally the type of optimization method can be chosen:
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Minimum mean error
The goal of the optimization is to achieve a minimum mean error (nearest to zero). The standard
deviation is not considered and thus might be larger.

Minimum mean squared error
The goal of the optimization is to achieve a minimum mean squared error. The standard deviation
is not considered and thus might be larger.

Minimum standard deviation:
The goal of the optimization is to achieve a minimum standard deviation. The mean error is not
considered and thus might be larger.

Minimum weighted error
The goal of the optimization is to find the best combination of minimum mean error and minimum
standard deviation. The weighting between mean error and standard deviation can be adapted by
the user.

The range of the model parameters can be defined in the Model settings tab. As larger the range is, as
longer the calibration will take. The model parameters depend on the selected propagation model, each
model offers individual model parameters.

Figure 465: The Parameters for Intelligent Ray Tracing dialog.

The model parameters can be modified on the dialog. Depending on the propagation model the material
database or the clutter/land usage database can be calibrated additionally. After clicking on Start, the
calibration begins and the progress is shown with a progress bar. In some cases the calibration process
does take up to 1 hour.

Calibration Result
After a calibration has finished the results are displayed in a table.
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Figure 466: Example of calibration results. for intelligent ray-tracing urban.

The model parameters listed in the table can now be transferred manually into the project settings
of ProMan and the project can be recomputed to achieve better results based on the new model
parameters. By clicking on Apply, the material properties (as far as they have been calibrated) are
applied to the vector / material database.

The message box shown above gives also information about mean value and standard deviation from
measurements to predictions before and after the calibration. Depending on the optimization method
different results can be obtained.

Working with Rural Projects (Vector Databases)
The wave propagation in rural and suburban scenarios is very often characterized by multi path
propagation due to interactions (reflections, diffractions, scattering) at various obstacles (hills,
buildings, towers). Simple empirical propagation models for these scenarios do either ignore the
topography between transmitter and receiver (Hata-Okumura model, empirical two ray model) or they
consider only the shadowing due to obstacles in the vertical plane (deterministic two ray model).

More sophisticated approaches include multiple diffractions in the vertical plane (knife edge diffraction
models) or they compute the wave guiding around obstacles in 3D (dominant path model). All these
prediction models listed above are focusing “only” on a single propagation path. But in reality there are
very often more propagation paths between transmitter and receiver. And only the superposition of all
these paths leads to an accurate prediction. Therefore, a (deterministic) multipath propagation model,
such as the rural ray-tracing model, considering phenomena like multiple reflections and wave guiding
effects in canyons is required to obtain accurate predictions of the signal level and the spatial channel
impulse response.

However, this approach requires rural vector databases for the description of topography, land usage
and buildings within the simulation environment.
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Figure 467: Rural vector databases.

Simulation Settings
The simulation can be configured by specifying the area of planning, the resolution of prediction results,
prediction height and whether additional prediction planes are defined in the database.

Click Project > Edit Project Parameter to open the Edit Project Parameter dialog. The simulation
settings are available on the Simulation tab.

Area of Planning / Simulation

Figure 468: The Area of Planning / Simulation group on the Edit Project Parameter dialog , Simulation tab.

Prediction (simulation area)

Individual for each transmitter
The simulation area can be defined as a superposition of individual prediction areas defined
separately for each transmitter/cell. These individual prediction areas can be defined on the
Transmitter definition tab of the corresponding transmitter.
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Identical for all transmitters

Rectangular area (Horizontal planes)
The rectangular simulation area can be specified by defining the lower-left and upper-

right corner coordinates. Another option is to use the  Prediction Rectangle

(Rectangle) icon on the Project toolbar, which allows you to draw a rectangle with
the mouse.

Multiple Points (Arbitrary Heights)

Specify the individual prediction or receiver points. The points can be added, deleted,
edited, imported or exported from or to a .txt file. The prediction points can be
moved by specifying a translation vector.

Figure 469: The Prediction Point dialog.

Multiple Trajectories

Specify a prediction trajectory / receiver trajectory. A trajectory can be added,
deleted, edited, imported or exported from or to a .txt file. For each trajectory,

specify the name, x (Longitude), y (Latitude), z (Height), Velocity, Yaw[26],

Pitch[27] and Roll[28].

26. Yaw is the rotation around the vertical axis.

27. Pitch is the rotation around the side-to-side axis.

28. Roll is the rotation around the front-to-back axis.
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Figure 470: The Trajectory dialog.

Another option to specify a trajectory is to use the  Prediction Trajectories icon

on the Project toolbar, which allows you to specify the points for the trajectory using
the mouse.

Resolution of prediction results
The resolution grid of the result matrix can be changed only if the database was not preprocessed
in area mode.

Prediction Height

The height of horizontal prediction planes can be defined relative to the ground level, absolute to
sea level or relative to defined floor levels.

For prediction heights relative to ground, the height of interest is location-dependent. A typical
example is where a person is walking in a hilly area with a cell phone.

For prediction heights absolute to sea level, the height of interest is fixed and does not follow the
terrain. A typical example is where an aircraft flies at 1500 m.

Tip:  Specify multiple prediction heights by entering space-separated values.

For example: 0.5 1.5 2.5

Trajectory sampling

The height of a prediction trajectory can be defined relative to the ground level or absolute to
sea level.

For a prediction trajectory relative to ground, the height of interest is location-dependent. A
typical example is where a person is walking in a hilly area with a cell phone.
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For prediction heights absolute to sea level, the height of interest is fixed and does not follow the
terrain. A typical example is where an aircraft flies at 1500 m.

Settings related to radio network planning simulations are only available for network projects. Some of
the general simulation parameters depend on the selected air interface.

Traffic Settings

There are different approaches for modeling cell loads in ProMan.

If no explicit traffic is defined, the cell load used for interference calculations can be specified in terms
of the assumed mean transmit power in downlink (in percent of the maximum available transmit power
of the cell together with the definition of the assumed mean noise rise) and the power backoff for the
cell assignment channel. These definitions can be specified either for all cells of the network or for each
cell individually.

In case clutter maps are available for location dependent traffic definitions, cell loads can be determined
based on traffic generated during static or Monte Carlo network simulations.

Cell Load Defined by User
If the traffic is defined independent of the location, a traffic map is not required because it is assumed
that the traffic is homogeneously distributed over the complete prediction area.

Figure 471: The Edit project parameter dialog - Traffic tab.

The cell load used for interference calculations can be specified in terms of the assumed mean transmit
power in downlink in percent of the maximum available transmit power of the cell.
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Note:  This value is only related to the power assigned for data transmission. The power
specified for the pilot signals is not influenced. In case of OFDM air interface the cell load can
either influence transmit power in downlink or the number of used subcarriers, depending on
the settings.

For interference computation in uplink, an assumed mean noise rise, caused by active mobile stations,
can be specified.

The default values for cell load, noise rise and power backoff can be defined in the upper section of the
Edit project parameter dialog. In the lower part all transmitters of the current project are listed and
the settings for each transmitter are displayed in the table. The text default indicates that a default
values defined in the upper section of the dialog is used for the corresponding transmitter. If individual
settings for a transmitter is to be defined, the transmitter has to be selected in the table and the check
boxes and edit boxes at the bottom of the dialog can be used to define individual values for cell load,
noise rise and power backoff.

Location Dependent Traffic Definitions
For the definition of location dependent traffic a traffic map is necessary.

Figure 472: Settings on the Traffic tab with speech settings.

Applications
Location dependent traffic requires the specification of at least one application. Reasonable
applications are for example Voice Calls, Video Calls and WWW Downloads.
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Figure 473: The Edit Application dialog.

Name
Description of application.

Position
Priority of the application during cell assignment. 0 means highest priority.

Color
Color of mobile stations generated for this application in display.

Definition of traffic / users
Either arrival rate in 1/sec/m² and hold time in sec or traffic in Erlang/m² can be defined.

Activity (occupation of resources over time)
Activity of users using this application (occupation of network resources over time) in %.

Transmission modes
At least one transmission mode must be assigned to each application. If an application is selected
with the mouse, the assigned transmission modes are displayed in the upper-right part of the
Edit project parameter dialog. If another application is selected by the user, the display of the
transmission modes is refreshed automatically. Transmission modes can be added or removed
with the corresponding buttons. The parameter Position specifies again the priority (0 means
highest priority) with which the transmission mode is considered during cell assignment.

Clutter classes
Clutter classes contained in the database of the project which are assigned to the selected
application. At least one clutter class is required to generate traffic for the defined application. If
another application is selected by you, the display of the clutter classes is refreshed automatically.
Clutter classes can be added or removed with the buttons in the lower-left section.

Traffic definition
When a clutter class is selected with the mouse the traffic values are displayed in the lower-right
area. You can modify the values and thus assign them to the selected clutter class. Depending on
the traffic mode specified for the current application, either two values (arrival rate in 1/sec/m²
and hold time in sec) or one value (traffic in Erlang/m²) must be defined. The unit for the area
definition (either m² or km²) can be modified with the drop-down list at the top of the dialog.
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Project Settings
The project settings for rural projects with vector databases are given.

Figure 474: The Database settings dialog.

Vector database
You can change the database file and its path.

Warning:  If you change to a completely different database, your settings (for
example, base station position) may not be valid any more. The database display is
not updated after a change of the database, therefore you should save the project
after a change of the database and open it again.

Material properties
The material properties of the walls are taken into account by most of the prediction models when
the prediction is computed. If the individual properties are not defined in the database or if the
user does not want to use the defined material properties, default values can be used by choosing
the option Default values. In this case, all materials defined in the database will have the same
electrical properties.
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Figure 475: The Change default values for Material properties dialog.

Note:  Parameters, which actually impact the wave propagation prediction, depend on
the selected propagation model and further propagation parameters.

Ray optical propagation models, such as standard ray-tracing (SRT) and rural ray-tracing
(RRT) use all material parameters listed in the dialog for Fresnel coefficients and GTD / UTD
or the empirical transmission, reflection and diffraction model, respectively, depending on the
computation mode of signal level. Semi-deterministic and empirical prediction models only use
parameters for Fresnel coefficients or the values for the transmission loss, respectively, depending
on the computation mode of signal level.

Subdivisions
Subdivisions contained in the database can be considered or neglected by selecting or clearing the
corresponding check box.

Multiple definitions of (identical) objects
Identical vector objects contained in the database can be neglected. This makes it possible to use
converted building data where the outline of the walls has been modeled directly, as the double
definitions of the walls (inner and outer part) can be combined to consider only one transmission
for the wall.

Computation Settings

The following wave propagation models are available for vector based rural environment databases:

• 3D ray-tracing

• rural ray-tracing model

• one slope model
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Figure 476: The Computation dialog.

Prediction Model
Different models using different computation approaches can be selected. The settings of the
models can be changed by using the Settings button.

Computation of signal level along propagation path (valid for all propagation models)
The deterministic mode uses Fresnel Equations for the determination of the reflection and
transmission loss and the GTD / UTD for the determination of the diffraction loss. This model
has a slightly longer computation time and uses four physical material parameters (thickness,
permittivity, permeability and conductivity). When using GTD / UTD and Fresnel coefficients
arbitrary linear polarizations (between +90° and –90°) can be considered for the transmitters.

The empirical mode uses five empirical material parameters (minimum loss of incident ray,
maximum loss of incident ray, loss of diffracted ray, reflection loss, transmission loss). For
correction purposes or for the adaptation to measurements, an offset to those material
parameters can be specified. Herewith the empirical model has the advantage that the
needed material properties are easier to obtain than the physical parameters required for
the deterministic model. Also the parameters of the empirical model can be calibrated with
measurements more easily. It is therefore easier to achieve a high accuracy with the empirical
model.

The diffraction loss depends besides the angles of the given propagation path also on the
relationship between the wedge direction and the polarization direction. According to physics and
verified by measurements there is an additional loss of about 5 dB if both directions are parallel
(for example, diffraction on vertical wedge for vertically polarized signal). While this effect is
automatically considered if using the GTD / UTD model, an offset is available for the empirical
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diffraction model. This additional loss is added to the diffraction loss in case the wedge direction
and the polarization direction are parallel. In case the wedge direction and the polarization
direction are orthogonal no additional loss is considered. In between there is a linear scaling of
this additional loss.

Note:  The computation mode for the signal level along the propagation path applies
for all propagation models.

Urban

Propagation Models
The design and implementation of personal communication systems requires the prediction of wave
propagation relating to signal-to-noise and signal-to-interference calculation in a cellular system. Small
cell network configurations – especially micro and pico cell types – are of major interest for urban
environments because of the increasing capacity demands.

The commonly used criterion for the definition of a micro cell is related to the height of the base station
antenna. For a typical micro cell the base station antenna height is below the average rooftop level of
the surrounding buildings or about the same height. Thus the resulting cell radius is in the range of
250-500m. A further characteristic is the low transmitting power. However, a prediction range up to
several kilometers has to be regarded for inter-cellular interference calculations. A pico cell base station
is usually installed inside a building providing coverage also outside around the building.

Figure 477: An urban propagation scenario.

Radio transmission in urban environments is subject to strong multipath propagation. Dominant
characteristics in these scenarios are reflection, diffraction, shadowing by discrete obstacles and the
wave guiding in street canyons. To consider these effects in a propagation model, it is necessary to
gain knowledge of all dominant propagation paths. These paths depend primarily on the base station
antenna height with respect to the building heights around.

For simplification of propagation modeling several two dimensional empirical models have been
developed under the assumption of over-rooftop propagation as main propagation mechanism. The
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model according to Walfisch-Ikegami with extensions from the European research cooperation COST
231 is such an analytical approach with empirically based equations and correction factors.

The second group of micro-cellular prediction models are deterministic and use ray optical methods.
They allow a very site-specific, three dimensional path loss and signal spread prediction including
impulse response for base station heights below as well as above rooftop level. Hence, a three
dimensional description for the propagation environment including building shape and building heights
has to be incorporated. Of course, due to the three dimensional ray optical methods these models
require a higher computation effort than the simplified approaches mentioned above. However, we
developed a method to accelerate this ray optical approach by an intelligent preprocessing of the
building data base which leads to computation times in the range of empirical models.

The described models are generally valid only for flat urban area, what means that the standard
deviation of the terrain heights is small in comparison to the standard deviation of the building heights
in the considered area. If this is not the case the influence of terrain should be taken into account by
adequate extensions of the above mentioned methods.

COST 231 Walfisch-Ikegami Model
This is an empirical model as described in COST 231 (extended Walfisch-Ikegami-model) which takes
into account several parameters out of the vertical building profile for the path loss prediction.

This model features a very short computation time. The accuracy is tolerable, but it does not reach the
one of deterministic ray optical models. This model does not consider wave-guiding effects which occur
for example in street canyons. However, if the dominant propagation mechanism is the over rooftop
propagation the results are far accurate as the empirical formulas approximate the multiple diffractions
over the rooftops of the buildings. Therefore this model is well suited for transmitters located above the
medium rooftop level, while the accuracy for transmitters below the medium rooftop level is limited.

However, their prediction accuracy is limited due to the fact that only a small number of parameters
is taken into account and the influence of the distance from the transmitter is over-emphasized.
Additionally, wave guiding effects in streets cannot be considered with an empirical approach. The
empirical model implemented in ProMan was developed in the course of the European COST 231 project
by a combination of the Walfisch and Ikegami models.

Computation
The model allows for improved path loss estimation by consideration of more data to describe the
character of the urban environment, namely:

• height of transmitter 

• height of receiver 

• mean value of building heights 

• mean value of widths of roads 

• mean value of building separation 

• road orientation with respect to the direct radio path
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Figure 478: Urban propagation scenario using the COST 231 Walfisch-Ikegami Model

However this model is still statistical and not deterministic because only characteristic values are taken
into account for the prediction. The model distinguishes between line-of-sight (LOS) and non-line-of-
sight (NLOS) situations. In the LOS case – between base station and mobile antenna within a street
canyon – a simple propagation loss formula different from free space loss is applied. The calibration of
this formula is done by measurements performed in European cities.

The model has also been accepted by the ITU-R and is included in report 567-4. The estimation of
path loss agrees rather well with measurements for base station antenna heights above rooftop level.
The mean error is in the range of 3 dB and the standard deviation 4-8 dB. However, the prediction
error becomes larger for  close to  compared to situations where . Furthermore
the performance of the model is poor for . The parameters  and  are not considered in
a physically meaningful way for micro cells. Therefore, the prediction error for micro cells may be
quite large. The model does not consider multipath propagation and as a result wave guiding effects
as occurring for example in street canyons are not taken into account. But in situations where the
propagation over the rooftops is dominant the model leads to good results.

Because of the calibration with measurements from European cities no parameters have to be adjusted
when using this model. However with this empirical approach it is not possible to predict the wideband
properties of the mobile radio channel as for example the delay spread or impulse response.

Additional Features
WinProp extended the empirical COST 231 Model for combined network planning (CNP). This extension
allows the combination of urban and indoor predictions. In the urban environment the prediction is
computed with the COST 231 Model, as described above. For the prediction of pixels located within a
building, the computation is done in two steps. First, the signal level of the indoor pixel is computed
without consideration of the building, which surrounds the pixel under evaluation, using the empirical
COST 231 model. After that, the occurring indoor loss along the path section running within the
building, is added to take into account the additional attenuation caused by the building penetration.
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Figure 479: Urban propagation scenario using the COST 231 Walfisch-Ikegami model with added CNP features.

ITU-R P.1411 Model
The ITU-R P.1411 propagation model is intended for outdoor short-range propagation over the
frequency range from 300 MHz to 100 GHz.

Short-range propagation over distances less than about 1 km is typically affected more by buildings and
trees than by variations in ground elevation. The effect of buildings is expected to dominate, since most
short-path radio links are found in urban and suburban areas. The mobile device is most likely to be
held by a pedestrian or located in a vehicle.

Figure 480: The Parameters of ITU-R P.1411-10 dialog.

Propagation Environment

The propagation model distinguishes four categories of propagation environments:

• Urban Very High Rise
There is a high density of very tall buildings with tens of floors. Propagation is through
deep urban canyons. Heavy traffic of cars and pedestrians is present in the streets.

• Urban / Urban High Rise
The streets are lined with buildings of several floors each. Propagation is through
urban canyons and over rooftops. Large numbers of moving vehicles are present in the
streets.
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• Suburban / Urban Low Rise
There are buildings and their heights are generally less than three stories. Over-rooftop
diffraction is likely. There are some reflections and shadowing from moving vehicles.

• Residential
There are one and two-story buildings. Streets contain trees with foliage. Parked cars
and light traffic are present.

Propagation Models

For propagation models, two options exist:

• Site-Specific

For this option, the simulation will take the given buildings, as defined in the urban
database and visible in the ProMan GUI, accurately into account.

• Site-General

This option is convenient when an urban database is not available, or when a quick
look is desired without specifying all the buildings. When this option is selected,
the simulation takes the general properties of the environment (urban high rise or
residential) and the antenna height into account and provides representative results.
ProMan will always require a database to be part of the project, but with this option the
(urban) database can be almost empty, and antenna positions be chosen in an area
away from the remaining (unused) buildings.

Propagation Situation

This option is related to the predominant height of the base stations. In al cases, the mobile
station is located near street level. The difference lies in the height of the base station.

• Over Roof-Tops

Base stations are typically located above the roof level. The (short-distance)
propagation path must be an over-rooftop path.

• Within Street Canyons

Base station is located below roof level but above the level of a person’s head.

• Near Street Level

Both the base station and the mobile station are near street level.

• Auto Detection

This option is recommended, especially if not all base stations are at similar heights. It
allows ProMan to determine automatically the situation that applies.

Calculation mode (LOS)
Even within the line of sight, the path loss is not simply a free-space path loss. Depending on
the frequency, ITU recommendations contain expressions for expected path loss, with lower and
upper bounds. Based on the properties of your urban area of interest, you may choose to perform
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calculations based on the Lower Bound or Upper Bound of the line-of-sight path loss, or on the
Median Value.

Note:  Option only available in combination with Site-Specific propagation models.

Traffic (affects the breakpoint distance)

Traffic can be set to Light or Heavy. Heavy traffic also affect the effective road height and as a
result the breakpoint distance. Select the Ignore break-point distance check box if you want to
disregard the breakpoint distance.

Site-General Settings

Depending on whether a Site-General or a Site-Specific simulation was chosen, different Site-
General Settings are available.

Figure 481: The Site-General Settings dialog.

Site-General simulation

In a Site-General simulation, ProMan has the ability to determine, based on the building
database, whether paths are line-of-sight or non-line-of-sight paths. If you are performing
your site-general simulation in an empty area of the urban database, ProMan might
assume pure line-of-sight conditions for all pixels. Select the Use a statistical model to
determine LOS/NLOS regions check box to ensure that the two conditions receive the
appropriate weight.

Select the Add Gaussian random variable check box to include an additive zero-mean
Gaussian random variable in the path-loss computation in the site-general case. It is

described in the ITU recommendation[29].

Site-Specific simulation

In a Site-Specific simulation, some pixels may remain without prediction. For such pixels,
which otherwise remain white and without value in the result display, you can choose to use
the result of a site-general model instead.

29. “Propagation data and prediction methods for the planning of short-range outdoor
radiocommunication systems and radio local area networks in the frequency range 300 MHz to 100
GHz” International Telecommunication Union, Geneva, Switzerland, August 2019.
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When the Use site-general models for unpredicted pixels of site-specific models
check box is selected, the Use a statistical model to determine LOS/NLOS regions and
Add Gaussian random variable options are available.

Additional loss (Transmitter inside a building)

The ITU-R P.1411 model also allows the transmitter to be inside a building. In such a situation,
you have the option to add a value in dB for additional loss: the power loss suffered by the signal
to travel through the walls from inside to outside the building.

Figure 482: Additional Loss option (dB) when a transmitter is located inside a building.

ProMan will check whether the transmitter is inside a building. If the transmitter is located
outside, even with the Site-General propagation models, this setting has no effect. This way, you
can have some transmitters inside and some outside buildings.

Urban Dominant Path Model
The dominant path model (DPM) determines exactly this dominant path between the transmitter and
each receiver pixel. The computation time compared to ray-tracing is significantly reduced and the
accuracy is nearly identical to ray-tracing.

Ray-optical propagation models are still very time-consuming – even with accelerations like
preprocessing. And what is even more important, they rely on a very accurate vector database. Small
errors in the database influence the accuracy of the prediction. On the other hand, empirical models
rely on dedicated propagation effects like the over-rooftop propagation (for example the direct ray
COST 231). A comparison of prediction results computed with three types of prediction models is
presented in the following figure.
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Figure 483: Predictions results for three types of prediction models. Empirical COST 231
(on the left), Intelligent Ray Tracing (middle) and Urban Dominant Path (to the right).

Analyzing typical propagation scenarios shows that in most cases one propagation path contributes
more than 90% of the total energy. The dominant path model (DPM) determines exactly this dominant
path between the transmitter and each receiver pixel. So the computation time compared to ray-tracing
is significantly reduced and the accuracy is nearly identical to ray-tracing.

Figure 484: Typical channel impulse response where one path dominates.

Empirical models (like COST 231) consider only the direct path between a transmitter and a receiver
pixel. Ray tracing models (like IRT) determine numerous paths. DPM determines only the most relevant
path, which leads to short computation times.

Figure 485: Comparison of different approaches (COST 231
on the left, ray-tracing in the middle and DPM to the right).
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Advantages of the Dominant Path Model
As a consequence of the properties and restrictions of the available prediction models mentioned above,
the dominant path prediction model (DPM) has been developed. The main characteristics of this model
are:

• The dependency on the accuracy of the vector database is reduced (compared to ray-tracing).

• Only the most important propagation path is considered, because this path delivers the main part
of the energy.

• No time-consuming preprocessing is required (in contrast to IRT).

• Short computation time.

• Accuracy reaches or exceeds the accuracy of ray-optical models.

Typical Application of the Dominant Path Model
As the dominant path model does not require a preprocessing of the vector building database it
is ideally suited for very large areas. Additionally the approach to compute only the dominate ray
emphasizes this operational area. The model does not compute the complete channel impulse response,
thus if the user is interested in the channel impulse response, the delay spread or the angular spread, a
ray-tracing model is recommended. The DPM is the ideal approach to compute coverage predictions in
large urban areas.

Algorithm of the Dominant Path Model
The DPM determines the dominant path between transmitter and each receiver pixel. The computation
of the path loss is based on the following equation:

(90)

L is the path loss computed for a specific receiver location. The following parameters are considered by
the model:

• Distance from transmitter to receiver ( )

• Path loss exponent ( )

• Wave length ( )

• Individual interaction losses due to diffractions ( )

• Empirically determined loss reduction due to wave guiding ( )

• Gain of transmitting antenna ( )

As described above,  is length of the path between transmitter and current receiver location. p is
the path loss exponent. The value of  depends on the current propagation situation. In dense urban
areas p tends to be slightly higher than in open areas. See Table 43 for further guidance. In addition, p
depends on the breakpoint distance. After the breakpoint, increased path loss exponents are common
due to distortions of the propagating wave. The function  yields the loss (in dB) which is caused
by diffractions. The diffraction losses are accumulated along one propagation path. Reflections and
scattering are included empirically. For the consideration of reflections (and scattering), an empirically
determined wave guiding factor is introduced. This wave guiding factor takes into account, that a wave
propagating in a long street canyon will be reflected on the walls leading to less attenuation compared
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to free space. Thus, wave guiding effects can be expressed as an additional gain in dB. The directional
gain of the antenna (in direction of the propagation path) is also considered.

Configuration of the Dominant Path Model
The following screenshot shows the configuration dialog of the DPM.

Figure 486: The Configuration of Dominant Path Model dialog.

Path Loss Exponents
The path loss exponents influence the propagation result computed by the DPM significantly.
The path loss exponents describe the attenuation with distance. A higher path loss exponent
leads to a higher attenuation in same distance. The following figure shows a comparison of three
predictions with different path loss values for the LOS area.
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Figure 487: Path loss predictions based on three different path loss values. LOS exponent
2.0 (on the left), LOS exponent 2.3 (middle) and LOS exponent 2.6 (to the right).

The following table shows recommended path loss exponents, depending on the height of the
transmitter. The density of obstacles in the real scenario which are not modeled in the vector
database do also influence the path loss exponent. The more objects that are missing in the
vector database, the higher the path loss exponent should be.

Table 43: Recommended path loss exponents.

Environment High Transmitter Low Transmitter

LOS before breakpoint 2.3 2.6

LOS after breakpoint 3.3 3.8

OLOS before breakpoint 2.5 2.8

OLOS after breakpoint 3.6 4.0

Note:

• A high transmitter is mounted above the rooftop (typically several meters or tens
of meters).

• A low transmitter is mounted between the buildings.

Interaction losses
Each change in the direction of propagation due to an interaction (diffraction, transmission /
penetration) along a propagation path causes an additional attenuation. The maximum
attenuation can be defined. The effective interaction loss depends on the angle of the diffraction.
It is recommended to leave the default value.
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Waveguiding effects
As mentioned before, the DPM includes wave guiding effects to achieve highly accurate results.
Two parameters are available to configure the wave guiding module. The first parameter is used
to define the maximum distance to walls to be included in the determination of the wave guiding
factor. With the second parameter the weight of the wave guiding effects in the computation of
the path loss is defined (1.0 is suggested. Values below 1.0 reduce the influence of the wave
guiding factor and values above 1.0 increase it). In typical scenarios the wave guiding effects can
be turned off, this reduces the prediction time

Adaptive resolution management

For acceleration purposes, the DPM offers an adaptive resolution. In close streets a fine resolution
is used for the prediction and on large places or open areas DPM switches automatically to a
coarse resolution. The prediction time and the memory demand are positively influenced by the
adaptive resolution but the accuracy is limited - especially if the highest level for the adaptive
resolution is selected by the user.

For the adaptive resolution management, the level (factor) can be specified. Possible levels
(factors) are 0, 1, 2, 3, and 4. Level 0 disables the adaptive resolution management (each pixel is
computed with the DPM algorithm).

As the level is increased, fewer and fewer pixels are computed in open areas (for example, for
Level 1 every other pixel is computed) and the remaining ones are interpolated. The adaptive
resolution management is not applied close to the transmitter.

• Factor 1 is only applied for distances larger than 400m.

• Factor 2 is only applied for distances larger than 800m.

• Factor 3 is only applied for distances larger than 1000m.

• Factor 4 is only applied for distances larger than 1200m.

Additional Features
The DPM supports additional features:

Consideration of vegetation in urban environment
Vegetation databases describe areas of vegetation with polygonal cylinders (individual height for
each cylinder possible). Additional attenuation can be defined for each vegetation element. All
paths penetrating the vegetation get an additional loss per meter (in dB/m) and all signals at
receiver locations inside the vegetation blocks are additionally attenuated (loss in dB). This makes
sure that the prediction result is not too optimistic, if dense vegetation is present. Vegetation
databases describe areas of vegetation with polygonal cylinders (individual height for each
cylinder possible). Additional attenuation can be defined for each vegetation element. All paths
penetrating the vegetation get an additional loss per meter (in dB/m) and all signals at receiver
locations inside the vegetation blocks are additionally attenuated (loss in dB). This makes sure
that the prediction result is not too optimistic, if dense vegetation is present.

Combined network planning
The DPM offers the CNP mode which allows the combination of urban and indoor predictions. In
the urban environment the prediction is computed with the urban dominant path model (UDP),
its settings and the resolution selected for the urban domain. For the predictions in the indoor
area the indoor dominant path model (IDP) with a higher resolution is used. The settings of the
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dominant path model, such as path loss exponents and interaction losses, can be defined for both
environments (urban and indoor) individually.

Auto Calibration
The model can be calibrated automatically.

3D Intelligent Ray Tracing
This model performs a rigorous 3D ray-tracing prediction which results in a high accuracy and with the
pre-processing of the database, the computation time is short.

The mobile radio channel in urban areas is characterized by multi-path propagation. Dominant
propagation phenomena in such built-up environments are the shadowing behind obstacles, the
reflection at building walls, wave guiding effects in street canyons and diffractions at vertical or
horizontal wedges. The deterministic ray optical models consider these effects, which leads to accurate
prediction results.

To cope with the excessive computation times for the deterministic approach with ray tracing the
following aspects have been investigated:

• The deterministic modeling of path finding generates a large number of rays, but only few of them
deliver the main part of the received electromagnetic energy.

• The visibility relations between walls and edges are independent of the position of the base station.

• In many cases neighboring receiving points are hit by rays whose paths differ only slightly.
For example, every receiving point in a street orthogonal to the street in which the transmitter
is located and it is hit by a double reflected - single vertically diffracted ray and the points of
interaction of these rays with walls and edges are independent of the receiver position.

Based on these considerations it is possible to accelerate the time consuming process of ray path
finding by a single intelligent pre-processing of the data base for buildings.

Principle
The intelligent ray-tracing technique allows it to combine the accuracy of ray optical models with the
speed of empirical models. To achieve this, the database undergoes a sophisticated pre-processing.
In a first step the walls and edges of the buildings are divided into tiles and segments, respectively.
Horizontal and vertical edge segments are distinguished. For every determined tile and segment all
visible elements (prediction pixels, tiles and segments) are computed and stored in file.

For the determination of the visibility the corresponding elements are represented by their centers.
Additionally, the occurring distances as well as the incident angles are determined and stored. Due
to this pre-processing the computational demand for a prediction is reduced to the search in a tree
structure. The following picture shows an example of a tree consisting out of visibility relations. 
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Figure 488: Tree of visibility relations.

Only for the base station with an arbitrary position and antenna pattern (not fixed at the pre-
processing), the visible elements including the incident angles have to be determined at the prediction.
Then, starting from the transmitter point, all visible tiles and segments are tracked in the created tree
structure considering the angle conditions. This tracking is done until a prediction point is reached or a
maximum number of interactions (reflections / diffractions / transmissions (only indoor) ) is exceeded.
The following picture shows the division into tiles and segments.

Figure 489: Division into tiles and segments.

The following picture shows an example of a ray path between a transmitter and a receiver with a
single reflection. The tiles and segments are also visible. These are examples of an urban database. The
procedure with indoor databases is the same, only transmissions are additionally considered.
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Figure 490: Example of a ray path between a transmitter and receiver with a single reflection.

Additionally to the rigorous 3D ray-tracing there are two different other modes available with improved
performance concerning the relationship between accuracy and computation time:

2x2D (2D-H IRT + 2D-V IRT)
The pre-processing and as a follow on also the determination of propagation paths is done in two
perpendicular planes. One horizontal plane (for the wave guiding, including the vertical wedges)
and one vertical plane (for the over rooftop propagation including the horizontal edges). In both
planes the propagation paths are determined similar to the 3D-IRT by using ray optical methods.

2x2D (2D-H IRT + COST231-W-I):
This model treats the propagation in the horizontal plane in exactly the same way as the
previously described model by using ray optical methods (for the wave guiding, including the
vertical wedges). The over rooftop propagation (vertical plane) is taken into account by evaluating
the COST 231-Walfisch-Ikegami model.

The pre-processing is not done within ProMan but has to be done within the WallMan application.
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Settings

Figure 491: The Parameter: Intelligent Ray Tracing (IRT) dialog.

Propagation paths (number of interactions
This dialog allows to specify how many interactions should be considered for the determination of
ray paths between transmitter and receiver including maximum number of reflections, diffractions
and scattering. Separate definitions for terrestrial and for satellite transmitters are possible.

Computation of the contribution of the rays
The deterministic mode uses Fresnel equations for the determination of the reflection and
transmission loss and the GTD / UTD for the determination of the diffraction loss. This model
has a slightly longer computation time and uses four physical material parameters (thickness,
permittivity, permeability and conductivity). In case of a full polarimetric analysis, the
deterministic mode should be selected. In case of a standard analysis, it is optional.

The empirical mode uses five empirical material parameters (minimum loss of incident ray, maximum
loss of incident ray, loss of diffracted ray, reflection loss, transmission loss). For correction purposes or
for the adaptation to measurements, an offset to those material parameters can be specified.

The empirical model has the advantage that the needed material properties are easier to obtain than
the physical parameters required for the deterministic model. Also, the parameters of the empirical
model can be calibrated with measurements more easily.
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The diffraction loss depends besides the angles of the given propagation path also on the relationship
between the wedge direction and the polarization direction. According to physics and verified by
measurements there is an additional loss of about 5 dB if both directions are parallel (for example,
diffraction on vertical wedge for vertically polarized signal). While this effect is automatically considered
if using the GTD / UTD model, a corresponding offset is available for the empirical diffraction model.
This additional loss is added to the diffraction loss in case the wedge direction and the polarization
direction are parallel. In case the wedge direction and the polarization direction are orthogonal no
additional loss is considered. In between there is a linear scaling of this additional loss.

Diffuse scattering in urban scenarios can play an important role, especially for determining the actual
temporal and angular dispersion of the radio channel. The IRT model for urban scenarios was extended
to consider the scattering on building walls and other objects. Activate the scattering in the model
settings (where also the number of reflections and diffractions are defined). As the scattering increases
the overall number of rays significantly, there is a limitation of one scattering per ray.

Figure 492: Example of diffuse scattering.

Furthermore, the surface roughnesses of the corresponding materials need to be defined (in WallMan
and ProMan). The scattered power depends on surface roughness and on direction, in accordance

with [30][31]. For the scattering in the IRT model the tiles as defined in the WallMan pre-processing are
considered. The scattered contribution is weighted with the size of the scattering area (tile). Accordingly
the resulting scattered power from the whole object is for large distances independent of the tile size.
For small distances there is an impact due to the modified scattering angles which depend on the tile
size.

Accordingly the resulting scattered power from the whole object is for large distances independent of
the tile size. For small distances there is an impact due to the modified scattering angles which depend
on the tile size.

Propagation Paths (Selection of Paths)
Limitation of number of paths per pixel with the following options:

30. Xiao Dong He, Kenneth E. Torrance, François X. Sillion, Donald P. Greenberg: "A Comprehensive
Physical Model for Light Reflection". SIGGRAPH’91 conference proceedings, 1991, Las Vegas, United
States. inria-00510144

31. G. Nassif, C. Gloaguen and P. Martins, "A Combined Stochastic and Physical Framework for
Modeling Indoor 5G Millimeter Wave Propagation," in IEEE Transactions on Antennas and
Propagation, vol. 70, no. 6, pp. 4712-4727, June 2022, doi: 10.1109/TAP.2022.3161286.
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• maximum path loss of rays

• maximum number of paths

• dynamic range of paths

Consideration of Rays for Computation of Angular Spread and Mean
During computation of delay or angular spread and mean, the contribution of each propagation
path to the delay or angular spread/mean is considered. Each path contributes a signal level to
the spread. This level can be either considered as power (in dBm or Watt) or as field strength
(in dBµV/m or in µV/m). Power values include the gain of the Rx antenna and depend on the
frequency, whereas field strength values do not depend on the frequency. The values can be
considered either in logarithmic scale (dBm or dBµV/m) or in linear scale (mW or µV/m).

Figure 493: The Selection of Rays dialog.

Path Loss Exponents and Breakpoint Properties

The breakpoint describes the physical phenomenon that from a certain distance on the received
power decreases with 40 log(distance/km) instead of 20 log(distance/km) which is valid for the
free space propagation. This is due to the superposition of the direct ray with a ground reflected
contribution.

Exponent before breakpoint (LOS/NLOS) / Exponent after breakpoint (LOS/NLOS). These four
exponents influence the calculation of the distance dependent attenuation. For further refined
modeling approaches different exponents for LOS and NLOS conditions can be applied. The default
values are 2.4 and 2.8 for the exponents before the breakpoint (LOS and NLOS) and 3.6 and 4.0
for the exponents after the breakpoint (LOS and NLOS).

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.510

Figure 494: The Breakpoint Settings dialog.

The breakpoint distance depends on the height of transmitter and receiver as well as the wavelength.

The initial value is calculated according to . This value can be modified by setting an additional

offset (in meters). 

Figure 495: The Breakpoint Settings dialog.

Acceleration

Further options exist to accelerate the prediction model. If many rays are received at a pixel,
the sum of the contributions of all rays might be higher than the contribution of the LOS ray to
this pixel. Then you can decide to stop the computation for this pixel and no further rays are
determined to save computation time.

But it makes only sense if you look at the signal level, because if you have already achieved -80
dBm at the pixel with a few rays, a further ray with -95 dBm does not modify the total power for
this pixel.

You can even add 5 rays with -95 dBm each to this pixel - the total power will remain at -80
dBm. So it makes actually sense to ignore all further rays as they have nearly no impact on the
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predicted power result. But when you want to compute the delay spread or angular spread, you
need obviously all rays to get an accurate result.

If you have one ray with 80 dBm and 5 further rays with -95 dBm each, the signal level might be
-80 dBm if you consider 1 ray or 6 rays. But the delay spread would be 0 ns in case of one ray
and 5 ns or 10 ns or 15 ns if you consider all 6 rays. So you cannot neglect further rays if you are
predicting the delay spread or the angular spread.

Post Processing
[Optional] Prediction results can be post processed using the knife-edge diffraction model.
Parameters for this model can be specified on a separate dialog which can be found by clicking
Settings.

Indoor Penetration Models
Three models for indoor penetration are presented.

Figure 496: Settings for indoor penetration - the Parameter Indoor Prediction dialog.

All indoor penetration models utilize an algorithm that uses the values of the predicted pixels around
the building and considers the penetration (transmission) loss defined for  the outer building walls.

Constant level model
Predicts a homogeneous indoor level by subtracting the defined transmission loss from the
average signal level at the outer walls.

Figure 497: The constant level model.
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Exponential decrease model
Considers the defined transmission loss of the outer walls and additionally an exponential
decrease towards the interior, with an attenuation rate depending on the building depth (around
0.1 dB/m).

Figure 498: The exponential decrease model.

Variable decrease model
Allows to consider a definable attenuation rate (default value 0.6 dB/m) in addition to the
transmission loss for the outer walls. In this model the user can modify the exponential decrease
of the signal level inside the buildings. The following sample shows the variable decrease model
with an indoor attenuation rate of 0.6 dB/m.

Figure 499: The variable decrease model.

Working with Urban Projects
Propagation of electromagnetic waves in urban scenarios in the frequency range above 300 MHz is
influenced by reflections and diffractions at the buildings. Therefore, a detailed vector database of the
buildings is required.

Urban vector databases contain a description of each urban building or vegetation area in an urban
environment. In contrast to the topographical or clutter pixel databases, the urban databases are
vector databases, each building is described by a vector (polygon) and attributes (height, material, type
(building, courtyard, tower, vegetation)). 

The buildings are described by polygonal cylinders, buildings with arbitrary forms can be used. The
building database offers the following features:
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• Each polygon can have an arbitrary number of corners. At least three corners are required to define
a valid polygon (building).

• Each building has a uniform height (polygonal cylinder). The height is either relative to the ground
or absolute above sea level. Absolute height values require additionally a topographical database.

• Flat rooftops are used (horizontal planes).

• Only vertical walls (parallel to z-axis) are allowed.

• Each building has a single set of material properties which are used for the whole building.

• The polygon of a building cannot intersect itself.

• The polygon of a building can intersect other polygons (buildings).

Types of Buildings
Four different types of buildings are possible:

Standard buildings
These can be used to model a building in an urban environment.

Courtyards & Towers
This type of building is used to define a building which is totally inside a second building. If the
inner building is higher this is called a tower and if it is lower it is called a court yard. Courtyards
have the same material properties as standard buildings. But there is one big difference: While a
standard building has no information about the situation above the building, the courtyard defines
also the environment above the building. No standard building, vegetation building or virtual
building is possible above a courtyard. Only courtyards above courtyards are possible.

Vegetation buildings
This type of building is used to model vegetation (for example parks, trees). The “building” is
transparent (the rays have no intersections (reflection, diffraction,…) at the “building”). The (part
of the) ray inside the “building” (polygonal cylinder) has an additional loss (per meter) and the
pixels inside the “building” (polygonal cylinder) have an additional loss. The vegetation buildings
can also be used to model persons or cars (traffic) or all other objects which do not totally shadow
electromagnetic waves and where a part of the wave is able to penetrate the object (with an
additional loss compared to free space propagation).

Virtual buildings
With this type of building only pixels are excluded from the prediction (all pixels inside virtual
buildings are not computed to accelerate the prediction and reduce the memory requirements).
The virtual buildings are transparent for all prediction models. So the rays can pass the building
without any additional loss. Only pixels inside the virtual buildings will not be predicted to save
computation time. Virtual buildings can be used at the border of the database where areas are
free of buildings and which are of no interest. Or they can be used to exclude pixels in the middle
of a river/lake in a city where predictions are not required.

Consideration of Topography
The topography can additionally be considered. Either the building heights in the vector database are
defined inclusive topography or exclusive. This must be selected when preprocessing the database in
WallMan. WallMan determines the topographical height of the center of the building and then either the
relative height is obtained by subtracting the topographical height from the absolute building height
(if absolute heights are given inclusive topography in the building database) or the absolute height
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is determined by adding the topographical height to the relative building height (if relative building
heights are defined in the building databases).

Arbitrary topographical databases can be used and converted with WinProp. Topographical databases
are pixel databases and they are internally converted during the computation into a triangle
approximation of the terrain profile.

Figure 500: Triangle approximation of the terrain profile.

Preprocessing of Databases
The raw format of the urban databases is the .odb format. These files can be created or converted with
WallMan. To compute a prediction, the database should be preprocessed for all urban prediction models.
This must be done with WallMan.

The different prediction models require different preprocessing computations and thus different file
types. When creating an urban propagation project, you can choose between the following database
types:

Table 44: Urban propagation database types.

Database file extension Description

.odb Outdoor Database Binary
Raw outdoor binary vector database. This database has to be
preprocessed first, to be used for a computation..

.ocb Outdoor COST binary database
Preprocessed database for a prediction with the empirical COST
model.

.oib Outdoor IRT binary database
Preprocessed database for a prediction with the deterministic
intelligent ray-tracing (IRT) model.
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Database file extension Description

.opb Outdoor UDP binary database
Preprocessed database for a prediction with the urban dominant
path (UDP) model. 

Traffic Settings

Cell Load Defined by User
If the traffic is defined independent of the location, a traffic map is not required because it is assumed
that the traffic is homogeneously distributed over the complete prediction area.

Figure 501: Traffic Settings - Traffic tab.

The cell load used for interference calculations can be specified in terms of the assumed mean transmit
power in downlink in percent of the maximum available transmit power of the cell.

Note:  This value is only related to the power assigned for data transmission. The power
specified for the pilot signals is not influenced.

This value is related to the power assigned for data transmission, only. The power specified for the pilot
signals is not influenced.

In case of OFDM air interface the cell load can either influence transmit power in downlink or the
number of used subcarriers, depending on the settings.
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For interference computation in uplink, an assumed mean noise rise, caused by active mobile stations,
can be specified.

The default values for cell load, noise rise and power backoff can be defined in the upper section of the
property tab. In the lower part all transmitters of the current project are listed and the settings for
each transmitter are displayed in the table. The text Default indicates that a default values defined
in the upper section of the dialog is used for the corresponding transmitter. If individual settings for
a transmitter shall be defined the transmitter has to be selected in the table and the check- and edit
boxes at the bottom of the dialog can be used to define individual values for cell load, noise rise and
power backoff.

Location Dependent Traffic Definitions
For the definition of location dependent traffic a traffic map is necessary.

Figure 502: Traffic Settings - Traffic tab.

Applications
Location dependent traffic requires the specification of at least one application. Reasonable
applications are e.g. Voice Calls, Video Calls and WWW Downloads.
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Figure 503: The Edit Application dialog.

Name

Description of application.

Position
Priority of the application during cell assignment. 0 means highest priority.

Color
Color of mobile stations generated for this application in display.

Definition of traffic / users
Either arrival rate in 1/sec/m² and hold time in sec or traffic in Erlang/m² can be defined.

Activity (occupation of resources over time)
Activity of users using this application (occupation of network resources over time) in %.

Transmission Modes
At least one transmission mode must be assigned to each application. If an application is selected
with the mouse, the assigned transmission modes are displayed in the upper-right part of the
Edit project parameter dialog. If another application is selected by the user, the display of the
transmission modes is refreshed automatically. Transmission modes can be added or removed
with the corresponding buttons. The parameter “Position” specifies again the priority (0 means
highest priority) with which the transmission mode is considered during cell assignment.

Clutter classes
Clutter classes contained in the database of the project which are assigned to the selected
application. At least one clutter class is required to generate traffic for the defined application.
If another application is selected by the user, the display of the clutter classes is refreshed
automatically. Clutter classes can be added or removed with the buttons in the lower-left section.

Traffic Definition
When a clutter class is selected with the mouse the traffic values are displayed in the lower-
right area. The user can modify the values and thus assign them to the selected clutter class.
Depending on the traffic mode specified for the current application either two values (arrival rate
in 1/sec/m² and hold time in sec) or one value (traffic in Erlang/m²) must be defined. The unit for
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the area definition (either m² or km²) can be modified with the drop-down list at the top of the
dialog.

Simulation Settings
The simulation can be configured by specifying the area of planning, the resolution of prediction results,
prediction height and whether additional prediction planes are defined in the database.

Click Project > Edit Project Parameter to open the Edit Project Parameter dialog. The simulation
settings are available on the Simulation tab.

Area of Planning / Simulation

Figure 504: The Area of Planning / Simulation group on the Edit Project Parameter dialog , Simulation tab.

Prediction (simulation area)

Individual for each transmitter
The simulation area can be defined as a superposition of individual prediction areas defined
separately for each transmitter/cell. These individual prediction areas can be defined on the
Transmitter definition tab of the corresponding transmitter.

Identical for all transmitters

Rectangular area (Horizontal planes)
The rectangular simulation area can be specified by defining the lower-left and upper-

right corner coordinates. Another option is to use the  Prediction Rectangle

(Rectangle) icon on the Project toolbar, which allows you to draw a rectangle with
the mouse.

Multiple Points (Arbitrary Heights)

Specify the individual prediction or receiver points. The points can be added, deleted,
edited, imported or exported from or to a .txt file. The prediction points can be
moved by specifying a translation vector.
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Figure 505: The Prediction Point dialog.

Multiple Trajectories

Specify a prediction trajectory / receiver trajectory. A trajectory can be added,
deleted, edited, imported or exported from or to a .txt file. For each trajectory,

specify the name, x (Longitude), y (Latitude), z (Height), Velocity, Yaw[32],

Pitch[33] and Roll[34].

Figure 506: The Trajectory dialog.

Another option to specify a trajectory is to use the  Prediction Trajectories icon

on the Project toolbar, which allows you to specify the points for the trajectory using
the mouse.

32. Yaw is the rotation around the vertical axis.

33. Pitch is the rotation around the side-to-side axis.

34. Roll is the rotation around the front-to-back axis.
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Resolution of prediction results
The resolution grid of the result matrix can be changed only if the database was not preprocessed
in area mode.

Prediction Height

The height of horizontal prediction planes can be defined relative to the ground level, absolute to
sea level or relative to defined floor levels.

For prediction heights relative to ground, the height of interest is location-dependent. A typical
example is where a person is walking in a hilly area with a cell phone.

For prediction heights absolute to sea level, the height of interest is fixed and does not follow the
terrain. A typical example is where an aircraft flies at 1500 m.

Additional Prediction Planes
When the Surface of Buildings check box is selected, results will also be computed on surfaces
of those buildings for which Surface Prediction was defined in WallMan. Those results will be
visible in the 3D view, not in the 2D view.

Figure 507: An example of predictions along building surfaces in an urban scenario.

Trajectory sampling

The height of a prediction trajectory can be defined relative to the ground level or absolute to
sea level.

For a prediction trajectory relative to ground, the height of interest is location-dependent. A
typical example is where a person is walking in a hilly area with a cell phone.

For prediction heights absolute to sea level, the height of interest is fixed and does not follow the
terrain. A typical example is where an aircraft flies at 1500 m.

Settings related to radio network planning simulations are only available for network projects. Some of
the general simulation parameters depend on the selected air interface.
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Reduce Computation Time for Large Databases
For large databases, computation time can be reduced by defining database areas where ray
interactions are tracked.

In case of very large databases, the rectangular prediction area may well be (much) smaller than the
total area in the database. This means that results is only computed for pixels in that limited area.

Figure 508: Example of a prediction area that is small relative to the database.

Even then, depending on the simulation method, simulation times can be long because the tool still
investigates how interactions of rays with all buildings (including those far away) affect the results in
the prediction area. To reduce the simulation time further, you can define a polygon that describes
which database area is to be included in the tracking of the ray interactions.

Create the polygons by clicking Project > Database Area: Draw/Erase or use the  icon.

An example of such a database area around the prediction area is shown in Figure 509. Buildings
(or any vector objects) that are completely outside the database area, are ignored. Buildings (vector
objects) that are completely or partly inside are included. For indoor and urban scenarios, the database
area does not have to be larger than the prediction area; you have considerable freedom to exclude
buildings.
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Figure 509: The database area is indicated by the blue polygon. Ray tracking is limited to inside the polygon.

Since the database area applies to vector objects, it is available in indoor and urban scenarios, including
scenarios with vector topography (ground described by triangles, for example, via a file with .tdv
extension). It is not available in rural scenarios based on pixel databases (files with .tdb extension).

As for time-variant scenarios, any database area is active for all time steps but the polygons (the
geometry selection) can only be drawn with the first time step and this selection is the same for all the
time steps.

In case of multiple transmitters, you may want to define multiple database areas and assign them to

transmitters. Once a new polygon is drawn using the  icon, the Cells dialog is displayed containing a

list of all the cells. Select a cell to assign the polygon to the desired transmitter.

Figure 510: The Cells dialog.

To manage all the database areas open the Database Polygons dialog. Click Project > Edit project
Parameter. Select the Building Data tab and under Database Polygons, select the Consider
database polygons check box and click Settings to launch the Database Polygons dialog.
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Figure 511: The Database Polygons dialog.

From the Database Polygons dialog, you can:

• Add a new polygon.

• Delete an existing polygon.

• Add a new point to a polygon. The position of the point can be specified by selecting one of the
existing points (the position will be next the selected point), if no position was specified the point
will be added to the end of the points list.

• Edit an existing point.

• Delete an existing point.

◦ When adding, editing, or deleting a point, some checks are performed if the polygon is still
valid (does not intersect itself and it has at least three points).

• Modify the assigned transmitters to this polygon.

In the computation:

• If a cell does not have a polygon, the whole database is considered as usual.

• If a cell has one or more polygons, the objects that are inside any one of the polygons are
considered while the remaining objects are ignored.

In case of vector topography, the selection of database area also applies to the triangles that represent
the ground. In that case, it is important to choose the database area large enough to include the entire
prediction area, otherwise the topo height at some prediction pixels is no longer properly defined.

If you have multiple transmitters and a modest prediction area between them, defining database areas
(see Figure 512) can be efficient. The prediction area (the red rectangle where results is computed) is
part of all database areas, and each individual database area also includes the buildings between the
transmitter and the prediction area.

In order to distinguish between different object types in the 2D and 3D views:

• The objects, which are ignored by all transmitters, are considered as virtual objects and are
represented in blue.
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• The objects, which are considered by all the transmitters, are represented by its default color.

• The objects, which are considered by one ore more transmitters and ignored by other transmitters,
are considered as partially virtual and are represented in light blue.

Figure 512: An example showing multiple defined database areas.

Traffic Settings

There are different approaches for modeling cell loads in ProMan.

If no explicit traffic is defined, the cell load used for interference calculations can be specified in terms
of the assumed mean transmit power in downlink (in percent of the maximum available transmit power
of the cell together with the definition of the assumed mean noise rise) and the power backoff for the
cell assignment channel. These definitions can be specified either for all cells of the network or for each
cell individually.

In case clutter maps are available for location dependent traffic definitions, cell loads can be determined
based on traffic generated during static or Monte Carlo network simulations.

Cell Load Defined by User
If the traffic is defined independent of the location, a traffic map is not required because it is assumed
that the traffic is homogeneously distributed over the complete prediction area.
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Figure 513: The Edit project parameter dialog - Traffic tab.

The cell load used for interference calculations can be specified in terms of the assumed mean transmit
power in downlink in percent of the maximum available transmit power of the cell.

Note:  This value is only related to the power assigned for data transmission. The power
specified for the pilot signals is not influenced. In case of OFDM air interface the cell load can
either influence transmit power in downlink or the number of used subcarriers, depending on
the settings.

For interference computation in uplink, an assumed mean noise rise, caused by active mobile stations,
can be specified.

The default values for cell load, noise rise and power backoff can be defined in the upper section of the
Edit project parameter dialog. In the lower part all transmitters of the current project are listed and
the settings for each transmitter are displayed in the table. The text default indicates that a default
values defined in the upper section of the dialog is used for the corresponding transmitter. If individual
settings for a transmitter is to be defined, the transmitter has to be selected in the table and the check
boxes and edit boxes at the bottom of the dialog can be used to define individual values for cell load,
noise rise and power backoff.

Location Dependent Traffic Definitions
For the definition of location dependent traffic a traffic map is necessary.
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Figure 514: Settings on the Traffic tab with speech settings.

Applications
Location dependent traffic requires the specification of at least one application. Reasonable
applications are for example Voice Calls, Video Calls and WWW Downloads.

Figure 515: The Edit Application dialog.

Name
Description of application.

Position
Priority of the application during cell assignment. 0 means highest priority.

Color
Color of mobile stations generated for this application in display.
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Definition of traffic / users
Either arrival rate in 1/sec/m² and hold time in sec or traffic in Erlang/m² can be defined.

Activity (occupation of resources over time)
Activity of users using this application (occupation of network resources over time) in %.

Transmission modes
At least one transmission mode must be assigned to each application. If an application is selected
with the mouse, the assigned transmission modes are displayed in the upper-right part of the
Edit project parameter dialog. If another application is selected by the user, the display of the
transmission modes is refreshed automatically. Transmission modes can be added or removed
with the corresponding buttons. The parameter Position specifies again the priority (0 means
highest priority) with which the transmission mode is considered during cell assignment.

Clutter classes
Clutter classes contained in the database of the project which are assigned to the selected
application. At least one clutter class is required to generate traffic for the defined application. If
another application is selected by you, the display of the clutter classes is refreshed automatically.
Clutter classes can be added or removed with the buttons in the lower-left section.

Traffic definition
When a clutter class is selected with the mouse the traffic values are displayed in the lower-right
area. You can modify the values and thus assign them to the selected clutter class. Depending on
the traffic mode specified for the current application, either two values (arrival rate in 1/sec/m²
and hold time in sec) or one value (traffic in Erlang/m²) must be defined. The unit for the area
definition (either m² or km²) can be modified with the drop-down list at the top of the dialog.
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Project Settings
The project settings for urban projects are given.

Settings

Figure 516: The Edit project parameter dialog, Building data tab.

Building database
You can change the database file path only.

Material properties of buildings
The individual material properties of the buildings (as defined in the building database) can be
used by the prediction models when the prediction is computed or default values for all buildings
can be used. This can be selected on the Database tab of the Edit project parameters dialog.

The COST model does not consider the material properties of the buildings. The consideration of
the material properties in the propagation models and their influence on the prediction results
is explained together with the propagation models, because they are used in a different way
(for example the COST Walfisch-Ikegami model does not consider the material properties of the
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buildings at all, therefore these fields are not enabled when a COST database is loaded which
allows only COST predictions).

If the individual properties are not defined in the database or if the user does not want to use
the material properties defined in the database, default values can be used by enabling Default
transmission loss for all buildings. In this case, all buildings are assigned the same building
penetration loss independent of the definitions in the database (individually defined properties are
not taken into account, for all buildings the same material properties are used). The default value
can be changed by using the Change button.

Figure 517: The Change default values for Material Properties dialog.

Note:  Parameters, which actually impact the wave propagation prediction, depend on
the selected propagation model and further propagation parameters.

Ray optical propagation models, such as standard ray-tracing (SRT) and intelligent ray-tracing (IRT)
use all material parameters listed in the dialog for Fresnel coefficients and GTD / UTD or the empirical
transmission, reflection and diffraction model, respectively, depending on the computation mode
of signal level. Semi-deterministic and empirical prediction models only use parameters for Fresnel
coefficients or the values for the transmission loss, respectively, depending on the computation mode of
signal level.

Topography
Terrain elevation data can be considered additionally. The corresponding database file can be
selected via the Change button. After that, the heights of the buildings contained in the vector
database have to be specified to be either relative to the ground level (terrain elevation data) or
absolute to sea level.

Note:  This option is not available if a pre-processed database is used. In this case
topography data can be considered optionally during pre-processing and is already
included in the building vector database then.
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Vegetation Objects
Vegetation data can be considered optionally. Vegetation blocks can be included either as vector
objects or based on a pixel database, which can be specified additionally. If no vector vegetation
objects are already contained in the database, a pixel database describing vegetation can be
specified using the Change button.

For both vector and pixel based vegetation objects material properties can be specified. If pixel
based vegetation objects are used or if the user does not want to use the properties defined for
vegetation objects in the vector database, new values can be used by clicking Default values. In
this case, all vegetation blocks are assigned the same values, independent of possible definitions
in the vector database. Individually defined properties are not taken into account for vector based
vegetation blocks, for all vegetation objects the same material properties are used. The default
values can be changed by using the Change button. After clicking on the button, the dialog for
the definition of the vegetation properties appears.

Figure 518: The Vegetation Default Properties dialog.

If vector based vegetation blocks are used, the vegetation properties are defined in the vector
database. These individual properties, specified for each vegetation block, can be modified with a
common offset additionally. 

Clutter (morpho) properties
For the dominant path model (DPM), morphological properties of the area can be considered
during the prediction. For this purpose, an additional morphological database is needed. This
is optional and can therefore be disabled. The clutter database does only contain a class ID for
each pixel. The properties of the class are defined in a clutter table. This clutter table must be
additionally specified when working with clutter databases.

Properties of clutter classes

For each clutter class a frequency dependent attenuation can be defined in the clutter table.
You can select if this additional attenuation is considered during the prediction or if the
value is neglected. If no properties for a class ID are found in the clutter table, you can
decide if the software should cancel all further prediction steps or if only this pixel is not
predicted.

Most propagation tools only consider the class at the receiver pixel for the influence on the
wave propagation. But this means, that if 90% of the distance between transmitter and
receiver are, for example, in the clutter class urban and only the receiver pixel is in the
class forest, the properties of the class forest would be used. This is obviously not correct
if 90% of the area between transmitter and receiver are urban. Therefore, WinProp offers
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optionally the determination of the dominant class between transmitter and receiver and
this class is then used for the evaluation of the receiver pixel. But some classes have a
greater influence on the propagation than others. Therefore, each class can be assigned a
weight factor. The higher the weight factor the stronger the influence of the class on the
propagation.

Example: If 1 urban and 3 water classes are between transmitter and receiver and all
classes would have the same weight (for example 1), the dominant class would be water.
If the weight factor of urban would be 5 and the weight factor of water would be 1, the
dominant class would be urban, because the total weight of urban would be 5 (1 class * 5
weights) compared to the total weight of water which would be 3 (3 classes * 1 weight).

In order to avoid the impact of the URBAN clutter classes (clutter names like urban,
dense_urban, high_buildings, residential) on areas where building vector data is already
considered in the urban DPM, you need to define the corresponding clutter losses and/or
heights to 0 in the clutter table.

Database polygons
To manage the database areas, select the Consider database polygons check box. For more
information refer to Reduce Computation Time for Large Databases.

Computation Settings

For more information on how to set up a new propagation projects, see Set Up a New Project.

Note:  The multi-path propagation results are only available with the IRT[35] model.

Settings

Figure 519: The Edit project parameter dialog, Computation tab.

35. intelligent ray tracing model (IRT)
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Prediction Model
Only the model which was selected at the preprocessing can be chosen for the prediction because
the database contains only data for this prediction model. This simplifies the usage of ProMan as
all other models can not be activated. Known from literature are the intelligent ray-tracing (IRT)
model as well as the COST 231 (Walfisch-Ikegami) model. The IRT model allows fast rigorous
3D and 2x 2D ray-tracing predictions. The settings of the models can be changed by using the
Settings button.

Indoor Prediction
Select the Indoor Coverage (without indoor walls) check box if you want to compute an
estimation of the indoor coverage. No additional database is needed. Use the Settings button to
choose an indoor penetration model.

Calibration of Urban Models
View the calibration settings

WinProp allows the automatic calibration of nearly all available propagation models based on
measurement data. Additionally some propagation models support the calibration of material properties
and of clutter/land usage databases. The following table shows an overview of the models and the
features.

Table 45: Overview of propagation models and features.

Scenario Model Material calibration Clutter calibration

One slope model no not applicable

Motley-Keenan model no not applicable

Multi-Wall (COST 231)
model

yes not applicable

Dominant path model no not applicable

Standard ray-tracing model yes not applicable

Indoor

Intelligent ray-tracing
model

yes not applicable

Knife edge model no not applicable

Walfisch-Ikegami (COST
231) model

no not applicable

ITU-R P.1411 model no not applicable

Urban

Dominant path model no not applicable
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Scenario Model Material calibration Clutter calibration

Intelligent ray-tracing
model

no not applicable

Empirical two ray model n/a yes

Deterministic two ray
model

n/a yes

Rural

Dominant path model n/a no

The following picture shows the procedure for the calibration of the propagation models:

Figure 520: Procedure for calibration of propagation models.

During the prediction, calibration files are written to the hard disk. The calibration is done afterwards
based on the calibration files (.cal).

Generation of WinProp Measurement Files
Measurement files in WinProp file format (.fpp, .fpl, .fpf) have to be created prior to the calibration.
This means the raw measurement data has to be imported from simple ASCII files into the WinProp
software. See Import Prediction Data for more information.

Assignment of Measurement Files to Transmitters
To retrieve a calibration file (.cal) after the prediction, a measurement file has to be assigned to the
corresponding transmitter. Only one measurement route can be assigned to one transmitter.
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Figure 521: The Cell dialog.

The Measurements button is used to assign a measurement file (.fpp, .fpl, .fpf files are supported)
to the selected transmitter. The measurement file must contain measured data from the selected
transmitter only. Superposed measurement data from several transmitters is not supported. When the
measurement data is in path loss format (.fpl) cable loss must not be included. In contrast to this,
cable loss is expected as “included” when measurement data is available in field strength or power file
format. Antenna gain is always expected as “included”.

Computation of Propagation Prediction
After the assignment of the measurement files to the transmitters is completed, the wave propagation
prediction can be launched as usual. The propagation paths output needs to be activated, otherwise no
.cal files will be generated.

For each transmitter (with measurement data assigned) a calibration file (.cal) is written to the hard
disk. If the files are missing, click the Prediction tab, under Additional Prediction Data... and select
the Propagation Paths check box.

Calibration Computation
The calibration tool can be started from the Computation menu (Computation > Auto Calibration
(Models & Materials)). The calibration files generated during the wave propagation prediction have to
be added to the list.
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Figure 522: The Calibration dialog.

Files can be added by clicking on Add files. They can be deleted by clicking on Remove file.

The settings can be adapted to the users needs by selecting General settings. This allows you to
influence the selection of the measurement points. Only points in a given power (dBm), path loss (dB)
or distance (m) range will be considered.

Figure 523: The Settings dialog.

Additionally the type of optimization method can be chosen:
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Minimum mean error
The goal of the optimization is to achieve a minimum mean error (nearest to zero). The standard
deviation is not considered and thus might be larger.

Minimum mean squared error
The goal of the optimization is to achieve a minimum mean squared error. The standard deviation
is not considered and thus might be larger.

Minimum standard deviation
The goal of the optimization is to achieve a minimum standard deviation. The mean error is not
considered and thus might be larger

Minimum weighted error
The goal of the optimization is to find the best combination of minimum mean error and minimum
standard deviation. The weighting between mean error and standard deviation can be adapted by
the user.

The range of the model parameters can be defined in the Settings dialog. As larger the range is, as
longer the calibration will take. The model parameters depend on the selected propagation model. Each
model offers individual model parameters. The following screenshot shows model parameters for the
urban intelligent ray-tracing.

Figure 524: The Parameter Ray Tracing (IRT) dialog.

The model parameters can be modified on the dialog.

Depending on the propagation model the material database or the clutter/land usage database can be
calibrated additionally. More information about the material calibration can be found here.
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After clicking on Start the calibration begins and the progress is shown with a progress bar. In some
cases the calibration process does take up to 1 hour.

Calibration Result
After a calibration has finished the results are displayed in a table. The picture below shows the results
for the urban dominant path model. Depending on the propagation model different parameters are
listed in the table.

Figure 525: The Results for Dominant Path Urban dialog.

The model parameters listed in the table can now be transferred manually into the project settings
of ProMan and the project can be recomputed to achieve better results based on the new model
parameters. By clicking on Apply the material properties (as far as they have been calibrated) are
applied to the vector/material database.

The dialog shown above gives also information about mean value and standard deviation from
measurements to predictions before and after the calibration. Depending on the optimization method
different results can be obtained.

Indoor
The phenomena which influence radio wave propagation can generally be described by four basic
mechanisms: Reflection, diffraction, penetration and scattering. For the practical usage of propagation
models in real scenarios these mechanisms must be described by approximations.

Predicting the propagation characteristics between two antennas inside a building is important
especially for the design of wireless local area networks (WLAN). Also the installation of cellular systems
with indoor base stations involves the usage of indoor propagation models.

The indoor propagation channel differs considerably from the outdoor one. The distance between
transmitter and receiver is shorter due to high attenuation caused by internal walls and furniture and
often also because of the lower transmitter power. The short distance implies shorter delay of echoes
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and consequently lower delay spread. The temporal variations of the channel are slower compared to
mobile antennas moving with a car. As it is the case in outdoor systems, there are several important
propagation parameters to be predicted. The path loss and the statistical characteristics of the received
signal envelope are most important for coverage planning applications. The wide-band and time
variation characteristics are essential for evaluation of the system performance.

Propagation Models

For the installation of mobile radio systems, wave propagation models are necessary to determine
propagation characteristics for any arbitrary configuration. The predictions are required for a
proper coverage planning, the determination of multipath effects as well as for interference and cell
calculations, which are the basis for the high-level network planning process.

The environments where these systems are intended to be installed, are ranging from indoor up to
large rural areas. Hence wave propagation prediction methods are required covering the whole range
of macro-, micro- and pico-cells including indoor scenarios and situations in special environments like
tunnels or along highways.

Figure 526: Definition of different cell types.

For the wave propagation prediction of leaky feeder cables special models are used, which can be
specified and parameterized on the Computation tab.

The phenomena which influence radio wave propagation can generally be described by four basic
mechanisms: Reflection, diffraction, penetration and scattering. For the practical usage of propagation
models in real scenarios these mechanisms must be described by approximations.

The basis for any propagation model is a data base which describes the propagation environment.
Considering indoor propagation suggests, for the purpose of propagation modeling, that each building
element should be categorized into classes (wall, floor, door, window) and specified by its coordinates
and finally its material properties (thickness, permittivity, conductivity).

To get a more accurate description of wave propagation, the building data are stored in a 3D-vector
format including all walls, doors, and windows. All elements inside the building are described in terms
of plane elements. Every wall is for example represented by a plane and its extent and location is
defined by its corners. Additionally, for each element individual material properties can be taken into
account. With respect to an efficient use it is also possible to import .dxf files, a common data format
in architecture.
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Figure 527: Example of a 3D building database used in ProMan for indoor propagation.

One Slope Model (Modified Free Space Model)
The one slope or modified-free-space model analyzes the building structure only regarding LOS / NLOS
situation in the vertical plane between transmitter and each receiver point.

Different path loss exponents and offsets are considered for LOS / NLOS. The attenuations of the walls
are not considered during the computation. Therefore, this model computes the path loss similar to the
free space loss with adaptable exponent and offset for line-of sight (LOS) and non-line-of-sight (NLOS)
areas. Herewith it assumes that the path loss depends only on the distance d with a specific attenuation
coefficient n and the offset lc.

(91)

According to this simple approach the prediction results are fairly inaccurate and only suited for a rough
estimation.

Click Project > Edit Project Parameter and click the Computation tab.
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Figure 528: Propagation result in the 3D view.

To calibrate this model with measurement data the exponents and the offsets to be used for this model
can be specified by using the Settings button. For LOS situations the values for n are in the range
between 2.0 and 2.8, in NLOS scenarios values up to 4.0 are possible. The offsets are applied to field
strength / power / neg. path loss results (larger offsets mean more optimistic results).

Figure 529: The Parameter: One Slope Model dialog.

Motley-Keenan Model (MK)
The model, according to Motley and Keenan, computes the path loss based on the direct ray between
transmitter and receiver.

In contrary to the modified free space model this model considers the exact locations of the walls, floors
and ceilings of the building taken into account. Additional factors for absorption of the direct ray path by
walls consider these shadowing effects.

Click Project > Edit Project Parameter and click the Computation tab.
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Figure 530: Principle of the Motley-Keenan Model.

(92)

The parameter kw describes the number of walls intersected by the direct path between transmitter
and receiver. An uniform transmission (penetration) loss lw for all walls is used for the computation (the
material properties of the individual walls are not considered). This uniform transmission loss can be
specified by using the Settings button.
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Figure 531: Propagation result in 3D view of ProMan.

Figure 532: Parameters of the Motley-Keenan model.

COST-Multi-Wall Model (MW)
The multi-wall model gives the path loss as the free space loss added with losses introduced by the
walls and floors penetrated by the direct path between transmitter and receiver.

It has been observed that the total floor loss is a function of the number of the penetrated floors. This
characteristic is taken into account by introducing an additional empirical correction factor.
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Figure 533: Principle of the COST-Multi-Wall Model.

The individual penetration losses for the walls (depending on their material parameters) are considered
for the prediction of the path loss. Therefore, the multi-wall model can be expressed as follows:

(93)

where

•  is the free space loss between transmitter and receiver

•  is the constant loss

•  is the number of penetrated walls of type i

•  is the number of penetrated floors

•  is the loss of wall type i

•  is the loss between adjacent floors

•  is the number of different wall types

The constant loss in the equation above is a term which results when wall losses are determined
from measurement results by using multiple linear regression. Normally it is close to zero. The third
summand in the equation represents the total wall loss as a sum of the walls between transmitter and
receiver. For practical reasons in ProMan the individual wall loss of the intersected walls is considered.

It is important to notice that the loss factors in the formula express not physical wall losses but model
coefficients which are optimized with the measured path loss data. Consequently, the loss factors
implicitly include the effect of furniture. However, wave guiding effects are not considered with this
model, thus the accuracy is moderate. On the other hand, this model has a low dependency on the
database accuracy and because of the simple approach a very short computation time. Therefore, no
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preprocessing of the building data is needed for the computation of the prediction and no settings have
to be adapted for this prediction model. 

Figure 534: Propagation result in 3D view of ProMan.

Figure 535: The Parameter: Multi Wall Model dialog.

Indoor Dominant Path Model
The dominant path model (DPM) determines the dominant path between the transmitter and each
receiver pixel. So the computation time compared to ray-tracing is significantly reduced and the
accuracy is nearly identical to ray-tracing.

Ray-optical propagation models are still time-consuming – even with accelerations like preprocessing.
And what is even more important, they rely on an accurate vector database. Small errors in the
database influence the accuracy of the prediction. On the other hand, empirical models are rely on
dedicated propagation effects like the over-rooftop propagation (for example the direct ray COST 231).
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A comparison of prediction results computed with three types of prediction models is presented in the
following figure:

Figure 536: Prediction results with three types of prediction models. Empirical COST 231
(on the left), intelligent ray-tracing (in the middle) and indoor dominant path (to the right).

Analyzing typical propagation scenarios shows that in most cases one propagation path contributes
more than 90% of the total energy. The dominant path model (DPM) determines exactly this dominant
path between the transmitter and each receiver pixel. So the computation time compared to ray-tracing
is significantly reduced and the accuracy is nearly identical to ray-tracing.

Figure 537: A typical channel impulse response where one path dominates.

Empirical models (like COST 231) consider only the direct path between a transmitter and a receiver
pixel. Ray tracing models (like IRT) determine numerous paths. DPM determines only the most relevant
path, which leads to short computation times.
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Figure 538: Comparison of different approaches (COST 231
on the left, ray-tracing in the middle and DPM to the right).

Advantages of the Dominant Path Model
As a consequence of the properties and restrictions of the available prediction models mentioned above,
the dominant path prediction model (DPM) has been developed. The main characteristics of this model
are:

• The dependency on the accuracy of the vector database is reduced (compared to ray-tracing).

• Only the most important propagation path is considered, because this path delivers the main part
of the energy.

• No time-consuming preprocessing is required (in contrast to IRT).

• Short computation times.

• Accuracy reaches or exceeds the accuracy of ray-optical models.

Typical Application of the Dominant Path Model
As the dominant path model does not require a preprocessing of the building vector database, it is
ideally suited for large indoor areas. Additionally the approach to compute only the dominate ray
emphasizes this operational area. The model does not compute the complete channel impulse response,
as a result, if you are interested in the channel impulse response, the delay spread or the angular
spread, a ray-tracing model is recommended. The DPM is the ideal approach to compute coverage
predictions in large multi-story indoor environments.

Algorithm of the Dominant Path Model
The DPM determines the dominant path between transmitter and each receiver pixel. The computation
of the path loss is based on the following equation:

(94)

where L is the path loss computed for a specific receiver location. The following parameters are
considered by the model:

• Distance from transmitter to receiver ( )

• Path loss exponent ( )

• Wave length ( )

• Individual interaction losses due to diffractions ( )

• Individual transmission losses of all penetrations ( )
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• Empirically determined loss reduction due to wave guiding ( )

• Gain of transmitting antenna ( )

As described above, l is length of the path between transmitter and current receiver location. p is the
path loss exponent. The value of p depends on the current propagation situation. In buildings with a
lot of furniture (which is not included in the vector modeling) p = 2.3 is suggested, whereas in empty
buildings p = 2.0 is reasonable. The function f yields the loss (in dB) which is caused by diffractions.
The diffraction losses are accumulated along one propagation path. Reflections and scattering are
included empirically. For the consideration of reflections (and scattering), an empirically determined
wave guiding factor is introduced.

This wave guiding factor takes into account, that a wave propagating in a long close corridor will
be reflected on the walls leading to less attenuation compared to free space. Thus, wave guiding
effects can be expressed as an additional gain in dB. The transmission (penetration) losses are also
accumulated along the one propagation path. The directional gain of the antenna (in direction of the
propagation path) is also considered.

Configuration of the Dominant Path Model

Figure 539: The Configuration of Dominant Path Model dialog.
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Path Loss Exponents
The path loss exponents influence the propagation result computed by the DPM significantly. The
path loss exponents describe the attenuation with distance. A higher path loss exponent leads to
a higher attenuation in same distance.

Figure 540: Three predictions using different path loss values. LOS exponent 2.0
(on the left), LOS exponent 2.3 (in the middle) and LOS exponent 2.6 (to the right).

The following table shows recommended path loss exponents. The more objects that are missing
in the vector database, the higher the path loss exponent should be.

Table 46: Recommended path loss exponents.

Environment Empty buildings Filled buildings

LOS 2.0 2.1

OLOS 2.1 2.3

NLOS 2.2 2.5

Losses
Each change in the direction of propagation due to an interaction (diffraction, transmission/
penetration) along a propagation path causes an additional attenuation. The maximum
attenuation can be defined. The effective interaction loss depends on the angle of the diffraction.
It is recommended to use the default value.

Waveguiding effects
As mentioned before, the DPM includes waveguiding effects to achieve accurate results. Two
parameters are available to configure the wave guiding module. The first parameter is used to
define the maximum distance to walls to be included in the determination of the wave guiding
factor. With the second parameter the weight of the wave guiding effects in the computation of
the path loss is defined (1.0 is suggested. Values below 1.0 reduce the influence of the wave
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guiding factor and values above 1.0 increase it). In typical scenarios the wave guiding effects can
be turned off, this reduces the prediction time.

Breakpoint distance
The breakpoint distance describes the distance from the transmitter when destructive
superposition of the direct ray and the ground reflected ray occurs. Because of that the
attenuation is much higher and thus larger path loss exponents are often used. The default
distance for the breakpoint distance in indoor environments is 500m.

Additional Features
The DPM supports additional features:

• Combined network planning: The DPM offers the CNP mode which allows the combination urban
and indoor predictions. In the urban environment the prediction is computed with the urban
dominant path model (UDP), its settings and the resolution selected for the urban domain. For the
predictions in the indoor area the indoor dominant path model (IDP) with a higher resolution is
used. The settings of the dominant path model, such as path loss exponents and interaction losses,
can be defined for both environments (urban and indoor) individually.

• Multi-story prediction: The DPM is able to compute wave propagation predictions on several heights
(layers) at the same time. This is useful for network planning in multi-story buildings.

Auto Calibration
The model can be calibrated automatically.

3D Shooting and Bouncing Rays
The Shooting and Bouncing Rays (SBR) method performs a rigorous 3D ray-launching prediction which
results in a high accuracy, but it can be computationally expensive.

Deterministic models are used to simulate the propagation of radio waves physically. Therefore, the
effect of the environment on the propagation parameters can be taken into account more accurately.
Another advantage is that deterministic models make it possible to predict several propagation
parameters. For example, the path loss, impulse response and angle-of-arrival can be predicted at the
same time.

Figure 541: Principle of ray optical models.
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As smaller wavelengths (higher frequencies) are considered, the wave propagation becomes similar to
the propagation of light. Therefore a radio ray is assumed to propagate along a straight line influenced
only by refraction, reflection, diffraction or scattering which is the concept of geometrical optics (GO).
The criterion taken into account for this modeling approach is that the wavelength should be much
smaller than the extension of the considered obstacles, for example, the walls of a building. At the
frequencies used for mobile communication networks this criterion is also inside buildings sufficiently
fulfilled.

There are two different basic approaches for the determination of the ray paths between transmitter
and receiver in the geometrical optics technique:

• ray-tracing

• ray launching

Propagation Paths
Each transmission through a wall, each reflection at a wall and each diffraction at an edge counts as
an interaction. The computed propagation paths can be limited within the propagation model settings.
The value Max. defines the maximum number of interactions that are allowed for each propagation
path. The appropriate value depends on the building structure. If, for example, the building has a
corridor that runs around a corner three times, then it would be better to compute more interactions,
because multiple diffractions are needed to reach all prediction pixels. The same occurs if a building has
a structure where the rays have to pass many walls to reach every point of the building, because then
more transmissions are needed. The only constraint is that the computation time naturally increases if
more interactions are computed. On the other hand, if too few interactions are computed, the accuracy
decreases. In this case additionally more prediction pixels might not be reached by the SBR prediction,
which leads to the need to compute those pixels with an empirical model which will decrease the
accuracy even more. As a basic rule, an appropriate setting for the maximum value would be 2 – 4,
depending on the building structure.

If the indoor database contains additional objects defining the ground, such as topography and clutter
objects, the interactions (reflection, diffraction) at those objects can be activated as well.

Note:  This option is only available if topography or clutter objects are included in the
database.

Computation of Each Ray's Contribution
For the computation of the rays, not only the free space loss has to be considered but also the loss
due to the transmissions, reflections and (multiple) diffraction. This is either done using a physical
deterministic model or using an empirical model.

Note:  This does only affect the determination of the transmission, reflection and diffraction
coefficients. The prediction itself always remains a deterministic one (the same rays are
taken into account).

The deterministic model uses Fresnel equations for the determination of the reflection and transmission
loss and the GTD / UTD for the determination of the diffraction loss. This model has a slightly longer
computation time and uses three physical material parameters (permittivity, permeability and
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conductivity). When using GTD / UTD and Fresnel coefficients arbitrary linear polarizations (between
+90° and –90°) can be considered for the transmitters.

The empirical model uses five empirical material parameters (minimum loss of incident ray, maximum
loss of incident ray, loss of diffracted ray, reflection loss, transmission loss). For correction purposes or
for the adaptation to measurements, an offset to those material parameters can be specified. Here with
the empirical model has the advantage that the needed material properties are easier to obtain than the
physical parameters required for the deterministic model. Also the parameters of the empirical model
can more easily be calibrated with measurements. It is therefore easier to achieve a high accuracy with
the empirical model.

Note:  The computation mode for the signal level along the paths can be selected on the
Computation tab. For the Shooting and Bouncing Rays method, both the empirical losses
and the electrical material parameters need to be set correctly.

The effect of bookshelves and cupboards covering considerable parts of walls is taken into account
by including an additional loss of the wall's penetration (transmission) loss. An additional loss of 3
dB was observed to be appropriate. This additional loss is introduced in context of walls covered by
bookshelves, cupboards or other large pieces of furniture. Furthermore, it was found necessary to set
an empirical limit for the wall transmission loss which otherwise becomes very high when the angle of
incidence is large.

The following interaction types exist:

Specular Reflection

The specular reflection phenomenon is the mechanism by which a ray is reflected at an angle
equal to the incidence angle. The reflected wave fields are related to the incident wave fields
through a reflection coefficient which is a matrix when the full polarimetric description of the wave
field is taken into account.

The most common expression for the reflection is the Fresnel reflection coefficient which is valid
for an infinite boundary between two media, for example, air and concrete. The Fresnel reflection
coefficient depends on the incident wave field and upon the permittivity and conductivity of each
medium. The application of the Fresnel reflection coefficient formulas is very popular and these
equations are also applied in ProMan.

To calibrate the prediction model with measurements, some ray optical software tools consider an
empirical reflection coefficient varying with the incidence angle to simplify the calculations. Such
an empirical approach is also available in ProMan.

Diffraction

The diffraction process in ray theory is the propagation phenomena which explain the transition
from the lit region to the shadow regions behind the corner or over the rooftops. Diffraction by
a single wedge can be solved in various ways: empirical formulas, perfectly absorbing wedge,
geometrical theory of diffraction (GTD) or uniform theory of diffraction (UTD).

The advantages and disadvantages of using either one formulation is difficult to address since it
may not be independent on the environments under investigation. Indeed, reasonable results are
possible with each formulation. The various expressions differ mainly from the approximations
being made on the surface boundaries of the wedge considered. One major difficulty is to express
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and use the proper boundaries in the derivation of the diffraction formulas. Another problem is
the existence of wedges in real environments: the complexity of a real building corner or of the
building’s roof illustrates the modeling difficulties.

Despite these difficulties, however, diffraction around a corner or over rooftop are commonly
modeled using the heuristic UTD formulas since they are well behaved in the lit/shadow transition
region, and account for the polarization as well as for the wedge material. Therefore these
formulas are also used in ProMan to calculate the diffraction coefficient.

Multiple Diffraction

For the case of multiple diffraction the complexity increases dramatically. One method frequently
applied to multiple diffraction problems is the UTD. The main problem with straightforward
applications of the UTD is that in many cases one edge is in the transition zones of the previous
edges. Strictly speaking this forbids the application of ray techniques, but in the spirit of the UTD
the principle of local illumination of an edge should be valid. At least within some approximate
degrees, a solution can be obtained which is quite accurate in most cases of practical interest.

The key point in the theory is to include slope diffraction, which is usually neglected as a higher
order term in an asymptotic expansion, but in the transition zone diffraction the term is of
the same order as the ordinary amplitude diffraction terms. Additionally there is an empirical
diffraction model available which can easily be calibrated with measurements.

Scattering

Rough surfaces and finite surfaces (surfaces with small extension in comparison to the
wavelength) scatter the incident energy in all directions with a radiation diagram that depends
on the roughness and size of the surface or volume. The dispersion of energy through scattering
means a decrease of the energy reflected in specular direction.

This simple view leads to account for the scattering process by only decreasing the reflection
coefficient. The reflection coefficient is decreased by multiplying it with a factor smaller than one
where this factor is exponentially dependent on the standard deviation of the surface roughness
according to the Rayleigh theory. This description does not take into account the true dispersion
of radio energy in various directions, but accounts for the reduction of energy in the specular
direction due to the diffuse components scattered in all other directions.

Penetration and absorption
Penetration loss due to building walls have been investigated and found to be dependent on
the particular system. Absorption due to trees or the body absorption are also propagation
mechanisms difficult to quantify with precision. Therefore in the radio network planning
process adequate margins should be considered to ensure overall coverage. Another absorption
mechanism is the one due to atmospheric effects. These effects are usually neglected in
propagation models for mobile communication applications at radio frequencies but are important
when higher frequencies (for example 60 GHz) are used.
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Figure 542: The Parameter: Shooting & Bouncing Rays (SBR) dialog.

Propagation Paths and Interactions

The Propagation paths and interactions group allows to specify the number of interactions
that should be considered for the determination of ray paths between transmitter and receiver
including the maximum number of reflections, diffractions and scattering. To accelerate the
prediction, additional diffractions and transmissions can be ignored for all rays with more than
one reflection. The minimum length of wedges where diffractions can occur can be specified in
meters. The maximum inner angle of wedges can be specified in degrees. When a curved surface
is approximated by many triangles, those may form many wedges for which a calculation of
diffraction is not needed. This option enables you to exclude such diffractions and save simulation
time. In case the simulation database contains ground objects (topography in vector format),
interaction at those objects can optionally be considered. Diffuse scattering in indoor scenarios
can play an important role, especially for determining the actual temporal and angular dispersion
of the radio channel.
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The WinProp SBR model was extended to consider the scattering on building walls and other
objects. For this purpose the scattering can be activated in the model settings by enabling the
option “Consider additionally rays with scattering”. As the scattering increases the overall number
of rays significantly, there is a limitation of one scattering per ray. Furthermore, the surface
roughnesses of the corresponding materials need to be defined (in WallMan and / or ProMan).

For the scattering in the SRT model, tiles as defined in the dialog are considered. The scattered
contribution is weighted with the size of the scattering area (tile). Accordingly the resulting
scattered power from the whole object is for large distances independent of the tile size. For small
distances there is an impact due to the modified scattering angles which depend on the tile size.

Propagation Paths - Selection of Paths

This option allows the limitation of the number of paths per pixel with the following options:
maximum path loss of rays, maximum number of paths or dynamic range of paths.

Figure 543: The Selection of Rays dialog.

Tip:  The computation time of SBR can be reduced significantly by reducing the Max.
path loss of rays. Rays that encounter too much path loss will already be discarded
during the computation.

Note:  To accelerate the computation, SBR will estimate the path loss of a ray based
on empirical loss parameters. This way, rays which certainly are insignificant can be
rejected early. The final signal level of a ray will still be predicted using the user-
specified mode (based on Empirical Losses or on Fresnel Coefficients and GTD/UTD).

Propagation Paths - Direct Ray
The direct ray can be computed always, despite the number of transmissions specified in the first
section.

Computation of interaction losses of the rays

For the computation of the rays, not only the free space loss has to be considered but also the
loss due to the transmissions, reflections and (multiple) diffraction. This is either done using a
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physical deterministic model or using an empirical model similar to the method for the intelligent
ray-tracing (IRT). Optionally the interaction losses of the rays can be determined considering the
angle of incidence for the calculation of the transmission loss.

Path Loss Exponent for ray-optical models
Exponent for distance-dependent path loss.

Ray density

Since the SBR method starts by launching rays from the antenna, and, contrary to SRT, does not
guarantee that every possible path will be found, the ray density parameters are important.

The Max ray tube side width/height, i.e., the width and the height of the small outgoing wave
front of the ray tube, determines the minimum geometrical detail size that will affect the rays.
Ray tubes are split to ensure that any ray tube cross section at an intersection with an object will
not exceed the square of this value.

The Ray length to first split is the distance at which the splitting may commence. This length,
in combination with the maximum tube side width and height, determines the number of rays that
will be launched initially.

For instance, if this length is 1 m and the maximum tube width × height is 10×10 cm2, then 1257
rays will be launched to cover the 1-meter sphere with area 4π m2.

Transmier

Object

Figure 544: The concept of ray splitting to achieve proper ray density at interactions with objects.

In Figure 544, the orange rays are the original rays. An intersection algorithm determines
where interactions may occur. This algorithm ensures that any object larger than the minimum
geometrical detail size (see above) will be found, even if it might be between orange rays in the
figure. Geometry elements smaller than the maximum ray tube side width and height are not
ignored. You can still get interactions at those, but the algorithm cannot guarantee that those are
illuminated by at least a single ray.

At each interaction point the area of the ray cross section is computed. If this exceeds the user-
set maximum the ray segment is repeated with multiple, split rays, to ensure that the maximum
ray tube width and height are not exceeded at the interaction. The original ray (dotted in the
Figure 544) is discarded and replaced by the split rays (green rays in Figure 544). The directions
of the split rays are computed such that the ray cross sections cover the whole area of the original
ray tube’s front.
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Tip:  Ray length to first split is ideally set such that it is at least the distance
between the transmitter and the closest geometry (any geometry in the scenario, but
avoid choosing a distance close to zero if the transmitter is mounted on an object).

In a typical automotive-radar application, the ray length to first split may be between
one and ten meters, and the number of rays launched may be between 1E5 and 1E6.

If the distance is set too large, the ray density close to the transmitter becomes
unnecessarily high, and objects close to the transmitter, are hit by many more rays
than needed, which slows down the computation. The distance to first split will be
reduced automatically if needed to ensure that no more than 50 million rays be
launched from the transmitter.

Tip:  Max ray tube side width/height should always be smaller than the
discretization of the result pixels to reduce the chance that a result pixel will not
receive any rays.

The Gain adaptation determines to what extend a higher ray density will be used in directions
with higher antenna gain. Options are Off, Low, Medium, High.

Low
If the antenna gain for a direction is higher than MaxGain - 1 * 6dB the density will be
increased for that direction by a factor of 2 (side length).

Medium

If the antenna gain for a direction is higher than MaxGain - 2 * 6dB the density will be
increased for that direction by a factor of 2 (side length).

If the antenna gain for a direction is higher than MaxGain - 1 * 6dB the density will be
increased for that direction by a factor of 4 (side length).

High

If the antenna gain for a direction is higher than MaxGain - 3 * 6dB the density will be
increased for that direction by a factor of 2 (side length).

If the antenna gain for a direction is higher than MaxGain - 2 * 6dB the density will be
increased for that direction by a factor of 4 (side length).

If the antenna gain for a direction is higher than MaxGain - 1 * 6dB the density will be
increased for that direction by a factor of 8 (side length).

Scattered rays per impact determines how many new rays are spawned at each scattering
interaction. If the physics of the scattering predicts a lobe in a certain direction, then the density
of new rays in that lobe will automatically be higher than in other directions.

Diffracted rays per impact determines how many new rays are created at each diffraction
interaction.
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Indoor Intelligent Ray Tracing
The indoor intelligent ray-tracing method accelerates ray optical models and reduces the computation
time to that of empirical models. This method combines the advantages of both ray optical models and
neglects their disadvantages. It is based on a single preprocessing of the building data base.

Ray optical models are time consuming, because all possible rays must be determined. The model is
based on a single preprocessing of the building data base. All walls of the buildings are subdivided into
tiles and all wedges are subdivided into segments. The visibility relations between all tiles, segments
and receiving points in the data base are computed in the prepossessing, because they are independent
of the transmitter location.

Figure 545: Principle of ray optical models.

In a first step, the walls of the buildings will be divided into tiles and the edges into horizontal and
vertical segments, see Figure 546. After this discretization of the database the visibility relationships of
the different elements are determined and stored in a file. For this process all elements are represented
by their centers. This leads to a simplification of the problem of ray path finding (possible interaction
points are only the centers of the tiles and segments). The visibility relations between each tile
(segment) and all other tiles (segments) are computed in the pre-processing, because they are
independent of the transmitter and receiver locations.

For the decision about the visibility relation, the line of sight criterion between the centers of the tiles
(or segments) is evaluated. If there is line of sight between the centers, the rays from the center of the
first tile to the corners of the second tile are determined and the projection of the angles of the rays
on the first and second tile are stored together with the visibility relation. A similar computation for the
visibility relations between tiles and segments and between segments and other segments is done and
also stored in the file of the pre-processing.
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Figure 546: Subdivision of the building database into small elements.

The angles of the projection are important, because they define a range of possible reflection (or
diffraction) angles for the illuminated tile (or segment). The angle also continues on the neighboring
tile, so a very accurate prediction of the rays is possible even if the tiles or segments are large (up to
50 or 100 meters for urban data bases). A further improvement is possible if the grid of the prediction
points is also used in the pre-processing, because the prediction plane can be subdivided into tiles and
the visibility relations between the tiles of the prediction grid and the tiles (and segments) of the walls
represent the last part of the ray in the direction to the receiver.

If the receiver visibility relations are determined in the pre-processing, the only remaining visibility
relations to be computed in the prediction are the ones from the transmitter to the tiles (of walls and
prediction grid) and segments.

An example for the visibility relations between a tile and a receiving point is shown in Figure 546. For
the calculation of the angles the connecting straight lines between the receiving point and the four
edges of the tile are considered.

By projecting these four lines into the xy-plane and additionally into a plane perpendicular with respect
to the inspected wall, four angles are determined which give an adequate description of this visibility
relation.

Propagation Paths
This deterministic model allows an accurate rigorous 3D Ray Tracing prediction, because many
interactions can be taken into account. The selection of propagation paths is similar to the method for
the standard ray-tracing (SRT). Therefore each transmission through a wall, each reflection at a wall
and each diffraction at an edge counts as an interaction. Due to a pre-processing of the database the
IRT model has a short computation time.
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Figure 547: Determination of ray paths by searching in a tree structure.

The result of the pre-processing of the building data base is a tree structure containing tiles, segments
and receiving points of the prediction area, see Figure 547. In this tree every branch symbolizes a
visibility relationship between two elements. For the prediction only the tiles, segments and receiving
points, which are visible from the base station have to be determined. Additionally, the angles of
incidence for the visible tiles and segments have to be calculated. The relations in the first layer of the
tree must be computed in the prediction, all other relations are determined in the pre-processing and
can be read from a file.

The ray search is stopped, if a receiving point or a given maximum number of interactions is reached.
Finally the field strength is summed up at all potential receiving points.
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Settings

Figure 548: The Parameter: Intelligent Ray Tracing (IRT) dialog.

Propagation Paths - Number of Interactions

The Settings dialog allows to specify how many interactions should be considered for the
determination of ray paths between transmitter and receiver including maximum number of
reflections, diffractions and scattering.

Example: If Max Reflections AND Diffractions AND Scattering is 2 and if Max. Reflections
is 2 and Max. Diffractions is 2, the rays with a total of 2 interactions have either 2 reflections or
2 diffractions or one reflection and one diffraction. Rays with more than two interactions are not
considered in this case.

If Max Reflections AND Diffractions AND Scattering is 4, Max. Reflections is 2 and Max.
Diffractions is 2, we will compute the following rays

• 0 interaction: 0 R and 0 D

• 1 interaction: 1 R and 0 D (R), 0 R and 1 D (D)

• 2 interactions: 2 R and 0 D (R - R), 1 R and 1 D (R - D and D - R), 0 R and 2 D (D - D)

• 3 interactions: 3 R and 0 D (R - R - R), 2 R and 1 D (R - R - D and R - D - R and D - R - R), 1
R and 2 D (R - D - D and D - R - D and D - D - R), 0 R and 3 D (D - D - D)

• ...

• ...

The higher the value for Max Reflections AND Diffractions AND Scattering, the longer the
computation time.
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Diffuse scattering in indoor scenarios can play an important role, especially for determining
the actual temporal and angular dispersion of the radio channel. The IRT model for indoor
scenarios have been extended to consider the scattering on building walls and other objects. For
this purpose the scattering can be activated in the model settings (where also the number of
reflections and diffractions are defined). As the scattering increases the overall number of rays
significantly, there is a limitation of one scattering per ray.

Figure 549: Diffuse scattering.

Furthermore the surface roughness of the corresponding materials need to be defined (in WallMan
and ProMan). The scattered power depends on surface roughness and on direction, in accordance

with [36][37]. For the scattering in the IRT model the tiles as defined in the WallMan pre-processing are
considered. The scattered contribution is weighted with the size of the scattering area (tile). Accordingly
the resulting scattered power from the whole object is for large distances independent of the tile size.
For small distances there is an impact due to the modified scattering angles which depend on the tile
size

Propagation Paths - Selection of Paths

Limitation of number of paths per pixel with the following options

• maximum path loss of rays

• maximum number of paths

• dynamic range of paths

Consideration of Rays for Computation of Angular Spread and Mean

During computation of delay or angular spread and mean, the contribution of each
propagation path to the delay or angular spread/mean is considered. Each path contributes
a signal level to the spread. This level can be either considered as power (in dBm or Watt)
or as field strength (in dBµV/m or in µV/m). Power values include the gain of the Rx
antenna and depend on the frequency, whereas field strength values do not depend on the

36. Xiao Dong He, Kenneth E. Torrance, François X. Sillion, Donald P. Greenberg: "A Comprehensive
Physical Model for Light Reflection". SIGGRAPH’91 conference proceedings, 1991, Las Vegas, United
States. inria-00510144

37. G. Nassif, C. Gloaguen and P. Martins, "A Combined Stochastic and Physical Framework for
Modeling Indoor 5G Millimeter Wave Propagation," in IEEE Transactions on Antennas and
Propagation, vol. 70, no. 6, pp. 4712-4727, June 2022, doi: 10.1109/TAP.2022.3161286.
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frequency. The values can be considered either in logarithmic scale (dBm or dBµV/m) or in
linear scale (mW or µV/m).

Figure 550: Selection of rays dialog.

Propagation Paths - Direct ray
The direct ray can be computed always, despite the number of transmissions specified in the first
section.

Computation of Interaction Losses of the Rays
For the computation of the rays, not only the free space loss has to be considered but also the
loss due to the transmissions, reflections and (multiple) diffraction. This is either done using a
physical deterministic model or using an empirical model similar to the method for the standard
ray tracing (SRT).

Path Loss Exponent for Ray-Optical Models
Exponent for distance dependent path loss.

Superposition of Contributions
Superposition of contributions of different rays can be done either incoherent (without
consideration of the phases) or coherent (with consideration of the phases).

Note:  Parameters defined in the Settings dialog apply for both ray-tracing models
(for the standard ray-tracing model and the intelligent ray-tracing model).

3D Standard Ray Tracing
The standard ray-tracing model (SRT) performs a rigorous 3D ray-tracing prediction which results in a
very high accuracy, but it is computationally expensive.

Deterministic models are used to simulate the propagation of radio waves physically. Therefore, the
effect of the environment on the propagation parameters can be taken into account more accurately.
Another advantage is that deterministic models make it possible to predict several propagation
parameters. For example, the path loss, impulse response and angle-of-arrival can be predicted at the
same time.
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Figure 551: Principle of ray optical models

As smaller wavelengths (higher frequencies) are considered, the wave propagation becomes similar to
the propagation of light. Therefore a radio ray is assumed to propagate along a straight line influenced
only by refraction, reflection, diffraction or scattering which is the concept of geometrical optics (GO).
The criterion taken into account for this modeling approach is that the wavelength should be much
smaller in comparison to the extension of the considered obstacles, for example, the walls of a building.
At the frequencies used for mobile communication networks this criterion is also inside buildings
sufficiently fulfilled.

There are two different basic approaches for the determination of the ray paths between transmitter
and receiver in the geometrical optics technique:

1. ray-tracing

2. ray launching

The standard ray-tracing model (SRT) performs a rigorous 3D ray-tracing prediction which results
in high accuracy. Due to the determination of the individual paths, the computational effort is large.
Therefore several acceleration techniques both with and without loss of accuracy are developed and
integrated in this rigorous 3D approach.

This model has a long computation time, because only small parts of the prediction are preprocessed
and every propagation path is analytically determined. The initialization data is stored in an .idw file.
This file is created at the first prediction run. The computation time of subsequent predictions that are
based on the new .idw database is thus diminished. For this purpose, a new project based on the .idw
database has to be created.

Propagation Paths
Each transmission through a wall, each reflection at a wall and each diffraction at an edge counts as
an interaction. The computed propagation paths can be limited within the propagation model settings.
The value Max. defines the maximum number of interactions that are allowed for each propagation
path. The appropriate value depends on the building structure. If, for example, the building has a
corridor that runs around a corner three times, then it would be better to compute more interactions,
because multiple diffractions are needed to reach all prediction pixels. The same occurs if a building has
a structure where the rays have to pass many walls to reach every point of the building, because then
more transmissions are needed. The only constraint is that the computation time naturally increases if
more interactions are computed. On the other hand, if too less interactions are computed, the accuracy
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decreases. In this case additionally more prediction pixels might not be reached by the SRT prediction,
which leads to the need to compute those pixels with an empirical model which will decrease the
accuracy even more. As a basic rule, an appropriate setting for the maximum value would be 2 – 4,
depending on the building structure.

If the indoor database contains additional objects defining the ground, such as topography and clutter
objects, the interactions (reflection, diffraction) at those objects can be activated as well.

Note:  This option is only available if topography or clutter objects are included in the
database.

Computation of Each Ray's Contribution
For the computation of the rays, not only the free space loss has to be considered but also the loss
due to the transmissions, reflections and (multiple) diffraction. This is either done using a physical
deterministic model or using an empirical model.

Note:  This does only affect the determination of the transmission, reflection and diffraction
coefficients. The prediction itself always remains a deterministic one (the same rays are
taken into account).

The deterministic model uses Fresnel equations for the determination of the reflection and transmission
loss and the GTD / UTD for the determination of the diffraction loss. This model has a slightly longer
computation time and uses three physical material parameters (permittivity, permeability and
conductivity). When using GTD / UTD and Fresnel coefficients arbitrary linear polarizations (between
+90° and –90°) can be considered for the transmitters.

The empirical model uses five empirical material parameters (minimum loss of incident ray, maximum
loss of incident ray, loss of diffracted ray, reflection loss, transmission loss). For correction purposes or
for the adaptation to measurements, an offset to those material parameters can be specified. Here with
the empirical model has the advantage that the needed material properties are easier to obtain than the
physical parameters required for the deterministic model. Also the parameters of the empirical model
can more easily be calibrated with measurements. It is therefore easier to achieve a high accuracy with
the empirical model.

Note:  The computation mode for the signal level along the paths can be selected on the
Computation tab.

The effect of bookshelves and cupboards covering considerable parts of walls is taken into account
by including an additional loss of the wall's penetration (transmission) loss. An additional loss of 3
dB was observed to be appropriate. This additional loss is introduced in context of walls covered by
bookshelves, cupboards or other large pieces of furniture. Furthermore, it was found necessary to set
an empirical limit for the wall transmission loss which otherwise becomes very high when the angle of
incidence is large.

The following interaction types exist:
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Specular Reflection

The specular reflection phenomena is the mechanism by which a ray is reflected at an angle equal
to the incidence angle. The reflected wave fields are related to the incident wave fields through a
reflection coefficient which is a matrix when the full polarimetric description of the wave field is
taken into account.

The most common expression for the reflection is the Fresnel reflection coefficient which
is valid for an infinite boundary between two mediums, for example, air and concrete. The
Fresnel reflection coefficient depends on the incident wave field and upon the permittivity and
conductivity of each medium. The application of the Fresnel reflection coefficient formulas is very
popular and these equations are also applied in ProMan.

To calibrate the prediction model with measurements, some ray optical software tools consider an
empirical reflection coefficient varying with the incidence angle to simplify the calculations. Such
an empirical approach is also available in ProMan.

Diffraction

The diffraction process in ray theory is the propagation phenomena which explain the transition
from the lit region to the shadow regions behind the corner or over the rooftops. Diffraction by
a single wedge can be solved in various ways: empirical formulas, perfectly absorbing wedge,
geometrical theory of diffraction (GTD) or uniform theory of diffraction (UTD).

The advantages and disadvantages of using either one formulation is difficult to address since it
may not be independent on the environments under investigation. Indeed, reasonable results are
possible with each formulation. The various expressions differs mainly from the approximations
being made on the surface boundaries of the wedge considered. One major difficulty is to express
and use the proper boundaries in the derivation of the diffraction formulas. Another problem is
the existence of wedges in real environments: the complexity of a real building corner or of the
building’s roof illustrates the modeling difficulties.

Despite these difficulties, however, diffraction around a corner or over rooftop are commonly
modeled using the heuristic UTD formulas since they are well behaved in the lit/shadow transition
region, and account for the polarization as well as for the wedge material. Therefore these
formulas are also used in ProMan to calculate the diffraction coefficient.

Multiple Diffraction

For the case of multiple diffraction the complexity increases dramatically. One method frequently
applied to multiple diffraction problems is the UTD. The main problem with straightforward
applications of the UTD is, that in many cases one edge is in the transition zones of the previous
edges. Strictly speaking this forbids the application of ray techniques, but in the spirit of the UTD
the principle of local illumination of an edge should be valid. At least within some approximate
degrees, a solution can be obtained which is quite accurate in most cases of practical interest.

The key point in the theory is to include slope diffraction, which is usually neglected as a higher
order term in an asymptotic expansion, but in the transition zone diffraction the term is of
the same order as the ordinary amplitude diffraction terms. Additionally there is an empirical
diffraction model available which can easily be calibrated with measurements.
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Scattering

Rough surfaces and finite surfaces (surfaces with small extension in comparison to the
wavelength) scatter the incident energy in all directions with a radiation diagram that depends
on the roughness and size of the surface or volume. The dispersion of energy through scattering
means a decrease of the energy reflected in specular direction.

This simple view leads to account for the scattering process by only decreasing the reflection
coefficient. The reflection coefficient is decreased by multiplying it with a factor smaller than one
where this factor is exponentially dependent on the standard deviation of the surface roughness
according to the Rayleigh theory. This description does not take into account the true dispersion
of radio energy in various directions, but accounts for the reduction of energy in the specular
direction due to the diffuse components scattered in all other directions.

Penetration and absorption
Penetration loss due to building walls have been investigated and found to be dependent on
the particular system. Absorption due to trees or the body absorption are also propagation
mechanisms difficult to quantify with precision. Therefore in the radio network planning
process adequate margins should be considered to ensure overall coverage. Another absorption
mechanism is the one due to atmospheric effects. These effects are usually neglected in
propagation models for mobile communication applications at radio frequencies but are important
when higher frequencies (for example 60 GHz) are used.
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Figure 552: The Parameter: Standard Ray Tracing (SRT) dialog.

Propagation Paths and Interactions
The Propagation paths and interactions group allows to specify the number of interactions
that should be considered for the determination of ray paths between transmitter and receiver
including the maximum number of reflections, diffractions and scattering. To accelerate the
prediction, additional diffractions and transmissions can be ignored for all rays with more than
one reflection. The minimum length of wedges where diffractions can occur can be specified in
meters. In case the simulation database contains ground objects (topography in vector format),
interaction at those objects can optionally be considered. Diffuse scattering in indoor scenarios
can play an important role, especially for determining the actual temporal and angular dispersion
of the radio channel.

The WinProp SRT model was extended to consider the scattering on building walls and other
objects. For this purpose the scattering can be activated in the model settings by enabling the
option “Consider additionally rays with scattering”. As the scattering increases the overall number
of rays significantly, there is a limitation of one scattering per ray. Furthermore, the surface
roughnesses of the corresponding materials need to be defined (in WallMan and / or ProMan).
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For the scattering in the SRT model, tiles as defined in the dialog are considered. The scattered
contribution is weighted with the size of the scattering area (tile). Accordingly the resulting
scattered power from the whole object is for large distances independent of the tile size. For small
distances there is an impact due to the modified scattering angles which depend on the tile size.

Optionally, scattering at pixel and vector ground can be considered. As described under Project
Settings, a topography database can be included in an “ indoor” scenario. “Indoor” in WinProp has
grown to denote any scenario with more geometrical freedom than urban and rural scenarios. The
tile size for ground scattering can be chosen different from that on buildings.

The option Compute ground scattering loss based on the ground clutter coefficient
activates the constant-γ model for ground clutter, in which the ground’s radar cross section per
unit area σ0 is modeled as

(95)

where ψ is the grazing angle relative to the surface and γ is a parameter describing the scattering
property of the terrain surface.

For sea clutter, γ depends on Beaufort wind scale KB and radar wavelength:

(96)

The reflectivity of land clutter is much more difficult to characterize than that of the sea. The
constant-γ model is applied with values of γ for different terrain types as shown in Table 47.

Table 47: The reflectivity of land clutter.

Surface Description Mean Reflectivity
Coefficient γ [dB]

Mountains -5 Roughness ≥ 50 m.

Urban -5 Terrain type is building.

Wooded hills -10 10 m < Roughness < 50 m, and terrain type is
light or dark forest.

Rolling hills -12 10 m < Roughness < 50 m, and terrain type is
not light or dark forest.

Farmland, Desert -15 Roughness ≤ 10m, and small-scale average
roughness > 1.5 m.

Flatland -20 Roughness ≤ 10 m, and small-scale average
roughness between 0.5 m and 1.5 m.

Smooth surface -25 Roughness ≤ 10m, and small-scale average
roughness ≤ 0.5 m.
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WinProp will obtain the value of γ from the empirical reflection loss of the material, as defined
in the project or in the material catalogue. If you know the value of γ from measurements or
literature, use it when specifying the empirical loss of the particular ground material.

If the constant-γ model is not activated, then scattering at the ground will be calculated by the
same algorithm as scattering at building walls and other objects, using the specified surface
roughness and the frequency.

Propagation Paths - Selection of Paths
This option allows the limitation of the number of paths per pixel with the following options:
maximum path loss of rays, maximum number of paths or dynamic range of paths.

Figure 553: The Selection of Rays dialog.

Propagation Paths - Direct Ray
The direct ray can be computed always, despite the number of transmissions specified in the first
section.

Computation of interaction losses of the rays
For the computation of the rays, not only the free space loss has to be considered but also the
loss due to the transmissions, reflections and (multiple) diffraction. This is either done using a
physical deterministic model or using an empirical model similar to the method for the intelligent
ray-tracing (IRT). Optionally the interaction losses of the rays can be determined considering the
angle of incidence for the calculation of the transmission loss

Path Loss Exponent for ray-optical models
Exponent for distance-dependent path loss.

Superposition of contributions (different rays)
Superposition of contributions of different rays can be done either incoherent (without
consideration of the phases) or coherent (with consideration of the phases).

Special Features
Additional information can be displayed in the progress window during the simulation if desired.
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Note:  Parameters defined in the dialog apply for both ray-tracing models (for the
standard ray-tracing model and the intelligent ray-tracing model).

Leaky Feeder Cable Models
ProMan offers three different prediction models for leaky feeder cables.

As a radiating cable has gaps or slots in its outer sheath to allow signal to leak into or out of the cable
along its entire length, special prediction models have to be used to predict the wave propagation. The
transmission power along the cable decreases from the feeding point according to the losses defined on
the Cell Definition tab.

Shortest Distance Model (SDM)
The shortest distance model predicts the received power by always using the shortest geometric
distance between radiating cable and receiving point. The obstacles of the environment (walls) between
this cable point and the receiving point are taken into account in terms of different transmission losses
depending on the specified materials of the objects. Optionally, the angle of incidence can be considered
for the determination of the transmission loss as well.

The following figure shows a sample prediction of the power received from a radiating cable (blue line)
along a building corridor. The three exemplary drawn rays depict the propagation paths, which have
been considered for the selected receiving points.

Figure 554: Prediction of received power with shortest distance model (SDM).

Smallest Transmission Loss Model (STL)
Compared to the SDM, the smallest transmission loss model uses a discretization of the leaky feeder
cable, discrete “transmitting positions” along the cable. Starting from these discrete transmitting
locations, the direct propagation path covering the smallest overall transmission loss between radiating
cable and receiving point is taken into account. The discretization of the cable as well as the other
parameters of the model can be specified in the Parameter for Prediction of Radiating Cables
dialog shown below.
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The following figure shows a sample prediction of the power received from a radiating cable (blue line)
along a building corridor. The four exemplary drawn rays depict the propagation paths, which have been
considered for the selected receiving points.

Figure 555: Prediction of received power with smallest transmission loss model (STL).

Smallest Path Loss Model (SPL)
The smallest path loss model works in almost the same way as the smallest transmission loss model, it
uses a discretization of the leaky feeder cable. Starting from these discrete transmitting locations, the
direct propagation path covering the smallest overall path loss between radiating cable and receiving
point is taken into account. The discretization of the cable as well as the other parameters of the model
can be specified in the settings dialog shown below.

The following figure shows a sample prediction of the power received from a radiating cable (blue line)
along a building corridor. The four exemplary drawn rays depict the propagation paths, which have been
considered for the selected receiving points.

Figure 556: Prediction of received power with smallest path loss model (SPL).
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Parameters and Settings of the Models

Figure 557: The Parameter for Prediction of Radiating Cables dialog.

Note:  The selected angle dependency, as well as the path loss exponents apply for all leaky
feeder cable models.

Working with Indoor Projects
The different databases and how to use them is provided.

Indoor projects are based on indoor building databases which have to be modeled with WallMan.

In general, every database type can be used with any prediction model. For the empirical and semi-
empirical models (Multi-Wall, Motley-Keenan, Modified Free Space and Indoor Dominant Path), the .idb
database should be used.

The IRT model computes a sophisticated preprocessing before the prediction is computed. In this
preprocessing, all walls are divided into tiles and all edges are divided into segments. Then all visibility
relations between these elements are computed. This information is stored in a tree structure. This
means that a discretization of the ray path search is undertaken. For the prediction, the individual paths
do not have to be determined (like done in the SRT model). Instead, the path determination is reduced
to a search in the tree. This makes the computation much faster.

If you have created a project that is based on a preprocessed database (.idi), ProMan tries to use the
.idi database at first if you have selected the IRT model.

But with this preprocessed database you can choose also all other available propagation models.

Simulation Settings
The simulation can be configured by specifying the area of planning, the resolution of prediction results,
prediction height and whether additional prediction planes are defined in the database.

Click Project > Edit Project Parameter to open the Edit Project Parameter dialog. The simulation
settings are available on the Simulation tab.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.573

Area of Planning / Simulation

Figure 558: The Area of Planning / Simulation group on the Edit Project Parameter dialog , Simulation tab.

Prediction (simulation area)

Individual for each transmitter
The simulation area can be defined as a superposition of individual prediction areas defined
separately for each transmitter/cell. These individual prediction areas can be defined on the
Transmitter definition tab of the corresponding transmitter.

Identical for all transmitters

Rectangular area (Horizontal planes)
The rectangular simulation area can be specified by defining the lower-left and upper-

right corner coordinates. Another option is to use the  Prediction Rectangle

(Rectangle) icon on the Project toolbar, which allows you to draw a rectangle with
the mouse.

Multiple Points (Arbitrary Heights)

Specify the individual prediction or receiver points. The points can be added, deleted,
edited, imported or exported from or to a .txt file. The prediction points can be
moved by specifying a translation vector.
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Figure 559: The Prediction Point dialog.

Multiple Trajectories

Specify a prediction trajectory / receiver trajectory. A trajectory can be added,
deleted, edited, imported or exported from or to a .txt file. For each trajectory,

specify the name, x (Longitude), y (Latitude), z (Height), Velocity, Yaw[38],

Pitch[39] and Roll[40].

Figure 560: The Trajectory dialog.

Another option to specify a trajectory is to use the  Prediction Trajectories icon

on the Project toolbar, which allows you to specify the points for the trajectory using
the mouse.

38. Yaw is the rotation around the vertical axis.

39. Pitch is the rotation around the side-to-side axis.

40. Roll is the rotation around the front-to-back axis.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.575

Resolution of prediction results
The resolution grid of the result matrix can be changed only if the database was not preprocessed
in area mode.

Prediction Height

The height of horizontal prediction planes can be defined relative to the ground level, absolute to
sea level or relative to defined floor levels.

For prediction heights relative to ground, the height of interest is location-dependent. A typical
example is where a person is walking in a hilly area with a cell phone.

For prediction heights absolute to sea level, the height of interest is fixed and does not follow the
terrain. A typical example is where an aircraft flies at 1500 m.

For multi-floor buildings it is possible to define multiple heights for the coverage prediction
(and also network planning). In case of a high number of floors it is not required to predict the
coverage of every transmitter in each floor.

For example, a transmitter in ground floor has no influence on the coverage and interference in
the highest floor. To speed up the simulation in case of multi floor buildings it is now possible to
define a height range (for example, 3m), so that the coverage of a transmitter is only predicted
for prediction heights within the defined range (difference between z-coordinate of transmitter
and prediction height are within this range).

Tip:  Specify multiple prediction heights by entering space-separated values.

For example: 0.5 1.5 2.5

Trajectory sampling

The height of a prediction trajectory can be defined relative to the ground level or absolute to
sea level.

For a prediction trajectory relative to ground, the height of interest is location-dependent. A
typical example is where a person is walking in a hilly area with a cell phone.

For prediction heights absolute to sea level, the height of interest is fixed and does not follow the
terrain. A typical example is where an aircraft flies at 1500 m.

Additional Prediction Planes

ProMan also offers the possibility to do predictions on arbitrary user-defined prediction planes and
on the surfaces of walls. Under Additional Prediction Planes, select the Prediction Planes
defined in database check box and/or Surfaces of Walls check box.
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Note:  These options are only available, if the database of the current project supports
this features (if this features are modeled / enabled in the database). Predictions on
arbitrary predictions planes are possible using a ray-tracing model (SRT or IRT) or one
of the empirical indoor wave propagation models.

Figure 561: An example of predictions along building surfaces in an indoor scenario.

Settings related to radio network planning simulations are only available for network projects. Some of
the general simulation parameters depend on the selected air interface.

Reduce Computation Time for Large Databases
For large databases, computation time can be reduced by defining database areas where ray
interactions are tracked.

In case of very large databases, the rectangular prediction area may well be (much) smaller than the
total area in the database. This means that results is only computed for pixels in that limited area.

Figure 562: Example of a prediction area that is small relative to the database.

Even then, depending on the simulation method, simulation times can be long because the tool still
investigates how interactions of rays with all buildings (including those far away) affect the results in
the prediction area. To reduce the simulation time further, you can define a polygon that describes
which database area is to be included in the tracking of the ray interactions.

Create the polygons by clicking Project > Database Area: Draw/Erase or use the  icon.
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An example of such a database area around the prediction area is shown in Figure 563. Buildings
(or any vector objects) that are completely outside the database area, are ignored. Buildings (vector
objects) that are completely or partly inside are included. For indoor and urban scenarios, the database
area does not have to be larger than the prediction area; you have considerable freedom to exclude
buildings.

Figure 563: The database area is indicated by the blue polygon. Ray tracking is limited to inside the polygon.

Since the database area applies to vector objects, it is available in indoor and urban scenarios, including
scenarios with vector topography (ground described by triangles, for example, via a file with .tdv
extension). It is not available in rural scenarios based on pixel databases (files with .tdb extension).

As for time-variant scenarios, any database area is active for all time steps but the polygons (the
geometry selection) can only be drawn with the first time step and this selection is the same for all the
time steps.

In case of multiple transmitters, you may want to define multiple database areas and assign them to

transmitters. Once a new polygon is drawn using the  icon, the Cells dialog is displayed containing a

list of all the cells. Select a cell to assign the polygon to the desired transmitter.

Figure 564: The Cells dialog.

To manage all the database areas open the Database Polygons dialog. Click Project > Edit project
Parameter. Select the Database tab and under Database Polygons, select the Consider database
polygons check box and click Settings to launch the Database Polygons dialog..
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Figure 565: The Database Polygons dialog.

From the Database Polygons dialog, you can:

• Add a new polygon.

• Delete an existing polygon.

• Add a new point to a polygon. The position of the point can be specified by selecting one of the
existing points (the position will be next the selected point), if no position was specified the point
will be added to the end of the points list.

• Edit an existing point.

• Delete an existing point.

◦ When adding, editing, or deleting a point, some checks are performed if the polygon is still
valid (does not intersect itself and it has at least three points).

• Modify the assigned transmitters to this polygon.

In the computation:

• If a cell does not have a polygon, the whole database is considered as usual.

• If a cell has one or more polygons, the objects that are inside any one of the polygons are
considered while the remaining objects are ignored.

In case of vector topography, the selection of database area also applies to the triangles that represent
the ground. In that case, it is important to choose the database area large enough to include the entire
prediction area, otherwise the topo height at some prediction pixels is no longer properly defined.

If you have multiple transmitters and a modest prediction area between them, defining database areas
(see Figure 566) can be efficient. The prediction area (the red rectangle where results is computed) is
part of all database areas, and each individual database area also includes the buildings between the
transmitter and the prediction area.

In order to distinguish between different object types in the 2D and 3D views:

• The objects, which are ignored by all transmitters, are considered as virtual objects and are
represented in blue.
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• The objects, which are considered by all the transmitters, are represented by its default color.

• The objects, which are considered by one ore more transmitters and ignored by other transmitters,
are considered as partially virtual and are represented in light blue.

Figure 566: An example showing multiple defined database areas.

Traffic Settings
View the different approaches for modeling cell loads.

Cell Load Defined by User
If the traffic is defined independent of the location, a traffic map is not required because it is assumed
that the traffic is homogeneously distributed over the complete prediction area.
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Figure 567: Indoor settings Traffic tab.

The cell load used for interference calculations can be specified in terms of the assumed mean transmit
power in downlink in percent of the maximum available transmit power of the cell.

Note:  This value is related to the power assigned for data transmission, only. The power
specified for the pilot signals is not influenced. In case of OFDM air interface the cell load can
either influence tx power in downlink or the number of used subcarriers, depending on the
settings.

For interference computation in uplink, an assumed mean noise rise, caused by active mobile stations,
can be specified.

The default values for cell load, noise rise and power back off can be defined in the upper section of
the Property page. In the lower part all transmitters of the current project are listed and the settings
for each transmitter are displayed in the table. The text default indicates that a default values defined
in the upper section of the dialog is used for the corresponding transmitter. If individual settings for
a transmitter shall be defined the transmitter has to be selected in the table and the check- and edit
boxes at the bottom of the dialog can be used to define individual values for cell load, noise rise and
power back off.

Location Dependent Traffic Definitions
For the definition of location dependent traffic, a traffic map is necessary.
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Figure 568: Indoor settings, Traffic tab.

Applications
Location dependent traffic requires the specification of at least one application. Reasonable
applications are for example Voice Calls, Video Calls and WWW Downloads.

Figure 569: The Edit Application dialog.

Name
Description of application.

Position
Priority of the application during cell assignment. 0 means highest priority.

Color
Color of mobile stations generated for this application in display.
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Traffic mode
Either arrival rate in 1/sec/m² and hold time in sec or traffic in Erlang/m² can be defined.

Activity (in %)
Activity of users using this application (occupation of network resources over time).

Transmission modes
At least one transmission mode must be assigned to each application. If an application is selected
with the mouse, the assigned transmission modes are displayed in the upper-right part of the
property page. If another application is selected by the user, the display of the transmission
modes is refreshed automatically. Transmission modes can be added or removed with the
corresponding buttons. The parameter Position specifies again the priority (0 means highest
priority) with which the transmission mode is considered during cell assignment.

Clutter classes
Clutter classes contained in the database of the project which are assigned to the selected
application. At least one clutter class is required to generate traffic for the defined application.
If another application is selected by the user, the display of the clutter classes is refreshed
automatically. Clutter classes can be added or removed with the buttons in the lower-left section.

Traffic definition
When a clutter class is selected with the mouse the traffic values are displayed in the lower-
right area. The user can modify the values and thus assign them to the selected clutter class.
Depending on the traffic mode specified for the current application either two values (arrival rate
in 1/sec/m² and hold time in sec) or one value (traffic in Erlang/m²) must be defined. The unit for
the area definition (either m² or km²) can be modified with the drop down box at the top of the
dialog.
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Project Settings

Figure 570: The Edit Project Parameter dialog, Database tab.

Object database
File path and name of the building vector database of the project are displayed for information.
Material properties of the objects contained in the database can be changed by clicking the Edit
Materials button.

Material properties
Material properties of the walls are taken into account by most of the prediction models
when the prediction is computed. If the individual properties are not defined in the database
or if you do not want to use the defined material properties, default values can be used by
choosing the option Default values. In this case, all materials defined in the database will
have the same electrical properties.
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Figure 571: The Change default values for Material Properties dialog.

Note:  Parameters, which actually impact the wave propagation prediction,
depend on the selected propagation model and further propagation parameters.

Ray optical propagation models, such as standard ray-tracing (SRT) and intelligent ray-
tracing (IRT) use the appropriate material parameters listed in the dialog for Fresnel
coefficients and GTD / UTD or the empirical transmission, reflection and diffraction model,
depending on the computation mode of signal level.

Semi-deterministic and empirical prediction models only use parameters for Fresnel
coefficients or the values for the transmission loss, respectively, depending on the
computation mode of signal level.

Topography database
Terrain elevation data can be considered additionally. The corresponding database file can be
selected via the Change button. After that, the heights of the buildings contained in the vector
database have to be specified to be either relative to the ground level (terrain elevation data) or
absolute to sea level.

Note:  This option is not available if a pre-processed database is used.

Via the Ground Mat. button, the properties of the ground material can be specified.
These properties are considered when interacting with the topography in ray optical
propagation models.

Subdivisions
Subdivisions, such as doors and windows are always considered.

Furniture
Furniture objects can be considered optionally if contained in the database.
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Monostatic radar cross-section (RCS)

For simulations with SRT, car models with thousands of polygons can be replaced by monostatic
RCS as computed in Altair Feko to accelerate virtual-drive tests. For more information, see Import
Radar Cross-Section from Feko.

Multiple definition of (identical) objects
CAD planes of buildings often contain outline representations of walls, a single wall is represented
with two lines. This leads to the creation of two individual walls during the conversion into
the WinProp format. Transmissions, reflections and diffractions are considered for both walls
individually during the simulation, which is not correct in such a case. By selecting the option
Correction of multiple (identical) definition of objects, ProMan combines these parallel walls
and handles them as identical during the predictions. The maximum distance between walls to be
considered as identical can be specified.

Database polygons
To manage the database areas, select the Consider database polygons check box. For more
information refer to Reduce Computation Time for Large Databases.

Computation Settings

Note:  Multipath propagation results are only available with:

• intelligent ray-tracing model

• standard ray-tracing model
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Figure 572: Computation tab of Project settings dialog.

Prediction Model
Different models can be selected depending on the type of transmitter. Special models, which are
used for the prediction of leaky feeder cables only, can be selected at the bottom of the dialog
depicted above. The settings of the models can be changed by using the Settings button.

Computation Mode of Signal Level

The deterministic mode uses Fresnel equations for the determination of the reflection and
transmission loss and the GTD / UTD for the determination of the diffraction loss. This model
has a slightly longer computation time and uses four physical material parameters (thickness,
permittivity, permeability and conductivity). When using GTD / UTD and Fresnel coefficients
arbitrary linear polarizations (between +90° and –90°) can be considered for the transmitters.

The empirical mode uses five empirical material parameters (minimum loss of incident ray,
maximum loss of incident ray, loss of diffracted ray, reflection loss, transmission loss). For
correction purposes or for the adaptation to measurements, an offset to those material
parameters can be specified. Herewith the empirical model has the advantage that the
needed material properties are easier to obtain than the physical parameters required for
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the deterministic model. Also the parameters of the empirical model can be calibrated with
measurements more easily. It is therefore easier to achieve a high accuracy with the empirical
model.

Besides the angles of the given propagation path, the diffraction loss also depends on the
relationship between the wedge direction and the polarization direction. According to physics
and verified by measurements there is an additional loss of about 5 dB if both directions are
parallel (for example diffraction on vertical wedge for vertically polarized signal). While this effect
is automatically considered if using the GTD / UTD model, an offset is available for the empirical
diffraction model. This additional loss is added to the diffraction loss in case the wedge direction
and the polarization direction are parallel. In case the wedge direction and the polarization
direction are orthogonal no additional loss is considered. In between there is a linear scaling of
this additional loss.

Note:  The computation mode for the signal level along the propagation path applies
for all propagation models.

Calibration of Indoor Propagation Models

WinProp allows the automatic calibration of nearly all available propagation models based on
measurement data. Additionally some propagation models support the calibration of material properties
and of clutter / land usage databases. The following table shows an overview of the models and the
features:

Table 48: Overview of propagation models and features.

Scenario Model Material calibration Clutter calibration

One slope model no not applicable

Motley Keenan model no not applicable

COST 231 model yes not applicable

Dominant path model no not applicable

Standard ray-tracing yes not applicable

Indoor

Intelligent ray-tracing yes not applicable

Knife edge model no not applicable

Dominant path model no not applicable

Urban

Intelligent ray-tracing no not applicable

Rural Empirical two way model n/a yes
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Scenario Model Material calibration Clutter calibration

Deterministic two ray
model

n/a yes

Dominant path model n/a no

The following flow diagram shows the procedure for the calibration of the propagation models:

Figure 573: Flow diagram illustrating the procedure for calibration of propagation models.

During the prediction, calibration files are written to the hard disk. The calibration is done afterwards
based on the calibration files (.cal).

Generation of WinProp Measurement Files
Measurement files in WinProp file format (.fpp, .fpl, .fpf) have to be created prior to the calibration.
This means the raw measurement data has to be imported from simple ASCII files into the WinProp
software. See Import Prediction Data for more information.

Assignment of Measurement Files to Transmitters
To retrieve a calibration file (.cal) after the prediction, a measurement file has to be assigned to the
transmitter. Only one measurement route can be assigned per transmitter.
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Figure 574: Assigning a measurement file to a transmitter.

The Measurements button is used to assign a measurement file (.fpp, .fpl, .fpf files are supported)
to the selected transmitter. The measurement file must contain measured data from the selected
transmitter only. Superposed measurement data from several transmitters is not supported. When the
measurement data is in path loss format (.fpl) cable loss must not be included. In contrast to this,
cable loss is expected as “included” when measurement data is available in field strength or power file
format. Antenna gain is always expected as “included”.

Computation of Propagation Prediction
After the assignment of the measurement files to the transmitters is completed, the wave propagation
prediction can be launched as usual. The propagation paths output needs to be activated, otherwise no
.cal files will be generated.

For each transmitter (with measurement data assigned) a calibration file (.cal) is written to the hard
disk. If the files are missing, click the Prediction tab, under Additional Prediction Data... and select
the Propagation Paths check box.

Calibration Computation
The calibration tool can be started from the Computation menu (Computation > Auto Calibration
(Models & Materials)). The calibration files generated during the wave propagation prediction have to
be added to the list.
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Figure 575: The Calibration dialog.

Files can be added by clicking Add files. They can be deleted by clicking on Remove file.

The settings can be adapted to your needs by clicking General settings. This allows you to influence
the selection of the measurement points, for example, only points in a given power (dBm), path loss
(dB) or distance (m) range will be considered.

Figure 576: The Settings dialog.

Additionally the type of optimization method can be selected:
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• Minimum mean error: The goal of the optimization is to achieve a minimum mean error (nearest to
zero). The standard deviation is not considered and as a result might be larger.

• Minimum mean squared error: The goal of the optimization is to achieve a minimum mean squared
error. The standard deviation is not considered and as a result might be larger.

• Minimum standard deviation: The goal of the optimization is to achieve a minimum standard
deviation. The mean error is not considered and as a result might be larger.

• Minimum weighted error: The goal of the optimization is to find the best combination of minimum
mean error and minimum standard deviation. The weighting between mean error and standard
deviation can be modified.

The range of the model parameters can be defined in the Model settings tab. As larger the range is, as
longer the calibration will take. The model parameters depend on the selected propagation model (each
model offers individual model parameters).

Depending on the propagation model the material database or the clutter/land usage database can be
calibrated additionally.

After clicking on Start, the calibration begins and the progress is shown with a progress bar. In some
cases the calibration process does take up to 1 hour.

Calibration Result
After a calibration has finished the results are displayed in a table. Depending on the propagation model
different parameters are listed in the table.

Figure 577: The Results for Intelligent Ray Tracing Urban dialog.

The model parameters listed in the table can now be transferred manually into the project settings
of ProMan and the project can be recomputed to achieve better results based on the new model
parameters. By clicking on Apply, the material properties (as far as they have been calibrated) are
applied to the vector / material database.
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The message box shown above gives also information about mean value and standard deviation from
measurements to predictions before and after the calibration. Depending on the optimization method
different results can be obtained.

Calibration of Materials
Some propagation models allow the calibration of the material database in addition to the calibration of
the propagation model. Therefore the calibration must be enabled for the material properties for which
a calibration should be done.

Enable Calibration of Materials
The following figure shows the properties of a material. This dialog is available in WallMan or in the
ProMan Calibration tool.

Figure 578: The Material Properties dialog.

The check box Allow calibration of material must be enabled in order to calibrate this material later
(standard configuration is “enabled”). In the frequency depending properties dialog (which can be
reached by clicking on Edit) the minimum and maximum values for the parameters can be defined.

The definition of the minimum and maximum values is shown in the image below.
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Figure 579: The Frequency Dependent Material Properties dialog.

For each property the value and the range is defined. The Min (%) and Max (%) values are given in
percent. If the value is 6 dB and the minimum and maximum values are 75% and 125%, the absolute
minimum and maximum values will be 4.5 dB and 7.5 dB. The Calibration approach can be selected
from the drop-down list (standard selection is “medium”).

Note:  The more sophisticated the calibration approach is, the longer the calibration takes.

Activate Calibration of Materials
Materials will be calibrated if the current prediction model supports material calibration and if the check
box is selected.
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Figure 580: The Calibration dialog.

Time-Variant

Wireless communication in time-variant ad hoc networks is very challenging. The increasing demand for
mobile multimedia and safety applications in time-variant environments requires new concepts for the
development of such wireless systems.

Time-variant scenarios can be found in several environments:

• Vehicle-to-vehicle or vehicle-to-infrastructure communication used for driving assistance systems

• Driver assistance systems such as adaptive cruise control (ACC)

• MESH and sensor networks in time-variant scenarios

• Wi-Fi hotspots in railroad stations, airports or city centers

• Stations and underground stations with moving trains

• Airports with moving airplanes

• Elevators inside buildings

The main difference in such applications compared to the classical network planning is the time variance
of these scenarios. The locations of transmitters, receivers, and/or obstacles are time-variant. These
effects influence the propagation and lead to time-variant channel impulse responses.

The workflow for time-variant simulations with moving geometrical objects is different from the
workflow in which transmitters or receivers move in time but all geometrical objects in the database
remain stationary. In the first case, the movement of objects has to be specified in WallMan. In the
other case, antenna patterns can be specified to move along trajectories in ProMan without the need to
specify any time-dependent behavior in WallMan. Table 49 provides an overview.
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Table 49: Workflows involving time variance.

Intended Scenario in ProMan Preparation in WallMan Key step in ProMan

Indoor Convert external indoor database
or create/edit indoor database

Urban Convert external urban database
or create/edit urban database

Rural/suburban Optionally, convert external
topography database

Tunnel Optionally add objects to a
.idb file created in TuMan

Specify that a transmitting
antenna will move along a
trajectory and/or specify that a
prediction point will move along
a trajectory.

Time-variant with moving objects Convert external indoor database
or create/edit indoor database.

Specify movement of groups of
objects.

Specify that a transmitting
antenna will move with a moving
object group, and/or specify that
a prediction point will move with
a moving object group.

Time-variant with moving objects
defined via external control
software

Convert external indoor database
or create/edit indoor database.
Define groups of objects. (*)

Note:  (*) To define the time-variant movement of a group of objects via external control
software, the .nip file can be edited.

Lines like the following example can be inserted at the end of the Database block in the .nip file.

***** Dynamic postion [object number, time,x,y,z,az,tilt,roll,velocity,direction] per
 time step ******
GROUP_POSITION_TIME_VARIANT 1 0.000000, 0.000000, 0.000000, 0.000000, 0.00, 0.00,
 0.00, 2.000, 1.000000, 0.000000, 0.000000
GROUP_POSITION_TIME_VARIANT 1 1.000000, 2.000000, 0.000000, 0.000000, 0.00, 0.00,
 0.00, 2.000, 1.000000, 0.000000, 0.000000
GROUP_POSITION_TIME_VARIANT 1 2.000000, 4.000000, 0.000000, 0.000000, 0.00, 0.00,
 0.00, 2.000, 1.000000, 0.000000, 0.000000
GROUP_POSITION_TIME_VARIANT 1 3.000000, 6.000000, 0.000000, 0.000000, 0.00, 0.00,
 0.00, 2.000, 1.000000, 0.000000, 0.000000
GROUP_POSITION_TIME_VARIANT 1 4.000000, 8.000000, 0.000000, 0.000000, 0.00, 0.00,
 0.00, 2.000, 1.000000, 0.000000, 0.000000
GROUP_POSITION_TIME_VARIANT 1 5.000000, 10.000000, 0.000000, 0.000000, 0.00, 0.00,
 0.00, 2.000, 1.000000, 0.000000, 0.000000
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Working with Time-Variant Projects
Time-variant projects are based on time-variant vector databases or are based on regular (stationary)
databases in which trajectories are defined in ProMan.

Time-variant databases are created by defining dynamic behavior for groups of objects in ordinary 3D
indoor vector databases which can be generated with the WallMan tool or which can be imported from
various CAD file formats.

Figure 581: Example of a time-variant database in WallMan.

Trajectories
A transmitter can move along a defined trajectory (optional), without the need to connect it to a moving
object.

If an antenna will be tied to a moving object in the time-variant geometry database, then no trajectory
will be needed to describe the movement of that antenna. If a transmitting antenna will be moving
without being tied to such an object, then a trajectory will need to be defined. Define a trajectory using

the  icon in the project toolbar.

Left-click once for each vertex in (X,Y); right-click after specifying the last vertex. Then either define
the next trajectory or toggle the icon off to leave the trajectory-definition mode. Z coordinates, speed,
yaw, pitch and roll can be defined later when an antenna is tied to a trajectory.
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It is also possible to define a trajectory by editing the .net project file with a text editor. The format is
shown in the following lines:

** Dynamic antenna [time,x,y,z,az,tilt,roll,velocity,direction] per time step *
 ANTENNA 1 POSITION_TIME_VARIANT 0.000, 508276.420, 5393273.950, 30.000, 0.00, 0.00,
 0.00, 10.000, 1.000, 0.000, 0.000
 ANTENNA 1 POSITION_TIME_VARIANT 1.000, 508376.420, 5393273.950, 30.000, 45.00, 0.00,
 0.00, 10.000, 1.000, 0.000, 0.000
 ANTENNA 1 POSITION_TIME_VARIANT 2.000, 508476.420, 5393273.950, 30.000, 90.00, 0.00,
 0.00, 10.000, 1.000, 0.000, 0.000

Simulation Settings
The simulation can be configured by specifying the area of planning, the resolution of prediction results,
prediction height and whether additional prediction planes are defined in the database.

Click Project > Edit Project Parameter to open the Edit Project Parameter dialog. The simulation
settings are available on the Simulation tab.

Area of Planning / Simulation

Figure 582: The Area of Planning / Simulation group on the Edit Project Parameter dialog , Simulation tab.

Prediction (simulation area)

Individual for each transmitter
The simulation area can be defined as a superposition of individual prediction areas defined
separately for each transmitter/cell. These individual prediction areas can be defined on the
Transmitter definition tab of the corresponding transmitter.

Identical for all transmitters

Rectangular area (Horizontal planes)
The rectangular simulation area can be specified by defining the lower-left and upper-

right corner coordinates. Another option is to use the  Prediction Rectangle
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(Rectangle) icon on the Project toolbar, which allows you to draw a rectangle with
the mouse.

Multiple Points (Arbitrary Heights)

Specify the individual prediction or receiver points. The points can be added, deleted,
edited, imported or exported from or to a .txt file. The prediction points can be
moved by specifying a translation vector.

Figure 583: The Prediction Point dialog.

To move a prediction point with a moving object group or along a trajectory, select the
Time variant location (non-stationary) check box.

Multiple Trajectories
Trajectories can be selected and edited. A trajectory selected at this stage is called a prediction
trajectory and will be colored red. Although a receiving antenna pattern with appropriate
orientation will be considered at every point of the trajectory, a receiving antenna will not move
as a function of time along such a trajectory. Instead, received power along the entire trajectory
will be computed at every time step. The combination of time-variant scenarios and prediction
trajectories is a rare use case. Constant prediction areas and moving prediction points are more
common in combination with time-variance.

Resolution of prediction results
The resolution grid of the result matrix can be changed only if the database was not preprocessed
in area mode.

Prediction Height

The height of horizontal prediction planes can be defined relative to the ground level, absolute to
sea level or relative to defined floor levels.

For prediction heights relative to ground, the height of interest is location-dependent. A typical
example is where a person is walking in a hilly area with a cell phone.
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For prediction heights absolute to sea level, the height of interest is fixed and does not follow the
terrain. A typical example is where an aircraft flies at 1500 m.

Settings related to radio network planning simulations are only available for network projects. Some of
the general simulation parameters depend on the selected air interface.

Simulation Parameters
Specify the time steps in a time variant simulation.

Figure 584: Specification of the time step in the simulation
on the Edit Project Parameter dialog - Simulation tab.

Antenna Settings
ProMan allows also the assignment of time-variant behavior to an antenna. The antenna moves in the
same way as the object group does to which the antenna is assigned, or moves as specified along the
trajectory to which it is assigned. The trajectory can be edited at this stage.

The assignment of the antenna to a certain group or trajectory can be made in the cell dialog.
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Figure 585: Setting the location of the antenna as time-variant in the Cell dialog.

Note:  Time-variant settings are available if the time-variant simulation is enabled on the
Edit Project Parameter dialog (Simulation tab).

Visualization of Results
ProMan allows the visualization of the results for different time stamps.

Note:  Figure 586 shows the time stamps and prediction heights from the drop-down list.

Time-variant prediction results (field strength, power, path loss) can be opened with the tree view on
the left side of the ProMan main window.
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Figure 586: Example of time-variant prediction results.

Import Radar Cross-Section from Feko
Ray-optical simulations in WinProp can be accelerated if selected objects are replaced by scattering
information that was imported from Feko.

In simulations of automotive radar systems, one can include the shapes of all objects accurately in
WinProp and use standard ray tracing model (SRT) in the analysis.

Figure 587: An example of automotive radar systems.

A disadvantage is that many objects (many surface panels) may be needed to approximate an object
(for example, a car) accurately enough. This can make the simulations time-consuming.

An alternative approach is to perform radar cross-section (RCS) simulations in Feko and use the
results of such simulations in WinProp. An object in WinProp can then be simple; it can even be just
a box. Whenever a ray hits the simple model, the RCS information from Feko is used to calculate
the monostatic reflection. ProMan automatically corrects the (far-field) RCS to account for the finite
distance, since in the near field, the wave fronts are not planar anymore.

To produce the necessary file with RCS information in a Feko simulation, set up a monostatic RCS
simulation in Feko with an angular sweep of incident plane waves. Request far fields in Feko; select the
option Calculate fields in plane wave incidence direction to obtain the monostatic RCS. On the
Advanced tab of the far field request, select output to an ASCII file. The Feko solver will write a .ffe
file to disk.
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Figure 588: An example of monostatic RCS results in Feko.

The monostatic RCS from Feko can be assigned to a (moving) object group in a (time-variant) ProMan
project, under Monostatic radar cross-section (RCS), see Figure 589.

Figure 589: The Edit Project Parameter dialog, Database tab.

The origin of the RCS information is placed by default in the center of the bounding box of the group of
objects to which it is assigned. In this context, a group is usually the collection of faces that together
form one moving object such as a car. Such groups are defined in WallMan when creating the time-
variant scenario.
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Figure 590: The Add a new RCS dialog.

The location of the origin can be adjusted depending on the actual scenario of interest. In particular, it
is often convenient to adjust the Z-coordinate of the RCS origin depending on the height of the radar
system in the WinProp simulation.

The theta and phi angles from the Feko simulation are used in ProMan as follows:

• Theta is the angle with the Z-axis, for example, the vertical axis.

• Phi is the angle from the East in a counter-clockwise direction.

If East is considered the X-axis, then this means that the spherical coordinates in Feko and WinProp are
identical.

The azimuth angle can be adjusted in case the object, for example, the car, does not have the same
orientation in the Feko and WinProp simulations.

An averaging filter is provided because the RCS results from Feko, at high frequencies, can vary by
many dB within a couple of degrees. In the real world, where the radar system and other objects
move in a complicated scenario, small and high reflections can alternate rapidly. Also, due to finite
distances, deep nulls in the far-field RCS will be filled in. Therefore, the application of an averaging filter
is appropriate to obtain more realistic results.

6.2.3 Calibration of Models
WinProp allows the automatic calibration of nearly all available propagation models based on
measurement data.

Calibration of Propagation Models
WinProp allows the automatic calibration of nearly all available propagation models based on
measurement data. Additionally some propagation models support the calibration of material properties
and of clutter/land usage databases. The following table shows an overview of the models and the
features.
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Table 50: Overview of propagation models and features

Scenario Model Material calibration Clutter calibration

One slope model no not applicable

Motley-Keenan model no not applicable

COST 231 model yes not applicable

Dominant path model no not applicable

Standard ray-tracing yes not applicable

Indoor

Intelligent ray-tracing yes not applicable

Knife edge model no not applicable

Dominant path model no not applicable

Urban

Intelligent ray-tracing no not applicable

Empirical two ray model not applicable yes

Deterministic two-ray
model

not applicable yes

Rural

Dominant path model not applicable no

The following picture shows the procedure for the calibration of the propagation models:

Figure 591: Procedure for calibration of propagation models.

As shown in the picture, during the prediction calibration files are written to the hard disk. The
calibration is done afterwards based on the calibration files (.cal). The steps for the calibration are
explained in the following sections.
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Generation of WinProp Measurement Files
Measurement files in WinProp file format (.fpp, .fpl, .fpf) have to be created prior to the calibration.
This means the raw measurement data has to be imported from simple ASCII files into the WinProp
software. See Import Prediction Data for more information.

Assignment of Measurement Files to Transmitters
to retrieve a calibration file (.cal) after the prediction, a measurement file has to be assigned to the
corresponding transmitter. Only one measurement route can be assigned to one transmitter. In the
picture below it is shown how a measurement file can be assigned to a transmitter.

Figure 592: The Cell dialog.

The button indicated with the red circle is used to assign a measurement file (.fpp, .fpl, .fpf files
are supported) to the selected transmitter. The measurement file must contain measured data from the
selected transmitter only. Superposed measurement data from several transmitters is not supported.
When the measurement data is in path loss format (.fpl) cable loss must not be included. In contrast
to this, cable loss is expected as “included” when measurement data is available in field strength or
power file format. Antenna gain is always expected as “included”.

Computation of Propagation Prediction
After the assignment of the measurement files to the transmitters is completed, the wave propagation
prediction can be launched as usual. The propagation paths output needs to be activated, otherwise no
.cal files will be generated.
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For each transmitter (with measurement data assigned) a calibration file (.cal) is written to the hard
disk. If the files are missing, click the Prediction tab, under Additional Prediction Data... and select
the Propagation Paths check box.

Calibration Computation
The calibration tool can be started from the Computation menu (Computation > Auto Calibration
(Models & Materials)). The calibration files generated during the wave propagation prediction have to
be added to the list. This is shown in the image below.

The Calibration dialog

Files can be added by clicking on Add files. They can be deleted by clicking on Remove file.

The settings can be adapted to the users needs by selecting General settings. This allows you to
influence the selection of the measurement points, thus only points in a given power (dBm), path loss
(dB) or distance (m) range will be considered.
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Figure 593: The Settings dialog.

Additionally the type of optimization method can be chosen:

Minimum mean error
The goal of the optimization is to achieve a minimum mean error (nearest to zero). The standard
deviation is not considered and thus might be larger.

Minimum mean squared error
The goal of the optimization is to achieve a minimum mean aquared error. The standard deviation
is not considered and thus might be larger.

Minimum standard deviation
The goal of the optimization is to achieve a minimum standard deviation. The mean error is not
considered and thus might be larger

Minimum weighted error
The goal of the optimization is to find the best combination of minimum mean error and minimum
standard deviation. The weighting between mean error and standard deviation can be adapted by
the user.

The range of the model parameters can be defined in the Model settings dialog. As larger the range
is, as longer the calibration will take. The model parameters depend on the selected propagation model,
thus each model offers individual model parameters. The following screenshot shows model parameters
for the Urban Intelligent Ray Tracing.
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Figure 594: The Parameters for Intelligent Ray Tracing dialog.

Depending on the propagation model the material database or the clutter/land usage database can be
calibrated additionally.

After clicking Start, the calibration begins and the progress is shown with a progress bar. In some cases
the calibration process does take up to one hour.

Calibration Result
After a calibration has finished the results are displayed in a table. The picture below shows the results
for the urban Dominant path model. Depending on the propagation model different parameters are
listed in the table.

Figure 595: The Results for Dominant Path Urban dialog.

The model parameters listed in the table can now be transferred manually into the project settings
of ProMan and the project can be recomputed to achieve better results based on the new model
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parameters. By clicking on Apply the material properties (as far as they have been calibrated) are
applied to the vector/material database.

The message box shown above gives also information about mean value and standard deviation from
measurements to predictions before and after the calibration. Depending on the optimization method
different results can be obtained.

6.2.4 Inclusion of the Receiving Antenna
Specify the receiver antenna pattern for a mobile station.

To specify the antenna properties at the mobile station, open the Edit Project Parameter dialog and
click the Propagation tab. Under Consideration of Antenna Properties at Mobile Station, select
the Consider Antenna of MS check box.

Figure 596: The Consideration of Antenna Properties at Mobile
Station group on the Edit Project Parameter dialog - Propagation tab.

Click Edit Parameters to display the Settings of the Mobile Station dialog (see Figure 597).
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Figure 597: The Settings of the Mobile Station dialog - Mobile Station / Rx tab.

The mobile station is, by default, a single isotropic antenna. With this setting, the received-power result
with the mobile station included is the same as for a regular propagation-only simulation, since the
propagation-only simulation works with exactly that assumption when calculating the received power. A
non-isotropic pattern can be specified by double-left-clicking on Omnidirectional in the table.

Settings of the Mobile Station: Mobile Station / RX Tab
On the Settings of the Mobile Station dialog, click the Mobile Station / RX tab. Under Type of
receiver antenna, select one of the following antenna arrays for the mobile station:

• Single antenna element

• Uniform vertical rectangular antenna array

• Uniform linear antenna array

• Uniform circular antenna array

• Individual location offset for each element

After you have selected the type of antenna array, an info dialog may be displayed stating that the
value is set to default, see Figure 598. Click OK to continue.
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Figure 598: The Info dialog stating that the default value is used.

Figure 599 shows an example of how a linear array can be specified.

Figure 599: An example of specifying a uniform linear antenna array.

The image in the Figure 599 shows a top view of the antenna array where  is the array azimuth angle
(East over North) and  is the azimuth orientation of the individual antenna elements (East over North).
Antenna elements are specified on the Antenna Element dialog (see Figure 600) that is accessed by
double-clicking on the given antenna element in the table.
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Figure 600: The Antenna Element dialog.

To specify a large antenna array, for example, for massive MIMO, the option Uniform Vertical
Rectangular Antenna Array can be used (see Figure 601).

Figure 601: An example of specifying a large antenna array.

The image in Figure 601 has a mixed perspective. The grid of antenna elements is in the vertical plane
and is rectangular, with horizontal rows and vertical columns. The angle  denotes the rotation of the
entire vertical array around the vertical axis (East over North), and the angle  denotes the azimuth of
the individual antenna elements (East over North).
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The image also indicates the numbering, which is row by row. The number of Rx elements is defined
in the dialog and then the next integer that is a square is used as a basis. For example, in case of 6
elements defined, a 3x3 vertical array is the basis, and only the antenna elements for the two upper
lines are considered. The maximum number of antenna elements is 64, for an 8×8 array.

As the computation of the stream results is very time consuming for larger numbers of elements, the
stream results are automatically disabled if more than 4 Tx or Rx elements are defined. However, the
subchannel results are computed and written if this option is activated. The memory consumption can
become large for simulations with large arrays and many result pixels. Also, the disk usage for the
result files can become large.

Settings of the Mobile Station: Channel Data Tab
MIMO systems can be evaluated in more detail by calculating the MIMO channel matrix, which describes
the radio channel between each transmit and each receive antenna of the system.

There is a complex single-input-single-output (SISO) channel impulse response of length L+1 between
every transmit antenna m and every receive antenna n of a MIMO system.

(97)

In this equation, L relates to the tapped delay line, and the time dependence accounts for the possibility
that antennas or objects are moving.

The linear time-variant MIMO channel is represented by the channel matrix with dimension :

(98)

with complex elements:

. (99)

The MIMO channel matrix can be determined by post-processing the ray data simulation output of a
regular propagation simulation by just calculating the phase differences between the single antenna
elements of the MIMO antenna arrays at the base station and at the mobile station.

The ray data give a description of all considered propagation paths between the position of the
transmitter and each predicted receiver pixel. Field strength, delay and all interaction points
(reflections, diffractions, transmissions, scatterings) are listed for the propagation paths that contribute
to the signal level at a specified location. Based on these data and the dimensions of the MIMO antenna
arrays, the phase shifts between the single elements can be computed in the following way. The
transmitter location given in the ray file is assumed to be the center of the transmitting MIMO antenna
array. At the receiver side, the same assumption is made. Each point to be computed in area/trajectory/
point mode can be assumed to be the center point of a receiving MIMO antenna array. In order to
determine the MIMO channel matrix now, only the phase shifts between the single array elements have
to be computed, based on the ray data given in the ray file and on the array settings.

First of all, the angles of departure and arrival have to be computed, using the coordinates of
transmitter and the first interaction point of each path and the coordinates of the last interaction point
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of each path and the receiver, respectively. After that, the phase shifts between the antenna elements
of both arrays can be easily computed.

Figure 602: The Settings of the Mobile Station dialog - Channel Data tab.

Propagation Paths
The ray data file used for the simulation is listed under Propagation Paths. The maximum
number of rays, to be considered for each receiver location is set to 128 (can be only changed
manually in the .mic file). This number has to be a power of two. If the ray data file contains
more path data for a specific receiver location than specified here, the additional rays are skipped.

Channel Type
The radio channels can be modeled using the amplitude and phase information extracted from
the ray data file (ray tracing simulation). Alternatively, the phases of the simulated radio channels
can be derived randomly, for example, Gaussian distributed random variables are used for the
phases. The corresponding amplitudes are taken from the ray tracing simulation. The third option
can be used to simulate randomly derived Rayleigh fading channels with statistically distributed
amplitudes and phases.
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Channel Bandwidth

The bandwidth is considered for the computation of the SNIR (noise power depends on the
bandwidth) if the Calculate SNIR map check box is selected.

Furthermore the channel bandwidth is considered for the Frequency Sample Rate (see Results
tab).

Normalization of Channel Matrices

The calculated channel matrices can be normalized in various ways using different normalization
algorithms either in time or frequency domain. The chosen normalization mode can be applied for
all computation steps of the simulation or for the calculation of the MIMO channel capacity and
Keysight PROPSIM output only.

The channel capacity of a non-frequency selective MIMO channel can be written as

(100)

with the unity matrix I, the overall transmit power P and the noise power. The channel matrices
HF have to be determined by NF point Fast Fourier Transformation. The FFT needs to be done
for a certain number of sampling points (the number needs to be a power of two) which is by
default 128.

Frequency domain - Same path loss
In order to compare different MIMO channels based on the same path loss, the system has
to be normalized to fulfil the following condition:

(101)

where l is the loop index over the sample points in the frequency domain.

Frequency domain - Same SNIR
For comparison of different MIMO channels based on the same SNR, the system has to be
normalized to fulfil the following condition:

(102)

Signal-to-Noise-and-Interference-Ratio

The signal-to-noise-and-interference-ratio (SNIR) at the receiver locations is used for the
calculation of the channel capacity. The SNIR can be specified to be a mean value for all receiver
locations. This means the same mean value is considered for all specified receiver locations,
independent of the actual received power at the receiver.

The Calculate SNIR map option calculates the SNIR for each receiver location separately taking
into account the actual received power as well as the thermal noise (depending on the bandwidth)
and an addition interference level, which can be also specified.
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The Load SNIR map from file option enables the user to load a previously computed SNIR map
from the ProMan ray tracing simulation.

Settings of the Mobile Station: Results Tab

Figure 603: The Settings of the Mobile Station dialog - Results tab.

Channel Matrices

An overall MIMO channel matrix can be computed per receiver point (Channel matrices per
point which is activated by default). This result is derived by summing up coherently all ray
contributions impinging on the receiving antenna element. The complex power values of the
channel matrices can be written either as real and imaginary part or in amplitude and phase
notation.

Additionally, the channel condition number can be computed as well by selecting the Channel
Condition Number check box. The MIMO channel condition number is a MIMO performance
indicator and computed as ratio of the largest and smallest eigenvalues of the MIMO channel
matrix, with lower condition numbers allowing higher data rate transmissions.

Results for all Modes (stationary and non-stationary scenarios)

Generate per stream and sub-channel power results

The sub-channel results include the power for a single sub-channel (between one Tx
antenna element and one Rx antenna element).
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The stream result includes always the best value from the sub-channels (the higher value
is always considered without adding anything, as a result, corresponding to selection
diversity).

The “normal ” RunMS power result includes the superposition of the sub-channels (for
example, power addition in case incoherent superposition has been selected).

Frequency Sample Rate
This value is only considered for the ASCII subchannel power results. Defined frequency
sample rate is considered together with the defined frequency channel bandwidth (under
Channel Data tab) to compute the coherent power superposition for a set of frequency
bins, which is done by re-computing the phase of each ray for the new frequency (loop over
the frequency bins) and then summing the ray contributions coherently for this frequency
bin.

Results for Trajectories

Doppler shift
The option Doppler shift gives the Doppler shift per ray due to the velocity along the
trajectory in [Hz]. Doppler shift results are only available if the receiver array is moving on
a trajectory.

Doppler spread
Doppler spread is computed based on the power weighted mean Doppler shift and
represents the square root of the Doppler variance for all ray contributions (squared
difference of ray Doppler shift minus mean Doppler shift, multiplied with ray power,
normalized with total power (same principle formulas as for delay spread)).

(103)

(104)

Doppler spread results are only available if the receiver array is moving on a trajectory.

Propsim Channel Sounder

WinProp radio channel data can be converted into the Keysight PROPSIM channel format
(.asc file per subchannel and a .shd file).

In order to generate channel data, which can be directly imported into the Keysight
PROPSIM F8 channel emulator, some requirements have to be fulfilled:

• Calculating the channel data for the channel emulator is only possible for a receiver
moving along a trajectory. Therefore a corresponding receiver trajectory must be
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defined in the ProMan project file and considered in RunPRO. In order to guarantee
proper emulation results, the distance resolution should be chosen in such a way, that
the resulting evaluation points along the trajectory are located not more than half a
wavelength apart from each other. Besides this, the velocity assigned to the defined
trajectory points should be constant.

Generating channel data for the Keysight PROPSIM F8 emulator requires channel
normalization of type Time Domain - Strongest ray.

Settings of the Mobile Station: Results – Optional Tab

Figure 604: The Settings of the Mobile Station dialog - Results - Optional tab.

Mutual Antenna Coupling
This option is disabled by default, as such an analysis is better handled using Altair Feko.

Diversity Combining

Receive diversity can be evaluated using different combining techniques at the receiver array. The
resulting diversity gain can be written for each receiver location as well as in terms of probability
density functions and cumulative probability density functions.

So far the diversity combining results are only provided as separate .txt files, where the
computed diversity gain is given for each computed point (for example, along trajectory).
Additionally, there is some information about the expected theoretical diversity gain mentioned in
the header of the .txt file, for example:

• Theoretical diversity gain for Rayleigh fading channel: 3.01 dB

• Mean diversity gain of evaluated area: 2.99 dB
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In order to improve the signal reception in mobile radio various diversity techniques can be
applied, for example, by using multiple receiving antenna elements. Based on this, different
diversity combining techniques can be utilized to combine the multiple received signals into a
single improved signal.

Selection combining (SC)
For this option, the strongest signal is selected of the N received signals. When the N signals
are independent and Rayleigh distributed, the expected diversity gain has been shown to be

, expressed as a power ratio. Accordingly the additional gain for increasing numbers of

received signals is limited.

Equal gain combining (EGC)
For this option, all the received signals are summed up coherently.

Maximum ratio combining (MRC)
For this option, the received signals are weighted with respect to their SNR and then

summed up. The resulting SNR yields  where SNRk is SNR of the received signal k.

This combining technique is often used for large phased-array systems.

Channel Capacity
The ergodic and / or outage MIMO channel capacity is computed by calculating the eigenvalues
for equal power or water filling power allocation mode. The results are available for each specified
receiver location as well as in terms of probability density functions and cumulated probability
density functions. The chosen normalization mode for the channel matrices and the considered
SNIR (defined on the Channel Configuration dialog) are displayed here as these settings have a
strong influence on the channel capacity.

After Specifying the Mobile Station
After a regular propagation simulation (RunPro) was completed, and before a network simulation
(if applicable), the inclusion of the mobile-station antenna pattern can be launched using one of the
following workflows:

• Click Computation > Propagation incl. Mobile Station.

• Click the  RunMS icon in the project toolbar.

• Press F6 to use the keyboard shortcut.

The option Computation > Run All Computations launches all three simulations (if applicable) in the
following succession:

1. RunPro

2. RunMS

3. RunNet

Of the three simulation types, the propagation simulation (RunPro) tends to be the most time
consuming. Sometimes you need to modify the properties of the mobile station, or modify related
output requests, without losing the results of the regular propagation simulation. That can be achieved
by accessing Project > Edit Parameter of Mobile Station.
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This option is not available (grayed out) in a new project. It becomes available when the Consider
Antenna of MS check box was selected (Project  > Edit Project Parameter - Propagation tab.
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6.3 Network and Base Station Planning Projects

6.3.1 Air Interfaces
The performance of wireless communication networks depends on an efficient architecture of the
network. Due to the wide range of available air interfaces for cellular and broadcast wireless networks
with their different behavior and parameter settings, radio network planning is essential to analyze
the performance of the wireless network. ProMan offers predefined network planning modules for all
common cellular and broadcast air interfaces. Beyond this, the parameters can be easily adapted via
dialogs in ProMan to support arbitrary air interfaces.

FDMA (Broadcast)
Broadcasting networks (TV, radio or paging networks) are only using downlink signals radiated from
fixed terrestrial transmitters or satellites to fixed or mobile receivers. Accurate propagation models
allow a detailed analysis of the coverage scenario and avoid areas without any coverage.

Air Interface Parameters
All parameters related with a selected air interface can be specified on the Air Interface tab of the
Edit Project Parameter dialog.

Figure 605: The Edit Project Parameters dialog, Air interface tab.
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For frequency division multiple access in broadcast mode, the following settings are available:

• Duplex Separation

◦ As this multiple access scheme is designed for broadcasting systems (transmission in downlink
only), the duplex separation is fixed to simplex.

• Channel Bandwidth

◦ Available bandwidth of the channel. This value is used to calculate thermal noise impact.

• Carrier Separation

◦ Available bandwidth of the channel. This value is used to calculate thermal noise impact.

• Mobile Station /Subscriber Station

◦ Receiver of Mobile Station

∙ Noise figure of receiver (Parameter defines the additional noise generated due to the
receiver within the mobile station).

∙ Minimum SNIR which is required to receive the signals.

∙ Minimum required signal level required for reception.

◦ General Parameters of Mobile Station

∙ Antenna gain of the mobile station.

∙ General losses (for example, body). General parameter, which can be used to model all
kind of additional losses (body losses) around a mobile station.

◦ Fast fading

∙ The parameter Fast Fading Margin represents the difference (in dB) between the
maximum possible transmitting power and the maximum allowed transmitting power.
to ensure the fast power control to compensate the deep fades of the radio channel
this specific headroom is required. Appropriate values for this headroom have to be
determined via link level simulations and will depend on the mobile speed.
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Figure 606: The Mobile Stations dialog.

Output Options
• General Results

◦ Best Server (Cell Assignment)

◦ EMC Analysis

• Results Based on the Analysis of the Downlink

◦ Maximum Received Power in Downlink (at MS)

◦ SNIR for each Carrier at MS

◦ Superposition of Identical Carriers

◦ Number of Carriers Received

◦ Number of TRX Received

◦ Number of Sites Received

FDMA (Downlink and Uplink)

Air Interface Parameters
For frequency division multiple access in downlink and uplink the following settings are available:
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Figure 607: The Edit Project Parameters dialog, Air interface tab.

Multiple Access Settings
Clicking the Settings button will open a dialog, where the power backoff used for cell assignment
can be specified. This back off is defined with respect to the maximum available transmit power of
the corresponding carrier. The resulting percentage of the total transmit power used for the pilot
channel and the data channels, respectively depends on the chosen power back off and is shown
in the dialog as well.

Note:  The Tx power back off should exceed 0 dB for FDMA systems. For a power back
off of 0 dB, the total transmit power is used for the pilot channel and no power is left
for the data channels. 
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Figure 608: The Multiple Access: FDMA dialog.

Duplex Separation
Separation of uplink and downlink can be chosen to be either in frequency (frequency division
duplex) or in time (time division duplex). Further settings related to the duplex separation can be
specified by clicking on the Settings button.

MIMO Technology
MIMO is not supported for this air interface.

Channel Bandwidth
Available bandwidth of the channel. This value is used to calculate thermal noise impact.

Carrier Separation
Frequency separation of two adjacent carriers. This value is used for determination of adjacent or
co-channel interference.

MIMO Technology
MIMO is not supported for this air interface.

Channel Bandwidth
Available bandwidth of the channel. This value is used to calculate thermal noise impact.

Carrier Separation
Frequency separation of two adjacent carriers. This value is used for determination of adjacent or
co-channel interference.

Output Options
• General Results

◦ Best Server (Cell Assignment)

◦ Maximum achievable Throughput

∙ This results describes the overall throughput which is possible considering the defined
network with various transmission modes and possibly multiple carriers.

◦ EMC Analysis

• Individual Results for each Modulation and Coding Scheme

◦ Minimum Required Transmitter Power

◦ Maximum achievable Received Signal Strength
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◦ Reception Probability (including Fast Fading)

∙ The Reception Probability (including Fast Fading) is computed for each transmission mode
in the network-planning results by assuming a Rayleigh distribution of the signal levels
due to fast fading. Based on the difference between the computed mean Signal-to-Noise-
and-Interference Ratio (SNIR) and the required SNIR for the transmission mode, the
reception probability is computed and reported.

◦ SNIR (Maximum achievable SNIR)

◦ Maximum Number of Parallel Streams at Pixel

∙ This result describes how many streams can be supported in parallel at the given location
(with respect to the defined transmission mode and the overall number of available time
slots).

◦ Throughput at Pixel in Transmission Mode

∙ This result describes the maximum throughput at the given location evaluating the data
rate of the defined transmission mode and the maximum number of parallel streams.

• Results Related to the Cell Assignment

◦ Serving Carrier: Received Power (Cell Assignment)

◦ Serving Carrier: SNIR (Cell Assignment)

◦ Number of Carriers Received

◦ Number of TRX Received

◦ Number of Sites Received

◦ Neighbor Cell List

• Analysis of the Serving Carrier

◦ Serving Carrier: Received Signal, Noise + Interference

◦ Serving Carrier: Received Noise + Interference

TDMA

Air Interface Parameters
For time division multiple access the following settings are available:
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Figure 609: The Edit Project Parameters dialog, Air interface tab.

Multiple Access Settings

The number of time slots on a carrier as well as the maximum number of time slots for a single
radio link can be specified on the TDMA properties dialog by clicking the Settings button on the
Air Interface tab.

The power back off used for cell assignment can be specified here as well. This back off specifies
the attenuation of the pilot signals and is defined with respect to the maximum available transmit
power of the corresponding carrier.

Note:  As the signals used for cell assignment are transmitted in a separate time
slot, this back off value does not influence the available transmit power for data
transmission.
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Figure 610: The Multiple Access: TDMA dialog.

Duplex Separation
Separation of uplink and downlink is in frequency (frequency division duplex). Further settings
related to the duplex separation can be specified by clicking on the Settings button.

MIMO Technology
MIMO technology is not supported for this air interface. 

Channel Bandwidth
Available bandwidth of the channel. This value is used to calculate thermal noise impact.

Carrier Separation
Frequency separation of two adjacent carriers. This value is used for determination of adjacent or
co-channel interference.

Output Options
• General Results

◦ Best Server (Cell Assignment)

◦ Maximum achievable Throughput

∙ This results describes the overall throughput which is possible considering the defined
network with various transmission modes and possibly multiple carriers.

◦ EMC Analysis

• Individual Results for each Modulation and Coding Scheme

◦ Minimum Required Transmitter Power

◦ Maximum achievable Received Signal Strength

◦ Reception Probability (including Fast Fading)

∙ The Reception Probability (including Fast Fading) is computed for each transmission mode
in the network-planning results by assuming a Rayleigh distribution of the signal levels
due to fast fading. Based on the difference between the computed mean Signal-to-Noise-
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and-Interference Ratio (SNIR) and the required SNIR for the transmission mode, the
reception probability is computed and reported.

◦ SNIR (Maximum achievable SNIR)

◦ Maximum Number of Parallel Streams at Pixel

∙ This result describes how many streams can be supported in parallel at the given location
(with respect to the defined transmission mode and the overall number of available time
slots).

◦ Throughput at Pixel in Transmission Mode

∙ This result describes the maximum throughput at the given location evaluating the data
rate of the defined transmission mode and the maximum number of parallel streams.

• Results Related to the Cell Assignment

◦ Serving Carrier: Received Power (Cell Assignment)

◦ Serving Carrier: SNIR (Cell Assignment)

◦ Number of Carriers Received

◦ Number of TRX Received

◦ Number of Sites Received

◦ Neighbor Cell List

• Analysis of the Serving Carrier

◦ Serving Carrier: Received Signal, Noise + Interference

◦ Serving Carrier: Received Noise + Interference

OFDM / SOFDMA (Broadcast)
Orthogonal frequency division multiple access is a multiple access scheme, used in nearly all actual and
future wireless broadcast air interfaces, such as DAB, DVB-T/DVB-H, and DTMB.

A large number of closely-spaced orthogonal sub-carriers are used to carry data. The data is
divided into several parallel channels, one for each sub-carrier. Each sub-carrier is modulated with a
conventional modulation scheme (such as QAM or QPSK) at a low symbol rate, maintaining total data
rates similar to conventional single-carrier modulation schemes in the same bandwidth.

Air Interface Parameters
All parameters related with a selected air interface can be specified on the Air Interface tab of
the Edit Project Parameter dialog. For orthogonal frequency division multiple access for simplex
broadcasting networks the following settings are available:
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Figure 611: The Edit Project Parameters dialog, Air interface tab.
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Figure 612: The OFDM and OFDMA dialog.

• Multiple Access Settings

◦ Settings related to the multiple access mode (guard period, sub-carriers) can be specified in
the dialog shown below, which is reachable by clicking Project > Edit Project Parameter
and selecting the Air Interface  tab.

• Guard Period

◦ The selected ratio for the guard period defines the length of the guard interval with respect to
the defined symbol duration.

• Guard Interval and Interference

• Sub carriers and Symbols

◦ Maximum number of sub carriers used (the size of fast Fourier transformation). Sub carrier
spacing and symbol duration is calculated automatically based on the specified system
parameters. Number of guard, control and reference sub-carriers. The number of data sub-
carriers depends on the other parameters specified and is calculated automatically.

• Receiver Window

◦ Selection of if the receiver window starts at the first contribution above the specified threshold
or with the strongest contribution. This is important for the interference computation
considering the guard interval.

• Duplex Separation
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◦ For broadcasting simplex mode is used. There are no further settings available.

• MIMO Technology

◦ MIMO technology is not supported in simplex mode.

• Channel Bandwidth

◦ Total bandwidth of the channel. This value is used to calculate the thermal noise power.

• Carrier Separation

◦ Frequency separation of two adjacent carriers. This value is used for determination of adjacent
or co-channel interference.

• Cell Assignment

◦ The first step in the network planning computation is the cell assignment procedure. The best
server for each receiver pixel is determined based on the maximum Rx power (for carriers
which fulfill the min. power and min. SNIR defined under the Mobile Station settings).

• Mobile Station / Subscriber Station

Output Options
• General Results

◦ Best Server (Cell Assignment)

◦ Strongest Transmitter (ID)

• Results related to the cell assignment

◦ Best Server: Received Power (Cell Assignment)

◦ Best Server: SNIR (Cell Assignment)

◦ Serving Carrier: Received Power (Cell Assignment)

◦ Serving Carrier: SNIR (Cell Assignment)

OFDM / SOFDMA (Downlink and Uplink)
Orthogonal frequency division multiple access is a multiple access scheme, used in nearly all actual and
future wireless air interfaces, such as DVB-T/DVB-H, DAB, LTE, WiMAX, WLAN and 5G.

A large number of closely-spaced orthogonal subcarriers are used to carry data. The data is divided
into several parallel channels, one for each subcarrier. Each subcarrier is modulated with a conventional
modulation scheme (such as QAM or QPSK) at a low symbol rate, maintaining total data rates similar to
conventional single-carrier modulation schemes in the same bandwidth.

Air Interface Parameters
All parameters related with a selected air interface can be specified on the Air Interface tab of the
Edit Project Parameter dialog. For orthogonal frequency division multiple access, the following
settings are available:
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Figure 613: The Edit Project Parameters dialog, Air interface tab.
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Figure 614: The OFDM and OFDMA dialog.

• Multiple Access Settings

Settings related to the multiple access mode (guard period, sub-channelization) can be specified in
the dialog shown below, which is reachable by pressing the corresponding Settings button on the
Air Interface tab.

◦ Tx Power Settings (Downlink)

∙ The Tx power is split among the given sub carriers (by default each sub carrier gets the
same power). In case the sub carriers with pilot or reference signals should get less
power an additional backoff can be defined. The resulting shares of the Tx power for the
transmission of pilot, reference and data signals are displayed here, which are computed
by evaluation of the settings defined in the field “Symbols”.

◦ Sampling Rate

◦ Cell Load

∙ The cell load can be used to either control the “Tx power in downlink” or the “Number
of sub carriers used”. If the option “cell load controls Tx power in downlink” is selected
the power is adapted on all data sub carriers in the same way which leads to the same
interference situation on all data sub carriers (for example in case of 50% load every data
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sub carrier gets 3 dB less than the maximum power per sub carrier). If the option “cell
load controls number of subcarriers used” is selected, the sub carriers are transmitted
either with the maximum power per sub carrier or the sub carriers are not transmitted
at all (for example in case of 50% load only every second data sub carrier is used in the
considered cell, which means that the other 50% of the sub carriers can be used without
interference in the neighboring cells).

◦ Frequency Reuse

◦ Sub Carriers

∙ Maximum number of sub carriers used, thus the size of Fast Fourier Transformation.

Number of guard and pilot sub carriers. The number of data sub carriers depends on the
other parameters specified and is calculated automatically.

∙ DC subcarrier

Sub carrier spacing and symbol duration are calculated automatically based on the
specified system parameters. Depending on the channel bandwidth and the numerology,
a certain total number of subcarriers will be available. This number has been set by the
3GPP (www.3gpp.org). Of those many subcarriers, most are used to transmit data, but
some are needed to send reference signals, send control signals or provide a guard band.

∙ Extended Cyclic Prefix

For 5G Numerology 2, two different types of Cyclic Prefix are supported. One is normal
Cyclic Prefix and the other is Extended Cyclic Prefix which is longer than the Normal Cyclic
Prefix. A check box is provided to activate the Extended Cyclic Prefix for 5G Numerology
2. For the Extended Cyclic Prefix, the number of OFDM symbols within a slot is 12 symbols
instead of 14 symbols resulting in lower throughput.

◦ Guard Band

◦ Symbols

∙ This field allows to define the split of the resources (symbols and sub carriers) among the
different signal types (pilot, reference, and data). If “identical settings for each symbol” is
selected the split can be only done in the frequency domain by defining a corresponding
number of sub carriers for pilot and reference signals (the remaining sub carriers are
used for data transmission). If the option “individual sub carrier settings for symbols
(pilot./ref.)” is selected a more detailed assignment of the resources in both the time and
frequency domain is possible, which is especially important for LTE networks as it effects
the power and interference situation for the reference signals (RSRP, RSRQ, RSSI).

∙ Figure 615 shows the split among data, pilot and reference signals in a LTE physical
resource block (for the symbols which carry the reference signal). This resource
assignment for LTE is defined under Symbols, see Figure 614.
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Figure 615: The split among data, pilot and reference signals in a LTE physical resource block.

◦ Resource Blocks

∙ In this field the number of sub carriers in one resource block can be defined. The option
“fractional load allowed” is only relevant if the option “cell load controls number of
subcarriers used” is selected. In case the transmission modes include the transmission of a
certain number of resource blocks in parallel (for example, 25 in case of 5 MHz bandwidth)
the activation of this option evaluates the situation on higher granularity (resource block
level), thus how many resource blocks can be transmitted in parallel (especially if below
the defined number in the transmission mode).

◦ Interference Bandwidth Overlap

∙ In network planning simulations in ProMan, two antennas interfere if they are on the same
frequency. If two antennas are not on the same frequency, their interference is negligible.
For modern wireless standards that use OFDM/SOFDMA, such as LTE and 5G, the situation
is slightly more complicated. Each carrier may have hundreds of subcarriers. You select for
each base station antenna on which carrier it operates, but the simulation does not select
the precise subcarriers.

This parameter enables you to specify to what extent the subcarriers, used by different
antennas, may overlap and interfere. The best case is 0%, which is approximated when
traffic is low, while the worst case is 100%, which may occur in high traffic.

• Duplex Separation

◦ Separation of uplink and downlink in cellular networks can be chosen to be either in frequency
(frequency division duplex) or in time (time division duplex). Besides this, simplex mode can
be chosen for broadcasting applications (downlink only). Further settings related to the duplex
separation can be specified by clicking on Settings.

• MIMO Technology

◦ MIMO technology can be either disabled or enabled using two or four parallel streams.

• Channel Bandwidth

◦ Total bandwidth of the channel. This value is used to calculate the sub carrier spacing. Based
on the spacing and the number of sub carriers for a certain transmission mode the thermal
noise is determined.

• Carrier Separation
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◦ Frequency separation of two adjacent carriers. This value is used for determination of adjacent
or co-channel interference.

Output Options
• General Results

◦ Best Server (Cell Assignment)

◦ Maximum achievable Throughput

∙ This results describes the overall throughput which is possible considering the defined
network with various transmission modes and possibly multiple carriers.

◦ EMC Analysis

• Individual Results for each Modulation and Coding Scheme

◦ Minimum Required Transmitter Power (BS) in downlink (output power of PA)

◦ Minimum Required Transmitter Power (MS) in uplink (output power of PA)

◦ Maximum Received Power (MS) in downlink (considering number of streams)

◦ Maximum Received Power (BS) in uplink (considering number of streams)

◦ Reception Probability (including Fast Fading)

∙ The Reception Probability (including Fast Fading) is computed for each transmission mode
in the network-planning results by assuming a Rayleigh distribution of the signal levels
due to fast fading. Based on the difference between the computed mean Signal-to-Noise-
and-Interference Ratio (SNIR) and the required SNIR for the transmission mode, the
reception probability is computed and reported.

◦ SNIR (Maximum achievable SNIR)

◦ Maximum Number of Parallel Streams at Pixel

∙ This result describes how many streams can be supported in parallel at the given location
(with respect to the defined transmission mode and the overall number of available
resource blocks).

◦ Throughput at Pixel in Transmission Mode

∙ This result describes the maximum throughput at the given location evaluating the data
rate of the defined transmission mode and the maximum number of parallel streams.

• Results related to the cell assignment

◦ Serving Carrier: Received Power (Cell Assignment)

◦ Serving Carrier: SNIR (Cell Assignment)

◦ Pilot: Total received (signal + noise + interference)

∙ Considers the bandwidth of the pilot/reference signals.

◦ Pilot: Interference level (noise + interference)

∙ Considers the bandwidth of the pilot/reference signals.

Results related to the cell assignment

• Serving Carrier: Received Power (Cell Assignment)

• Serving Carrier: SNIR (Cell Assignment)

• Pilot: Total received (signal + noise + interference)
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◦ Considers the bandwidth of the pilot/reference signals.

• Pilot: Interference level (noise + interference)

◦ Considers the bandwidth of the pilot/reference signals.

• LTE Reference Signals (RSRP, RSSI, RSRQ)

◦ Reference Signal Received Power (RSRP) is the average of the power measured in a
single resource element that contains cell-specific reference signals. RSSI is the total
received wideband power on the given frequency bandwidth, which includes the power
from the own cell and from interfering cells as well as any other noise source. Reference
Signal Received Quality (RSRQ) is the difference between RSRP and RSSI considering the
number of resource blocks: RSRQ = 10.0*log(# of RB) + RSRP - RSSI.

• Number of Carriers Received

• Number of TRX Received

• Number of Sites Received

• Neighbor Cell List

UWB
View the settings for ultra wide band.

Air Interface Parameters
All parameters related with a selected air interface can be specified on the Air Interface tab of the
Edit Project Parameter dialog. For ultra wide band mode, the following settings are available:
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Figure 616: The Edit Project Parameters dialog, Air interface tab.

Duplex Separation
Duplex separation is fixed to simplex, thus only downlink direction is possible.

MIMO Technology
MIMO technology is not supported for this air interface.

Channel Bandwidth
Available bandwidth of the channel. This value is used to calculate thermal noise impact.

Carrier Separation
Frequency separation of two adjacent carriers. This value is used for determination of adjacent or
co-channel interference.

Output Options
Results based on the Analysis of the Carriers

• Number of Carriers received

CDMA / WCDMA / HSPA

Air Interface Parameters
All parameters related with a selected air interface can be specified on the Air Interface tab of the
Edit Project Parameter dialog. For code division multiple access, the following settings are available:
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Figure 617: The Edit Project Parameters dialog, Air interface tab.

Multiple Access Settings
Click on the Settings button to open a dialog, where the multiple access parameters can be
defined.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.641

Figure 618: The Multiple Access: CDMA dialog.

Orthogonality of Signals in Downlink
Physically the orthogonality depends on the multipath channel conditions and the receiver
implementation. Pure line-of-sight (LOS) profiles lead to nearly perfect orthogonality (DOF
approximate 1), while non-line-of-Sight (NLOS) profiles have reduced orthogonality depending
on the degree of multipath propagation (for example DOF = 0.4 … 0.9). It is common practice
in CDMA system simulations to use an average DOF for the complete simulation, thus for each
downlink connection the same constant DOF is used.

Handover (soft/softer)
The handover type in CDMA is related to the number of cells which are received within a certain
window. The window sizes for soft and softer handover can be defined in the corresponding fields.
If only one cell is received, no handover is possible at all. In case two cells are received within
the defined handover window, soft handover is possible. If two cells (sectors) from one site are
received within the defined window, softer handover is possible. If two cells (sectors) from one
site and another cell from another site are received within the defined windows, both soft and
softer handover is possible.

Properties of Base Stations

To achieve higher data rates multiple codes can be used in parallel within a single transmission
mode (for example in UMTS HSPA). This maximum number of codes, which are available for users
operating on the same carrier within a cell, can be defined.

Note:  The throughput results depend on the maximum number of available codes as
the feasible data rate for one user is multiplied with the number of possible streams.
Additionally, the number of parallel used codes defined on transmission mode level
should be below this maximum number.

Pilot Channel for Cell Assignment

The Tx power backoff used for the cell assignment can be specified in dB and is defined with
respect to the maximum available transmit power of the corresponding carrier. The percentage of
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the total transmit power used for the pilot channel and the data channels respectively depend on
the chosen power backoff and are shown in the dialog as well.

Note:  The Tx power backoff should exceed 0 dB for CDMA systems. For a power
backoff of 0 dB, the total transmit power is used for the pilot channel, thus no power is
left for the data channels.

Duplex Separation
Separation of uplink and downlink can be chosen to be either in frequency (frequency division
duplex) or in time (time division duplex). Further settings related to the duplex separation can be
specified by clicking on the Settings button.

MIMO Technology
MIMO technology can be either disabled or enabled using two or four parallel streams.

Channel Bandwidth
Available bandwidth of the channel. This value is used to calculate thermal noise impact.

Carrier Separation
Frequency separation of two adjacent carriers. This value is used for determination of adjacent or
co-channel interference.

Output Options
• General Results

◦ Best Server (Cell Assignment)

◦ Maximum Achievable Throughput

∙ This result describes the overall throughput which is possible considering the defined
network with various transmission modes and possibly multiple carriers. Additionally, the
maximum achievable data rate is predicted as well.

◦ EMC Analysis

• Individual Results for each Modulation and Coding Scheme

◦ Minimum Required Transmitter Power

◦ Maximum achievable Received Signal Strength

◦ Reception Probability (including Fast Fading)

∙ The Reception Probability (including Fast Fading) is computed for each transmission mode
in the network-planning results by assuming a Rayleigh distribution of the signal levels
due to fast fading. Based on the difference between the computed mean Signal-to-Noise-
and-Interference Ratio (SNIR) and the required SNIR for the transmission mode, the
reception probability is computed and reported.

◦ Maximum achievable Ec

∙ In UMTS the RSCP stands for Received Signal Code Power – the energy per chip in CPICH.
This means the RSCP corresponds to the “Received Ec” in ProMan (energy per chip).

◦ Maximum achievable Eb

∙ The “Received Eb” (energy per bit) is the sum of the Ec and the spreading gain.

◦ Maximum achievable Ec/(N0+I0)
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∙ The Ec/(I0 + N0) describes the situation before despreading. Accordingly I0 includes the
full interference power density of the own cell (independent of the defined orthogonality
factor) as well as the interference power density of the neighboring cells and the noise
power density. Ec is the energy per chip.

◦ Maximum achievable Eb/N0

∙ The Eb/N0 describes the situation after despreading, which extracts by correlation the
desired signal out of the interference mix. Accordingly, the Eb (energy per bit) is the
sum of the Ec and the spreading gain. The interference power density of the own cell is
reduced by factor (1-alpha), with alpha being the defined orthogonality factor.

◦ Maximum Number of Parallel Streams at Pixel

∙ This result describes how many streams can be supported in parallel at the given location
(with respect to the defined transmission mode and the overall number of available
codes).

◦ Throughput at Pixel in Transmission Mode

∙ This result describes the maximum throughput at the given location evaluating the data
rate of the defined transmission mode and the maximum number of parallel streams.

• Results related to the cell assignment

◦ Serving Carrier: Received Power (Cell Assignment)

◦ Serving Carrier: Eb/N0 and Ec/Nt (Cell Assignment)

◦ Pilot: Total received (signal + noise + interference)

◦ Pilot: Interference level (noise + interference)

◦ Handover Regions (Soft / Softer / Hard)

◦ Number of Carriers Received

◦ Number of TRX Received

◦ Number of Sites Received

◦ Neighbor Cell List

Note:  Results for each modulation and coding scheme are predicted based on the usage of
a single code considering the number of streams. Maximum data rate results consider only
the number of parallel codes, whereas throughput results consider the number of parallels
used codes as well as the number of streams.  

WCDMA (Dynamic Simulations)
View the settings for code division multiple access.

Air Interface Parameters
All parameters related to a selected air interface can be specified on the Air Interface tab of the Edit
Project Parameter dialog. For code division multiple access, the following settings are available.
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Figure 619: The Edit Project Parameters dialog, Air interface tab.

Multiple Access Settings
Clicking on the Settings button will open a dialog, where the chip rate of the carrier can be
defined.

Duplex Separation
Separation of uplink and downlink can be chosen to be either in frequency (frequency division
duplex) or in time (time division duplex). Further settings related to the duplex separation can be
specified by clicking on the Settings button.

In the case of TDD mode, some further parameters are required. The dialog below shows a possible
UTRAN TDD parameterization. A frame is subdivided into a certain number of slots. These slots are
assigned to the uplink and the downlink direction according to the traffic request. Therefore it is
possible to utilize the spectrum more efficiently in case of asymmetric traffic demand compared to the
FDD case with equal uplink and downlink bandwidth. To reduce interference, sectors of a single site use
the same time slots for uplink and downlink transmission. Therefore the traffic demand is analyzed per
site and the time slots are assigned to uplink and downlink according to the respective traffic demand.
The minimum number of time slots that are used for uplink and downlink can be specified. To ease
synchronisation and reduce interference the TDD mode provides a guard period. The guard interval
can be specified in µs. Within this interval perfect synchronization is assumed. The guard period limits
the cell range (signal delay to the cell edge must be smaller than half of the guard period). In the
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simulation all mobiles with signal delays larger than half the guard period will be blocked, thus 25µs
corresponds to a maximum cell range of 3.75km.

Figure 620: Time domain code domain graph.

The number of Resource Units (RU) that are available in a TDD time slot can be specified. In case
of a CDMA network, this corresponds to the number of available codes. In UTRAN TDD a maximum
spreading factor of 16 specified leading to 16 RU per time slot. Services with higher bandwidth demand
will be served with several SF16 codes in parallel, or with the reduced spreading factor. This can be
mapped to the assignment of several RU per time slot to individual mobiles. That means that the TDD
radio resources are consist of two-dimensional matrix with the granularity of one RU. The dimensions
are the number of time slots and the number of codes (maximum spreading factor). The number of
switching points is reduced to limit the interference. One block of downlink slots is generated at the
beginning of the frame, the remaining time slots at the end of the frame are used for the uplink.

The number of RU requested by each mobile is defined in the service settings. For the assignment of
the available resource units to the mobiles different algorithms are available. Currently, the resources
assigned to one mobile do not change during the lifetime of this mobile, thus there is no re-assignment
of RU.

• First available time slot: For each mobile, the first time slots of the respective downlink and uplink
block are checked if they can be used to set up a new connection.

• Least occupied time slot: The time slots with less occupied RU are tested first to set up a
connection.

• Random allocation: available RU are searched in randomly among the respective downlink and
uplink time slots.

In TDD networks mobile-to-mobile (MS-MS) interference and cell-to-cell (BS-BS) interference arise.
These sources of interference are considered during simulation assuming a LOS connection with the
respective antenna pattern. The propagation coefficient can be specified separately for the MS-MS and
BS-BS interference. For BS-BS interference the coefficient may be quite low in the case of ‘over-rooftop’
mounted antennas, for example, 2.5. In the case of MS-MS interference, the propagation coefficient
may be somewhat higher in urban scenarios, resulting in higher MS-MS attenuation due to the NLOS
situation.
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Figure 621: The Duplex Properties TDD dialog.

MIMO technology
MIMO technology is not supported for this air interface.

Channel Bandwidth
The available bandwidth of the channel. This value is used to calculate thermal noise impact.

Carrier Separation
Frequency separation of two adjacent carriers. This value is used for the determination of
adjacent or co-channel interference.

Adjacent Carrier Leakage
These parameters model the RF filter characteristic in terms of carrier separation. The attenuation
of the neighbor carriers can be defined in discrete steps for the direct neighbor carrier (adjacent),
the next carrier (alternate), and for any further carriers.

Figure 622: The Carrier dialog.
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Modulation and Coding Schemes

To distinguish between the different services a well-defined Name for example speech, low-data
can be attributed. Using the dialog, Timing in Simulations, you can specify the Setup and Drop
timers for the actual service. These values define the time a new MS waits to get a connection
or an established MS holds a connection in case of insufficient signal quality, respectively. The
parameter Data Rate defines the bit rate of the corresponding service. By the activity factors
for uplink and downlink, the effective data rate can be reduced if the transmission channel is not
required continuously.

A typical example is the speech service with activity factors of about 60% each (50% +
signaling). Additionally, asymmetric data services can be considered by utilizing these values.
The Eb/N0 values define the ratio between signal power density to noise- and interference power
density, which is required at the receiver after despreading for a specific bit error rate. These
values depend on the receiver implementation and can be taken from link level simulations. In
CDMA simulations the effective data rate is considered in the computation of the processing gain.
Consequently, if we specify the net-bit rate, the Eb/N0 values taken from link level simulations
have to refer to the net bit rate also. Physical layer overhead (for example coding rate) is
therefore taken into account by the link level simulations.

The maximum possible transmitting power of the MS can be limited for each service individually
by specifying the maximum output power of the amplifier. For mobile data and speech services in
W-CDMA simulations usually, the specified power classes 3 and 4 (from the 3GPP standard) with
power limits of 24dBm and 21dBm, respectively are taken into account.

Note:  During simulation, the uplink power limit is reduced by the Fast Fading
Margin.

Therefore the maximum power that can be found in the result files can be less than the specified
maximum amplifier power, even at the cell borders. Additionally, for each service the maximum
transmitting power in the downlink can be limited. This can be helpful especially for the evaluation
of asymmetric data services.

Note:  This is the power that can be used per single downlink connection. The overall
power amplifier parameters (including power limit) have to be set via the Sites/
transmitters dialog.
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Figure 623: The Service of CMDA/WCDMA network dialog.

The allocation of resource units for a mobile depending on the service specification (bit rate) can be
done either automatically or manually for each service in TDD mode. Press the RU Allocation button
and set the required RU for uplink and downlink in time domain and code domain. (In TDMA access
scheme the code domain corresponds to the respective time slots).

Mobile Types
For each service at least one type of mobile stations (mobile type) has to be defined to specify
the noise figure, antenna gain, losses, fast fading margin, and mobility parameters. The
parameter, Noise Figure, defines the additional noise generated due to the receiver within
the mobile station. The values of Antenna Gain and General Losses refer to the gain of the
transmitting antenna (in dBi), or the additional losses between the antenna and the power
amplifier, respectively. The parameter, Fast Fading Margin, represents the difference (in dB)
between the maximum possible transmitting power and the maximum allowed transmitting power.
To ensure the fast power control to compensate for the deep fades of the radio channel, this
specific headroom is required. Appropriate values for this headroom have to be determined via
link level simulations and will depend on the mobile speed.

The mobility characteristic of the mobile type is determined by its speed, a minimum distance
the mobile moves on straight lines, the probability for a turn after this distance and a maximum
turn angle. The actual turn angle is statistically distributed between +/- maximum angle. If the
traffic settings are based on the mobile location (depending on the clutter data, for example,
“Hot-Spot”-scenarios or outdoor / indoor scenarios) a mobile will not leave its traffic class. That
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means for example that mobiles will not penetrate buildings if the building has a different traffic
class. Instead, they are reflected. The same happens at the border of the simulation area. The
traffic generator setting can be reached by clicking Project > Edit Project Parameter because
the traffic settings can be individual or common for all services.

Through a sub-dialog, the parameters of the actual MS class related to the power control can be
chosen: the power control step size (for example, 1 dB in UMTS) and the SNIR margin. The SNIR
margin specifies the value by which the SNIR target can be missed and the signal quality is still
considered as sufficient. This is required as the actual measured SNIR will oscillate around the
target SNIR (due to the closed loop power control).

If there is more than one type of mobiles per service, the number of mobiles generated of each
type can be controlled by a weight factor giving the relative proportion for the different MS types
within this service. One of the mobile types has to be selected to be used for the coverage tests
for this service (and for the full-area-measurements).

Figure 624: The Mobile Stations for Service dialog.

Active Server Table
The active set of a mobile station is the list of sectors to which a link is established. The active set
can be modified from slot to slot. There are three operations defined on the Active Set (AS):

• Add a Link to the AS (Window Add)
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• Drop a Link from the AS (Window Drop)

• Replace a Link within the AS by a better Link (Window Replace)

This operation can be specified with the corresponding parameters in dB. The decisions for a link
to be added to, removed from or replaced within the active set are based on the static path loss
measurements to each cell. The reference path loss for the link addition and link drop windows
is the strongest cell in the current active set (thus the cell with the lowest static path loss). The
replace window enables a link to enter a filled active set if its path loss is better than (thus below)
the worst cell of the current active set by more than the specified value.

Figure 625: The Active Server Table dialog.

Common Channels
Different common channels (CCH) can be defined by pressing the respective buttons (Add /
Delete/Edit). For each CCH the required C/I has to be specified.

Note:  The channel quality C/I is measured before despreading (in contrast to Eb/N0
in the definition of the services).

It is common practice to specify the CCH by their required C/I. During the simulation, ProMan
assures that all defined CCH are received by the mobile station with sufficient signal quality.
Otherwise the call gets blocked or dropped. The CCH transmission power can be defined through
the TRX settings for all sectors in common or every sector individually. These transmission powers
- together with one CCH transmission power value for CCH not explicitly defined - contribute to
the interference.

Figure 626: The Channels dialog.

Power Control
The Power Control button opens a dialog that enables you to set some general transmit power
control (TPC) related parameters. First, the interval of the closed loop power control has to be
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specified. This interval determines the rate with which the power control feedback information
(“power up” or “power down”) is sent from the receiver to the transmitter. In case of UMTS, this
corresponds to the slot length, thus 0.667ms. Furthermore, a TPC error rate can be defined,
which introduces the probability for corrupted TPC feedback commands. A typical value for this
error rate is 4%.

Figure 627: The Fast Power Control dialog.

HSPDA Settings
If the HSDPA option is enabled, the corresponding settings can be specified on the following
dialog.
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Figure 628: The Definition of Parameters for HSDPA dialog.

Note:  A separate document describing the dynamic WCDMA system simulator is available
on demand.

Output Options
• General Results

◦ Best Server (Cell Assignment)

◦ Maximum achievable Bit Rate

◦ EMC Analysis

• Individual Results for each Service

◦ Minimum Required Transmission Power

• Further CDMA related Results for each Service

◦ Coverage Probability

◦ Soft/Softer Handover Areas
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◦ SNIR

◦ Channel Quality Indicator (only for HSDPA

• Further Results for Dynamic Simulations

◦ Statistics and Delays for PS Services

◦ Locations of Mobile Stations

◦ Detailed MS Information

Fifth Generation (5G) Cellular Network

Air Interface Parameters
All parameters related with a selected air interface can be specified on the Air Interface tab of the
Edit Project Parameter dialog.

Note:  The 5G keyword in the .wst file enables the 5G relevant settings on the Edit Project
Parameter dialog.

Figure 629: The Edit Project Parameters dialog, Air interface tab.
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Bandwidth

Important 5G-specific settings are the Channel Bandwidth and the Numerology. The Channel
Bandwidth is the total frequency range spanned by all the sub-carriers, and the numerology
governs the sub-carrier spacing. These settings are only available in projects that have the 5G
keyword in the .wst file. The 5G keyword also affects some options in the OFDM/OFDMA settings
(see OFDM / SOFDMA (Downlink and Uplink)) and on the Carrier dialog.

6.3.2 Local Settings
Adjust the display settings for the current project.

Display adjustments for the current project can be specified with the local settings dialog, which can be

reached via Settings > Local Settings (Display of Data) or the toolbar icon .

Figure 630: The Display Settings dialog.

Layout Tab - Display of Results

Layout Options
On this dialog, you can specify how result data and databases are displayed in 2D and 3D views of
ProMan.
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Figure 631: The Display Settings dialog, Layout tab.

Note:  The options are only visible if the data is present in the current project.

Prediction Data
The predicted data of the opened result can be hidden by disabling the option Prediction data.

Legend
The legend corresponding to a result or a database can be hidden by disabling the option
Legend. Click the Text button to open a dialog, where texts located within the legend can be
edited. 

Topography database (DEM)
In case the project contains a topography database, it can be hidden by disabling the option
Topography database (DEM). By clicking on the Options button, the following dialog will be
displayed.
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Figure 632: The Display of Topography dialog.

For the 2D view, the light intensity (in percent), as well as the direction of light (x, y, z-direction), can
be specified. For the 3D view, the color of the topography database can be changed by clicking within
the colored region on the right side of the dialog. Additionally, a scale factor for the heights can be
chosen here as well.

Urban database (vector data)
In case the project contains an urban building database (vector data), it can be hidden by
disabling the Urban database (vector data) option . By clicking on the Options button, the
following dialog, which offers further display options for urban vector databases, will be displayed.
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Figure 633: The Display of Buildings dialog.

Height of Buildings
Display heights of all buildings contained in the database.

Number (ID) of buildings
Display number/ID of all buildings contained in the database.

Draw virtual buildings
Special object types, such as virtual buildings, vegetation blocks or the shape of CNP
buildings can be enabled or disabled to be displayed independently.

Colorize heights (bright/dark)
The height of the individual buildings is represented by the color intensity used for drawing
the object. The specified intensity can be either auto-scaled according to the building
heights contained in the database or adjusted manually with a user-defined scale.

Drawing of buildings
Objects can be displayed either filled or in wire frame mode. This option can be specified
independently for standard buildings, CNP buildings and vegetation objects. Besides this,
vector objects can be drawn using the color of the assigned material or the corresponding
default color of the object type

3D display
The transparency of the roofs can be chosen arbitrarily. This makes it possible to see
prediction results within the buildings.

Indoor database
In case the project contains an indoor database (vector data), it can be hidden by disabling the
option “Indoor database”. By clicking on the Options button, the following dialog, which offers
further display options for indoor vector databases, will be displayed.
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Figure 634: The Display of Walls dialog.

Width of walls
Display width of all walls contained in the database.

Number (ID) of walls
Display number/ID of all walls contained in the database.

Draw subdivisions
Special object types, such as subdivisions or furniture can be enabled or disabled to be
displayed independently.

Colorize widths (bright/dark)
Objects can be displayed either filled or in wire frame mode. Besides this, vector objects can
be drawn using the color of the assigned material or the corresponding default color of the
object type. Optionally the width of the walls can be ignored for the display.

Drawing of walls
Objects can be displayed either filled or in wire frame mode. Besides this, vector objects
can be drawn using the color of the assigned material or the default color of the object type.
Optionally the width of the walls can be ignored for the display.

3D Display
The transparency of the walls can be chosen arbitrarily. Horizontal wall objects are not
displayed by default to have a better look at the prediction results. However, this can be
changed by enabling the corresponding option. Optionally, only a part of the database can
be drawn as well. The minimum and maximum height of the database part to be visualized
can be specified by the user.
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Rays / Propagation Paths
If propagation paths are displayed on the screen, you can hide them by disabling the option
Rays / Propagation Paths. Clicking the Options button will open an additional dialog
with further settings related to the display of propagation paths. The location of interactions
occurring along the propagation paths can be displayed optionally by enabling Draw Ray
Interactions. The size of the balls indicating the ray interactions can be specified as well. 

Figure 635: The Ray Interaction Settings dialog.

Bitmaps
If the project contains background images, you can display or hide them by selecting or clearing
the option Bitmaps.

Scale Tab

The scale of ProMan's result data can be either discrete with up to 14 margins or continuous. The type
of the scale, as well as the thresholds and value ranges, can be specified on the Scale tab of the Local
settings dialog.

Figure 636: The Display Settings dialog - Scale tab.

In the lower part of this dialog, the thresholds or value range can be defined for the current result.
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Default thresholds
Default values depending on the result type will be used.

Auto-defined thresholds
The value range of the scale will be set according to the minimum and maximum values of the
current result file.

User-defined thresholds
Arbitrary specification of the threshold levels. By clicking on the Change button, the following
dialog will open.

Figure 637: The Margins dialog.

Discrete Scale

Thresholds
Up to 14 threshold can be defined with an operator for comparison.

Number of Considered Margins
Number of margins that shall be considered for the legend.

Auto Button
By pressing the Auto button, the threshold values are specified automatically to cover the
whole range of values contained in the result map.
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Continuous Scale

Range
The user has the possibility to define the minimum and the maximum value of the scale. By
default the minimum and maximum value contained in the map are displayed. These default
values can be obtained also by pressing the Auto button.

Thresholds

Threshold values of the scale can be determined either automatically depending on the
specified range (minimum and maximum value) or the user-defined thresholds of the
discrete scale (upper part of the dialog) can be used.

Using the thresholds of the discrete scale can be beneficial if a specific, user-defined value,
for example, a certain planning target or minimum requirement, shall be contained explicitly
in the scale. The figure below shows an example, where the values have been defined
explicitly to visualize the planning target of -93.25 dBm and the corresponding CDF value.

Figure 638: Example of setting threshold values for visualization of the planning target.

Palette Tab

Color Palette
ProMan can use different color palettes to visualize simulation results. The color palette to be used for
the current result can be specified on the Palette tab of the Display settings dialog. On this dialog
there are six predefined palettes. Besides this, you can define your palette.

Further display options are related to the drawing of result pixels as wire frames and transparency.
Transparency is (in contrast to previous versions of ProMan) related to bitmaps which are included in
the project. Bitmaps are drawn above the data layer and thus transparency has to be used to make the
layers behind the bitmaps visible on the screen.
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Figure 639: The Display Settings dialog, Palette  tab.

Note:  A local palette can not be selected if a user-defined palette is specified to be used for
all results on the Legend tab of the Global settings dialog.

The following table shows the predefined color palettes of ProMan:

Table 51: Predefined color palettes in  ProMan.

Mandatory Parameter Description

Rainbow (bright)

Rainbow (dark)

CMR

Greyscale
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Mandatory Parameter Description

Flower Power

Green Meadow

A user-defined color palette can be created or edited via the Data menu: Data > Color Palette (user
defined) > New color palette (user defined) or Data > Color Palette (user defined) > Edit
Color Palette (user defined).

Figure 640: The User defined color palette dialog.

The color for the 14 thresholds can be defined by clicking on the colorized rectangles and saved to file
afterward. The user-defined color palette can be loaded by defining the corresponding file path on the
Legend tab of the Global settings dialog. This color palette can be used as a default palette for all
results (optionally).
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Sites / Cables Tab

Display Options for Sites and Feeder Cables
On this dialog, you can specify how sites and feeder cables are displayed in 2D result views of ProMan.

Figure 641: The Display Settings dialog, Sites/Cables  tab.

Sites
The Color of site symbol and Text size of site name can be specified here. It is also possible to
hide the site name by unchecking the Show Name check box.

Display of Sites
Site symbols can either be hidden, displayed with or without a border line.

Feeder Cables
The Text size of feeder cable name can be specified here. It is also possible to hide the name
of the feeder cable by unchecking the Show Name check box. The color of the cables can be
defined for each cable individually.

Display of Feeder Cables
Feeder cables can either be hidden, displayed with or without a border.

Transmitter / Antenna Tab

Display Options for Transmitters / Antennas
On this dialog, you can specify how transmitters and antennas are displayed in ProMan.
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Figure 642: The Display Settings dialog, Transmitter/Antenna  tab.

General
The color of transmitter / antenna symbol.

Display Mode
Transmitters / antennas can be either hidden, displayed with or without a border.

Directional Antennas
Directional antennas can be displayed either with an arrow symbol or with a circle symbol. Omni-
directional antennas are always displayed using a circle symbol.

Text
Besides the transmitter symbol, additional text can be displayed to describe the antennas further.

The font size of additional text can be specified here as well as the antenna parameters which
shall be displayed. The name and the assigned transmit power can be displayed by selecting the
option Show Name and Show Power, respectively. In network planning projects the carrier
assigned to transmitters / antennas can be depicted additionally.

It is possible to visualize the additional text information either for all transmitters/antennas or
only at the current mouse position.

Components Tab

Display of Results
On this dialog, you can specify how components are displayed in ProMan.
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Figure 643: The Display Settings dialog, Components tab.

Symbols
The size of component symbols.

Text Size
The font size of description texts for components and cables.

Text

Besides the component symbol, additional text can be displayed to describe the components
further.

The component parameters such as power and carrier ID can be displayed (optionally). It is
possible to visualize the additional text information either for all components or only at the
current mouse position.

Drawing with respect to the floors
To get a better overview, it is possible to draw only those components which are located at the
currently active floor level. To distinguish between components on different floors, components on
other floors than the currently active one can be drawn differently. Selecting the last option will
display all components on all floor levels.

3D Tab
View the 3D tab.

Display Results in 3D View
Simulation results including ray data and topographical database (if available) can be displayed
three dimensional with ProMan. This option is available at Display > 3D Display or by selecting the
corresponding toolbar icon. Options related to the 3D display can be specified at Settings > Local
Settings.
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Figure 644: The Display Settings dialog, 3D tab.

Prediction Data

You can choose an arbitrary transparency level for the prediction data.

In case of multi-layer results, either all prediction layers (height levels) or only the currently
active one can be selected for display.

Transmitters and Sites in 3D Display
Site symbols can be hidden optionally in the 3D View.

Options of 3D Display
A border around the simulation environment can be shown additionally.

Scale Factors
The size of the site/antenna symbols in the 3D View can be changed with a scaling factor. Scaling
factors for the size (diameter) of feeder cables and ray paths can be specified here as well. Result
data in 3D View can be rotated and zoomed with the mouse.

Note:  Click Settings > Local Settings (Display of data) and click the Layout tab
to specify which data of the current layout is to be shown.

Examples
The following examples show prediction results in an urban environment and inside a subway tunnel,
respectively.
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Figure 645: Example of prediction results in an urban environment.

Figure 646: Example of prediction results in a subway tunnel.

Legend Tab

Legend
ProMan's legend for result data consists of three sections - company logo, scale, and status field.
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Figure 647: Example of a legend in ProMan.

In the upper part of the legend, an arbitrary company logo can be shown. The bitmap file for the
company logo can be loaded via the context menu, which is available by right-clicking on the legend.

In the middle, the scale of the result data is shown. The scale of a result is automatically set depending
on the result type. Nevertheless, all settings related to the scale, such as color palette, value range and
type can be specified by the user as well.

The status field of the legend contains additional information like file name, statistical information or the
prediction height of the result. The status field is optional and can be hidden as well.

The legend can be switched on and off. Click Settings > Local Settings (Display of data) and click
the Layout tab.

The above dialog also contains a tab where the company symbol of the legend can be switched on and
off, and the information contained in the status field can be specified.
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Figure 648: The Display Settings dialog, Legend tab.

Title
Enable or disable the company logo.

Labels
The user can select either default labels in English language or arbitrary user defined labels. If
the option User defined labels is selected, the legend texts can be edited by pressing the Text
button.

Figure 649: The Text dialog.
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On this dialog, you can specify all texts contained in the legend.

Status Field
The status field in the lower part of the legend can contain different additional information, such
as the file name of the result or statistical information. Optionally, three lines of arbitrary user-
defined text can be displayed.

The status field in the lower part of the legend can contain different additional information, such as the
file name of the result or statistical information. Optionally three lines of arbitrary user-defined text can
be displayed as shown in the figure below.

Figure 650: Example of user-defined text added to a legend.

User-defined text can be edited by pressing the Text button. Besides the text contained in the three
lines, also the size of the font can be specified here.

Figure 651: The Text in Legend dialog.
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Additional Information
As an option the cumulative distribution function (CDF) or 100% - CDF of the data can be
displayed on the left side of the scale. The displayed CDF values consider all predicted pixels of
the current data, including all height layers and prediction planes. In this way it can directly be
analyzed which coverage percentage is above a certain threshold.

All settings related to the legend can also be specified using the legend context menu by right-clicking
on the legend.

Figure 652: The Legend context menu.

6.3.3 Site Settings
View the different settings for sites.

Working with Sites and Transmitters
An overview of all sites and transmitters of the current project can be found at Project > Edit Project
Parameter and click the Sites tab or the corresponding toolbar icon .
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Figure 653: The Project Parameter dialog.

Add
Use this button to add a new site to the project. After pressing the button, a dialog opens, where
the transmitter type has to be chosen. Besides this, the number of sectors for this site as well as
azimuth and tilt values for the specified sectors can be defined here.

Figure 654: The Transmitter Type dialog.
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After pressing OK, the parameters of the generated site can be further adjusted with the site definition
dialog. In the upper part, the user can modify the parameters corresponding to the site, for example,
the location coordinates. In the lower part of the dialog, the transmitters belonging to the sectors of the
site can be edited. It is also possible to add or delete transmitters / sectors.

Figure 655: The Site dialog.

Site
An arbitrary site ID (name), as well as a comment, can be specified for each site to identify it in
the simulation project.

Type of Site
Description of the type of current site.

Location
Location coordinates (x / Longitude, y / Latitude, and z / Height) of the site.

Note:  The height value is only used for the display of the site on the screen. There is
no impact on the prediction. The height defined for transmitters/antennas is used for
the prediction.

Antennas
List with transmitters/antennas assigned to the site and their most important parameters.

Copy
This option can be used to copy an already existing site with all parameters. The site to be copied
has to be selected before copying.

Delete
Delete a site from the project. The site to be deleted has to be marked in the site list.
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Edit
After selecting a site from the site list and pressing the Edit button, the user can edit the site with
the Site dialog.

Enable
By pressing this button, all transmitters belonging to the selected site will be enabled (all
transmitters will be considered during the simulation). Single transmitters of a site can be enabled
with the transmitter definition dialog.

Disable
By pressing this button, all transmitters belonging to the selected site will be disabled (will not
be considered during the simulation). Single transmitters of a site can be disabled with the
transmitter definition dialog.

Initial parameters for new sites or sectors/cells respectively can be defined by pressing the
corresponding buttons shown below. Each new site/sector which is added to the project will have the
initial parameters which are defined here.

Figure 656: The Initial Properties of New Objects dialog.

Default properties for transmitter antennas and the prediction area can be defined by clicking the
TRX or the Pred. Area button, respectively. These values will be used during the simulation if default
properties for antennas are selected in the transmitter definition dialog.

Figure 657: The Default Properties of Cells / Sectors / Antennas dialog.

After clicking the TRX button, you can specify transceiver settings such as cable loss, hardware
limitations and receiver noise figure. For the WCDMA air interface, the common powers have to be
defined here as well.
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Figure 658: The Specifications of TRX Settings dialog.

Cable loss
This parameter represents the loss of the cable between the power amplifier and the antenna of
the base station transmitter. The specified cable loss impacts the propagation results only if power
mode “Output Power Amplifier” is selected for the transmitter. In case power mode is chosen to
be “EIRP” or “ERP” the cable loss does not influence on propagation simulations.

Figure 659: Antenna, power amplifier and cable losses scenario.

The cable loss can be defined manually or a cable geometry can be selected in the drop-down list. In
this case, the cable loss is determined automatically based on the cable length and the attenuation per
100 meter specified in the cable settings. Cables can be drawn in the main view of ProMan.

Note:  The consideration of the cable loss parameter has changed in Version 12.3 and
following.

In former versions, cable loss was not considered during wave propagation predictions but only in
the network planning module. Now and in future releases, cable loss is also considered during wave
propagation predictions. This means that the received signal level in each wave propagation result is
lower by the cable loss if cable loss is larger than 0.0 dB and “output power amplifier (OPA)” mode
is selected. You will be informed about this modification by a message box each time you start a
prediction (RUN PRO / RUN NET) within a project based on the old definition of cable losses. You can
convert the project to the new cable loss handling by using the menu item Project > Convert Project >
Cable Loss Definition.
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The prediction area can be defined either by a radius around the transmitters, by corner coordinates
or by using the total prediction area as defined at Project > Edit Project Parameter and click the
Simulation tab.

Figure 660: The Prediction Area dialog.

Note:  Transceiver and prediction area settings can be defined for each transmitter
individually on the transmitter definition dialog, as well.

6.3.4 Network Project
View the network planning modules for 2G/2.5G, 3G/HSDPA/LTE, WLAN, WiMAX, TETRA networks that
ProMan (Network) offers.

The ProMan (Network) software offers network planning modules for 2G/2.5G, 3G/HSDPA/LTE, WLAN,
WiMAX, TETRA networks. Static network planning modules as well as dynamic network simulators
are included. Besides these cellular network planning features, ProMan also supports the planning of
broadcasting networks (terrestrial and satellite).

Network simulations are based on the wave propagation results of the transmitters within the
network and the definition of the wireless air interface. Therefore wave propagation predictions for all
transmitters of the network project is mandatory before network planning results can be computed.
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Figure 661: Summary of network planning

Examples

Figure 662: Example of Network Planning project
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Figure 663: Example of Network Planning project

Set Up New Project
Create a new project in ProMan for network planning.

To start a new project in ProMan for network planning (for example, 4G, LTE or 5G), on the File menu,
click New Project.

After selecting New Project, a dialog opens where you can specify the air interface definition file, the
scenario and the database to be used for the new simulation project.

Figure 664: The New Project dialog

Wireless Technology
For radio network planning the definition of a wireless air interface is mandatory. You can either
select a predefined air interface file (.wst) which is available for most of the common wireless
technologies or define an individual air interface (recommended only for experienced users). It is
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also possible to modify a predefined air interface in ProMan during the planning process. In case
Propagation Analysis is selected, no network planning is possible.

Scenario
Selection of the environment (rural, urban, indoor, tunnel, time-variant) for the network project,
depending on the available database.

Databases
Selection of the database file to be used for the simulations. Depending on the scenario, one or
multiple database files can be specified here.

Note:  For simulations with the intelligent ray tracing (IRT) wave propagation model a
preprocessed database is required. This preprocessing has to be done with WallMan before
the database is selected here.

You will be asked to specify the display height (z-coordinate) for the 2D display afterwards. The selected
height can be changed later on the Display menu. Click Display > Change Height in Display.

Configuration of a Network Project
After setting up a network project, further configurations have to be done to do simulations. Parameters
related to the network project can be edited by selecting Edit Project Parameter from the Project
menu or the toolbar icon . Before predictions can be done, set up the configurations on the following

tabs:

Air Interface tab
If a predefined wireless standard was loaded, then no changes are required.

Simulation tab
The simulation area can be changed here by editing lower-left and upper-right corner coordinates.
By default, the full area of the database will be predicted. The resolution grid of the result matrix
as well as the heights of horizontal prediction planes can be changed only if the database was not
preprocessed in area mode.

Figure 665: The Edit Project Parameter dialog, Simulation tab.

Network predictions can be done using three different simulation approaches. Static simulations use
either homogenous traffic assumptions per cell or location dependent traffic definitions based on clutter
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maps. A Monte Carlo simulation offers the possibility to generate distinct users at random locations
according to location dependent traffic definitions. The simulator uses multiple prediction runs to
determine a stable network load, thus convergence of the cell loads.

Figure 666: The Edit Project Parameter dialog, Simulation tab.

Traffic tab
Further information about cell load and traffic definitions for the network simulation can be found
here.

Network tab
Specify a directory where the computed network results are to be saved. Besides this, all network
planning results which can be computed with the selected wireless air interface are listed here.
You can select available results types by selecting the corresponding check box.

Propagation tab
As wave propagation is mandatory for the simulation of network projects, a path for storing the
propagation results has to be specified. For the network planning only the computation of the
received power for each transmitter in the network is required.

Sites tab
Detailed information about handling sites and transmitters can be found here.

Components tab
Detailed information about handling sites and transmitters can be found here.

Database tab
No changes are required here, as the databases have been loaded during set up of the network
project.

Computation tab
The wave propagation model and the related settings are selected on the Computation dialog.

After the configuration of the project (including definition of sites/transmitters), the simulation process
can be started with the wave propagation prediction by clicking Computation > Propagation:
Compute All or the toolbar icon. This first step must be computed once to predict wave propagation
for all transmitters separately. In the second step, the actual network planning is computed by clicking
Computation > Network Simulation or use the corresponding toolbar icon.

Carrier Assignment
Specify the carrier definition settings of a transmitter or cell.

On the Project menu, click Edit Project Parameter and click the Sites tab.

Under Sites, select a site and click Edit to launch the Site dialog. Under Antennas, select an antenna
and click Edit to launch the Cell dialog where you can specify the settings for the carrier definition of a
transmitter, see Figure 667.
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Figure 667: The Cell dialog.

Under Transmitter and Receiver Settings, click Assign Carrier to launch the Carrier Assignment
dialog, see Figure 668.

Figure 668: The Carrier Assignment dialog.
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All available carriers are listed under Available Carriers. Double-click on a carrier to assign to the
current transmitter. You will see the current transmitter configuration on the right side.

Click Edit to define the individual settings for the selected transmitter/cell, see Figure 669.

Figure 669: The Carrier dialog.

The following settings can be defined:

Maximum Tx Power
Maximum transmit power of the carrier in dBm or Watt. In case of carrier groups, the specified
value applies for each carrier contained in the group.

Definition of Tx Power
See transmitter settings.

Antenna Gain
Gain of the assigned antenna.

Transmitted Signal
This parameter allows the definition of distributed antenna systems (DAS). In DAS all antennas
operating on the same carrier transmit the same signal. Because of that all received signals from
all antennas in the DAS are superposed. Thus the contributions from the antennas of the DAS
are not considered in the calculation of the interference for this carrier. DAS can be activated by
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selecting the signal index in the drop down list “transmitted signal”. The indices (for example
“Signal 1”) of all antennas of the DAS must be the same and all antennas must be on the same
carrier of course. If “individual signal” is selected in the drop down list, the antenna belongs to no
DAS.

MIMO Stream
In case of a MIMO system, a MIMO stream can be assigned for the carrier.

Parameters of Network Simulation

Mean cell load, mean uplink noise rise and power back off can be defined individually for each
transmitter.

Settings for 5G NT

Numerology
In 5G, the numerology μ is a key parameter that sets 5G apart from 4G. It governs the sub-
carrier spacing and the slot length.

Additional Gains due to Beamforming
This parameter enable you to approximate the concept of beam forming by a 5G phased-
array base station antenna. Instead of running a Monte-Carlo simulation with individual
users and beam forming to serve individual mobile devices, you can simulate with either:

1. an omni-directional base station antenna pattern

2. an envelope antenna pattern consisting of all possible beams

Both approaches are not complete without specifying additional gains due to beamforming.
In case 1, all four fields are available. In case 2, the first two are set to N/A (not applicable)
because the gains of the serving beams are already in the envelope pattern. In both
approaches, neighboring cells in the simulation produce, with their broader beams, more
interference than the real base stations with narrow beams would. The bottom two fields
enable you to correct that effect.

Antenna Beams
The number of antenna beams also relates to the concept of beamforming by a 5G phased-
array base station antenna. Such an antenna might for several beams at once to serve individual
mobile devices. This requires the base station to divide its available power over those beams. The
number you enter here divides the available power, and the network-planning results are adjusted
accordingly.

Feeder Cables
Feeder cables can be drawn by the user and assigned to a transmitter.

The attenuation of a cable is determined automatically depending on cable length and loss per 100
meter. The attenuation is applied as “cable loss” for the selected transmitter.

Drawing of Cables
Click Project > Feeder Cables > Feeder Cables: New to draw a cable. It is possible to draw cables
only in network planning projects, not in pure propagation projects. After selecting the draw mode, the
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user can draw a poly line. The poly line can be completed with the right mouse button. After completion
the following dialog appears in which the settings of the cable can be defined:

Figure 670: The Cable dialog.

With the button Edit coordinates the coordinates (for example, z coordinate) can be modified
manually.

Management of Cables
Cables can be modified and deleted with the menu item Project > Feeder Cables > Feeder Cables:
Edit.... The dialog window shows all cables defined in the current project together with the most
relevant information. It is also shown the transmitter to which a cable is assigned. If the cable is
assigned to several transmitters only the first transmitter is shown in the table. The assignment of
cables to transmitters can be done in the transmitter dialog.

Figure 671: The Cable list dialog.

5G Network Analysis
There are three simulation approaches when analyzing 5G networks.

Fifth generation (5G) network planning has several unique characteristics, such as the use of antenna
arrays at the base stations that can direct relatively narrow beams at individual mobile stations. As
base stations are changing the directions in which beams are pointing (beam switching) to serve
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mobile stations (see Figure 672), their coverage and their interference change. This leads to simulation
approaches that differ from the ones used for pre-5G simulations. Therefore, 5G air-interface files
(.wst) contain a keyword, such as 5G_FDD or 5G_TDD, that triggers a few small but essential changes.
The most important changes are related to simulation strategies to deal with antenna-pattern
information.

Figure 672: Examples of beam patterns achieved with phased arrays at a base station (top view).

Three simulation approaches exist for 5G network planning:

1. with isotropic antennas

2. with envelope antenna patterns that represent a set of possible beams

3. with individual beams

Simulation Based on Isotropic Base-Station Pattern
One possible approach is to specify omni-directional (isotropic) antennas. When you do this in a 5G
network planning project, ProMan enables you to specify additional antenna gains to account for
beamforming. This is done during carrier assignment, see Figure 673.

Figure 673: Example of beamforming gains added to an envelope pattern in a 5G project on the Carrier dialog.

For a given mobile station, one base station antenna is the server, and the other ones are interferers
(if they use the same carrier frequency). The server points its beam to the mobile station, so the
expected beam gain to be added to the isotropic antenna is positive. The interferers are serving their
own mobile stations and are likely to be pointing their beams in other directions, at least most of the
time. Therefore, the gain to be added to those antennas is likely to be small and may be negative.

Simulation Based on Envelope Antenna Pattern
The second possible approach is to simulate with the envelope antenna pattern (see Figure 674) of all
possible beams. This assumes that, if a mobile station is in the cell, the base-station array directs its
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best beam at that mobile station. For that mobile station, the gain of the envelope pattern equals the
gain of the specific beam, so the propagation result is correct.

Figure 674: Envelope antenna pattern for a set of four beams (usually the set would be larger).

Note:  An envelope pattern is different from a traditional sector-antenna pattern.

The envelope pattern is the envelope of all possible beams, which are relatively narrow, so it has a
higher gain than a typical sector pattern. The integral of the gain over all directions will be higher than
that of a regular antenna pattern.

All mobile stations in the same cell receive the best beam for their location, so the envelope pattern
provides correct propagation results. Individual mobile stations in the cell may operate on different sub-
carriers or be served in different time slots.

For interference from other cells, the gain of the envelope antenna pattern of the interfering cell has to
be corrected, because an envelope pattern (in the simulation) will send more power into neighboring
cells than one beam (of an actual base station) would. This correction is specified in ProMan during
carrier assignment when using an envelope pattern, see Figure 675.

Figure 675: Example of beamforming gains added to an envelope pattern in a 5G project.

To provide values for additional gain in the interfering case is not hard science. There will be occasional
time slots where a narrow beam from an interfering cell points right at a mobile station in a serving cell
(correction would be 0 dB, worst case). There will also be more time slots where an interfering beam
points in a completely different direction (correction would be -20 dB or lower; only minor interference).
The default values of -7 dB and -11 dB are seen as a time average of the occasional worst case and the
more-frequent cases where the interfering beam points elsewhere.
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Simulation Based on Individual Beams
The final possible approach is to simulate with individual beams, see Figure 672. Since this requires
knowledge of where the mobile stations are, this is usually combined with a Monte-Carlo analysis.
When setting up a Monte-Carlo analysis, the offered traffic, which can be location-dependent and
service dependent, is specified. During the Monte-Carlo analysis, ProMan generates snapshots with
semi-random distributions of mobile stations to be served and performs the network analysis for each
snapshot. Since the beams are known, no additional gains due to beamforming need to be specified
(contrary to the approaches with omni-directional patterns and with envelope patterns).

Antenna Masking in Network Planning
In 5G network analysis, an antenna can have different antenna patterns for control and for data.
Furthermore, depending on the simulation approach, many different beams are possible. To avoid
the need to perform many simulations, the option Apply Antenna Masking for Network Planning
(Propagation Results with Omni Pattern) exists on the Edit Project Parameter, Network tab.

Figure 676: The Edit Project Parameter dialog, Network tab.

Select the Apply Antenna Masking for Network Planning (Propagation Results with Omni
Pattern) check box:
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• Propagation simulation is performed, and results displayed, with an omni-directional (isotropic)
pattern.

• Network planning is performed by adjusting propagation results based on actual antenna patterns
for control and for data. These could be envelope antenna patterns or individual beams.

Clear the Apply Antenna Masking for Network Planning (Propagation Results with Omni
Pattern) check box (traditional mode):

• Propagation simulation is performed with one antenna pattern.

• Network planning is based on one antenna pattern for both control and for data.

Masking mode is necessary for Monte Carlo simulations with individual beams, and is useful for
simulations with envelope patterns when those for control and for data differ significantly. Traditional
mode is attractive for simulations with envelope patterns when the patterns for control and for data do
not differ significantly. In the latter case, the display of the propagation results are more informative. In
both masking mode and traditional mode, only one propagation simulation per antenna is performed.

6.3.5 MIMO in Network Planning

Motivation

Multiple-input and multiple-output (MIMO) technology is the use of multiple antennas at both the
transmitter and receiver to improve communication performance. MIMO technology offers significant
increases in data throughput and link range without additional bandwidth or transmit power. It achieves
this by higher spectral efficiency (more bits per second per hertz of bandwidth) and link reliability or
diversity (reduced fading). Because of these properties, MIMO is an important part of modern wireless
communication standards such as WiMAX, HSPA+, 3GPP Long Term Evolution, 4G, and IEEE 802.11n
(Wifi).

Figure 677: Conventional SISO antenna system.

Figure 678: MIMO antenna system.

The MIMO antenna configuration can be used for spatial multiplexing. In this case a high rate signal is
split into multiple lower rate streams and each stream is transmitted from a different transmit antenna
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in the same frequency channel. If these signals arrive at the receiver antenna array with sufficiently
different spatial signatures, the receiver can separate these streams into (almost) parallel channels.

Accordingly the spatial multiplexing by using MIMO antennas is a powerful technique for increasing
channel capacity at higher signal-to-noise-and-interference ratios (SNIR). The maximum number of
spatial streams is limited by the lesser in the number of antennas at the transmitter or receiver.

Typical MIMO schemes are MIMO 2x2 (that is two antennas each at both transmitter and receiver), and
MIMO 4x4. In case of spatial multiplexing each MIMO antenna element transmits a separate MIMO data
stream. The MIMO scheme 4x2 transmits the MIMO stream 1 from two antenna elements and the MIMO
stream 2 from two other antenna elements, combining MIMO with a distributed antenna system (DAS).
The receiver includes also two antenna elements (for separating the two different MIMO streams).

MIMO in WinProp
Learn the two kinds of MIMO simulations.

Two kinds of MIMO simulations are feasible in WinProp: in network planning to obtain results like data
rate and as a propagation post-processing step to obtain results like channel capacity.

For MIMO in network planning, each base station (BS) antenna element needs to be defined separately.
The simulation of the MIMO performance is based on the analysis of the individual MIMO streams.

Here the spacing and polarization of the Tx and especially Rx antenna elements is considered
(empirically) via the interference ratio between the individual MIMO streams.

In the case of MIMO through propagation post processing, the propagation simulation is performed with
an isotropic transmitter, and the antenna arrays are defined during the post processing of all the stored
ray paths.

Modeling MIMO in Network Planning

For considering MIMO antennas in the WinProp radio network planning project, first the MIMO scheme
has to be selected on the Air Interface tab. Depending on the selected MIMO scheme, a number of
separate MIMO data streams is considered, up to MIMO 8x8 with eight parallel streams.
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Figure 679: Air Interface definition including MIMO technology.

When you click the Settings button, further properties of the MIMO antenna system can be specified.

Signaling Overhead
When transmitting multiple data streams in parallel due to spatial multiplexing, there is an additional
signaling overhead required which reduces the effective achievable data rate. The defined signaling
overhead value (see Figure 680) is considered once for MIMO 2x2, 1.5 times for MIMO 3x3, twice for
MIMO 4x4, and so on up to four times for MIMO 8x8.

Beam forming
Beam forming at the transmitter can be achieved by spatial processing. In this case the same signal
is emitted from each of the transmit antennas with appropriate phase weighting such that the signal
power is maximized at the receiver input.

The benefits of beam forming are to increase the received signal gain, by making signals emitted from
different antennas add up constructively, and to reduce the multipath fading effect. Spatial multiplexing
can also be combined with beam forming when the channel is known at the transmitter.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.692

In the absence of scattering, beam forming results in a well defined directional pattern, thus increasing
the antenna gain for the desired signal and reducing the antenna gain for the interfering signal.
Consequently the antenna gains for the serving and interfering signals can be defined in the MIMO
settings if beam forming is utilized. These values shall be kept to 0 dB if no beam forming is applied.

See Figure 680 for the settings related to beam forming.

Interference between MIMO streams
Spatial multiplexing by using MIMO antennas allows to increase the throughput depending on the
signal-to-noise-and-interference ratio (SNIR). The SNIR is also influenced by the interference between
the different MIMO streams.

The MIMO Settings tab provides three different options for this purpose:

No interference (ideal separation of different streams)
If different polarizations are used (for example, vertical polarization for MIMO stream 1 and
horizontal polarization for MIMO stream 2) the streams are well separated, especially in LOS
areas. Thus a simple assumption consists in neglecting the interference between the different
MIMO streams.

Relative contribution to interference due to non-ideal separation of streams

In this case an overall ratio for the interference between the different streams is specified. For
example, 20 dB which means that for a MIMO 2x2 system the received power for MIMO stream
1 will increase the interference level for MIMO stream 2 (received power minus 20 dB) and vice
versa. This option considers a constant relative interference impact over the whole simulation
area (considering the individual received power values for each stream at each location).

Alternatively, specify the envelope correlation coefficient (ECC) of the mobile station's antennas.
While a universal relation between interstream interference and ECC does not exist, the following
can be expected in practice:

ECC <= 0.01 MIMO interstream interference of 20 dB

ECC = 0.1 MIMO interstream interference of 16 dB

ECC = 0.5 MIMO interstream interference of 12 dB

Based on condition number
The condition number of the channel matrix is used to determine the interference between MIMO
streams.

Location dependent determination of interference due to non-ideal separation of streams

This option considers the individual receiver location and the properties of the radio link (LOS/
NLOS) for the interference impact. In order to ensure high accuracy the user shall define
if different polarizations are used for the individual MIMO streams (for example vertical
polarization for MIMO stream 1 and horizontal polarization for MIMO stream 2), which reduces the
interference, especially in LOS conditions.

The options to use the condition number or the localization-dependent interference can be used
for simulations with ray-tracing methods. The condition number should be the most accurate
option however only in cases there are many ray paths with significant power to the mobile
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station. The localization-dependent interference is rather complex to be used because of the many
parameters.

Note:  In cases with widely-separated MIMO antennas on the mobile station (for
example, separated by several or many wavelengths), the paths from the base station
to each of the mobile station's antennas are noticeably different, which means the
correlation between them will be low, so you may as well choose to use the option for
MIMO interstream interference with a large value for the ratio.

Figure 680: The MIMO Settings dialog.

Antenna Definition
Generally the antennas belonging to MIMO systems are defined in the same way than conventional
antennas, location, carrier frequency, and transmit power of the antennas are defined as usual. For each
MIMO antenna element a separate antenna has to be defined in ProMan.

The Signal Group has to be set to the same ID for all antennas belonging to a MIMO system.
Furthermore the transmitted MIMO stream has to be selected.

For conventional antennas, the Signal Group ID is set to individual (no MIMO stream can be selected).
Generally all antennas belonging to a MIMO system must have the same carrier. Depending on the
assigned Signal Group ID and the assigned MIMO stream the signals from different antennas are
combined constructively or interfere each other.
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Table 52: For conventional antennas the Signal Group ID is set to individual (no MIMO stream can be selected).

Antenna Type Signal Group MIMO Stream

Conventional antenna Individual Not available

Antenna belonging to DAS A / B / C / … No MIMO

Antenna belonging to MIMO A / B / C / … MIMO stream 1 / stream 2

To specify the MIMO Stream, click Project > Edit Project Parameter and click the Sites tab. Select
a site and click Edit. Select an antenna, click Edit and click Edit Carrier.

Figure 681: The Carrier dialog.

The Signal Group and MIMO stream selection can be found in the carrier settings of a transmitter.

All antennas belonging to one MIMO system must have the same Signal Group ID. If only one MIMO
system is available in your project it is recommended to use Signal Group A for all antennas which are
part of the MIMO system.

Theory
Learn the MIMO theory.

Computation of MIMO Results
For the computation of the MIMO result maps, the received power (dBm) and the SNIR (dB) are
computed for each defined MIMO stream (according to the specified MIMO scheme) in each receiver
pixel. In this context also the interference between different MIMO streams operating on the same
carrier (and Signal Group ID) is considered (depending on the selected option. Finally the feasible
modulation and coding scheme depending on the given SNIR is selected.
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If the serving cell is a MIMO antenna the received power is the superposition of the signal power values
from all antennas belonging to the MIMO system and transmitting the same MIMO stream.

Table 53: Antenna type and received power.

Antenna Type Received Power

Conventional antenna Received power from serving cell

Antenna belonging to
distributed antenna system
(DAS)

Superposition of received power values from all antennas belonging to
DAS of serving cell

Antenna belonging to MIMO
system

Superposition of received power values from all antennas transmitting
the same MIMO stream as the serving cell

Computation of Interference
Usually signals which are radiated on the same carrier but from different antennas interfere with each
other as individual signals are transmitted. Signals which are radiated from different antennas but
within the same DAS do not interfere (if they have the same Signal Group ID). If the antennas belong
to a MIMO system the interference depends on the transmitted MIMO stream. Antennas transmitting
the same MIMO stream are considered to operate like a DAS (for example, in a 4x2 MIMO system). If
the antennas transmit different MIMO streams they interfere each other depending on the individual
situation (spatial separation, usage of different polarizations, LOS/NLOS scenario). The interfering effect
can be reflected by selecting the appropriate option on the dialog.

Table 54: Antenna types, MIMO streams and interference.

Antenna 1 Antenna 2 Interference (same carrier)

Conventional antenna Conventional antenna Yes

Conventional antenna Antenna belonging to DAS A Yes

Antenna belonging to DAS A Antenna belonging to DAS A No

Antenna belonging to DAS A
MIMO Stream 1

Antenna belonging to DAS A
MIMO Stream 1

No

Antenna belonging to DAS A
MIMO Stream 1

Antenna belonging to DAS A
MIMO Stream 2

Yes

Antenna belonging to DAS A Antenna belonging to DAS B Yes
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Example
This section presents an example for the better understanding of the MIMO feature in WinProp.

The figure shows an office scenario with two antennas (distributed MIMO system). Both antennas use
the same carrier - otherwise there would be no co-channel interference in the scenario.

Figure 682: Office scenario with two antennas (DAS or MIMO 2x2).

Figure 683: Office scenario (3D) with two antennas (DAS or MIMO 2x2).

The main parameters of the network are shown in the following table:

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.697

Table 55: Network main parameters.

Parameter Value

Frequency 2630 MHz

System bandwidth 20 MHz

Transmit power 5 dBm Output power of PA

Antenna height 2.5 m

Min. required SNIR
(depending on MCS)

Between –5.4 and 17.2 dB

Air interface LTE

Two different antenna configurations are analyzed in the following:

1. Configuration 1: Both sites are conventional antennas forming a DAS (Signal Group A).

2. Configuration 2: Both sites are MIMO antennas (Signal Group A) and transmit individual MIMO
streams (site 1 MIMO stream 1 and site 2 MIMO stream 2).

Figure 684: Maximum data rate (DL) for DAS network (configuration 1).
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Figure 685: Maximum data rate (DL) for DAS network (configuration 2).

In configuration 1 both antennas operate on the same carrier and form a distributed antenna system.
Because of that the signals from both antennas are superposed constructively and improve the SNIR
situation. Nevertheless the maximum data rate is limited to 75 Mbit/s as only one data stream can be
transmitted.

Configuration 2 shows where again both antennas operate on the same carrier, but this time sites 1
and 2 form a 2x2 MIMO system. Here MIMO stream 1 is transmitted from site1 and MIMO stream 2 is
transmitted from site 2 in spatial multiplex. Accordingly higher data rates can be achieved for a large
part of the office building (assuming here ideal separation of the different MIMO streams). Generally the
performance depends also on the interference between the MIMO streams.
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Figure 686: Maximum data rate (DL) for MIMO 2x2 network with visualised MIMO streams.

The above figure shows the active MIMO streams 1 and 2 contributing to the maximum data rate for a
specific pixel (red shows the best received stream with the maximum data rate, in dark red color the
other MIMO streams are given).
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6.4 MIMO Analysis Through Post-Processing
The MIMO workflow for network analysis requires an air interface and all transmitter antennas to be
defined and analyzed explicitly. As is common for network analysis, results of that workflow include data
rates.

This section describes a different MIMO analysis workflow, which is not a network analysis. The
propagation simulation is performed for one isotropic transmitter antenna. The actual antenna
patterns and array configurations are defined as a post-processing step. Results of this analysis include
channel capacity. Since it is a post-processing step, the effects of different antenna patterns and array
configurations can be investigated quickly.

6.4.1 Analysis
The analysis of MIMO at the mobile station is launched by clicking Computation > Propagation
Postprocessing incl. Tx and Rx. This brings up the Post Processing of Mobile Station dialog.

Figure 687: The Postprocessing of Mobile Station dialog.

After selecting which of the available transmitters is to be used and which of the available trajectories is
to be analysed (if any), click Edit Parameters to define further options. This bring up the Settings of
the Mobile Station dialog.
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Figure 688: The Settings of the Mobile Station dialog, Mobile Station / Tx tab.

Here, the Base Station / Tx tab and the Mobile Station / Rx tab are where the MIMO antenna arrays
can optionally be defined:
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Figure 689: The Settings of the Mobile Station dialog, Mobile Station / Tx tab.

MIMO is optional, since the same dialog can be used for SISO (single input, single output).

You can select a uniform linear antenna array or a circular array here.

Note:  Antenna elements in a circular array are located in the same horizontal plane.

Besides the principal array type, the number of antenna elements has to be specified. For a linear
antenna array, the spacing factor in wavelengths and the azimuth adjustment of the array have to
be given, too. In case of a circular array, the radius of the array has to be specified in wavelengths,
whereas the spacing factor is determined automatically, depending on the number of antenna elements
which are equally distributed over the circle.

In the lower section of the dialog, the single antenna elements within an array can be specified with an
antenna pattern, azimuth and tilt adjustments. By default, all antenna elements are considered to be
omnidirectional isotropic radiators. By double clicking on an antenna element, the antenna adjustment
dialog opens. You can import an antenna pattern (.ffe, .apa or .apb format) and specify the location
and orientation.

On the Channel Data tab, you specify how ray information is to be combined. Coherent superposition
includes detailed multipath, but the visualization of small-scale fading is not always desired.
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Figure 690: The Specification of the Mobile Station, Channel Data tab.

The normalization mode for the MIMO channel capacity has to be chosen, depending on the way you
intend to compare the calculated capacities. For a comparison based on the same SNIR, you have to
choose Same SNIR. Other options in the drop-down list include Path Loss. The mean SNIR to be
considered during the channel capacity calculations has to be specified, too.

On the Results tab, you specify the desired output such as the directory for the post-processing
results, the channel matrices to be computed, the results for stationary and non-stationary scenarios
(for example, the power azimuth spectrum can be determined with a specified angle resolution in
degrees), as well as the results for trajectories.
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Figure 691: The Specification of the Mobile Station, Results tab.

Results for Trajectories

Doppler shift
The Doppler shift for trajectories is written to a .txt file (for example:
Site 1 Ant 1 DopplerShift_Trajectory_0_Route 0.txt).

Doppler spread
The Doppler spread for trajectories is written to a .txt file (for example:
Site 1 Ant 1 DopplerSpread.txt).

PROPSIM Channel Sounder (F8)
WinProp radio channel data is exported to Keysight PROPSIM .asc file and a .shd file.

On the Results – Optional tab, you specify the optional output, see Figure 692.
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Figure 692: The Settings of the Mobile Station dialog, Results - Optional tab.

Once everything has been specified, click Start Computation to return to the Post Processing of
Mobile Station dialog, see Figure 687.

6.4.2 Results
All results have ASCII text format and are computed for the specified prediction area.. Due to the
open ASCII format, you can draw graphs with third-party tools and do further evaluations and post-
processing.

MIMO channel matrices are computed per point and per ray. If antenna correlation is considered
additionally, the matrices will include the effect of the antenna correlation.

The antenna correlation coefficients can be written optionally to an ASCII file either for the antenna
spacing defined on the Tx array and Rx array page, or for a specified range of antenna distances. For
the second case a matrix or a tabular output format can be chosen.

The matrix format of the antenna correlation coefficients has the following design:

(105)

In the tabular format, the correlation coefficients are listed with increasing distances between the
elements one after the other.
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The section about the channel capacity offers a general output with the capacity value of the MIMO
channel at each pixel of the investigation area. Besides this, the probability density function and the
cumulated probability density function of the channel capacity (whole evaluation area) can be written to
an ASCII file. These values can be easily plotted with another software tool.

Figure 693: Sample outputs.
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Figure 694: Sample outputs.

Figure 695: Sample outputs.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.708

6.4.3 Other Applications
The ray data output of ProMan can also be post-processed to obtain the power spectrum over the
azimuth and elevation angles. This information can be used to determine direction estimation for
adaptive antenna techniques and radar applications.
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6.5 Results

6.5.1 Display of Results

Open

Result files can be opened with ProMan in two different ways.

First, there is the possibility to open results with the tree view on the left. All result files available for
the current project are listed in this tree view and can be loaded by clicking on a tree item. The selected
result will be displayed on the right side. The tree view makes it possible to access results and switch
between them easily.

Figure 696: The tree view of Open Results.

Alternatively result files can be opened in separate result windows. Click File > Open Result or click

the  icon. In case there is additional data available for a result (for example, propagation paths), you

can load the additional data as well.
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Move

Move Window with Result Data
Result data can be moved within the window to get a better view. This can be done by using the
scrollbars at the right and at the bottom of the window.

A further possibility is to use the move window tool. Click Display > Move window and specify the
distance as well as the direction of movement.

Figure 697: The Move Window dialog.

Besides the general move window command described above, there are further options for moving the
result window available in the Display menu. These options have a fixed distance increment and a fixed
direction and can be reached using shortcuts.

Zoom

Zoom Options for Result Data

Results data can be zoomed either in constant steps   or by drawing a zoom window  with

the mouse. After a zooming operation the window can be reset  to view the overall result file again.

Zoom options are also available on the Display menu. Use the mouse wheel to zoom in and out.

Legend

ProMan's legend for result data consists of three sections - company logo, scale and status field.
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Figure 698: Example of a legend.

In the upper part of the legend an arbitrary company logo can be shown. The bitmap file for the
company logo can be loaded via context menu, which is available by right click on the legend. In the
middle the scale of the result data is shown. The scale of a result is automatically set depending on the
result type.

Nevertheless, all settings corresponding to the scale, such as color palette, value range and type can
be specified by the user as well. The status field of the legend contains additional information like file
name, statistical information or the prediction height of the result. The status field is optional and can
be hidden.

The legend can be enabled or disabled. Click Settings > Local Settings (Display of data) and select
the Layout tab on the Display settings dialog.

On the Legend tab you can enable / disable the company log and specify the information contained in
the status field.
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Figure 699: The Display Settings dialog.

Title
Enable or disable the company logo.

Labels
You can select either default labels in English or arbitrary user-defined labels. If the User defined
tab is selected, the legend texts can be edited by pressing the Text button.

Figure 700: The legend Text dialog.
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Status Field
The status field in the lower part of the legend can contain different additional information, such
as the file name of the result or statistical information. Optionally, three lines of arbitrary user-
defined text can be displayed.

Figure 701: A legend with user-defined text.

User-defined text can be edited by pressing the Text button. Besides the text contained in the three
lines, also the size of the font can be specified. 

Figure 702: The Text in Legend dialog.
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Additional Information
Optionally, the cumulative distribution function (CDF) or 100% - CDF of the data can be displayed
on the left side of the scale. The displayed CDF values consider all predicted pixels of the current
data, including all height layers and prediction planes. This allow you to analyze which coverage
percentage is reached above a certain threshold.

All settings related to the legend can be specified also using the legend context menu by right-clicking
on the legend.

Figure 703: The context menu for legend.

Additional Channel Characteristics

Additional channel characteristics like channel impulse responses, spatial channel impulse responses
and angular profiles can be displayed for user-defined locations in separate graphs. Propagation paths
can be shown for each type of propagation result either in 2D or 3D display. You have the option to
display all available rays for single, multiple selected pixels or to display only a user-defined selection of
rays available for a pixel.

Tip:

• Additional channel characteristics are only available for ray-optical wave propagation
models if the additional ray data output is enabled.

• Ray data cannot be displayed in combination with path loss results.

Multi-Layers

Display of Results on Multiple Layers
ProMan allow you to do predictions on multiple height levels within the same project. Step through the
single layers (height levels) by pressing Ctrl + Alt + Arrow Up / Arrow Down to display the layer above
or the layer below the current layer.

The prediction height of the layer currently displayed is indicated in the legend below the scale. In
the 3D view you have the option to show all predicted height layers simultaneously. Click Settings >
Local Settings (Display of Data)..., click the 3D tab and select the Display all prediction layers
(heights) check box.
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Example
This example shows a prediction on multiple building floors:

Figure 704: Prediction on multiple building floors.

Figure 705: Prediction on multiple building floors.

Time-Variant

Display Results in Time-Variant Scenarios
Result data of time-variant scenarios can be handled in the same way as other result data. To step
through the time-variant simulation (see the computed snapshots along the time-axis) press Ctrl +
Alt + Arrow Up / Arrow Down to display the next or the previous time step. The time step currently
displayed is indicated in the legend below the scale.

Example
The following example shows a time-variant car-to-car communication scenario with a transmitter
mounted on top of a moving vehicle:
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Figure 706: Example a time-variant car-to-car scenario.

Figure 707: Example a time-variant car-to-car scenario.

3D View

Display Results in 3D View
Simulation results, including ray data and topographical database (if available), can be displayed three

dimensional in ProMan. Click Display > 3D Display or by clicking  icon. Settings related to the 3D

display can be modified, click Settings > Local Settings (Display of data) and select the 3D tab.
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Figure 708: The Display Settings dialog.

Prediction data
Specify an arbitrary transparency level for the prediction data. In case of multi-layer results,
either all prediction layers (height levels) or only the currently active one can be selected for
display.

Transmitters and Sites in 3D Display
Hide site symbols in the 3D View.

Options of 3D Display
Add a border around the simulation environment.

Scale Factors
Change the size of the site / antenna symbols in the 3D view with a scaling factor. Scaling factors
for the size (diameter) of feeder cables and ray paths can be specified here as well.

Note:  Click Settings > Local Settings and click the Layout tab to specify the data of the
current layout that should be displayed.

Result data in 3D view can be rotated and zoomed with the mouse.

Examples
The following examples show prediction results in an urban environment and inside a subway tunnel,
respectively.
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Figure 709: Example of prediction results in an urban environment.

Figure 710: Example of prediction results in a tunnel.

6.5.2 Modification of Results
ProMan result files can be modified in various ways. An arbitrary selection of result pixels can be
changed using the drawing tools. Mathematical operations offer the possibility to add, subtract or
multiply either constant values or other result files to the values of the currently active result. to obtain
arbitrarily shaped result data (for example circular areas, hexagonal areas), result files can be masked
by applying user-defined mask files.

Paint Tool
The paint tool allows you to select result pixels of a geometrical object using a mouse.

Click Edit > Edit Data to specify the paint settings. Click  to enable the actual drawing operation or

click  to select the different drawing operations..
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Figure 711: The Paint Settings dialog.

Under Value, specify the value to be set during the drawing operation. Result values can either be set
to an arbitrary defined value or to not computed. A value which is set to Value not computed is drawn
white in the graphical display.

Under Mode, you can change the drawing mode. The specified value can be set directly to the selected
pixels, added or multiplied to the actual values of the selected pixels. It is also possible to copy and
past the values of selected pixels to other pixels. The Copy and Move Pixels mode copies the values
of selected pixels and pastes them to a user-defined location within the result area. Using the Cut and
Move Pixels mode instead, cut the values at the original position. The result values at the original
location will be set to Value not computed after the paste operation in this case.

Clear the Change undefined values check box to exclude pixels which are set to Value not
computed from the drawing operations.

Masking
Results can be masked to obtain result values that are only within a user-defined area.

Masking Results
Arbitrary result files can be masked with a (0/1) result mask, a LOS mask or a clutter / morpho class
mask. Click Edit > Mask Data and select a mask option.

Mask Result File (0/1)
This option allows you to mask result data with user-generated masks, for example, a circle around a
transmitter. To define a mask, an arbitrary result file of the same project has to be loaded. After that,
all values of the result area which is to be neglected (set to “not computed”), are set to zero. All result
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values that remain, are set to one by using the drawing tools. Afterwards the resulting mask file has to
be saved and renamed to have the extension .mas.

Figure 712: Example of a result data mask.

LOS Prediction Result
This option allows you to mask result data according to predicted line-of-sight conditions. After selecting
a predicted LOS result a dialog opens where the status of the pixels for each LOS condition can be
specified either to be set to “Set values to "not computed"” or Keep values.

Figure 713: The Mask based on LOS prediction result dialog.

Clutter / Morpho Data
This option allows you to mask result data according to areas belonging to a specific clutter / morpho
class. After selecting a clutter / morpho database a dialog opens where a clutter / morpho class can be
selected for applying a mask mode.
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Figure 714: The Mask based on clutter classes dialog.

Generate Mask from Result
This option allows you to create a mask file based on the currently loaded result file. A mask can be
generated considering numerous parameters.

Figure 715: The Generate mask from result dialog.

Output File for Masking
File name and path of the resulting mask file (.mas).

Threshold Definition
The threshold values can be applied to either the result values of the current matrix (including
arbitrary planes) or to the distance from a receiver point to the selected transmitter.

Transformation Operations
Considering the two threshold values defined, all values contained in the result file can be
classified into three regions.

• The first region covers all values below threshold one.

• The second region contains all values between threshold one and two.

• The third region covers values above threshold two.
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For each region, you have the possibility to set either the contained result values to a user-
defined value, to not compute the result values or to keep the original value.

Example 1
This example shows a delay spread result, which was masked to visualize only values within a circle of
500 meters around the transmitter.

Figure 716: Example of a delay spread results, with mask.

Example 2
This example shows a field strength result which was masked with a LOS mask to keep only LOS pixels.

Figure 717: Field strength results masked with a LOS mask.
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Example 3
This example shows a path loss result which was masked with a clutter / morpho mask in order to keep
only those result pixels belonging to the clutter class “open”.

Figure 718: Example of a path loss result masked with a clutter / morpho mask.

Using the Generate Mask from Result option, various combinations of masks can be generated.

Example 4
The following example shows three masks around three transmitter locations. These masks were
combined to a single mask covering all three transmitter ranges.

Individual masks are combined using Edit > Combine Data.

An existing mask can be loaded using File > Open Result and masked again.

Combining and loading masks make it possible to create complex masks for arbitrary purposes.
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Figure 719: Example of three masks around three transmitter positions.

Mathematical Operations

In ProMan it is possible to add, subtract, or multiply the values contained in a result file to / from / with
another constant value or even another result file. Mathematical operations on result files can be found
on the Edit menu.

A combination of two result files is also possible to get a result file which contains the maximum, the
minimum or the mean value of the two selected result files. Combine result file by clicking Edit >
Combine Data.

6.5.3 Evaluation of Results
ProMan's simulation results can be evaluated in various ways. Besides the 2D and 3D result maps,
ProMan offers the possibility to evaluate simulation results statistically in terms of histograms,
probability density functions, cumulated probability density functions and further statistics. Result
values can also plotted along user-defined lines or compared to measurement data. Depending on the
simulation module, reports may also be generated during the simulation.

Information

The Information dialog displays general information about simulation projects or result data,
depending on the currently active view. This page shows statistical values like minimum, maximum
and mean values and standard deviation as well as computation times, database parameters and

transmitter settings. To show the information page, click Analysis > Information or click the  icon.
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Figure 720: Example of a path loss result file.

Probability Density Function (PDF)

ProMan offers the possibility to determine the probability density function for each type of simulation
result, click Analysis > Display PDF (Probab. Density Fct) of Values, where you can select whether
the PDF is determined for one of the following:

• all prediction planes and all horizontal layers

• all horizontal prediction planes

• prediction planes and surfaces only

• currently active horizontal prediction plane

• zoomed area of the currently active horizontal plane

After selecting the area to be evaluated, you have to specify the quantization interval, which is used to
discretize the result data.

Note:  Unpredicted result pixels (result values which are set to “not computed”) are not
considered for the generation of the PDF.
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Figure 721: Example of a probability density function of a received power prediction.

Cumulated Probability Density Function (CDF)

Cumulated Probability Density Function (CDF)
ProMan offers the possibility to determine the cumulated probability density function for each type of
simulation result. Click Analysis > Display CDF (Cum. Density Fct) of Values, where you can select
whether the CDF is considered for:

• all prediction planes and all horizontal layers

• all horizontal prediction planes

• prediction planes and surfaces only

• currently active horizontal prediction plane

• zoomed area of the currently active horizontal plane

Note:  Unpredicted result pixels, that is result values (which are set to “not computed”) are
not considered for the generation of the CDF plot.

Figure 722: Example of a cumulated probability density function of power prediction in an urban environment.
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100% - Cumulated Probability Density Function (100% - CDF)
Besides the standard cumulated probability density function ProMan also offers the possibility to
determine the 100% - CDF for each type of simulation result. This option can be chosen from
menu Analysis > Display 100% - CDF (Cum. Density Fct) of Values or from toolbar. In the
corresponding submenu the user can select whether the 100% - CDF plot shall consider all prediction
planes and all horizontal layers, prediction planes and surfaces only, all horizontal prediction planes, the
currently active horizontal prediction plane or the zoomed area of the currently active horizontal plane.

Note:  Unpredicted result pixels, for example result values which are set to “not computed”,
are not considered for the generation of the 100% - CDF plot.

The following example shows a 100% - CDF plot of a maximum downlink SNIR prediction in an indoor
environment.

Figure 723: Example of a 100% CDF plot.

Comparison to Measurements
Prediction results can be compared with measurement data in ProMan.

After importing the measured data, the difference between predicted and measured values can be
obtained by applying the mathematical subtraction operation.

Reports of Monte Carlo Simulation
The traffic simulation report in ProMan based on the Monte Carlo approach that evaluates the numbers
of served, blocked and not assigned mobiles (users) for each application and for each cell.

Monte Carlo Simulation Report
The results are given for the total simulation area (considering all cells) and for the sum of all defined
applications.
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Table 56:  The four different states for a mobile generated in the Monte Carlo simulation.

State Description

Served The mobile is served by the cell and the corresponding radio resources are
allocated for the defined application.

Not assigned Cell assignment not feasible for the corresponding location (signal level too low
and SNIR too low) -white pixels in cell area map.

Note:  Coverage holes need to be filled by additional base stations.

Blocked (traffic) Cell assignment possible for the corresponding location and Rx power as well
as SNIR sufficient for the desired transmission mode. But the required radio
resources are not available in the corresponding cell (for example, codes in CDMA
and time slots in TDMA).

Note:  Addition of further carriers required or smaller cell for the hot
spot areas.

Blocked (quality) Cell assignment possible for the corresponding location, but for the desired
transmission mode the Rx power and the SNIR is not sufficient (interference too
high).

Note:  Interference reduction required (modification of Tx power,
antenna pattern or carrier assignment).

The following example shows a report of a Monte Carlo network simulation with 10 snapshots.
Figure 724 shows only the 10th snapshot and average value of all 10 snapshots.
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Figure 724: Example report of a Monte Carlo network simulation.

Additional results, on a per-transmitter basis, include transmitter power load in downlink and noise
rise in uplink. The transmitter power load in downlink indicates at what percentage of full capacity the
transmitter is operating.

The noise rise in uplink is due to mobile devices in neighboring cells that operate on the same carrier, in
other words, mobile devices in interfering cells. For those mobile devices, the tool knows the locations
and the power they transmit to“ their” base station. Therefore, the power received from an interfering
cell by the base station of interest is also known. To what extent this power leads to interference
depends on which sub carriers are in use in the cells (mobile devices only interfere if they are on the
same sub carrier). This is included in a probabilistic way depending on the number of mobile devices in
each cell. The noise rise in dB is the difference between the interfering power and the noise floor. The
noise floor is taken to be the thermal noise.
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Monte Carlo Result Maps
Additional result maps for traffic analysis can be created for each defined application. Enable the output
of these results by clicking Project > Edit Project Parameter and click the Network tab.

The available result maps are described below:

Traffic Evaluation
State of generated mobiles for all simulation runs.

Served Users
Overall served users at the locations of the generated users for all simulation runs.

Blocked Users
Overall blocked users at the locations of the generated users for all simulation runs.

Offered Traffic
Overall offered traffic at the locations of the generated users.

User Distribution
Overall number of generated users per application within the simulation area.

Note:  To generate a result map with the number of generated users per Monte Carlo
snapshot, the keyword NUMBER_USERS_GENERATED_EACH_STEP y can be inserted manually in
the project file (.net).

6.5.4 Analysis of the Radio Channel
Additional channel characteristics like channel impulse responses, spatial channel impulse responses
and angular profiles can be displayed for user-defined locations in separate graphs.

Propagation paths can be shown for each type of propagation result either in 2D or 3D display. You have
the possibility to display all available rays for single as well as for multiple selected pixels or to display
only a user-defined selection of rays available for a pixel.

Note:

• Additional channel characteristics are only available for results predicted with ray-optical
wave propagation models.

• Additional ray data output has to be enabled.

• Additional channel characteristics cannot be displayed in combination with path loss
results.
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Channel Impulse Response
The channel impulse response of the radio channel can be analyzed for each computed pixel within the
simulation area.

Click Analysis > Channel Impulse Response or click the  icon. You have the possibility to specify

an evaluation location by positioning the mouse cursor in the result window. During mouse movement,
the graph window is updated automatically. After clicking, the channel impulse response for the current
location will be fixed.

Note:  Channel impulse responses can only be analyzed if the simulation was calculated
with a ray-optical propagation model and the additional ray data output was enabled. While
loading the result file, you will be asked to load additionally available data. This question has
to be answered with yes to do analysis of the radio channel.

Figure 725: Example of a channel impulse response for a specified location.

Propagation Paths
ProMan offers the possibility to visualize propagation paths determined during wave propagation
prediction.

Propagation paths can be shown in 2D and in 3D view. There are several options to select the
propagation paths to be displayed:

Display propagation paths on mouse move
The 2D view showing the propagation paths is updated directly while moving the mouse cursor
within the result data. This option is available by clicking Display > Propagation Paths > Show
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all Paths for Pixel on Mouse Move or clicking the  icon. Clicking the left mouse button, the

propagation paths for the pixel at the current mouse position is fixed.

Display propagation paths on mouse click
This options offers the possibility to show all propagation paths of one or more result pixels after
selecting the corresponding locations with the mouse. In this mode the display is not updated
while moving the mouse cursor. To select this option, click Display > Propagation Paths >
Show all Paths for Pixel on Mouse Click.

Show only selected paths for a pixel
In this mode an individual selection of rays contributing to a selected pixel can be displayed.

Click Display > Propagation Paths > Show Paths for Pixel individually or click the  icon.

You have to specify the pixel to be evaluated. Afterwards, the Propagation Paths dialog opens
where all rays contributing to the selected pixel are listed. In case the Update display only after
mouse click check box is selected, the ray information listed on the dialog can be updated by
clicking on another pixel. Otherwise the display is updated automatically while moving the mouse
cursor.

Figure 726: The Propagation Paths dialog.

The rays in the list are initially sorted according to decreasing signal level, but the sorting sequence
can be changed by clicking on the column headers. The rays to be displayed and further evaluated can
be selected by selecting the corresponding check box in the index column. By clicking All or None, all
paths of the current pixel can be selected or deselected. The Filter button makes it possible to select
paths in a specified signal level range or to select a fixed number of paths depending on the sorting
sequence.
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Figure 727: The Selection of Paths dialog.

Further information about the selected paths (for example, the coordinates of the interaction points)
can be obtained by clicking Info.

Figure 728: The Propagation Paths dialog.

To erase all rays drawn on the display, select Display > Propagation Paths > Delete all Paths on
Display or click the  icon.

Additionally it is also possible to highlight the interactions occurring along the propagation paths with
balls. This option can be enabled or disabled by clicking Settings > Local Settings and clicking the
Layout tab.

Note:  Propagation paths can be analyzed only if the simulation was calculated with a ray-
optical propagation model and the additional ray data output was enabled. While loading
the result file, you will be asked to load additionally available data. This question has to be
answered with yes to do analysis of the radio channel.

Examples
Ray data evaluation in urban environment:
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Figure 729: Example of ray data in an urban environment.

Figure 730: Example of a propagation paths inside motorway tunnel.

Figure 731: Propagation paths in an indoor environment.
Interactions occurring along the paths are indicated with blue balls.
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Spatial Impulse Response
The spatial channel impulse response at the mobile station can be analyzed for each computed pixel
within the simulation area.

Click Analysis > Spatial Channel Impulse Response (MS) to specify an evaluation location by
positioning the mouse cursor in the result window. After selecting a location by clicking the left mouse
button, the spatial channel impulse response for the current location is displayed in a new window.
Within this window, the 3D impulse response can be analyzed by rotating and zooming the graph with
the mouse.

Further adjustments of the graph can be done in the Settings dialog, which can be reached by clicking

the  icon in the toolbar.

To open the Impulse Settings 3D dialog, right-double click on the spatial channel impulse response.

Figure 732: The Impulse Settings 3D dialog.

Note:  The spatial channel impulse response can only be analyzed if the simulation was
calculated with a ray-optical propagation model and the additional ray data output was
enabled. While loading the result file, you will be asked to load additionally available data.
This question has to be answered with yes to do analysis of the radio channel.
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Figure 733: Example of a spatial impulse response for a specified location.

Angular Profile
Angular profiles at the base station as well as at the mobile station can be analyzed for each computed
pixel within the simulation area.

Click Analysis > Angular Profile (BTS) or Analysis > Angular Profile (MS) to specify an evaluation
location for the angular profile by positioning the mouse cursor in the result window. During mouse
movement the graph window is updated automatically. After clicking, the angular profile for the current
location is fixed.

Note:  Angular profiles can be analyzed only if the simulation was calculated with a ray-
optical propagation model and the additional ray data output was enabled. While loading
the result file, you will be asked to load additionally available data. This question has to be
answered with yes to do analysis of the radio channel.
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Figure 734: Example of an angular profile at the base station for a specified location.

6.5.5 Measurements
The most important criterion to measure the performance of a prediction model is the accuracy. The
accuracy of a prediction models can be analyzed by comparing simulation results with measurements.

Therefore ProMan offers the possibility to import and compare measurement data with prediction
results.

Besides analyzing the accuracy of prediction models, measurement data can also be used to calibrate
wave propagation models for specific environments.

Import Measurement Data from ASCII file
ProMan offers the possibility to import measurement data to do comparisons between predictions and
measurements.

Measurement data can be imported from an ASCII file by clicking File > New Measurement File....

After selecting a database to which the measurement should be imported, the ASCII file containing the
measurement data has to be selected. As the coordinates used in the ASCII file must match the ones of
the selected database, you have the possibility to convert and adjust the coordinates of the ASCII file
during import. The data contained in the currently active result view can be deleted before importing
the new data by selecting the corresponding option in the lower-left part of the dialog.

In the right part of the dialog the format of the data contained in the ASCII file can be specified.
The data to be imported has to be in a tabular format with longitude / latitude coordinates and
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a corresponding measurement value. The columns to be imported can be specified within the
Measurement Import dialog. In case the ASCII file contains a header section, keywords indicating the
data section to be imported have to be entitled in the lower-right part of the Measurement Import
dialog..

Figure 735: The Measurement Import dialog.

Note:  Depending on the resolution of the simulation area, several measurement points
might fit into a single raster point of the result file. In this case ProMan takes the average of
those measurement points.

For example, if multiple measurement points fall in the same ProMan pixel and the those measurement
values are -68 dBm and -72 dBm, the mean value of -70 dBm will be considered and saved in the file
with the imported measurements.

The following example shows an ASCII import file with a header section and a keyword for the
indication of the data section. The value “N.C.” stands for not computed - this point is left white in the
graphical display.
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Figure 736: Example of an ASCII import file.

Modification of Measurement Data
Modifications of measurement data can be done similar to the modification of other results by using the
drawing tools or mathematical operations.

Sometimes it might be useful to modify the imported measurement data. For example, if an additional
attenuator was used during the measurement campaign or if the data contains no errors. Another
reason for erasing or modifying measurement values could be that there are measurement points for
locations which are not modeled correctly in the simulation database (for example, under crossing of
railway lines and tunnels). Modifications of measurement data can be done similar to the modification of
other results by using ProMan's drawing tools or mathematical operations. 

In case measurement values are scattered along a measurement route, for example, ProMan offers the
possibility to align those values along an arbitrary line, which can be drawn by the user, click Edit >
Align Data Along a Line. After selecting the tool, you have to draw a polygonal line along which
the data is to be aligned. Then a dialog opens, where you can specify a radius. All values which are
contained in the matrix and which are located within this radius will be automatically moved onto the
specified line.
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Figure 737: The Measurement radius dialog.

Comparison of Predictions

Predicted result values can be compared to measured data with ProMan. First step is that the
measurement data has to be imported into a result file of the corresponding simulation project. As a
result, measurement data of the same type as the prediction data should be available in an ASCII file
with tabular arranged values. The imported values can be modified in case of known measurement
errors or for places which are not modeled correctly in the simulation database (for example, under
bridges). After the import of the measurement data is finished, the resulting file should be saved to disk
for further usage.

To do a comparison between predicted results and the corresponding measurement values, you can
subtract the measured values from the predicted ones. Click Edit > Subtract Data > Value (File,
linear) after the prediction result was opened and select the result file which contains the imported
measurement data. ProMan will then show a new result file with the difference between simulation and
measurement.

Figure 738: Imported values along a measurement route in an urban environment.
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Figure 739: Example of a prediction result.

Figure 740: Difference between predicted and measured power values.
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Figure 741: Information page containing further statistics.

6.5.6 Types of Results
View the available result types and the corresponding file extensions.

The section gives an overview of the available result types and the corresponding file extensions of
ProMan.

Table 57: Wave propagation.

Result Type File Extension

ASCII export of arbitrary result data .txt

Delay spread .fpd

Delay time .fpt

Field strength .fpf

Field strength (linear) .fsl

Interactions .fpi

Line-of-sight (LOS) condition .los

Morpho loss .fml

Path loss .fpl

Power .fpp

Ray data (ASCII format) .str

Ray data (binary format) .ray
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Table 58: Radio network planning.

Result Type File Extension

Active set size .ast

Angular spread (BS) .asb

Angular spread (MS) .asm

ASCII export of arbitrary result data .txt

Best server .fpb

Channel capacity .cap

Cell area .cid

Coverage .cov

Channel quality indicator (CQI) .cqi

Data rate (downlink) .dda

Data rate (uplink) .dua

Eb / No (downlink) .ebn

Eb / No (uplink) .ebu

Ec / Nt (downlink) .ecd

Ec / Nt (uplink) .ecu

Exposure .exp

Exposure field strength .fse

Interference .oif

Interference and noise power (downlink) .din

Interference and noise power (uplink) .uin

LMU .sig

Localization 50m .p05

Maximum field strength .fpg

Maximum data rate (downlink) .mdr

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.744

Result Type File Extension

Maximum data rate (uplink) .mdu

Maximum received downlink power .fpm

Maximum throughput (downlink) .mtd

Maximum throughput (uplink) .mtu

MIMO streams (downlink) .msd

MIMO streams (uplink) .msu

Number of received carriers .hho

Number of received sites .sit

Number of received TRX .fpn

Orthogonality .ort

Power density .pdy

Quality .fpq

Reception probability .rpb, .pro

Reference signal received power (RSRP) .srp

Reference signal receive quality (RSRQ) .srq

Received signal strength indication (RSSI) .ssi

Rx power (BS) .bsr

Rx power (MS) .msp

Signal power .spr

Signal-to-noise-ratio (downlink) .snr

Signal-to-noise-ratio (uplink) .snu

Signal-to-noise-and-interference-ratio .fpc

Signal area .sig

Site area .sid

Soft handover .sho
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Result Type File Extension

Spatial streams .sps

Superposition field strength .fpe

Superposition power .fpa

Total received interference .sin

Throughput (downlink) .atd

Throughput (uplink) .atu

Tx power (BS) .bsp

Tx power (MS) .mst

User distribution .uds

Areas

Cell Area
The cell area result indicates which antenna is received best at the corresponding location.

Figure 742: A cell area result.

Site Area
The site area result indicates which site is received best at the corresponding location. In case a site has
multiple cells, these cells can not be distinguished with this result.
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Figure 743: A site area result.

Signal Area
The signal area result indicates that the five antennas belong to two different signal groups (with ID A
and ID B), thus forming a distributed antenna system (DAS).

Note:  This result is available for distributed antenna systems (DAS) only.

Figure 744: A signal area result.

Line-of-Sight

ProMan distinguishes five line-of sight (LOS) conditions:

Line-of-sight (LOS) condition
Direct line of sight between transmitter and receiver. The transmitter can see the receiver and
inversely.

Obstructed-line-of-sight (OLOS) condition
Transmitter and receiver can be connected without wall intersection, for example, the transmitter
and the receiver are in the same corridor but without having direct line of sight (exists only in
indoor scenarios).
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Non-line-of-sight (NLOS) condition
No direct line of sight between transmitter and receiver. The transmitter can not see the receiver
and inversely due to shadowing by an obstacle (for example, a building).

Line-of-sight for buildings but shadowing caused by vegetation objects (LOS-V) condition
Line of sight between transmitter and receiver regarding the buildings, but shadowing due to the
vegetation objects.

Non-line-of-sight for buildings and shadowing caused by vegetation objects (NLOS-V) condition
No line of sight between transmitter and receiver regarding the buildings and additional
shadowing due to the vegetation objects.

Figure 745: Example of LOS status.

Multi Service Maps

The position (priority) of the transmission modes affects the throughput results as the transmission
modes are analyzed according to their position value. The networks are configured to maximize the
throughput. For this purpose the transmission mode with the first position should be analyzed first. If
there are some radio resources remaining (for example, resource blocks in LTE) then the transmission
mode with the second position is analyzed for checking if the throughput can be further increased and
so on.

For example, in an LTE network with 5 MHz bandwidth a total of 25 resource blocks are available.
At a specific location in the network it might be possible to transmit 15 streams in parallel of the
transmission mode with position 1 (leading to 710.2 kBit/s per stream). If the remaining 10 resource
blocks the SNIR of the first position is not fulfilled (as the interference for each sub-band depends on
the frequency reuse in the neighboring cells), maybe the SNIR target for the second position (with
665.9 kBit/s per stream) is fulfilled. In this case the overall throughput would result in 15*710.2 kBit/s
+ 10*665.9 kBit/s = 17,312 kBit/s.

The resulting mix of services which contribute to the throughput at a specific location can be visualized
in ProMan. After loading a result, you will be asked if additional result data should be loaded. If yes, an
additional dialog opens, where the contributing transmission modes, the occupied resources and the
data rate is displayed.
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Figure 746: An example of a multi service map.

Figure 746 shows the computed maximum throughput in downlink for an indoor LTE network with a
bandwidth of 5 MHz.

A detailed analysis of the selected location (red line) shows, that this pixel is served from carrier
0 of Site 2. Two transmission modes contribute to the overall data rate of 5.5 MBit/s. The 16 QAM
transmission mode uses two resource blocks, which gives a data rate of 947 kBit/s (473,5 kBit/s per
resource block). The remaining 23 resource blocks are used for a QPSK transmission mode, which
results in an additional data rate of 4.5 MBit/s (195 kBit/s per resource block).

Number of Received Carriers

This result map specifies the number of received carriers for each location (pixel) of the simulation area.
If the same carriers are used on different sites (or transmitters) the number of received carriers might
be increased (depending on the individual conditions). For example, if carrier X could be received from
site/transmitter A and from site / transmitter B as well (and no other site / transmitter as well as no
other carrier is defined in the network) the number of received carriers would be equal to two.

Ray Data

ProMan offers the possibility to write the data corresponding to the calculated propagation paths into an
ASCII (.str) or a binary (.ray) file. This optional output (ASCII version) is required for the evaluation
of the radio channel characteristics and can be selected by clicking Project > Edit Project Parameter
and click the Propagation tab. Besides this, the ray data contained in these files can be used to do

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.749

further post-processing with other tools, for example, calculation of angles of arrival / departure,
angular spreads.

Figure 747: The Additional Prediction Data dialog.

Note:  Ray data can only be written if the coordinate system of the project databases is
UTM. For other coordinate systems, ray data output is not possible.

There are different output alternatives within this ray data file, depending on the selected propagation
model, the computation mode, the environment under investigation and the enabled outputs on the
Propagation tab.

The output of the transmission matrix and the corresponding vector of the electrical field strength is
only available, if the standard ray-tracing model (based on indoor databases) is selected in combination
with the Fresnel (reflection, transmission) and GTD / UTD (diffraction) model for the calculation of the
rays in indoor scenarios. The transmission matrix is always optional, whereas the channel impulse data
is always written (if the output of propagation paths is selected).

The ASCII ray file written by ProMan contains a header section with general information about the
evaluated scenario, such as lower-left corner, resolution of the prediction area and the specified
parameters of the transmitter. After the header section the data section with the ray information for
each predicted pixel starts. Coordinates of predicted pixels are indicated with the keyword POINT.
Subsequent the ray data belonging to this pixel follows indicated with the keyword PATH for each
available propagation path.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.750

Figure 748: Result file with detailed ray information in ASCII format.

Urban or Indoor Propagation Scenario
The possible combinations of the data contained in an ASCII ray file are given in the following:

POINT 0.0 -43.2 1.5 0

PATH 169.25 78.27 0 0 0 0 0.18 0.15 1.67 3.28 1.44 2.1 *

Figure 749: Channel impulse response.

POINT 0.0 -43.2 1.5 0

PATH 169.25 78.27 0 0 0 0 0.18 0.15 1.67 3.28 1.44 2.1 *

... -4.8e-6 -7.1e-6 2.2e-7 3.5e-7 2.6e-7 3.9e-7 -6.5e-7 -9.3e-7

... 4.2e+3 6.2e+3 -8.6e+2 -1.3e+3 8.3e+3 1.2e+4 -1.1e+2 -1.6e+2 1.3e+3 1.8e+3 -4.5e+2 -6.7e+2

Figure 750: Channel impulse response with transmission matrix.

POINT 0.0 -43.2 1.5 0

PATH 169.25 78.27 0 2 0 0 0.18 0.15 1.67 3.28 1.44 2.1 * 7.20 4.80 2.46 T 28 7 6.48 0.00 2.36 R 208 4

... -4.8e-6 -7.1e-6 2.2e-7 3.5e-7 2.6e-7 3.9e-7 -6.5e-7 -9.3e-7

... 4.2e+3 6.2e+3 -8.6e+2 -1.3e+3 8.3e+3 1.2e+4 -1.1e+2 -1.6e+2 1.3e+3 1.8e+3 -4.5e+2 -6.7e+2

Figure 751: Path data with transmission matrix.

Note:  * Doppler shift is only written in case of time-variant projects, either using a time-
variant database or a trajectory with velocity profile (then after RunMS).
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Coordinates of evaluation pixel (x, y, z) [m]

Coordinates of interaction point (x, y, z) [m]

Delay of path [ns]

Field strength [dBµV/m]

Type of path 0 = deterministic, 5 = empirical []

Number of interactions [#]

ID of pixel Unique ID []

ID of path Unique ID []

Phase of ray [rad]

Direction of Departure (DoD) (azimuth, elevation) [rad]

Direction of Arrival (DOA) (azimuth, elevation) [rad]

Doppler shift* [Hz] Doppler shift is only written in case of time-variant projects, either using a time-variant 
database or a trajectory with velocity profile (then after RunMS).

Type of interaction D = diffraction, R = reflexion, T = transmission []

ID of object where interaction occurs Unique ID []

ID of material at the interaction point Unique ID []

Transmission matrix Tvv Re{Tvv} Im{Tvv} []

Transmission matrix Tvh Re{Tvh} Im{Tvh} []

Transmission matrix Thv Re{Thv} Im{Thv} []

Transmission matrix Thh Re{Thh} Im{Thh} []

Electric field strength vector component Ex
(vertical)

Re{Ex} Im{Ex} [µV/m]

Electric field strength vector component Ey
(vertical)

Re{Ey} Im{Ey} [µV/m]

Electric field strength vector component Ez
(vertical)

Re{Ez} Im{Ez} [µV/m]

Electric field strength vector component Ex
(horizontal)

Re{Ex} Im{Ex} [µV/m]

Electric field strength vector component Ey
(horizontal)

Re{Ey} Im{Ey} [µV/m]

Electric field strength vector component Ez
(horizontal)

Re{Ez} Im{Ez} [µV/m]

Figure 752: Data contained in an ASCII ray file.

Note:  Ray data cannot be displayed in combination with path loss results.

Rx Power

Rx Power of Base Station and Mobile Station
The Rx Power results for both base station and mobile station provide values of the maximum power
which is received directly at the receiver. These values are determined taking into account the
maximum possible power of the transmitting station, no power control algorithms are considered.
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Note:  Rx Power results for the base station refers to the power received directly at the
receiver and not to the power received at the antenna. In the case that a cable loss is
defined, the received power at the antenna is reduced by this additional loss. 

Figure 753: An antenna and base station receiver scenario.

Signal-to-Noise-and-Interference-Ratio (SNIR)

Signal-to-Noise-and-Interference-Ratio at Base Station and Mobile Station
The SNIR results at both base station and mobile station are determined taking into account the
maximum possible power of the transmitting station, as well as the maximum possible noise and
interference power of the system. This means no power control algorithms are considered.

Convert SNIR to BER
Convert a SNIR plot to a Bit Error Rate (BER) plot.

Note:  This option is only available for network-planning results.

To obtain a BER plot, do the following:

1. Display the SNIR plot you wish to convert.
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Figure 754: An example of a SNIR plot.

2. Click Edit > Convert SNIR to BER.

3. Specify a text file that contains two columns with the following information:

a. Column 1: SNIR in dB

b. Column 2: 10-based log of the corresponding Bit Error Rate

For example:

*SNIR [dB] BER log[dB]
0.0  -0.30
5.0  -0.47  
11.0  -1.00
15.0  -2.00
18.0  -3.50
20.0  -5.30
21.0  -6.50
22.0  -7.90
23.0  -9.70
24.0  -12.00

For instance, at a SNIR of 21 dB, the Bit Error Rate for this transmission mode is 10-6.5 ≈ 3.2×10-7.
Since the BER curves depend on many parameters, you need to provide the table for the transmission
mode of interest.
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Figure 755: An example of a BER plot (converted from a SNIR plot).

Tx Power

Tx Power of Base Station and Mobile Station
The Tx power results for both base station and mobile station provide values of the minimum power
which is needed to establish a radio link to the corresponding receiver. These values take into account
power control algorithms of the evaluated system and consider always the output power of the power
amplifier.

EMF/EMC Results
The results for human exposure to electromagnetic fields (EMF) and for electromagnetic compatibility
(EMC) are displayed in the tree, below the Propagation and Network results.

Figure 756: The EMF and EMC results in the tree.
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Both the EMF results and the EMC results are governed by the specifications provided in the .emc file,
which can be defined at Data > EMC Specification, see Figure 757.

Figure 757: The EMC Specification dialog.

Figure 757 is for both EMF (human exposure) and EMC. It enables you to specify frequency-dependent
exposure limits according to multiple standards and multiple frequency bands. The exposure limit (for
electric field) is in V/m and the frequency is in MHz.

The EMF results show if and where human-exposure limits are exceeded, see Figure 758.

Figure 758: Example of an EMF result plot for human exposure.

The EMC results show the location-dependent field strengths. Fields from multiple antennas are
combined in principle according to

(106)

with one exception. If the strongest two or three signals at a given location, received from the same
transmitter site, differ by less than 150 MHz in frequency, then the signals are added according to

 under the  sign in order to account for the possibility that they might be almost in
phase.
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Doppler Analysis
Doppler analysis is mainly used to obtain insight in the results of automotive radar simulations, where
Doppler shift is critical in subsequent signal processing.

Doppler Shift / Doppler Shift (3D)
To obtain a plot, do the following:

1. In the results tree, select Power (MS) or Power. These are the power received by the receiver
antenna and the power received by a hypothetical isotropic antenna, respectively.

2. Select the time step of interest (if it was a time-variant simulation).

3. Click Display > Doppler Analysis and select one of the following:

• Doppler Shift

◦ Hover the cursor over the result pixel of interest for Doppler shift.

Figure 759: A graph showing for all contributing rays the Doppler
shift along the horizontal axis and the power along the vertical axis.

• Doppler Shift (3D)

◦ Click on the pixel of interest. In an automotive radar simulation, there is often just one
result pixel, located at the radar position.

Tip:  Zoom in if needed to view the result pixel.
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Figure 760: A 3D plot showing for all contributing rays the Doppler shift and the
signal delay along the two horizontal axes and the power along the vertical axis.

Doppler Heat Map
Plot radar results as a heat map, with range and relative velocity along the axes and signal strengths as
colors. To obtain a Doppler Heat Map, do the following:

1. In the results tree, select Power (MS) or Power. These are the power received by the receiver
antenna and the power received by a hypothetical isotropic antenna, respectively.

2. Click Display > Doppler Heat Map.

3. Click on the radar pixel to generate the heat map.

4. [Optional] Activate/deactivate the legend on the plot by right-clicking on the plot and click
Settings > Layout and select/clear the Display Legend check box.
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Figure 761: A heat map for the radar channel profile with range and velocity along the axes.

Signal Processing
Produce a heat map and/or IQ Data with the same algorithms that FMCW signal processing equipment
would use, to visualize the effects of limitations in such algorithms and/or optimize the parameters in
such algorithms.

FMCW Signal Processing
To obtain such a heat map and/or IQ Data, do the following:

1. In the results tree, select Power (MS) or Power. These are the power received by the receiver
antenna and the power received by a hypothetical isotropic antenna, respectively.

2. Click Display > FMCW Radar.
3. Click on the radar result pixel.

4. On the FMCW Radar Postprocessing dialog, specify the parameters.

You can specify the radar parameters using two modes, either with Set Radar Parameters or Design
Radar Parameters.

Set Radar Parameters
You can specify the following radar parameters:

• Chirp duration
The sawtooth chirp sweep period in μs. It has an impact on the maximum measurable

velocity and on the velocity resolution[41] of the radar.

41. Velocity resolution is the ability to resolve two objects having close velocities (they show up as two
peaks in the heat map).
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• Sweep Bandwidth
The difference between starting and final frequency of a chirp. It has an impact on the

maximum measurable range and on the range resolution[42] of the radar.

• Number of Chirps
The number of chirps in one frame. It has an impact on the velocity resolution.

• Frequency Bins
The number of FFT samples in one chirp. It has an impact on the maximum detectable range.

Design Radar Parameters
You can specify performance quantities like the desired range, range resolution, maximum velocity, and
velocity resolution. It will calculate/design the radar parameters (for example, chirp duration, sweep
bandwidth, number of chirps, and FFT samples) that can satisfy the required performance quantities.

Output
You can specify the desired output and optionally the type of windowing function. Windowing functions
are applied in the time domain to suppress the side lobes in the frequency domain. They are also used
to detect low signals that could be hidden beneath the side lobe of another target.

The output options are:

• Doppler-Range Heat Map

• Angle-Range Heat Map

• IQ Data.

The Doppler-Range Heat Map shows the processed signal as a function of range and relative velocity.

The Angle-Range Heat Map shows the processed signal as a function of range and angle of arrival.

For the angle of arrival estimation plots, the following requirements need to be satisfied:

• The receiver antenna type must be a Uniform Linear Array with number of receiving elements > 1.

• The array azimuth angle needs to be set correctly, for example, in case of simulating an automotive
radar, the antenna array must be aligned horizontally with radar car's bumper.

• The horizontal spacing between the Rx elements must be  (  corresponds to maximum angular

field of view ±90° where  represents the wavelength).

To obtain an accurate angle estimation, the following recommendations apply:

• Use a large number Rx elements. For N receiving elements (with antenna spacing of ), the

angular resolution can be calculated as follows: .

• Apply a window function to reduce the ripples caused by zero padding in the angle-FFT. The angle-
FFT was processed using zero-padding to improve the angle estimation accuracy.

42. Range resolution is the ability to resolve two closely spaced objects (they show up as two peaks in
the heat map).
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If a heat map is chosen, it will be plotted. If IQ Data is selected, it is written to disk in ASCII format for
external signal processing.

Figure 762: A snapshot in a time-variant simulation and an example of a heat map produced
by FMCW processing. This heat map shows not only the range and relative velocities, but

also the artifacts produced by the signal-processing algorithm with user-defined parameters.
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6.6 Addenda

6.6.1 Indoor 3D Objects: Material Properties
Indoor vector buildings can be modeled using individual material properties for each 3D object.

All defined settings for the individual materials can be edited in the WallMan application. Material
parameters, which do not affect the pre-processing of a database can be edited in ProMan as well.

Databases with the following file extension support the edit functionality for the material properties in
ProMan at the moment:

• .idb

• .idc

• .idi

• .idp

• .idw

View the material table in ProMan, which lists all materials defined for a database, by clicking Edit >
Edit Material Properties. Alternatively, click Project > Edit Material Properties.

Figure 763: The Material Catalogue dialog.

Show & modify
Open the Material Properties dialog for a selected list entry to view or edit the material
parameters.
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Save changes
Save the material table to a material catalogue file (.mcb) to import all or selected material
definitions into other building databases.

Note:  The import of material definitions from a material catalogue file is only possible in
WallMan.

After selecting a material from the material list by double clicking on a list item, the Material
Properties dialog opens, where the settings of the selected material can be changed.

Figure 764: The Material properties dialog.

Name
Arbitrary name of the material.

Propagation Phenomena
The consideration of propagation phenomena (diffraction, reflection, transmission) in ray-
tracing simulations can be enabled or disabled for each material individually. These settings are
considered during pre-processing for the ray-tracing propagation models and therefore can not be
changed in ProMan.
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Note:  These settings can only be changed in WallMan before pre-processing.

Thickness
Thickness of the material. Only relevant for visualization and for computation with Fresnel
coefficients.

Simplification
Allow or prohibit simplification of polygonal objects with this material.

Note:  This option can only be changed in WallMan.

Electrical Properties
Electrical properties of the material for different frequency bands.

Note:  During the prediction, the properties of the nearest defined frequency is used
for a material.

Color of Material
Display options for the material. The color of the objects with this material can be specified here.
Besides this, objects with this material can be enabled or disabled for drawing filled or drawing at
all on the display.

Select a frequency under electrical properties and click on Edit to get the frequency dependent material
properties as given in the following dialog:

Figure 765: The Frequency Dependent Material Properties dialog.

Frequency
Frequency for the specified material properties.
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Note:  During the prediction, the material properties of the nearest defined frequency
is used.

Parameters for empirical transmission/reflection/diffraction/scattering model
Attenuation values for the different propagation phenomena, which are used for the empirical
transmission / reflection / diffraction / scattering model during ray tracing simulations.

Parameters for Fresnel Coefficients (Transmission, Reflection) and GTD/UTD (Diffraction)
Material parameters for calculating attenuations using Fresnel coefficients (transmission,
reflection) and GTU / UTD (diffraction) during ray-tracing simulations.

6.6.2 Rural 3D Objects: Material Properties
Rural topography, clutter and building vector objects can be modeled using individual material
properties for each 3D object.

View and Edit Material Properties
Rural topography, clutter and building vector objects can be modeled using individual material
properties for each 3D object. The assigned material properties are stored in a material database, which
is part of the rural vector database.

All defined settings for the individual materials can be edited in ProMan and WallMan.

To view the material table in ProMan, which lists all materials defined for a database, click Edit >
Edit Material Properties or by clicking on the Project > Edit Project Parameter and click on the
Database tab.

Figure 766: The Vector Database dialog.

To import materials in WallMan, click Edit > Materials > Import.
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Figure 767: The Import material from catalogue dialog in WallMan.

Show & modify
Open the Material Properties dialog to view or edit the material parameters for the selected
material.

Save changes
Save the material table to a material catalogue file (.mcb), which makes it possible to import all
or only selected material definitions into other building databases.

Note:  The import of material definitions from a material catalogue file is only possible
in WallMan.

After selecting a material from the material list by double clicking on a material, the Material
Properties dialog opens, where the settings of the selected material can be changed.
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Figure 768: The Material Properties dialog.

Name
Arbitrary name of the material.

Propagation Phenomena
The consideration of propagation phenomena (diffraction, reflection, transmission) in ray-
tracing simulations can be enabled or disabled for each material individually. These settings are
considered during pre-processing for the ray-tracing propagation models and therefore cannot be
changed in ProMan.

Note:  These settings can only be changed in WallMan.

Thickness
Thickness of the material. Only relevant for visualization and for computation with Fresnel
coefficients.

Restrictions
Allow or prohibit simplification of polygonal objects with this material.

Note:  This option can only be changed in WallMan.

Electrical Properties
Electrical properties of the material for different frequency bands.
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Note:  The nearest defined frequency for a material is used during the prediction.

Frequency depending properties of a material can be edited with the following dialog:

Figure 769: The Frequency Depending Material Properties dialog.

Frequency
Frequency for the specified material properties.

Note:  The nearest defined frequency for a material is used during the prediction.

Parameters for empirical transmission/reflection/diffraction model
Attenuation values for the different propagation phenomena that are used for the empirical
transmission / reflection / diffraction model during ray-tracing simulations.

Parameters for Fresnel coefficients and GTD / UTD model
Material parameters for calculating attenuation using Fresnel coefficients (transmission, reflection)
and GTU / UTD (diffraction) during ray-tracing simulations.

6.6.3 Definition of Carriers
Carrier settings can be specified by clicking Project > Edit Project Parameter... and clicking on the
Air Interface tab. ProMan offers the possibility to use multiple carriers in different frequency bands
within a network project. At least one carrier has to be defined to simulate a wireless radio network.
However, it is not possible to assign multiple carriers to a single cell.

For defining one or multiple carriers, you have to specify the channel bandwidth, the carrier separation
(only relevant if multiple carriers are defined) and the corresponding center frequencies. The bandwidth
of the channel is used for calculation of thermal noise. Frequency separation of two adjacent carriers
is used to determine adjacent or co-channel interference. Depending on the chosen duplex separation
mode (separation of downlink and uplink) one or two frequencies have to be defined for a carrier.

The following figure shows the carrier definition for a radio network with frequency separated uplink and
downlink channels.
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Figure 770: Carrier definition - frequency separated uplink and downlink.

The following figure shows the carrier definition for a radio network with time separated uplink and
downlink channels.

Figure 771: Carrier definition - time separate uplink and downlink.

Click Add to specify the number of carriers to be created and the center frequency of the first downlink
carrier. The chosen amount of carriers are created automatically using the specified channel bandwidth
and carrier separation.

For duplex separation mode FDD, the defined uplink and downlink separation is taken into account to
determine the center frequencies used for the uplink.
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For duplex separation mode TDD, only downlink carriers have to be defined as up- and downlink are
separated in time. Carriers which are set available can be selected in the Carrier Assignment dialog,
whereas inactive carriers are not displayed.

Definitions can be edited and deleted after selecting a carrier from the list.

The following color scheme is used for carriers:

• Green
Available / active carriers

• Red
Unavailable / not active carriers

Figure 772: The Carrier dialog.

6.6.4 Modulation and Coding (CDMA)

Modulation and Coding Schemes (MCS) for CDMA/WCDMA/HSPA Systems
To view a list with the currently defined MCS, click Project > Edit Project Parameter and click the
Air Interface tab. Further transmission modes can be defined, existing ones can be adapted during the
planning process. The defined transmission modes can be sorted considering various criteria. The order
of the MCS does not influence the simulations but the sequential arrangement in the tree view and on
the dialogs.
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Figure 773: The Transmission Modes (MCS) dialog.

To define the transmission mode parameters of a CDMA / WCDMA / HSPA system, double-click on an
item in Figure 773. The settings can be specified for the downlink (BS to MS) and the uplink (MS to BS)
direction separately.

Figure 774: The Transmission mode dialog.

Name
Arbitrary name for transmission mode.
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Direction to be analyzed
Downlink and uplink directions can be analyzed individually for each transmission mode. It is
possible to analyze transmission modes for Only Downlink or for Only Uplink without the
influence of the other direction.

Consider mode during simulation
If this option is enabled, the transmission mode is considered during network planning simulation.
Transmission modes which are specified to be not considered during simulation, are displayed in
red (see Figure 773).

Position of mode in simulation sequence
The position (priority) of the transmission modes affects the throughout results as the
transmission modes are analyzed according to their position value. The networks are configured
to maximize the throughput. For this purpose the transmission mode with the first position should
be analyzed first. If there are some radio resources remaining, then the transmission mode with
the second position is analyzed for checking if the throughput can be further increased and so on.
So to maximize the throughput, the transmission modes should be assigned reasonable values for
the position. Without this sorting it might happen that transmission modes with low data rates use
the available radio resources and thus the maximum throughput is not exploited.

Note:  It is not possible to have multiple transmission modes with the same position
in simulation sequence. The individual positions of the transmission modes do not
have to be consistent (gaps are possible).

Data Transmission Parameters (for downlink and uplink)

Modulation
Modulation scheme used for data transmission.

Code rate
The code rate states the portion of the total amount of information that is useful (that is
non redundant). If the code rate is k/n, k bits out of n totally generated bits are useful
information, whereas (n-k) bits are redundant. The redundant bits are used for error
detection and correction.

Spreading Factor
The spreading factor or processing gain, the ratio between chip rate and symbol rate of the
transmission mode.

Overhead ratio
Ratio between gross and net data rate.

Parallel Used Codes
Number of codes, which are used in parallel to achieve higher data rates. The defined
factor is considered for the resulting data rate, which is automatically computed in the
corresponding field.
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Note:  If multiple codes are used in parallel the own cell interference is
increased in addition to the interference due to predefined cell load. Furthermore
the required Tx power is increased. Accordingly there are limitations due to the
defined maximum Tx power of the base station and the defined Eb/N0 target for
the transmission mode. Both effects are considered in the network simulation.
The computed results shown in the result tree under the defined transmission
modes refer to the transmission of a single code, but the throughput results
depend on the number of parallel codes (increasing the data rate which is
multiplied with the number of possible streams).

Data rate (read only)
Net data rate, which is automatically computed according to the parameters specified
above.

Radio Parameters (for downlink and uplink)

Eb/N0 (min. required)
Minimum Eb / N0, which is required to use this transmission mode. Receiver locations,
where the predicted Eb /N0 is above this threshold will be assigned to this transmission
mode and the maximum available data rate for the corresponding Rx locations is set to the
value specified for this MCS.

Note:  The minimum required Eb/N0 for the uplink direction refers to the
input of the base station receiver and not to the power received directly at the
antenna. In case a cable loss is defined, the received power at the antenna
is reduced by the cable loss before it is compared to the specified minimum
required Eb/N0.

Figure 775: Antenna and Base Station Receiver scenario.
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Tx Power Back off
Power headroom which can be specified related to maximum available transmit power
of the base station (for downlink direction) or the mobile station (for uplink direction),
respectively. This headroom can be used to reduce available transmission power and
therefore crosstalk probability for high modulation and coding schemes.

Note:  This back off value influences only the transmit power used for data
transmission. The power assigned for pilot signals is not influenced.

6.6.5 Cell Assignment
The first step in the network planning computation is the cell assignment procedure. The best server for
each receiver pixel is determined based on different modes and parameters.

Cell Assignment
To specify the cell assignment parameters, click Project > Edit Project Parameters and select the Air
Interface tab.

Figure 776: The Cell Assignment dialog.

The cell assignment is made for all receiver pixels individually. For each pixel an evaluation of all
carriers from all transmitters / sites is made. A carrier is denoted with received, if the following criteria
are fulfilled:

• The SNIR criterion must always be met.

• The required received power criterion must be met.

In general several carriers are received at a certain receiver pixel. The selection which carrier / cell is
selected as serving cell can be influenced by the selection mode.

Selection Mode
If more than one carrier / cell can be received at a pixel, the selection of the serving cell is based on
this parameter. There are four different modes available:

1. Highest Rx power among the carriers received
At first the received carriers are determined based on the given criteria for SNIR and
received power (optional). From the remaining received carriers/cells the cell with the
highest received power is selected as serving cell.
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2. Highest Rx power of all carriers in the network
At first the carrier / cell with the highest received power is selected. If this carrier meets the
criteria for SNIR and received power (optional) it is taken as serving cell. If the criteria are
not met, the pixel is referred to as not served. The pixel remains not computed in the result
map.

3. Highest SNIR among the carriers received
At first the received carriers are determined based on the given criteria for SNIR and
received power (optional). From the remaining received carriers / cells the cell with the
highest SNIR is chosen as serving cell.

4. Highest SNIR off all carriers in the network
At first the carrier / cell with the highest SNIR is selected. If this carrier meets the criteria
for SNIR and received power (optional) it is taken as serving cell. If the criteria are not met,
the pixel is referred to as not served. The pixel remains not computed in the result map.

Minimum Required SNIR
This value defines the minimum required SNIR criterion. It is used to find out if a carrier from a
transmitter / site can be received or not. The value can also be negative.

Minimum Required Power
This is an optional parameter which defines the minimum required power criterion. If this parameter is
enabled, the power threshold is additionally considered for the evaluation of the received carriers.

Examples
Examples for the cell assignment are provided in the following tables. The criteria for the cell
assignment (two cells A and B considered) are:

• Minimum required SNIR: 3 dB

• Minimum required received power: -90 dBm

Table 59: Cell Assignments - Criterion.

Example 1 Example 2 Example 3 Example 4Criterion

Cell A Cell B Cell A Cell B Cell A Cell B Cell A Cell B

Received
power at
receiver
pixel

-80.0
dBm

-85.0
dBm

-80.0
dBm

-85.0
dBm

-80.0
dBm

-92.0
dBm

-80.0
dBm

-95.0
dBm

SNIR at
receiver
pixel

4.0 dB 4.5 dB 2.0 dB 4.5 dB 3.2 dB 4.5 dB 2.0 dB 4.5 dB
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Table 60: Cell Assignment - Selection Mode.

Selection Mode Serving Cell Serving Cell Serving Cell Serving Cell

Highest Rx power
among the carriers
received

Cell A Cell B Cell A not served

Highest Rx power
of all carriers in the
network

Cell A not served (SNIR
not met)

Cell A not served

Highest SNIR
among the carriers
received

Cell B Cell B Cell A not served

Highest SNIR of
all carriers in the
network

Cell B Cell B not served (rec.
power not met)

not served

Additional Results
To visualize the cell assignment and the best server, additional result output is required. Click
ProjectEdit Project Parameter... and click the Network button and select the Settings button for
Best Server (Cell Assignment)

Figure 777: The Cell Assignment and Best Server dialog.

Write no additional output
No additional ASCII output for visualization of the cell assignment will be written.

Write additional output
Write additional ASCII output for the visualization of cell assignment either only for the received
cells or for all cells of the network.

If additional ASCII output was enabled and you load a cell assignment from the tree view, you will be
asked if additional detail of the cell assignment should be loaded.

The additional information about the cell assignment, such as serving cell, received signal level and
signal-to-noise-and-interference-ratio is displayed in the Cell Assignment dialog after clicking on a
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receiver pixel with the mouse. Besides the serving cell (S), the links to the other received cells (AS), or
all cells of the network (AS and NR), are listed in the lower part of the dialog.

Figure 778: Additional Information displayed in the Cell Assignment dialog.

6.6.6 Modulation and Coding (FDMA)

Modulation and Coding Schemes (MCS) for FDMA Systems
To view a list with the currently defined MCS, click Project > Edit Project Parameter and click the
Air Interface tab. Further transmission modes can be defined, existing ones can be adapted during the
planning process. The defined transmission modes can be sorted considering various criteria. The order
of the MCS does not influence the simulations but the sequential arrangement in the tree view and on
the dialogs.

Figure 779: The Transmission Modes (MCS) dialog.

To define the trasnmission parameters of a FDMA system in ProMan, double-click on an item in
Figure 779. The settings can be specified for the downlink (BS to MS) and the uplink (MS to BS)
direction separately.
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Figure 780: The Transmission Mode dialog.

Name
Arbitrary name for transmission mode.

Direction to be analyzed
Downlink and uplink directions can be analyzed individually for each transmission mode. It is
possible to analyze transmission modes for Only Downlink or for Only Uplink without the
influence of the other direction.

Consider mode during simulation
If this option is enabled, the transmission mode is considered during network planning simulation.
Transmission modes which are specified to be not considered during simulation, are displayed in
red (see Figure 779).

Position of mode in simulation sequence
The position (priority) of the transmission modes affects the throughout results as the
transmission modes are analyzed according to their position value. The networks are configured
to maximize the throughput. For this purpose the transmission mode with the first position should
be analyzed first. If there are some radio resources remaining, then the transmission mode with
the second position is analyzed for checking if the throughput can be further increased and so on.
So to maximize the throughput, the transmission modes should be assigned reasonable values for
the position. Without this sorting it might happen that transmission modes with low data rates use
the available radio resources and thus the maximum throughput is not exploited.
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Note:  It is not possible to have multiple transmission modes with the same position
in simulation sequence. The individual positions of the transmission modes do not
have to be consistent (gaps are possible).

Data Transmission Parameters (for downlink and uplink)

Modulation
Modulation scheme used for data transmission.

Code rate
The code rate states the portion of the total amount of information that is useful (that is
non redundant). If the code rate is k/n, k bits out of n totally generated bits are useful
information, whereas (n-k) bits are redundant. The redundant bits are used for error
detection and correction.

Spreading Factor
The spreading factor or processing gain, the ratio between chip rate and symbol rate of the
transmission mode.

Overhead ratio
Ratio between gross and net data rate.

Parallel Used Codes
Number of codes, which are used in parallel to achieve higher data rates. The defined
factor is considered for the resulting data rate, which is automatically computed in the
corresponding field.

Note:  If multiple codes are used in parallel the own cell interference is
increased in addition to the interference due to predefined cell load. Furthermore
the required Tx power is increased. Accordingly there are limitations due to the
defined maximum Tx power of the base station and the defined Eb/N0 target for
the transmission mode. Both effects are considered in the network simulation.
The computed results shown in the result tree under the defined transmission
modes refer to the transmission of a single code, but the throughput results
depend on the number of parallel codes (increasing the data rate which is
multiplied with the number of possible streams).

Data rate (read only)
Net data rate, which is automatically computed according to the parameters specified
above.

Radio Parameters (for downlink and uplink)

SNIR (min. required)

Minimum signal-to-noise-and-interference-ratio, which is required to use this transmission
mode. Receiver locations, where the predicted SNIR is above this threshold will be assigned
to this transmission mode and the maximum available data rate for the corresponding Rx
locations will be set to the value specified for this MCS.
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Figure 781: Antenna and Base Station Receiver scenario.

Use additionally threshold for signal level

Optional threshold of signal level, which is required to use this transmission mode.

Note:  The specified minimum signal level for the uplink direction refers to the
input of the base station receiver and not to the power received directly at the
antenna. In case a cable loss is defined, the received power at the antenna is
further reduced by the cable loss before it is compared to the specified minimum
required signal level.

Tx Power Back off
Power headroom which can be specified related to maximum available transmit power
of the base station (for downlink direction) or the mobile station (for uplink direction),
respectively. This headroom can be used to reduce available transmission power and
therefore crosstalk probability for high modulation and coding schemes.

Note:  This back off value influences only the transmit power used for data
transmission. The power assigned for pilot signals is not influenced. 

6.6.7 Mobile Station
Parameters of the mobile user equipment can be defined.

Mobile Station
To define the parameters of the mobile user equipment, click Project > Edit Project Parameter... and
click the Air Interface tab. Under Mobile Station / Subscriber Station, click Settings to open the
Mobile/Subscriber Stations dialog.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
6 ProMan p.780

Figure 782: The Mobile/Subscriber Stations dialog.

Maximum Tx power
Maximum possible transmit power (at the output of the power amplifier) for the uplink direction.

Note:  During simulation, the uplink power limit is reduced by the fast fading margin.
Therefore, the maximum power found in the result files can be less than the specified
maximum amplifier power, even at the cell borders.

Fast Fading Margin
The parameter fast fading margin represents the difference (in dB) between the maximum
possible transmitting power and the maximum allowed transmitting power. To ensure the fast
power control to compensate for the deep fades of the radio channel, this specific headroom is
required. Appropriate values for this headroom must be determined using link level simulations
and depend on the mobile speed.

Noise Figure
This parameter defines the additional noise generated due to the receiver within the mobile
station.

Antenna Gain
Gain of transmitting antenna in dBi.

General Losses
General parameter, which can be used to model all kind of additional losses (body losses) around
a mobile station.

6.6.8 Modulation and Coding (OFDMA)

Modulation and Coding Schemes (MCS) for OFDM / SOFDMA Systems
To view a list with the currently defined MCS, click Project > Edit Project Parameter and click the
Air Interface tab. Further transmission modes can be defined, existing ones can be adapted during the
planning process. The defined transmission modes can be sorted considering various criteria. The order
of the MCS does not influence the simulations but the sequential arrangement in the tree view and on
the dialogs.
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Figure 783: The Transmission Modes (MCS) dialog.

To define the transmission mode parameters of a OFDM / SOFDMA system, double-click on an item
in Figure 783. The settings can be specified for the downlink (BS to MS) and the uplink (MS to BS)
direction separately.

Figure 784: The Transmission Mode dialog.

Name
Arbitrary name for transmission mode.
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Direction to be analyzed
Downlink and uplink directions can be analyzed individually for each transmission mode.
Accordingly it is possible to analyze transmission modes for Only Downlink or for Only Uplink
without influence of the other direction.

Consider mode during simulation
If this option is enabled, the transmission mode will be considered during network planning
simulation. Transmission modes which are specified to be not considered during simulation are
display with red (see Figure 783).

Position of mode in simulation sequence
The position (priority) of the transmission modes affects the throughout results as the
transmission modes are analyzed according to their position value. Typically, the networks are
configured to maximize the throughput. For this purpose the transmission mode with the first
position should be analyzed first. If there are some radio resources remaining (for example,
resource blocks in LTE) then the transmission mode with the second position will be analyzed
for checking if the throughput can be further increased and so on. In LTE with 5 MHz bandwidth
25 resource blocks are available for example. For a specific location in the network it might be
possible to transmit 15 streams in parallel of the transmission mode with position 1 (leading to
710.2 kBit/s per stream). If for the remaining 10 resource blocks the SNIR of the first position
is not fulfilled (as the interference for each sub-band depends on the frequency reuse in the
neighboring cells), maybe the SNIR target for the second position (with 665.9 kBit/s per stream)
is fulfilled. In this case the overall throughput would result in 15*710.2 kBit/s + 10*665.9 kBit/
s = 17,312 kBit/s.So to maximize the throughput, the transmission modes should be assigned
reasonable values for the position. Without this sorting it might happen that transmission modes
with low data rates use the available radio resources and thus the maximum throughput is not
exploited.

Note:  It is not possible to have multiple transmission modes with the same position
in simulation sequence. The individual positions of the transmission modes do not
have to be consistent (gaps are possible).

Data Transmission Parameters (for downlink and uplink)

Modulation
Modulation scheme used for data transmission.

Code rate
The code rate states the portion of the total amount of information that is useful (that is
non redundant). If the code rate is k/n, k bits out of n totally generated bits are useful
information, whereas (n-k) bits are redundant. The redundant bits are used for error
detection and correction.

Nr of Resource blocks
Number of resource blocks, which are used for this transmission mode.

Overhead ratio
Ratio between gross and net data rate.
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Data rate (read only)
Net data rate, which is automatically computed according to the parameters specified above
using the following formula:

Data rate = NrResourceBlocks * NrSubcarriers (perRB) * NrSymbols (perSlot) * NrSlots
(perSec) * NrBits (perSymbol) * CodeRate * (1 - OverheadRatio)

For example, for 5 MHz (25 RB) QPSK R=1/8 with 12% overhead:

Data rate = 25 * 12 * 7 * 2000 * 2 * 1/8 * 0.88 = 924 kBit/s.

Radio Parameters (for downlink and uplink)

Minimum required SNIR
Minimum signal-to-noise-and-interference-ratio, which is required to use this transmission
mode. Receiver locations, where the predicted SNIR is above this threshold is assigned
to this transmission mode and the maximum available data rate for the corresponding Rx
locations is be set to the value specified for this MCS.

Minimum required Signal Level (optional)
Optional threshold of signal level, which is required to use this transmission mode.

Note:  The specified minimum signal level for the uplink direction refers to the
input of the base station receiver and not to the power received directly at the
antenna. In case a cable loss is defined, the received power at the antenna is
additionally reduced by the cable loss before it is compared to the specified
minimum required signal level.

Figure 785: Antenna and Base Station Receiver scenario.

Tx power backoff
Power headroom which can be specified related to maximum available transmit power of
the base station (for downlink direction) or the mobile station (for uplink direction). This
headroom is used to reduce available transmission power and therefore crosstalk probability
for high modulation and coding schemes.
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Note:  This back off value influences only the transmit power used for data
transmission. The power assigned for pilot signals is not influenced. 

6.6.9 Frequency Division Duplex
The duplex separation of downlink (DL) and uplink (UL) is typically done either by using FDD or by
using TDD.

Air interface standards using FDD are, for example, LTE FDD or UMTS FDD. To specify the FDD
configuration of various air interfaces, click Project > Edit Project Parameter.... Select the Air
Interface tab and under Duplex Separation, click Settings.

Figure 786: The Duplex Properties FDD dialog.

Duplex Separation
Duplex separation between downlink and uplink channel in frequency duplex mode.

6.6.10 Time Division Duplex
The duplex separation of downlink (DL) and uplink (UL) is typically done either by using FDD or by
using time division duplex (TDD).

Time Division Duplex
Air interface standards using TDD are for example LTE TDD and TD-SCDMA. To specify the TDD
configuration of various air interfaces, click Project > Edit Project Parameters, click the Air
Interface tab. Under Duplex Separation, from the drop-down list, select Duplex: TDD and click
Settings.
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Figure 787: The Duplex Properties TDD dialog.

Duplex switching

Switching between downlink and uplink channel in TDD mode can be specified to be fixed or
adaptive. The adaptive mode allows switching between downlink and uplink according to the
traffic load, either with or without taking into account the guard interval. In case of adaptive
switching, always full availability is assumed for each direction (downlink or uplink). Therefore no
further specifications are required in this case.

The TDD properties specified for each cell/carrier individually radio button is active when
a 5G TDD air interface was selected when creating the project. In that case, TDD settings are
defined individually for the specified carrier in each cell. This is done on the Carrier dialog when
assigning a carrier to a transmitter. For 5G NR TDD, the Carrier dialog will offer fields for symbols
per slot (number of downlink, uplink and flexible symbols).

Transmission Blocks / Frames / Sub-Frames
Both standards (with switching points in each sub-frame or with switching points only once or
twice per frame) can be defined. Figure 787 shows the definition of 8 sub-frames completely
allocated to the downlink (DL), one sub-frame completely allocated to the uplink (UL), and
one specific sub-frame with 10:2:2 separation between DL:UL:GP where GP stands for guard
period. The resulting overall ratios for downlink and uplink allocation are automatically computed
(depending on the settings) and considered in the network simulation for each individual
modulation and coding scheme.
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Figure 788: Sketch of a sub frame.

MS : MS and BS : BS interference
Consider additional interference effects caused by other mobile stations or other base stations,
respectively.

6.6.11 Modulation and Coding (TDMA)

Modulation and Coding Schemes (MCS) for TDMA Systems
A list with all currently defined MCS can be found at Project > Edit Project Parameter and click the
Air Interface tab. Further transmission modes can be defined, existing ones can be adapted during the
planning process. The defined transmission modes can be sorted considering various criteria. The order
of the MCS does not influence the simulations but the sequential arrangement in the Tree View and on
the dialogs.

Figure 789: The Transmission Modes (MCS) dialog.

The following dialog shows the parameters which define a transmission mode of a TDMA system in
ProMan. The settings can be specified for the downlink (BS to MS) and the uplink (MS to BS) direction
separately.
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Figure 790: The Transmission Mode dialog.

Name
Arbitrary name for transmission mode.

Direction to be analyzed
Downlink and uplink directions can be analyzed individually for each transmission mode.
Accordingly it is possible to analyze transmission modes for Only Downlink or for Only Uplink
without impact of the other direction.

Consider mode during simulation
If this option is enabled, the transmission mode will be considered during network planning
simulation. Transmission modes which are specified to be not considered during simulation are
display with red text color in the Transmission Modes (MCS) list.

Position of mode in simulation sequence
The position (priority) of the transmission modes affects the throughout results as the
transmission modes are analyzed according to their position value. Typically the networks
are configured to maximize the throughput. For this purpose the transmission mode with the
first position should be analyzed first. If there are some radio resources remaining then the
transmission mode with the second position will be analyzed for checking if the throughput
can be further increased and so on. So to maximize the throughput, the transmission modes
should be assigned reasonable values for the position. Without this sorting it might happen that
transmission modes with low data rates use the available radio resources and thus the maximum
throughput is not exploited.
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Note:  It is not possible to have multiple transmission modes with the same position
in simulation sequence. The individual positions of the transmission modes do not
have to be consistent (gaps are possible).

Data Transmission Parameters (for downlink and uplink)

Modulation
Modulation scheme used for data transmission.

Code rate
The code rate states the portion of the total amount of information that is useful (that is
non redundant). If the code rate is k/n, k bits out of n totally generated bits are useful
information, whereas (n-k) bits are redundant. The redundant bits are used for error
detection and correction.

Nr of Timeslots
Number of time slots, which can be used for this transmission mode.

Overhead ratio
Ratio between gross and net data rate.

Data rate (read only)
Net data rate, which is automatically computed according to the parameters specified
above.

Radio Parameters (for downlink and uplink)

Minimum required SNIR
Minimum signal-to-noise-and-interference-ratio, which is required to use this transmission
mode. Receiver locations, where the predicted SNIR is above this threshold will be assigned
to this transmission mode and the maximum available data rate for the corresponding Rx
locations will be set to the value specified for this MCS.

Minimum required Signal Level (optional)
Optional threshold of signal level, which is required to use this transmission mode.

Note:  The specified minimum signal level for the uplink direction refers to the
input of the base station receiver and not to the power received directly at the
antenna. In case a cable loss is defined, the received power at the antenna is
additionally reduced by the cable loss before it is compared to the specified
minimum required signal level.
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Figure 791: Antenna and Base Station Receiver scenario.

Tx power backoff
Power headroom which can be specified related to maximum available transmit power
of the base station (for downlink direction) or the mobile station (for uplink direction),
respectively. This headroom can be used to reduce available transmission power and
therefore crosstalk probability for high modulation and coding schemes.

Note:  This back off value influences only the transmit power used for data
transmission. The power assigned for pilot signals is not influenced.

6.6.12 Simulation Parameters

Click Project > Edit Project Parameter or click the .

Figure 792: The Simulation parameters dialog.
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Type of Network Simulation
For radio network planning different types of simulations are available. Static simulations can be done
either with homogeneous traffic assumptions for each cell of the networks, for example, using cell
loads, or with location dependant traffic definitions. Monte Carlo Simulations use randomly distributed
users, which are generated according to location dependant traffic definitions.

Simulation Parameters

Figure 793: The Parameters of Cell Selection dialog.

Simulate Each Carrier Individually
For network projects with multiple assigned (frequency) carriers the ProMan provides the
additional option to simulate each carrier individually. In this case the results are generated for
each carrier individually (based on the individual cell assignment, assuming only the investigated
carrier is defined) plus the “superposed” results considering all defined carriers (based on the
corresponding cell assignment considering all carriers). Accordingly the “superposed” results
include the resulting value for the serving cell on each pixel (the throughputs from different
carriers are not superposed).

Maximum number of Monte Carlo simulations
Maximum number of snapshots (random samplings) during Monte Carlo simulation.

Note:  This option is only available if Monte Carlo Simulation (location dependent
traffic) check box is selected.

Draw mobile stations on screen during simulation
Draw mobile stations generated for each snapshot.

Note:  This option is only available if Monte Carlo Simulation (location dependent
traffic) check box is selected.

Selection of Mobile Stations for Cells
This option allows you to change the algorithm for the selection of mobile stations during cell
assignment. Besides a default algorithm which is implemented in WinProp, it is also possible
to implement a user-defined algorithm for the assignment of mobile stations to the cells of the
network via an open application interface.
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Selection of Mobile Stations for Cells

The algorithm for the assignment of mobile stations to the cells of the network can be
selected if user-defined algorithms are implemented. Otherwise the default algorithm
implemented in WinProp is used.

The algorithm implemented in ProMan sorts the generated mobiles and assigns them to the
cells beginning from the first one until the maximum cell load is reached. All further mobiles
are blocked.

Optionally the position (the priority) of the defined applications can be used to prioritize
mobiles during selection for cells.

The randomly generated mobiles can be sorted either according to their path loss,
independent of the actual cell load and interference situation or re-sorted after each
modification of the cell load (according to the current interference).

Reports for Traffic Analysis
During simulation with location dependant traffic different reports for additional analysis can
be stored in the result directory.

Note:  This option is only available if Static Simulation (location dependent
traffic) check box or Monte Carlo Simulation (location dependent traffic)
check box is selected.

File Formats
The desired file format for the reports can be selected depending on further
processing.

Evaluation Options
Evaluation details can be written for each defined application as well as for each
clutter class used for the location dependant traffic definition.

Number of Reports
Reports can be written either only after convergence is reached or for each iteration
step of the simulation.

Interaction between Cell Planning and Monte Carlo Simulator
Specify how to write the reports.

Cell load and traffic definitions used for interference calculations
These settings are specified on the Traffic Settings tab.

Interference Ratios
[Optional] Consider the influence of the polarization on the transmitted signals.
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Figure 794: The Interference ratios dialog.

If transmitting antennas with different polarizations (V/H or +45°/-45°) are used within the radio
network the co-channel interference depends on the polarization. Individual interference ratios
depending on the LOS/NLOS situation and the polarization relation can be defined. Orthogonal
polarization means 90° difference (for example, V and H for the two considered antennas) and
different polarization means 45° difference (for example,V and +45° for the two considered
antennas).

6.6.13 Navigation in 3D View
The 3D view can be controlled using the operational controls (buttons) within the 3D view window as
well as with the mouse.

Click Total View (top-right corner of the 3D view) to reset the view perspective to the initial state
(zoom to extents). The current view perspective is stored by clicking the Store button (top-right corner
of the 3D view).

To recall a stored view perspective, select the stored view from the drop-down list. Delete a previously
stored, view perspective by clicking Delete. All stored view perspectives are written to file after
closing the 3D view or the current document. This file is stored in the result folder of the corresponding
document and is automatically reloaded when the 3D view is activated.

Navigation in 3D View
Result data can be shifted, rotated and zoomed in 3D view by using the mouse. The following figures
show the available operations:

Table 61:  Available operations in the 3D view.

Shifting

Move the mouse while pressing the left mouse button to shift the view in a certain
direction.

Rotating
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Move the mouse while pressing the right mouse button to rotate the view.

Zooming

Scroll the mouse wheel up/down to zoom in/out.

6.6.14 Histograms

Histogram of Values
Click Analysis > Display Histogram of Values (absolute). From the sub menu, you can select
whether:

• the histogram is to be determined for all prediction planes and all horizontal layers

• for prediction planes and surfaces only

• for all horizontal prediction planes

• for the currently active horizontal prediction plane

• for the zoomed area of the currently active horizontal plane

After selecting the area to be evaluated, you have specify the quantization interval to be used to
discretize the result data.

Example
The following example shows a histogram of an angular spread prediction in an urban environment:

Figure 795: Example of a histogram of an angular spread prediction in an urban environment.
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6.6.15 Values Along a Line
Result data can be evaluated along arbitrary lines within the simulation area.

Arbitrary sampling distances can be selected. You can draw a line between two points with the mouse.

Click Analysis > Display values along a line or the  icon, click the left mouse button and keep the

mouse button pressed until the end of the line is reached.

Another option is to draw a line using the transmitter location for the first point of the line. Click

Analysis > Display values along a line (from transmitter) or click the  icon, you have the

choice to define the second point of the line with the mouse or to enter the coordinates in a dialog.

Example
This example show the predicted path loss on a line between two points of the simulation area:

Figure 796: Example of prediction values along a line.
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7 Methods

WinProp includes empirical and semi-empirical models (calibration with measurements possible),
rigorous 3D ray-tracing models as well as the unique dominant path model (DPM).

This chapter covers the following:

• 7.1 Propagation Models  (p. 796)

Besides the prediction of the path loss, the delay and angular spread can be computed as well as LOS /
NLOS, directional channel impulse response, angular profile and propagation paths.
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7.1 Propagation Models
Propagation models differ based on their assumptions, prediction accuracy and computational
resources. Select an appropriate propagation model for the application.

7.1.1 Motivation for Different Propagation Models
For the installation of mobile radio systems, wave propagation models are necessary to determine
propagation characteristics for any arbitrary configuration. The predictions are required for proper
coverage planning, the determination of multipath effects as well as for interference and cell
calculations, which are the basis for the high-level network planning process. In a GSM/DCS-system,
this planning process includes, for example, the prediction of the received power to determine the
parameter sets of the base stations. With the introduction of wireless broadband services in third
generation systems (UMTS) or wireless local area networks (W-LAN) the wideband properties (for
example, delay spread, angular spread, and impulse response) of the mobile radio channel are
important for the planning process.

The environments where these systems are intended to be installed are ranging from indoor to large
rural areas. Hence wave propagation prediction methods are required covering the whole range of
macro-, micro- and pico-cells including indoor scenarios and situations in special environments such as
tunnels or along highways.

Figure 797: Environments for the definition of different cell types.

Four basic mechanisms generally describe the phenomena that influence radio wave propagation:

1. reflection

2. diffraction

3. penetration

4. scattering

For the practical usage of propagation models in real scenarios, these mechanisms must be described
by approximations. This requires a multistage modeling process.
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In the first step, the propagation environment is digitized to create a database suitable for propagation
modeling. For the prediction of macro-cells the database includes terrain height information and land
usage data. For urban environments building shape, height information and building surface are taken
into account. Different types of databases with various resolutions and accuracy are used according to
the specified scenario. Investigations have been focused on proper techniques to consider the relevant
information in a time-efficient manner. Therefore easy format descriptions are applied, and various data
converters are available.

The second step is the definition of mathematical approximations for the physical propagation
mechanisms. These topics are described in the sections that follow. Basic problems such as the
diffraction around a non-perfectly conducting wedge, representing a building corner and the modeling of
propagation over rooftops are addressed.

Based on the solutions for the basic problems both deterministic and empirical approaches have been
developed and implemented for the various environments, which is the third modeling step.

In the different environments, distinctions of the propagation models are required both in terms of the
dominant physical propagation phenomena and the specification of the utilized database describing
the considered scenario. All models dedicated to the same environment and cell type are treated in
separate sections. As the definition of cell types is not unique in literature, the cell type definition used
in this documentation is explained in more detail.

In large cells and small cells the base station antenna is usually installed above the average rooftop
level of the surrounding buildings. Therefore the path loss is determined mainly by diffraction at
rooftops, and as a result, the main rays propagate above the buildings. Contrary to this scenario for
micro cells, the base station antennas are mounted below the rooftop level of the surrounding buildings.
In this case wave propagation is determined by diffraction around and reflection from buildings which
could lead to wave guiding effects in street canyons. Pico cells are applied to provide indoor coverage or
to cover very small outdoor areas. In any case, the base station antenna of a pico cell is mounted inside
a building or well below rooftop level where outdoors. An overview of the different cell types and their
description is provided in Table 62.

Table 62: Definition of different cell types.

Cell Type Typical Cell
Radius

Typical Position of a Base Station Antenna

macro cell (large cell, terrain) 1 km to 30 km outdoor, mounted above medium rooftop level,
heights of all surrounding buildings are below base
station antenna height

mini cell (small cell,
suburban)

0.5 km to 3 km outdoor, mounted above medium rooftop level,
heights of some surrounding buildings are below
base station antenna height

micro cell (small cell, urban) up to 1 km outdoor, mounted below medium rooftop-level,
heights of some surrounding buildings are above
base station antenna height
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Cell Type Typical Cell
Radius

Typical Position of a Base Station Antenna

pico cell (indoor) up to 500 m indoor or outdoor (mounted below rooftop level)

7.1.2 Terrain Models
Different models for macro-cellular prediction exist with differing accuracy and computational resource
requirements.

In macro-cellular prediction models, the forward propagation including multiple diffractions over terrain
and buildings are computed. Scattering and reflection from hills, mountains, and buildings can generally
be neglected because the base station is located above the surrounding obstacles to cover a large area.
Possible applications are, for example, broadcasting transmitters or base stations in low populated
areas.

The predictions are based on the knowledge of topography, land usage and in some models also the
building height information. This section describes the different approaches to the propagation modeling
in terrain scenarios.

Figure 798 shows a typical scenario for a terrain prediction.

Figure 798: A typical scenario for a terrain prediction.

Required Databases
Topographical databases (digital elevation model or DEM) are required for the prediction of propagation.

Topographical databases consist of binary stored pixel data with an arbitrary resolution, for example,
50m x 50 m.

Note:  The resolution must be constant per database.
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Additionally, morphological data can be considered by empirical correction values to improve the
accuracy of the model. This data is also stored as binary data. The different morphological properties
are coded, for example:

• 1 for urban

• 2 for suburban

• 3 for forest

• 4 for waters

• 5 for acre

Hata-Okumura Model
The Hata-Okumura model is a simple empirical approach for macro-cellular areas with vertical
polarization. This model features a very short computation time.

The Hata-Okumura model is based on the evaluation of intensive measurements at frequencies between
200 MHz and 2 GHz with vertical polarization. The equations derived from the measurement data
require only the following four parameters:

frequency ,

the distance between transmitter and receiver ,

antenna height of the transmitter ,

antenna height of the receiver .

Figure 799 shows the definition of the effective antenna height:

Figure 799: Definition of the effective antenna height.

Because of the calibration with measurement data the Hata-Okumura model is restricted to the
following ranges for the different parameters:

(107)

(108)

(109)
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(110)

The basic transmission loss in urban areas is then computed according to the following formulas. There
is an equation for the basic loss and different correction terms according to different propagation
environments (dense urban, suburban and open):

(111)

where for suburban areas

(112)

For urban areas ( ):

(113)

For urban areas ( ):

(114)

In addition to the formulas for the urban case, there are some modifications for rural (village) and open
areas (acre). This leads to the following equations:

(115)

(116)

These formulas describe the wave propagation assuming a flat terrain because the terrain profile
between the transmitter and the receiver is not taken into account. If there is, for example, a hill
between the transmitter and receiver, the results will not be affected. In addition, local effects around
the receiver are neglected (for example, reflection or shadowing).

COST 231 has extended the Hata-Okumura model to the frequency band between 1500 MHz and 2000
MHz by analyzing Okumura's propagation curves in the upper-frequency band. This combination is

denoted as the “COST-Hata-Model”[43]:

43. E. Damosso, ed., Digital Mobile Radio: COST 231 View on the Evolution towards 3rd Generation
Systems. Bruxelles: Final Report of the COST 231 Project, published by the European Commission,
1998.
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(117)

where  for medium-sized cities and suburban centers and  metropolitan centers.

Parabolic Equation Method
The parabolic equation method efficiently describes diffraction and forward-scattering processes in
inhomogeneous terrains.

Due to the limited accuracy of the empirical models, there is a need for methods which describe
diffraction and forward-scattering processes in inhomogeneous terrain, thus the effect of the terrain to
the large-scale variation. Therefore, different full wave approaches have been investigated, and one
efficient possibility is the parabolic equation method.

This method employs a numerical evaluation of the parabolic equation (PE) to compute the field
strength in a macro-cellular area based on terrain data. Because the different propagation mechanisms
(free space propagation, reflection and diffraction) are implicitly considered this model is very accurate.
Due to the sophisticated algorithm, the computation time is quite long in comparison to the empirical
models.

Basic Principles
Figure 800 shows the vertical terrain section and the computation domain of the PE model.

Figure 800: Vertical terrain section and computation domain.

Neglecting backward propagation and assuming a rotationally symmetric problem, a partial differential
equation of parabolic type out of the Maxwell equations can be derived:

(118)

(119)
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This so-called standard parabolic equation (SPE) leads to valid results if the propagation angle with
respect to the horizon is in the range, –15° to 15°. Therefore the PE must not be used in the vicinity of
the transmitter.

A finite difference technique solves the PE in the computation domain using an iterative method. In
WinProp the required start field at  is computed using free space propagation and a single ground
reflection ray.

Absorbing Media
As the implementation of a transparent boundary condition at the top of the computation domain
yielded to high computation times, an absorbing medium is used instead to avoid reflections at the
upper boundary. Having a width of about  wavelengths, the absorbing medium works well for
all frequencies if an adequate distance  to the highest terrain point is assumed.

The prediction plot in Figure 801 shows the field in the artificial absorbing medium above the dotted
line.

Figure 801: Sample prediction (945 MHz, vertical terrain section).

Impedance Boundary at the Ground
For all parabolic equations calculations, the conductivity and dielectric permittivity of the ground surface
is taken into account. Three variations how to model the impedance boundary condition are presented
here.

1. Discrete terrain approximation

A step-like height profile is assumed in Figure 802, which leads to the simplified Leontovich
boundary condition.

(120)

(121)
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Figure 802: Step-like height profile approximation.

Due to numerical instabilities of this method, the radial step size  of the computation grid is
reduced at down-sloping ground automatically.

2. Continuous terrain approximation

By setting appropriate values for the complex wave number , the ground is modeled as if it is a
part of the atmosphere. Together with a variable step size  this approach is very robust but
does not match the boundary condition exactly because abrupt alterations of the atmospheric
medium are not allowed when using the parabolic approximation.

3. Terrain profile approximation with coordinate transformation

Another possibility to prevent numerical instabilities is the transformation of the irregular
computation domain to a rectangular area as shown in Figure 803 for down-sloping ground.

Figure 803: Transformation of the computation domain.

Therefore the coordinate transformation

(122)

(123)

(124)

Because of the distortion of the computation grid, the transformation should only be used for
slight hilly terrains.
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Wide Angle Parabolic Equation
The disadvantage of the small valid propagation angle of the standard parabolic equation can be
remedied if an extended parabolic approximation of the Maxwell equations is used.

Therewith propagation angles up to about 40° are acceptable. The additional terms do hardly prolong
the computation time and thus the wide angle PE should be preferred.

Comparison between the Hata-Okumura and Parabolic Equation
Models
Differences between the Hata-Okumura and parabolic equation models are exemplified in the prediction
of shadowing.

Figure 804 and Figure 805 show the two prediction results (Hata-Okumura model and parabolic
equation model):

Figure 804: Hata-Okumura model prediction.

Figure 805: Parabolic equation model prediction.
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Figure 806 and Figure 807 show the height profile and the difference of the two prediction results

Figure 806: Height profile for the prediction.

Figure 807: Difference plot between the two models.

When looking at the difference plot with consideration of the height profile, the parabolic equation
model accounts much better for shadowing effects as they occur in valleys. On the other hand, the
Hata-Okumura model is too pessimistic in cases where both the transmitter and the receiver are located
on hills.
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Further Approaches
Approximate the terrain profile in large with simple geometrical objects, use ray optical methods or use
empirical models for improved accuracy.

There are further approaches to the prediction of the field strength in large areas based on
topographical databases.

Replacement Obstacles Technique
Simple geometrical objects represent the terrain profile. An approximation of the terrain profile is
obtained by replacing the terrain obstacles by absorbing cylinders, wedges or knife edges depending on
the elevation curve considered. This leads to a so-called “replacement obstacles” technique. Hence the
propagation is described as multiple diffraction phenomena where reflections are neglected.

Figure 808: Replacement of the terrain profile by obstacles.

Ray-Optical Methods (Ray Tracing) Using GTD/UTD
For these objects, expressions exist to compute the UTD diffraction coefficients. For efficient
computations, algorithms for the multiple diffractions calculation are derived. Forward scattering
processes can be considered heuristically.

Empirical Models Considering the Shape of the Individual Obstacles
Based on measurement data and the dominant path above the path loss can be calculated taking the
obstacles into consideration. An additional consideration of morphological data is possible by empirical
correction factors depending on land usage. Models based on the replacement of the terrain profile by
obstacles are available in ProMan.

7.1.3 Urban Models

Motivation for Different Urban Models
Radio transmission in urban environments is subject to strong multipath propagation. Characterization
of the multipath propagation is performed by means of several empirical models.

The design and implementation of personal communication systems require the prediction of wave
propagation related to signal-to-noise and signal-to-interference calculation in a cellular system.
Small cell network configurations, especially micro and pico cell types, are of major interest in urban
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environments because of the increasing capacity demands. The commonly used criteria for the
definition of a micro cell is related to the height of the base station antenna. For a typical micro cell, the
base station antenna height is below the average rooftop level of the surrounding buildings or about
the same height. Thus the resulting cell radius is in the range of 250-500m. A further characteristic is a
low transmit power. However, a prediction range up to several kilometers has to be taken into account
for inter-cellular interference calculations. A pico cell base station is usually installed inside a building
providing coverage also outside around the building.

Figure 809: Propagation scenario in a typical urban environment.

Radio transmission in urban environments is subject to strong multipath propagation (see Figure 809).
Dominant characteristics in these scenarios are reflection, diffraction, shadowing by discrete obstacles
and wave guiding effects in street canyons. To consider these effects in a propagation model, it is
necessary to gain knowledge of all dominant propagation paths. These paths depend primarily on the
base station antenna height with respect to the surrounding building heights.

For simplification of propagation modeling, several two-dimensional empirical models have been
developed under the assumption of over-rooftop propagation as the main propagation mechanism. The
model according to Walfisch-Ikegami with extensions from the European research cooperation, or COST
231, is such an analytical approach with empirically based equations and correction factors.

The second group of micro-cellular prediction models are deterministic and use ray-optical methods.
They allow a site-specific, three-dimensional path loss and signal spread prediction including impulse
response for base station heights below as well as above rooftop level. Hence, a three-dimensional
description for the propagation environment including building shape and building heights has to be
incorporated. Of course, due to the three-dimensional ray-optical methods, these models require a
higher computation effort than the simplified approaches mentioned above. However, we developed a
method to accelerate this ray-optical approach by an intelligent preprocessing of the building database
which leads to computation times in the range of empirical models.

The described models are generally valid only for flat urban areas. This requires that the standard
deviation of the terrain heights is small in comparison to the standard deviation of the building heights
in the considered area. If this is not the case, the influence of terrain should be taken into account by
adequate extensions of the methods mentioned above.
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Required Databases
An appropriate database for the propagation model considered is important for accurate prediction data.

The basis for any propagation model is a database that describes the propagation environment. Micro
cell and indoor propagation modeling rely strongly on high-resolution geographical information. Most
organizations are now using high-resolution databases of the building structures in the urban area
with an accuracy in the range of 1-2m derived from aerial photography measurements. For urban
propagation, it is essential to have accurate information at least about the average height of individual
buildings, especially when base stations are operating close to rooftop height.

Figure 810: Building a database in vector format to describe the urban environment.

As micro cells are planned to increase the network capacity in urban areas, it is obvious to use building-
focused databases. To get a more accurate description of wave propagation, the building data are
stored in a vector format. Every building is modeled as a vertical cylinder with a polygonal ground plane
and a uniform height above street level. With this approach, only the propagation environment including
building vertical walls and horizontal flat roofs are considered. Also, the material properties (thickness,
permittivity, conductivity) of the building surfaces can be taken into account, which is important for
the calculation of the reflection and diffraction coefficients and also for the penetration into buildings.
Figure 810 shows an example of a data base for buildings in vector format used in ProMan.

Considering the influence of database information on prediction accuracy, it is noted in Damosso[44] that
prediction errors in micro cells of up to 15 dB were attributed to database inaccuracies arising from poor
resolution of the building data. Given the sensitivity to the terrain surface, the terrain profile should be
considered for propagation modeling if the considered area is not flat. Therefore terrain databases in
pixel format are required with resolutions about 20-30 m. This resolution is higher compared to terrain
models.

44. E. Damosso, ed., Digital Mobile Radio: COST 231 View on the Evolution towards 3rd Generation
Systems. Bruxelles: Final Report of the COST 231 Project, published by the European Commission,
1998
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Empirical COST-Walfisch-Ikegami Model
The empirical COST-Walfisch-Ikegami model considers only vertical plane propagation for faster
prediction. Accuracy is reduced but is acceptable in specific scenarios described.

The so-called empirical models (for example, the model according to Walfisch/Ikegami) consider only
the propagation in a vertical plane which contains the transmitter and receiver. For the field strength
prediction, significant parameters have to be extracted from this vertical section (for example, average
building height).

Equations containing these parameters have to be optimized and fitted to numerous measurements to
get a prediction model which is applicable in different propagation environments. The main advantage
of empirical models is their short computation time.

However, their prediction accuracy is limited because only a small number of parameters is taken into
account and the influence of the distance from the transmitter is over-emphasized. Additionally, wave
guiding effects in streets cannot be considered with an empirical approach.

The empirical model implemented in ProMan was developed in the course of the European COST 231
project by a combination of the Walfisch and Ikegami models. The model allows for improved path loss
estimation by consideration of more data to describe the character of the urban environment, namely:

• height of the transmitter 

• height of the receiver 

• mean value of building heights 

• mean value of widths of road w

• mean value of building separation b

• road orientation with respect to the direct radio path 

Figure 811: Typical propagation situation in urban areas and the
definition of the parameters used in the COST-Walfisch-Ikegami model.

However, this model is still statistical and not deterministic because only characteristic values are taken
into account for the prediction. The model distinguishes between line-of-sight (LOS) and non-line-of-
sight (NLOS) situations. In the LOS case – between the base station and mobile antenna within a street
canyon – a simple propagation loss formula different from free space loss is applied. The calibration of
this formula is done by measurements performed in European cities.

LOS case:

(125)

where the first constant is determined in such a way that  is composed of the terms, free space loss
, multiple screen diffraction loss , and rooftop-to-street diffraction loss :
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NLOS case:

(126)

(127)

(128)

The free space loss is given by:

(129)

The term  describes the coupling of the wave propagation along a multiple screen path into the street
where the mobile station is located. The determination of  is mainly based on Ikegami’s model. It
takes into account the width of the street and its orientation. COST 231, however, has applied another
street-orientation function to improve on the Ikegami model:

(130)

The orientation loss  is an empirical correction factor gained from measurements:

(131)

A scalar electromagnetic formulation of multi-screen diffraction results in an integral for which Walfisch
and Bertoni published an approximate solution for the case of base station antennas located above
rooftops. This model is extended by COST 231 for base station antenna heights below the rooftop
levels using an empirical function based on measurements. The heights of buildings and their spatial
separations along the direct radio path are modeled by absorbing screens for the determination of :

(132)

where:

(133)
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(134)

(135)

(136)

The COST-Walfisch-Ikegami model is valid in the following ranges:

(137)

(138)

(139)

(140)
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Figure 812: Prediction with the COST-Walfisch-Ikegami model in an urban area.

The model has also been accepted by the ITU-R and is included in report 567-4. The estimation of
path loss agrees well with measurements for base station antenna heights above rooftop levels. The
mean error is in the range of 3 dB, and the standard deviation is 4-8 dB. However, the prediction error
becomes larger for  close to  compared to situations where . Furthermore, the
performance of the model is poor for . The parameters b, w and  are not considered
in a physically meaningful way for micro cells. Therefore the prediction error for micro cells may be
quite large. The model does not consider multipath propagation. Therefore wave guiding effects in
street canyons are not taken into account. But in situations where the propagation over the rooftops is
dominant, the model produces good results.

Because of the calibration with measurements from European cities no parameters have to be
adjusted when using this model. However, with this empirical approach, it is not possible to predict the
wideband properties of the mobile radio channel such as the delay spread or impulse response. Further

information is available in Damosso[45].

45. E. Damosso, ed., Digital Mobile Radio: COST 231 View on the Evolution towards 3rd Generation
Systems. Bruxelles: Final Report of the COST 231 Project, published by the European Commission,
1998.
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Basics of Ray-Optical Models
Knowing the terminology and concepts of ray-optical methods aids the selection of an appropriate ray-
optical technique regarding accuracy and prediction time.

Primary Criterion for Ray-Optical Models
The mobile radio channel in urban environments is characterized by strong multipath propagation.
Dominant propagation mechanisms in these scenarios are reflection, diffraction, shadowing by discrete
obstacles and wave guiding effects in street canyons. With a ray-optical approach, it is possible to
consider these effects in a propagation model.

As smaller wavelengths (higher frequencies) are considered, the wave propagation becomes similar to
the propagation of light. A radio ray is assumed to propagate along a straight line influenced only by
refraction, reflection, diffraction or scattering. These are the concepts of geometrical optics (GO). The
criterion taken into account for this modeling approach is that the wavelength should be much smaller
in comparison to the extents of the considered obstacles (buildings for urban environments). At the
frequencies used for mobile communication networks, this criterion is sufficiently satisfied.

Specular Reflection
Specular reflection phenomena are the mechanism by which a ray is reflected at an angle equal to the
incident angle. The reflected wave fields are related to the incident wave fields through a reflection
coefficient which can be expressed as a matrix when the full polarimetric description of the wave field is
taken into account. The most common expression for the reflection is the Fresnel reflection coefficient
which is valid for an infinite boundary between two mediums, for example, between air and concrete.
The Fresnel reflection coefficient depends on the incident wave field and upon the permittivity and
conductivity of each medium. The application of the Fresnel reflection coefficient formulas is popular,
and these equations are also applied in ProMan.

Figure 813: Specular reflection is where the incident angle is equal to the reflected angle.

To calibrate the prediction model with measurements some ray-optical software tools consider an
empirical reflection coefficient is varying with the incidence angle to simplify the calculations. Such an
empirical approach is also available in ProMan.

The reflection loss in the empirical model depends on the angle of incidence (with respect to the
perpendicular line of the wall) and the reflection loss defined in the material properties. For the
reflection loss there is a linear decrease from full reflection loss at perpendicular incidence to half of the
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loss for grazing incidence. This means the defined reflection loss is used for perpendicular incidence and
half of the loss for grazing incidence.

Figure 814: The reflection loss depends on the angle of incidence with respect to the perpendicular line of wall.

Diffraction
The diffraction process in ray theory is the propagation phenomena which explain the transition from
the illuminated region to the shadow regions behind a corner or over rooftops. Diffraction by a single
wedge can be solved in various ways: empirical formulas, perfectly absorbing wedge, geometrical
theory of diffraction (GTD) or uniform theory of diffraction (UTD). The advantages and disadvantages
of using either formulation are difficult to address since it may not be independent of the environments
under investigation. However reasonable results are possible with either formulation. The various
expressions differ mainly in the approximations being made on the surface boundaries of the wedge
under consideration. One major difficulty is to express and use the proper boundaries in the derivation
of the diffraction formulas. Another problem is the existence of wedges in real environments - the
complexity of a real building corner or the building’s roof illustrates the modeling difficulties.

Despite these difficulties, however, diffraction around a corner or over rooftops are commonly modeled
using the heuristic UTD formulas since they are well behaved in the illuminated/shadow transition
region, and account for the polarization as well as for the wedge material. Therefore these formulas are
also used in ProMan to calculate the diffraction coefficient.

Multiple Diffraction
For the case of multiple diffractions, the complexity increases dramatically. In the case of propagation
over rooftops, the result of Walfisch and Ikegami has been used to produce the COST-Walfisch-Ikegami
model. One method frequently applied to multiple diffraction problems is the UTD. The main problem
with straightforward applications of the UTD is in many cases one edge is in the transition zones of the
previous edges. Strictly speaking, this forbids the application of ray techniques, but in the spirit of the
UTD, the principle of local illumination of an edge should be valid. At least to some approximate degree,
a solution can be obtained which is quite accurate in most cases of practical interest.

The key point in the theory is to include slope diffraction, which is usually neglected as a higher order
term in an asymptotic expansion, but in the transition zone diffraction, the term is of the same order
as the ordinary amplitude diffraction terms. ProMan utilizes the UTD including slope diffraction for over
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rooftop propagation for the calculation of multiple diffractions. Also, there is an empirical diffraction
model available which can easily be calibrated with measurements.

Scattering
Rough surfaces and finite surfaces (thus surfaces with small dimensions regarding the wavelength)
scatter the incident energy in all directions with a radiation diagram which depends on the roughness
and size of the surface or volume. The dispersion of energy through scattering means a decrease of the
energy reflected in the specular direction.

One can account for the scattering process by simply decreasing the reflection coefficient. You can
do this by multiplying it by a factor smaller than one which depends exponentially on the standard
deviation of the surface roughness according to the Rayleigh theory.

To take into account the true dispersion of radio energy in various directions, one can also specify the
surface roughness.

This roughness value represents the standard deviation of a Gaussian distribution, meaning that 68%
of surface points are within plus or minus this value from the average surface height. The scattering
intensity Is at any observation point P above a rough surface S, is expressed in terms of the intensity of

the incident field Ii, through the Bidirectional Reflectance Distribution Function (BRDF)[46][47].

The BRDF, denoted ρ and expressed in sr-1, represents the spatial distribution of Is (P) and is defined
as the ratio of the scattering intensity in the direction (θs, θs) to the total incident intensity Ii in an
elementary solid angle dωi on the surface S in the direction θi (we note that ϕi = 0°). The BRDF is the
sum of three components: specular ρsr, directional diffuse ρdd and uniform diffuse  ρud (see Figure 815).

(141)

The first two components result from first-order surface reflections on the tangential planes: ρsr is
due to reflection from the mean surface and ρdd is due to diffraction and interference from surface
irregularities. The third component ρud results from multiple surface and subsurface reflections. In
the limit of the surface roughness approaching zero, the first term will approach the familiar specular
reflection of a flat surface while the other two terms approach zero.

46. Xiao Dong He, Kenneth E. Torrance, François X. Sillion, Donald P. Greenberg: “A Comprehensive
Physical Model for Light Reflection”. SIGGRAPH’91 conference proceedings, 1991, Las Vegas, United
States. inria-00510144

47. G. Nassif, C. Gloaguen and P. Martins, “A Combined Stochastic and Physical Framework for
Modeling Indoor 5G Millimeter Wave Propagation”, in IEEE Transactions on Antennas and
Propagation, vol. 70, no. 6, pp. 4712-4727, June 2022, doi: 10.1109/TAP.2022.3161286 https://
arxiv.org/abs/2002.05162v2 Paper: https://arxiv.org/pdf/2002.05162v2.pdf
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Figure 815: The main BRDF components.

Computing the BRDF (ρ) for a given direction (θs, θs ), requires the following parameters:

• the surface roughness (σ0).

• the wavelength of the used frequency (λ).

• the properties of the surface material.

• the incident and scattering angles (θi, θs, and ϕs).

The surface roughness and the wavelength are used to compute the relative roughness , which tells

us how rough a given surface is with respect to the wavelength of the incident field.

Based on the relative roughness, we can define three main types of surface roughness profiles (see
Figure 816):

• low surface roughness

• moderate surface roughness

• high surface roughness

These profiles determine how narrow or large the resulting scattering lobe is, and the incident angle
determines its directivity.

Figure 816: Scattering lobe for (a) low, (b) moderate, and (c) high surface roughness profiles.

Penetration and Absorption
Penetration loss due to building walls has been investigated and found very dependent on the particular
system. Absorption due to trees or absorption by the human body is also propagation mechanisms
difficult to quantify with precision. Therefore in the radio network planning process, adequate margins
should be considered to ensure overall coverage.
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Another absorption mechanism is the one due to atmospheric effects. These effects are usually
neglected in propagation models for mobile communication applications at radio frequencies but are
important when higher frequencies (for example, 60 GHz) are used.

Ray Tracing Versus Ray Launching
Ray-optical propagation models are often used for the prediction of the field strength in urban
scenarios. They are very accurate because they consider wave guiding effects in street canyons and
they include diffraction at wedges. There are two different approaches to determine the ray-optical
propagation paths between transmitter and receiver:

• ray-tracing

• ray launching

Ray tracing computes all rays for each receiver point individually and guarantees the consideration of
each wall as well as a constant resolution. The image principle is used to find all reflections. In the ray
launching approach, the rays are launched from the transmitter with a constant angular increment.
Thus ray launching might neglect a wall because it is very small and located between two rays. Different
approaches to a better resolution with ray launching were proposed recently, but ray launching has
still kept the disadvantage of a variable resolution depending on the distance to the transmitter. The
only advantage of ray launching is the shorter computation time compared to standard ray-tracing
algorithms (This is not valid for the intelligent ray tracing, which is much faster than ray launching).
Figure 817 illustrates the differences between ray-tracing and ray launching.

Figure 817: Deterministic propagation models.

Regardless of the model that is used for the determination of the rays between the transmitter
and the receiver, the received power has to be calculated by the superposition of all contributions.
WinProp offers two options, uncorrelated (a statistical summation of contributions based on power
considerations) and correlated (taking the phases into account). The latter is important in some
multipath situations, but may often be undesired in urban scenarios because it will include the small-
scale fading.
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Ray Tracing

Path Classes
Characterize the ray types based on the expected path loss.

There are different types of rays (direct, reflected, diffracted) especially when we consider the
combination of reflections and multiple diffractions. The path loss occurring along these rays depends
on the number and the kind of interactions. Therefore the different ray types can be arranged in classes
according to the expected path loss. When making the prediction, the type of rays that should be
considered during the prediction is defined using these so-called path classes.

Table 63: Classification of the different rays in path classes.

Path Class Description

1 Direct path

2 Single reflection

3 Double reflection

4 Single diffraction

5 Triple reflection

6 One reflection + one diffraction

7 Double diffraction

8 Two reflections + one diffraction

9 Four reflections

10 Five reflections

11 Six reflections

Inside a specific class, a similar interaction loss for the different rays can be assumed and with
increasing order of the path class the interaction loss to be expected increases. For the prediction, a
maximum and a minimum number of path classes can be defined.

The maximum number defines the maximum path class which is computed. The minimum number
defines the abort condition: The computation for an individual pixel is canceled if at least one ray is
found that is in the minimum class or higher. That means that if the minimum number is chosen too
small, the prediction could be too pessimistic since additional rays with an important contribution to
the received power are neglected. In standard ray-tracing the number of path classes considered in the
prediction process has a strong influence on the computation time. However with intelligent ray-tracing
the computation time remains nearly constant and is independent of the selected path classes.
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Acceleration
ProMan offers the possibility to accelerate the prediction by canceling the search for rays as soon as
the accumulated prediction value reaches the free space loss. The consequent prediction error is small
because the received power is rarely above the received power in the free space case. This might be
only the case very near to the transmitter in a LOS situation with additional wave guiding effects.

Computation of Each Ray’s Contribution
Mathematical background and equations show how WinProp calculates the contribution to the prediction
for each ray.

For the computation of the rays, not only the free space loss has to be considered but also the loss due
to the reflections and (multiple) diffractions. This is either done using a physical deterministic model or
using an empirical model.

Note:  This only affects the determination of the reflection and diffraction coefficients. The
prediction itself always remains a deterministic one, thus the same rays are taken into
account.

The deterministic model uses Fresnel equations for the determination of the reflection and transmission

loss and the GTD/UTD for the determination of the diffraction loss.[48] This model has a slightly
longer computation time and uses three physical material parameters (permittivity, permeability and

conductivity). For details see Landron[49].

The empirical model uses five empirical material parameters (minimum loss of incident ray, maximum
loss of incident ray, loss of diffracted ray, reflection loss, transmission loss). For correction purposes or
the adaptation to measurements, an offset to those material parameters can be specified.

The empirical model has the advantage that the needed material properties are easier to obtain than
the physical parameters required for the deterministic model. Also, the parameters of the empirical
model can more easily be calibrated with measurements. It is, therefore, easier to achieve high
accuracy with the empirical model.

Both diffraction models are based on the angles shown in Figure 818

48. Balanis, “Advanced Engineering Electromagnetics”, Wiley, New York, 1989.

49. O. Landron, M. J. Feuerstein, and T. S. Rappaport: “A Comparison of Theoretical and Empirical
Reflection Co-efficients for Typical Exterior Wall Surfaces in a Mobile Radio Environment,” IEEE
Transactions on Antennas and Propagation, vol. 44, pp. 341–351, Mar. 1996
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Figure 818: Angles for diffraction on a wedge.

For the empirical diffraction model the loss  of the diffracted rays is computed depending on the
angles  and  using the following equations:

(142)

(143)

(144)

(145)

(146)

Figure 819: Empirical variation of the diffraction loss depending on the angle.

The angle dependencies are derived from the uniform diffraction theory (UTD) by the evaluation of
measurements with different materials (brick, concrete) in an anechoic chamber and can be varied with
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the parameters ,  and  within appropriate limits. With these three parameters, the model
can be calibrated with measurements.

Breakpoint
In free space, there is a reverse proportional relation between the square of the distance  from the
transmitter to the receiver and the power at the receiver (  is the propagation factor):

(147)

To account for different propagation scenarios and to allow the user to manipulate the free space loss
computation, the above conditions were considered by an extension of the equation:

(148)

With this approach a smooth transition of the free space loss is ensured. In general the breakpoint
distance depends on the transmitter height, the height of the antenna at the mobile station and the
frequency. The parameter BP is the breakpoint distance that is set to a default value according to the
following formula:

(149)

Figure 820: The breakpoint distance depends on the transmitter height,
the height of the antenna at the mobile station and the frequency.

For distances larger than the breakpoint distance, the angles  and  approach 90° and the reflection
coefficient approaches -1. The two rays approach destructive interference. The received power then
depends on distance as indicated in Equation 148, where the exponent P2 tends to be significantly
larger than the free-space exponent.
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The parameters  (exponent before breakpoint) and  (exponent after breakpoint) can also be set by

the user. The default values are  and .

Description of the Individual Ray-Optical Models

Standard 3D Ray Tracing (SRT)
This model performs a rigorous 3D ray-tracing prediction which results in very high accuracy, but
computation time is increased.

Due to the determination of the individual paths, the computational effort is very large. Therefore
several acceleration techniques both with and without loss of accuracy are developed and integrated
into this rigorous 3D approach.

Some sources of literature are available about the ray-tracing technique, for example, Glassner[50], or

Wolfle[51]. Therefore the details of the implementation of the standard ray-tracing model in WinProp is
not covered in this document.

Neighbor Pixels
Investigations have shown that there is a high probability that two adjacent pixels have the same
ray paths. The prediction can be accelerated if the ray paths of the neighboring pixels are known.
Therefore, if this option is enabled, at first only every second pixel is computed. Then the ray paths
of the remaining pixels are computed with the same path classes as for the neighboring pixels. The
prediction error remains marginal while the acceleration factor is in the range of two.

Reduced Resolution
To accelerate the process of ray pathfinding, it is possible to determine in a first step the coverage
(received power or field strength) of a considered area with a reduced resolution, thus for a grid of
pixels where, for example, every second pixel is calculated. After this, the prediction values for the
remaining pixels can be determined by spatial filtering (averaging) over the predicted grid. To reduce
the loss of accuracy, it is important that pixels which are close to buildings calculated in the first step
because of the expected changes by shadowing. In contrary to this there are no problems when using
this algorithm for open areas. This approach leads to an acceleration factor about two if every second
pixel is calculated in the first step (see Figure 821).

50. A. Glassner, ed., An Introduction to Ray Tracing. San Diego: Academic Press, 1989

51. G. Wölfle and F. M. Landstorfer, “Intelligent ray-tracing - A new approach for the field strength
prediction in microcells”, 47th Vehicular Technology Conference (VTC) 1997, Phoenix, Arizona, USA,
pp. 790-794, May 1997.
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Figure 821: Prediction with reduced resolution (gray pixels are predicted in the first step).

Intelligent Ray Tracing (IRT)
This unique model performs a rigorous 3D ray-tracing prediction which results in very high accuracy and
due to the preprocessing of the database in very short computation time.

To cope with the excessive computation times for the deterministic approach with ray tracing the
following aspects have been investigated:

• The deterministic modeling of pathfinding generates a large number of rays, but only a few of them
deliver the main part of the received electromagnetic energy.

• The degree to which visibility relations between walls and edges are independent of the position of
the base station.

• The number of cases where neighboring receiving points are hit by rays for which the paths differ
only slightly. For example, every receiving point in a street orthogonal to the street in which the
transmitter is located is hit by a double reflected, single vertically diffracted ray and the points
of interaction of these rays with walls and edges are independent of the receiver position (see
Figure 822).

Based on these considerations it is possible to accelerate the time-consuming process of ray pathfinding
by a single intelligent preprocessing of the database for buildings.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
7 Methods p.824

Figure 822: Rays between transmitter and receiver determined by ray-tracing.

Preprocessing
In a first step, as indicated in Figure 823, the walls of the buildings are divided into tiles and the edges
into horizontal and vertical segments.

After this discretization of the database, the visibility relationships of the different elements are
determined and stored in a file. For this process, all elements are represented and stored using
their center positions. This leads to a simplification of the problem of ray pathfinding since possible
interaction points are only determined by these the center positions of the tiles and segments.

The visibility relations between each tile (segment) and all other tiles (segments) are computed in
preprocessing because they are independent of the transmitter and receiver locations.

For the decision about the visibility relations, the line of sight criterion between the center positions of
the tiles (or segments) is evaluated. If there is a line of sight between the center positions, the rays
from the center positions of the first tile to the corners of the second tile are determined. Then the
projection of the angles of the rays on the first and second tile is stored together with the visibility
relation.

A similar computation for the visibility relations between tiles and segments and between segments and
other segments is performed and also stored in the preprocessing file.
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Figure 823: Subdivision of the building database into small elements.

The angles of the projection are very important because they define a range of possible reflection (or
diffraction) angles for the illuminated tile (or segment). The angle also continues onto the neighboring
tile resulting in a very accurate prediction of the rays even if the tiles or segments are large - up to 50

or 100 meters for urban databases (Hoppe[52]).

A further improvement is possible if the grid of the prediction points is also used in the preprocessing
because the prediction plane can be subdivided into tiles and the visibility relations between the tiles
of the prediction grid and the tiles (and segments) of the walls represent the last part of the ray in the
direction to the receiver.

If the receiver visibility relations are determined in the preprocessing, the only remaining visibility
relations to be computed in the prediction are the ones from the transmitter to the tiles (of walls and
prediction grid) and segments. Figure 823 depicts the visibility relations between a tile and a receiving
point. For the calculation of the angles, the connecting straight lines between the receiving point and
the four edges of the tile are considered.

By projecting these four lines onto the XY plane and additionally into a plane perpendicular with respect
to the inspected wall, four angles are determined which give an adequate description of this visibility
relation.

Memory Requirement and Computation Time
Table 64 shows the memory requirements for the preprocessed database file and computation times for
different urban scenarios. They were all computed with a maximum extension of the tiles and segments
of 50 meters and a prediction resolution of 10 meters.

52. R. Hoppe, G. Wölfle, and F. M. Landstorfer, “Fast 3D Ray Tracing for the Planning of Microcells by
Intelligent Preprocessing of the Database” in 3rd European Personal and Mobile Communications
Conference (EPMCC), (Paris), March 1999
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Table 64: Memory requirements and relative computation times for the preprocessing.

Example Area [km2] Number of
Buildings

File Size [MB] Relative
Computation
Time

Munich 8 2000 50 100%

Stuttgart 4 300 18 4%

Lille 1 86 6 0.6%

These computation times are shorter than the computation times of a single prediction for the same
area using the standard ray-tracing because each visibility relation is only computed once in the
preprocessing while in the prediction with standard ray tracing similar visibility relations might be
considered and computed for many prediction points.

Prediction
The result of the preprocessing of the building database is a tree structure containing tiles, segments
and receiving points of the prediction area, for example, as indicated in Figure 824. In this tree, every
branch symbolizes a visibility relationship between two elements.

For the prediction only the tiles, segments and receiving points, which are visible from the base station,
have to be determined. Also, the angles of incidence for the visible tiles and segments have to be
calculated. Subsequently, pathfinding can be done similar to the ray launching algorithm by recursively
processing all visible elements and checking if the specific conditions for reflection or diffraction are
fulfilled. The ray search is stopped if a receiving point or a given maximum number of interactions is
reached. Finally, the field strength is summed up at all potential receiving points.

Figure 824 shows the arrangement of all visibility relations computed in the preprocessing and the
prediction.

The preprocessing of the building database reduces the time-consuming process of pathfinding
to the search in a tree structure. A comparison between the number of branches in the first layer
(determined in the prediction) with the number of branches in the remaining layers (determined
in the preprocessing) in the tree structure given in Figure 824 indicates the relation between the
computational effort in the prediction and the computational effort in the preprocessing.
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Figure 824: Determination of ray paths by searching in a tree structure.

Due to the small number of visibility relations in the first layer of the tree, the computation times
are very short. Most of the time is spent on reading the visibility data from a file. If more than one
transmitter is considered at the same time, the preprocessed data must only be read once and thus the
prediction of the second transmitter is even faster than the prediction of the first transmitter because
the visibility tree is already loaded into memory.

Low Dependency of Prediction Area
The computation time for the prediction is nearly independent of the size of the prediction area
because the whole tree is computed once for each prediction and all receiver points are included in the
prediction. Only the time for computing the field strength is necessary for the evaluation of a prediction
point and this time depends on the location of the point (inside or outside the prediction area). The rays
to all preprocessed receiver points are always determined in each prediction.

Therefore if the size of the prediction area is reduced, a smaller number of prediction points must
be considered (more preprocessed prediction points are neglected) and the time for computing the
field strength is reduced. But this part of the computation time is very short compared to the time
for determining the rays and therefore the total computation time is nearly independent of the size
of the prediction area. The number of interactions influences the computation time because each new
interaction corresponds to a further layer in the visibility tree.

Results
Very good results are achieved with a maximum number of three interactions (reflections and multiple
diffractions in different combinations with a maximum number of two diffractions in each ray).

Table 65 shows the computation times for the different urban scenarios using intelligent ray-tracing.
The computation times are compared to the ones of an accelerated 3D standard ray-tracing model.
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Table 65: Relative computation times for the two different ray-tracing algorithms.

Example Area km2 Number of
Buildings

Relative Time,
IRT

Relative Time,
SRT

Munich 8 2000 0.3% -

Stuttgart 5 300 0.05% 100%

Lille 1 86 0.006% 20.8%

Figure 825: Prediction of the received power with intelligent ray-tracing.

A comparison of this prediction with preprocessing of the database on the one hand with a prediction
calculated with the standard 3D ray-tracing, on the other hand, leads to very small differences.

2 x 2D Modeling
From the many transmitter-to-receiver propagation paths, the most dominant ones have to be selected
to obtain the total received power with moderate computation time. A useful acceleration of the process
of ray pathfinding under the consideration of the main propagation mechanisms is the limitation
to two orthogonal planes (double 2D). Rooftop diffracted paths are included in the vertical plane
approach, while for buildings the diffracted paths are modeled with the transverse plane approach as
depicted in Figure 826. The propagation in both the vertical and the transverse plane is considered
in two dimensions. However, the determination of the building corners in the transverse plane is not
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necessarily performed in a horizontal plane. This principle can also be considered for the intelligent ray-
tracing approach which leads to the following two 2 x 2D models included in ProMan:

1. 2x2D (2D-H IRT + 2D-V IRT)

The preprocessing and the determination of propagation paths are done in two perpendicular
planes. One horizontal plane (for the wave guiding, including the vertical wedges) and one vertical
plane (for the over rooftop propagation including the horizontal edges). In both planes, the
propagation paths are determined similarly to the 3D-IRT by using ray optical methods. This
approach neglects the contributions from reflections at the building walls which are in most cases
only relevant for the streets with LOS to the transmitter.

2. 2x2D (2D-H IRT + COST231-W-I)

This model treats the propagation in the horizontal plane in the same way as the previously
described model, thus by using ray-optical methods (for the wave guiding, including the vertical
wedges). The over rooftop propagation (vertical plane) is taken into account by evaluating the
COST 231-Walfisch-Ikegami model. By using this model, only the propagation in the horizontal
plane is determined by ray-optical methods taking into account the vertical wedges of the
buildings, while the over rooftop propagation is modeled by an empirical approach.

Due to the restriction to two orthogonal planes, this approach has better computational performance
but at the cost of a slightly reduced accuracy - not all buildings are taken into account for the
determination of ray paths.

Figure 826: Ray tracing within a vertical and a transverse transmitter-receiver plane.

Hybrid Predictions
Ray-optical propagation models consider a maximum number of reflections and diffractions. Use a
hybrid approach combining empirical prediction with ray-optical prediction.

Due to the limited number of considered reflections and diffractions, not all prediction points may be
reached with the ray-optical algorithms (especially far away from the transmitter). This remaining part
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of the pixels can be computed with empirical models, based on the direct ray between transmitter and
receiver. For urban scenarios, the COST-Walfisch-Ikegami model is implemented.

A transition function between the empirical prediction and the ray-optical prediction leads to a smooth
transition between the two models. An example of the transition function between the two models is
shown in Figure 827.

Figure 827: Transition function between Ray Tracing and COST-Walfisch-Ikegami

Depending on the difference between the ray-optical and the empirical prediction, a weighted sum of

both predictions is computed. The functions for the weight factor are either  or . Therefore
the sum of both functions is always equal to 1 for all possible values of x.

Investigations have shown that the hybrid prediction reduces the overall prediction error.

Description of the Indoor Estimation Models
Obtain coverage inside buildings for the planning of mobile radio networks using different models for
indoor coverage prediction.

Different models for the estimation of the indoor coverage were developed. These models allow to
compute an estimation of the indoor coverage from an area-wide urban prediction.

The term “estimation” should rather be used since the prediction is computed without consideration of
the inner structure of the buildings. This naturally limits the accuracy of the prediction.

Models Based On the Penetration Loss
Two models are available that are based on the penetration loss (which is equal to the material
parameter transmission loss).

The first model, which is an empirical model, computes a homogeneous field strength in the inner of a
building by averaging the prediction values at the pixels surrounding the building and subtracting the
transmission loss.

The second model, which is a semi-deterministic model, considers the angle of the incident rays. If
the empirical COST-Walfisch-Ikegami model is used, the angle information is not available and is thus
assumed to be 90°. Currently also for the intelligent ray-tracing (IRT), no angle information is available.
Subsequently, it leads to a constant penetration loss.
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Furthermore, this model can be calibrated using four parameters , ,  and . The following default

values should be used: , , and . The penetration loss  at arbitrary angles

 relative to the penetration loss at  is computed using the following equation:

(150)

Figure 828 shows the penetration loss  dependency on the incident angle. For ,  and  the default

values were chosen.

Figure 828: Dependency on the penetration loss on the incident angle.

Different Heights
It is required at times to compute the indoor estimation at different heights. This is possible with an
extension to the two described models.

Empirical Model
In the empirical model, an additional floor loss  (in dB/m) must be specified.

The field strength in height  is then computed from the originally computed field strength on the
height , which is the same height as for the urban preprocessing:

(151)

This naturally leads to higher field levels on higher floors. A limitation to the field strength computed
outside the buildings is included.

Semi-Deterministic Model
In this model, the pixels surrounding the buildings are computed with the urban prediction at the
corresponding height. If the standard ray-tracing is used, then the incident angle of the rays are
correctly considered.
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Consideration of Topography
The terrain profile should be considered for propagation modeling when the considered urban area is
not flat. Include terrain information in preprocessing and prediction.

The criterion taken into account is the standard deviation of the terrain heights in comparison to
the standard deviation of the building heights. For large standard deviations of the terrain heights
databases in pixel format are required with resolutions of 20-30 m. This is a higher resolution compared
to terrain models.

To reduce the additional computational effort the terrain information is included in preprocessing and
prediction. At the preprocessing, all buildings are shifted in the Z direction according to the terrain
height at their centers of gravity. With this approach, the shapes of the buildings remain constant while
the arrangement of the buildings among each other is changed. If the intelligent ray-tracing is used,
the topography also has to be considered for the determination of the visibility relations between the
elements of the building database. Therefore the shadowing by hills has to be evaluated for all visibility
relations. Additional ray paths because of the topography (for example, diffraction from the ground) are
not taken into account as their influence can be neglected in urban environments.

For the prediction again the shifted buildings have to be used to determine the elements (tiles,
segments, and receiver points) that have line-of-sight to the transmitter. Because of the topography, it
is possible that the line-of-sight area seen from the transmitter may have changed considerably.

Figure 829: Topographical extension to the COST-Walfisch-Ikegami model.

The topography has a significant influence on the wave propagation from the transmitting to the
receiving antenna. Therefore a topographical extension of the empirical COST-Walfisch-Ikegami model
is necessary. This can be done by calculating the empirical parameters (mean value of building heights,
the height of transmitter, and height of receiver) according to a new reference level which is determined
by the footprints of transmitter and receiver (see Figure 829). As a result of the formulas of the COST-
Walfisch-Ikegami model implicitly consider the terrain profile for the prediction.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
7 Methods p.833

7.1.4 Indoor Models

Motivation for Indoor Propagation Models
Predicting the propagation characteristics between two antennas inside a building is important
especially for the design of cordless telephones, wireless local area networks (WLAN), and in some
cases, indoor cellular base stations.

The indoor propagation channel differs considerably from the outdoor one. The distance between
transmitter and receiver is shorter due to high attenuation caused by internal walls and furniture and
because of the typically lower transmitter power. The short distance implies a shorter delay of echoes
and consequently lower delay spread. The temporal variations of the channel are slower compared
to mobile antennas moving with a car. As is the case in outdoor systems, there are several important
propagation parameters to be predicted. The path loss and the statistical characteristics of the received
signal envelope are most important for coverage planning applications. The wide-band and time
variation characteristics are essential for evaluation of the system performance.

Figure 830: Different approaches to the modeling of indoor propagation.

The considered propagation models can be categorized into three groups:

1. empirical narrow-band models

2. empirical wide-band models

3. deterministic models

Empirical narrow-band models are expressed in the form of simple mathematical equations that give
the path loss as output. The equations are obtained by fitting the model to measurement results. The
empirical wide-band models (dominant paths) also allow the prediction of the wide-band characteristics
of the channel (for example, delay spread). Deterministic models are calculation methods that
physically simulate the propagation of radio waves. These models yield both narrow-band and wide-
band information of the mobile radio channel inside buildings.

All of the presented models are based on or calibrated with propagation measurements. These
measurements have mostly been carried out at 1800 MHz which is most appropriate considering the
common indoor systems. The usage of the models at other frequency bands is possible when the
material parameters of the propagation environment are known.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
7 Methods p.834

Required Database
Categorize buildings into different elements and specify their material parameters for accurate indoor
propagation modeling.

The basis for any propagation model is a database which describes the propagation environment. For
indoor propagation modeling, each building element is categorized into classes (for example, wall,
floor, door) and specified by its coordinates and finally its material properties (thickness, permittivity,
conductivity).

To get a more accurate description of wave propagation, the building data are stored in a 3D-vector
format including all walls, doors, and windows. All elements inside the building are described in terms of
plane elements. Every wall is, for example, represented by a plane and its extent and location is defined
by its corners. Also, for each element individual material properties can be taken into account. It is also
possible to import .dxf files, a common data format in architecture. Figure 831 shows an example for a
three-dimensional building database used in ProMan.

Figure 831: Example of a 3D building database for indoor propagation.

Modified Free Space Model (MF)
The modified-free-space model analyzes the building concerning distances between walls and
penetration losses of the walls, but the individual positions of the walls and their material properties are
not considered.

This model computes the path loss similar to the free space loss with an adjustable exponent and offset.
Herewith it assumes that the excess path loss (in dB) is linearly dependent on the distance with a
specific attenuation coefficient n:

(152)
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The modified-free-space model does not consider the walls of the building, thus no database is
required. With constant values for n and lc the prediction leads to field strength values decreasing in
concentric circles around the transmitter. According to this the prediction results are fairly inaccurate
and only suited for a rough estimation.

Figure 832: Principle of the modified free space model.

To calibrate this model with measurement data the exponent and the offset to be used for this model
can be specified by using the Settings button. For line-of-sight to the transmitter, the values for n are
in the range between 1.0 and 1.4, in non-line-of-sight scenarios values up to 2.0 are possible.

Motley-Keenan Model (MK)
The modified-free-space model analyzes the distances of the building between walls and penetration
losses of the walls.

The model according to Motley and Keenan computes the path loss based on the direct ray between
transmitter and receiver. In contrary to the modified free space model this model considers the exact
locations of the walls, floors, and ceilings. Additional factors for absorption of the direct ray path by
walls are considered.

Figure 833: Principle of the Motley-Keenan model.

(153)
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As shown in Figure 833 the parameter kw describes the number of walls intersected by the direct path
between transmitter and receiver. A uniform transmission (penetration) loss lw for all walls is used for
the computation, that is the material properties of the individual walls are not considered. This uniform
transmission loss can be specified by using the Settings button.

COST-Multi-Wall Model (MW)
The multi-wall model gives the path loss as the free space loss including losses introduced by the walls
and floors in the direct path between transmitter and receiver.

The multi-wall model gives the path loss as the free space loss including losses introduced by the walls
and floors in the direct path between transmitter and receiver (see Figure 834). It has been observed
that the total floor loss is a function of the number of penetrated floors. This characteristic is taken into
account by introducing an additional empirical correction factor.

Figure 834: Principle of the multi-wall model.

The individual penetration losses for the walls (depending on their material parameters) are considered
for the prediction of the path loss. Therefore the multi-wall model can be expressed as follows:

(154)

where

 = free space loss between transmitter and receiver,

 = constant loss,

 = number of penetrated walls of type i,

 = number of penetrated floors,

 = loss of wall type i,

 = loss between adjacent floors,

 = number of different wall types.
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It is important to note that the loss factors in the formula are not physical wall losses but model
coefficients which are optimized with the measured path loss data. Consequently, the loss factors
implicitly include the effect of furniture. This model has a low dependency on the database accuracy and
because of this simple approach a very short computation time. However, wave guiding effects are not
considered with this model leading to a moderate accuracy level.

No preprocessing of the building data is needed for the computation of the prediction, and no settings
have to be changed for this prediction model.

Standard Ray Tracing (SRT)
The standard ray-tracing model (SRT) performs a rigorous 3D ray-tracing prediction which results in
very high accuracy but at the cost of a large computational effort.

Deterministic models are used to model the propagation of radio waves physically. Therefore the effect
of the environment on the propagation parameters can be taken into account more accurately. Another
advantage is that deterministic models make it possible to predict several propagation parameters. For
example, the path loss, impulse response, and angle-of-arrival can be predicted at the same time.

Figure 835: Principle of ray-optical models.

As smaller wavelengths (higher frequencies) are considered, the wave propagation becomes similar
to the propagation of light. Therefore a radio ray is assumed to propagate along a straight line
influenced only by refraction, reflection, diffraction or scattering (see Figure 835) which is the concept
of geometrical optics (GO). The criterion taken into account for this modeling approach is that the
wavelength should be much smaller in comparison to the extension of the considered obstacles, which
are typically the walls of a building. At the frequencies used for mobile communication networks, this
criterion is also sufficiently fulfilled inside buildings.

There are two different basic approaches for the determination of the ray paths between transmitter
and receiver in the geometrical optics technique:

• ray-tracing

• ray launching

The so-called standard ray-tracing model (SRT), which is based on Uniform Theory of Diffraction,
performs a rigorous 3D ray-tracing prediction which results in very high accuracy. Due to the
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determination of the individual paths, the computation time can be long. An acceleration technique
based on "angular Z buffer" has been integrated into this rigorous 3D approach. This technique is
memory-intensive and has been limited to geometries with no more than 20,000 objects. The latter
can be changed if desired by editing the value for SRT_AZB_MAX_OBJECTS in the project's .nip file.
To activate the technique for a given project, set the value larger than the total number of objects
in the geometry. Be aware that the memory consumption grows with the square of the number of
objects. Expect around 75 GB for a geometry with 100,000 objects. The time saving, which is project-
dependent, can be an order of magnitude.

This model has a long computation time because only small parts of the prediction are preprocessed,
and every propagation path is analytically determined. The initialization data is stored in a .idw file.
This file is created at the first prediction run. The computation time of subsequent predictions that are
based on the new .idw database is thus reduced. For this purpose, a new project based on the .idw
database has to be created.

Propagation Paths
The computed propagation paths can either be selected by using a selection file (.sel) and choosing
the option Only user defined propagation paths. Usually, however, the option Number of
interactions is used. Each transmission through a wall, each reflection at a wall and each diffraction at
an edge counts as an interaction.

The value Max. defines the maximum number of interactions that are allowed for each propagation
path. The appropriate value depends on the building structure. If, for example, the building has a
corridor that runs around a corner three times, then it would be better to compute more interactions
because multiple diffractions are needed to reach all prediction pixels. The same occurs if a building has
a structure where the rays have to pass many walls to reach every point of the building because then
more transmissions are needed.

The only constraint is that the computation time naturally increases if more interactions are computed.
On the other hand, if too few interactions are computed, the accuracy decreases. For the case of the
unreached pixels, an empirical model should be used, but with decreased accuracy.

As a basic rule, an appropriate setting for Max. value would be 2 – 4, depending on the building
structure.

Computation of Each Ray’s Contribution
For the computation of the rays, not only the free space loss has to be considered but also the loss
due to the transmission, reflections and (multiple) diffractions. This is either done using a physical
deterministic model or using an empirical model.

Note:  This only affects the determination of the transmission, reflection and diffraction
coefficients. The prediction itself always remains a deterministic one. Thus the same rays are
taken into account.

The deterministic model uses Fresnel equations for the determination of the reflection and transmission
loss and the GTD/UTD for the determination of the diffraction loss. This model has a slightly longer
computation time and uses three physical material parameters (permittivity, permeability, and
conductivity).
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The empirical model uses five empirical material parameters (minimum loss of incident ray, the
maximum loss of incident ray, loss of diffracted ray, reflection loss and transmission loss). For correction
purposes or the adaptation to measurements, an offset to those material parameters can be specified.

The empirical model has the advantage that the required material properties are easier to obtain
compared to the physical parameters for the deterministic model. Also, the parameters of the empirical
model can more easily be calibrated with measurements. It is, therefore, easier to achieve high
accuracy with the empirical model.

The effect of bookshelves and cupboards covering considerable parts of walls is taken into account by
including an additional loss for the wall’s penetration (transmission) loss. An additional loss of 3 dB has
been observed to be appropriate. This additional loss is introduced in the context of the walls covered
by bookshelves, cupboards or other large pieces of furniture. Furthermore, it was found necessary to
set an empirical limit for the wall transmission loss which otherwise becomes very high when the angle
of incidence is large.

Shooting and Bouncing Rays (SBR)
The shooting and bouncing rays method (SBR) performs a rigorous 3D ray-tracing prediction which
results in high accuracy but potentially at the cost of a large computational effort.

Deterministic models are used to model the propagation of radio waves physically. Therefore the effect
of the environment on the propagation parameters can be taken into account more accurately. Another
advantage is that deterministic models make it possible to predict several propagation parameters. For
example, the path loss, impulse response, and angle-of-arrival can be predicted at the same time.

As smaller wavelengths (higher frequencies) are considered, the wave propagation becomes similar
to the propagation of light. Therefore a radio ray is assumed to propagate along a straight line
influenced only by refraction, reflection, diffraction or scattering (see Figure 835) which is the concept
of geometrical optics (GO). The criterion taken into account for this modeling approach is that the
wavelength should be much smaller in comparison to the extension of the considered obstacles, which
are typically the walls of a building. At the frequencies used for mobile communication networks, this
criterion is also sufficiently fulfilled inside buildings.

There are two different basic approaches for the determination of the ray paths between transmitter
and receiver in the geometrical optics technique:

• ray-tracing

• ray launching

The so-called shooting and bouncing rays method (SBR) is a ray-launching method that performs
a rigorous 3D ray-tracing prediction which results in high accuracy. Due to the determination of the
individual paths, the computational effort can be large. Therefore several acceleration techniques both
with and without loss of accuracy are developed and integrated into this rigorous 3D approach.

The ray-tracing and ray-launching techniques make similar approximations and yield similar results. An
important difference is that ray-tracing methods (such as SRT) trace rays backward from every result
pixel to the transmitter, while ray-launching methods (such as SBR) launch a number of rays from the
transmitter and calculate their paths from there. SRT guarantees that it will find all possible ray path
between any result pixel and any antenna, subject to a maximum number of interactions. The price
to pay is that the simulation time increases exponentially with the number of objects in the geometry
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database. Adding one interaction to SRT in a geometry with many objects can be expensive. SBR does
not have this guarantee that it will find all possible ray path between any result pixel and any antenna,
subject to a maximum number of interactions. If the ray density is not high, then a few result pixels (in
low-intensity areas behind objects) may not be reached by any rays. The advantage of SBR is that the
price for an increased number of reflections in a geometry with many objects is modest.

Propagation Paths
The computed propagation paths are limited by the option the option Number of interactions. Each
transmission through a wall, each reflection at a wall and each diffraction at an edge counts as an
interaction.

The value Max. defines the maximum number of interactions that are allowed for each propagation
path. The appropriate value depends on the building structure. If, for example, the building has a
corridor that runs around a corner three times, then it would be better to compute more interactions
because multiple diffractions are needed to reach all prediction pixels. The same occurs if a building has
a structure where the rays have to pass many walls to reach every point of the building because then
more transmissions are needed.

The only constraint is that the computation time naturally increases if more interactions are computed.
On the other hand, if too few interactions are computed, the accuracy decreases. For the case of the
unreached pixels, an empirical model should be used, but with decreased accuracy.

As a basic rule, an appropriate setting for Max. value would be 2 – 4, depending on the building
structure.

Computation of Each Ray’s Contribution
For the computation of the rays, not only the free space loss has to be considered but also the loss
due to the transmission, reflections and (multiple) diffractions. This is either done using a physical
deterministic model or using an empirical model.

Note:  This only affects the determination of the transmission, reflection and diffraction
coefficients. The prediction itself always remains a deterministic one. Thus the same rays are
taken into account.

The deterministic model uses Fresnel equations for the determination of the reflection and transmission
loss and the GTD/UTD for the determination of the diffraction loss. This model has a slightly longer
computation time and uses three physical material parameters (permittivity, permeability, and
conductivity).

The empirical model uses five empirical material parameters (minimum loss of incident ray, the
maximum loss of incident ray, loss of diffracted ray, reflection loss and transmission loss). For correction
purposes or the adaptation to measurements, an offset to those material parameters can be specified.

The empirical model uses five empirical material parameters (minimum loss of incident ray, the
maximum loss of incident ray, loss of diffracted ray, reflection loss and transmission loss). For correction
purposes or the adaptation to measurements, an offset to those material parameters can be specified.
The empirical model has the advantage that the required material properties are easier to obtain
compared to the physical parameters for the deterministic model. Also, the parameters of the empirical
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model can more easily be calibrated with measurements. It is, therefore, easier to achieve high
accuracy with the empirical model.

The effect of bookshelves and cupboards covering considerable parts of walls is taken into account by
including an additional loss for the wall’s penetration (transmission) loss. An additional loss of 3 dB has
been observed to be appropriate. This additional loss is introduced in the context of the walls covered
by bookshelves, cupboards or other large pieces of furniture. Furthermore, it was found necessary to
set an empirical limit for the wall transmission loss which otherwise becomes very high when the angle
of incidence is large.

Intelligent Ray Tracing (IRT)
Accelerate ray-optical models by combining the advantages of ray-optical and empirical models.

Motivation for the Intelligent Ray Tracing (IRT)
Ray-optical models are time-consuming because all possible rays must be tracked. A new approach to
the acceleration of ray-optical models reduces the computation time to that of empirical models. This
method combines the advantages of both ray-optical models and neglects their disadvantages. It is
based on a single preprocessing of the building database. All walls of the buildings are subdivided into
tiles, and all wedges are subdivided into segments. The visibility relations between all tiles, segments
and receiving points in the database are computed in the preprocessing stage because they are
independent of the transmitter location.

Propagation Paths
This deterministic model allows a very accurate rigorous 3D ray-tracing prediction because many
interactions can be taken into account. The selection of propagation paths is similar to the method
for standard ray-tracing (SRT). As a result, rays can either be selected by using a selection file (.sel
file) and choosing the option, Only user defined propagation paths or the option Number of
interactions. Therefore each transmission through a wall, each reflection at a wall and each diffraction
at an edge counts as an interaction. Due to a preprocessing of the database, the IRT model has a very
short computation time.

Computation of Each Ray’s Contribution
For the computation of the rays, not only the free space loss has to be considered but also the loss
due to the transmission, reflection and (multiple) diffraction(s). This is either done using a physical
deterministic model or using an empirical model similar to the method for the standard ray-tracing
(SRT) mentioned.

Note:  This does only affect the determination of the transmission, reflection, and diffraction
coefficients. The prediction itself always remains a deterministic one. Thus the same rays are
taken into account.
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Preprocessing
Divide each wall into tiles and each edge into segments. Use these tiles and segments to determine the
visibility relations between these elements for the propagation paths in the prediction.

For the determination of visibility relationships each tile and segment is represented by its center,
while the transmission, reflection or diffraction point can be an arbitrary point on the tile respectively
segment. The size of the tiles and segments has an important impact on the preprocessing and
the prediction. If tiles and segments are decreased in size then the following consequences will be
observed:

• The accuracy of the prediction will increase because the rays are determined more precisely.

• The computation time (of the preprocessing and the prediction) will increase because more visibility
relations have to be computed (at preprocessing time) and checked (at prediction time).

• The size of the database file after preprocessing will increase because more visibility relations have
to be stored.

You can specify the maximum size of the tiles and the segments. Appropriate values would be 1 – 3
meters for the tiles and 2.5 – 3.5 meters for the segments. The appropriate maximum sizes depend
on the structure of the building. The smaller the rooms, the smaller the maximum sizes should be
chosen. The size of the segments is less critical than the size of the tiles. If the maximum size of the
segments is chosen too large, the effects on the prediction are smaller. Therefore the maximum size of
the segments can be chosen higher than that for the tiles.

If a wall is smaller than the chosen maximum tile size or if an edge is smaller than the chosen
maximum segment size then the wall or segment is treated as a whole part, but it is not combined with
other or edges.

Table 66: Dependency of preprocessing time, file size, and prediction time.

Resolution for the
Discretization [m]

Preprocessing Time
[s]

Size of the
Preprocessed fFle
[MB]

Prediction Time [s]

1 7212 51.6 110

1.5 1835 24.9 100

2 1095 12.2 67

2.5 680 7.3 16

3 457 3.2 1

Table 66 tabulates the dependencies of the preprocessing time, size of the preprocessing file and the
prediction time for different resolution values used for the discretization of the building database shown
in Figure 831, thus an extension of the tiles and segments while the resolution of the receiving points
remains constant at 1 m.
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Prediction
Use a visibility tree and building database for fast prediction.

Figure 836 illustrates the visibility relations computed in the preprocessing in the shape of a “visibility
tree”. Only the relations in the first layer of the tree must be computed in the prediction which can be
done very fast - all other visibility relations are determined during the preprocessing stage and can be
read from file. The stored visibility relations (except the first layer) can be used for all predictions with
the same database.

Figure 836: Determination of ray paths by searching in a tree structure.

Figure 837 shows a field strength prediction of the building database. This prediction indicates the
typical behavior of ray-optical modeling including wave guiding along the corridor. The difference
between measurement and prediction for a part of the building leads to good values for the mean error
(1.9 dB) and the standard deviation (2.8 dB).
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Figure 837: Field strength prediction with IRT (transmit power 0.1 W at 1800 MHz).

For the prediction shown in Figure 837, a resolution of 1 m for the discretization of the building
database was selected. However, it is possible to increase the resolution to some extent without
reducing accuracy.

Dominant Paths (DP)

Multipath Propagation in Indoor Environments
Mitigate multipath effects, inaccuracies in the building database and time-variant obstacles for the
prediction of indoor wave propagation.

In indoor scenarios, there are many possible rays between a transmitter and a receiver, as shown in
Figure 838. On the one hand, the computation of all of these rays is time-consuming, on the other
hand, these rays are not time-invariant and depend on the accuracy of the database.

If, for example, a door is opened, the determined rays are no longer valid, and the predicted field
strength is wrong. Also, people and furniture are time-variant obstacles and can not be included in the
database of the building. The second problem is if the positions of the walls and edges are not known
exactly (they may vary inside a specified area) some of the determined rays do not reach the receiver.
In most databases, the positions of the walls are not known as precisely as they should be for a ray-
tracing algorithm.

Therefore a new approach for the prediction of the field strength should not rely on the knowledge
of all possible rays between a transmitter and a receiver. Only the representative paths should be
determined, and they should be independent of the accuracy of the database and of the time-variant
effects. While these effects influence the wave propagation, there are many rays passing the same

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
7 Methods p.845

rooms between the transmitter and the receiver with different reflection and diffraction points.
Consequently, changes in these points of interaction do not influence the received power.

Figure 838: Multipath propagation in an indoor scenario and dominant paths.

It is only necessary to know which rooms are passed by the rays and which walls are penetrated.
The wave guiding by multiple reflections must not be determined by the computation of all possible
reflection and diffraction points. It should be determined independently of the different points of
interaction. All these aspects are included in the approach with dominant paths which is described in the
next section.

Principle of the Dominant Paths
Group similar rays together based on the sequence of rooms and walls transmitted through.

If the rays in the left part of Figure 838 are analyzed, it is seen that most of them are similar. Therefore
the rays can be subdivided into different groups, each group defined by the following criteria:

• Similar sequence of rooms passed

• Transmissions through the same walls

It must be pointed out that in contrast to the deterministic models the number of interactions is not
used for the classification of the rays. It is not important how many reflections, or diffractions occur
along the ray - more important is the sequence of rooms passed and sequence of walls transmitted
through.

All rays, passing through the same rooms and transmitting through the same walls, can be described by
a representative dominant path. Therefore each receiver point is reached by different dominant paths,
passing the rooms and transmitting the walls in a different sequence.

This effect is pointed out with the example given in Figure 838. All rays reaching receiver R2 in
the left part of the figure can be described by their corresponding dominant paths in the right part
of the figure. As these dominant paths have no reflection, or diffraction points but only points of
changing directions, it is impossible to compute the field strength at their ends by using GTD/UTD. One
possibility for computing the field strength is some kind of empirical model, based on the regression of
measurements. Another approach is artificial neural networks.

One of the basic ideas of the new prediction model is the fast determination of the dominant paths.
While in principle it is possible to determine all rays with a ray-tracing algorithm and then to combine
the different groups of rays to dominant paths, a very fast algorithm is developed for the determination
of the dominant paths. This algorithm is nearly as fast as the prediction with empirical models.
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Determination of the Dominant Paths
The determination of dominant paths and the discarding of non-dominant paths can save time, but also
compromise accuracy. Use specific settings to control the accuracy and prediction time.

In a first step, the sequence of the transmitted walls and rooms passed by the dominant path must
be determined. Therefore an analysis of the database is mandatory. In the database, only information
of the walls and the material of the walls is given, and no information about rooms is available.
Therefore, rooms must be determined in a first step. After this initial step, a tree of the room-structure
is computed as shown in Figure 839.

Figure 839: Tree of the room-structure of the building presented in the left part.

The root of the tree corresponds to the room in which the transmitter is placed. The first layer contains
all neighboring rooms. If there are different walls between the transmitter room and the neighboring
rooms (for example, wall E and F between room 1 and 5), the neighboring room is placed in this layer
of the tree as many times as there are coupling walls between the rooms. After this first layer of the
tree, the second layer is determined similarly, thus all neighboring rooms (and coupling walls) are
branches of the corresponding rooms of the first layer. The tree contains as many layers as necessary
for completeness, thus each room of the building must occur in the tree at least once.

After the determination of the tree, the dominant paths between the transmitter and the receiver can
be computed very easily because if the receiver is located in room i, the tree must only be examined for
room i. If room i is found in the tree, the corresponding dominant path can be determined by following
all branches back to the root of the tree. For example, the path to room 5 through wall E is highlighted
in Figure 839 to show the determination of the paths.

Figure 840: Combination of rooms.

The coordinates of the path are always computed with the same algorithm, independent of the number
of transmitted walls and passed rooms. This is only possible by combining all passed rooms to one room
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for the determination of the path. This is shown in Figure 840 for a given dominant path. Rooms 1 and
5 are combined, erasing wall E (names of the walls and rooms are given in Figure 839). Subsequently,
the situation becomes similar to the situation where the receiver and the transmitter are located in
the same room. The solution for the determination of the path inside a single room is described in the
following section.

Path Determination in a Single Room
There are two different cases for the determination of the dominant path between a transmitter and a
receiver located in the same room:

1. Line of sight

2. Obstructed line of sight

Note:  No line of sight is possible because the rooms of the transmitter and the receiver are
combined to a single room.

In the first case (line of sight) the determination of the dominant path is easy because it corresponds
to the direct ray between the two points. The second case (obstructed line of sight) is a bit more
complicated. In a first step, all the corners of the room get a number and are arranged into two lists,
one containing all convex corners and the second list all concave corners (see Figure 841).

The concave corners are not used for determining the path, and thus the path between the two points
must pass different convex corners (at least one convex corner). For the corners of the room, two trees
are generated, as shown in Figure 841.

Figure 841: Determination of dominant paths in a single room.

Two trees are necessary, one for the transmitter and one for the receiver. If there is a line of sight
between the transmitter (receiver) and a convex corner, this corner is put in the first layer of the tree.
The second layer consists of all convex corners which are visible (by a line of sight) from the corners in
the first layer.

Subsequently, the determination of the path can be readily determined because it is only necessary to
compare the trees for the transmitter and the receiver. If the same corner number is encountered on
the first layer in both trees, the path leads via this corner (for example, corner 10 in Figure 841). If
there are different numbers, the second layer in both trees must be compared to the first layer in the
other tree, and if the same number is encountered here, then the path leads via this corner and the
corresponding corner in the first layer. If no path is found at this level, the corners in the second layers
of both trees are compared. This is done until the same number in both trees is encountered.
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In the last step, the dominant path must be modified to be independent of the exact location of the
corners, as mentioned above. Therefore the path is moved inside the room, depending on the angle of
the corner and the distance to the next wall.

The option, Layers deeper than optimal path layer, determines how many layers deeper than the
optimal layer of the room tree should be used for the path determination. A minimum and a maximum
value can be specified. Appropriate values for min are 1 – 3 (default 2) and for max, 2 – 4 (default 3).

The option, Threshold for consideration of paths, defines the maximum difference (in dB) between
the best path and the path under consideration: when this threshold is (not) exceeded the path under
consideration is discarded (considered). Appropriate values are 2 – 6 dB, the default value is 3 dB.

If the box, Consider 3D path determination, is selected (default), then a rigorous 3D path search is
performed. Otherwise only a 2D search is performed, leading to reduced accuracy.

If the box, Consider outdoor paths, is selected paths that exit the building and “re-enter” are also
considered. Selecting the box could increase the accuracy in some building structures where the
propagation through the outdoor area is an important part of the coverage, but it also increases the
computation time.

Path Selection Criteria
The different path selection criteria parameters are described in Table 67:

Table 67: Different path selection criteria.

LP Allows changing the weighting of the path loss (free space loss) that was computed for the
rays. The default value is 1. A larger value increases the weight of the path loss.

LT Allows changing the weighting of the transmission loss (due to the walls) that was computed
for the rays. The default value is 1. A larger value increases the weight of the transmission
loss.

LI Allows changing the weighting of the interaction loss (due to diffraction) that was computed
for the rays. The default value is 1,5. A larger value increases the weight of the interaction
loss.

LW Allows changing the weighting of the computed wave guiding gain (due to long parallel
walls, for example, in corridors) that was computed for the rays. The default value is 2. A
larger value increases the weight of the wave guiding gain.

nl This is an additional correction factor (> 0) which allows considering an additional loss
depending on the number of interactions. Appropriate values are between 0 and 2.

nmin This is an additional correction factor (> 0) which allows considering an additional gain for
the pixels that are reached in the first layer of the room tree. This is suggestive if these
pixels are predicted with a too pessimistic value due to the building structure. Appropriate
values are between 0 and 2.
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Share of the Empirical and Neural Model
In the current version, predictions with a neural part > 0 % are not possible. This empirical model
allows an accurate prediction with moderate computation time. The dependency on the database
accuracy is low, but a complex room detection is required, which determines all existing rooms
and corridors. The computation time is moderate because only small parts of the prediction are
preprocessed, and every propagation path is analytically determined. Still, it is much faster than the
standard ray-tracing, as only the dominant paths are determined.

7.1.5 Description of the Output Files and Cell Parameters

Output Files
Different output file types are created with specific output data.

Table 68 shows the possible output files, thus files that are computed based on a project with a single
base station / transmitter.

Table 68: Possible output files.

Extension Result File Type

FDH Height data in [m]. Only for terrain projects.

FDM Morpho data. Only terrain and urban projects.

FPD Predicted single transmitter delay spread [ns].

FPF Predicted single transmitter field strength in [dBµV/m].

FPL Predicted single transmitter path loss in [dB].

FPP Predicted single transmitter power in [dBm].

Cell Parameters Output
The different cell parameters and their output files are described using examples.

Figure 842 shows an example of a typical urban configuration.
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Figure 842: Typical urban configuration for ProMan.

The base stations TRX_1a and TRX_1b use the same channel #50, TRX_2a and TRX_2b use the same
channel #60 and TRX_3 uses channel #70. All base stations have the same transmit power.

Co-Channel Interference (CCI) (.fpc)
The co-channel interference (CCI) can only be computed if there is more than one transmitter using
the same channel. The interference level between the transmitters with the same channel is computed
in dB. There are two different cases:

1. The individual CCI computation:

This computation is done for each channel for the whole prediction area. The CCI is only
computed if two base stations use the same channel. The result files are named: output-
filename_Cxx.fpc, where “xx” is the channel number.

Figure 843 shows the results for the two transmitter pairs. The scale is the same as that used in
Figure 844.
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Figure 843: Individual CCI computation: TRX 1a and 1b (left), and TRX 2a and 2b (right).

2. The total CCI computation:

The CCI is computed for all channels respectively where the individual channel is best server. The
result files are named output-filename.fpc. shows an example of a .fpc file:

Figure 844: Example of a total CCI computation result.

The total CCI is always computed in the areas where the individual channel is the best server channel.

Best Server (.fpb)
A best server plot shows the channel number of the channel that provides the maximum received power
at the individual point. Figure 845 shows the result.
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Figure 845: Example of a best server plot.

Maximum Value (.fpm)
For each receiver pixel a prediction of each base station is computed. The maximum value of the
received power in dBm at each pixel is chosen and displayed.

Figure 846: Example of a prediction of the maximum value.
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Superpose transmitters (.fpa For Received Power In [dBm] and .fpe For Field
Strength In [dBµV/m])
For each channel the prediction of all base stations with this channel number are accumulated and
the result is written in a file for each channel (the file name gets an extension, for example, _C60 for
channel 60).

An example of channel 60 is shown in Figure 847.

Figure 847: Prediction plot for channel 60 by superposing two transmitters.

Coverage Degree (Number of Channels Higher Than Threshold) (.fpn)
For every prediction pixel, the number of base stations where the predicted received power is above a
user-defined threshold is computed. This threshold can be changed in the prediction parameter section
of the ProMan. The result reflects the coverage degree in the individual positions.

Figure 848 shows the coverage degree result. It is visible that in some areas a bad coverage (degree of
0) is achieved.
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Figure 848: Prediction plot for the degree of coverage.
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8 Main Applications

In WinProp various air interfaces and applications are pre-defined: broadcasting, cellular, wireless
access, WiFi, sensor networks, ICNIRP and EM compliance.

This chapter covers the following:

• 8.1 Propagation  (p. 857)

• 8.2 Network Analysis for Mobile Communication  (p. 862)

• 8.3 Virtual Drive Test (Evaluation of Antenna Configuration)  (p. 863)

• 8.4 Vehicle-to-X Communication and Automotive Radar  (p. 864)

• 8.5 Satellite Communication  (p. 866)

• 8.6 Sensor Networks  (p. 867)
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8.1 Propagation
WinProp enables you to perform propagation studies for many applications, including but not limited
to cellular mobile communication, WiFi, WLAN, vehicular communication systems, radio and TV, and
communication with satellites.

Multiple transmitters can be placed. For each transmitter, quantities like frequency and power are
defined by the user. For a quick look, the user can specify omnidirectional antennas, while for a more-
sophisticated analysis an antenna pattern can be imported from an Feko simulation or from measured
data.

Typical result quantities are maps of field strength and received power, rays between transmitter and
points of interest, Line-of-Sight analysis results, and, depending on the simulation method, channel
impulse response, delay spread and angular spread.

Scenarios include indoor, urban, combined urban/indoor, and rural / suburban.

8.1.1 Indoor
Indoor scenarios have the most detailed geometry descriptions, with exterior walls, windows, interior
walls, doors, and whatever else is relevant. Object dimensions are typically much larger than a
wavelength, since WinProp uses high-frequency and empirical methods.

Figure 849: Example of an indoor database with walls made of different materials, with doors and with windows.

Furniture and people can be included explicitly, but are more often defined by assigning a larger
attenuation to specific volumes.
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Figure 850: Extra attenuation occurs in areas with furniture
and people, without the need to specify the geometrical details.

Indoor scenarios are not limited to buildings. WiFi coverage in an aircraft is also a regular indoor
scenario. The aircraft is usually defined in WallMan.

In special non-indoor cases one can, if desired, include a significant amount of geometrical detail and
save the geometrical database as an indoor database. This is sometimes done for vehicle-to-vehicle or
vehicle-to-infrastructure communication, or for propagation in a stadium.

Figure 851: A open-air stadium is defined as an “indoor”
database to have the freedom to define any geometrical shape.

In the case of communication in tunnels, the tunnel geometry is usually built in TuMan and optionally
enhanced in WallMan.
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Figure 852: A tunnel geometry is defined in TuMan and optionally enhanced in WallMan. In the end, it is
saved as an “indoor” database to have the geometrical freedom that urban and rural databases don’t offer.

8.1.2 Urban
Urban scenarios, on a scale that includes more than a few city blocks and can easily include an entire
city, justify giving up some geometrical detail. Buildings are modeled as polygonal cylinders. Each
building can have its own material and height.

Figure 853: Buildings in an urban database are polygonal cylinders.

Elevation differences within the city can be included. Vegetation between buildings, such as a park with
trees, can be included by specifying a volume and assigning a certain attenuation to this volume.
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Figure 854: Propagation results for urban database combined with elevation map.

Note that the database in the above image is not a rural database because the buildings are still defined
explicitly. One can transition smoothly from dense urban to spread-out suburban to rural.

8.1.3 Combined Urban / Indoor
In a straightforward way, you achieve the best of both worlds: the speed of an urban simulation
combined with the detail of an indoor simulation. A typical application is cellular coverage inside a
building of interest, while several other buildings of lesser interest are in the vicinity, possibly partly
obstructing the line of sight to the base station. To specify the geometrical database, open an urban
database in WallMan and import an existing indoor database. After positioning the indoor database
in the urban one, you have a combined urban/indoor database. It has the same file extension as the
regular urban database, but ProMan will include the indoor detail in the simulation.

Figure 855: A combined urban/indoor database.

8.1.4 Rural / Suburban
The main content of a rural/suburban database is a description of the terrain profile (the elevation
map). A second feature is a clutter / land usage map, indicating whether the signals interact with forest,
fields, buildings, water, etc.
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Figure 856: Clutter (land usage) map of the Detroit area.

Note that the land-usage map can include urban areas. The database is called rural-suburban because
buildings are not defined explicitly. One can transition smoothly from explicit urban databases (with
elevation profile) to rural / suburban ones.

With rural / suburban databases, areas of several hundred by several hundred kilometers are routinely
handled.

Figure 857: Propagation results around the Grand Canyon.

Atmospheric effects such as frequency-dependent attenuation can be included. Altitude-dependent
gradients in refractive index are not included at the time of this writing (2017).
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8.2 Network Analysis for Mobile Communication
Use network analysis for the planning of the locations of base stations.

Network analysis builds on a propagation analysis. In addition to the usual input for a propagation
analysis, you also specify an Air Interface, for example, whether you use CDMA or OFDM, with all
relevant details concerning carriers, transmission modes, duplex mode. Important additional output is
signal-to-noise-and-interference ratio (SNIR). One important contributor to SNIR is that multiple base
stations (usually not the nearest neighbours) may have to use the same carrier.

Network analysis is instrumental in planning the locations of the base stations. One of the standard
results is a map of which transmitter serves which area, and, for any receiver location, the number
of transmitters, carriers and sites can be received. The latter is instrumental in visualizing hand-over
options.

From the maps of received power and SNIR, more results are derived: best server, cell assignment,
maximum achievable throughput, coverage probability, as well as data rates and other quantities for
particular transmission modes.

Figure 858: Example of maximum achievable data rates for a given air interface.

Figure 859: Best-server map in an urban area. Note each site (each mast) has three sector antennas.
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8.3 Virtual Drive Test (Evaluation of Antenna
Configuration)
In any propagation analysis, the antenna pattern of the receiving antenna (usually referred to as the
mobile station in the graphical user interface) can be included. In a regular propagation analysis, one
specifies the orientation of the receiving antenna relative to the coordinate system of the geometry.
When the receiving antenna is mounted on a vehicle, however, it will turn with the vehicle. Therefore,
in a virtual drive test, one defines a trajectory. The receiving antenna is moved along the trajectory,
its orientation changing in accordance with the direction in which it moves. In combination with a
propagation or network analysis, quantities like received power and maximum throughput are plotted
for this specific scenario.

Note:  The virtual drive test is not the same as a simulation with time variance, since all
geometry is stationary (a vehicle geometry is not explicitly part of the model; it is only
implicitly included in the mobile antenna pattern) and the antenna position is not explicitly a
function of time.

Figure 860: Example results of a virtual test drive. In the bottom image, interference was taken into account.
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8.4 Vehicle-to-X Communication and Automotive
Radar
In vehicle-to-vehicle and vehicle-to-infrastructure communication, as well as in simulations of
automotive radar, you usually want to include at least one moving vehicle in the simulation. Therefore,
these fall in the category of time-variant scenarios. Applications of vehicle-to-X communication include
vehicular networks, intelligent transportation systems, and active safety measures at intersections, see
Figure 861.

Figure 861: Antenna on car (at the bottom of image) communicates with a traffic light (near the green truck).

Advanced driver assistance systems use sensors such as automotive radar. The transmitter and the
receiver are connected to small antenna arrays, often mounted side by side in the front bumper.

In the process of setting up an automotive-radar simulation, both the transmitting antenna and the
receiving antenna are defined to move with a vehicle. For the transmitting antenna, when specifying its
location, the dialog offers the Location of antenna is time variant check box and the object group
with which it moves can be specified. For the receiving antenna, the key is to specify an individual
prediction point (as opposed to a prediction area or a trajectory). An individual prediction point can be
specified as time variant. Figure 862 shows a typical simulation result.
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Figure 862: Result of an automotive radar simulation. Transmitter and
receiver move with the car, and rays are weighted by antenna patterns.

In addition to power of individual rays, Doppler shift and delay are reported for further post-processing.

A useful option for automotive-radar simulations is to import patterns of monostatic radar cross section
(RCS) from Feko. This can save simulation time and improve accuracy. The complicated reflecting object
in WinProp can be replaced by a simple object plus the RCS information, see Figure 863.

Figure 863: On-coming car was replaced by a simple object plus detailed monostatic RCS information from Feko.

Since monostatic RCS contains only the backscatter information, it is not suited for vehicle-to-X
communication simulations.
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8.5 Satellite Communication
Satellite communication is not really a separate application, but deserves separate mention. In addition
to transmitters being terrestrial, they can be mounted on satellites. Geostationary satellites are defined
by their height (for example, 36 000 km) and their longitude. All LEOs (low earth orbit constellations)
and navigation satellites are described either by the two line element method or for the GPS satellites
by the data provided in the Almanac data sets. ProMan offers the possibility to define a time (UTC
time) and a location on the globe (coordinates of location in an arbitrary UTM zone, based on WGS
84 coordinate datum) - and then the location of the satellites relative to this location are computed
by ProMan automatically. Antenna gains for the satellite transmitters are considered in the path loss
predictions.

The satellite radio transmission to the mobile terminal is strongly affected by the variation of the
received signal power because of the presence of fading phenomena (large-scale fading due to
obstacles and small-scale fading due to multipath propagation). Multipath propagation arises from
signal reflection and diffraction on obstacles. In satellite communications, the received signal is usually
the superposition of two components: a main path and a summation of time-delayed scattered paths.
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8.6 Sensor Networks
In many cases, conditions are monitored with sensors that pass their information on wirelessly. In
industrial plants, sensors may be distributed to monitor air quality. In mountains, sensors may be
deployed to monitor snow conditions and avalanche risk. In forests, sensors may serve to detect forest
fires early. These sensors don’t necessarily all connect to base stations like mobile phones do. Instead,
they form their own network and pass information on from one to the other. Therefore, the connectivity
analysis is a bit different and is done in a dedicated tool CoMan. Still, propagation analysis plays a
central role.

Results include a matrix of point-to-point predictions and a map of optimum information flow.

Figure 864: Example: map of optimum information flow for sensors in a petrochemical plant.
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9 Optimization (OptMan)

The OptMan component allows the automatic optimization of orientations of antennas in cellular
networks to achieve various targets.

This chapter covers the following:

• 9.1 Introduction  (p. 869)

• 9.2 Antenna Adjustment Optimization  (p. 870)

• 9.3 Antenna Subset Selection  (p. 872)

• 9.4 Example  (p. 873)

• 9.5 Optimization Target  (p. 876)
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9.1 Introduction
The OptMan application included in the WinProp software suite provides the possibility to optimize radio
networks designed with WinProp. OptMan requires a ProMan network-planning project to work on.

Existing networks, containing transmitters with directional antennas, can be optimized regarding
azimuth and tilt adjustment of the antennas. Beyond this, the tool is able to assist during the planning
process of new radio networks by extracting a subset of specified antennas required to fulfil a user
defined set of thresholds. Further details about the two optimization approaches can be found in the
following chapters.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
9 Optimization (OptMan) p.870

9.2 Antenna Adjustment Optimization
For the optimization of the adjustment of directional antennas in azimuth and tilt, the user can define
a range and increment for each antenna separately. The azimuth for one antenna can be changed,
for example, between 10° and 50° with an increment of 10°, whereas the tilt of the same or another
antenna can be specified to vary between 5° and 15° with an increment of 5°, for example. Individual
antennas can also be excluded from the optimization process and considered as fixed. Furthermore, the
antennas disabled in the ProMan project are also listed.

Figure 865 depicts the graphical user interface of OptMan with the list of all antennas included in
the ProMan project in the upper field. The color in the first column indicates if the antenna shall be
considered for the optimization (green), shall be considered as fixed (yellow) or is disabled (red). The
lower field allows to consider the antenna for optimization and to define the optimization range for each
antenna individually.

Figure 865: Graphical user interface of the WinProp optimizer.

For the optimization of the azimuth and tilt values for the individual antennas an optimization target
has to be defined. Therefore the user has to select a result (for example, SNIR) which shall be used for
optimization. For this result at least one target threshold has to be specified.

The tool will automatically compute all combinations of azimuth and tilt angles and display the
performance of each combination (Figure 866). After the simulation, the combination which provides
the best performance can be assigned and saved in the project file.

Depending on the number of combinations the computation time can be high. However, the OptMan tool
implements an time efficient approach, so that each potential sector orientation is only computed once
(regarding the propagation part). Furthermore the user can influence the number of combinations to be
examined, and therefore the required simulation time, by using larger increments for the angles. After a
coarse tuning, a fine tuning with reduced ranges but finer increments can be done.
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Figure 866: Optimization chart.
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9.3 Antenna Subset Selection
During the installation of new radio networks it is often quite difficult to find the optimum location of
new transmitter antennas.

OptMan offers the possibility to find the best suitable subset of a larger set of possible, user defined
transmitters/cells within a radio network. The user has to define a radio planning project with possible
and completely configured transmitters/cells (typically more transmitters than expected). Based on
any specified result type, for example, data rate, signal level, interference level and corresponding
optimization target definitions, OptMan finds the best subset of transmitters/cells to fulfill these
specified targets or approach the defined targets as close as possible.

The tool automatically computes the wave propagation and network planning predictions. It adds a first
transmitter / cell to the configuration from the list of available pre-defined transmitters / cells. Then the
next transmitter / cell will be added to the network if a min. cell area is additionally provided by this
transmitter, and so on until all user defined thresholds are achieved.

The current performance of the network is displayed online during the optimization process, as depicted
in Figure 867.

Figure 867: Optimization chart.

After the simulation, the required transmitters / cells will be enabled - all others, which are not required
will be disabled. This optimized configuration can be saved and used in ProMan afterwards.
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9.4 Example
The following figure shows a part of a large city, where a LTE radio network shall be installed. 25
possible locations and configurations for transmitters are known and depicted in the figure. The target
is to provide a data rate of 100 kBit/s for 90 percent of the area, outdoor as well as indoor, with a
minimum number of transmitters / cells.

Figure 868: LTE-network with all possible cells.

Based on the shown radio network planning project (see Figure 868), an optimization project can be
started in OptMan. As depicted in Figure 869, the optimization target is specified according to the given
requirements. Besides the threshold definition, the minimum cell area a single site shall cover is defined
to be four percent of the overall simulation area.

During the simulation, the optimization chart (see Figure 870) displays the performance increase
resulting from adding transmitters/cells. Each percentage increase means, that a new transmitter/cell
was added to the network. If there is no increase between two simulation runs (for example, between
run 4 and run 5 in Figure 870), the tested transmitter/cell was discarded.

The optimization diagram in Figure 870 shows that 11 out of 25 transmitters / cells have been selected
to setup the radio network, which fulfills the specified targets best. Using these 11 transmitters, almost
90 percent of the defined target values can be reached. The selected subset of transmitters/cells is
depicted in Figure 871.
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Figure 869: Graphical User Interface of OptMan.

Figure 870: Optimization chart.
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Figure 871: Resulting configuration after optimization.
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9.5 Optimization Target
The definition of an optimization target (a quantity that shall be improved) is required for both the
optimization of antenna adjustments and the selection of an antenna subset. This target can be
specified on the Target tab of the Settings dialog in OptMan (see Figure 872).

Figure 872: Optimization targets for antenna adjustment (left) and optimization targets for antenna subset (right).

In the upper section a result, which shall be used for optimization, has to be selected. For this result,
arbitrary thresholds can be defined either globally for the whole simulation area or per clutter class
in case clutter data is available. The threshold definition per clutter class makes it possible to weigh
different regions of the simulation area, for example, within a building (see Figure 873), differently
by using individual targets (percentage and threshold) per clutter class. Each threshold definition is
a combination of a value for the percentage of the simulation area where the defined threshold value
shall be reached and the threshold value itself. In the left part of the figure above (Figure 872) two
thresholds for Maximum Data Rate are defined for the clutter class Meeting Room. For 50 percent
of the area covered by clutter class Meeting Room, a maximum data rate of 700 kBit/s shall be
reached. For 75 percent of this area, the target is 550 kBit/s. For the evaluation of the targets all pixels
in the simulation area are considered (not-computed pixels are also considered). So in case in an
urban scenario the indoor coverage is disabled and 40% of the pixels are indoors, this means that on
maximum 60% of the total area the defined target can be reached.

In case a subset of possible antennas shall be found, the user can additionally limit the maximum
number of cells to be included in the network. Furthermore the minimum cell area (in percent of the
whole simulation area, independent if the pixels are computed or not) has to be specified here as well.
This value defines the minimum cell area a possible new site/antenna has to cover in order to be added
to the network (otherwise the corresponding antenna will be discarded from the network).
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Figure 873: Definition of clutter classes for a building in WallMan.
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10 Connectivity Manager (CoMan)

The CoMan component allows the simulation of the reliability and connectivity in wireless mesh / sensor
networks.

This chapter covers the following:

• 10.1 Basics  (p. 879)

• 10.2 Projects  (p. 930)

• 10.3 Addenda  (p. 943)
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10.1 Basics

10.1.1 Getting Started
The CoMan application is part of the WinProp suite and allows the simulation of the reliability and
connectivity in wireless mesh and sensor networks. Model wireless sensor networks with different types
of nodes.

Connectivity aspects between the nodes of the network can be predicted based on the underlying
propagation scenario in different environments (rural, urban and indoor). Depending on the specified
wireless air interface of the system, interference is considered as well. The paths of the information
flow between the nodes of the network can be determined depending on the predicted radio channels
between the nodes and the specified service requirements of the air interface.

In order to set up a new project and run simulations based on the specified data, the following steps are
required: 

1. Creation of a new project

2. Configuration of the wireless system

3. Propagation prediction

4. Network prediction (optional)

5. Connectivity prediction

6. Analysis of computation results

10.1.2 Components
CoMan offers the possibility to define standard components, which can be used as templates in different
projects.

Component Catalog
The Component Catalog can be opened using the menu Project > Component Catalog. By default,
there are three different predefined node types as well as a wireless system. These default entries can
be modified, copied or deleted using the corresponding buttons at the bottom of the dialog. Further
nodes and systems can be added to the component list by selecting the corresponding Add button.
After modifications have been done, the catalog should be stored by pressing the Save button in the
upper part of the dialog. Already existing Component Catalogs can be loaded using the Load button.
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Figure 874: The Component Catalog dialog.

Nodes that have been defined in the Component Catalog can be selected during the insertion of new
nodes to the defined simulation environment. Node and system definitions can also be copied from
and to the Component Catalog by using the Load Default and Save Default buttons on the Node
Configuration dialog or the System tab of the System Configuration dialog, respectively.

Tip:  The System Configuration dialog can be opened from Project Parameter >
System Configuration.

10.1.3 File Types
Details of all file types and file extensions related with the CoMan application.

Table 69: File types and file extensions for CoMan.

File Extension File Content File Type

.chm Online manual binary

.apa Antenna pattern file ascii

.apb Antenna pattern file binary

.msi Antenna pattern file ascii

.cal Calibration file for tuning of wave propagation models binary

.meb Component catalog binary
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File Extension File Content File Type

.cpb CoMan project file binary

.bpw, .jgw Geo reference files for images ascii

.bmp, .jpg Images files binary

.cam Stored camera perspectives of the 3D View binary

.msa System configuration file ascii

.tdb Terrain database binary

.txt Measurement file ascii

.mdb Morpho-Clutter database binary

.mct Morpho-Clutter-Class database ascii

.tdv Vector database (rural) binary

.odb Vector database (urban) binary

.idb Vector database (indoor) binary

.fpf Field strength (propagation result) binary

.los Line-of-Sight state (propagation result) binary

.log Log file ascii

.con Network connectivity (network result) binary

.fpl Path loss (propagation result) binary

.mia Point-2-Point prediction (propagation result) ascii

.mib Point-2-Point prediction (propagation result) binary

.ray Ray data file (propagation result) binary

.str Ray data file (propagation result) ascii

.fpp Received power (propagation result) binary

.csv Character separated values file ascii

.kml Keyhole Markup Language file for Google Earth ascii

.net ProMan Project file ascii
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File Extension File Content File Type

.txt Output data file ascii

10.1.4 Command Line
CoMan can be started with additional arguments passed in the command line in order to load and
execute existing projects automatically.

The first and minimum required parameter, which has to be passed to the command line, is the path
and the name of the CoMan project file to be loaded. Further parameters are optional and can be
passed in an arbitrary order.

The basic syntax of the command line mode is as follows:
Coman.exe "C:\CoMan.cpb"

Table 70: Optional command line parameters for CoMan.

Optional
Parameters

Description

-pa Compute Wave Propagation Prediction (Area Prediction)

-pp Compute Wave Propagation Prediction (Point-to-Point Prediction)

-n Compute Network Prediction

-c Compute Connectivity Prediction

-o “C:\results” Specification of output folder (Output folder defined in the project will be
neglected, but not replaced)

-l Write computation log file

-q Close application after task(s) are successfully finished

10.1.5 Graphical User Interface
CoMan's graphical user interface window consists of three main parts, the File Browser, the Project View
and the Output View.

Overview
A menu and different toolbars offer quick access to all the functionalities of the CoMan application. The
Status Bar on the bottom of the main frame gives additional information about the current project.
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Further views, such as the Legend View, can be visualized on demand by choosing the corresponding
commands.

Figure 875: CoMan graphical user interface overview.

Notification Messages
In case CoMan is minimized during a computation, the user will be informed about the completion of the
simulation with a tray message pop-up.

Figure 876: Tray message pop-up for completed computation.
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2D View
CoMan's 2D View visualizes the specified environment database and computed result for an arbitrary
defined horizontal cutting plane.

The horizontal display height, as well as further parameters related to the 2D View can be specified on
the Display tab of the Settings dialog. The currently displayed height level is shown in the status bar
and can be modified easily by pressing Shift while scrolling the mouse wheel.

Tip:  To edit the parameters of the 2D View, use the menu Edit > Local Settings >
Display.

Figure 877: CoMan 2D graphical view.

The dashed gray line around the database highlights the border of the vector database, whereas the red
polygon indicates the horizontal prediction area. If the prediction mode is set to point-to-point for node
locations (see the Prediction tab of the System Configuration dialog), the prediction area will not be
displayed.

3D View
Three dimensional representations of the specified environment database(s) and the computation
results can be shown with the 3D View of CoMan.

The 3D View can be enabled by selecting View > Show 3D View or by pressing the corresponding
button on the View toolbar.
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Figure 878: CoMan 3D View.

Selecting Total View will reset the view perspective to the initial state, which will display the whole
environment. The current view perspective of the 3D scenario can be stored by pressing the Store
button in the 3D View window. In order to recall a stored view perspective afterwards the corresponding
name of the desired perspective has to be chosen using the drop-down list. A selected previously stored
view perspective can be deleted by pressing the Delete button. All stored view perspectives will be
written to a file after closing the 3D View or the current document, respectively. This file will be stored
in the result folder of the corresponding document and will be automatically reloaded when the 3D View
is activated.

Table 71: Navigation in 3D View.

Mouse button Description

Shifting:

Move the mouse while pressing the left mouse
button to shift the view in a certain direction.
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Mouse button Description

Rotating:

Move the mouse while pressing the right mouse
button to rotate the view.

Zooming:

Scroll the mouse wheel up/down to zoom in/out.

Further parameters related to the visualization in the 3D View can be adjusted on the Display 3D tab
of the Settings dialog. Use the menu, Edit > Local Settings > Display 3D.

File Browser
Computation results visualized with CoMan are listed in a tree structure within the File Browser.

The File Browser can be accessed by selecting View > Show File Browser or by moving the mouse
cursor over the button File Browser on the left side of the main window. The browser can slide in and
out automatically or can be pined by pressing the pin button in the upper-right corner of the window.
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Figure 879: File Browser window of CoMan.

In order to load and show computation results in the Project View an item of the tree structure has
to be selected and double-clicked. A click on the Database item on top of the tree will unload the
previously selected results. In this case only the database(s) will be displayed in the Project View.

The context menu of the File Browser offers the possibility to update the content manually and to
erase single results or even whole result folders from disk.

Information View
CoMan's Information View provides additional information for the data currently displayed in the Project
View.

The Information View provides additional information for the data currently displayed in the Project
View, such as parameters of environment databases, result databases and settings of the wireless
system. The Information View can be opened by selecting View > Show Informationor by pressing
the corresponding button of the View toolbar.

The content of this view can be adjusted using the Information tab of the Settings dialog. Use the
menu, Edit > Local Settings > Information.
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Figure 880: Information view in CoMan.

Legend View
The Legend View provides the legend for the pixel data currently displayed in the Project View.

The Legend View can be opened by selecting View > Show Legend or by pressing the corresponding
button of the View toolbar.
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Figure 881: The legend view in CoMan.

The settings of the legend, which are automatically assigned for each type of result or database, such
as the color palette or the value range, can be adjusted on the Legend tab of the Settings dialog.
Once these settings have been changed they are stored for all results or databases of the same type
within the current project.

The context menu of the Legend View offers the possibility to access the Legend Settings.

Output View
The Output View consists of two tab sheets. The Tasks tab displays the progress of currently active
tasks. The Events tab lists all events of the session with a corresponding time stamp.

The Output View can be accessed by selecting View > Show Output View or by moving the mouse
cursor over the Output button on the bottom of the main window. The Output View can slide in and out
automatically or can be pined by pressing the pin button.

The content of the Output View (both tab sheets) can be cleared by selecting View > Clear Output
View.
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Figure 882: The Output view in CoMan - Tasks tab.

If the option Write Log File is enabled on the General tab of the Settings dialog, the content of the
Tasks tab will be written to the specified log file after a computation has finished. Using the context
menu, it is also possible to write log file manually. 

The content of the tab will be cleared automatically before a new simulation starts. Beyond this, the tab
can be cleared via context menu, as well.

Figure 883: The Output view in CoMan - Events tab.

If the option Write Log File is enabled on the General tab of the Settings dialog, the content of the
Tasks tab will be written to the specified log file after choosing the corresponding option from the
context menu.

The content of the tab can be cleared manually using the context menu. The event list can be sorted by
clicking on one of the column headers.

Project View
The Project View of CoMan displays the database(s) and results of the current project in 2D and 3D.

The splitter window can be shifted to the left or the right side to change the size of the views. If the 3D
View is disabled, the 2D View covers the whole Project View.
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Figure 884: The Project view in CoMan.

Global Settings Dialog
The Global Settings dialog covers all general settings and parameters of CoMan which are independent
of a specific project.

The Global Settings dialog can be opened by selecting Edit > Global Settings.

Figure 885: The Global Settings dialog.

The News Ticker drop-down list can be used to display the latest news about the WinProp software
suite, such as available updates. Use the drop-down list to display all news messages, only news related
to software updates, or select to disable all news.
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Note:  The News Ticker requires an internet connection.

Local Settings Dialog
The Local Settings dialog covers all settings and parameters of the current CoMan project.

The Local Settings dialog specifically covers all settings and parameters of the current project which
are not directly related to the configuration parameters of the wireless system. The Local Settings
dialog can be accessed by selecting Edit > Local Settings or by pressing the corresponding button on
the Edit toolbar.

General Tab

Figure 886: The Settings dialog, General tab.

Files
File paths and names of system parameter file, result folder and log file.

Undo / Redo
Size of the undo / redo buffer, thus the number of steps that can be undone or redone,
respectively.

Display Tab
The Display tab covers general settings related to the 2D View and 3D View displays.
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Figure 887: The Settings dialog, Display tab.

General

Display height in 2D View
This value is the horizontal cut plane height. It is shown in the status bar and can be
modified by pressing Shift while scrolling the mouse wheel in the 2D View. Further objects
to be drawn in the 2D View and (partly) in the 3D View can also be selected here.

Databases
Databases to be visualized in the Project View can be selected here. The objects of vector
databases can be displayed using their individual material colors, material thickness, filled or in
wire frame mode.
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Paths
The width and drawing style of paths can be changed by adjusting the corresponding fields. Line
styles other than “Solid” can be selected only for path widths of one. If a path width larger than
one is selected, the style automatically changes to “Solid”.

Color
There are five different modes available for the colorization of paths showing the information flow
between the nodes of the simulated network.

1. Unique Color: A single user defined color will be used to draw all paths. This color can be
changed by clicking on the colored rectangle on the right-hand side.

Note:  In case multiple nodes are selected for displaying connectivity paths, this
mode will be selected automatically.

2. According to Path Type: Pre-defined colors that indicate the type (direct neighbor,
gateway, optimum) of the paths are used.

3. According to Path Loss Thresholds: This option offers the possibility to define arbitrary
thresholds and corresponding path colors for different path losses. The colors for the defined
thresholds can be changed by clicking on the colored rectangles.

4. According to Path Delay Thresholds: This option offers the possibility to define arbitrary
thresholds and corresponding path colors for different path delays. The colors for the
defined thresholds can be changed by clicking on the colored rectangles.

5. According to Received Power Thresholds: This option offers the possibility to define
arbitrary thresholds and corresponding path colors for different received power values. The
colors for the defined thresholds can be changed by clicking on the colored rectangles.

Note:  As there are two nodes corresponding to a path segment, the received
power values of both nodes are evaluated. The path segment is colored
according to the defined threshold color of the lowest received power.  

Filter
Path types that will be displayed can be selected using the first drop-down list of this section.

Note:  Choose Online visualization before running a Connectivity Prediction in order
to visualize the determination of the optimum paths.

Path data can be further filtered using a minimum and a maximum value of a specific key parameter
of the path. Currently filters for path delay, path loss, probability of failure and probability of stability
can be applied. Active path filters are listed in the list box on the left-hand side. If one or multiple path
filters are active, the paths will be displayed only if the corresponding path parameter is within the
defined minimum and maximum value of the filter.

Note:  Path filters apply for the 2D and 3D display as well as for the Object Information
tool.
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Display 3D Tab
Settings for the 3D View are set on this tab.

Figure 888: The Settings dialog, Display 3D tab.

Scenario Databases

Vector Database
Set the transparency level for objects contained in the vector databases. A value of 0%
results in opaque objects while a value of 100% results in completely transparent objects.

Pixel Database
Set the transparency level for pixels contained in pixel databases (topography or clutter/
morpho databases). A value of 0% results in opaque pixels while a value of 100% results in
completely transparent pixels.

Antenna Symbols
Set the Size Factor for drawing antenna symbols on the 3D View.

Miscellaneous:
Enable or disable drawing of optional border around the scenario database.

Images
In case images are specified to be an overlay for topography or result databases, the shading
mode can be defined here. If Replace is chosen, the database will get the corresponding color
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of the image pixels. If Add is selected, the colors of the database and the image pixels will be
added.

Result Databases
Set the transparency level for pixels contained in result databases. A value of 0% results in
opaque pixels while a value of 100% results in completely transparent pixels.

Height Layers
In case of multiple prediction heights, either all predicted height layers or only the one currently
shown on the 2D View can be displayed.

Note:  The current display height for the 2D View can be specified on the Display
tab. 

Path Data
Set the Size Factor for drawing information flow paths on the 3D View.

Note:  The colorization of the paths can specified for 2D View and 3D View on the
Display tab. 

Computation Tab
All parameters related to the computation engine can be found on this tab.

Figure 889: The Settings dialog, Computation tab.

Processors to be Used
Check processors that can be used by the computation engine to compute the selected
computation task. If multiple processors are enabled the engine will compute multiple nodes in
parallel, which speeds up the computation time.

Priority of Computation Threads
Priority level which is used to run computation tasks.

Note:  Changes could influence the overall system performance sustainable! Therefore
it is not recommended to change this value.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
10 Connectivity Manager (CoMan) p.897

Legend Tab
Settings of the Legend View which are automatically assigned for each type of result or database, such
as color palette or the value range can be adjusted on the Legend tab.

Figure 890: The Settings dialog, Legend tab.

Type
Discrete legends have a fixed linear scale with range between the specified minimum and
maximum value (see the Range section) as well as a predefined color palette, which can be
chosen in the Color Palette group. User Defined Legends can be customized individually by the
user. Legends in CoMan can, depending on the type of the currently displayed database or result,
have up to 14 discrete color margins. The mode of the legend selects the sign of the defined scale
margins. Possible values are Threshold More, Threshold equal, or Threshold less.

Clicking the Default button will reset the values to the defaults for the currently active database
or result

Color Palette
Pre-defined color palettes for the scale.

Range
Minimum and maximum values defining the range, which is displayed in the Legend View.
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Clicking the Default button will reset the values to the overall minimum and maximum value
contained in the currently active environment or result database.

If the option Automatically adjust range is enabled, the value range will be reset to the overall
minimum and maximum value contained in the currently active environment or result database
each time a result or database of this type is loaded. This guarantees that the whole range of
values is always covered by the legend. In case this option is not active, the specified range of
values will not change for this type of result or database, even if a new result or database is
loaded. That makes it possible to easily compare results using the same scale range. 

Additional Information
Margin Statistic:
The probability density or the cumulative probability density of the currently displayed pixel
database can optionally be shown for the individual margin values.

The selected margin statistics can be computed taking into account either all height layers
contained in the pixel database or considering only the height, which is currently displayed in the
2D View. Arbitrary result planes belonging to the currently displayed pixel database (if available)
can be selected to be considered as well.

Information Tab
Settings corresponding to the Information View can be specified on the Information tab of the
Local Settings dialog.

Figure 891: The Settings dialog, Information tab.

General
Enable or disable the display of database, result and system parameters in the Information
View.

Reporting
Logo Image:
An image that can be included in printed reports.
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Status Bar
The status bar provides information about the status of the propagation engine and the 2D View

The status bar consists of six sections and can be enabled or disabled by selecting View > Status Bar.

Figure 892: Example of the status bar in CoMan.

Table 72: Status bar information.

Section Description

1 (left) General state of the application

2 Number of errors and warnings which are displayed in the Output View.

3 Status of the simulation engine. If a simulation is running, “Engine Busy” will be
displayed here.

4 xy coordinates of the mouse cursor in the 2D View. z coordinate of the currently
selected display height in 2D View.

5 Current zoom factor of the 2D View

6 (right) Value of the pixel database at the position of the mouse cursor. This section is
empty if no pixel data is available.

Toolbar
The status bar provides information about the status of the propagation engine and the 2D View.

Toolbars
There are four toolbars available in CoMan which provide quick access to all frequently needed
functionalities. All toolbars can be enabled or disabled by selecting the View menu.

Standard Bar

Table 73: Standard bar.

Icon Description

Create new project

Open project
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Icon Description

Save project

Undo command

Redo command

Print

About dialog

View Bar

Table 74: View Bar.

Icon Description

Show/hide rulers.

Zoom in.

Zoom out

Draw zoom window

Adjust zooming to display whole prediction area (only if area prediction is selected)

Adjust zooming to display whole database

Open/Close 3D View

Open/Close Legend View

Open/Close Information View

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
10 Connectivity Manager (CoMan) p.901

Edit Bar

Table 75: Edit Bar.

Icon Description

Open Local Settings

Selection Tool

Selection for time stamp to be displayed and considered for computation.

Selection for service to be displayed and considered for computation

Analysis Bar

Table 76: Analysis Bar. 

Icon Description

Object Information Tool

Path Visualization Tool

Threshold Tool

Mouse Meter Tool

Project Bar

Table 77: Project Bar. 

Icon Description

Open System Configuration

Predication Area Tool

Additional Data Tool

Node Insert Tool
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Icon Description

Node Delete Tool

Node Move Tool

Node Configuration Tool

Cut selected node(s)

Copy selected node(s)

Paste node(s)

Run Wave Propagation Prediction

Run Network Prediction

Run Connectivity Prediction

Cancel current prediction

Menus
Different menus in CoMan provide quick access to different functionalities.

Menu items will be disabled if the corresponding function is currently not available or applicable. Further
view dependent options are selectable in the context menus of the different views which can be reached
from the context menu.

File Menu

Table 78: CoMan File menu.

Menu Item Description

New Project Create new project

Open Project Open project

Close Project Close active project

Save Project Save (overwrite) active project

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
10 Connectivity Manager (CoMan) p.903

Menu Item Description

Save Project As Save active project with new name(Optionally the project can be saved in the format
of a former software version)

Open Result Open result database

Close Result Close active result database

Save Result Save (overwrite) active result database

Save Result As Save active result database with new name

Page Setup Open Print page configuration dialog

Print Preview Open print preview window

Print Print 2D View

Import Import data from different formats

Export Export data to different formats

Recent file list List of recently used projects

Exit Close the CoMan application

Edit Menu

Table 79: CoMan Edit menu.

Menu Item Description

Undo Undo command

Redo Redo command

Global Settings Open Global Settings dialog

Local Settings Open Local Settings dialog

Select Object Activate Selection Tool

Pixel Data Operations for modification of pixel databases
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Project Menu

Table 80: CoMan Project menu.

Menu Item Description

Parameter Open System Configuration dialog

Component
Catalog

Open Component Catalog dialog

Define
Prediction Area
(Rectangle)

Activate Prediction Area Tool

Additional Data Activate Additional Data Tool

Object Different operations on node objects

Print Report Print project report

Computation Menu

Table 81: CoMan Computation menu.

Menu Item Description

Compute
Project

Start computation of whole project, thus run all possible predictions successively.
(Wave propagation for a specified area, wave propagation for a node location as well
as network and connectivity predictions)

Compute All Start computation for all nodes

Compute
Modified

Start computation for all nodes which have been modified

Compute
Selected

Start computation for selected nodes

Cancel
Computation

Stop current computation task

Auto Calibration Start calibration of wave propagation model and materials
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Analysis Menu

Table 82: CoMan Analysis menu.

Menu Item Description

Object
Information

Activate Object Information Tool

Show Paths Activate Path Visualization Tool

Show Threshold Activate Threshold Tool

Mouse Meter Activate Mouse Meter Tool

Calculator Launch Windows Calculator Application

Image Menu

Table 83: CoMan Image menu.

Menu Item Description

Configuration Open Image Configuration dialog

Move Image Activate Image Move Tool

Scale Image Activate Image Scale Tool

Scale Image
Via Line

Activate Image Scale Tool in line mode

View Menu

Table 84: CoMan View menu.

Menu Item Description

Standard Bar Show or hide Standard toolbar

View Bar Show or hide View toolbar

Edit Bar Show or hide Edit toolbar

Analysis Bar Show or hide Analysis toolbar

Project Bar Show or hide Project toolbar
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Menu Item Description

Status Bar Show or hide Status Bar

Show File
Browser

Open File Browser

Show Output
View

Open Output View

Clear Output
View

Clear content of Output View

Show Rulers Show or hide rulers of 2D View

Show 3D View Show or hide 3D View

Show Legend Show or hide Legend View

Show
Information

Show or hide Information View

Zoom In Zoom in (2D View)

Zoom Out Zoom out (2D View)

Zoom
Prediction Area

Adjust zooming to display whole prediction area (only if area prediction is selected)

Zoom Total Adjust zooming to display whole database

Window Menu

Table 85: CoMan Window menu.

Menu Item Description

Cascade Cascade several project windows

Tile Horizontal Tile project windows horizontally

Tile Vertical Tile project windows vertically

Arrange Icons Arrange icons of ionized project windows

Window List List with all open project windows
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? (Help) Menu

Table 86: CoMan Menu.

Menu Item Description

User Manual Open CoMan User Manual

Software
Status ...

Check if software updates / new service packs are available

About Open About dialog

Context Menus
Context menus for the 2D View, the Output View, the File Browser as well as for the Legend View
provide quick access to frequently needed functions.

The context menus can be reached from the context menu within the corresponding view window. Menu
items may be disabled if the corresponding function is currently not available.

Context Menu of 2D View.

Table 87: CoMan 2D view menu.

Menu Item Description

Insert Activate Insert Node Tool

Delete Delete selected node

Move Activate Node Move Tool for selected node

Cut Cut selected node

Copy Copy selected node

Paste Paste node(s)

Properties Open Node Configuration dialog for selected
node

Compute Start computation for selected node
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Context Menu of Output View

Table 88: CoMan output view menu.

Menu Item Description

Export to ASCII File Write content of Output View to an ASCII file, thus
write a log file

Clear Clear content of Output View

Context Menu of File Browser

Table 89: CoMan file browser menu.

Menu Item Description

Update Update content of File Browser

Erase Erase selected files or folders from hard disk

Rename Rename selected file or folder

Context Menu of Legend View

Table 90: CoMan legend view menu.

Menu Item Description

Settings Open Legend Settings dialog

Context Menu of Information View

Table 91: CoMan information view menu.

Menu Item Description

Settings Open Information Settings dialog
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10.1.6 Object Handling

Object Selection
CoMan's Selection Tool is the basic tool, which is enabled by default if no other tool is currently active.

The Selection Tool can be started by selecting Edit > Select Object from the Edit menu of by pressing
the corresponding button on the Edit toolbar. Objects that have been selected are marked with red
color. Multiple objects can be selected simultaneously by holding the Ctrl key while selecting. In order to
select all objects at once, hold the Ctrl key and the A key simultaneously.

Insert Nodes
New nodes can be added to the simulation environment either directly via the Nodes tab of the
System Configuration dialog or by using the Node Insert Tool.

The Node Insert Tool defines the location of a new node with the mouse. The Node Insert Tool can
be started by selecting Project > Object > Insert from the Project menu or by pressing the
corresponding button on the Project toolbar. A further possibility is to use Insert from the context
menu of the 2D View.

If the tool is started, the mouse cursor changes to a cross and the new node location can be specified
graphically with the mouse. After right-clicking, a dialog opens where parameters of the node to be
inserted can be edited.

Figure 893: The Insert new Node dialog.

Position
Location (x, y and z coordinate) of the node to be inserted.

Object
List of available node templates that are defined in the Component Catalog. The parameters of
the selected template can be modified by pressing the Edit Settings button.

After closing this dialog with the OK button, the new node will be inserted into the simulation
environment.
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Note:  All tools can be closed by pressing the ESC key on the keyboard. In this case the
active operation will be canceled and the Selection Tool will be activated.

Delete Nodes
Nodes defined in the project can be deleted either directly via the Nodes tab of the System
Configuration dialog or by using the Node Delete Tool.

With the Node Delete Tool a node can be erased with the mouse. The Node Delete Tool can be accessed
by selecting Project > Object > Delete from the Project menu or by pressing the corresponding
button on the Project toolbar. A further possibility is to use Delete from the context menu of the 2D
View if the node to be erased is already selected.

If the tool is started, the mouse cursor changes and the node to be deleted can be specified graphically
with the mouse using the context menu.

Note:  All tools can be closed by pressing the ESC key on the keyboard. In this case the
active operation will be canceled and the Selection Tool will be activated.

Move Nodes
The Node Move Tool defines the location of the node with the mouse.

Node locations can be changed either directly via the Nodes tab of the System Configuration dialog
or by using the Node Move Tool. The Node Move Tool can be accessed by selecting Project > Object >
Move from the Project menu or by pressing the corresponding button on the Project toolbar. A further
possibility is to use Move from the context menu of the 2D View if the node to be moved is already
selected.

If the tool is started, the mouse cursor changes to a finger symbol and the node to be moved has
to be selected. After right-clicking, the selected node can be moved while moving the mouse cursor.
The display height of the 2D View automatically changes to the actual height of the selected node.
By pressing the Shift key while scrolling the mouse wheel, the height of the 2D display as well as the
height of the node to be moved can be changed. If the final location is reached, another right-click will
release the node and assign the new location coordinates.

If the Node Move Tool is started for a pre-selected node via the context menu of the 2D View, a dialog
opens where the movement of the selected node can be specified either as a shift vector or as a fixed
location vector.
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Figure 894: The Move Object dialog.

Nodes can be shifted with the specified vector or moved to the defined location vector.

Note:  All tools can be closed by pressing the ESC key. In this case the active operation will
be canceled and the Selection Tool will be activated.

Configure Nodes
Configure the parameters of a node with the Node Configuration Tool.

Parameters of nodes defined in the project can be configured either directly via the Nodes tab of the
System Configuration dialog or by using the Node Configuration Tool, which offers the possibility
to specify a node with the mouse. The Node Configuration Tool can be started by selecting Project >
Object > Edit Parameters from the Project menu or by pressing the corresponding button on the
Project toolbar. A further possibility to configure the parameters of a node is to use Properties from
the context menu of the 2D View if the node to be configured is selected already.

If the tool is started, the mouse cursor changes and the node to be edited can be specified graphically
with the mouse. After pressing the right mouse button, the Node Configuration dialog opens, where
all parameters of the selected node can be edited.

Note:  All tools can be closed by pressing the ESC key on the keyboard. In this case the
active operation will be canceled and the Selection Tool will be activated.

Automatic Distribution of Nodes
Distribute nodes stochastically within the simulation environment.

A stochastic distribution of nodes is useful if their exact position is unknown because they have been
placed randomly in order to monitor large areas for example. CoMan offers the possibility to randomly
distribute transceiver nodes over the whole simulation area either using a fixed number of nodes, a
homogeneous distribution density or based on land usage maps with a density value for each land
usage class.

The Node Distribution function can be accessed via Project > Object > Distribute Automatically in
the Project menu.
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Note:  This option is available for rural simulation scenarios only.

Distribution Settings
Different options are available for distributing nodes within the simulation environment.

Figure 895: The Node distribution dialog.

Distribution Mode
Nodes can be distributed either using a fixed number of nodes, a homogeneous distribution
density or based on a land usage map in combination with a distribution table.

Fixed number
Fixed number of nodes, which shall be distributed. This value is only relevant if “Fixed number of
nodes” is selected for the distribution mode

Density
For the homogeneous distribution a fixed density value, thus the average number of nodes per
square kilometer, has to be specified. This value is only relevant if Homogeneous with fixed
density is selected for the Distribution Mode.
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Distribution Table
In case the project contains land usage data, the distribution can be done clutter specific using
a distribution table, which defines the distribution densities for the relevant clutter classes
individually. 
If a distribution table is already available, the file can be browsed for using the Browse button.
The Create / Edit Distribution Table button offers the possibility to create a new table or to
edit the already specified one. By pressing this button, the dialog shown below opens and displays
the current content of the selected distribution table.

Figure 896: The Distribution Table dialog.

Add
Create a new distribution class using the Distribution Class dialog shown below.

Edit
Modify an already existing distribution class using the Distribution Class dialog shown below.

Delete
Remove one or several selected distribution classes from the table.

A distribution class can be created or edited with the dialog depicted below.

Figure 897: The Distribution Class dialog.
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Name
Arbitrary name of the defined distribution class.

Density
Fixed density value, thus the average number of nodes per square kilometer for this distribution
class.

Clutter Classes
Clutter classes contained in the clutter database of the project can be assigned to the distribution
class. Therefore the drop-down list on the right-hand side contains all available clutter classes
which have not been assigned yet. By selecting a clutter class and pressing the Add button, the
defined distribution settings are considered in the area of the selected clutter class. Selected
clutter classes can be removed from the distribution class by pressing the Delete button. If the
option “Colorize Clutter Classes” is enabled, the list entries are displayed with the color of the
corresponding clutter class.

Distribution Area
The area which shall be considered for the distribution can be specified with its lower-left and
upper-right corner coordinates. By pressing the Reset button, the coordinates are set in order to
obtain the maximum possible distribution area.

Node

Template
The general parameters of the nodes to be created can be specified with a template node.
The available templates are contained in the Component Catalogue, which can be directly
accessed by pressing the Edit button.

Height
The height of the nodes above ground level has to be specified in meters.

Channel ID
The drop-down list contains the available channel IDs of the channels defined on the
Channel tab of the System Configuration dialog. The selected channel ID will be
assigned to all created nodes.

10.1.7 Image Handling
Visualize the background and overlay images in the Project View.

Image files with the extensions .bmp, .jpg, .png, .gif, or .tif are supported and can be loaded
and configured in CoMan. The Image Configuration dialog can be accessed by selecting Image >
Configuration from the Image menu.
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Figure 898: The Image Configuration dialog.

Image Files
One or more image files can be loaded into the current project by pressing the Add button.
Selected images can be removed from the project by clicking Delete.

Image Properties
An imported image usually requires correct repositioning. This can be done either by specifying
the coordinates of the Lower-left corner together with the Width and Height of the image, or
by loading an already available geo reference file. If the image adjustment is done manually, a
geo reference can be stored for later use by pressing the Save button in the geo reference sub
section. Images can be displayed as a standard background image in the xy-plane or as overlays
for topography or result databases.

Note:  Images can be moved and scaled also with the mouse using the Image Move
Tool or the Image Scale Tools, respectively.

Plane
The plane to display the selected image can be defined with the drop-down list.

Transparency (2D View)
The transparency level of the selected image can be adjusted with the slider. A value of zero
percent results in an opaque image while a value of one hundred percent results in a completely
transparent image.

The specified settings are applied after pressing the Apply button.
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Move Images
Change image locations readily using the Image Move Tool

The Image Move Tool can be accessed by selecting Image > Move Image from the Image menu.

In case the project contains several image files, the image to be moved has to be selected from a
list. To move an image to a new location, click on the image with the left mouse button and keep it
depressed while moving the mouse cursor to the desired location. Once the image is in the correct
position, release the mouse button. The Image Move Tool is active as long as no other tool is selected.
Therefore it is possible to move an image several times.

Note:  All tools can be closed by pressing the ESC key on the keyboard. In this case the
active operation will be canceled and the Selection Tool will be activated.

Scale Images
Scale images readily using the Image Scale Tool.

Images can be scaled in CoMan either directly using the mouse or by drawing a reference line with a
defined length.

Scale Image
In order to scale an image directly using the mouse, select Image > Scale Image from the Image
menu. In case the project contains several image files, the image to be scaled has to be selected from
a list. To scale an image, click on the image with the left mouse button and keep it depressed while
moving the mouse cursor until the image has the desired proportions. Once the image has the correct
dimensions, release the mouse button. The scale tool is active as long as no other tool is selected.
Therefore it is possible to scale an image several times.

Scale Image Via Line
Images can also be scaled by drawing a reference line and defining a corresponding length for this line.
This option can be selected by choosing Image > Scale Image Via Line from the Image menu. In
case the project contains several image files, the image to be scaled has to be selected from a list. After
that, the user will be asked to draw the reference line with the mouse by clicking left for starting and
ending point of the line. When the line has been drawn, its corresponding length has to be specified in
order to scale the image.

Note:  Width and height of the image are always scaled proportionally. If this is not desired,
the scaling has to be done manually (with lock ratio disabled) by adjusting the values for
Width and Height separately in the Image Configuration dialog.  

Note:  All tools can be closed by pressing the Esc key . In this case the active operation will
be canceled and the Selection Tool will be activated.
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10.1.8 Additional Tools

Additional Data Tool
Add highlighting or illustrations to the scenario database.

Additional database objects can be added such as rectangles, lines, polylines, circles and text and
do not influence the computation. The Additional Data Tool can be accessed by selecting Project >
Additional Data from the Project menu or by pressing the corresponding button on the Project
toolbar.

Additional data objects can be stored in different layers, which can be enabled or disabled for
visualization separately. Currently additional data objects can be shown in the 2D View only.

Figure 899: The Additional Data dialog.

Layer
The currently active layer can be selected using the drop-down list on top. The name of the active
layer can be edited directly.
New layers can be added to the list by pressing the Add button. An existing layer can be removed
(together with all its content) by pressing the Delete button.
Layers can be shown or hidden using the Visible check box.

Object
The type of object to be inserted with the mouse can be selected in this section.

Rectangle
Two opposite corner of the rectangle have to be defined by pressing the left mouse button.
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Polygon
Definition points can be inserted by clicking the left mouse button. Pressing the right mouse
button will close the polygon by connecting the first and the last definition point.

Circle
The first click with the left mouse button defines the center of the circle. The second click
with the left mouse button defines the radius.

Ellipse
The two vertices of the ellipse can be defined with the first and the second click with the left
mouse button.

Line / Polyline
Definition points can be inserted by clicking the left mouse button. Pressing the right mouse
button will finish the input for this object.

Text
The first click with the left mouse button defines the position of the left corner of the bottom
line, thus the starting position for the text input. The text to be displayed can be specified
using the keyboard. The second click with the left mouse button finishes the text input.

Selection Tool
Already available objects corresponding to the currently active layer can be selected using
the selection tool. Objects belonging to other layers than the active one can not be selected.
If an object is selected, a rubber band will be displayed to indicate its bounding box.
To move an object, click the left mouse button near the rubber band and keep the mouse
button pressed while moving the mouse to the new object location. Depending on the
selected object, individual vertices can be changed by clicking the left mouse button near
the vertex to be changed.

Color
The color of the object can be changed by clicking into the colored rectangle.

Filled
If this option is enabled, the object will be displayed filled.

Bold
The inserted text will be formatted bold.

Italic
The inserted text will be formatted italic.

Line Width / Text Size
Width of lines or text size in points.

Orientation
Azimuthal orientation of object (counter clockwise rotation).

Note:  All tools can be closed by pressing the Esc key on the keyboard. In this case the
active operation will be canceled and the Selection Tool will be activated.
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Auto Calibration
Automatically calibrate propagation models based on measurement data.

Some propagation models support the calibration of material properties and of clutter/land usage
databases. The following diagram shows the basic procedure for the calibration of the propagation
models.

Figure 900: Procedure for the calibration of propagation models.

Note:

Calibration files can only be generated if measurement data is located within the prediction
area or at the prediction points.

If the dominant path prediction model is used, the adaptive resolution management has to
be disabled.

The calibration tool can be used to tune wave propagation models based on calibration files obtained
during wave propagation predictions. The calibration tools can be started by selecting Computation >
Auto Calibration from the Computation menu. One or more calibration files can be added to the list.
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Figure 901: The Calibration dialog.

Calibration Files Used for Model Tuning 
Files can be added by clicking on Add files or deleted by clicking on Remove file.

Configuration of Calibration

General Settings
This allows the user to influence the selection of the measurement points, thus only points
in a given power (dBm), path loss (dB) or distance (m) range will be considered.

Model Settings
The ranges of the model parameters can be defined here. As larger the range is, as longer
the calibration will take. The model parameters depend on the selected propagation
model, thus each model offers individual model parameters. The model parameters for the
dominant path model are shown in Figure 902.

Materials
Depending on the propagation model the material database or the clutter/land usage
database can also be calibrated.

Start
Starts the calibration computation. The current progress is displayed in a progress bar.

Results
After the calibration process has finished, the calibration results can be displayed.
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Figure 902: The Settings dialog - model parameters for the dominant path model.

The goal of the optimization is to achieve a minimum mean error (nearest to zero). The standard
deviation is not considered and thus might be larger. One of the following optimization methods can be
selected:

• Minimum mean squared error:

The goal of the optimization is to achieve a minimum mean squared error. The standard deviation is
not considered and thus might be larger.

• Minimum standard deviation:

The goal of the optimization is to achieve a minimum standard deviation. The mean error is not
considered and thus might be larger.

• Minimum weighted error:

The goal of the optimization is to find the best combination of minimum mean error and minimum
standard deviation. The weighting between mean error and standard deviation can be adapted by
the user.
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Figure 903: The Parameters for Dominant Path dialog.

Figure 904: The Results for Dominant Path Urban dialog.

The statistical evaluation gives information about mean value and standard deviation from
measurements to predictions before and after the calibration. Depending on the optimization method
different results can be obtained.

Define Prediction Area
Define an area for the prediction manually or graphically.

The prediction area can be defined either manually using the Prediction tab of the System
Configuration dialog or graphically using the Prediction Area Tool. The Prediction Area Tool can be
started by selecting Project > Define Prediction Area (Rectangle) from the Project menu or by
pressing the corresponding button on the Project toolbar. After the tool is started, the mouse cursor
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changes to a cross and the prediction area can be drawn. The first left-click defines an arbitrary corner
point of the area. The area can be adjusted while moving the mouse. A second click ends the tool and
assigns the new prediction area. The defined prediction area will be displayed with a red rectangle in
the 2D View as long as the computation mode for Wave Propagation Predictions is not set to point-to-
point for node locations on the System Configuration dialog.

Note:  The maximum size of the prediction area is automatically limited to the maximum
size of the environment database.

All tools can be closed by pressing the Esc key. In this case the active operation will be canceled and the
Selection Tool will be activated.

Mouse Meter
Measure distances with the mouse meter tool.

The Mouse Meter Tool can be used to measure distances within the 2D View. The tool can be activated
by selecting Analysis > Mouse Meter from the Analysis menu or by pressing the corresponding
button on the Analysis toolbar. The mouse cursor will change to a cross symbol and the next left-click
in the 2D View will start the distance measurement. After that the distance between the first click point
and the current mouse location will be measured while moving the mouse. Clicking a second time will
freeze the measurement. Clicking again will start the measurement process from the beginning. The
Mouse Meter Tool can be closed by pressing the Esc key.
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Figure 905: Example of a distance measurement using the Mouse Meter tool.

Command Overview

Table 92: Mouse meter tool commands.

Command Description

Ctrl + M Start the Mouse Meter Tool.

L Activates or deactivates the Mouse Meter line
display.

C Activates or deactivates the Mouse Meter circle
display.

Note:  Only possible if the polyline
option is not active.

P Activates or deactivates the Mouse Meter polyline
option.
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Command Description

Left mouse button click Sets new reference (centre) point.

Right mouse button click Closes the Mouse Meter Tool if the polyline option
is not active. Inserts a new polyline point in case
the polyline option is active.

Esc Closes the Mouse Meter Tool.

Note:  All tools can be closed by pressing the ESC key on the keyboard. In this case the
active operation will be canceled and the Selection Tool will be activated.

Object Information
Obtain information about objects in the database using the object information tool.

The Object Information Tool can be started by selecting Analysis > Object Information from the
Analysis menu or by pressing the corresponding button on the Analysis toolbar. If the tool is active, tool
tips showing information about the modeled nodes will be displayed while the mouse cursor is above a
node.
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Figure 906: Example of the Object Information tool.

After clicking on a node, all available connectivity results related to the selected node will be displayed
in a dialog.
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Figure 907: Node Information dialog.

Selected Node
Some details of the selected node, such as type and location.

Results of Node
Computed result values of selected node.

Connectivity of Node
The lower section of the dialog shows the connectivity of the selected node, thus the information
flow paths originating at the selected node. In case the selected node has multiple transceivers,
the transceiver to be considered can be selected using the drop-down list.

The number of available paths and the selected path filters (Local Settings > Display) is depicted as
well.

Note:  All tools can be closed by pressing the Esc key on the keyboard. In this case the
active operation will be canceled and the Selection Tool will be activated.
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Path Visualization
Show the possible information flow on paths between the nodes of the network with the Path
Visualization Tool.

The path visualization tool can be started by selecting Analysis > Show Paths from the Analysis
menu, or by pressing the corresponding button on the Analysis toolbar. After selecting one or multiple
nodes, paths originating at these nodes will be displayed. There are several drawing and display options
for connectivity path data available, which can be changed on the Display tab of the Settings dialog. If
no paths are available for the selected nodes, a corresponding message will be displayed in the Output
View. To exit the Path Visualization Tool, select Analysis > Show Paths from the Analysis menu or the
corresponding button on the Analysis toolbar has to be selected again.

Figure 908: Example of the path visualization tool.

Note:  All tools can be closed by pressing the Esc key on the keyboard. In this case the
active operation will be canceled and the Selection Tool will be activated.

Threshold Analysis
Analyze prediction results with the Threshold Tool using an arbitrarily user defined threshold value.

The threshold tool is applied to prediction results computed for horizontal planes (area predictions)
using an arbitrarily user defined threshold value. The Threshold Tool can be started by selecting
Analysis > Show Threshold from the Analysis menu or by pressing the corresponding button on the
Analysis toolbar. The result to be considered has to be loaded using the File Browser prior to starting
the tool. After starting the Threshold Tool a dialog opens, where the user defined threshold can be
specified.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
10 Connectivity Manager (CoMan) p.929

Figure 909: The Field Strength dialog.

The threshold plot will be displayed after closing the dialog by pressing OK.

Figure 910: Example of the threshold tool.

The Threshold Tool can be closed by selecting Analysis > Show Threshold from the Analysis menu or
by pressing the corresponding button on the Analysis toolbar again. The original result will be visualized
then.
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10.2 Projects

10.2.1 Create a Project
Create a new project in CoMan, select the scenario as well as the data base.

In order to do simulations with CoMan, a new project has to be created first. This can be done by
selecting File > New Project from the File menu or by clicking on the corresponding toolbar button. A
dialog will open where the simulation environment and further parameters can be specified.

Figure 911: The New Project dialog.

Scenario
Selection of simulation environment depending on the available databases.

Databases & Parameters
The database(s) of the modeled simulation environment has (have) to be specified in this section
depending on the selected scenario. In addition, the location and name of a folder to store the
computation results has to be specified.

Note:  The absolute path for the result folder will be added automatically, depending
on the absolute path of the database, if the default name is not changed, but it can
still be changed manually.

After the creation of a new project the wireless system to be simulated has to be configured. This
can be done either manually using the graphical user interface or by importing data from external
applications.
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10.2.2 System Configuration
Configure the wireless system to be simulated using the System Configuration dialog.

The wireless system to be simulated can be configured via Project > Parameter in the Project menu
or by clicking the corresponding button of the Project toolbar.

Figure 912: The System Configuration dialog showing the Network tab.

Network Tab
On the Network tab you can set general definitions for the overall network.

General
General network settings:

Name
Arbitrary name of the network. Results covering the whole network will contain this name as
part of their file names.

Type
Type of the network. This parameter can not be changed as it depends on the simulation
scenario which was selected when the project was created.

Time Variance
Available for indoor projects. Node locations and orientations as well as objects of the vector
database can vary over time.

Enable
Enable or disable time variance for whole project.

Starting time
First time stamp of simulation in seconds.

End time
Last time stamp of simulation in seconds. 
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Time interval
Granularity of time stamps between starting time and end time in seconds. For example, a
starting time of 0 seconds, an end time of 10 seconds and a time interval of 1 second result
in 11 time stamps with a time difference of 1 second.

System Tab
On the System tab you can set parameters that define the wireless air interface.

Figure 913: The System Configuration dialog showing the System tab.

Name
Arbitrary name to identify the wireless system.

Save Default / Load Default
Save current system configuration to the Component Catalog or load a system configuration from
the Component Catalog, respectively.

Type
Type of air interface. This parameter can not be changed in CoMan

Multiple Access Scheme
Multiple access scheme of the air interface. This parameter is typically set to CSMA-CA (carrier
sense multiple access with collision avoidance) for mesh/sensor networks.
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Duplex Mode
The duplex mode of the system is automatically pre-selected depending on the chosen multiple
access system but can also be changed manually.

Noise Rise due to Coexisting Networks
Coexisting networks operating in the same or in adjacent frequency bands cause additional
interference, which can be specified here.

Channels
The available radio channels of the system are listed on the Channels tab. Channel
Configurations can be added, modified or deleted using the Add, Edit, and Delete buttons.

Services
The available services of the wireless system can be defined on the Services tab of the dialog
page. At least one service has to be defined per system. Service Configurations can be added,
modified or deleted using the Add, Edit, and Delete buttons.

Database Tab
The databases used for the simulations are listed on the Database tab. Depending on the project
different types of databases (vector, topography, clutter) are available.

Figure 914: The System Configuration dialog showing the Database tab.

Vector Database
Available for indoor and urban projects.

Database
Path and file name of the vector database.

Material Properties
During the prediction phase the material properties of the vector objects contained in
the database can be considered either individually for each object, as defined in the
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database, or the same default properties can be used for all objects. Both the default and
the individual material properties can be modified by clicking on the corresponding Edit
button.

Note:  Material parameters, which actually impact the wave propagation
prediction, depend on the selected propagation model and further propagation
parameters. Please refer to the ProMan user manual for more details about the
propagation models.

Topography Database
Available for urban (optional) and rural projects.

Consider Topography Database
For urban projects, the consideration of topography database (if available) is optional and
can be disabled. The topography database is mandatory for rural projects and must be
considered

Database
Path and file name of the topography database.

Nodes Tab
All nodes of the network are listed on the Nodes tab. Node Configurations can be added, modified or
deleted by pressing the corresponding buttons at the bottom of the dialog. Configuration of Multiple
Nodes/Transceivers is possible if multiple nodes are selected before pressing the Edit button.

Figure 915: The System Configuration dialog showing the Nodes tab.

Note:  Node names marked with an asterisk indicate nodes which have been modified.
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Prediction Tab
The parameters of the simulation area and the wave propagation model can be specified on the
Prediction tab. Wave propagation results can be selected in the lower section of the dialog.

Figure 916: The System Configuration dialog showing the Prediction tab.

Simulation Area
Wave propagation results can be computed at the locations of the nodes (point-to-point
prediction), for the total available simulation area or for an arbitrary rectangular area smaller than
the total simulation area. The point-to-point prediction for the locations of the nodes is required
for the simulation of the connectivity between the nodes.

Resolution
Specify the resolution (pixel size) of the propagation results.

Note:  The smaller the resolution, the more accurate the prediction results.
However, the computation time increases with decreasing resolution of the
prediction area.

Prediction Height(s)
Prediction heights can be specified for area predictions only. Multiple prediction heights can
be defined in indoor environments only and have to be separated with spaces.
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Prediction Model
The available prediction models suitable for the chosen simulation environment are listed in the
drop-down list. The settings of the selected propagation model can be edited by clicking on the
Settings button.

Note:  The point-to-point prediction mode for predictions at node locations is
supported for only a subset of the available propagation models.

Computation Mode for Signal Level

The computation mode for the signal level along the propagation path can be either
deterministic (Fresnel Coefficients and GTD/UTD) or Empirical. The deterministic mode
uses Fresnel Equations for the determination of the reflection and transmission loss and
the GTD/UTD for the determination of the diffraction loss. This model has a slightly longer
computation time and uses three physical material parameters (permittivity, permeability
and conductivity). The empirical mode uses five empirical material parameters (minimum
loss of incident ray, maximum loss of incident ray, loss of diffracted ray, reflection loss,
transmission loss).

For correction purposes or for the adaptation to measurements, an offset to those material
parameters can be specified. As a result, the empirical model has the advantage that the
needed material properties are easier to obtain than the physical parameters required for
the deterministic model. Also the parameters of the empirical model can more easily be
calibrated with measurements. It is therefore easier to achieve a high accuracy with the
empirical model.

Note:  Please refer to the ProMan user manual for more details about the wave
propagation models.

Additional Options
For urban environments indoor predictions of the buildings can also be done. Settings of the
Optional Indoor Prediction can be specified by clicking on the Settings... button after enabling
the Indoor Prediction option.
For rural environments, it is possible to use the exact, matrix based, receiver coordinates
instead of a vertical plane approximation. The consideration of the clutter database during wave
propagation prediction can be enabled or disabled if clutter data is available in the project.
Depending on the selected propagation model, additional Knife Edge diffraction and or 3D
scattering occurring on the topography database can be considered as well.

Results
Results which shall be computed and saved to disk during wave propagation simulation can be
enabled or disabled.

Connectivity
Additional parameters for connectivity simulations can be specified on the Connectivity tab.
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Figure 917: The System Configuration dialog showing the Connectivity tab.

Path determination

Weights for Selection of Optimum Paths
The path searching algorithm uses four values (signal-to-noise-and-interference ratio at the
receiving node, path loss between two nodes, path delay between two nodes and probability
of failure along the path between two nodes) to determine the optimum path of information
flow between the nodes of the network. The effects of the different values (weight factors)
can be defined to be between zero and one hundred percent each.

Note:  Along a path containing more than two nodes, the maximum SNIR
value and the maximum path loss value occurring along the path is considered,
whereas the values of path delay and probability of failure are summed up along
the path. 

Miscellaneous
The maximum number of hops per path, i.e. the maximum number of nodes between transmitter
and receiver node can be limited optionally. This makes it possible to configure the path
determination according to the limitations of the hardware.

Results
Results which shall be computed and saved to disk during connectivity simulation can be enabled
or disabled.
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10.2.3 Wave Propagation
Perform wave propagation for point-to-point or area predictions.

After the configuration of the wireless network is completed, wave propagation simulations can
be computed either for all nodes of the network or only for selected nodes. A wave propagation
computation can be started by selecting Computation > Compute All > Wave Propagation or
Computation > Compute Selected > Wave Propagation from the Computation menu or by
clicking the corresponding button of the Project toolbar. Computations for a selected node can be
started also from the context menu, which can be opened from the context menu.

There are two different computation modes available:

1. Point-to-Point Prediction

Point-to-point predictions for node locations are required to do connectivity analysis between the
nodes of the network, i.e. without this result it is not possible to do connectivity predictions.

Note:  Results of point-to-point prediction can not be displayed in CoMan and are
therefore not selectable in the File Browser.

2. Area prediction

Wave propagation predictions can be done for horizontal prediction planes as well. The area to
be predicted, the resolution of the results as well as the height(s) of the prediction planes can be
defined on the Prediction tab of the System Configuration dialog. The results which have been
selected to be computed and stored to the disk can be displayed in 2D view and 3D view using the
File Browser.

These two prediction modes can be selected on the Prediction tab of the System Configuration
dialog. Propagation results which have been computed will be saved in the propagation sub folder
within the specified result folder.

Figure 918: Example of wave propagation results.
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10.2.4 Network Prediction
Perform network prediction based on wave propagation results.

Network predictions require wave propagation prediction results on horizontal prediction planes for
more than one transceiver.

Note:  Network predictions can be done only after wave propagation prediction has been
computed for all nodes of the network.

A network prediction can be started by selecting Computation > Compute All > Network from the
Computation menu or by clicking the corresponding button of the Project toolbar.

Network predictions can be done for horizontal prediction planes only. The area to be predicted, the
resolution of the results as well as the height(s) of the prediction planes depend on the corresponding
parameters of the wave propagation results which are considered for the computation. The results
which have been selected to be computed and stored to disk can be displayed in the 2D view and 3D
view using the File Browser. Network results which have been computed will be saved in the sub folder
network within the specified result folder.

Figure 919: Example of network prediction results.

10.2.5 Connectivity Prediction
Perform connectivity prediction based on point-to-point mode wave propagation.

After the wave propagation prediction in point-to-point mode for the node locations is completed,
connectivity simulations can be computed either for all nodes of the network or only for selected nodes.
Connectivity computations can be started by selecting Computation > Compute All > Connectivity
or Computation > Compute Selected > Connectivity from the Computation menu or by clicking
the corresponding button of the Project toolbar. Computations for a selected node can be started also
from the context menu, which can be opened from the context menu.

The results which have been selected to be computed and stored to the disk can be displayed in the 2D
view and 3D view using the File Browser. Connectivity results which have been computed will be saved
in the network sub folder within the specified result folder.
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Besides the binary file, which can be selected with the File Browser for visualization of the paths of
information flow, there are two additional files in ASCII format, which also contain the computed
connectivity data. These additional outputs can be selected on the Connectivity tab of the System
Configuration dialog.

Figure 920: Example of connectivity prediction results.

10.2.6 Import and Export Options
Show the possible information flow on paths between the nodes of the network with the Path
Visualization Tool..

Project Data
Project data can be imported into the current CoMan project from different formats. All available import
filters are available under File > Import > Project Data. Descriptions of the individual import filters
can be found by clicking on the corresponding filter in the list below.

ProMan Project File

Object Data
Object data can be imported into the current CoMan project from different formats. All available
import filters are available under File > Import > Object Data. Descriptions of the individual
import filters can be found by clicking on the corresponding filter in the list below.

CSV File

Customer specific
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Measurement Data
Measurement data can be imported from arbitrary ASCII file formats. The import filter is available
under File > Import > Measurement Data.

Additional Data
Additional data can be imported from a specific ASCII line format with keywords. The import filter
can be reached via File > Import > Additional Data from the File menu.

Export Data
Object Data

Object data of the currently active CoMan project can be exported to different formats. All
available export functions are available under File > Export > Object Data. Descriptions of the
individual export options can be found by clicking on the corresponding item in the list below.

ASCII file

CSV File

Customer Specific

Map Data
Map data of the currently active CoMan project can be exported to different formats. All available
export functions can be reached via File > Export > Map Data from the File menu. Descriptions
of the individual export options can be found by clicking on the corresponding item in the list
below.

Image File

Google Earth File

Additional Data
Additional data available in the currently active CoMan project can be exported to an ASCII file.
The export function is available under File > Export > Additional Data. The file format is fixed.

Additional data available in the currently active CoMan project can be exported to an ASCII file. The
export function can be reached via File > Export > Additional Data from the File menu. The file
format is fix. A description of the file format can be found here.

10.2.7 Analysis of Results
Choose an appropriate method for analyzing computation results with CoMan.

Wave Propagation and Network Prediction
• Graphical Analysis

Wave Propagation Prediction  and Network Prediction results that have been computed for an
arbitrary user defined prediction area can be displayed in the 2D View and the 3D View. The color
scale and the values corresponding to the individual color margins can be visualized in the Legend
View.

• Numerical Analysis
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Individual values of the prediction pixels are displayed in the status bar while moving the mouse
cursor in the 2D View. Besides this, all results predicted for user defined horizontal planes can be
analyzed using the Threshold Tool. Additionally it is also possible to export prediction results to
ASCII files, which can be analyzed and post-processed with other tools.

Connectivity Prediction
• Graphical Analysis

Connectivity Prediction results can be visualized graphically in the 2D View and the 3D View using
the Path Visualisation Tool.

• Numerical Analysis

The connectivity of individually selected nodes can be further analyzed with the Object Information
Tool. Additionally it is also possible to output the results of the connectivity prediction to ASCII files,
which can be analyzed and post-processed with other tools.

10.2.8 Modification of Pixel Database
Modify pixel databases, such as result databases or topography and morpho/clutter databases, using
different methods.

If a pixel database is visible in the Project View, the different database modification options available
for pixel databases can be selected via Edit > Pixel Data from the Edit menu. The available operations
are as follows:

• Interpolate

Interpolate undefined (“not computed”) pixels using values of surrounding pixels.

• Filter

Filter pixel values using filters of different type and order.

• Smooth

Beautify pixel database, e.g. for presentations, by assigning a higher resolution followed by a filter
operation. 

• Edit Values

Arbitrarily edit values contained in the pixel database.
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10.3 Addenda

10.3.1 User Defined Legend
Customize the legend in the Legend View for better interpretation of results.

CoMan offers the possibility to individually customize the legend displayed in the Legend View. The
dialog to customize the legend of the currently displayed result or scenario database can be accessed
from the Legend tab of the Settings dialog by selecting User Defined in the Type section and
pressing the Configure button.

Once a user defined legend has been defined for a specific result or a scenario database it will be
displayed for all results or databases of the same type within the current project. Another legend type
has to be selected in the Type section of the Settings dialog in order to use the default legend again.
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Figure 921: The User Defined Legend dialog.

Settings

Number of margins
The legend can have up to 14 discrete color margins.

Mode
The mode of the legend selects the sign of the defined scale margins. Possible values are
Threshold more, Equal, Threshold less or Space (no sign).

Margin description equals margin value
Copies the specified margin value automatically to the margin description box.

Legend

Title
An arbitrary legend title can be specified to be displayed in the caption of the Legend View.
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Margin Color
The color of the margins can be changed by clicking on the colored rectangle of a selected
margin.

Margin Value
The margin values represent the threshold values which are contained in the pixel database.
The thresholds are used to colorize the result or the scenario database with the defined
margin colors.

Margin Description
Descriptions of the margins corresponding to the defined margin colors. These values or
strings will be displayed in the Legend View right after the margin signs. 

10.3.2 Analysis of Connectivity Paths
Visualize connectivity prediction results in the 2D View and the 3D View.

Connectivity Prediction results can be visualized graphically in the 2D View and the 3D View using the
Path Visualization Tool for a selected node. The path types to be shown as well as the colorization of
the displayed paths can be specified on the Display tab of the Settings Dialog. Additional descriptive
information for the connectivity paths of the selected node can be obtained by using the Object
Information Tool.

Display of Path Types
Paths and their sub sections between the nodes along the path can be displayed and colored according
to their type. In case several path types apply to a path section (for example direct neighbor is also an
optimum path), the display color is selected according to the following priority order:

1. Path to Direct Neighbor

2. Path to Gateway Node

3. Optimum Path

Figure 922: Example of path types.
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Display of Path Loss Thresholds
User defined path loss thresholds for the path sections along the connectivity paths of a selected node
can be visualized as well. The path sections are colorized according to the path loss along the path
section taking into account the specified threshold values. The threshold values and the corresponding
drawing color can be specified on the Display tab of the Settings dialog. 

Figure 923: Example of path loss thresholds.

Display of Path Delay Thresholds
The occurring delays along the connectivity paths of a selected node can be evaluated with CoMan. The
path sections are colorized according to the summed path delays along the path taking into account the
specified threshold values. Starting from the selected node, the overall delay consisting of path delay
and process delay of the nodes located in between is added along the path. A path section is colorized
depending on the delay at the end of the section before the next node. The threshold values and the
corresponding drawing color can be specified on the Display tab of the Settings dialog.

Figure 924: Example of path delay thresholds.

For example the color of the path section between node “WHA APD 16” and “WHA APD 48” is
determined as follows:

 Delay (at node “WHA ADP 48”) = Path delay (between nodes “WHA ADP 0” and “WHA ADP 16”)

                                                          + Process delay (node “WHA ADP 16”)
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                                                          + Path delay (between nodes “WHA ADP 16” and “WHA ADP
48”)

            As Delay (at node “WHA ADP 48”) > 900ns ==> red color

10.3.3 Bearer Configuration
Configure the parameters of the bearer.

The parameters of the bearer can be specified on the Bearer Configuration dialog.

Tip:  The Bearer Configuration dialog opens after clicking the Add or Edit button on the
System Configuration dialog.

Figure 925: The Bearer Configuration dialog.

Name
Arbitrary name of bearer.

ID
Unique ID of bearer (can not be changed).

Type
Type of bearer (for example circuit switched, packet switched).

Priority
Priority level of bearer.

QoS Class
Quality of service class for this bearer.
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Downlink / Uplink

Data Rate
Net data rate of bearer.

Required SNIR
Minimum signal-to-noise-and-interference-ratio that is required to use this bearer.
Receiver locations where the predicted SNIR is above this threshold will be assigned to this
transmission mode and the maximum available data rate for the corresponding Rx locations
will be set to the value specified for this bearer.

Required Signal Level
Threshold of signal level, which is required to use this bearer.

Max. TX Power
Maximum transmit power that can be used for this bearer.

Power Backoff
Power headroom that can be specified related to maximum available transmit power of
the transmitter. This headroom can be used to reduce available transmission power and
therefore crosstalk probability for high modulation and coding schemes.

Note:  This backoff value influences only the transmit power used for data
transmission. The power assigned for pilot signals is not influenced.

10.3.4 Channel Configuration
Configure the parameters of the radio channel.

Parameters of radio channel can be specified on the Channel Configuration dialog.

Tip:  The Channel Configuration dialog opens after clicking the Add or Edit button on the
System > Channel tab of the System Configuration dialog, which can be accessed from
the Project menu.
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Figure 926: The Channel Configuration dialog.

ID
Unique ID of radio channel.

Note:  This value is determined automatically and can not be changed.

Center Frequency
Center frequency of radio channel in downlink direction.

Bandwidth
Available bandwidth of radio channel.

Adjacent channels
Frequency separation of neighboring channels.

Note:  This value is determined automatically and can not be changed.

10.3.5 Export Map Data to ASCII File
Export map data to ASCII file.

Map data (result or pixel databases) shown in the Project View can be exported to ASCII file by
selecting File > Export > Map Data > ASCII File from the File menu. After that, a dialog opens,
where the file path and name of the resulting ASCII file has to be specified.

10.3.6 Export to Google Earth File
Export result data to Google Earth.

Result data shown in the Project View can be exported to Google Earth. To export the content of the
2D View to Google Earth select File > Export > Map Data > Google Earth File. After that, a dialog
opens, where the export settings can be specified.
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Figure 927: The Export to Google Earth dialog.

General

Filename
Specify a file name to store the image file(s) and the Google Earth file. CoMan automatically
suggests a default file name, which is created using the path of the current result folder.
By default, the format of the images is .bmp. However, this can be changed by selecting
another file extension.

Prediction Data
Simulation results of area predictions can be exported if available. The transparency of the
exported data can be specified arbitrarily between opaque and fully transparent using the
slider. Pixels which are not computed can be set to a user defined color. The default color can
be changed by clicking on the color rectangle. The transparency of the undefined pixels can be
adjusted only if .gif images have been selected for the export format.

Path Data
Connectivity path data can be exported optionally if available. The transparency of the exported
path data can be specified arbitrarily between opaque and fully transparent using the slider.

Note Data
Node locations can be exported optionally if available. The transparency of the exported nodes
can be specified arbitrarily between opaque and fully transparent using the slider.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
10 Connectivity Manager (CoMan) p.951

Legend
The currently active Legend View can be exported optionally. The transparency of the exported
image can be specified arbitrarily between opaque and fully transparent using the slider.

10.3.7 Export Image File
Export result data to an image file.

Map data shown in the Project View can be saved to image files. The following file formats are
supported:

• .bmp

• .jpg

• .png

• .gif (not 3D View)

• .tif (not 3D View)

To export the content of the different views to image files select File > Export > Map Data > Image
File. Subsequently a dialog will open where the export settings can be specified.

Figure 928: The Export to Image File dialog.

General

Filename
Specify a file name to store the image file(s). CoMan automatically suggests a default
file name which is created using the path of the current result folder and the name of the
current project. By default, the format of the image is bitmap. However this can be changed
by selecting another file extension instead of .bmp.
The size of the image created from the 2D View can be specified either by defining a
resolution or a scale factor. The default resolution is chosen to be the current resolution of
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the 2D View. The default scale is 1000, thus one meter in real world coordinates is scaled to
round about one millimeter on the image.

Export
The views to be saved to images can be selected in this section.

For the 2D View it is possible to save an additional geo reference file, which offers the possibility to
reference the image using real world coordinates.

The content of the 3D View can be exported to an image file as well. However, the file formats are
restricted to .bmp, .jpg, and .png.

Alternately, the current Legend View can be exported if it is available.

10.3.8 Export Object Data to CSV File
Export node and transmitter data to a .csv file.

Node and transmitter data can be exported to arbitrary CSV (comma-separated values) format. To
export object data of the current CoMan project to a .csv file, select File > Export > Object Data >
CSV File. Then specify the name of the file to be created as well as the data format.

Figure 929: The Object Data dialog.
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Filename
File path and name of the data file to be written.

Data Format

Preview of first line
Displays the preview of the specified data format when the option Write Headline is
enabled.

Comment Indicator
Sign which indicates comments within the file to be created.

Column Separator
Sign which separates individual data columns within the file, for example a semicolon.

Decimal Separator
Sign which is used for decimal separation.

Write Headline
Displays a description of the specified file format and write to file. The line which will be
written to the file as a comment is displayed in the Preview of first line field.

List with content of the individual columns
The content of the individual columns of the data file has to be specified using the drop-
down list. It contains possible content descriptions of the data columns which can be added
to the list by pressing the Add button. The order of the columns can be changed by using
the Up or Down button after selecting an item of the list to be moved. Items which are
removed from the list will be available in thedrop-down list again. 

10.3.9 Import Additional Data from ASCII File
Import additional data for highlighting and illustration from an ASCII file.

Additional data such as vector objects for highlighting and illustration purposes, shown in the Project
View, can be imported from ASCII file by selecting File > Import > Additional Data. A dialog will
open where the file path and name of the ASCII file to be imported has to be specified.

The format of the file is restricted to the definitions given below. Lines which do not start with a
keyword listed below will not be considered. Each layer or object starts with a new line. Individual
values have to be separated with a space.

Data Layer

Tip:  At least one layer has to be available in order to import data objects. In case data
layers are already defined in the project, objects can be imported also to these existing
layers if the correct layer ID is specified.
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Table 93: Importing a data layer.

Keyword Arbitrary Name ID Visible (yes or no)

LAYER “Layer 1” 0 y or n

Note:  At least one layer has to be available in order to import data objects. In case data
layers is already defined in the project, objects can be imported also to these existing layers
if the correct layer ID is specified.

Rectangle Objects

Table 94: Importing a rectangle object.

Keyword Layer ID Line Width Color (RGB) Filled Mode
(yes or no)

Lower- Left
Corner (x,
y, z)

Upper-Right
Corner (x,
y, z)

RECTANGLE 0 1 255 0 128 y or n 0.00 0.00
0.00

10.75 10.34
0.00

Polygon Objects

Table 95: Importing a polygon object.

Keyword Layer ID Line Width Color (RGB) Filled Mode
(yes or no)

Number of
Definition
Points

Definition
Points (x, y,
z)

POLYGON 0 2 255 0 128 y or n 4 -1.75
10.34 1.50
-4.45 .....
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Polyline Objects

Table 96: Importing a polyline object.

Keyword Layer ID Line Width Color (RGB) Number of
Definition
Points

Definitions
Points (x, y,
z)

POLYLINE 0 1 255 0 128 2 3.28 2.00 1.50
4.87 3.45 1.50

Circle Objects

Table 97: Importing a circle object.

Keyword Layer ID Line Width Color (RGB) Filled Mode
(yes or no)

Lower-Left
Corner (x,
y, z)

Upper-Right
Corner (x,
y, z)

RECTANGLE 0 1 255 0 128 y or n 0.00 0.00
0.00

5.00 5.00
0.00

Ellipse Object

Table 98: Importing a polyline object.

Keyword Layer ID Line Width Color (RGB) Filled Mode
(yes or no)

Lower-Left
Corner (x,
y, z)

Upper-Right
Corner (x,
y, z)

ELLIPSE 0 2 255 0 128 y or n 0.00 0.00
1.00

10.75 15.34
1.00

Text

Table 99: Importing text.

Keyword Layer ID Font
Size

Bold Italic Color
(RGB)

Definition
Point (x,
y, z)

Orientation
(degree)

Text

TEXT 0 14 y n 255 0
128

0.00 0.00
0.00

45 “Sample
Text”
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Tip:  For the layer ID an ID of an existing data layer has to be specified. All coordinates
have to be given in the coordinate system of the project, thus in meters.

Figure 930: A sample of an import.

Note:  In case there a doubts concerning the import format, please define a corresponding
object in CoMan and export it to an ASCII file. 

10.3.10 Import Measurement Data
Import measurement data from an arbitrary ASCII file.

Measurement data can be imported from arbitrary ASCII line formats to be used in CoMan. To import a
Measurement File select File > Import > Measurement Data. Then specify the file to be imported as
well as file path and name of the conversion result.

The following dialog shows the settings and parameters which can be adjusted to specify the format of
the ASCII data to be imported.
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Figure 931: The Import Data dialog for importing measurement data.

General

Filename
File path and name of the input file.

Data Type
Type of data which is contained in the input file. Measurement values can be either field
strength [dBµV/m], path loss [dB] or receiver power [dBm] values.

Resolution
The resolution of the data can be either determined automatically or a fixed, user defined
value can be used. If the automatic mode is chosen, the tool automatically selects the
smallest distance between two measurement locations contained in the file for the
resolution.

Tip:  Only use this mode if the file contains continuous measurement values.

Input Format

Comment Indicator
Sign which indicates comments within the input file. If a line starts with the selected
comment sign, it will be ignored, thus not read.
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Column Separator 
Sign which separates individual data columns within the file. The column separation sign
can be determined using a standard text editor.

Keywords for Data Section
Keywords for the begin and the end of the data section to be read can be defined. If this
option is enabled all data before the “begin” keyword and after the “end” keyword will be
ignored.

List with content of the individual columns 

The content of the individual columns of the measurement file has to be specified using the drop-
down list. It contains possible content descriptions of the data columns that can be added to the list by
pressing the Add button. The order of the columns can be changed by using the Up or Down button
after selecting an item of the list to be moved. Items which are removed from the list will be available in
the drop-down box again.

10.3.11 Import Object Data from CSV File
Import node and transmitter data from an arbitrary ASCII file.

Node and transmitter data can be imported from arbitrary CSV (comma-separated values) formats.
To import object data into the current CoMan project from a .csv file, select File > Import > Object
Data > CSV File. Then specify the name of the file to be loaded as well as the format of the contained
data.
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Figure 932: The Object Data dialog for importing node and transmitter data.

General

Filename
File path and name of the data file to be used.

Object Template
Nodes contained in the Component Catalogue can be used as template for radio
parameters that are not imported from the .csv file. This means all radio parameters of the
imported nodes/transceivers that are not read from the file are copied from the selected
template.

Note:  Only radio parameters of node and transceivers can be copied from the
template.

Data Format

Preview of first line
Displays the content of the first line of data contained in the file. In case the file starts with
comment lines instead of data, the last comment line will be shown. This can be useful to
determine the format of the data contained in the file to be imported.
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Comment Indicator
Sign which indicates comments within the file to be imported. This parameter has to be
chosen according to actual file format.

Column Separator
Sign which separates individual data columns within the file, for example a semicolon. This
parameter has to be chosen according to actual file format.

Decimal Separator
Sign which is used for decimal separation. This parameter has to be chosen according to
actual file format.

List with content of the individual columns

The content of the individual columns of the data file has to be specified according to the
actual file format using the drop-down list. It contains possible content descriptions of the
data columns, which can be added to the list by pressing the Add button. The order of the
columns can be changed by using the Up or Down button after selecting an item of the list
to be moved. Items which are removed from the list will be available in the drop-down list
again.

Note:  The file must not contain further data as the one specified on this import
dialog.

10.3.12 Import ProMan Project File
Import a wave propagation or network planning project created with ProMan.

A wave propagation or network planning project which was created with the ProMan application can be
imported into a CoMan project. This makes it possible to port site and transmitter definitions as well
as some other settings specified in ProMan to a CoMan project. To import a ProMan Project File select
File > Import > Project Data > ProMan Project File. Thereafter specify the file to be imported
and the data to be considered. The following dialog shows the settings and parameters which can be
imported from a ProMan Project File.

Figure 933: The Import Project Data dialog.
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Prediction Settings

Prediction Area Definitions
If this option is enabled the border coordinates of the prediction area will be imported from
the file.

Parameters of Prediction Models
Settings and parameters of prediction models, such as path loss exponents, can be
imported optionally.

Object Settings

Nodes and Transceivers (Name and Position)
General node and transceiver parameters will be imported if this option is selected.
This means state, locations and names of nodes and transceivers as well as antenna
adjustments (type of antenna, azimuth, tilt pattern) will be imported. All other parameters
will be set to their default values.

Radio Parameters
Further radio parameters of the transceivers can be imported optionally. If this option
is enabled, transmit power, frequency and receiver noise figure of the transceivers are
imported additionally.

10.3.13 Node Configuration
Specify the parameters of a node.

Parameters of a node are specified on the Node Configuration dialog.
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Figure 934: The Node Configuration dialog.

General

Name
Arbitrary name of node.

ID
Unique ID of node (not changeable).

Type
Type of node (for example client, gateway). A node can be either static (fixed location)
or time variant (moving). If the Terminator option is enabled, the node can not act as a
messenger, thus the node can only be information source or sink and can not be between
information source and sink.

Probability of Failure
Probability for an occurring failure during transmission/re-transmission/message processing.

Process Delay
Processing time for reception-message processing-transmission cycle.

Location and Orientation
Location coordinate(s) and orientation of the node. In time variant scenarios, a location and
orientation has to be defined for each time stamp to be evaluated.
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Transceiver

Transceivers associated with the node can be added, edited and deleted using the corresponding
buttons. All corresponding parameters can be specified on the Transceiver Configuration
dialog.

10.3.14 Node Multi-Configuration
Specify the parameters of multiple nodes.

Parameters of multiple nodes can be specified on the Node/TRX Configuration dialog. This makes
it possible to assign the same value for the corresponding parameters of all selected nodes and their
associated transceivers.

Figure 935: The Node / TRX Configuration dialog.

Parameter
Parameters listed in the drop-down box can be selected to be modified. After choosing a
parameter from this list, the new value to be assigned can be specified below.

Add > >
Add a selected parameter and its new value to the list of parameters which shall be changed after
pressing the OK button.

< < Remove
Remove a parameter from the list of parameters which will be changed after pressing the OK
button. The removed parameter will be available in the drop-down list again and can be re-
selected.

Note:  Parameters which are selected here affect ALL selected nodes including ALL
corresponding transceivers.
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10.3.15 Optional Indoor Prediction Configuration
Configure the indoor prediction settings.

For urban environments, indoor penetration can be predicted for pure urban buildings (only outline
polygons of buildings without indoor walls) as well as for Combined Network Planning Project (CNP)
Buildings. CNP Buildings are buildings which have been modeled as indoor databases and imported into
the urban environment database.

Figure 936: The Indoor Settings dialog.

Urban Buildings

Compute Indoor Coverage
Option to enable indoor coverage prediction.

Indoor Coverage Model
Indoor penetration can be predicted for pure urban buildings (only outline polygon of
building without indoor walls) using one of three different indoor coverage models. All
indoor coverage models utilize an algorithm that uses the values of the predicted pixels
around the building and considers the penetration (transmission) loss defined for the outer
building walls.

1. Constant Level Model: Predicts a homogeneous indoor level by subtracting the defined
transmission loss from the average signal level at the outer walls.

2. Exponential Decrease Model: Considers the defined transmission loss of the
outer walls and additionally an exponential decrease towards the interior, with an
attenuation rate depending on the building depth (around 0.1 dB/m).

3. Variable Decrease Model: Allows to consider a definable attenuation rate (default value
0.6 dB/m) in addition to the transmission loss for the outer walls. In this model the
user can modify the exponential decrease of the signal level inside the buildings.
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CNP Buildings
Predictions within CNP Buildings can be done using different resolution and prediction heights
compared to the urban prediction. Multiple prediction heights have to be separated with blanks.
The specified height mode defines the absolute position of the chosen prediction height(s). The
prediction height(s) can be either identical to the urban prediction height, relative to the ground
level of the building, relative to the defined floor levels of the building, relative to lowest or
highest floor level of the building or relative to the roof top of the building.
The simulation results of the CNP Buildings is stored in the corresponding urban result files.
Optionally, they can be stored in individual result files as well. This makes it possible to
investigate the indoor results separately.

Note:  Predictions inside CNP Buildings can be enabled only if the database of the
current project contains at least one CNP Building.

10.3.16 Edit Pixel Data
Modify pixel data, such as result databases or topography and morpho / clutter databases.

Pixel data, such as result databases or topography and morpho / clutter databases, can be modified
with CoMan. If a pixel database is visible in the Project View, the edit tool can be started by selecting
Edit > Pixel Data > Edit Values. Then specify the settings in the dialog that opens.

Figure 937: The Pixel Data dialog.

Value
Either an arbitrary decimal value or Value not computed can be specified.

Paint Tool
The tool to be used for the edit operation can be selected in this section of the dialog.

Rectangle
Two opposite corner of the rectangle have to be defined by pressing the left mouse button.
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Polygon
Definition points can be inserted by clicking the left mouse button. Pressing the right mouse
button will close the polygon by connecting the first and the last definition point.

Circle
The first click with the left mouse button defines the center of the circle. The second click
with the left mouse button defines the radius.

Ellipse
The two vertices of the ellipse can be defined with the first and the second click with the left
mouse button.

Line / Polyline
Definition points can be inserted by clicking the left mouse button. Pressing the right mouse
button will finish the input for this object.

Pixel
Individual pixels can be selected by clicking with the left mouse button.

Mode
The values of the pixel database, which have been selected with the paint tool, can be can be
replaced (set), added to or multiplied with the value specified in the upper section of the dialog.

Change undefined pixels
Pixels which are undefined, thus not computed in the pixel database can be considered optionally.

10.3.17 Filter Pixel Data
Filter pixel data, such as result databases or topography and morpho / clutter databases.

Pixel data, such as result databases or topography and morpho/clutter databases, can be filtered with
CoMan. If a pixel database is visible in the Project View, the filter option can be started by selecting
Edit > Pixel Data > Filter. Then specify the settings of the filter on the Filter Settings dialog.

Figure 938: The Filter Settings dialog.

Filter Type
Type of filter to be used. Either arithmetic or median filter can be chosen.

Filter Order
The filter order can be specified to be an arbitrary odd number between 3 and 101.
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Note:  The higher the filter order, the longer the filter operation will last.

10.3.18 Smooth Pixel Data
Smooth pixel data, such as result databases or topography and morpho/clutter databases.

Pixel data, such as result databases or topography and morpho/clutter databases, can be beautified
using the Smooth operation. If a pixel database is visible in the Project View, the Smooth option can be
started by selecting Edit > Pixel Data > Smooth. Then specify the settings on the dialog that opens.

Figure 939: The Smooth Settings dialog.

Resolution Factor
Factor for increasing the original resolution of the pixel database, thus a resolution factor of two
will double the original resolution.

Note:  The minimum possible resolution is limited to 0.1 meter. If a database has
reached this value, its resolution will not changed anymore.

Filter Order
The filter order can be specified to be an arbitrary odd number between 3 and 101.

Note:  The higher the filter order, the longer the filter operation will last.

10.3.19 Service Configuration
Specify the parameters of the wireless system service.

Parameters of service can be specified on the Service Configuration dialog.
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Figure 940: The Service Configuration dialog.

ID
Unique ID of service (not changeable).

Name
Arbitrary name of service.

Type
Type of service (for example speech and data.

Activity Uplink
Activity of service in the uplink direction.

Activity Downlink
Activity of service in the downlink direction.

Note:  By using the activity factors for uplink and downlink you can reduce the
effective data rate, provided the transmission channel is not required continuously. A
typical example is the speech service with activity factors of about 60% each (50% +
signaling). In addition asymmetric data services can be considered by utilizing these
values.

Bearers
All available bearers of the service are listed in this section. Bearers can be configured using the
Bearer Configuration dialog. The buttons on the bottom offer the possibility to add, edit and
delete bearers from the current service. 
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10.3.20 Transceiver Configuration
Specify the parameters of the transceiver.

Parameters of a transceiver can be specified on the Transceiver Configuration dialog.

Figure 941: The Transceiver Configuration dialog.

General

Enabled
Option to enable/disable transceiver. If the transceiver is disabled, it will be excluded from
all computations and displayed with grey color.

Note:  Disabled transceivers can be hidden in the 2D View and 3D View by
pressing Ctrl + F1.

Name
Arbitrary name of transceiver.

ID
Unique ID of transceiver (can not be changed).
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Channel ID
ID of radio channel that is used for communication.

Downlink Frequency
Center frequency of the downlink channel. This is just for information. The frequency can be
changed by selecting another channel via channel ID.

Transmitter

Power
Transmit power of transceiver.
The power unit can be adjusted using the corresponding drop-down box. After changing the
unit, the power value will be converted automatically according to the selected unit.

Note:  The specified power will always be converted to and stored in dBm after
closing the dialog. 

Fast Fading Margin
The parameter Fast Fading Margin represents the difference (in dB) between the
maximum possible transmit power and the maximum allowed transmit power. In order
to ensure fast power control to compensate for the deep fades of the radio channel this
specific headroom is required. Appropriate values for this headroom have to be determined
via link level simulations and will depend on the mobile speed.

Accumulated Transmission Time
Accumulated time of transmission for determination of overflows.

Measurement
Optionally measurement data can be assigned to the transmitter in order to calibrate the
wave propagation model.

Min. Required SNIR
Minimum signal-to-noise-and-interference-ratio which is required to receive the signals.

Receiver

Noise Figure
Defines additional noise generated by the receiver.

Min. required signal level
Minimum signal level required for reception.

Antenna

Type
Omni directional (isotropic) or directional antenna.

Orientation
Azimuth and tilt adjustment of the antenna element. The azimuth angle is defined north
over east, thus north direction corresponds to zero degree, east direction corresponds to
90 degree. A down tilts can be specified using a positive number, an up tilt is defined with a
negative number. 
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Pattern
File path and name of the antenna pattern to be considered.

Figure 942: The Transceiver Measurement Data dialog.

Measurement File
Measurement data which shall be assigned to the current transceiver.

Calibration File
File path and name of the resulting calibration file. The calibration file will be created during the
wave propagation prediction and can be used to calibrate the wave propagation model.

Usage Mode
The assigned measurement data can be either used for Area Prediction or Point-To-Point (Node
Prediction). If measurement data shall not be used at the moment, Inactive has to be selected.

Table 100: Azimuth and tilt adjustment of the antenna element.

Azimuth adjustment Tilt adjustment
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11 WinProp Utilities

The WinProp utilities consist of the Launcher utility and the Updater.

This chapter covers the following:

• 11.1 Launcher Utility  (p. 973)

• 11.2 Updater  (p. 975)
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11.1 Launcher Utility
The Launcher utility is a single application that allows you quick access to the shortcuts for the Feko
components, WinProp components, newFASANT, WRAP components, documentation, Altair license
utility and updating parallel credentials. Pin the application to the taskbar for quick launching.

Figure 943: The Launcher utility allows quick access to Feko, WinProp,
newFASANT, WRAP components, documentation and utilities.

Note:  When WRAP is installed in an existing Altair Feko installation, the WRAP components
are enabled on the Launcher utility.

11.1.1 Opening the Launcher Utility (Windows)
There are several options available to open the Launcher utility in Windows.

Open the Launcher utility using one of the following workflows:

• Open the Launcher utility from the Windows start menu:

1. On the desktop, click the Windows Start button.

2. Type Feko or WinProp.

3. Select Feko 2022.1 from the list of filtered options.

• Open the Launcher utility using the desktop shortcut (if you selected the option to install shortcuts
during installation).

11.1.2 Opening the Launcher Utility (Linux)
There are several options available to open the Launcher utility in Linux.

Open the Launcher utility using one of the following workflows:

• Open a command terminal. Use the absolute path to the location where the Launcher utility
executable resides (for example, /home/user/2022.1/altair/feko/bin/feko_launcher).

• Open a command terminal. Source the script “initfeko” using the absolute path to . /home/
user/2022.1/altair/feko/bin/feko_launcher. Type feko_launcher and press Enter.
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Note:  Take note that sourcing a script requires a dot (".") followed by a space (" ") and
then the path to initfeko in order for the changes to be applied to the current shell
and not a sub-shell.
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11.2 Updater
The feko_update_gui utility and the feko_update utility allows you the flexibility to install an update
containing features, minor software enhancements and bug fixes on top of an existing base installation
for Altair Feko (which includes Feko, newFASANT and WinProp).

11.2.1 Version Numbers
Each major release, upgrade or update is assigned a version number. A version number contains a
unique set of numbers assigned to a specific software release for identification purposes. You can
determine from the version number if its an initial release, update or upgrade.

The following terminology is used to define a version number:

Feko <Major>.<Minor>.<Patch>

for example:

Feko 2019.1.2

2019
Indicates the major release version. A major release is made available roughly once a year and
has a minor and patch version of “0”.

Note:

• The update utility does not support upgrades between major versions.

• A major release requires a new installer.

1
Indicates the minor release version and is referred to as an upgrade. Large feature enhancements
and bug fixes are included in the upgrade. Minor upgrades are released quarterly, for example “1”
indicates the first minor upgrade after the initial release. Use the update utility to upgrade to a
newer minor version (when available).

2
Indicates the patch version and is referred to as an update or “hot fix”. Minor feature
enhancements and bug fixes are included in the update. Patch updates are released between
minor upgrades, for example “2” indicates the second patch update after an upgrade.

Proprietary Information of Altair Engineering



Altair WinProp 2022.1
11 WinProp Utilities p.976

11.2.2 GUI Update Utility
Use the feko_update_gui to check for new versions of the software and install an update using a
graphical user interface (GUI).

Click on Application menu > Check for updates to do a forced check for updates[53].

When either CADFEKO, EDITFEKO or POSTFEKO is launched and the scheduled interval time has
elapsed, the update utility (GUI mode) automatically checks for updates. By default the schedule is set
to check for updates once a week. If updates are available, the update utility displays a notification alert
as well as giving you the option to select and install updates.

The GUI update utility can be started from the command line using:

feko_update_gui

Updates can be installed from a web repository[54] or a local repository. During an update a list
containing the latest software is retrieved and compared to installed components.

Note:  No information is collected during an update.

Viewing the Installed Component Versions
View the version numbers of the installed Feko components.

1. Open the Updater using the Launcher utility.

2. On the Altair Feko update dialog, click the Installed versions tab.

3. View the Component, Version and Date information for the current installation.

53. A forced update can also be done from the application menu in CADFEKO, POSTFEKO and
EDITFEKO.

54. Requires internet access.
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Figure 944: The Altair Feko update dialog - Installed versions tab.

4. Click the Update tab and click Close to exit the Altair Feko update dialog.

Updating or Upgrading to a New Version
Updating and upgrading refers to the process of installing a new version containing features, minor
software enhancements and bug fixes on top of an existing base installation.

1. Open the Updater using the Launcher utility.

2. On the Altair Feko update dialog, click the Update tab.

3. Click the Refresh button to view the available Feko versions for download.

4. Select a version to view the available components and their individual file size in the table.

Tip:  Click Details to view the release notes in the message window.
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Figure 945: The Altair Feko update dialog - Update tab.

5. Click Update to update or upgrade to the selected version.

a) Before an upgrade is started, you will be asked to confirm the upgrade from the current
version to the selected version. Click Continue with upgrade to allow the update/upgrade
process to proceed.

b) During the update process, click Details to expand the message window and view detailed
information regarding the update process.

6. When the update or upgrade is complete, click Close.
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Updating From a Local Repository (GUI)
Update (or upgrade) from a local repository using the graphical user interface.

1. Open the Updater using the Launcher utility.

2. On the Altair Feko update dialog, click the Settings tab.

3. Under Update from, click Local repository to update from a local repository.

Figure 946: The Altair Feko update dialog - Settings tab.

4. Under Local repository, select one of the following:

• If the local repository contains extracted archives or multiple zipped archives, select Folder
(with extracted or zipped archives) and specify the folder.

The path for the local Feko update repository must be an absolute file path which can point to
an unmapped network share (Windows), mapped (mounted) network share or a directory on
a local drive.

Warning:  Point the local repository path to the root folder of the updates.

Example: The Feko updates for the Windows and Linux platforms were extracted
and merged to C:\Updates. The path to the local repository points to C:\Updates.

C:\Updates 
    └─FEKO_2022.1.x
               └─WIN64_X86_64
               └─LINUX_X86_64

• If the local repository contains a single zipped archive, select File (zipped archive) and
specify the zip file.

5. Click Save to save the local repository settings.

6. Update or upgrade to a new version.
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Troubleshooting:  Error 16700: Unable to find the file 'XX/YY/manifest.xml.gz'
in the local repository.

Error 16700 indicates that the path to the local repository is incorrect. The path must point
to the root folder of the local update repository and the folders should not be modified.

Scheduling Automatic Updates
Schedule and configure an automatic Feko update.

1. Open the Updater using the Launcher utility.

2. On the Altair Feko update dialog, click the Settings tab.

Figure 947: The Altair Feko update dialog - Settings tab.

3. Select the Check for updates automatically check box to automatically check for updates.
Select one of the following options:

• every week

• every month

• every N days

4. Select the download location under Update from group box.
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Web
The updates are downloaded from the web repository.

Local repository
This option is recommended when the computer network or cluster has no internet
access due to security reasons or only limited available bandwidth. The updates may be
downloaded from the Connect website by the system administrator and placed at a location
accessible for the computer network or cluster.

5. Optional: Specify the proxy server and authentication when the web is specified as the repository
under Proxy group box.

6. Click Save to save the new settings.

11.2.3 Command Line Update Utility
Use the feko_update utility for scripted updates or updates from a Feko terminal.

The command line update utility is called from the command line using:

feko_update

-h,--help
Displays the help message.

--version
Output only the version information to the command line and terminate.

UPGRADE_OPTION
Argument that allows a specific major patch version to be specified. This option is used to view
the Feko component changes for a specific major patch version, their respective download size
and the release notes. UPGRADE_OPTION can be any of the following:

1-9
Indicates the major patch version.

latest
This option selects the largest valid major patch version that has a repository.

--check [UPGRADE_OPTION] [[USER:PASSWORD@]PROXY[:PORT]]
The update utility checks if new versions are available. If UPGRADE_OPTION was not specified and
new versions are available, it will list the version and its associated UPGRADE_OPTION value. For
example:

Update/upgrade options are available (UPGRADE_OPTION):
0: Minor update to version 2022.1.0.1

If the computer is behind a proxy server, the proxy server address and the login details can be
supplied as required.
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--check-from LOCATION [UPGRADE_OPTION]
The update utility checks if new versions are available. Here the update source is the local
repository specified by LOCATION. If UPGRADE_OPTION was not specified and new versions are
available, it will list the version and its associated UPGRADE_OPTION value.

--update [USER:PASSWORD@]PROXY[:PORT]]
The update utility checks if new versions are available within the current patch major version
from the web repository. If an update is available, download and install the new version. If the
computer is behind a proxy server, the proxy server address and the login details can be supplied
as required. If updates are available, the following information is printed to the screen:

• Print each file which is being downloaded (only available when the update does not contain
many files).

• Print each file which is being updated (only available when the update does not contain many
files).

• Print a message stating that the update was successful and exit.

--update-from LOCATION
The update utility checks if new versions are available within the current patch major version
and installs the new version. Here the update source is the local repository specified by
LOCATION. The path must be an absolute file path which can point to an unmapped network
share (Windows), mapped (mounted) network share or a directory on a local drive that can
contain either extracted archives, multiple zipped archives or a single zipped archive.

--upgrade UPGRADE_OPTION [[USER:PASSWORD@]PROXY[:PORT]]
The update utility checks if new patch major versions are available from the web repository. If an
upgrade is available, download and install the new version.

--upgrade-from LOCATION UPGRADE_OPTION
The update utility checks if new patch major versions are available from the web repository. If an
upgrade is available, it will download and install the new version. Here the update source is the
local repository specified by LOCATION. The path must be an absolute file path which can point
to an unmapped network share (Windows), mapped (mounted) network share or a directory on a
local drive that can contain either extracted archives, multiple zipped archives or a single zipped
archive.

--no-progress
Suppress the download progress when updating from a web repository.

--no-proxy
Suppress the use of a proxy (including the system proxy).

Updating From a Local Repository (Command Line)
Download a new software update (or upgrade) from a local repository using the command line utility.

1. Open a command terminal using the Launcher utility.

2. Download the latest version using one of the following workflows:
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• To update (if an update is available) within the current minor version, type:

feko_update --update-from LOCATION

• To upgrade to a new minor version, type:

feko_update --upgrade-from LOCATION VERSION

where LOCATION is either an absolute file path which can point to an unmapped network share
(Windows), mapped (mounted) network share or a directory on a local drive that can contain
either extracted archives, multiple zipped archives or a single zipped archive.

The version is the minor version that you would like to upgrade to and would usually be 1, 2 or 3,
but it is possible to use latest to upgrade to the latest version.

The command line updater has many options to check for updates without updating or update to
the latest version. Use the following command to see a list of options:

feko_update --help

11.2.4 Proxy Settings Overview
The feko_update_gui utility and feko_update utility (GUI and command line) use the system proxy by
default, although it may be changed or the use of a proxy suppressed.

Windows
The proxy used is the same as is used by Internet Explorer. The proxy can be specified or by using a
proxy auto-config (PAC) file.

Linux
The system proxy is defined by the environment variable http_proxy. If the environment variable
http_proxy is not defined, then no proxy will be used.

Suppressing the Use of a Proxy
The parameter --no-proxy bypasses the system settings and use a direct connection.
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Figure 948: The Altair Feko update dialog - Settings tab.

11.2.5 Creating a Local Update Repository
Create a local Feko update repository to allow users to update without internet access or to limit the
list of update versions that users can use. Local update repositories can also be used to reduce the
amount of data being downloaded by downloading a repository once and making it available to many
local machines or compute clusters.

A local repository folder can be set up using:

• downloaded and extracted archives

• downloaded, zipped archives

1. Create the local repository folder, for example, C:\Updates.

2. If you already have an update repository for the same version, delete previous updates located in
this local repository folder.

3. Download the updates for the required platforms from Altair Connect.

For example, if both the Windows and Linux platforms are required, download the following:

• FEKO_2022.1_WIN64_X86_64.zip

• FEKO_2022.1_LINUX_X86_64.zip

4. Create the repository using one of the following workflows:
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• Unzip the downloaded archives to the local repository folder. The zip file contains a folder
structure which must be kept intact. Below is an example of the directory structure for the
two platforms after extracting the zip archives to C:\Updates:

C:\Updates 
    └─FEKO_2022.1
               └─WIN64_X86_64
               └─LINUX_X86_64

Note:  If multiple platforms are downloaded, the platform updates must be
located at the same folder (grouped by version) and “merged” as seen in the
example.

• Copy the zipped archives to the local repository without extracting the files.
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