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Introduction

Goal of the tutorial

» The goal of this tutorial is to show how to use the shape optimization feature into Flux

* The purpose of this new feature is to give to you some trends to optimize your device

S S

« For more details and reference about the method used please look at the documentation :

fir * Flux * Construction of a Flux project * Structural optimization in Flux * Shape Optimization
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Introduction

Studied cases

The example carries out the shape optimization of a synchronous reluctance machine (SRM).
Mean torque, calculated using an Altair Compose code, will be optimized.

Case 1: Shape optimization of the mean torque using optimization function programmed in Altair
Compose file. No optimization constrains are applied.

Case 2: Asimilar shape optimization of the torque will be carried out. In this case a rotor mass
reduction > 20% will be imposed.

Case 3: Shape optimization of the torque fulfilling two constrains: Rotor symmetry and a reduction
mass of the rotor > 20%.
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Environment preparation
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* You need to install on your machine (Available on Altair One Market Place) :

« Altair OptiStruct 2021.1 (at least)

 Altair Compose 2021.1 (at least)

Altair One
Q
* Favorite Apps

My Apps

All Apps

Clear all filters
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Environment preparation

« Set the path into Flux Supervisor Options

(Coupled software) for :
* Altair OptiStruct

 Altair Compose

1 Open Flux supervisor
2 Open Options

Select [Access path] ->
[Coupled software]

Establish Compose
environment script

Indicate OptiStruct scripts
directory

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

Altair Flux” €9 O ALTAR

Open project

Open example

% Material
» Manager

Distribution Server = Command -

~ Unit Manager 15!...”_1;_4[\[?1 98 Manager Manager “* " line Shell

e-Machine
= Toolbox

" Options x
B General Coupled software

MATLAB directory (eg: C:\Program Files\MATLAB\R2013a)

- Fie types [ IR

Macros C Compiler {vcvarsall.bat for windows, gcc for linux)

F:\Drugram Files (x86) Microsoft Visual Studio\2019\Communi ity \WCAundilary \Build'vcvarsall.bat .| T

NN

Paralel computing

viranment script (Compose.bat for windows, Compose for finux)
+Graphic mode

Network ports | \2021. 1\Compase2021. 1\Compase bat Ef_"i fi]
R
Optistruct scripts drectory 5
| 12021 1\wisolvers\scripts ol

- Exter

nsions
Coupled software
s

+Sketcher [Modeler
Geometric construction

‘- Meshing generation
Sohving
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Shape Optimization with Altair Flux

Implemented for multiple applications

Data Tree

E}| General data
D Geometry . )
B3 Mesh « Transient Magnetic
D Physics
#-C3 Parameter/Quantity

2D applications

* Magnetostatic

* Linear and Non-Linear Material

E-(5 Solver + Parametric study (without remeshing)
- B Selving scenario
J‘g Free mechanical set visualization * Magnets allowed (no change of the orientation)
ﬁj Solving process options .
€7y Audit of scenarios * Multiple Responses
- [=~ Adaptive solver options «  Sum of Flux trough the coils
E}@ Optimization
E1-4G) Responses  Flux trough a list of faces / list of lines
. - OPTIMIZATIOMRESPOMNSE _1
E}@ Constraints * Torque
{1 OPTIMIZATIONCONSTRAINT_SYM - Magnetic forces
. - OPTIMIZATIONCONSTRAINT_VOLUME
=+ (@) Optimization problem « Constraints allowed
. -OPTIMIZATIONPROBLEM_1
=g Cptmization options * Volume of a part of the device
- OPTIMIZATION_OPTIONS

* Symmetries

9 /\ ALTAIR



Shape Optimization with Altair Flux

Define the output variable

10

Data Tree

| General data

D Geometry

f-C3 Mesh

D Physics

D Parameter/Quantity

=25 Solver
#--55 Solving scenario
Free mechanical set visualization
- | Solving process options
€7y Audit of scenarios
[E- Adaptive solver options
Ei@ Optimization

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

"-1:1'3 Mew Optimization Response >

E}@ Responses
: L QPTIMIZATIOMRESPOMSE_1
E}@ Constraints
. L. OPTIMIZATIONCONSTRAINT _VOLUME
E}@ Optimization problem
: L OPTIMIZATIOMPROBLEM_1
E}@ Cptmization options
L QPTIMIZATION_QFTIONS

v

Mame ofthe response *
|DptimizatinnRespnnse_2 |

Comment

- Physical quantity to optimize
Flux flowing through faces -

Flux flowing through lines

Force computed via the integral of Bn on a path
Sum of the fluxes of selected coils

Torque computed via the integral of Bt on a path

J\ ALTAIR



Shape Optimization with Altair Flux

Define the optimization problem

11

Data Tree

| General data

D Geometry
-1 Mesh
-3 Physics
-3 Parameter/Quantity
=} Solver
& 5§ Solving scenario
Free mechanical set visualization
- | Solving process options
€7 Audit of scenarios
[E- Adaptive solver options
E}@ Optimization

E}@ F.esponses

L QPTIMIZATIOMRESPOMSE_1

E}@ Constraints

b OPTIMIZATIOMCOMNSTRAINT _SYM
. L. OPTIMIZATIONCONSTRAINT _VOLUME
E}@ Optimization problem
L OPTIMIZATIOMPROBLEM_1
E}@ Cptmization options

L QPTIMIZATION_OPTICONS

v

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

'1;3 Mew Optimization constraint

MName of the constraint *

| OptimizationConstraint_1

Comment

- Optimization constraint

| Double symmetry constraint -|

Coordinates system for definition *

[30r1 ~ [
Origin of the symmetry axis Formula or Value

First coordinate L)

Second coordinate L0
Direction of one of the axes Formula or Value

First coordinate Kit]

Second coordinate L0

0K | | Cancel ‘ﬂ | ) ‘ [ Petre ||

J\ ALTAIR



Shape Optimization with Altair Flux

Define the optimization problem

12

Data Tree

| General data

#-£3 Geometry

-1 Mesh

-3 Physics

-3 Parameter/Quantity

=} Solver

#--55 Solving scenario

Free mechanical set visualization

- | Solving process options
L7y Audit of scenarios

l [E- Adaptive solver options

E} @ Optimization

I_;} @ Responses
~QPFTIMIZATIOMRESPOMNSE _1

E} @ Constraints
: OPTIMIZATIOMCOMSTRAINT _SYM

i OFTIMIZATIOMCOMSTRAINT _VOLUME
E} @ Optimization problem

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

5 MNew Optimization problem x

Mame of the optimization *
| OptimizationProblem_1 |

Comment

Minimization or maximization *

{ ~OPTIMIZATIONPROBLEM_1
E}@ Optmization options
L QPTIMIZATION_QFTIONS

v

|Ma_\{imize v|
~Objective function to optimize —————
Predefined function hd
(Compose function
Response(s) II]
Constrainte(s) (¥
G o [ e J[ ® |

J\ ALTAIR
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Shape Optimization with Altair Flux

Define the optimization problem — Predefined function

13

oI5 New Optimization problem

X 5 Mew Optimization problem X

Mame of the optimization *

Mame ofthe optimization *

| OptimizationProblem_1

| [OptimizationProblem_1 |

Comment

Comment

Minimization or maximization *

Minimization or maximization *

|Maximize v| |Maximize v|
- Objective function to optimize ———————————— - Objective function to optimize
Predefined function ~] | | Predefined function

Select a function: *
Compose function Design response(s) -

Response(s)

Constrainte(s)

[

Average of reponses (AVG)

| |{Average of absolute value of reponses (AVGABS|

| {Maximum of reponses (MAX)

Maximum of absolute reponses (MAXABS)

Minimum of reponses (MIM)

Minimum of absolute value of reponses (MINAB

||Root mean square value of reponses (RMS)

IE [|Square root of sum of squares of reponses (RS]
1Sum of square of reponses (55Q)

"1Sum of reponses (SUM)

"Sum of absolute value of reponses (SUMABS)

J\ ALTAIR
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Shape Optimization with Altair Flux

Define the optimization problem — User function (through Compose)

5 New Optimization problem X

Mame of the optimization *
| OptimizationProblem_1 |

Comment
Minimization or maximization *

| Maximize v|
- Objective function to optimize

Predefined function hd

(Compose function

Response(s) [

Constraint=(s) (>

14

~end

B function [rresp, dresp, udata] = Obj_Func (iparam, rparam, nparam, iresp, rresp, dresp, nresp, isens, udata)

SLCSNario/project valuss
Engpos=[2:2:180]; sRotor angular position (for currents)
n=[0:44,-45:-1]; ifft indsx for 90 samplss in ones psriocd
P=2; $Number of pole pairs

c_angle=45; i2lontrol angle (%)

Ipk=15; &Psak current (Apk)

$Read flux iIn phase 1 from flux project and build flux in phase 2 and 3 from it
flux = rparam;

phl=[flux(2:end),-flux(3:end-1)1];

PHI=£ft (phl):

PH2=PHL.*exp (—3*2%pi/3*n);

PH3=PHL.*exp (j*2*pi/3*n):

ph2=ifft (PH2) ;

ph3=iffc (PH3):

$Rebulld currents that are fed in Flux project

Il= Ipk*sin(pi/1280* (Angpos*P+c_angle)); £C
I2= Ipk*sin(pi/180* (Angpos*P+c_angle)-2*pi/3); £C
I3= Ipk*sin(pi/180* (Angpos*P+c_angle)+2*pi/3); $C

urrent 1n phase

urrent in phase

L bty ke

urrsnt in phass
save ('auxiliar.mat', 'flux')

$output (torgue's mean valus over one period)

T = B/sqrt(3)*(I1l.* (ph3-ph2)+I2.* (phl-ph3)+I3.* (ph2-phl));

rresp(l) = mean(T);

Motor’s torque through Park’s equation

J\ ALTAIR
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Shape Optimization with Altair Flux

Define the optimization problem

15

¥ | Solving process options
€7 Audit of scenarios
t [E- Adaptive solver options
E}@ Optimization
E}@ Responses
L QPTIMIZATIOMRESPOMSE_1

: L OPTIMIZATIOMPROBLEM_1
E}@ Optmization options

L QPTIMIZATION_OPTICONS

Data Tree
E}| General data
#-C1 Geometry
-3 Mesh
D PhFSICS & Edit Optimization options[ OPTIMIZATION_OPTIONS] X
D Parameteeruanﬁty |Opﬁmizaﬁon tolerance (in %) * |
H 05
E}E' Solver Maximum number of iterations *
-5 Solving scenario [30 |
-7y Free mechanical set visualization PLEE LI
| Automatic -

E}@ Constraints [0.1 |
> ----- OPTIMIZATIOMCOMSTRAINT _SYM - Open a Flux with the final design when optimization is done

. -DPTIMIZATIONCONSTRAINT _VOLUME [yes vl‘

E}@ Optimization problem | ok || mppy || Cancel || Demmi>:> ||| @ || Piwe |

rSensibilities filter
Autormnatic -

Tolerance for the barrier *
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Synchronous Reluctance Machine Optimization

SRM as ideal candidate for shape optimization

- Why SRM?

18

Very few constrains needed

Only two materials in the rotor: Iron and air

Reluctance is causing all the effective torque:

Shape optimization acts over it directly

At constant speed: torque -> mechanical
power -> power density

/\ ALTAIR
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Synchronous Reluctance Machine Optimization

Optimization inputs

19

Rotor airgap interphase + rotor holes

Goal function : Torque according with park
equation:

P
T = E(Il(d)g —¢2) + L(p1 — ¢3) + [3(¢, — ¢1))

Three different optimizations have been
carried out depending on restriction

1. Basic optimization (no restrictions)
2. Rotor mass reduction = 20% imposed

3.  Symmetry and rotor mass reduction
imposed

/\ ALTAIR



STEP BY STEP TUTORIAL -
GEOMETRY AND MESH
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Flux project preparation

« Copy initial files from example directory into working directory

Open directory of the example

1 “Shape optimization of a SRM”
Copy the input files
> GEOM_INIL.STEP and

Obj_Func.OML in the working
directory

21

~

Mame

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

» Working_Dir

Date modified

| | GEOM_INLSTEP
Obj_Func

23/07/2021 10:22
29/04/2021 23:35

v 0 & Search Working_Dir
Type Size
STEP File 34T KB
Altair Compose 20... 2KB

J\ ALTAIR



Flux project preparation

+ Define Altair OptiStruct and Altair Compose

paths for coupling

1 Open Flux supervisor
2 Open Options

Select [Access path] ->
[Coupled software]

Establish Compose
environment script

Indicate OptiStruct scripts
directory

22

Altair Flux™

Open project

Open example

Start @j:n

» Manager

[Pracameray

& UnitManager & Skin depth

13,65 863,69 GB

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

€9 O ALTAR

I e-Machine Distribution Server = Command -
Toolbox 28 Manager Manager "~ line Shell

kocable mermery 1679 GRI73.39 B b oce 231,52 Blzo0.74 0

I Options

X

3 ser mode

= General
Language
Recent files
File types
Shorteuts

--Macros

=-System

.. Memary

.. Parallel computing

- Graphic mode

. Network ports
Debug

Coupled software
MATLAB directory (eg: C:\Program Files\MATLAB\R2018a)
| RN |

C Compiler (vcvarsall.bat for windows, gec for linux)

F:\Prugram Files (x36) Microsoft Visual Studio}20 19\Community WC\Audliary \Build\vevarsall.bat {q

Compose environment script (Compose.bat for windows, Compose for linusx)

F:\Prugram Files\Altair\2021\Compose2021.0. T\Compose bat 5

OptiStruct saripts directory

User version

Python

Materials
-Extensions

Flux
...Sketcher [ Modeler
- Geometric construction
.Meshing generation

Solving

- 'ounled software

F:\ngramFl\es\ahz\r\lﬂzl.l\hwsolvers\smpts R |

/\ ALTAIR
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Flux project preparation

« Launch new Flux 2D project

Altair Flux” € O ALTAR

1 Select the [2D] simulation .
context pen examp
’ Click on [New project]

w

Choose the working directory

I

Click on [Star a new project]

Start a new project

[ lachine Distribution Server = Command

e-Machine Serve ;
« Toolbox 3 Manager *  Manager line Shell

A »
BT Options e '::::::: < UnltMonager 4 Skin depth

23 /\ ALTAIR



Geometry
* Import SRM geometry

1 Close the sketcher

Click on menu [Project] ->
[Import] -> [Import geometry] -
> [Import geometry from a
STEP file (advanced mode)]

Choose GEOM _INI.STEP as
input file

4 Go to tab [Entities]

Check options [Import free
faces], [Import free lines]

24
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—

"'.;B Import geometr;@STEP file (advance.. X

Gen era| \ Entities Mlng ‘\ Assembly ‘\

File name *

| GEOM_INISTEP I
| -
Scale factor

[1.0

Center the geometry

) yes

@ no

Al o || o | ®

- Appication  Geometry Mesh Physics Display View Select Tools Extensions Help

Naw iy T\»l\l%‘*& ol v wl e % g'|1;_ .
Open project ... Ctl-0 — Iﬁ'ﬂphi:
blem dle o Ble. o 8@ e -
| save cirl-s
) save as,
@ Command fil »
“ Macro »
B overlay 3
Irpart FLUX object
' Export » Import geametry fram a SAT File
& Print »|  Importmesh ¥ | mmport geometry from & CATIAVS file
& e o ‘ Inport geometry from 2 DXF Fle
Import geometry from a FED File {FLUX2D)
Import geometry from 2 IGES file (advanced mods)
Import geametry from 2 Inventor file
Import geometry from a Pro file
Iport m a STEF file

"'.;B Import geometry from a STEP file (advance.. X

General " Entities ‘\ healing‘\Msemhly\
Import solids *

® [yes]
i no 5)
Import free faces * A\
) yes
) no
Import free lines *
) yes
) no
mpor Invisible entities =
. yes
i no

B o I == J[_® ]|
J\ ALTAIR




Geometry
* Import SRM geometry

1

Close the sketcher

Click on menu [Project] ->
5 [Import] -> [Import geometry] -
> [Import geometry from a
STEP file (advanced mode)]

Choose GEOM _INI.STEP as

€ input file
4 Go to tab [Entities]
5 Check options [Import free

faces], [Import free lines]

25
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Project Aoglaton  Geomeby Meh Pysc PuametwQuntly Sovng  Diley  Vew Select Took Fxtansom

..} -
(L e P TR IR AR | L A T I A Y s ""L
Data [ | [oraptic =y
e S R 1 P (S I L A N I
\
\
\
\
\
\
\
|
|
I d
Output = =l
il MeshPosnt| INFINITY_BOX) cxeate: d I
] nennLine 1RCAY W) created |
W Adsdtesn(1) noditied u
Pyflux Command = |
Conmrd rongt | o & A0 oo | momct pyar ogay |
> cl® ATN 7 Aseaionn(i asdesmamicaze-asdeatesninacivace I8
> - -
kd -«
B o | ~ « —
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Geometry

» Define geometric parameters

Go to [Data Tree] ->
[Geometry] ->[Geometric tools]

1 -> [Geometric parameter] ->
[New]
Define a geometric parameter
2 N_PPAIRS =2 (number of
pole pairs)
3 Define a geometric parameter

LSTACK = 110 (motor length)

26

Data Tree (=
i=-|General data = G Bn A
E--BGEumety

(-3 Domain
(= Geometric tools

-t Coordinate system
4 Transformation
(1 Geometric entities
Ll Geometric defects
(-3 Mesh
(-3 Physics
1-C3 Solver
-3 Post processing
-3 Tools
(1[5 Extensions
fed Macros
9_-3 User overlays
“[ servers

(i
fm il [Create a new Geometric Parameter |
o, Edit array CulF
ig. Delete Supprimer

i!. Farce delete Maj-Supprimer

Select all

ﬁ. Edit dynamics Fields of instance

&, Display PyFlux command

2 List
@ Find usages

d, XML export
?, Python expart
hud, TRT export
?, Excel export

wZ, Copy to dipboard

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

| N .
= Mew Geometric Parameter

@
Mame of Parameter *

[N_PPAIRS |

Comment
|Number of pole pairg| |

Algebraic expression for the parameter *

()

|2

Ao [[ e I ® |
©

Mame of Parameter *

|LSTACK |

Comment
|M0t0r|ength |

L .
=i Mew Geometric Parameter

Algebraic expression for the parameter *
[110 [70]

=

Ao || o | ® |

J\ ALTAIR
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Physics domain

» Define physical application

Geometry  Mesh  Physics  Display  View  Select  Tools

Define b E Magneto Static 20

Data Tree Electric * Steady Stake AC Magnetic 20 |
El General data Thermal b |5 Transient Magnetic 20
B Geometry Thermal Coupling — # Gk Magnetic with Yelocity Term 2D
Click on menu [Application] -> . _ .
1 [Define] -> [Magnetic] -> "¢ Define Magneto Static 20 application >
[Magneto Static 2D] Definition , Coils Coeflicient |
, Stablish the depth of the Eg “'l"“a'” type |
domain = LSTACK plane b
Length Unit*
|MILLIMETER - m,—z\'
Depth of the domain * \&/
|LSTACK] 10/
Q oK cancel || ®
/\ ALTAIR

27
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Physics domain

. , o Data Tree — | |Graphic
* Define motor’s periodicity = General data e & Q|
L—__}[Ev Geometry
(= Domain

-l i 1 Create a new Periodidty
'

Supprirnear
Go to [Data Tree] ->
1 [Geometry] -> [Domain] ->
Periodicity] ->[New ( )
[ ] -l ] %5 Mew Periodicity >k2
Define new perqulcny: -Geometrical type of the periodicity
2 2*N_PPAIRS repetition, and | Rotation about Z axis with number of repetiions -|
odd per|0d|C|ty Repetition number of the periodicity about Z *
| 2*N_PPAIRS 0]
Offset angle with respect to the X line (Z0OX plane) *
0 L0
- Even or odd periodicity / number of modeled poles
([Odd (anticyclic boundary conditions) -|

B o I ow J[_ o ]

28
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Physics domain
¢ Add infinite box

29

Go to [Data Tree] ->
[Geometry] -> [Domain] ->
[Infinite box] ->[New]

Create infinity box with given
internal and external radius

Go to [Data Tree] ->
[Geometry] -> [Domain] ->
[Infinite box] ->[Complete

Infinite box]

Accept default options and
complete infinite box

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

[ — | |eraphic

Data Tree
2| General data

% o &

= Bv Geometry

.&

(= Geom:

:’;z"m & Edit array

CirlE
Create a new Infinite

b | .- -
o Mew Infinite Box
3 £, Complete Infinite box - Type ofthe Infinite Box
. Select al Disc 2
Disc size Formula or Value N
Internal radius 86.25
External radius 105
Data Tree I:] ‘Graphic
| General data e g &
[} Geometry
(25 Domain
+ - e New
: “': &, Edit chrlE
& a Edit array chel-F
Et[= Gee % pelete SUpprimer 4
= 2\

1 oe SEE visible

".;B Complete Infinite box[InfiniteBox Disc]

Building options for propagation *

(Add Faces, Lines and Puaints

|

Coordinates system of points creation *

|STEP_1

-]

Periodicity == Associated link mesh *

|Add link mesh associated

b |

[ oc [[ et I]

J\ ALTAIR
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Meshing

« The goal of this part is to create a mesh suitable for shape optimization

30

The mesh should be, as much as possible,

regular in the area that touches the lines that we want to optimize

J\ ALTAIR
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Meshing

e |nactivate aided mesh

w2 Edit Aided mesh[1] \/ x
State of aiged mesn
Inactivated ~] Aided mesh inactivated

Go to menu [Mesh] -> [Aided

1 .
Mesh] -> [Edit]
Remark:
. Aided meshis r_u)l app!ied
5 Select Inactivated as state of on any geometrical enfily

aided mesh

Project  Application  Geometry
TR ]

Physics  Parameter/Quantity

Aided Mesh

Solving

I Tree E‘ Mesh options Edit entity Aided medt
IE}| General data B4 skin depth computation (e E Y= ﬁ'
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Meshing
« Define new mesh points

Go to [Data Tree] -> [Mesh] ->
1 [Meshing tools] -> [Mesh point]
->[New]

Define three new mesh points
as indicated in the table below

Point name Value of the

mesh point

STATOR_LONG 10
ROTOR_LIMITS_MESH 0.5

INFINITY_BOX 10

32
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'1:?. Mew Mesh Point \2)

Name of the Mesh Paint*
[sTATOR_LONG |
Comment
| |
Definition ', Appearance ',
Associated Length Unit* ol
[MiLLIMETER -
Data T \Graphi
‘ "’:da E_'J (raphec : Value of the Mesh Point (Length of elements) =
| General data D o B H @ a [10 |1l
El-(= Geometry
3 Domain

- Geometric tools

EI L&- Geometric parameter
i LLSTACK
1t Coordinate system
‘o ETransformation
(-0 Geometric entities
4| Geometric defects
E1-{5 Mesh

[ 3 Mesh generator
B-C3 Relaxation
E1-{5 Mesh entities

3 Face element
o[ Mesh objet

- Mesh defects
(- Mesh visuslization
B3 Physics

-3 Parameter/Quantity
(-3 Solver
[
[

73 Post processing
713 Tools

E}-{& Extensions

i Mamoes
I .

B[ o J[ et JI[ @ ]|
(-
w2 Edit Mesh Point[AIRGAP_MESH] \2
|

Name of the Mesh Point *

ROTOR_LIMITS_MESH|

Comment

1 Definition | Appearance ',
e e = ClE Associated Length Unit
A cdtarray <HrlF MILLIMETER ~|[¥]
o Valug of the Mesh Point (Length of elements) *
; Delete L
= Upprimer . [
% Force delete Maj-Supprimet
et Bl J[ e J[ et JT ® ]

2

Edit dynamics fields of instance 2

LN .
5 New Mesh Point
Displary PyFlux command “za Mew Mesh Pain

List Name of the Mesh Paint *

&) Find usages [INFINITY_BOX |
s HML export ne Comment ‘
+ Python expart: e
& THT export o Definition \Appearance\

x Excel export Associated Length Unit*
« Copy bo cipboard fa [MILLIMETER |k

[EAreonaTTeaty eatearared v Value ofthe Mesh Point (Length of elements) *

[10 ]

B[ o J[ et JI[ @ ]|
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Meshing

1

3

Update mesh points values

Go to [Data Tree] -> [Mesh] ->
[Meshing tools] -> [SMALL]-
>[Edit]

Assign 0.5 as value of the
mesh point

Go to [Data Tree] -> [Mesh] ->
[Meshing tools] -> [MEDIUM]
->[Edit]

Assign 2.5 as value of the
mesh point

Data Tree

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

%5 Edit Mesh Point[SMALL]

=-| General data

-2 Geometry

-3 Domain

-2 Geometric tools

Ehf_,‘ Geometric parameter

1 Coordinate system
s B Transformation
-3 Geometric entities

----- L Geometric defects
[=}-{=F Mesh

L:_}[E- Meshing toals

b 3 Mesh paint

Mame of the Mesh Point

[SWALL

Comment

|small mesh size

Definition \‘ Appearance ',
Associated Length Unit *

[MILLIMETER

Value ofthe Mesh Point (Length of elements) *

[E

o [[ mev |

concel ||

5 Edit Mesh Point{MEDIUM]

&
ErH o Mesh generator
3 Relaxation

@

Name ofthe Mesh Paint*

[MEDIUM

Comment

|I'u'|edium mesh size

Definition ', Appearance ‘|
Associated Length Unit *

|MILLIMETER

~|[M

Yalue of the Mesh Point (Length of elements) *

[25

0]

o [[ wey [| cne ]

@

|
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Meshing
« Define new mesh line @

"i:; Mew Mesh Line

Step Action Mame ofthe Mesh Line *
| AIRGAP_MESH |

Go to [Data Tree] -> [Mesh] -> Comment
1 [Meshing tools] -> [Mesh line] | |
->[New] Definition ', Appearance ',
Define new mesh line Type ofthe Mesh Line
2 AIRGAP_MESH as shown in | Arithmetic d
the figure Mumber of segments (of elements) *
|180] |
BB Mesh

[} [ Meshing tools

Eb w Mesh paint
+---AIDED_MESHPOINT

- INFINITY _BOX

- LARGE

- MEDIUM

+-ROTOR _MESH

- SMALL
--STATOR_LONG

- Mesh lind

B o Mesh generator

B3 Relaxation

A B (e e e Lo

[=}-(25 Mesh entities ‘3’ Edit array Ctrl-F
-, 4 Node xf Delete Supprimer
. Line element x‘;a! Force delete Maj-Supprimer

- g Face element

13 e seect | ok | | Cancel IH| @ I
) 2\ ALTAIR
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Meshing

» Assign mesh points to points 2

Points [»]
457 -
460
456
459
455

Mesh pointto assign to Points
INFINITY_BOX

|
~|[x
: [ |
Step Action

Go to [Data Tree] ->

El-[& Geometric entities | I

1 [Geometric] -> [Geometric > -
entities] -> [Point] ->[Assign are e
i I = "'H:Gmmeh a: Edit array Chel-F
mesh points to points] = ”g";ig 2 e ™y
0 s o E1-i@ Mesh er} *, Force delete Waj-Supprimer
Assign “INFINITY_BOX” to o e
2 infinite box points as shown in D’;Z‘:L st I 3
. esh del "“a Propagste points = Dl
the flgure [J--; mei :i 2! Extrude points = ’
e Physics 43 Assign regions to points 83 | l

£-(0 Parameter /) Ee Y ————————

Assign “STATOR_LONG" to & e qﬁ, :
- . 5 Postprocess ® e COmPute point coordinates Mesh pointto assign to Points.
3 ex‘[ernal stator pomts as £ Tods $% Compute distance between points T — |

shown in the figure 7 Bla Jle=il o] \\\\
\%&} _
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Meshing
» Assign mesh points to points

To assign MEDIUM mesh
points, select the points

! through “selection by face”
option
5 Select the faces
corresponding to the slots
3 Choose “Union option”
4 Click ok to accept selection

Assign also the central point
5 in the origin to MEDIUM mesh
point

36

3 Assign mesh point to points

Points

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

Mesh pointto assign to Points
MEDIUM -

@l o [ ena

\ Mesh pointto assign to Points.
\

MEDIUM ~I[»]

\ o=t

|

J\ ALTAIR



Meshing

» Assign mesh points to points

To assign
ROTOR_LIMITS MESH
1 mesh points, select the points
through “selection by line”
option

Select the lines corresponding
2 to the shaft-rotor limits and the
stator-airgap limits

3 Choose “Union option”

4 Click ok to accept selection

37
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';3 Assign mesh point to points x |
Ponts L
g New
Select all
Clean selection
Select last instance

Select by
Mesh pointto 1o Points 1
ROTOR_LIMITS_MESH -
Selection by Face :

o A el || ® Selection by surface

<),

P A

2 Selection by line X

Line of selection [ ]l

0 | 2\ ALTAIR



Meshing

» Assign mesh points to points

To assigh SMALL mesh
points, select the points
through “selection by face”

option
Select the faces
2 corresponding to the rotor’s air
holes
3 Choose “Union option”
4 Click ok to accept selection

38

- Assign mesh point to points

Ponts

Mesh 1o assign to Points
SMALL

~[ )

Selection

byine
B = Cancel LLAJ Selection by suface

Selection by volume
Selection by inear region
Selection by Face region
Selection by constraint
Selection by discretization
Selection by color
Selection by visiity
Selection by nature

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

"4'-

8RBBBY

3

[nen et |

i
!
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Meshing

* Assign mesh line to lines

Go to [Data Tree] ->
[Geometric] -> [Geometric

1 entities] -> [Line] ->[Assign
mesh line to lines]
Assign “AIRGAP_MESH” to
5 central airgap lines and to the

limit between rotor and
airgap,as shown in the figure

111
112

Mesh Line to assign to Lines
[ARGAP_MESH ~|[)

]

Il

Cancel

Il

(&)

|I

- A
A Hew

"l o Edi HlE

i .3' Edit array Chl-F
x/ Delete Supprirmer

*'+ Force delete Maj-Supprimer
j-Supp!

Set Visible
Set Invisible
L’;/ Propagate lines
92 Extrude lines
”;i Assign regions ko lines

¥ Assign mesh line ko lines

39
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Meshing

 Assign relaxation to faces

Go to [Data Tree] ->

B Assign relaxation to faces

1 [Geometric] -> [Geometric —
entities] -> [Face] ->[Assign 25
relaxation to faces]
Assign “AIDED_RELAXFACE”
2 to rotor’s face, as shown in the e oGs
figure AIDED_RELAXFACE
B =i \

[} (& Geometric entities
@ o Pont
@ Line
CR !
=& Mesh 4 edv aray pan s
w]lﬁmmx‘m
" At A Force delete Maj-Supprimer
LARI 73 Buld faces

STA' S, Propagate faces
5 4 Mes v g Assign regions to faces (modication mode)
AIR( a4 Assion mesh generator to faces (modfication mode)

3
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Meshing

» Mesh and check the resulting mesh

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

« Shape optimization process is very sensible to the quality of the mesh in the region to be optimized

Go to menu [Mesh] -> [Mesh

1 domain]

Check mesh quality through

menu [Mesh] -> [Check mesh]

Surface elements :
Humber of elements not evaluated
Iumber of excellent quality slements
Number of good quality elements
Number of average quality elements
Iumber of poor quality elements

Iumber of nodes : 34139

Iumber of line elements : 1750
Imber of surface elements : 16938
Mesh order : Znd order

0%
H-]: M)
: 0.54
: 0.28
: 0.08

-Phys'cs Display  View Select

@y Aided Mesh
[} Mesh options

El{: Skin depth computation

. Mesh point

2 Mesh line
= Mesh generator
" Relaxation

‘@ Assign mesh information
& Cle:an all mesh infarmation
24 Structure mesh

## Meash

’ﬁ} Mesh domain

Chrl-r

Check mesh results
41

Es Mesh elements
<P Mesh defect

| =% Delete meshing

gﬁ Check mesh

Alt-ra

Results of the meshing process

J\ ALTAIR
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Physics

» Define I/O parameters

Step ACtlon '-[:B Mew Physical parameter \2‘)
> |t b Geometic defects MName of the Physical parameter *
GO tO [Da.ta Tree] g ::::G dmg data model ‘Fll‘zximda%.:ir.p‘ ||F'K ‘
1 [Parameter/Quantlty] > ? ?.?:;EWEEVMUE%W Recording commands in 'E:/Alejan o

[Parameter I/O] ->[New] | DpTme B Peak current \

#-C3 Solver 2 eat am e Type of Physical parameter
g ::Z\tsmmmg 5: Delete Supprimer | Parameter controlled via a scenario v|

Define three 1/0 parameters o e e ﬁ;ferencevalue* |
as indicated in the table below

Param eter I/O '-[:; Mew Physical parameter < 2 ) '-[:; Mew Physical parameter ‘ 2 )
Mame of the Physical parameter * Mame of the Physical parameter *
[cammA | [TURNS \
IPK: Peak current 15 Comment Comment
|Phase advance angle (elec. degrees) | |Cm| turns ‘
Type of Physical parameter Type of Physical parameter
GAMMA Phase angle 45 |Parametercontrolledviaascenario v| |Parametercontrolledviaascenario v|
(electric deg rees) Reference value * Reference value *
|45 | [18 |

TURNS: Caoil’'s turns 16
43 J\ ALTAIR



Physics

» Define physics materials

Go to [Data Tree] -> [Physic] -

1 > [Material] ->[New]

Define a non-magnetic steel
2 AMAGNETIC-STELL as
shown in the figure

Go to [Data Tree] -> [Physic] -
3 > [Material] ->[Import
material .DAT

Load predefined material
FLU_M400_50A

44

=]

=

[ Physics
#-23 Domain
- cufa Material
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"];B Import material .DAT

&3 Regions E‘:?el itz
- 3 Mechanif FA Edit
E-(3 Electricd 1 Byt apra
Y
(25 Parameter/Q) ﬁ
= ?i' Paramety
;T-G.&MMA X Force delete

Chel-E
Chel-F
xg‘ Delete Supprimer

Maj-Supprimer

Materials

L IPK
B Import From material manager 3

L TURNS
"::g. EELEET  rport material DAT

',;; MNew Material

MName of the material *

| AMAGMETIC_STEEL

Comment

B(H) ', J(E) ', D(E) ', K(T) ', RCP(T) ', Mass densily ', Iron losses |,

Magnetic property
Magnetic property

\Linearisotropic

Relative permeability *

L1l

4 FLU_BAKELITE : <
& FLU_CERAMICS

4 FLU_COPPER

4 FLU_M1000_65D

4 FLU_M1000_65DNR

4 FLU_M270_35A

4 FLU_M330_35A

@ FLU_M330_35A_VALEO :

& FLU_M330_65A

FLU_M400_504
4 FLU_MB00_50A
& FLU_MB00_55A
4 FLU_M300_50A
4 FLU_MB00_55A
4 FLU_MU_METAL : =

Al oot || e ]| ® |
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Physics

* Define mechanical sets

Go to [Data Tree] -> [Physic] -

1 > [Mechanical set] ->[New]

Define STATOR as fixed
mechanical set

Define ROTOR as multi-static
3 mechanical set rotating
around (0,0)

. {3 Electric druit
- (= Parameter /Quanti &5 Edi
. By Parameter 10

[Create a new Mechanical set
@ Edit array

’u Delete

;a Force delste

& Spatial quanti

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

'123 Mew Mechanical set

@

Mechanical set name *

|STATOR

Comment

Type of mechanical set

45

[Fixed -
'133 Mew Mechanical set ks,) '133 Mew Mechanical set k3)
Mechanical set name * Mechanical set name *
|ROTOR || |||roTOR |
Comment Comment
| [ | |
- Type of mechanical set - Type of mechanical set
|R0tati0n around one axis v| |R0tati0n around one axis v|
Axis | Kinematics ', s Kinematics
Rotation Axis Type of kinematics
“Rotation around one axis parallel to Oz v|‘ [ﬁu‘lulti static |
Coordinate system *
[0 -]
Pivot paint Formula or Value
First coordinate 0 L0
Second coordinate 0 |LA)
B o« J[ e [ ® ] Gl ok || e || @ | |

J\ ALTAIR
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Physics

* Define coil conductors as balanced three-phase system 25 New Col conductor \2)
|Coil conductor name * |
v}
i |
Go to [Data Tree] -> [Physic] - e
. . . | Coil conductor with imposed current (A) v|
> [Electric Circuit] ->[FE Value (A)*
coupling components]->[CoiI | IPK*Sin(PI()/180*AngP os(ROTOR)*N_PPAIRS+GAMMAPI()180) |10
conductor]->[New] 5 & fhysis G o« [ cend I @ | |

-3 Domain
E c“?e‘ Material
i p-AMAGNETIC_STEEL
+--FLU_M400_50A
3 Regions
+}-- {} Mechanical set
[=+(&= Electric drouit
[} FE coupling companents
“[f} Coil conductor

Define three coil conductors
as indicated in the table below

'1:3 Mew Coil conductor (2 '
e

Caoil conductor name *
v |
Comment

)= Parameter/Quantity

Coil conductor type
-y, Parameter If0 " . ——
Coil T AMMA A Edie | Coil conductor with imposed current (4) -|
Value (A 2 cdtarey \'\‘Sl:fswgl 180"AngPos(ROTOR)'N_PPAIRS-2"PI()/3+GAMMA*PI(I180
conductor ( ) 7 Spate quentiy :g Deleted | | in(PICY gPos( )N 0 (180} [0
Farce delete
. S W[ o [ e [ ® | |
U IPK*Sin(PI1()/180*AngPos(ROTOR)*N_
PPAIRS+GAMMA*PI()/180) = New Call conductor (2
Coil conductor name *
v IPK*Sin(P1()/180*AngPos(ROTOR)*N_ lw |
PPAIRS-2*PI()/3+GAMMA*PI()/180) f“’“’“e”‘ |
Coil type
W IPK*Sin(PI()/180*AngPos(ROTOR)*N_ | Soncondscoruity mpssos eurent (4 ]
PPAIRS+2*PI()/3+GAMMA*PI()/180) [IPK=Sin(PI)M20*AngPos (ROTOR)*N_PPAIRS+2*PIVZ+GAMMAPI(180) [0l

. Bl Il ew= [ ® | |
4 Z\ ALIAIR




Physics
» Create face regions

Go to [Data Tree] -> [Physic] -
1 > [Regions] ->[Face regions]-
>[New]

Define ROTOR face region as
shown in the image

Define STATOR face region
as shown in the image

Define SHAFT face region as
4 shown in the image

47

(2 Physics
-C2 Domain
Ebp, fo Material
- AMAGNETIC_STEEL
o FLU_M400_504
B[ Regions
o Point region

F

el & el [Create a new Face region | @ik
- @ Mech 2 Edt array chrlF
‘(3 Electrit g Delete

& @Pa.ra:natar 4} Force delete

Suppritner

Maj-Supprimer

x
%5 Mew Face region

Name ofthe region *
|sTATOR

Comment

Wagnetostatic 2D | Appearance | Mechanical Set |
rType of region

‘Laminaled magnetic non conducling region
Material of sheetiron ™

[FLU 11400 504 ~|[»
Thickness of sheetiron (in m) *

05E3 [10]
‘Stacking factor (0 < Stacking_factor < 1)*

[0.98 J 0]

®
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Y
% New Face region

Name of the region *
ROTOR ]
Comment

Magnetostatic 2D | Appearance ', Mechanical Set |

r Type of region

| Laminated magnetic non conducting region -|
Material of sheetiron *

[FLU_m400_504 ~[»
Thickness of sheet iron (in m) *
0.56-3 0]
Stacking factor (0 = Stacking_factor = 1) *
0.98 [0

B o J[ e [ @ | |

Name of the region * :)

[SHAFT ]
Comment
|

% New Face region

Magnetostatic 2D \ Appeavance\\ Mechanical Set\
[Tyne of region

IMagnetic non conducting region |
Material of the region *
AMAGNETIC_STEEL -1

B o= 10 | |
/\ ALTAIR




Physics

» Create face regions

Define PRESLOT face region

. as shown in the image

Define WEDGE face region as
shown in the image

Define ROTATING_AIRGAP
3 face region as shown in the
image

Define ROTOR_AIR face
region as shown in the image

Define STATOR_AIR face
region as shown in the image

48

Y
% New Face region

Name of the region *
PRESLOT

Comment

ic 2D | Y Set )

- Type of region

/A or vacuum region

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

Y
% New Face region

Name of the region *

WEDGE

Comment

WMagnetostatic 2D ', Appearance | Mechanical Set |

~ Type of region

| Air or vacuum region

El | ot [ ® | [E o || e [ & |
% Mew Face region k3 5 New Faceregion \4) 5 New Faceregion
= N

Name of the region *

MName of the region *

MName of the region *

| ROTATING_AIRGAP

| STATOR_AIR|

|ROTOR_AIR

Comment

Comment

Comment

Magnetostatic 2D \‘ Appearance\ Mechanical Set \

- Type of region

Magnetostatic 2D \ Appearance \ Mechanical Set\

Type of region

Magnetostatic 2D \ Appearance \ Mechanical Set\

Type of region

[ Air or vacuum region

\Nvorvacuum region

\Nvorvacuum region

G o ]

G o J[ o= [ ® ]

J\ ALTAIR
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Physics
% Edit Face region[U_POS]

» Create face regions
oo

% New Face region 2

Name of the region *

U e |

U_POS
‘Comment Comment
DYy 1 Set'| Evaluated information |, lagnetostatic 2D | Appearance | Mechanical Set |
Type of regl Type of reg
[ Coil conductor region - [ Cail canductor region -

[ Origntation for the currentin the region ——————————————————) [Orientation for the currentin the region ———————————
St Ctl (0] |[Postne orentaton forte curent = || Megative orientation for the current il

Coil conductor region Coil conductor region component *

[u -] I

Define U_POS face region as T I o Numer oftums of e conducor
— G |

and periodicities: conductors in series or in para.

ShOWn |n the |mage [Althe and periodical conductors are in series -|
|A” the symmetrical and periodical are in series "

Define U_NEG face region as

2 ) : o | v | o || el ||| @ | x [ e | ® |
shown in the image
. . %2 Edit Face region[V_POS] 3 5 Edit Face region[W_NEG]
3 Define V_POS face region as st et
. . V_POS W_NEG
shown in the image e ‘ PR |
Dy % Set', Evaluated information °, D', Y\ Set' Evaluated Y
. . Type of region Type of region
Deflne W NEG face reglon as [Coil conductor region ~ [ Goil conauctor region -
_ ,—Dnentaﬂon forthe currentin the regon rOnemanon for the current in the regon
4 Shown |n the Image || Positive orientation for the current - |[Negative orientation for the current ~|
lcnn conductor region . 5 ‘Cm\cundudormgiun . o
v ~|[» w ~|[
Number of turns of the conductor * Number oftums of the conductor *
[4TURNS [l [4frURNS [0]
and in series or in p: and in series or in p:
[Allthe and periodical conduclors are in series - [Allthe and periodical are in series ~|
o J[ wwr [ ot [[ et [ @ ] [ oc ][ awr J[ owent ][ == J[ ® |
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Physics
« Assign mechanical set and colors to phase regions

* Region’s color are optional but highly recommended

) | B g Face regon
Step Action . “
- O — :

Go to [Data Tree] -> [Physic] - T 1) o e
. . i - STAT _ @ e+ D DT MENCT (AWM. ROTOR  [AOIORAR (SFT (STATOR (SRR [ubEs (U5 |vros  [wies W
1 > [Regions] ->[Face regions]-> P e ot oo e, i — i
. g H VPO Force delete W, ik e | = = . === z ey
Select all regions ->[Edit array] o
2 Update Color and Mechanical
set as shown in the figure
=]
Fac.e Infinite Preslot RoFatlng Rotor Rot_or_ Shaft Stator Stat_or_ U_neg U_pos V_pos W_neg Wedge
region _airgap air air
Proposed . Blue . Yellow Blue . Red .
colour Turquoise Yellow Yellow Dark White Dark Dark White Red Dark Green Magenta While
Zescerla”'c Stator Stator Stator Rotor Rotor Rotor Stator Stator Stator Stator Stator Stator Stator
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Physics

 Assign region to faces

1

51

Go to menu [Physics] -> [Face
region]->[Assign regions to
faces (competition mode)]

Assign face to ROTOR as
shown in the image

Assign face to SHAFT as
shown in the image

RS pxameteriquantty Soving Display Vien Seet Toos Extensons Hep

<o Infinite box
i Periodcky
Sl Symmetry
(& Domain options

A AN VN Y EXE

o terd
3 Poink region

€3 Mechanical set
T Electrical camponents.

»
T sy a <@ m bt
»
>
»

= Assion regions to Oeometric &ntiies
% Assign coll conductor components to regions

4% Delete Arrows.

@ Display arrows on magnet

* Load and run physics macro

"% Check physics

Faces

Region Face for Faces *
ROTOR - »

&l

x [ o Il ® |

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

Region Face for Faces *
SHAFT

=]

[ e ==

e |

J\ ALTAIR
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Physics

 Assign region to faces

w33 Assign regions to faces (completion mode) \ 1
Faces (>
23

i =

Region Face for Faces *

Assign face to STATOR as STATOR

1 shown in the image Bl o Jl e J[ & ]
Assign face to STATOR_AIR
2 as shown in the image

Faces )

33

Region Face for Faces *
STATOR_AIR ~I[p]

[ _ox ][ ot [ ® |
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Physics

 Assign region to faces

Assign faces to WEDGE as

53

shown in the image

Assign faces to PRESLOT as

shown in the image

w35 Assign regions to faces (completion mndekl
Faces b

P73 ==

Region Face for Faces *

|weDGE

~|(xd

[El |

“i Assign regions to faces (completion m 2

Faces
14 -
13
15
12
G
11 ==
Face for Faces *
PRESLOT ~|[»

[ o J[ o [ @ |
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o . . 1
ASS I g n reg Io n to faces -«;; Assign regions to faces (completion mnde]Q

I3 Faces |‘-|_}]
5
32
29
27
30 vIEI
- Region Face for Faces * m
Ste Action = =
b B o J[ e ]I @ |

Assign faces to ROTOR_AIR
as shown in the image

A .
Assign face to

5 ROTATING_AIRGAP as
shown in the image ms

+ Assign regions to faces (completion mode) X

10

Region Face for Faces *
ROTATING_AIRGAP
B e [ coms ]

DR ‘

o4 2\ ALTAIR
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Physics

 Assign region to faces
o Assign regions to faces (completion mode) X
Faces (>

-

[

O —
B o [ e [ © |

1 Assign faces to U_NEG as
shown in the image

Assign faces to U_POS as

2 shown in the image
i Assign regions to faces (completion mode) @
Fces |2
i)
9
(8 a
Face for Faces *

U_POS ~I[»)

[ o [ cnn J[ @ |
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* Assign region to faces o Asign s s ampleon \1)
Faces |N

1 ~]
3
2

: IMW_NochanamrFms' - m
A e i

Assign faces to W_NEG as

L shown in the image
Assign faces to V_POS as
2 shown in the image

%3 Assign regions to faces (completion mod( 2 )
Faces ]
4 ~J

6
5

Face for Faces *
V_POS ~»

G o J[ e JI @ ]
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Physics

« Check the resulting physics Check physies throligh| menl)

» Final aspect of the SRM model is shown below [Physics] - [Check physics ]

- Parameter/Quantity Solving Display View Select Tools Extensions Help

AN I TP R EEE T Y

o Infinite box

i Periodicity

gl Symmetry
&) Domain options

% [Ty 3 < m by R b, b b b bg e b

bt Material
o} Paint region
= Line region

»
L3
»
L3
L]
A Face region »
L]
3
L]
3

£ Mechanical set

a@ Electrical components

% Agsign regions ko geometric entities

uh Assign coil conductor companents to regions

@ Display arrows on magnet
A% Delste Arrows

V.
2 Load.andrun.ph; I
1
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Solving

Display View Select Tools Extensions

 Define solving scenario

1 Go to menu [Solving] -> [Solving
Scenario] ->[New]

In controllable parameters select
the tab [Mechanical_set] and
select the parameter
ANGPOS_ROTOR

The parameter will vary from 0°
to 92° with a step of 2°

Name the scenario as
Scenario_Ref

59

& Edic

crlE

7] Check project before solving process

%S| Delete  Supprimer

, By Solve  Majs

['% Delete results

4| Solving process options
[# Adaptive solver options

3 . .
=26 New Solving Scenario

(4)

T
MName of the solving scenario *I‘ Scenario_Ref
L

ment |

Adaptive salver: []

Control of parameters. \ Result storage \l HyperView export \

[] Parametric distribution

- Controllable parameters
Geometric \ Physic * Mechanical set \\

(2
Controlled parameters .4
Synthesis.

Parameter name

Reference value

Parameter name

Multi-values : [0.0,92.0]

£F ANGPOS_ROTOR

- Parameter control : ANGPOS_ROTOR (Reference value : 0.0)

Control type |Mu|ﬁ~u’alues

Parameter control \List of resulting values ',

rInterval definition rIntervals table

Lower limit ‘ Lower limit Higher limit Method Values I
Variation method

Sip ke —

Clear last interval
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Solving

» Define shape optimization responses

B[ Solver
B 5F Solving scenario
Free mechanical set visualization

'E Solving process options
€7y Audit of scenarios
%- Adaptive solver options
El =) Optimization

Go to [Data Tree] -> [Solver] ->
1 [Optimization] -> [Responses] - —
~-{ma) Constraints

>[NeW] - (=) Optimization problem

El M) Optmization options
e OPTIMIZATION_OPTIONS

L B DONSE

5 Define the flux through the coil U
as the response

'1:3 Mew Optimization Response 2
Mame of the response *

[optimizationResponse_1 |
Comment

Physical quantity to optimize
|Sum ofthe fluxes of selected coils v|

Lt of coils [
U |
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Solving

+ Define shape optimization constraints o s
used in cases 2 and 3 G- Solving scenario

J‘g Free mechanical set visualization
: -] Solving process options
Step Action A4 Solving process op

€7y Audit of scenarios

% Adaptive solver options
Go to [Data Tree] -> [Solver] -> £ @ Optimzation
1 [Optimization] -> [Constraints] - ‘... {Z) Responses
>[New] t-— (= Constraints
:-{g) Optimization problem
“ i =-{%) Optmization options
Select (Eonstramt of 2D face§ ¥ OPTIMIZATION OPTIONS
2 volumes” and select the rotor’s
face
2 New Optimization constraint bd
Select the “bounds set by values” Name e CorStaL e |
3 and establish upper bound at Comment A
5.33E-5 m2 (80% of the current Optiization '\2
Constraint of 2D faces volume
rotor volume) lstof faces D

I
hzs

Bounds set by values
Lower bound p_min *
[1E5

Upper bound p_max *
5.3305E-5

| G o I et T @ [ oo

LS
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Solving

« Define shape optimization constraints S
USGd |n cases 3 E Solving scenario

)g) Free mechanical set visualization

: ﬁj Solving process options
. €73 Audit of scenarios
Step Action % Adaptive solver options
E}@ Optimization
Go to [Data Tree] -> [Solver] -> (@ Responses
1 [Optimization] -> [Constraints] - A Constraints
(%) Optimization problem
>[NeW] [=1-{F4) Optmization options
- OPTIMIZATION _OPTIONS

Impose the rotor's symmetry as

2 constrains and shown in the 5 New Optistion consint /) *
. Name of the constraint * [ | 2j .
flg ure [OPTIMIZATIONCONSTRAINT_SYM = Symmetry Axis

Comment

[ || | Sets the direction of the symmeiry line.

- Optimization constraint In the example below the axis is (1, 1).

‘ Symmetry constraint v|

‘Coordinates system for definition *

[xr1 =]

Origin of the symmetry axis | Formula or Value Symmetry axis
First coordinate 0 L
Second coordinate 0
Direction of the axis | Formula or Value

First coordinate 1
Second coordinate 1

<
QOrigin

[ oc [ e [ & [[Tree]
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Solving

« Creation of the compose file

A

 rparam is the input values coming
from the “Responses” defined in the
previous slides. In our case it is the
flux through the coil U

The name of the function
must be “Obj_Func”

 rresp will be the response used by
Optistruct to perform the
optimization (in this case the torque)

63

e
[ R T T

-
N

e e e
;oo W

[ R T Y O X )

WO R R R R R MR MR

(8]

Wow oW ow W
[T =
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B fonction [rresp, dresp, udata] = Obj_Func (iparam, rparam, nparam, iresp, rresp, dresp, nresp, isens, udata)
£ iparam - vector of ints
£ tor of doubl
2 or of ints
3 - output parameter (vector of ints)
£ - output paramstsr (matrix of MxN dimesnsion)
H of output wvector
% i itivity flag
2 K erdata
iScenario/projsct valuss
Angpos=[2:2:180]; S2Rotor angular position (for currents)
n=[0:44,-45:-11: ft index for 90 samplss in ons psriod
P=2; iNumber of pole pairs
c_angle=45; £lontrol angle (°)
Ipk=15; tPsak currsnt (Apk)
$R=ad flux in phase 1 from flux projesct and build flux in phase 2 and 3 from 1t
flux = rparam:
phl=[flux(2:end),-flux (3:end-1)];
H1=fft (phl);
JEexp (-3%2%pif3*n)
E JRexp (I*2*pi/f3*n);
ph2=ifft (PHZ):
ph3=ifft (PH3) ;
= f=d in Flux projsct
*P+c_angle)); §Current in pha
*P+c_angle)-2*pi/f3): $Current in pha
I3= Ipk*sin(pi/180* (Angpos*P+c_angle)+2*pi/3); $Current in pha
save ('auxiliar.mat', 'flux')
sOutput (torgue’'s mean valus over one perioed)
T = P/sgrt (3)* (I1.* (ph3-ph2)+I2.* (phl-ph3)+I3.* (ph2-phl)):
rresp(l) = mean(T):
- end

1
3
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Solving

» Case 1 : optimization problem

« Shape optimization of the mean torque
using optimization function programmed
in Altair Compose file. No optimization
constrains are applied.

Go to [Data Tree] -> [Solver] ->
1 [Optimization] -> [Optimization
problem] ->[New]

Select maximize the objective
2 function, defined through a
Compose file (see slide 13)

Select the responses previously
3 X
defined

64

B[ Solver
- 5 Solving scenario

Solving process options
€7 Audit of scenarios
+ % Adaptive solver options
EI@ Optimization

. {F4) Responses
- {m) Constraints

J‘g Free mechanical set visualization

~--OPTIMIZATION_OPTIO)

II-.J Optimization problem
=¥ Optmization options 1
M
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& Edit Optimization problem[OPTIMIZATIONPROBLEM_1] X

Mame of the optimization *

OPTIMIZATIONPROBLEM_1

Constrainte(s) II‘

Comment

Minimization or maximization * \2

| Maximize M

- Objective function to optimize

|Compose function v|
Select a Compose file (.oml) *
[0BJ_FUNC.ONL B

Response(s) L3
OPTIMIZATIOMRESPOMNSE _1 -

([ o J[ wy [[ cod [] @

J\ ALTAIR




Solving

» Case 2 : optimization problem

« Shape optimization of the mean torque
using optimization function programmed
in Altair Compose file. In this case a rotor
mass reduction > 20% will be imposed.

Go to [Data Tree] -> [Solver] ->
1 [Optimization] -> [Optimization
problem] ->[New]

Select maximize the objective
2 function, defined through a
Compose file (see slide 13)

Select the responses and the
3 volume constraint previously
defined

65

B[ Solver
- 5§ Solving scenario
J‘g Free mechanical set visualization
Solving process options
€7 Audit of scenarios
+ % Adaptive solver options
EI@ Optimization
. {F4) Responses
: =) Constraints
II-.J Optimization problem g)
EI =) Optmization options 1
M

~--OPTIMIZATION_OPTIO)
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& Edit Optimization problemn[OPTIMIZATIONPROBLEM_1] X

Mame of the optimization *

OPTIMIZATIONPROBLEM_1 |

|Comment

Minimization or maximization * \2 >
| Maximize M

- Objective function to optimize

|Compose function v|
Select a Compose file (.oml) *

[0BJ_FUNC.OML | ®=

7 4
Response(s) 3
OPTIMIZATIOMRESPOMNSE _1 ot

Constrainte(s) II‘
OPTIMIZATIOMCOMSTRAINT _VOLUME

A o || wov [[ o [| ® |
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Solvmg

Case 3 : optimization problem

« Shape optimization of the mean torque
using optimization function programmed
in Altair Compose file fulfilling two
constrains: Rotor symmetry and a
reduction mass of the rotor > 20%.

Go to [Data Tree] -> [Solver] ->
1 [Optimization] -> [Optimization
problem] ->[New]

Select maximize the objective
2 function, defined through a
Compose file (see slide 13)

Select the responses and the
3 symmetry and volume constraint
previously defined

66

B[ Solver
- 5 Solving scenario

| Solving process options
€7 Audit of scenarios
+ % Adaptive solver options
EI@ Optimization

. {F4) Responses
- {m) Constraints

J‘g Free mechanical set visualization
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& Edit Optimization problem[OPTIMIZATIONPROBLEM_1] X

Mame of the optimization *

OPTIMIZATIONPROBLEM_1

~--OPTIMIZATION_OPTIO)

II-.J Optimization problem
=¥ Optmization options 1
M

|Commem

Minimization or maximization * \2
[ Maximize -
- Objective function to optimize

|Compose function v|
Select a Compose file (.oml) *

[ 0BJ_FUNC.OML [

OPTIMIZATIONCONSTRAINT _SYM
OPTIMIZATIONCONSTRAINT _VOLUME

Constrainte(s) lI

7
Response(s) k3
OPTIMIZATIOMRESPONSE_1 =

([ o J[ wy [[ cod [] @
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Solving
« Launch shape optimization E” S e Semew n

":] Check project before solving process
3 Solve

[j Delete results

Q_:] Solving process options

. & Adaptive solver options
Step ACt I 0 n %, MUt physic solving session (new scenario)

<y Mulki phyysic solving session {existing scenario)
G (0] tO menu [SO |VI n g] -> [R un ¢ Generate component For HyperStudy coupling (For HyperStudy 2019.1 and I
Shape Optimization] =

1

@ Run Shape Optimization (Finite Difference)

. . % Run Shape Optimization X ‘
Select solving scenario, ——— *
2 optimization problem and shape —
optimization working directory St
- Select last instance
, \Salect by coordinates
Solving scenario * L\ /
| SCENARIO_REF h Selection by point

Warking directary * Selection by face

To select the lines of the shape mpShapeominizaion 1Y ssktinby suface
- o B o Selection by volume
3 to be optimized click on (P TMZATIONPROBLEM 1 :
[Selection by face region]

Selection by relaxation
Selection by colar
Selection by visibility
Selection by nature
Selection by defect
Selection by infinite box

‘ Selection by discretization
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Solving

» Launch shape optimization

1

68

Select ROTOR as face region
and click on [Union]

Pushing the case “shift”
unselected rotor-shaft limit and
right and left rotor’s borders

Launch optimization process
clicking on [OK]. It can take about
90 minutes to be computed

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

<}
Il

Lines of the. tobe.

%7 Selection by face region

Face region of selection

ROTOR

mization
OPTIMIZATIONPROBLEM_1

(&l

OK

==

2 Run Shape Optimization

111
112
114
115

17

Lines of the shape to be optimized

Sohving scenario *
SCENARIO_REF

‘Working directory *
tmpShapeOptimization

J\ ALTAIR



POSTPROCESSING

J\ ALTAIR



© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

Postprocessing

Optimization process outputs

» Outputs of the optimization process are shown in Flux, including computation time and % of
improvement of the objective function

« The path for three files containing all the optimization process are also provided

Optimization
results

Output files (more
information in next
slides)

~

Computation time

oL Ll

put

*** Results :

e e e Iumber of iteration : 12

i Initial walue of the objective function : 1.19Z855e+01

Rt Final value of the objective funetion : 1.336Z35e+01

i Increase of the wvalue of the objective function : 12.03888£7954 %
AEHE KAAAKATAAATANNN

*HK

**% 411 the results are in the directory :

70

bt " ShapelptinSEN ShapeiptimSEM Cased’ tmpShapedptimization
FHF You will find
[rax - The Flux file with the update nodes :
dad Y Shape0ptinSEM ShapeOptinSEM Cased' tmpShapelptinization’20_sym reduction mass OptimizationFesults.FLU
[rax - The Hyperview file with all the iteration (Geometry) :
dad \ShapelptimSEM' ShapelptimSEM Case3' tmpShapelptimization’20_sym reduction mass.mvw
[rax - The Hyperview file with all the Flux wvalues :
rxx S ShapelptinSEM ShapeOptinSEM Case3' tupShapelptimization’20_sym reduction mass_hist.mvw
ks
*** Total execution time : £307.0320000& sec. I
CECULElU

L R EEEEEEEE————————

J\ ALTAIR
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Postprocessing

Flux file with update nodes

* The output project _OptimizationResults.FLU shows the solved Scenario_Ref for the optimized design
* A complete postprocessing can be carried out

The geometry is not updated, only the mesh node have been moved.

TORQUE

Mechanical set / Magnetic torque [ROTOR]
Mechanical set / Magnetic torque [ROTOR] (N.m)
rFS

2.300
2.165
2.029
1.894
1.759
1.624

] 1 ] I

it
VR YL VT

1.488
1.353
1.218
1.082

947.059E-3

811.76SE-3
€7€.471E-3

Y 541.176E-3

£ 405.882E-3

270.588E-3

% 135.294E-3

17.927E-9

flux density / Vector in T

—

S . . ——

71

Reset

w
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Postprocessing
Hyperview file with all the iterations (geometry)

« Contained in optimization working directory tmpShapeOptimization

* Hyperview file shows the geometry evolution for each iteration of the optimization process

Lot U DIPRLRREE mR 2

Design History

Select geometry /

orientation

Iteration of the
represented /

geometry

lalaf Bl0ig@peE R AR

Animation controls

and iterator —

selector

- Q@ 8hiw PP R W IoPL YL FELE T E #[©- 00000
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Postprocessing
Hyperview file with all the Flux values

« Contained in optimization working directory tmpShapeOptimization

» Hyperview file which shows the objective function and the constraints evolution

Ongectve tuncson

Objective function
s s evolution

- Cumert Project
~ [ p1:Objective function
- L wiiXY Plot

~ 4 \

. »

: \ o

+ [E3 p2:Maximum constraint violation | =

- la wIXY Flot
- 1

RESP1 -OPTIMZA - Vohme for propery 36 (Giobal

Y

~ [ p3:DRESP1 -OFTIMIZA - Volume for property 25 (Global) : 1

- Lo WIXY Plot '
-~

Y
~ [ p4:DRESP2 - comp_obj (Giobal)
- Lo wIXY Plot
-~

¥

Rotor’s volume

evolution

(constraint in red)
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Results

« As introduced in slide 16, three optimization process with the same objective function but

with different constraints have been included in this example. The presented tutorial presents
the results of the design 3.

« Very good results have been obtained, as it is shown in table below

Mean torque Torque improv. Computation

Mass improv. (%) (Nm) (%) time

Initial design - 11.93 - -
/' ™) - ")

Design 1 (no restriction) 22% 13.78 1551 % 62 min

Design 2 (mass reduction = 20%) 20.0 % 13.52 13.40 % 82 min

Design 3 (symmetry imposed 20.0% 13.36 12.03% 90 min

and mass reduction imposed) N ' ) ' k ' J
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Results
* Rotor shapes obtained by the three optimization processes

o . . -

Design 3: Rotor mass constraint

Design 2: Rotor mass constraint and symmetry imposed
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Conclusions

78

Shape optimization supposes significant
improvement even for initial design with
high performances

High flexibility using Compose to define
goal functions

Fast, robust and efficient

Let results speak by themselves...
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Mass Torque
Design improv. improv
(%) (%)
Design 1 (no 22% | 1551% 62
restriction) min
Design 2 (mass 82
reduction = 20.0% 13.40% min
20%)
Design 3
(symmetry 9
imposed and 20.0% 12.03% .
. min
mass reduction
imposed)

J\ ALTAIR



79

altair.com

DYy 809

#ONLYFORWARD

2\ ALTAIR



