HELMHOLTZ COIL
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Overall view on the device

A Helmholtz coil is a coil divided into two parts to obtain a
constant magnetic field in a large volume inside the coil.

A gap equivalent of the radius of the coil shares the two parts, in
order to reach this constant magnetic field inside the coil.

The following tutorial shows how to create a Helmholtz coil of 10
turns for each part in Flux software.

The device will be drawn in Flux using a 2D ax symmetric
representation.
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STARTING A NEW PROJECT

J\ ALTAIR



Starting a new project : new project

Open Flux 12.1 supervisor
Start a new project

Open project
Open example
Python scripts

Batch solve

Start a new
project

Innovate in 3D!

Efficient 3D geometry definition
Time gain with distributed computation
Precise mesh with 3D auto-adaption

Evaluation of static hysteresis effects

Close the sketcher if necessary (Project > Close sketcher 2D context)
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Starting a new project : application

Define a new axi-symmetric magneto-static application (Application > Define > Magnetic > Magneto
Static 2D)

-
@- Define Magneto Static 2D aEEIicaﬁc:n L. - M
Flux2D 12.1 5F1 - —
Definition \Cnils Coefﬁcient"..
Project Geometry  Mesh  Physics  Display  View  Select  Tools  Exten 2D domain type
D a Cefine # L Magneta Static 20 ||Axisymmetric "'”
e Electric b Steady State AC Magnetic 2D ‘
El General data Thermal » | ¥ Transient Magnetic 2D
B Geometry Thermal Coupling — »
. E Domain
QI oK Cancel || @
e
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GEOMETRY
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Geometry : symmetry

Create a symmetry along X-axis (Geometry > Symmetry > New )

Praject  Application Mesh Physics Display View Select Tools Extensions Help
£ £ 2 < I E ‘
Data Tree oo Infinibe bo » -
& [Generaldata " Perioicty N Geometrical type of the symmetry
5%} gm[;ew_ | Wersus X-axis e |
= omain ] ’ i
Domain opkions » Edit . .
® % it v e Y offset Position of symmetry axis *
i W& Geometric parameter Pl b | 0 || f,UJ
s Coordinate system 3 S Delete Supprimer

(& Geomet] n Transformation b ~Physical aspects of the symmetry
(2, Geo : - - - - —
- gCoof ® O ’ |Normal magnetic fields, tangent electric field, adiabatic condition |
ioyyy| o Line (]
- B Tran Face »

| Geometr = @ OK Cancel H @ Picture

..... '_4_ Geomet 2 Propagate 4

-3 Mesh ¥ Extrude »
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Geometry . geometric param eters
Create two new geometric parameters (Geometry > Geometric tools > Geometric parameter)

© Fup 121 501 - AnoNvNOUS I
CEOCENCETTTE e

A2 dER 2 ™a g

Balaliven [ [erar Radius_conductor 0,5
| Cenral dot ] Radius_Coil_Helmholtz 100
(= Geometry
D Domain

= Geometric tools

R .t GEOmetric parameter
- 1 Coordinate system

+ o4 Transformation
-1 Geometric entities

b L) Geometric defects

Open the Sketcher 2D context (Geometry > Sketcher Context) to start creating the geometry

8 J\ ALTAIR



© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

Geometry : the coil

Create 10 random circles in the sketcher (Construction > Circle > Circle center + radius)

{ Flux2D 12.1 SP1 - ANONYM

Project Edition  Construction Tools Display/View Domain Options Help

PO ILY || « C[G[- [C@E a4 58 X[~08 Qo
Data Tree — || |Graphic
- |General data -
EI[E' Geometry
l {23 Demain
EI [ Geometric tools
- & Geometric parameter
= ----- RADIUS_COIL_HELMHOLTZ
--RADIUS_CONDUCTOR.
g. Coordinate system
a4 Transformation
. E Geometric entities
_,},._ Geometric defects

e A AN

Graphical
shortcut
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Geometry : radius of wires of the coil

Edit all lines to set a radius of RADIUS _CONDUCTOR (CTRL+CLICK on all line in the data tree >
Right click > Edit array)

Force the value
RADIUS CONDUCTOR

'@ Edit Line[1,2,3,4,5,6,7,89,10...] ﬂ
Entities |Modify all 1 2 3 4 5 6 8 el 10 11 12 13
=] e Line
e Mature STANDARD  [STANDARD  [STANDARD  |STANDARD STANDARD WARD STAMDARD  |STANDARD  |STAMDARD  |STANDARD  |STAMDARD |STANDARD  |STAMDARD g
G Region
e Mesh AIDED_MES. .. | AIDED_MES... | AIDED_MES. .. |AIDED_MES... MES AIDED_MES. .. | AIDED_MES... | AIDED_MES... AIDED_MES... |AIDED_MES...|AIDED_MES... | AIDED_MES... | AIDED_MES... | |
G Relaxation AIDED_REL... |AIDED_REL... | AIDED_REL... .Q]DEJ_R%,/ AIDED _REL... |AIDED_REL... |AIDED_REL... |AIDED_REL... |AIDED_REL... |AIDED_REL... |AIDED_REL... AIDED_REL... |AIDED_REL... |4
G Calor * White White White W'hy/ White White White White White White White White White i
G Visibility = VISIBLE VISIBLE VISIBLE 'ﬁS]ELE VISIBLE WISIBLE VISIBLE VISIBLE VISIBLE VISIBLE VISIBLE VISIBLE VISIBLE \
=] @ Sub types Initial values Arc defined ... | Arc defined ... Arcd)ﬁéd ...|Arc defined ...| Arc defined ... | Arc defined ... | Arc defined ...| Arc defined ... | Arc defined ... | Arc defined ... | Arc defined ...| Arc defined ... | Arc defined ... | 4|2
=] @ Arc defined by Starting, Ending anc Arc defined ... | Arc defined yédeﬁned ...|Arc defined ...| Arc defined ...| Arc defined ... | Arc defined ...| Arc defined ... | Arc defined ...| Arc defined ... | Arc defined ...| Arc defined ...| Arc defined ...|
G Coordinate system * Initial values Xl X¥1 Wl XYl KY1 Y1 KY1 X¥1 X1 Xl X¥1 W1 X1 ¥
=] @ Points defining the arc
(B Starting point of the arc * 2 3 5 3 8 9 1 12 14 15 i7 18 20 i
e Ending point of the arc * 2 5 5 g 8 12 il 15 14 18 17 i |
e Center point of the arc * 1 1 4 4 7 ® 10 10 13 1= 15 16 19
G |radius_mnducmr| |radiu5_cnnd..‘ radius_cond... |radius_cond. .. |radius_cond...|radius_cond...|radius_cond... |radius_cond...|radius_cond...|radius_cond...|radius_cond...|radius_cond...|radius_cond...|radius_cond...|r
G Angle * Initial values 180 179.999999... (180 180 180 180 180 180 130 180 130 180 180 i
b == = == —= == = — = == == == == == == == =—
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Geometry : center of the wires of the coil

Edit all centers to give them the following coordinates ( Right click on a point > Edit)
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RADIUS_COIL_HELMHOLTZ
RADIUS_COIL_HELMHOLTZ
RADIUS_COIL_HELMHOLTZ
RADIUS_COIL_HELMHOLTZ
RADIUS_COIL_HELMHOLTZ
RADIUS_COIL_HELMHOLTZ
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Geometry : create arectangle to make thiner the mesh along the X
axis

Create a new random line (Construction > Line > Polyline)

Edit the extremity points of the line, to set the following coordinates ( by a right click on the point >
Edit)

RADIUS_COIL_HELMHOLTZ 0,5*RADIUS_COIL_HELMHOLTZ+9*RADIUS_CONDUCTOR*1,1

2 RADIUS_COIL_HELMHOLTZ 0,5*RADIUS_COIL_HELMHOLTZ+7*RADIUS_CONDUCTOR*1,1 0

Close the sketcher context ( Project > Close sketcher context )
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Geometry : create a rectangle to make thiner the mesh along the
axis

Create a new transformation (Geometry > Transformation > New)

Mame of Geometric Transformation *
| extrud_radius

Comment

- Type of Geometric Transformation
|Trans|atinr1 Vector

Coordinate System for definition *
| %Y1

Translation Vector Formula or Value
Vector component DX

RADIUS _COIL_HELMHOLTZ
Vector component DY 0

13
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axis
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Geometry : create a rectangle to make thiner the mesh along the

Extrude the last line created using the transformation EXTRUD_RADIUS (Geometry > Extrude >

Extrude lines)

Select the
last created
line in the
sketcher

Select the option

« Add Faces and
associated Extrusion

Mesh Generator

Extrude lines
Lines }
21
Transformation for extrusion *
|EXTRUD_RADIUS | »

Mumber of times to apply the transformation *

K

Extrusion type: Standard or Straight Forced *

| Standard

Building options for extrusion *

14

Add Faces and associated Extrusion Mesh Generator

Q oK Cancel || i)
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Geometry : before to create infinite box

At this step, the geometry looks as following

15

Coill

Extruded face
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Geometry : infinite box
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Create an infinite box depending of RADIUS_COIL_HELMHOLTZ (Geometry > Infinite box > New )

x

- Type of the Infinite Box

|Disc

Disc size

Formula or Value

Internal radius

S RADIUS_COIL_HELMHOLTZ

External radius

L}

[S*RADIUS_COIL_HELMHOLTZ

|LfiC)

@- Complete Infinite box

|

Complete infinite box (Geometry > Infinite box >

Complete infinite box)

All built faces will appear in turquoise

16

Infinite Box *

|InﬁniteEnxDisc

Building options for propagation *

Add Volumes, Faces, Lines and Points

Coordinates system of points creation *

| XY

Periodicity == Associated link mesh *

|Add link mash associated

Hl oK

Cancel
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MESH
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Mesh : create mesh point

Create a new mesh point for the coil (Mesh > Mesh point > New)

18

@- Mew Mesh Point

Mame ofthe Mesh Paoint *

| Coil

Comment

Definition ', Appearance |
Associated Length Unit*

| MILLIMETER

~|[]

Walue ofthe Mesh Point (Length of elements) *

K

0]

8| oK Cancel

®
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Mesh : assign mesh point

Assign the mesh point to all points defining the 10 turns (CTRL + click on all points on the 10 turns >
right click on one of the selected points > Edit > Mesh)
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Mesh : create mesh line
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Create two mesh line, to make the mesh thinner along the X axis. (Mesh > Mesh Line > New) The two

mesh line correspond to the following panels:

Orverie

Crovorin e

Mame of the Mezh Line * Mame of the Mesh Line *
|arithmetic3 | | ARITHMETIC75 |
Comment r}omment |
| |
Definition "l,l Appearance \l". Definition "'. Appearance "'.
Type ofthe Mesh Line Type ofthe Mesh Line
| Arithmetic ~| | Arithmatic -|
|Numher of segments (of elements) * | |N L;l mber of segments (of elements) * |
3 T

20
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Mesh : assign mesh line

Assign the mesh line as following (right click on a line > Edit > Mesh)

ARITHMETIC75

ARITHMETIC3
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Mesh : mesh the domain

Mesh domain ( Mesh > Mesh Domain). The mesh should be as following.

Aided mesh
(triangle elements)

e
e
e
-
s
L
(0
os
-
oo

Extrusiv mesh
(squared elements)
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PHYSICS
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Physics : create face regions to describe the physics

Create two face regions for the air and the coil (Physics > Face region > New)

o

Mame of the region *

|COIL

Comment

Magnetostatic 20 \". Appearance \". Mechanical Set \".

- Type of region

| Fegion with current density

Material of the region

Current density by spatial formula (in &/ mm2) *

K

24

ot

Mame ofthe region *

|AIR

Comment

Magnetostatic 2D | Appearance | Mechanical Set |

- Type of region

([&ir orvacuum region

J\ ALTAIR
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Physics : assign face regions

Assign the COIL region to all faces belonging to the coil (CRTL + click on all faces of the coil
> right click on one of the selected faces > Edit > Region > COIL)

Geometric complements " Region ‘l.l Mesh "'. Appearance "..
Region holding the face

COIL ~|[ ]

ok | _® |
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Physics : assign face regions

Assign the AIR region to the two last faces (CRTL + click on the two last faces inside the infinite box >
right click on one of the selected faces > Edit > Region > AIR)

28]

Geometric complements ] Region ‘l.l Mesh ‘I.Iﬁ.ppearance"..
Region holding the face
][

Supprimer

Maj-Supprimer

s ko Faces (modification mode)

iesh generator ko faces (modification mode)
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Physics : edit a face region

Validate the box of the Face region INFINITE (In the data tree Physics > Region > Face Region >
INFINITE > double click > OK))

Project  Application  Geometry Mesh Physics Parameter/Quantity Solving Display View Select Tools Extensions Help

B2 dEd 2 ] i s v s o n 9 2 a5 ] w2 5

Data Tree [_— | Jeraphic
e o e e BT - S O P T N R P I PR
S AIR
Locon

...... €3 Mechanical s 4

-3 Electric orou L et vy —

=3 E Parameter/Quan

@) Edit Face region[INFINITE]

T of Parameter 1 %P Delete Supprimer i -
o oot quent] " Force deete - Suppriner Mame of the region
E}_é poemer | g orient matere forfaxe region INFIMITE |

55 Solvingscend 59t Visible
i -REFERENCEV  Set Invisible
g Free mechan| Ui g ian ol conductor componients bo Facs ragions
-4 Selving procd
i +SOLVING_OP| =3 Display PyFlux command
B[ Adaptive sol 2 Find ussges

*. ADAPTIVE_S¢ "
=& Post processing

Comment
|Inﬁnite region |

2 #ML export
) Python export
A TXT export

2 Excel export

2B Copy to clipboard

Magnetostatic 2D "n Appearance ‘\ Mechanical Set ".I Evaluated information ".I
Type of region
|Mrnruacuumreginn '|

T% 2D curve (Path)
-1 20 curve (1/0 parameter)
I\_ﬁ‘" 2D curve (Material)
4 3D curve (2D grid)

3D cwrve (Path +1/O parameter)
¢ fejee 3D Curve (2 IfO parameters)
[ Computation
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SOLVING
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Solving : solve a scenario

Solve the reference scenario (Solving > Solve)

29

i Solve with reference values
i1 Solve adaptively with reference values
i Solve solving scenario
Scenario *| REFERENCEVALUES ~|[»

Save solved project as *
i) Current project
i@ New project

| Helmholtz_Coil| | E
5 oK cancel || @
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Choose the directory where
store the solved file
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POSTPROCESSING
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Postprocessing : display isolines and isovalues of the magnetic
field

Directly from the GUI

Project  Application  Solving Dataexchange Support Graphic Curve Computation Advanced Display View Help

D2 W d 2 xEn BTaewx e SN EEE @Y S kHA : :
Data Tree ] [oraphic Display isovalues
E‘---;;d:;:m 2 o jv.@ ® @@ Gl <[H] %]~ 5

E---D'Domain

[ g Infinite Box

Display isolines

{2 Geometric tools
-, Geometric par|

4 Transformatiol
[=}-[z5+ Geometric entities
F- o Point
Line
a Face
----- '_.}_ Geometric defects|
(& Mesh
[} Meshing tools
B .+ Mesh point
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Postprocessing : create a path

Create a path (Support > Path > New > Add)

Select the line
highlighted below

32
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Defined by & number of interval -
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Postprocessing : create a path
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The software automaticaly propose to create an other path : quit this window

Validate the compound path pannel

33

@ Mew Compound path . g

Mame of the compound path =

| CompoundPath_1

Comment

Definition \l\ Appearance \,
Mechanical set

rSections

Section list

PATH_1
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Create a curve along a path (Curve > 2D curve (Path) > New 2D Curve (Path))

Mame of 20 curve (Path)*
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Postprocessing : plot B values on the created path

O oo

===

| Comparison_bteween_theoritical_B_and_simulate d_EI{

Comment

Spatial path*

| COMPOUNDPATH_1

Current density

Energy (volume density)
Lorentz force (volume density)
Magnetic field
Magnetic flux density
Permeability

Variable ran

34

Direction [deqg]

w component [T]

v component [T]

Mormal component [T]
Tangential component [T]

Formula

Modv(E)

Ele

Open the formula
box to type the
formula of the

theoretical B

J\ ALTAIR




Type the formula

Validate the box

35

(4/5)~(3/2) *Mul () *10*P1i() *0.5~2,/0.1
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Postprocessing : plot B values on the created path

0 Editor of formula and spatial quantities

Magnetic volume region ', Magnetic face region | XYZ | State variable | Parameters ',

g/ [ o ]
dFlaplace [ _|
\
Math \,‘-m-go \\ Coord Sys \\ Constant \,‘ ~Vector Complex Mumerical
[toa | [x][_abs ][ son ][ modo || [compt][ vec2 | || [(cmobs ][ Real | |[7][2][2][7][{]
[togto] ([ mn [ max [ ||| [comp2][ vecs ] || [ conj | [ mag | ||4][5][s]|[=] 1]
[ | 3] [ _vaid_|[ Trapez | [comp3 ] [ evee | || [ st ][ ag | |([1][2][3]|[][<]
|ValidLR:x1<=x<=x2'|| VﬂﬁdLR] |M"J| Mod I |ModC]| Mod I IEH:]
rUser function
| et
- Expression
; |(4!5J“(3!2:*mo(]*lﬂ*?i(]*ﬂ.5“2fﬂ.l| |mj
[ o [ et [[ cexr || & |
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Postprocessing

Superimposed curves

....... ~

. plot B values on the created path
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Splitted

T0.00E-5 s

Legend >> H

Sorted by formula

Magnetic flu, =" itude

COMPARISON_BETWEEN_THEORETICAL_B_AND_SIMULATED_B

agnetic lus gensly J iaanipds 0~

@ Magnetic flux density / Magnitude (T)

B000E-6

50.00E-

40.00E-

30.00E-

20.00E-

10.00E-

Reset

2500E-2

(4/5)"(3/2)*Mu0()*10*Pi()*0.5**2/0.1

Choose « absolute » to
superimposed curves

&
&

T5.00E3

r ABS_CURY_COMPOUNDPATH

(415 (3 Q)'NJAUO'.{U'PD*U 2101

T0.0E-6
B0.00E-

B (AT MO0 1T PI0.520.1

5000E-6

40 00E-

30.00E-

20.00E-

10.00E-

5

Reset

25.00E-2

5000E-2

T5.00E3

r ABS_CURY_COMPOUNDPATH,
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