HELMHOLTZ COIL
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Overall view on the device

A Helmholtz coil is a coil divided into two parts to obtain a constant
magnetic field in a large volume inside the coil.

A gap equivalent of the radius of the coil shares the two parts, in
order to reach this constant magnetic field inside the coil.

The following tutorial shows how to create a Helmholtz coil of 10
turns for each half of the colil in Flux software.

The device will be drawn in Flux 3D using a non meshed coil.
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STARTING A NEW PROJECT
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Starting a new project : new project

Open Flux 12.1 supervisor
Start a new 3D project (select 3D at the top of the supervisor, and then the tab New project on the left)

S Flspeniso LT e |
Flux 0 Skew o % SEDRAT

Start a new
project

& Unit Manager

Open the Modeler context if necessary (Geometry > Modeler context)
4 J\ ALTAIR



© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

GEOMETRY
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Geometry : create a new cylinder

From the graphical shortcut
&7 Flux3D 12.1 5P1 - Modeler context - ANONYMOUS
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Geometry : close Modeler context

From the graphical shortcut (orange cross at the top right of the screen)
o (5] S

R EEEE R ﬁj

o (a7 e G L by R MR b b RS |
*\g
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Geometry : symmetry
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Create a symmetry along X-axis (Geometry > Symmetry > New )
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Geometry : infinite box

Create an infinite box (Geometry > Infinite box > New )

Complete infinite box (Geometry > Infinite box > Complete infinite box)

Project  Application Mesh Physics Display View Select Tools Extensions Help
O @ d E (g9 Modeler Context

s o B[ 2 e
Data Tree ST
Infinite box
Eml&mnd - » . Bdtt  [Create a new Infinte Box| | & Complete Infinite box M
'"E & New Infinite Box Fit arrane Chl-F Infinite Box *
pe of the Infinite Box

[infiniteBoxCylinderZ ~ [
|zCytinder |

Building options for propagation *
Cylinders sizes | Add Volumes, Faces, Lines and Points
Inner Radius 200
Outer Radius

250
150
200

Coordinates system of points creation *
| COORDSYS_XY_PLANE ~|[»

Periodicity == Associated link mesh *

| gadlinicmash assgciated

oK Cancel ||| @

Inner Size, Half Height
QOuter Size, Half Height

r
p—
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Geometry view of he geometry

All built faces appear in Turquoise
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MESH
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Mesh : create a mesh line

Create a new mesh line “05MM” (Mesh > Meshline > New)

& Mew Mesh Line

Mame of the Mesh Line *

| 05MM| |

“Comment

Definition Wln Appearance ‘\

Mumber of segments (of ellernents:l *

1314

12

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

J\ ALTAIR



Mesh : assign mesh line
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Assign the mesh line 05MM to 4 lines of the built cylinder (CTRL + click on lines 1,2,3,4 in the data
tree > right click on one of the selected lines > Edit)

13

&7 Flux3D 12.1 SP1 - ANONYMOQUS

Project Application Geometry Mesh Physics Display View Select Toc
I

B2 A =& 2

& Edit Line[4,1,3,2]

==

Data Tree P
|(_5eneral data Geometric complements "'. Region ' Mesh \". Appearance "'.
E-= Geometry
-3 Domain Mesh Line defining the mesh onthe line |
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B Line
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Mesh : create a relaxation on face

Create a new relaxation on face (Mesh > Relaxation > Relaxation on face > New)

-
& New Relaxation Face ﬁ
& Flux3D 12.1 SP1 - ANONYMOUS Mame of the Relaxation Face *
Project Application Geometry Physics Display View Select Tools Extensions Help |Re|axFace_an I |
B dE Q‘ <2 | % Aided Mesh YolE, i R s s 5] % 92 T Comment
D‘""T‘ Tree = Mash point J | |
| General data i po| T o8 B s @ e |~ o
(& Geometry :; mzz: "rrlaemerator » = H A I_ I_ Defniton \l.l.nﬁ.ppearance xll'
. ®-£3 Domain : J . — -Mesh relaxation on face |
#-C3 Geometric tooks “» Relaxation N -~ Felaxation ine » ||L — 025 | v"
& = Geometric entities | ¥ Shadow g tion face v [ New E el S 0.2 i
B o Point : :
B Line %2 Assign mesh information » | % Relaxation volume ¥ g Edft
- eLine[1] 25 Clean all mesh information | |m_ Bt array
| |
ok | cancal ||| @
b . i
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Mesh : Assign the relax face

Assign the relaxation “RelaxFace_Low” to face 1 (right click on face 1 in the data tree > Edit)

& Edit Face[1] . LN ===

Appearance‘l.l
Geometric Definition ".I Geometric complements ".I Region MESh".I

Mesh generatar defining the mesh on the face

| |

Relaxation of the mesh on the face 1
[RELAXFACE LOW | ~][»
~|[»
|
-]
[ -]
| | | |
- ok |l Apply Cancel Detail >> || @
L | | N =
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Mesh : mesh the domain

Mesh domain ( Mesh > Mesh Domain).

Check the mesh (Mesh > Check Mesh) The results of the check mesh appears in the output window,
as following

(A=

[1 Volume elements :
HNumber of elements not evaluated 0%
HMumber of excellent cuality elements @ 19.82 %
Number of good uality elements 47,45 %
NMumber of average (uality elements : 28.9 %
Hunber of poor quality slements p 3.83 %

IMmber of nodes @ 11341
Mumber of line elements : 1409
Mumber of surface elements : Z1105
Mumber of wolume elements : 48871
Mesh order : lst order

checkMesh executed
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Physics : create a new application

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

Create a new application “Magneto static 3D” (Application > Define > Magnetic > Magneto Static 3D)

18

&= - .
Define Magneto Static 3D ﬂpphCﬂthﬂ_

==

-Formulation maodel

Formulation Model ‘gﬁoils Coefﬁcient‘l.l

|Automatic formulations

- COrder of finite element functions for scalar potential

| Automatic

- COrder of nodal finite element functions for vector potential

| Automatic

|

OK

Cancel
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Physics : create a new stranded coil conductor

Create a new stranded coil conductor (Physics > Electrical components > Stranded coil conductor >

New)

19

&~ MNew Stranded coil conductor

==

Stranded coil conductor name *

| HelmholtzCoil

Comment

Stranded coil conductor type

|Stranded coil conductor with imposed current (A) '|

WValue (A)*

| Pi(y0.5"2]

0]

Cancel ||
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Physics : create a new non meshed coll

Create a new non meshed coil (Physics > Non meshed coil > New)

&7 New Coil

- » 5 s
Mame of coil * I

-
Geometric Definitio

pearance\'.l
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: ST CoTTE et s ociated with the coil *
[HelmholzCoil | [HELMHOLTZCOIL ~[[»]
Comment )
[ Mumber of turns of the coil *
— 10 |0l
Geometric Definition || Electrical | Appearance | _
L Fill factor (0 « 3f < 1)

|Circu|ar coil | 0.7 || fﬂ|
Coordinate System for definition * Resistivity (2.m)

e b Geometric Definition ‘\ Electrical

Coll center 1| | mass density (Kg/m?) o cotor
First coordinate 0 Red
Second coordinate 0 =
i i EIME material F——

Third coordinate  |E Coil visibility

oil radiuvs* N\ |"u"ISIElLE

100 ~Symetries and periodicities : conductors in series or in parallel |

Coil section | All the symmetrical and periodical conductors are in series - |
|Redang|e

Height *

[11 1
Width * r3ymetries and periodicities : duplication or none

Duplication by the symmetries and the periodicities
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Physics : create volume regions to describe the physics

Create two volume regions for the air and the coil (Physics > Volume region > New)

& MNew Volume Region

™

Mame of the region * I

Infinite] |

Comment

Magnetostatic 3D "l.l Appearance "'. Mechanical Set "'.

I |Airnrvac:uum region I
|

21

& New Volume Region

Mame ofthe region * I

AR |

Comment

Magnetostatic 3D ‘l.l Appearance "'. Mechanical Set \".

I Alr orvacuum region I
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Physics : assign volume regions

Assign AIR volume region to volumes 1 and 2,and INFINITE volume region to volumes 3,4,5,6,7 (
CTRL + click on all volumes with the same volume region to assign in the data tree > right click on one

of the selected volumes > Edit)

& EditVolume[1,2]
Region \". Mesh ' Appearance ',

AR ~|[ ]

L e

& Edit Volume[34567] e [ 28 |

Region \". Mesh ', Appearance ',

Jolume Rﬁ'm holcing the volume
~] [

INFINITE |

Gl ok Apply || Canq |

o J[_aeor I[ conce J|_® |
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Physics : check the physics

Check the physics (Physics > Check physics)

The results appears in the output window

23

2]

Coil(l)

Total mumber of coils obtained by duplication :

Coil(z) DUPLICATED by anti-symmetry
Mumber of portions of conductors in parallel

Coll[HELMHOLTZCOIL] created
BegionVolume[ATR] created
BegionVolune[ INFINITE ] created
Volume[l, Z] modified
Volume[3, 4, 5, €, 7] modified

Begin of physical check ...

End of physical check.
checkPhysic executed

1
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o

SymmetryXiplane 1
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SOLVING
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Solving : solve a scenario

Solve the reference scenario (Solving > Solve)

&7 Solve E

) Splve with reference values

1 Solve adaptively with reference values
'@ Solve solving scenario

Scenario *| REFERENCEVALUES  ~|[ )
Save solved project as *
) Current project
'® New project

HelmholtzCoil_solved|

Choose the directory where
! | store the solved file

=
=
Q
2
S
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POSTPROCESSING
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Post processing : set the infinite box invisible

Set the infinite box invisible (right click on the Infinite box in the data tree > Set Invisible)

Project Application Solving Dataexchange Support Graphic Curve Computation Advanced Di

i@ @ S SN S EE

DA dEE 2 s E DGO

Data Tree
= General data ~
= Geometry
-1 Domain

sh Symmetry
=& Domain options
#-C3 Geometric tools
== Geometric entities
- o Point

2 Line

B u Face

L B N

27

1 InfiniteBoxCylinderZ

Edit
& Edit array

Chrl-F

et i

= Display PlSet Tnvisible the points, ines, faces and volume of infinite box|

&), Aind usages
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Post processing : display isovalues of the magnetic flux density

Directly from graphical shortcuts

Display isovalues

it B e @Y Ko xdA Ml % B \
|Graphic |
B G LB cdd & «o| H[BE R~ 8& x|
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Post processing : create a 2D grid to display results

Create a new 2D grid to display the magnetic flux density
on the symmetry plane inside the coil (Support > 2D grid
> New)

29

-
- -
& New 2D gnid
IO L,
Mame of the 2D grid *
| Grid2D_1 |
Comment
| N
Definition ﬁppearance\l
Typeof 2D gid— —————
Annular |
Origin of the 2D grid | Formula or Value
First coordinate 0
Second coordinate 0
Third coordinate 0
Characteristics along radi§s |F0rmula or Val..
Internal radius 1
External radius 100
Number of discretization elemefits 20
| |
Characteristics along Thela |Formula or Val..
Minimal value 0
Maximal value 359
Number of discretization elemefits 36
Coordinate system for definition *
[xovz1 ~ [
Mechanical set associated III

Lo [ cnce [T @ [ pouwre |

- "__ﬂ
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Post processing : plot the magnetic flux density on a 2D grid

Create a 3D curve (Curve > 3D Curve (2D grid) > New 3D Curve (2D grid))

30

& New 3D curve (2D grid) S

Mame of 3D curve (2D grid) *
| Spatial3DCurve_1

Comment
2D grid for the 3D spatial curve *
| GRID2D_1
Computation region
[] Computation region

|"u"u:|IL|me region

Région volumique *

AR
e —
Current density
Energy (volume density) "
Lorentz force (volume density) | [y component [T]
Ldaomedic fiald component [T]
[ Normal component [T]
Absolute tangential component [T]
Absolute normal component [T]
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Post processing : plot the magnetic flux density on a 2D grid

Validate the box, to see the curve as below:

E coosmie —— SPATIAL3DCURVE_1
4 E5.475E-& T
2 ec.e0lE-& —
E €0.328E-6 — T
g 115586 T
~ ©55.181 E-&
5 52.608 E-6
N £0.034 B-& 7062166
8 47.4618-6
= 44 888 E-& 66.24TE-6
% 40,314 E-6
Y 39741 56 61.672E-6
Y 37.168 E-6
& 34 594 E-& 5T 49TE-6
E‘ f;’ii; i:: 53.122E-6
SE.BT4 -6 flux dansity / {T) 48.748E-6
4437366
39.8988E-6
35624E-6
31.249E-6
L WIHER
.
U_GRIDZD_1
Formula: Magnetic flux density / Magnitude s2mETT000
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Post processing : Create a path

Create a new path (Support > Path > New)

& New Compound path

=X=)

i N
Coil_Radius_on_symmetry_plan I

T
| |
Definition \ Appearance \

Mechanical set
---------- -|[»]
-Sedions#

Section st | Add

G

Hit « Add » to
open the window
for a new section
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Hit « OI-<—»‘and then cancel the window

automatically opened for a second section

5
& New Section . L u
Name of the section * B [
|Path_1 |
Comment
General \ Appearance \\
~ Type of section
| Section defined by 2 points -
- I-%l
Definition by coordinates -
8 "'M"
_—
Coordinates system xXYZ1 K71
First coordinate 0 0
Second coordinate 0 100
Third coordinate 0 ]
Type of constraint No constraint  |No constraint ||
Localization constraint
- Region *
Region of section *
|AIR : Volume region '|
- Discretization
|Deﬂned by a number of interval '|
Value =
100] | |
s || 0 |
b | —
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Postprocessing : plot B values on the created

Create a curve along a path (Curve > 2D curve (Path) > New 2D Curve

© Altair Engineering, Inc. Proprietary and Confidential. All rights reserved.

path

(Path) )

-

& New 2D curve (path)

Mame of 2D curve (Path)*

o |

|Cnmparisnn_beh.n.reen_thenritiu:aI_El_and_simulated_El I

Tumment

Spatial path*

| COIL_RADIUS_ON_SYMMETRY_PLAN | » Open the formula
_ box to type the
Current densty l rormua__/11|  formula of the
Energy (volume density) / X componen ModV(B) % theoretical B
Lorentz force (volume depéity) | |y component [T] ]
idaaRete-field z component [T]
[ Absolute normal component [T]
Tangential component [T] Delete all
Absolute tangential component [T]
33
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Type the formula

Validate the box

34
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Postprocessing : plot B values on the created path

(4/3)~{3/2) *Mul () *10*P1i()*0.5~2/0.1

@ Editor of formula and spatial quantities

Magnetic volume region | Magnetic face region | XYZ | State variable | Parameters *,

B H W v dEnergy /dv || dFmagfds |
cFaplce /&Y _|
Math \Tn‘go \de SYS\\Cmmt\ ~Vector Complex Mumerical
[toa |[x)|[_Abs [ Son_ ]| Modo ||||[Comp1][ vec2 | || [ cmpix |[ Real | |[7][8][3]
(o010 L&) [ J[ Max ][ ||| [Comp2][ vecs | ||[ conj |[ mag |||[4][5][s]|[=][2]
[ ||| vaid_|[ Trapez | [ comp3 | [ Pvec | || [ mst |[ A | ||[[1][2][3]|[ ][
[ValidlRixt<=x<=x2 || VaidiR_]||| [ Modv || Mod ||| [ modc |[ mod | |||[0f[.][E]
rUserfunction
et
r Expression

[(4/5)~ (3/2) *Mu0 () *10%P1 () *0.5~2/0.1]
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Postprocessing : plot B values on the created path

Validate the box to plot curves as below

|6raphic

Ll B

-
eetd

Sored by o - Jegend > |
™~ COMPARISON_BETWEEN_THEORITICAL_B_AND_SIMULATED_B

@ Magnetic flux density / Magnitude { T)
B = T F
GO.00E-B

e T VO
S0.00E-6 e e
40.00E-6

soes — | Choose « absolute » to "S-w.
1oes superimposed curves

Reset 2500E-3 50.00E-3 i I
(4/5)**(3/2)"Mu0()*10*Pi()*0.5**2/0.1

(45 (3 2M i o
TO0EGam

ABS_CURY_COIL_RADIUS_ON_SYMMETRY_PLAN |

B (45 (3 MUY 10 PP 0.5™2/0.1
G0.00E-G

50.00E-G

40.00E-G

30.00E-

20.00E-&

10.00E-8

Reset 25.00E-3 SO.00E-3 TSOOE3 r ABS CURV COIL RADIUS OM SYMMETRY PLAN |¥

35 J\ ALTAIR



THANK YOU

altair.com

DYy 809

2\ ALTAIR



