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Foreword
Please read before starting this document

Description of the example
The goal of this technical example is to demonstrate the ability and advantage of Flux for the simulation
of trident-shaped contactor Schneider Electric computation problems. This document contains the
general steps and all the data needed to describe the different simulations.

To begin
This example is designed for the user who is already familiar with the basic functions of Flux software.

For beginner users, please report to the “Flux Starting Guide” opened automatically by the supervisor.
(If not opened, please open it by clicking on the button “?” on the top right of the supervisor). The
interface contains videos, which helps the beginners while using Flux for the first time.

Support files included...
To view the completed phases of the example project, the user will find the .py files, including the
geometry, physics and post-processing descriptions. The .py files corresponding to the different study
cases in this example are available in the folder:

…\DocExamples\Examples3D\Tutorial_Technical\TranslatingMotion\

Supplied files are command files written in Pyflux language. The user can launch them in order to
automatically produce the Flux projects for each case.

Note:  .py files are launched by accessing Project > Command file from the Flux drop
down menu.

Files

Supplied files Contents
Flux file obtained after
launchnig the .py file

CASE1/buildGeomesh.py Geometry and mesh CASE1/Geomesh.FLU

CASE1/buildPhys.py Physics CASE1/BuiltPhys.FLU

CASE1/solving.py Solving process CASE1/Solved.FLU

CASE1/postprocessing.py Post processing CASE1/Postprocessed.FLU

CASE2/TESTCASE_INI.FLU Initial Flux project

CASE2/buildPhys.py Physics CASE2/BuiltPhys.FLU

CASE2/solving.py Solving process CASE2/solved.FLU
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Supplied files Contents
Flux file obtained after
launchnig the .py file

CASE2/postprocessing.py Post processing CASE2/postprocessed.FLU

Note:  Some directories may contain a main.py enabling the launch of the command files.

Flux files are ready to be meshed and then solved.
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General information 1

1 General information

This chapter covers the following:

• 1.1 Overview  (p. 7)

• 1.2 Strategy to build the Flux project  (p. 13)

• 1.3 Kinematics: Theoretical aspects  (p. 18)

Introduction
The aim of this tutorial is the computation of magnetic field and mechanical quantities for a trident-
shaped contactor Schneider Electric.

This chapter describes the device, explains the strategies used for geometry construction, mesh
generation and physical description and introduces the theoretical aspects of the magneto-mechanical
coupling and kinematic models.
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1.1 Overview

Introduction
This section is an overview of the sample problem. It contains a brief description of the device and
studied cases.

Contents
This part contains the following:

• Foreword

• Description of the studied device

• Studied cases
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1.1.1 Foreword

Contactor
The study of a trident-shaped contactor Schneider Electric is carried out in this tutorial. Planar view of
the trident is presented in the figure below.

Measurements used in the study
The contactor has been fully analyzed in the Schneider Electric laboratories, and the kinematic
properties of modeled device for case 2 are based on these measurements.

The kinematic properties of the device are defined using its resistant force. In the graph below
the model of the resistant force is presented by the black curve, while the red curve shows the
measurements done by the Schneider Electric Company.
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1.1.2 Description of the studied device

Studied device
The device to be analyzed is a contactor – the trident – that serves as a switch to start an electric
motor.

The studied device, represented in the figure below, includes the following elements:

• a lower grip – ferromagnetic (laminated) fixed part

• an upper grip – ferromagnetic (laminated) moving part assembled on springs

• a coil placed around the central tooth

Upper grip

Lower grip

Coil

Operating principle
When current passes through the coil, a magnetic field is produced which attracts the ferrous objects,
in this case the moving core of the contactor is attracted to the stationary core. Since there is an air
gap initially, the coil draws more current initially until the cores meet and reduce the gap, increasing the
inductive impedance of the circuit.

The different phases of the process are the following:

• the coil is supplied by 24-volt power voltage source

• under the effect of the magnetic force, the upper part moves to make contact with the lower one

• then the switch is on
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Geometry
The trident is composed of two main parts – fixed and moving. Only a quarter of the device is modeled
because of the presence of two symmetries.

The dimensions of the modeled fixed part – lower grip – are presented in the figure below:

56.25

23.25

8.05

25.85

36.2

6.155.95

6

The dimensions of the modeled moving part – upper grip – are presented in the figure below.

26.35

8.05

25.35

46.15

5.2
5.5

5
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The dimensions of the modeled coil are presented in the figure below.

28

49.2

24

6
r = 2

Material
The trident is made of ferromagnetic strip iron material, which prevents eddy currents from appearing.

Source
The source of a magnetic field is the current flowing through the coil.
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1.1.3 Studied cases

Studied cases
Two cases are carried out:

• Case 1: study with the multi-static model (different linear positions)

• Case 2: study with the coupled load model (with circuit coupling)

Case 1
The first case is a study using the multi-static kinematic model (Magneto Static application).

In this case (multi-static kinematic model), the moving part of the device can take various positions
fixed arbitrarily.

We are interested in the computation of the magnetic field for arbitrarily chosen positions of the mobile
grip.

With this model it is possible to evaluate the force acting on the fixed grip at different positions.

Case 2
The second case is a parametric study using the coupled load kinematic model (Transient Magnetic
application).

In this case (coupled load kinematic model), a resistant force is exerted on the moving part of the
device by means of a system of return springs; the coil is supplied by an external electric circuit
(voltage source).

The advantage of this model is to study the time variation of the position and speed of the mobile grip
and the time variation of the electromagnetic force acting on the mobile grip.
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1.2 Strategy to build the Flux project

Introduction
This section explains the strategies of the geometry, mesh and physical description.

Contents
This section contains the following topics:

• Main stages for geometry description

• Main stages for mesh generation

• Main stages for physical description
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1.2.1 Main stages for geometry description

Outline
An outline of the geometry building process presented in the table below:

Stage Description

1 Creation of the lower grid using the sketch context

2 Extrusion of the shape in the modeler context

3 Creation of the upper grid shape using a sketch

4 Extrusion of the shape in the modeler context
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Stage Description

5
Creation of symmetries to model a quarter of the
trident

Symmetry

Symmetry

plane YZ

plane ZX

6
Creation of an infinite box to impose a zero
magnetic field at infinity

7
Closing of the domain and creation of faces and
volumes
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1.2.2 Main stages for mesh generation

Outline
An outline of the mesh generating process presented in the table below:

Stage Description

1 Meshing the device and analyze of the mesh
Mesh with the default settings of AIDED
MESH. It is possible to improve the mesh
quality

2 Modification of the AIDED MESH
Reduce the relaxation values to low
(r=0.25)

3
Creation and assignment of a local line relaxation
(r=0.1) to control the density in an automatic
mesh

RELAXLINE_MC

4

Meshing:

• meshing lines

• meshing faces

• meshing volumes

• generating 2nd order elements

Proprietary Information of Altair Engineering



Altair® Flux®

1 General information p.17

1.2.3 Main stages for physical description

Outline
An outline of the physical description process presented in the table below:

Stage Description

1 Definition of the application Magneto Static 3D

2 Definition of physical aspects of the symmetry Tangent magnetic field

3 Creation of 3 mechanical sets

• FIXED_PART
• COMPRESSIBLE_PART
• TRANSLATION_PART

4 Creation of a material
• FESI – material with a nonlinear B(H)

characteristic

5 Creation and assignment of volume regions

AIR

UP_GRIP

DOWN_GRIP

6 Creation of sources

COIL_1
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1.3 Kinematics: Theoretical aspects

Introduction
The kinematic module allows us to take into consideration the displacement of a moving part of a device
due to:

• mechanical forces from springs, friction, gravity, etc.,

• and electromagnetic forces, generated by magnets, coils, etc.

This module solves problems with magneto-mechanical coupling or performs studies with
kinematic coupling.

Contents
This section contains the following:

• Magneto-mechanical coupling

• Kinematic models

• Effect of displacement on the geometry description and re-meshing

Reading advice
The theoretical aspects of kinematic coupling are presented in the User’s guide (see “Kinematic
coupling: principles”)
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1.3.1 Magneto-mechanical coupling

Magneto mechanical coupling
The magneto-mechanical coupling takes into account the magnetic and kinematic aspects of a
problem. The magnetic aspect is characterized by Maxwell equations and the kinematic one by the
fundamental equations of dynamics in translating or rotating motion.

Fundamental dynamics equation in translating motion
The dynamics of a body in translating motion is expressed by the fundamental equation:

where:

• m is the mass of the moving body

• y is the instantaneous body position and ÿ is its linear acceleration

• Fr is the resistant mechanical force acting on the body

• Fem is the electromagnetic force acting on the body

Solving principle
The magneto-mechanical coupling is a weak coupling between the electromagnetic and kinematic
aspects of the problem. To solve this type of problem, we apply a four-stage procedure, as outlined
below. At each time step, the electromagnetic aspect is analyzed first and then the kinematic one.

The algorithm of this method can be summarized as follows:

Stage Description

1
Solve the Maxwell equations and compute the electromagnetic force or torque acting on the
moving part for a given relative position between the moving and fixed parts of the device

2
Solve the equation of moving part dynamics, compute the acceleration and speed of the
moving part during a time step and compute the new position of the moving part for the
next time step.

3 Move the moving part to the new position and (if necessary) re-mesh the displacement area.

4 Return to stage 1 for the next computation step

Additional notes
The electromagnetic force and the magnetic torque acting on the moving part are computed by the
virtual work method.

The mechanical force or torque acting on the moving part is an input data of the problem, entered by
the user.
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1.3.2 Kinematic models

Introduction
The analysis of the magnetic field in devices with moving and fixed parts can be performed with three
kinematic models provided by Flux.

Multi-static kinematic model
In the multi-static kinematic model, the movable part of the device is not moving.

The computation of the electromagnetic field is carried out for various arbitrary relative positions
of moving and fixed parts. This model performs a set of magneto-static computations (
in Maxwell equations), and does not take into consideration the dynamics equation. This model is
equivalent to a parametrized study where the position of the moving part is a parameter.

Imposed speed kinematic model
In the imposed speed kinematic model, the movable part is considered as moving at a constant
velocity with respect to the fixed part.

The computation of the electromagnetic field is carried out for the different positions defined by the
imposed speed of the moving part. As in the previous (multi-static) kinematic model, the dynamics
equation is not considered.

In the imposed speed kinematic model, the physical application used is the Transient Magnetic
physical application. In this case, the Maxwell equations consider the time dependence of the
electromagnetic field (  ).

Important notes
The imposed speed model and the multi static model offer the same results if the sources of the
electromagnetic field are constant: constant current sources, permanent magnets, etc. and that there is
no coupling circuit.

On the other hand, the results of these two models are different under the following conditions:

• time-varying sources: varying current sources (directly in the Flux project or through a circuit
coupling), etc.

• conductive regions, where eddy currents occur, etc.

Coupled load kinematic model
In the coupled load kinematic model, the moving part drives an external device that represents the
mechanical load of the studied device.

This is the model where the magneto-mechanical coupling is considered, that is to say, both the
magnetic aspect and the kinematic aspect of a problem.

The physical application used is the Transient Magnetic application.
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1.3.3 Effect of displacement on the geometry description
and re-meshing

Mechanical set
To describe motion in the finite element domain, the regions are assigned to mechanical sets. A
mechanical set is a set of regions and coils that have the same displacement characteristics.

A mechanical set of … includes the regions corresponding to…

fixed type fixed parts

moving type mobile parts

compressible type the area of air in which the mobile part is moving

Displacement of the moving part and re-meshing
The displacement of the moving part determines the modification of the geometry of the modeled
device. Consequently, the computation domain must be re-meshed at each time step.

There are different re-meshing techniques depending on the type of motion and on the presence or
absence of an air-compressible area.

Technique used
The technique used consists in dissociating the different parts and re-meshing only the compressible
part; the fixed and moving parts are not re-meshed.

Compressible mechanical set
Different methods of defining the compressible area are presented in the table below. The first case
corresponds to the most common one.

1st case 2nd case

Geometry scheme
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1st case 2nd case

Compressible mechanical set
Maximum area, corresponding to
the air region

Minimum area, in which the moving
part moves

Advantage
No need to create a specific
region

Reduced area to re-mesh → reduced
requirements for mesh storage

Disadvantage
Larger area to re-mesh → larger
requirements for mesh storage

Requires creation of a specific region
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2 Construction of the Flux project

This chapter covers the following:

• 2.1 Geometry description process  (p. 24)

• 2.2 Mesh generation process  (p. 36)

• 2.3 Physical description process  (p. 44)

Introduction
This chapter describes the main steps of the geometry construction, mesh generation and physical
description of the trident.

Project name
The project is saved under the name GEO_MESH_PHYS.FLU.



Altair® Flux®

2 Construction of the Flux project p.24

2.1 Geometry description process

Introduction
This section explains the geometry construction of the trident in the Modeler context of Flux 3D. The
device is presented in the figure below.

Movable part

Fixed part

Contents
This section explains the geometry construction of the trident in the Modeler context of Flux 3D.

• Create the fixed part

• Create the mobile part

• Add symmetries to the domain

• Add an infinite box to the domain
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2.1.1 Create the fixed part

Goal
The fixed part (coil + magnetic circuit) is created in the Modeler context. The steps are presented in the
following table.

Only 1/4 of the device will be modelled, as symmetry with physical properties will be created later in
this document.

The outline of the fixed part is shown in the figure below.

Action (1)
The steps of the construction of the magnetic circuit are presented in the following table.

Step Action Illustration

1

Create a sketch of the magnetic circuit on XZ plane

by menu: Tools > Sketch > New

(access by icon:  )
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Step Action Illustration

2

Modify the options of the grid:

Option of the grid

Magnetization Length of grid cell Number of subdiv.
Number of

points/subdiv

Yes 30 30 30

by menu: Option > Edit

(access by icon: )

3

Create the sketch using Polyline command, starting
point 1 and ending point 18 as in the figure.

by menu: Construction > Line > Polyline

(access by icon: )

4

Modify the coordinates of all points:

Flux point 1st coord. 2nd coord.

1 -34 0

2 -12.15 0

3 -12.15 0.98

4 2.2 4.825

5 2.2 5.95

6 -28 5.95

7 -28 17.1

8 22.25 17.1

9 22.25 17.686

10 7.65 23
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Step Action Illustration

Flux point 1st coord. 2nd coord.

11 7.65 25.85

12 5.475 25.85

13 5.475 23

14 3.3 23

15 3.3 25.85

16 -2.557 25.85

17 -9.7 23.25

18 -34 23.25

Select all points and choose: Edit array

(access by icon: )

5

Close the sketch context. The model appears as in the
figure in the Flux Modeler

by menu: Project > Close Sketch context

(access by icon: )

6

Extrude the SKETCH_1 with the following
characteristics:

Definition Faces to extrude

EXTRUDE_1 face 1
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Step Action Illustration

Extrusion

Type
Coord.
system

Formula
or value

Length
Offset
origin
plane

Along a
vector

COORDSYS_

XZ_PLANE
0, 0, 1 8.05 0

by menu: Tools > Extrusion > New

(access by icon: )
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2.1.2 Create the mobile part

Goal
The mobile part is created in the Modeler context. The steps are presented in the following table.

The outline of the mobile part is shown in the figure below.

Action (1)
The steps of the construction of the magnetic circuit mobile part are presented in the following table.

Step Action Illustration

1

Open the sketch created previously : SKETCH_1

by menu: Tools > Sketch > Open sketch > New

(access by icon: )

2

Create the sketch using Polyline command,
starting point 55 and ending point 67 as in the
figure.

by menu: Construction > Line > Polyline

(access by icon: )

3

Create a reference line by linking the two
reference points. This reference line will be used
to create the second reference plane around an
angle.

Flux point 1st coord. 2nd coord.

55 -11.15 0

Proprietary Information of Altair Engineering



Altair® Flux®

2 Construction of the Flux project p.30

Step Action Illustration

Flux point 1st coord. 2nd coord.

56 -11.15 0.595

57 3.2 4.44

58 3.2 5.5

59 30 5.5

60 30 18

61 23.625 18

62 8.65 23.45

63 8.65 25.35

64 25 25.35

65 25 23.2

66 35 23.2

67 35 0

Select all points and choose: Edit array

(access by icon: )

4

Close the sketch context. The model appears as in
the figure in the Flux Modeler

by menu: Projet > Close Sketch context

(access by icon: )
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Step Action Illustration

5

Extrude the SKETCH_1 with the following
characteristics:

Definition
System
coord.

Faces to
extrude

EXTRUDE_2 XYZ1 face 22

Extrusion

Type
Coord.
system

Formula
or

value
Length

Offset
origin
plane

Along
a

vector

COORDSYS_

XZ_PLANE
0, 0, 1 8.05 0

by menu: Tools > Extrusion

(access by icon: )

Select Project > Return to standard geometry

(access by icon: )
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2.1.3 Add symmetries to the domain

Goal
Two symmetry planes – one parallel to the XZ plane and one parallel to the YZ plane – are created to
model a quarter of the trident geometry.

Outline
The symmetry plane used in this study is shown in the figure below.

Symmetry

Symmetry

plane YZ

plane ZX

Data
The characteristics of the symmetries are presented in the tables below.

Symmetry versus YZ plane

Geometrical aspects
Name (automatic)

Type Y offset position
Physical aspects*

COORDSYS_YZ_PLANE Versus YZ plane 0 -
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Symmetry versus ZX plane

Geometrical aspects
Name (automatic)

Type Y offset position
Physical aspects*

COORDSYS_ZX_PLANE Versus ZX-plane 0 -

Note:  Physical aspects of the symmetries are specified in the section concerning the
physical description.

Access
• by menu: Geometry > Symmetry > New
• by icon: 
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2.1.4 Add an infinite box to the domain

Goal
In order to automatically impose the natural condition of a zero magnetic field at infinity, the studied
device is placed inside an infinite box. One quarter of the infinite box is modeled because of the
presence of symmetries.

Data
The infinite box and its characteristics are presented below.

Infinite box of Parallelepiped type

Name
(automatic)

X inner
size, ½
length

X outer
size, ½
length

Y inner
size, ½
length

Y outer
size, ½
length

Z inner
size, ½
length

Z outer
size, ½
length

InfiniteBoxCube 35 40 20 25 51 56

Access
• by menu: Geometry > Infinite box > New
• by icon : 
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Action
Complete the Infinite box in order to close domain.

Access
• by menu: Geometry > Infinite box > Complete Infinite box
• by icon: 
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2.2 Mesh generation process

Introduction
This section presents the general steps of mesh generation for the computational domain and the data
required to describe the trident mesh. The meshed device is presented in the figure below.

Contents
This section covers the following:

• Mesh the device

• Modify the aided relaxation

• Create and assign line relaxation

• Generate the mesh
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2.2.1 Mesh the device

Goal
Mesh generation process is an essential step of the Finite Element method. At this stage, the
computational domain is divided in small elements.

Each node of the mesh constitute a support where the state variable approximation (such as scalar
or vector potentials, temperature, etc.) and the derived fields (such as magnetic field and induction,
magnetic flux density, electric field, thermal flux density, etc.) are computed.

Aided mesh is activated by default in Flux. Such tool permits to obtain a first basic mesh with global
settings.

.

Action
Mesh the device.

Access
• by menu: Mesh > Mesh domain
• by icon: 

Result
The result appears as below.
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Comments
To optimize the accuracy of the results, it is advised to have a mesh:

• with well proportioned mesh elements (close to equilateral triangle)

• taking into account the physics (the mesh must be denser in the areas with important field
variation)

For instance, solutions to improve the mesh here are :

• to modify the aided relaxation

• to create and assign line relaxation
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2.2.2 Modify the aided relaxation

Goal
The aided relaxation is modified in order to refine the global mesh, especially in the magnetic circuit..

Data
The modified characteristic of the aided mesh is presented in the table below.

Relaxation

Aided Relaxline/Relaxface/Relaxvolume Setting of relaxation

Assign Low (r=0.25)

Access:
• by menu: Mesh > Aided mesh > Edit
• by icon: 
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2.2.3 Create and assign line relaxation

Goal
One local line relaxation is created and assigned to control the density in an automatic mesh.

In order to refine the magnetic circuit mesh, RELAXLINE_MC line relaxation is created and assigned to
the circuit lines except in the air gap.

The concerned lines are presented in the figure below.

RELAXLINE_MC

Data
The characteristics of the line relaxation are presented in the table below.

Relaxation line

Name Comment Mesh relaxation on line Coef. Color

RELAXLINE_MC Trident lines User 0.1 Green

Access
• by menu: Mesh > Relaxation > Relaxation line > New
•

by icon: 

Action
Assign relaxation line to lines.
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Access
• by menu: Mesh > Assign mesh information > Assign relaxation / shadow > Assign

relaxation to lines
• by icon: 
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2.2.4 Generate the mesh

Goal
Lines, faces and volumes of the computation domain are meshed using the algorithm of automatic mesh
generator to generate the first order elements. Then the second order elements are generated.

Action (1)
Mesh domain.

Access (1)
• by menu: Mesh > Mesh domain
• by icon: 

Note:  Another solution is to select both commands Mesh Faces / Mesh Volumes.

Result
The resulting mesh of the computation domain is shown in the figure below.

Action (2)
Generate second order mesh elements
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Access (2)
• by menu: Mesh > Generate second order elements
• by icon: 

Result
Details of the resulting mesh of the trident are presented below.

Nombre d'elements non evalues : 0 %

Nombre d'elements d'excellente qualite : 46.12 %

Nombre d'elements de bonne qualite : 42.78 %

Nombre d'elements de qualite moyenne : 10.28 %

Nombre d'elements de qualite mediocre : 0.82 %
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2.3 Physical description process

Introduction
This section presents the definition of the physical application, physical properties (materials, regions,
coils) and kinematic properties (mechanical sets).

Contents
This section covers the following:

• Define the physical application

• Define physical aspects of symmetry

• Create mechanical sets

• Create materials

• Create and assign volume regions

• Create a coordinate system for a coil

• Create a source (electric components and coil)
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2.3.1 Define the physical application

Goal
First, the physical application is defined. The required physical application is the 3D Magneto Static
application.

Data
The characteristics of the application are presented in the table below.

Magneto Static 3D application

Formulation model

Order or finite
element functions

Order of finite
element functionsFormulation model

Scalar potential Vector potential

Coils coefficient

Automatic formulations Automatic Automatic Automatic coefficient

Access
by menu: Application > Define > Magnetic > Magneto Static 3D
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2.3.2 Define physical aspects of symmetry

Goal
Physical aspects of the symmetries created in the geometry description are defined.

Data
The characteristics of the modified symmetries are presented in the table below.

Symmetry versus YZ plane

Name (automatic) Geometrical aspects Physical aspects

SymmetryYZplane_1
Add symmetries
to the domain

Tangent magnetic field, normal
electric field, adiabatic condition

Symmetry versus ZX plane

Name (automatic) Geometrical aspects Physical aspects

SymmetryZXplane_1
Add symmetries
to the domain

Tangent magnetic field, normal
electric field, adiabatic condition

Proprietary Information of Altair Engineering



Altair® Flux®

2 Construction of the Flux project p.47

2.3.3 Create mechanical sets

Goal
Three mechanical sets are created to define kinematic properties of the trident.

Data
The characteristics of the mechanical sets are presented in the table below.

Fixed Mechanical Set

Name Comment

FIXED_PART Fixed part

Compressiblemechanical set

Name Comment Used method

COMPRESSIBLE_PART
Compressible part

surrounding the movable part
Re-meshing of the air part

surrounding the moving body

Translation along one axis mechanical set

AxisName Comment

Translation axis Coord. system

Kinematcs

TRANSLATION _PART Movable part along Z XYZ1 Multi-static

Access
by menu: Physics > Mechanical set > New

• by menu: Physics > Mechanical set > New
•

by icon: 
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2.3.4 Create materials

Goal
One material characterized by a nonlinear B(H) curve is created directly for the physical description of
the trident.

Data
The characteristics of the material are presented in the table below.

B(H) magnetic property: isotropic analytic saturation + knee adjustment

Name Comment
Initial relative
permeability

Saturation
magnetization [T]

Knee adjustment
coeff.

FESI Nonlinear magnetic steel 2500 2.01 0.075

Access
• by menu: Physics > Material > New
• by icon: 
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2.3.5 Create and assign volume regions

Goal
Three volume regions necessary for the physical description of the trident are created and assigned to
volumes.

The volumes volume regions are shown in the figure below.

AIR

UP_GRIP

DOWN_GRIP

Data
The characteristics of the volume regions are presented in the table below.

Volume region

Name Comment Type Material Color Mech. set

AIR
Air surrounding
the upper and

lower grips

Air or vacuum
region

- Turquoise
COMPRESSIBLE

_PART

UP_GRIP Upper trident grip
Magnetic non-

conducting
region

FESI Grey_anthracite
TRANSLATION

_PART

DOWN_GRIP Lower trident grip
Magnetic non-

conducting
region

FESI Grey_steel FIXED_PART

Access
• by menu: Physics > Volume region > New
• by icon: 
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Action (1)
The AIR volume region is assigned to the five volumes of infinite box.

The five volumes of the AIR region are presented in the figure below.

5

2

4

7

6

Action (2)
The UP_GRIP volume region is assigned to the volume of the movable part.
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Action (3)
The DOWN_GRIP volume region is assigned to the volume of the fixed part.

Access
• by menu: Physics > Assign regions to geometric entities  > Assign regions to volumes

(completion mode)
•

by icon: 
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2.3.6 Create a coordinate system for a coil

Goal
One coordinate system is created to define a non-meshed coil.

Data
The coordinate system and its characteristics are presented below

center of the coil
COIL_CS

XYZ1
center of the device

1.05

Cartesian coordinate systemdefined with respect to the Local coordinate system

Origin coordinates Rotation angle

Name

Comment Parent
coord.
system 1st (X) 2d (Y) 3rd (Z) About

X-axis
About
Y-axis

About
Z-axis

COIL_CS For a coil XYZ1 0 0 -1.05 0 0 0

Access
• by menu: Geometry > Coordinate system  > New
•

by icon: 

Proprietary Information of Altair Engineering



Altair® Flux®

2 Construction of the Flux project p.53

2.3.7 Create a source (electric components and coil)

Goal
One non-meshed coil with an associated electric component (of coil conductor type) is created to model
a current source of the trident.

Data (1)
The characteristics of the electric component (of coil conductor type) are presented in the table below.

Stranded coil with imposed current (A)

Name Comment Value Color

SOURCE Current source of coil 0.3 Orange

Access (1)
• by menu: Physics > Electrical components > Stranded coil conductor  > New
• by icon: 

Data (2)
The non-meshed coil and their characteristics are presented below.
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Rectangular coil: geometric definition

Coil Dimension Filet
radius

Number Coord. system Center Radius Along X Along Y Thickness

1 COIL_CS 0, 0, 0 9 24 28 2

Rectangular coil: geometric definition

Coil section

Type Height Width
Mechanical set

Rectangle 49.2 6 FIXED_PART

Rectangular coil: electrical definition

Electric component
associated with the coil

Number
of turns

Conductors in
series or in parallel

Symmetries and periodicities:
duplication or none

SOURCE 3250 … in series duplication

Access
• by menu: Physics > Non meshed coil > New
• by icon: 
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3 Case 1: Study using the multi-static kinematic model (different linear positions)

This chapter covers the following:

• 3.1 Case 1: Solving process  (p. 56)

• 3.2 Case 1: Results post-processing  (p. 58)

Case 1
The first case is a study using the multi-static kinematic model (Magneto Static application):

In this case (multi-static kinematic model), the moving part of the device can take various positions
fixed arbitrarily.

We are interested in the computation of the magnetic field for arbitrarily chosen positions of the
mobile grip.

With this model it is possible to evaluate the force acting on the fixed grip at different positions.

Starting Flux project
The starting Flux project is GEO_MESH_PHYS.FLU. This project contains:

• the geometry description of the contactor

• the mesh of the computation domain

• the initial physical description of the contactor

New Flux project
The new Flux project is CASE1.FLU.
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3.1 Case 1: Solving process

Introduction
This section explains how to prepare and solve case 1.

Contents
This section contains the following topics:

• Define solving scenario and solve the project
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3.1.1 Define solving scenario and solve the project

Goal
The solving scenario with one controlled parameter for mechanical set is defined for a solving process,
and then case 1 is solved.

Data
The characteristics of the scenario for the solving process are presented in the table below.

Solving scenario

Name Comment Type

CASE1 Multi-static kinematic model Multi-values

Solving scenario

Parameter control

IntervalControlled
parameter Lower endpoint Upper endpoint Method Step value

LINPOS_
TRANSLATION_PART

0.006 0 Step value -0.0005

Access
• by menu: Solving > Solving scenario > New
•

by icon: 

Action
The project is solved using the CASE1 scenario.

Access
• by menu: Solving > Solve
• by icon: 
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3.2 Case 1: Results post-processing

Introduction
This section explains how to analyze the principal results of case 1.

Contents
This section contains the following topics

• Display default isovalues

• Compute and display isovalues of the relative permeability on volume regions

• Plot a 2D curve of the electromagnetic force versus the linear position
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3.2.1 Display default isovalues

Goal
First, the computation step of the study using a multi-static kinematic model is selected; then, the
scalar quantities of the magnetic flux density on the volume regions are computed and displayed via
isovalues plots of color shadings.

Data
The characteristics* of the scenario and computation step selection are presented in the table below.

Scenario and computation step selection

Computation stepScenario

Parameter name Value

CASE1 LINPOS_TRANSLATION_PART 0

Action
Display isovalues (ISOVAL_NO_VACUUM).

Access
• by menu: Graphic > Isovalues > Display Isovalues
• by icon: 

Result
This chart shows the magnetic flux density on the DOWN_GRIP and UP_GRIP volume regions.

Note:  *These characteristics are located in the dialog box below the data tree.
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3.2.2 Compute and display isovalues of the relative
permeability on volume regions

Goal
The scalar quantities of the relative permeability is computed on the volume regions and displayed
via isovalues plots of color shadings for the following computation step previously selected:
LINPOS_TRANSLATION_PART = 0.

Data
The characteristics of isovalues are presented in the table below.

Isovalues on spatial groups

Volume region Formula

V_DOWN_GRIP ; V_UP_GRIP Mur

Action
Create isovalues (ISOVAL_1).

Access
• by menu: Graphic > Isovalues > New
• by icon: 

Result
This chart shows the relative permeability on the DOWN_GRIP and UP_GRIP volume regions.

Proprietary Information of Altair Engineering



Altair® Flux®

3 Case 1: Study using the multi-static kinematic model (different linear positions) p.61

3.2.3 Plot a 2D curve of the electromagnetic force versus
the linear position

Goal
The variation of the electromagnetic force versus the linear position is computed and displayed as
curve.

Data
The characteristics of the curve are presented in the table below.

2D curve (I/O parameter)

Parameter Mechanical set

Name Comment
Name

Limit
min.

Limit
max.

Mec. set Quantity

CURVE Force LINPOS_
TRANSLATION_PART

0 0.006 TRANSLATION_PART Electromagnetic
force

Access (1)
• by menu: Curve > 2D curve (I/O parameter)  > New 2D curve (I/O parameter)
• by icon: 

Result
The following curve shows the variation of electromagnetic force for different values of the linear
position.
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4 Case 2: Study using the coupled load kinematic model (with circuit coupling)

This chapter covers the following:

• 4.1 Case 2: Physical description  (p. 63)

• 4.2 Case 2: Solving process  (p. 71)

• 4.3 Case 2: Results post-processing  (p. 74)

Case 2
The second case is a parametric study using the coupled load kinematic model (Transient Magnetic
application)

In this case (coupled load kinematic model), a resistant force is exerted on the moving part of the
device by means of a system of return springs; the coil is supplied by an external electric circuit
(voltage source).

The advantage of this model is to study the time variation of :

• The position of the mobile grip

• The speed of the mobile grip

• The electromagnetic force acting on the mobile grip

• The current through the coil

• The flux through the coil

Starting Flux project
The starting Flux project is GEO_MESH_PHYS.FLU.

This project contains:

• the geometry description of the contactor

• the mesh of the computational domain

• the initial physical description of the contactor

New Flux project
The new Flux project is saved under the name CASE2.FLU.
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4.1 Case 2: Physical description

Introduction
This section explains how to prepare and solve case 2.

Contents
• Define the physical application

• Import the electric circuit

• Define the circuit component

• Create an I/O parameter

• Modify a mecanical set

• Redefine the non meshed coil and the physical regions
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4.1.1 Define the physical application

Goal
First, the current physical application is deleted, and then the new physical application is defined. The
required physical application for case 2 is the 3D Transient Magnetic application.

Data
The characteristics of the application are presented in the table below.

3D Transient Magnetic application

Formulation model

Formulation
model

Approximating
functions

Approximation order
for scalar variable

Approximation
order for

vector variable

Coils
coefficient

Automatic
formulations

Nodal finite
elements

Automatic Automatic Automatic
coefficient

Action (1)
Delete the current application.

Access (1)
by menu: Application > Delete current application

Action (2)
Define the 3D transient magnet application.

Access (2)
by menu: Application > Define magnetic application > Transient magnetic application
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4.1.2 Import the electric circuit

Goal
An existing electric circuit is imported in the project.

Action
Import the electric circuit CASE2.ccs into the project CASE2.FLU.

Access
• by menu: Physics > Circuit  > Import circuit from a ccs file
•

by icon: 

Result
After importation, the electric circuit of the new project looks like the figure below.

Proprietary Information of Altair Engineering



Altair® Flux®

4 Case 2: Study using the coupled load kinematic model (with circuit coupling) p.66

4.1.3 Define the circuit component

Goal
The components of the imported electric circuit are defined.

Data (1)
The modified characteristics of the stranded coil of the imported electric circuit are presented in the
table below.

Stranded coil belonging to a circuit

Name Comment Resistance formula [Ω]

B1 - 73

Access (1)
• by menu: Physics > Electrical component  > Edit

Data (2)
The modified characteristics of the voltage source of the imported electric circuit are presented in the
table below.

Voltage source

Name Comment Value [V]

V1 - 24

Access (2)
• by menu: Physics > Voltage source  > Edit
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4.1.4 Create an I/O parameter

Goal
An I/O parameter is created to describe the resistive force in the TRANSLATION_PART mechanical
set.

Data
The characteristics of the parameter are presented in the tables below.

Parameter defined by a table of values

Name Comment I/O parameter for the abscissa

RF Resistive force LINPOS_TRANSLATION_PART

Parameter defined by a table of values

Abscissa Ordinate

0 10.9

0.0014 9.4

0.002 4.7

0.0036 4.5

0.0037 2.8

0.006 2.7

Access
• by menu: Parameter/Quality  > I/O Parameter  > New
• by icon: 
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4.1.5 Modify a mecanical set

Goal
The mechanical set TRANSLATION_PART is modified to describe the kinematic properties of the
device using its resistant force.

Data (1)
The modified characteristics of the mechanical set are presented in the table below:

Translation along one axis mechanical set

AxisName Comment

Translation axis Coord. system

Kinematics

TRANSLATION _PART Movable part along Z UP Coupled load

Translation along one axis mechanical set

General Internal characteristics

Velocity Position Type of load Mass Resistive force

0 6E-3 Mass and resistive force 0.11 -RF

Translation along one axis mechanical set

External characteristics Mechanical stops

Type of load Mass Resistive force Min Max

Mass and resistive force 0 0 -0.3863E-3 6E-3

Access
by menu: Physics  > Mechanical set  > Edit
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4.1.6 Redefine the non meshed coil and the physical
regions

Goal
The following physical information are changed:

• The non-meshed coil is modified to link the non-meshed coil to the electric component (of stranded
coil type) of the imported electric circuit

• All the volume regions are modified to activate them in the Transient Magnetic application

• The unused coil conductor SOURCE is deleted

Data (1)
The modified characteristics of the non-meshed coil are presented in the table below.

Rectangular coil: electrical definition

Electric comp.
assoc. with the coil

N° of turns Conductors in
series or in parallel

Symm. and periodicities:
duplication or none

B1 3250 … in series duplication

Access (1)
by menu: Physics  > Non meshed coil  > Edit

Data (2)
The modified characteristics of the volume regions are presented in the table below.

Volume region

Name Comment Type Material Color Mechanical set

AIR Air around upper
and lower grips

Air or vacuum region - Turquoise COMPRESSIBLE
_PART

UP_GRIP Upper trident grip Magnetic non-
conducting region

FESI Grey_anthracite TRANSLATION
_PART

DOWN_GRIP Lower trident grip Magnetic non-
conducting region

FESI Grey_steel FIXED_PART

Access (2)
by menu: Physics  > Volume region  > Edit
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Action
The SOURCE coil conductor used in case 1 is deleted.

Access
by menu: Physics  > Electrical components  > Stranded coil conductor  > Delete
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4.2 Case 2: Solving process

Introduction
This section explains how to prepare and solve case 2.

Contents
This section contains the following topics:

• Define solving scenario, solving options and solve the project
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4.2.1 Define solving scenario, solving options and solve
the project

Goal
The scenario is defined for a transient solving process; the solving options are defined to improve the
convergence of the New-Raphson solving process; then case 2 is solved.

Data (1)
The characteristics of the solving scenario are presented in the table below.

Solving scenario

Name Comment Control of transient state

CASE2 Coupled load kinematic model Control by time

Solving scenario - Parameter control

IntervalControlled
parameter Lower limit Higher limit Method Step value

0 0.02 0.0025

0.02 0.06 0.001TIME

0.06 0.15

Step value

0.0025

Access (1)
• by menu: Solving > Solving scenario > New
•

by icon: 

Data (2)
The characteristics of the solving options are presented in the table below.

Advanced solving options

Method for TO computation
Reinitialization of state variables
at the beginning of a time step

Project saving frequency

Automatically specified No state variable set to 0 Saving one step to N N=1
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Access (2)
Step 2: Solve this scenario

• by menu: Solving > Solving process options  > Edit
•

by icon: 

Action
The project is solved using the CASE2 scenario.

Access
Step 2: Solve this scenario

• by menu: Solving > Solved
• by icon: 
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4.3 Case 2: Results post-processing

Introduction
This section explains how to analyze the principal results of case 2.

Contents
This section contains the following topics:

• Plot a 2D curve of the linear position versus time

• Plot a 2D curve of the translating part speed versus time

• Plot a 2D curve of the current through the coil versus time

• Plot a 2D curve of the flux through the coil versus time

• Plot a 2D curve of the electromagnetic force versus time
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4.3.1 Plot a 2D curve of the linear position versus time

Goal
The values of the linear position versus time are computed and displayed as curve.

Data

2D curve (I/O parameter)

Parameter Mechanical set

Name Comment Name Limit
min

Limit
max

Mech. set Quantity

POSITION
Linear position

versus time
TIME 0.0 0.15 TRANSLATION _PART

Linear
position

Access

• by menu: Curve > 2D Curve (I/O parameter)  > New 2D Curve (I/O parameter)
• by icon: 

Result
The following curve shows the variation of linear position for different values of time.
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4.3.2 Plot a 2D curve of the translating part speed versus
time

Goal
The values of the linear speed versus time are computed and displayed as curve.

Data

2D curve (I/O parameter)

Parameter Mechanical set

Name Comment Name Limit
min

Limit
max

Mech. set Quantity

SPEED
Linear speed
versus time

TIME 0.0 0.15 TRANSLATION _PART Linear speed

Access

• by menu: Curve > 2D Curve (I/O parameter)  > New 2D Curve (I/O parameter)
• by icon: 

Result
The following curve shows the variation of speed for different values of time.
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4.3.3 Plot a 2D curve of the current through the coil
versus time

Data
The values of the current through the coil versus time are computed and displayed as curve.

2D curve (I/O parameter)

Parameter Circuit

Name Comment Name Limit
min

Limit
max

Stranded coil
conductor

Quantity

CURRENT
Current through

the coil versus time
TIME 0.0 0.15 B1 Current

Access

• by menu: Curve > 2D Curve (I/O parameter)  > New 2D Curve (I/O parameter)
• by icon: 

Result
The following curve shows the variation of current through the coil for different values of time.
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4.3.4 Plot a 2D curve of the flux through the coil versus
time

Data
The values of the flux versus time are computed and displayed as curve.

2D curve (I/O parameter)

Parameter Circuit

Name Comment Name Limit
min

Limit
max

Stranded coil
conductor

Quantity

FLUX
Magnetic flux through
the coil versus time

TIME 0.0 0.15 B1 Flux

Access
• by menu: Curve > 2D Curve (I/O parameter) > New 2D Curve (I/O parameter)
• by icon: 

Result
The following curve shows the variation of magnetic flux through the coil for different values of time.
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4.3.5 Plot a 2D curve of the electromagnetic force versus
time

Data
The values of the electromagnetic force versus time are computed and displayed as curve.

2D curve (I/O parameter)

Parameter Mechanical set

Name Comment Name Limit
min

Limit
max

Mech set Quantity

FORCE
Electromagnetic
force versus time

TIME 0.0 0.15 TRANSLATION_PART
Electromagnetic

force

Access
• by menu: Curve > 2D Curve (I/O parameter) > New 2D Curve (I/O parameter)
• by icon: 

Result
The following curve shows the variation of electromagnetic force for different values of time.
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