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Foreword 

*(Please read before starting this tutorial) 

 

  

  
Description of 

the document 
A very simple application is illustrated in this technical paper to explain how 

ECAD imports are managed within Flux PEEC; this document goes through 

all steps of the process allowing the user to import PCB layers and vias 

described in Gerber format. 

Moreover, description of actions required to define physical properties of 

imported objects is also presented. 
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1. A basic application to understand the procedure 

 
Studied device The aim is to import Gerber files describing a basic two layers PCB 

connected by perpendicular vias and build the entire project in Flux PEEC 

software using dedicated tools. 

 
Geometry to be 

imported 
Two rectangular planes situated on TOP and BOTTOM layers respectively 

are connected with seven perpendicular vias. The image below shows a top 

and a side view of the considered geometry. 

 

Top

Bottom

Vias
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1.1. Choice and definition of the suitable application 

 
Studied device This section presents the preliminary steps necessary for defining the Flux 

PEEC application to be used and the computation scenario. 

 

 

 

 

1.1.1. Start and define the suitable application 

 
Goal First, the Flux PEEC application is defined: goal of this example is the 

computation of the equivalent impedance of the structure described above. 

This simulation will consider the resistive, the inductive and the capacitive 

behaviour of the two-layer PCB. 

 
Definition of 

the application 
The chosen application is therefore Conductor impedances with capacitive 

effects and the default material for conductors is copper whose resistivity is 

17.2 nΩ∙m. 

Properties of the application are reported in the table below. 

 
Type of application Default material for new conductors 

Conductor impedances with capacitive effects copper 

 

 

 

 

1.1.2. Define the solving scenario 

 
Goal The solving frequency values are set via the solving scenario (only one 

scenario per project is allowed). 

 
Definition of 

the scenario 
For simplicity, a mono-value scenario will be solved in this technical 

example: the considered frequency will be 1 MHz. 

Properties of the solving process scenario are reported in the table below. 

 
Name Piloted variation parameter Control type Value 

Scenario_1 FREQUENCY Mono-value 1e6 
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2. Import of Gerber files describing TOP and 
BOTTOM layers 

 
Introduction Geometrical description of the PCB is provided by means of three Gerber 

files: one for each of the two layers and one for the vias. The procedure to be 

used within Flux PEEC requires to firstly import all layers and at the end the 

vias. In fact, such a procedure will automatically establish the connection 

between conductors of the layers and vias, thus making easier the definition 

of the global model. 

This section describes the import of two Gerber files: Gerber-example-top-

7vias.ger and Gerber-example-bottom-7vias.ger. These files are supplied to 

the user in the folder 

…\flux\Flux\DocExamples\ExamplesPEEC\Tutorial_Basic\ 

ECADImportGerberFormat\ECADImportGerberFormat.zip\ 

ECADImportGerberFormat_PEEC_Case1 

 

2.1. Import of TOP layer 

 
Introduction Thickness of both layers of this PCB is fixed at 35 µm, their centre-to-centre 

distance is 250 µm. 

Gerber import functionalities are accessible within Flux PEEC by the menu: 

 

 Project → ECAD import → Import of a Gerber layer 

 
Action (1) To import the TOP layer, fill in the dialog box with the following 

information: 
 

Gerber file containing the layer 
Gerber-example-top-7vias.ger 

Name of layer 
TOP 

Coordinate system for the layer positioning 
XYZ1 

Lower Z-coordinate of the layer 

0.250 

Layer thickness 
0.035 

Color of the layer 
Black 

Continued on next page 
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Remark The coordinate system XYZ1 is a standard Cartesian system automatically 

created by Flux PEEC for each new project; its length and angle units are by 

default millimetre and degree, respectively. That’s why in the previous dialog 

box it is necessary to convert Z-coordinate and thickness of the layer from 

micrometre to millimetre. 

User who prefers to work in micrometres as length unit has just to modify the 

properties of XYZ1 coordinate system or, better, to create a new coordinate 

system. 

 
Result The layer named TOP is imported into a 2D sketcher context, with many 

points and lines describing shapes of the conductors. 

This 2D context is used to easily clean and/or modify details of 2D layers in 

order to prepare with dedicated tools the project to simulate: it is advised for 

example to remove parts that require extensive computational resources 

without providing useful electromagnetic results. 
 

 

Continued on next page 
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Sketcher 

context 
Some imported elements seem to be very small, but a zoom-in by using the 

wheel of the mouse makes it possible to note that several segments are linked 

together to create circles representing the places where vias are positioned. 

 

 

 
Defects By zooming-in on the right top part (or on the bottom left part) of the 

imported TOP layer, two geometric defects appear: an additional 

protuberance exists at each corner of the rectangle. 

 

 

Continued on next page 
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Action (2) These defects can be easily corrected by the user by simply left-clicking on 

the central point of the protuberance and moving it down (or up, depending 

on the considered corner) towards the other point on the side to get the 

following geometric configuration: 

 

 

 
Action (3) Once all corrections are carried out, creation of faces of the layer is required 

to carry on with the import operations. This functionality is accessible by the 

menu: 

 

 Construction → Face → Build faces 
 

 

Eight faces are created: seven represent the area of vias and the latter the rest 

of the rectangle. Their color is black as previously indicated in the dialog box 

for the layer import. 

 

 

Continued on next page 
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Action (4) From a physical point of view, the PCB (ground or power) plane is 

constituted by the whole rectangle. The definition of such a conductor could 

be done by listing all these eight faces but it will be more efficient if they are 

merged together to create a global one. 

In fact, the seven faces describing the vias can be disregarded since their 

position is also stored in their Gerber file to be imported at the end of this 

process. Moreover, the fact that these via areas touch the main face means 

that they are electrically connected to the plane and they are not holes. 

Consequently, the geometry can be simplified by means of the menu: 

 

 Tools → Merge faces  

 

All faces need to be selected, either by graphic selection or in the data tree by 

keeping pressed the Ctrl button of the keyboard. As a result, only one face 

remains (see data tree), whereas points and lines identifying vias still appear 

in the graphical view. 

 

 

 
Remark These points and lines are also listed in the data tree, but they are now 

declared as “NO EXIST”, so that they do not contribute to the definition of 

the model. But, on the other side, in case the user needs to revise the 

geometry he can delete faces, modify the property of involved lines from 

“NO EXIST” to “STANDARD” and then rebuild faces in order to create the 

original geometry he had before the merging. 

 
Action (5) In this technical example, no revisions of the geometry are planned, so that 

the suppression of useless points and lines is achieved. To this aim, select in 

the data tree points from [9] to [64] by means of the Shift button of the 

keyboard, then right-click and select the Delete command in the menu that 

appears. 

Continued on next page 
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Result As a result, all points and lines that described the position of vias are 

suppressed. 

 

 

 
Action (6) At corners where protuberances existed at the beginning of the process, some 

useless points still remain and some lines can also be merged since they are 

constituted by several segment having the same direction. To this aim, use the 

menu: 

 

 Tools → Simplify all lines  

 

As a result, only four points and four lines still exist and they are enough for 

the definition of plane shape. 

 
Action (7) Operations in the 2D sketcher context for importing and simplifying the TOP 

layer of the PCB are concluded; coming back to the Flux PEEC standard 

working context is the next action that can be carried out by clicking on the 

orange cross at the right top corner of the window or by the menu: 

 

 Project → Close Sketcher2DContext 
 

Continued on next page 
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Result The points, the lines and the faces (only one in this example) describing the 

lower surface of the TOP layer are automatically transmitted to the standard 

working context of Flux PEEC. Moreover, a geometric parameter 

LAYER_THICKNESS_TOP, a coordinate system COORDSYS_TOP and a 

transformation TOP are created in order that the user could reposition the 

imported layer in the 3D space and especially could easily generate later the 

volumes representing the PCB planes and tracks. 

 

 

 
Remark An ECAD-layer entity named TOP has also been created (see data tree in the 

image below): it is fundamental to generate later the volumes representing the 

PCB planes and tracks, but it also enables to go back to the ECAD working 

context and continue defeaturing operations on the layer if some details have 

been forgotten. 

 

 

 

 

2.2. Import of BOTTOM layer 
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Action To import the file describing the BOTTOM layer, go to the menu: 

 

 Project → ECAD import → Import of a Gerber layer 

 

and then fill in the dialog box with the following data: 

Gerber file containing the layer 

Gerber-example-bottom-7vias.ger 

Name of layer 
BOTTOM 

Coordinate system for the layer positioning 
XYZ1 

Lower Z-coordinate of the layer 
0 

Layer thickness 
0.035 

Color of Layer 
Red 

 
Result The layer named BOTTOM is imported into the 2D sketcher context: 

 

 

 
Defects As it was for the TOP layer, also the BOTTOM presents two geometric 

defects: a chamfer on the left top corner and a protuberance of the right 

bottom corner of the rectangle. To correct them, the user has to left-click on 

points and move them to the location allowing to have a perfect rectangular 

shape. 

Continued on next page 
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Faces, lines and 

points 
Once all corrections are carried out, the user can proceed with the creation of 

the faces by the menu; 

 

 Construction → Face → Build faces 
 

 

This command generates eight new faces, whose color is red as it was 

previously indicated in the dialog box for the layer import. 

Merging these faces is the next action to perform by the menu: 

 

 Tools → Merge faces  

 

that compacts all faces of the BOTTOM layer in only one and modifies to 

“NO EXIST” properties of internal points and lines that identify the via 

positions. 

To further simplify the imported geometry, in this example, deletion of such 

useless points and lines is executed by selecting in the data tree points from 

[12] to [67] and then by pressing the Delete button of the keyboard. Please 

note that in the data tree also the entities belonging to the TOP layer 

(previously imported) are listed. 

Final action to complete BOTTOM-layer import is the merging of lines at the 

rectangle corners where defeaturing operations had been carried out: to this 

aim, use the menu: 

 

 Tools → Simplify all lines  

 

As a result, only four points, four lines and one face still exist for this 

BOTTOM layer and they are enough for the definition of the plane shape. 
 

 

Continued on next page 
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Action Operations on BOTTOM layer in the 2D sketcher context are concluded, so 

that user can quit this working environment by clicking on the orange cross at 

the right top corner of the window and come back to Flux PEEC standard 

view where the two planes (representing the TOP and the BOTTOM layers) 

are correctly placed. Moreover, all parameters, coordinate systems and 

transformations are automatically defined to easily continue the process. 

 

 

 
Advice At this stage of the process, it is highly recommended to save a copy of the 

project and keep it separated from the following actions. In fact, from now on, 

operations will be performed in the standard Flux PEEC context, but in case 

the geometry of the imported layers has to be revised, the modifications must 

be done in the 2D sketcher context. 
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3. Geometry and physics 

 
Introduction This section describes how to complete the geometric definition of the layers, 

their physical descriptions and the import of PCB vias from Gerber file. 

 

 

3.1. Geometry of TOP and BOTTOM layers 

 
Goal Aim of this part of the process is the creation of conductors describing PCB 

layers; this requires the creation of volumes from imported faces. 

 
Action To build volumes for a layer, in the data tree choose the ECAD layer, right-

click and select Extrude ECAD layer. Thanks to previously-created 

parameters and transformations, all faces of the considered layer are extruded 

to compose volumes whose thickness is equal to the value indicated in the 

Gerber-import dialog box. New faces and volumes are listed in the data tree: 

they have the same color of the layer. 

By repeating this extrusion for both layers, the geometry shown in the figure 

below is obtained. 
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3.2. Physics of TOP and BOTTOM layers 

 
Goal Define physical properties of the layers imported by Gerber files. 

 
Bidirectional 

conductors 
In this example, dimensions and shapes of volumes clearly indicate for both 

layers that they represent PCB power or ground planes. Their best model 

within Flux PEEC is thus the bidirectional-conductor type, since the current 

could freely flow in the two main directions on their surface. 

 

 Physics → Bidirectional conductor → New 
 

 

Properties for TOP and BOTTOM conductors associated to TOP and 

BOTTOM layers respectively, are presented in the table below. 

 
Bidirectional conductor defined by a list of volumes 

 

Name 

Description Meshing 

List of 

volumes 

Face of definition 

of the current 

flow plane 

Surface Thickness 

Type Side 1 Side 2  

TOP 1 7 
Uniform - 

Piecewise 
10 7 

None, 

i.e. one element 

BOTTOM 2 12 
Uniform - 

Piecewise 
10 7 

None, 

i.e. one element 

 
Result Two bidirectional conductors are created: their material is equal to the default 

one, set up at the beginning of the project, i.e. the copper. 

Once all interesting volumes belonging to imported layers are processed, the 

import of vias can be executed. 
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3.3. Import of vias 

 
Goal The last step of the PCB import procedure deals with vias stored in a Gerber 

file, which is supplied to the user in the folder 

…\flux\Flux\DocExamples\ExamplesPEEC\Tutorial_Basic\ 

ECADImportGerberFormat\ECADImportGerberFormat.zip\ 

ECADImportGerberFormat_PEEC_Case1 

 
Action This functionality is accessible within Flux PEEC by the menu: 
 

 Project → ECAD import → Import of Gerber vias 

 

For this example, fill in the dialog box with the following data: 

Gerber file containing the drill drawing 

Gerber-example-vias-7vias.ger 

Profile for vias 

circularVia 
 

 

 
Remark (1) Flux PEEC represents by default all imported vias as full-section conductors, 

even if in reality they are hollow: this choice makes it possible to 

tremendously limit the number of meshing elements and thus computation 

time, without downgrading the accuracy of the simulations, since frequencies 

analysed in power electronics applications are not so high and the main 

function of vias is the connection of layers. For signal integrity models, this 

assumption could not be true. The user who prefers to use hollow sections for 

vias can easily modify properties of all involved conductors by himself after 

import operations. 

At the same manner, the user has the possibility to define vias as full 

rectangular conductors in order to save much more meshing elements without 

compromising result precision. 

Continued on next page 
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Remark (2) During import of vias, not only unidirectional conductors are automatically 

created, but a lot of useful electrical entities are also generated: in particular, 

on TOP and BOTTOM bidirectional conductors, new points are created at the 

locations where vias intersect their volumes. Moreover, at each of these points 

an electrical terminal is created (see the Terminal menu in the data tree); their 

name is TERM_BOTTOM_1, etc. 

Since vias have also terminals (TERM_VIA_1_1, etc.) at each location where 

they intersect layers, all needed electrical connections (CO_AUTO_1, etc.) 

are set up between vias and bidirectional conductors. This automated 

procedure is of great help for the user since it accelerates the workflow and 

avoids potential manual errors. 

 
Result Gerber import of this simple example is now concluded. The user can carry 

on with construction of dielectric substrates if capacitance effects have to be 

considered in the simulation and/or with the connection of active (voltage and 

current source or impedance probe) and passive (RLC elements) components 

before solving. 

 

 


