ACU-T:3204 離散座標モデルを使用したシンプルなヘッドランプ内の放射熱伝達

前提条件

このチュートリアルでは、HyperWorks CFD内のDiscrete Ordinate輻射モデルを使用した輻射伝熱問題の設定について説明します。このチュートリアルを開始する前に、HyperWorks 入門チュートリアルである ACU-T:1000 HyperWorksユーザーインターフェースをすでに完了しHyperWorks CFDAcuSolveの基本を理解しているものとします。このシミュレーションを実行するには、ライセンス供与済みバージョンのHyperWorks CFDおよびAcuSolveにアクセスできる必要があります。

このチュートリアルを実行する前に、ここをクリックしてチュートリアルモデルをダウンロードしてください。 ACU-T3204_headlamp.x_t をHyperWorksCFD_tutorial_inputs.zipから抽出します。

問題の説明

ここで解析する問題をFigure 1およびFigure 2に図示します。この問題は、ハウジング、レンズ、およびバルブによる簡易ヘッドランプで構成されています。バルブ内部の空洞は空気で満たされ、バルブのワット数は1Wで体積熱源としてモデル化されます。流体ボリュームで自然対流の影響を考慮するため、空気にはBoussinesq密度モデルが使用されます。バルブで生成された熱は、バルブからハウジングへの伝導、空気ボリューム内の自然対流、およびバルブから空気ボリュームやレンズボリュームへの放射の3つの方法によって伝達されます。ヘッドランプの外側サーフェスの温度は300Kで一定とみなされます。


Figure 1.


Figure 2.
空気とレンズは、輻射伝熱の関与媒体としてモデル化されます。このチュートリアルでは、空気の吸収係数はゼロとみなします。空気ボリュームとレンズボリュームには、次の放射材料特性が使用されます。
Table 1.
  吸収係数 屈折率
空気 0 1.0
レンズ 900 1.57
関与媒体(participating media)を含むシミュレーションでは、各関与媒体の境界で、次の放射サーフェスタイプを定義する必要があります。
Table 2.
サーフェスタイプ 放射サーフェスタイプ
Participating medium - Participating medium Interface Radiation Interface - Internal
Participating medium - (Non- Participating) medium Interface Wall
External boundaries of Participating medium Radiation Interface - External or Wall
Discrete Ordinate輻射モデルをAcuSolveに実装することにより、鏡面、拡散、および部分鏡面の各インターフェースのモデル化が可能になります。これを行うには、放射サーフェスの定義の際に、拡散比の適切な値を指定します。拡散比の値が1の場合、サーフェスは完全に拡散反射し、値が0の場合、サーフェスは完全に鏡面反射します。0と1の間の値の場合、サーフェスは部分的に鏡面反射します。このチュートリアルでは、空気とレンズの両方が関与媒体としてモデル化されるため、レンズ-空気インターフェースとレンズの外側サーフェスは、それぞれ内部放射インターフェース、外部放射インターフェースとしてモデル化されます。内部インターフェースは、鏡面インターフェースとして定義され、外部インターフェースは拡散インターフェースとして定義されます。


Figure 3.

HyperWorks CFDの起動とHyperMeshモデルデータベースの作成

  1. WindowsのスタートメニューからStart > Altair <version> > HyperWorks CFDをクリックしてHyperWorks CFDを起動します。
    HyperWorks CFDが読み込まれると、Geometryリボンが表示されます(デフォルト)。
  2. 以下の方法のいずれかで新規.hmデータベースを作成します。
    • メニューバーFile > Saveをクリックします。
    • HomeツールのFilesツールグループからSave Asツールをクリックします。


      Figure 4.
  3. Save File Asダイアログで、データベースを保存したいディレクトリを指定します。
  4. データベース名として Headlamp_DOを入力して、Saveをクリックします。
    このディレクトリが解析用ディレクトリになり、シミュレーションに関連するすべてのファイルがこの場所に保存されます。

形状のインポート検証

形状のインポート

  1. メニューバーFile > Import > Geometry Modelをクリックします。
  2. Import Fileダイアログで、作業ディレクトリに移動し、ACU-T3204_headlamp.x_tを選択してOpenをクリックします。
  3. Geometry Import Optionsダイアログで、すべてのオプションをデフォルト設定にしたままImportをクリックします。


    Figure 5.


    Figure 6.

形状の検証

  1. ジオメトリリボンから Validateツールをクリックします。


    Figure 7.
    Validateツールは、モデル全体をスキャンし、サーフェスおよびソリッド上でチェックを実行して、形状に不具合(フリーエッジ、閉じたシェル、交差、重複、スライバーなど)があればフラグ付けします。
    サーフェスやソリッドのエラーは、ツールの下のリストに表示されます。


    Figure 8.
  2. SolidChecksをクリックします。
    Solid Repairツールが開き、これを使用してモデル内の形状エラーを修正できます。
    SolidChecks凡例から、モデルのソリッドに5つの交差があることがわかります。


    Figure 9.
  3. Intersectionsをクリックします。
    交差しているソリッドの修正に使用されるガイドバーが表示されます。
  4. Optional: および をクリックして各エラーを確認します。
  5. Keep common interfaceオプションをアクティブにして、Combine Allをクリックします。
    今度はSolidChecks凡例のすべてのエラーについてゼロが表示されています。
  6. もう一度Validateツールをクリックします。
    ツールアイコンの左上に青色のチェックマークが表示されているのがわかります。これは、何の問題も検出されず、次に進む準備が整ったことを示します。


    Figure 10.

流れのセットアップ

一般的なシミュレーションパラメータの設定

  1. Flowリボンから Physicsツールをクリックします。


    Figure 11.
    Setupダイアログが開きます。
  2. Physics modelsの設定で
    1. Time marchingがSteadyに設定されていることを確認します。
    2. Turbulence modelにLaminarを選択します。
    3. Include gravitational accelerationチェックボックスを有効にし、y方向のgravityを-9.81に設定します。
    4. Heat transferチェックボックスを選択します。


    Figure 12.
  3. Solver controls設定をクリックし、Thermal flow方程式をアクティブにします。


    Figure 13.
  4. ダイアログを閉じてモデルを保存します。

材料モデルの定義

  1. Flowリボンから Material Libraryツールをクリックします。


    Figure 14.
    Material Libraryダイアログが開きます。
  2. My Materialsタブをクリックします。
  3. をクリックして新しい流体材料モデルを追加します。
  4. 材料の作成ダイアログで左上の名前をクリックし、材料の名前をAir_Boussinesqに変更します。
  5. Densityタブで、
    1. TypeをBoussinesqに設定します。
    2. Densityの値を1.225に設定します。
    3. Expansivityの値を0.00347222に設定します。
    4. Reference temperatureの値を288に設定します。


    Figure 15.
  6. Specific Heatタブをクリックし、Specific heatの値を1005に設定します。


    Figure 16.
  7. Viscosityタブをクリックし、Viscosityの値を1.781e-05に設定します。


    Figure 17.
  8. Conductivityタブをクリックし、Conductivityの値を0.02521に設定します。


    Figure 18.
  9. 材料の作成ダイアログを閉じ、Material Libraryダイアログに戻ります。
  10. SettingsメニューでSolidを選択し、My Materialsタブをクリックしてから、 をクリックし、新しいソリッド材料モデルを作成します。
  11. この材料にPlasticという名前を付け、次の値を設定します。
    各特性で、TypeはConstantにする必要があります。
    • Density:1270
    • Specific Heat:1900
    • Conductivity:0.2
  12. 材料の作成ダイアログを閉じ、Material Libraryダイアログに戻ります。
  13. 同様に、ArniteおよびLEDという名前の新しいソリッド材料モデルを、次の特性で作成します。
    各特性で、TypeはConstantにする必要があります。
    Arnite
    • Density:1670
    • Specific Heat:2050
    • Conductivity:1.6
    LED
    • Density:5500
    • Specific Heat:0.3
    • Conductivity:5.0


    Figure 19.
  14. すべてのダイアログを閉じ、モデルを保存します。

材料プロパティの割り当て

  1. Flowリボンから Materialツールをクリックします。


    Figure 20.
  2. 下の図でハイライト表示されているレンズボリュームをクリックし、MaterialドロップダウンメニューからArniteを選択します。


    Figure 21.
  3. ガイドバーをクリックすると、コマンドを実行し、ツール内に留まります。
  4. ハウジングボリュームをクリックし、Plastic材料モデルを割り当てます。


    Figure 22.
  5. ガイドバーをクリックすると、コマンドを実行し、ツール内に留まります。
  6. Materials凡例で、Airを右クリックして、Isolateを選択します。
  7. 空気ボリュームをクリックし、Air_Boussinesq材料モデルを割り当てます。


    Figure 23.
  8. ガイドバーをクリックすると、コマンドを実行し、ツール内に留まります。
  9. Materials凡例で、Airを右クリックして、Isolateを選択します。
  10. バルブボリュームをクリックし、LED材料モデルを割り当てます。


    Figure 24.
  11. ガイドバーで、をクリックしてコマンドを実行し、ツールを終了します。
  12. モデルを保存します。

熱源の定義

  1. FlowリボンからSources > Heatツールをクリックします。


    Figure 25.
  2. モデリングウィンドウで、バルブボリュームを選択します。
  3. Heat Sourceダイアログで、熱源値を2049180W/m3に設定します。


    Figure 26.
  4. ガイドバーで、をクリックしてコマンドを実行し、ツールを終了します。
  5. Escキーを押してSourcesツールを終了し、Aキーを押してすべてのソリッドの表示をオンにします。
  6. モデルを保存します。

流れ境界条件の定義

この問題では、すべてのサーフェスが壁であるため、デフォルトの壁境界条件が割り当てられます。ヘッドランプの外壁には、一定温度のすべりのない壁境界条件が与えられます。

  1. Flowリボンから No Slipツールをクリックします。


    Figure 27.
  2. モデリングウィンドウで、下の図でハイライト表示されているサーフェスを選択します。


    Figure 28.
  3. マイクロダイアログで、下の図に示されている値を入力します。


    Figure 29.
  4. Boundaries凡例でWallをダブルクリックし、これをOuterwallsという名前に変更して、Enterキーを押します。
  5. ガイドバーで、をクリックしてコマンドを実行し、ツールを終了します。
  6. モデルを保存します。

放射のセットアップ

この手順では、熱放射のセットアップに関連したパラメータを指定します。

放射モデル設定の定義

  1. RadiationリボンのThermal RadiationツールからPhysicsツールをクリックします。


    Figure 30.
    Radiation Settingsダイアログが開きます。
  2. Thermal radiationをアクティブにし、Radiation modelをDiscrete Ordinateに設定します。
  3. Radiation quadratureがS4に設定されていることを確認します。


    Figure 31.
  4. ダイアログを閉じます。

放射率モデルの定義

  1. Radiationリボンから Surface Finish Libraryツールをクリックします。


    Figure 32.
    Surface finish libraryが開きます。
    をクリックして新しい放射率モデルを追加します。
  2. エンティティ欄をダブルクリックすることにより、モデルのNameをInnerに、Emissivity値を0.05に設定します。


    Figure 33.
  3. ダイアログを閉じます。

関与媒体放射モデルの定義

  1. RadiationリボンのParticipating MediaツールからModelツールをクリックします。


    Figure 34.
    Participating media model libraryが開きます。
  2. をクリックして新しいモデルを追加します。
  3. 新しいモデルにAirという名前を付け、次の特性値を割り当てます:
    • Absorption coefficient - 0
    • Scattering coefficient - 0
    • Phase coefficient - 0
    • Refractive index - 1
  4. 同様にしてLensという名前のもう1つのモデルを作成し、次の特性値を割り当てます:
    • Absorption coefficient - 900
    • Scattering coefficient - 0
    • Phase coefficient - 0
    • Refractive index - 1.57


    Figure 35.
  5. ダイアログを閉じます。

関与媒体(Participating Media)モデルの割り当て

  1. Radiationリボンから Assignツールをクリックします。


    Figure 36.
  2. レンズボリュームをクリックし、マイクロダイアログドロップダウンからLensモデルを割り当てます。


    Figure 37.
  3. ガイドバーをクリックすると、コマンドを実行し、ツール内に留まります。
  4. Participating Media凡例で、Lensを右クリックして、Hideを選択します。
  5. 空気ボリュームを選択し、Airモデルを割り当てます。


    Figure 38.
  6. ガイドバーをクリックすると、コマンドを実行し、ツール内に留まります。
  7. Participating Media凡例で、Airを右クリックして、Hideを選択します。
  8. モデルを保存します。

表面仕上げモデルの割り当て

  1. Radiationリボンから Surface Finishツールをクリックします。


    Figure 39.
  2. ハウジングの内側サーフェス(すなわち、ハウジング-空気インターフェース)のみを選択します。


    Figure 40.

    全部で9つのサーフェスが選択されるはずです。

  3. マイクロダイアログドロップダウンからInnerモデルを割り当てます。
  4. ガイドバーで、をクリックしてコマンドを実行し、ツールを終了します。
  5. Aキーを押して、モデル内のすべてのサーフェスの表示をオンにします。

放射インターフェースの定義

レンズと空気は半透明媒体として定義されるため、この2つの間のインターフェースはinternalのタイプの鏡面インターフェースとしてモデル化されます。したがって、レンズの外側サーフェスは、外部インターフェース放射サーフェスとしてモデル化されます。

  1. Radiationリボンから Interfaceツールをクリックします。


    Figure 41.
    レンズ-空気インターフェースサーフェス以外のすべてのサーフェスが透明になることに注意してください。空気ボリュームとレンズボリュームは関与媒体として定義されているため、HyperWorks CFDは自動的に内部放射インターフェースとして定義できるサーフェスを検出し、このツールがアクティブな場合はこれらのサーフェスのみが選択可能になります。
  2. ウィンドウ選択の手法を使用して、モデルの周りにウィンドウを描きます。
    レンズ-空気インターフェースが選択されている唯一のサーフェスであることを確認します。
  3. マイクロダイアログで、Radiation diffused fractionを0に設定します。


    Figure 42.
  4. ガイドバーで、をクリックしてコマンドを実行し、ツールを終了します。
  5. External Boundaryツールをクリックします。


    Figure 43.
  6. レンズボリュームの3つの外側サーフェスを選択します。
  7. マイクロダイアログで、Radiation diffused fractionを1に、External refractive indexを1に、External temperatureを300Kに設定します。


    Figure 44.
  8. ガイドバーで、をクリックしてコマンドを実行し、ツールを終了します。
  9. モデルを保存します。

メッシュの生成

このステップでは、メッシュコントロールを指定し、メッシュを作成します。

サーフェスメッシュコントロールの定義

  1. メッシュリボンから Surfaceツールをクリックします。


    Figure 45.
  2. ウィンドウ選択の手法を使用して、モデル内のすべてのサーフェスを選択します。
  3. マイクロダイアログで、Average element sizeを0.002に設定します。


    Figure 46.
  4. ガイドバーをクリックすると、コマンドを実行し、ツール内に留まります。
  5. 下の図でハイライト表示されているサーフェスを選択し、Hキーを押すか、右クリックしてコンテキストメニューからHideを選択することにより、このサーフェスを非表示にします。


    Figure 47.
  6. 下の図でハイライト表示されている3つのサーフェスを選択します。
  7. マイクロダイアログで、Average element sizeを0.001に、Mesh growth rateを1に設定します。


    Figure 48.
  8. ガイドバーで、をクリックしてコマンドを実行し、ツールを終了します。

境界層コントロールの定義

  1. メッシュリボンから Boundary Layerツールをクリックします。


    Figure 49.
  2. モデリングウィンドウを右クリックし、 Select > Advanced Select > By Material > Air_Boussinesqの順に選択します。
    すべての流体壁サーフェスを選択する必要があり、BL指定用のマイクロダイアログが表示されます。
  3. マイクロダイアログに次の値を入力します:
    • First layer thickness definition: Constant
    • First layer thickness:0.0005
    • Total number of layers:4
    • Growth method: Constant
    • Growth rate:1.3
    • Termination policy: Truncate
    • Enable surface mesh modificationオプションをアクティブにします。


    Figure 50.
  4. ガイドバーで、をクリックしてコマンドを実行し、ツールを終了します。
  5. すべてのサーフェスの表示をオンにします。

ボリュームメッシュコントロールの定義

ハウジングおよびレンズのソリッドは厚みが小さいため、ボリュームメッシュが生成されたときにこれらのソリッドの厚み方向に2つの層ができるように、薄層メッシングツールを使用します。

  1. メッシュリボンから Volume Meshツールをクリックします。


    Figure 51.
  2. ハウジングとレンズのソリッドを選択します。
  3. マイクロダイアログで、
    1. Average sizeを0.001に設定します。
    2. Growth rateを1.0に設定します。
    3. Thin layer meshingオプションをアクティブにして、Number of layersを2に設定します。


    Figure 52.
  4. ガイドバーで、をクリックしてコマンドを実行し、ツールを終了します。

メッシュの生成

  1. メッシュリボンから Volumeツールをクリックします。


    Figure 53.
    Meshing Operations ダイアログが開きます。
  2. Mesh growth rateを1に設定します。
  3. Meshをクリックします。
    Run Statusダイアログが開きます。解析が実行すると、ステータスが更新され、ダイアログが閉じます。
    Tip: メッシュジョブを右クリックし、View log fileを選択してメッシングプロセスの概要を表示します。
  4. モデルを保存します。

AcuSolveの実行

  1. Solutionリボンから Runツールをクリックします。


    Figure 54.
    Launch AcuSolveダイアログが開きます。
  2. Parallel processingオプションをIntel MPIに設定します。
  3. Optional: プロセッサーの数を、環境に応じて4または8に設定します。
  4. Default initial conditionsメニューを拡張表示し、Pre-compute flowオプションを無効にします。
  5. x-velocityを0に設定し、Temperatureを300に設定します。
  6. 他のオプションはデフォルト設定のままにし、RunをクリックしてAcuSolveを起動します。


    Figure 55.
    Run Statusダイアログが開きます。解析が実行すると、ステータスが更新され、ダイアログが閉じます。
    Tip: AcuSolve実行中、Run StatusダイアログでAcuSolveジョブを右クリックし、View Log Fileを選択することで、解析プロセスの状況を確認できます。

HW-CFD Postによる結果のポスト処理

  1. 解析の完了後、Postリボンに移動します。
  2. メニューバーFile > Open > Resultsをクリックします。
  3. 作業ディレクトリでAcuSolveログファイルを選択し、ポスト処理の結果を読み込みます。
    ソリッドとすべてのサーフェスがPostブラウザに読み込まれます。
  4. Slice Planesツールをクリックします。


    Figure 56.
  5. X軸に垂直な面を選択します(下図参照)。


    Figure 57.
  6. View Cube上のFrontフェイスをクリックし、モデルを揃えます。
    Figure 58.
  7. Slice plane マイクロダイアログをクリックします。
  8. 表示プロパティマイクロダイアログで、表示をtemperatureに設定します。
  9. Legendのトグルスイッチをアクティブにし、をクリックして範囲をリセットします。
  10. をクリックして、Legend locationをUpper Right Corner、Colormap NameをRainbow Uniformに設定します。


    Figure 59.
  11. ガイドバーをクリックします。
  12. Postブラウザで、Boundary Collectionsを非表示にします。


    Figure 60.


    Figure 61.
  13. ブラウザでSlice Plane 1を右クリックし、Editを選択します。
  14. 表示をincident radiationに変更します。
  15. をクリックして凡例の範囲を更新します。
  16. ガイドバーをクリックします。


    Figure 62.

要約

このチュートリアルでは、HyperWorks CFD内のDiscrete Ordinate輻射モデルにより、ヘッドランプ内の輻射伝熱問題を設定および解析する方法を学習しました。まず、形状をインポートしてクリーンアップし、流れ、熱、および放射の境界条件を設定しました。解が計算されたら、Postリボンを使用して結果を処理し、温度と入射放射のコンタープロットを作成しました。