ACU-T:7010 HyperStudyを使用した形状の最適化

前提条件

このチュートリアルを開始する前に、HyperWorks 入門チュートリアルである ACU-T:1000 HyperWorksユーザーインターフェースをすでに完了しHyperMeshAcuSolve、およびHyperViewの基本を理解しているものとします。このシミュレーションを実行するには、ライセンス供与済みバージョンのHyperMeshおよびAcuSolveにアクセスできる必要があります。

このチュートリアルを実行する前に、ここをクリックしてチュートリアルモデルをダウンロードしてください。 ACU-T7010_HyperStudy.hm をHyperMesh_tutorial_inputs.zipから抽出します。

HyperMeshデータベース(.hmファイル)には、メッシュ済みのジオメトリが含まれているため、このチュートリアルには、ジオメトリのインポートとメッシュ生成に関する手順は含まれません。

問題の説明

この問題の形状は、ベース形状として真円の断面を持つ単純な管流路で構成されています。入口から水が0.0003kg/sの流量で流入します。出口は、相対圧力がゼロの標準圧力出口です。流路の壁はすべりのない壁です。

目的は、管形状の変化の影響によって入口と出口の間に圧力低下を発生させることです。ベースラインのシミュレーションの実行後、入口と出口の間の圧力低下に対する管形状の変化の影響を分析するために、DOEスタディが実行されます。これは、HyperMeshHyperStudyによってAcuSolveを使用して実行できる多くのタイプのスタディの中のほんの1つを示すものです。


Figure 1.

HyperMeshモデルデータベースを開く

  1. HyperMesh Desktopを起動し、AcuSolveのユーザープロファイルを読み込みます。
    User ProfilesからAcuSolveを選択する方法については、HyperMeshの入門チュートリアルACU-T:1000 HyperWorksユーザーインターフェースをご参照ください。
  2. 標準ツールバーのOpen Modelアイコン をクリックします。
    Open Modelダイアログが開きます。
  3. モデルファイルの保存先ディレクトリを参照します。HyperMeshファイルACU-T7010_HyperStudy.hmを選択してOpenをクリックします。
  4. File > Save Asをクリックします。
    Save Model Asダイアログが開きます。
  5. 名前をPipe_HyperStudyとして新しいディレクトリを作成し、このディレクトリへ移動します。
    このディレクトリが作業ディレクトリになり、シミュレーションに関連するすべてのファイルがこの場所に保存されます。
  6. データベースのファイル名としてPipe_HyperStudyと入力するか、都合のいい名前を選択して入力します。
  7. 保存をクリックしてデータベースを作成します。

境界条件の指定

このシミュレーションでは、標準のシミュレーションパラメータとソルバーの設定を使用します。

デフォルトでは、すべてのコンポーネントは壁境界条件に割り当てられます。この手順では、それを適切な境界条件に変更し、流体ボリュームに材料特性を割り当てます。

  1. Solverブラウザで、12.Surfaces > WALLを展開します。
  2. Fluidをクリックします。エンティティエディターで以下を設定します。
    1. TypeをFLUIDに変更します。
    2. MaterialをAir_HMに設定します。


    Figure 2.
  3. Inflowをクリックします。エンティティエディターで以下を設定します。
    1. TypeをINFLOWに変更します。
    2. Inflow typeをMass fluxに変更します。
    3. Mass fluxの値を0.0003kg/secに設定します。


    Figure 3.
  4. Outflowをクリックします。エンティティエディターで、TypeをOUTLFOWに変更し、他のオプションはすべてデフォルトのままとします。


    Figure 4.
  5. Wallをクリックします。エンティティエディターで、TypeがWALLに設定されていることを確認します。


    Figure 5.
  6. モデルを保存します。

最適化パラメータの設定

モーフ形状の作成とエクスポート

  1. パネル領域で、HyperMorphをクリックし、morph volumesを選択します。
  2. createサブパネルでelemsコレクターをクリックし、allを選択します。
  3. createをクリックします。
    新しいモーフボリュームが作成されます。


    Figure 6.
  4. split/combineサブパネルに移動します。パネル領域で、オプションを# of splitsに切り替えて3に設定します。


    Figure 7.
  5. グラフィックス領域で、下の図に示すようにエッジを選択します。


    Figure 8.
  6. パネル領域splitをクリックします。
    モーフボリュームが小さいボリュームに分割されます。


    Figure 9.
  7. パネル領域で、update edgesサブパネルに移動します。1つ目の矢印をクリックし、update endsを選択します。次に2つ目の矢印をクリックし、by mvolsを選択します。最後に、3つ目の矢印をクリックし、main-secondaryオプションを選択します。


    Figure 10.
  8. main morphvolmesコレクターをアクティブにして、以下の図に示す外側の2つのモーフボリュームを選択します。続いて、secondary morphvolumesコレクターをアクティブにして、内側の2つのモーフボリュームを選択します。


    Figure 11.
  9. 上記の順序で各ボリュームを選択した後、updateをクリックします。
    ボリュームのエッジが、以下の図のように表示されます。


    Figure 12.
  10. return をクリックしてHyperMorphパネルに移動します。パネル領域morphを選択してから、move handlesサブパネルを選択します。このパネルで、
    1. 2つ目の矢印をクリックし、interactiveからtranslateに変更します。
    2. その下で、矢印をクリックしてalong vectorを選択します。
    3. その下で、方向セレクターをy-axisに設定します。
    4. dist=欄に0.01と入力します。


    Figure 13.
  11. handlesコレクターをアクティブにして、下の図に示すように4つの中間ハンドルを選択します。


    Figure 14.
  12. パネル領域morphをクリックします。
    グリッドがモーフィングされます。


    Figure 15.
  13. save shapeサブパネルに移動します。このパネルで、
    1. name欄をshape_1に設定します。
    2. 2行目でセレクターをas node perturbationsに設定します。
    3. saveをクリックします。
    4. “Save perturbations for nodes at global and morph volume handles?”という質問にYesを選択します。
    Modelブラウザに、Shapesという名前の新しいフォルダーが作成されます。shape_1を右クリックして該当するオプションを選択することで、保存された形状を表示または非表示にできます。
  14. undo allをクリックし、さらにreturnをクリックして、パネルを終了します。
  15. Utility Menuに移動します。
    utility menuが表示されない場合は、メニューバーのViewをクリックし、ドロップダウンからBrowsers > HyperMesh > Utilityの順に選択します。
  16. utility menuで、Dispをクリックし、さらにClear Temp Nodesをクリックして、モデル内のすべてのテンポラリー節点を削除します。

設計変数の定義

  1. メニューバーのDesign Studyをクリックし、ドロップダウンからDefine DVを選択します。
  2. パネル領域desvarサブパネルで、desvar=欄に名前としてbendと入力します。
  3. shape=欄をクリックし、shape_1を選択します。
  4. createをクリックして、'bend'という名前の設計変数を作成します。


    Figure 16.
  5. return をクリックしてパネルを終了します。
  6. モデルを保存します。

HyperStudyを使用したDOEスタディの起動

ベースランの開始

  1. CFDツールバーの をクリックします。
    HyperStudy Job Launcherダイアログ。
  2. Optional: 解析時間を短縮するには、使用可能なプロセッサの数に応じて、使用するプロセッサの数に大きい値(4または8)を設定します。
  3. SolverがAcuSolveに設定されていることを確認します。
  4. Define Responsesテーブルで以下を選択して、形状の変更によって流入で発生する圧力の変化を確認します。
    1. ResponsesをPressureに設定します。
    2. ComponentsをInflowに設定します。
  5. Launch HyperStudy without nominal runおよびExport optionsチェックボックスが両方ともオフであることを確認します。
  6. Launchをクリックします。


    Figure 17.
  7. 表示されるプロンプトでYesをクリックします。
ベースランが開始され、AcuTailウィンドウとAcuProbeウィンドウが自動的に開きます。ベースランが完了すると、HyperStudyウィンドウが開きます。

HyperStudyウィンドウで、Explorerメニューで各設定をクリックして1つずつ確認し、すべて適切に定義されていることを確認します。

DOEスタディの実行

  1. ExplorerウィンドウでStudy 1を右クリックしてAddを選択します。


    Figure 18.
  2. Add – Altair HyperStudyダイアログで、DOEを選択し、OKをクリックします。
    DOE 1 という名前のスタディが新規に作成されます。
  3. Explorerで、DOE 1の下のSpecificationsをクリックします。
  4. 作業領域で、Show more…を展開して、ModeをFull Factorialに設定します。


    Figure 19.
  5. Levelsタブをクリックし、レベル数を5に設定してApplyをクリックします。


    Figure 20.
  6. Explorerで、DOE 1の下のEvaluateをクリックします。
    スタディを実行するために使用されるテーブルが表示され、行われるすべての実行(1~5)が表示されます。


    Figure 21.
  7. 作業領域の下部にあるEvaluate Tasksをクリックします。
    実行が進行するにつれて、作業領域のテーブル内で各実行のステータスが更新されます。
  8. すべての実行が完了したら、Evaluation Dataタブをクリックします。
    テーブルには、設計変数用に使用される値のリストと、対応する応答変数(流入圧力)の値が表示されます。


    Figure 22.
  9. 上記のテーブルをプロットとして表示するには、Evaluation Plotタブをクリックします。
  10. チャネルセレクターで選択して、応答変数(流入圧力)の値をプロットします。


    Figure 23.

    ラベルをbendに切り替えることで、設計変数のリストをプロットすることもできます。

HyperViewによる結果のポスト処理

HyperViewインターフェースへの切り替えとAcuSolveモデルと結果の読み込み

  1. HyperMesh Desktopウィンドウで、グラフィックスウィンドウの左下隅のClientSelectorドロップダウンをクリックします。


    Figure 24.
  2. リストからHyperViewを選択します。
  3. 表示されたポップアップダイアログで、Yesをクリックします。
    インターフェースがHyperViewに変更されます。

    HyperViewを読み込むと、デフォルトでLoad model and resultsパネルが開きます。このパネルが表示されない場合は、File > Open > Modelの順にクリックします。

  4. Load model and resultsパネルで、Load modelの隣にある をクリックします。
  5. Load Model Fileダイアログで作業ディレクトリに移動し、さらに…\approaches\doe_1\run_00001\m_1\というディレクトリに移動します。Pipe_HyperStudy.1.Logファイルを選択します。
  6. Openをクリックします。
  7. パネル領域Applyをクリックして、DOEスタディの初回実行のモデルと結果を読み込みます。
    読み込むと、モデルが形状で色分けされます。

断面上での圧力コンターの作成

この手順では、z軸上の断面上の圧力のコンタープロットを作成します。
  1. ResultsツールバーでをクリックしてContourパネルを開きます。
  2. パネル領域で、Result typeをPressure (s)に変更します。
  3. Applyをクリックして、圧力コンタープロットを作成します。
  4. HV-DisplayツールバーのSection cut アイコンをクリックします。
  5. パネル領域で、Addをクリックして、Section 1という名前の新しい切断面を作成します。
  6. Define planeセクションで、軸をZ Axisに設定し、Applyをクリックします。
  7. BaseのZ座標を0に設定し、Enterを押します。
  8. Gridlineをクリックします。Gridline Optionsダイアログで、Grid lineの下のShowチェックボックスを非アクティブにして、OKをクリックします。


    Figure 25.
  9. Standard Viewsツールバーの をクリックすることで、xy平面を正面から見た表示にします。


    Figure 26. Run 1
  10. 上の手順を繰り返して、それぞれのログファイルを使用して個々の実行ごとの圧力のコンタープロットを作成します。


    Figure 27. Run 2


    Figure 28. Run 3


    Figure 29. Run 4


    Figure 30. Run 5

要約

このチュートリアルでは、Altair製品(HyperMeshAcuSolveHyperStudyHyperView)を使用してDOEスタディを実行する方法を紹介しました。最初にHyperMeshデータベースをインポートして、AcuSolveのシミュレーションパラメータを設定し、HyperMorphを使用してモーフ形状を作成しました。次に設計変数を設定して、モーフ形状をそこにリンクさせました。それからDOEスタディの設定に進みました。結果を取得した後、HyperViewを使用してこれらの結果を処理しました。