ACU-T:1000 HyperWorks CFDユーザーインターフェース

このチュートリアルでは、Altair HyperWorks CFDを使用した数値流体力学(CFD)シミュレーションの設定手順を説明します。HyperWorks CFDは、CADインポートから結果のポスト処理まで、CFD 解析を行うためのツールです。このチュートリアルでは、CFD解析の設定にHyperWorks CFDを使用する方法を学びながら、ジオメトリモデルのインポート、ジオメトリの検証、解析パラメータと境界条件の設定、メッシュの生成など、ソフトウェア内のさまざまな機能を確認します。その後、HyperWorks CFDから直接AcuSolveを起動して解析を実行し、HyperWorks CFD Post を使って結果をポスト処理します。

前提条件

このシミュレーションを実行するには、ライセンス供与済みバージョンのHyperWorks CFDおよびAcuSolveにアクセスできる必要があります。

このチュートリアルを実行する前に、ここをクリックしてチュートリアルモデルをダウンロードしてください。 ACU-T1000_manifold.x_t をHyperWorksCFD_tutorial_inputs.zipから抽出します。

問題の解析

CFDシミュレーションにおける重要なステップは、目前の工学的問題を調べ、AcuSolveに対して指定する必要のある重要なパラメータを決定することです。パラメータは、形状要素(入口、出口、壁など)に基づいて行うことができるとともに、流れの条件(流体プロパティ、速度、流れを乱流または層流のどちらでモデル化するのかなど)に基づいて行うことができます。

ここでシミュレートするシステムは、エンジン内のインレットマニホールドに似た、マニホールドパイプです。インレットマニホールドは、入ってきた流れを複数の出力に分散します。下の図のように、パイプには1つの入口と複数の出口が付いているため、流れが各出口に分散されます。エンジン内で使用されるインレットマニホールドで理想的なのは、流れがすべての出口でほぼ均等に分散されることが保証されたマニホールド設計です。ただし、ここで使用する形状は、単なるデモンストレーションケースであり、最適化されたマニホールド形状ではありません。


Figure 1. 問題の概略図

HyperWorks CFDの概要



Figure 2.
HyperWorks CFDグラフィカルユーザーインターフェースに表示されるツールおよびエンティティは、上図のように6つのなカテゴリに分けられます。
  1. メニューバー
  2. リボン
  3. モデリングウィンドウ
  4. エンティティセレクター
  5. ビューコントロールツールバー
  6. ブラウザ
  1. メニューバー(1)には、File入出力、Edit、およびViewの各操作のためのドロップダウンメニューが含まれます。
  2. リボン(2)には、HW-CFDで使用可能なさまざまな機能やツールが含まれます。メニューバーの右にある各種リボンタブをクリックすることで、さまざまなリボン間を移動できます。リボンを選択すると、対応するツールアイコンが画面上に表示されます。さまざまなリボンの機能と対応するツールの概略をこのセクションで説明します。
    Geometryリボン
    Geometryリボンには、形状の変更、修正、作成、編集および検証のためのツールが含まれています。FE Geometryサブセクションの下で利用可能なツールは、形状モデルのFEモデルへの変換、開口部の自動キャップ、局所的または近接するラッピングの制御の定義、モデルのラップ、ラップされた結果のリメッシュ、およびメッシュ品質の修正に使用できます。


    Figure 3.
    形状ファイルがインポートされたら、Repairツールを使用して、交差、フリーエッジ、重複、細長いサーフェスなど、CADモデルに存在する欠陥を検出し、このようなエラーを修正できます。


    Figure 4.
    Createサブセクションの下で利用可能なツールは、ポイント、ライン、サーフェスなど、形状エンティティの作成に使用できます。


    Figure 5.
    空洞を埋めたり、サーフェスをステッチするなどの操作を実行するために必要なツールは、Editサブセクションの下にあります。


    Figure 6.
    ValidateツールはCADモデルの内エラーの検出に使用でき、Defeatureツールはこのようなエラーの修正や新しい形状のモデル化に使用できます。このプロセスは通常CADクリーンアップとして知られています。


    Figure 7.
    Flowリボン
    Flowリボンには、シミュレーションパラメータ、ソルバー設定、および材料特性や熱源、多孔質媒体などの特性を設定するツールが含まれます。Setupサブセクションでは、物理方程式やソルバー設定のセットアップのほか、材料特性、Multiplier Function、およびパラメータの作成が可能です。


    Figure 8.
    Domainサブセクションには、材料、熱源や運動量ソース、座標系などの基準特性をボリュームに割り当てるツールが含まれます。


    Figure 9.
    入口、出口、遠方場などのサーフェス境界条件は、Boundariesサブセクションの下にあるツールを使用して割り当てることができます。デフォルトでは、すべてのサーフェスに‘auto_wall’のタイプの境界条件が割り当てられ、これらはDefault Wallに配置されます。auto_wallの詳細については、AcuSolve Surface Processingマニュアルをご参照ください。境界条件をサーフェスに割り当てると、それらのサーフェスはそれぞれのグループに移動されます。


    Figure 10.
    Radiationリボン
    Radiationリボンでは、放射物理の定義、熱、太陽、関与媒体(participating media)モデルの作成、および放射パラメータの適用が可能です。


    Figure 11.
    Motionリボン
    メッシュの境界条件およびメッシュモーション関連パラメータは、Motionリボン内にあるツールを使用して定義できます。メッシュモーションタイプやメッシュ変位の制約などのパラメータは、ここで定義できます。メッシュ境界条件に加えて、OptiStructMotionSolveのような外部コードとのコード結合は、ここで定義することができます。


    Figure 12.
    Meshリボン
    サーフェスメッシュコントロール、境界層パラメータ、ボリュームメッシュパラメータ、ゾーンメッシュパラメータなどのメッシュパラメータは、ここで定義できます。このリボンには、局所的な再メッシュのためのツールもあります。すべてのメッシュコントロールを定義したら、Volumeツールを使用してメッシュを生成できます。


    Figure 13.
    Solutionリボン
    Solutionリボンは、個々のポイント、サーフェス、またはボリュームのセット出力のモニターを設定するために使用します。Fieldツールは、モデル全体の節点出力頻度の設定に使用します。Initializeツールは、圧力、速度などの変数、および各乱流モデルに固有の変数の節点初期状態の設定に使用します。


    Figure 14.

    設定が完了したら、Runツールを使用してAcuSolveを起動します。AcuSolve実行パラメータが設定されるとシミュレーションを開始でき、Run Managerを使用して実行のステータスをモニターできます。

    Postリボン
    Postリボンは、結果をポスト処理するのに使用します。Postリボンの下にあるVisualizeツールは、コンタープロット、ベクトルプロット、流線、アイソサーフェス、断面表示に使用します。Measuresツールは、必要な場所で変数をプローブするために使用することができます。


    Figure 15.
  3. モデリングウィンドウ(3)は、モデルの表示場所です。モデルの表示は、下の表に示されたビューコントロールを使用して操作できます。モデルをクリックすると、選択されているエンティティがハイライト表示され、エンティティを右クリックすると、そのコンテキストに基づいて実行できる操作の追加オプションが表示されます。右クリックで利用できる機能には、Show、Hide、Isolate、Select、詳細選択、グループ作成などがあります。
    ボタン 操作
    マウスの中央スクロール ズームイン / アウト
    右クリックしたままドラッグ モデルの移動
    マウスの中央ボタンをクリックしたままドラッグ モデルの回転
    左クリック エンティティの選択
    Ctrl + 左クリック 複数のエンティティの選択
    左クリックしたままドラッグ ウィンドウ選択
    Shift + 左クリック エンティティの選択解除
  4. エンティティセレクター(4)では、左マウスボタンを使用して、選択できるエンティティを制御できます。下の図に示す任意のエンティティにセレクターを設定できます。ツールを開くと、そのコマンドに適したエンティティ(複数可)にセレクターが自動的に設定されます。


    Figure 16.
  5. モデルの表示は、ビューコントロールツールバー(5)で提供されるツールを使用して制御できます。メッシュの表示、モデルの表示モード(トポロジ、パート、アセンブリなど)、断面、標準ビューなどの表示を制御できます。


    Figure 17.
  6. ブラウザ (6)は、モデル内のエンティティと設定パラメーターを表示し、ツリー構造で一覧表示します。これらは表示メニューからオンまたはオフにすることができます。すべてのブラウザで実行できる共通の機能には、Show、Hide、Isolateがあります。Partブラウザブラウザは、モデルのパート、サーフェスボディ、ソリッドボディを管理するのに使用します。Setupブラウザブラウザは、境界条件、ドメイン、メッシュコントロールなどのモデル設定パラメーターのインスタンスを作成および編集するのに使用します。Postリボンでの作業時には、PartブラウザSetupブラウザは利用できません。Postブラウザを使用して、様々なポスト処理後のビジュアライゼーションの表示や編集を制御することができます。Postブラウザブラウザは、Postリボンで作業する場合のみ利用可能です。

HyperWorks CFDの起動とHyperMeshモデルデータベースの作成

  1. WindowsのスタートメニューからStart > Altair <version> > HyperWorks CFDをクリックしてHyperWorks CFDを起動します。
    HyperWorks CFDが読み込まれると、Geometryリボンが表示されます(デフォルト)。
  2. 以下の方法のいずれかで新規.hmデータベースを作成します。
    • メニューバーFile > Saveをクリックします。


      Figure 18.
    • HomeツールのFilesツールグループからSave Asツールをクリックします。


      Figure 19.
  3. Save File Asダイアログで、データベースを保存したいディレクトリを指定します。
    このディレクトリが解析用ディレクトリになり、シミュレーションに関連するすべてのファイルがこの場所に保存されます。
  4. データベースの名前(例:Manifold)を入力し、Saveをクリックします。

形状のインポート検証

形状のインポート

この手順を開始する前に、入力ファイルACU-T1000_manifold.x_tをディレクトリにコピーします。
  1. メニューバーFile > Import > Geometry Modelをクリックします。
  2. Import Fileダイアログで、作業ディレクトリに移動し、ACU-T1000_manifold.x_tを選択してOpenをクリックします。
  3. Geometry Import Optionsダイアログで、すべてのオプションをデフォルト設定にしたままImportをクリックします。


    Figure 20.
  4. 形状が読み込まれたら、モデルのフィーチャーを回転して確認します。
    モデリングウィンドウ内のモデルの表示は、次のビューコントロールを使用して制御できます。
    ボタン ビューコントロール
    マウスの中央スクロール ズームイン / アウト
    右クリックしたままドラッグ モデルの移動
    マウスの中央ボタンをクリックしたままドラッグ モデルの回転


    Figure 21.

形状の検証

  1. ジオメトリリボンから Validateツールをクリックします。


    Figure 22.
    Validateツールは、モデル全体をスキャンし、サーフェスおよびソリッド上でチェックを実行して、形状に不具合(フリーエッジ、閉じたシェル、交差、重複、スライバーなど)があればフラグ付けします。

    現在のモデルには、上記のような問題は存在しません。問題が見つかった場合は、ツール名の横の括弧内の数で示されます。

    Validateアイコンの左上に青色のチェックマークが表示されているのがわかります。これは、このツールでは形状モデルの問題は検出されなかったことを示しています。


    Figure 23.
  2. Escを押すか、モデリングウィンドウ内を右クリックして緑のチェックマーク上を右から左にスワイプします。
  3. データベースを保存します。

問題の設定

この手順では、方程式、ソルバー設定など、一般的なシミュレーションパラメータを設定します。その後、サーフェスの境界条件と材料物性を流体領域に割り当てます。

シミュレーションパラメーターとソルバーの設定

  1. Flowリボンから Physicsツールをクリックします。


    Figure 24.
    Setupダイアログが開きます。
  2. Physics modelsの設定で
    1. Single phase flowでIncompressibleオプションが選択されているのを確認します。
    2. Time frequencyをSteadyに設定します。
    3. Turbulence modelとしてSpalart-Allmarasを選択します。
      Spalart Allmaras乱流モデルはそのロバスト性と精度から、定常状態の流れのシミュレーションに非常に適しています。


    Figure 25.
  3. Solver controls設定をクリックし、下の図のようにパラメータが設定されていることを確認します。


    Figure 26.
  4. ダイアログを閉じてモデルを保存します。

材料プロパティの割り当て

  1. Flowリボンから Materialツールをクリックします。


    Figure 27.
  2. モデリングウィンドウから、マニホールド上の任意の位置をクリックします。
    マニホールド形状全体がハイライト表示され、Material マイクロダイアログが表示されます。


    Figure 28.
  3. ドロップダウンメニューをクリックし、材料リストからWaterを選択します。
  4. ガイドバーをクリックしてコマンドを実行します。
    ツール内での変更は、アイコンをクリックしてその変更が実行されるまでは有効になりません。
    コマンドが実行されると、形状の色が変わり、ボリュームに割り当てられた材料を示します。この場合、形状内のボリュームは1つのみであるため1色のみです。異なる材料が割り当てられた複数のボリュームがある場合は、材料ごとに個別の色が割り当てられ、適宜モデルが表示されます。


    Figure 29.
  5. ガイドバー をクリックしてツールを終了します。

流れ境界条件の割り当て

現在のモデルには、入口1つと出口3つがあり、残りのサーフェスが壁となっています。形状モデルがHyperWorks CFDにインポートされると、すべてのサーフェスがDefault Wall(Type = auto_wall)に配置されます。サーフェスの境界条件の割り当てを開始すると、これらのサーフェスが新しい境界条件グループに移動されます。すべてのサーフェス境界条件ツールが、FlowリボンのBoundariesサブセクションの下に配置されます。

  1. FlowリボンのProfiledツールグループから、Profiled Inletツールをクリックします。


    Figure 30.
  2. モデリングウィンドウで入口のサーフェスをクリックします。


    Figure 31.
    “Inlet”という新しいグループが、モデリングウィンドウの左上にあるBoundariesリストの下に作成されているのがわかります。現在のコマンドを実行すると、ハイライト表示されたサーフェスがInletグループに移動します。
  3. マイクロダイアログ、Average velocityに2.0m/secの値を入力します。


    Figure 32.
  4. ガイドバーをクリックしてコマンドを実行します。
    モデリングウィンドウの入口サーフェスの色が更新されます。
    Note: サーフェスに割り当てられる色はランダムです。したがって、下の図に示されたサーフェスの色は、ご自身の画面の色とは異なる可能性があります。


    Figure 33.
  5. Outletツールをクリックします。


    Figure 34.
  6. 下の図に示されている3つの出力サーフェスをクリックします。


    Figure 35.
  7. ダイアログ内のデフォルトのオプションはそのままにして、ガイドバーをクリックし、コマンドを実行します。
    出力サーフェスの色が変わり、左側の境界のリストが更新されます。各グループの下のサーフェスの数は、括弧内に表示されます。


    Figure 36.
    Note:
    • グループの色を更新するには、グループ名の左にある色の付いた四角形をクリックし、パレットから色を選択します。
    • グループの名前を更新するには、グループ名を右クリックし、コンテキストメニューからRenameを選択します。
  8. ガイドバー をクリックしてツールを終了します。
  9. モデルを保存します。

メッシュコントロールの設定

材料特性と境界条件を割り当てたので、次はモデルのメッシュパラメータを定義してメッシュを生成します。

サーフェスメッシュコントロールの定義

  1. メッシュリボンから Surfaceツールをクリックします。


    Figure 37.
  2. モデリングウィンドウを右クリックし、 Select > Allの順に選択します。


    Figure 38.
    モデル内のすべてのサーフェスがハイライト表示され、サーフェスメッシュパラメータのダイアログが開きます。
  3. Average element sizeに0.003と入力します。


    Figure 39.
  4. 残りのパラメータのデフォルト設定はそのままにして、ガイドバーをクリックし、コマンドを実行します。

境界層メッシュパラメータの定義

  1. メッシュリボンから Boundary Layerツールをクリックします。


    Figure 40.
  2. モデリングウィンドウを右クリックし、 Select > Advanced Select > By Boundaries > Default Wallの順に選択します。


    Figure 41.
    すべての壁サーフェスがハイライト表示され、境界層パラメータのダイアログが開きます。
  3. 下の図に示すように、ダイアログ内に値を入力します。


    Figure 42.
  4. ガイドバーをクリックしてコマンドを実行します。

メッシュの生成

  1. メッシュリボンから Volumeツールをクリックします。


    Figure 43.
  2. Meshing Operationsダイアログで、Average element sizeに0.005と入力します。


    Figure 44.
  3. Meshをクリックします。
    メッシングプロセスが開始されると、Run Statusダイアログが表示されます。メッシングプロセスのステータスを確認するには、プロセス行を右クリックしてView log fileを選択します。
    メッシュが完了するとそれに応じて実行ステータスが更新され、自動的にSolutionリボンに移動します。


    Figure 45.

AcuSolveの実行

  1. Solutionリボンから Runツールをクリックします。


    Figure 46.
  2. Launch AcuSolveダイアログで、ディレクトリとAcuRunパスが正しい場所を指していることを確認します。
  3. Parallel processingオプションをIntel MPIに設定します。
  4. Optional: プロセッサーの数を、環境に応じて4または8に設定します。
  5. Automatically define pressure referenceオプションを無効にします。
  6. Default initial conditionsメニューを拡張表示します。
  7. Pre-compute flowオプションを無効にし、x-velocityに2.0と入力します。
  8. Pre-compute turbulence流れオプションを無効にし、Eddy viscosityに1e-5と入力します。
  9. 他のオプションはデフォルト設定のままにし、RunをクリックしてAcuSolveを起動します。


    Figure 47.
    Run Statusダイアログが再度開き、AcuSolveの実行がリストに表示されます。
  10. AcuSolve実行を右クリックし、View log fileを選択します。

    ダイアログに出力される実行のサマリーには、AcuSolveがシミュレーションの実行を完了したことが示されます。解が収束すると、それに応じてステータスが更新されます。



    Figure 48.
  11. Run StatusダイアログでAcuSolveを右クリックし、コンテキストメニューからPlot time historyを選択します。
  12. Plot UtilityダイアログでResidual Ratio行をダブルクリックし、残存率のプロットを開きます。


    Figure 49.

    上のプロットは、時間ステップごとの解析の進行に伴う方程式の残差を示しています。残差が徐々に減少していることがわかります。圧力と速度の残存率が指定の収束許容値(0.001)を下回る値に達すると、解析は収束したと見なされます。デフォルトでは、渦粘性の収束許容値は、指定の収束許容値より1桁大きい値に設定されています(0.01)。

HyperWorks CFD Postによる結果のポスト処理

チュートリアルのこの部分では、HyperWorks CFD Postを使用した定常解析の操作方法を示します。

結果の読み込み

  1. 解析の完了後、Postリボンに移動します。
  2. メニューバーFile > Open > Resultsをクリックします。
  3. 作業ディレクトリを参照します。ファイルManifold.1.Logを選択してOpenをクリックします。
    ソリッドとすべてのサーフェスがPostブラウザに読み込まれます。

境界サーフェスでの圧力コンターの作成

  1. Boundary Groupsツールをクリックします。


    Figure 50.
  2. マウスの左ボタンを押しながらドラッグし、マニホールド全体を囲む長方形を描画することで、モデル内のすべてのサーフェスを選択します。


    Figure 51.
  3. マイクロダイアログで、表示変数をpressureに設定します。
  4. Legendのトグルスイッチをアクティブにし、をクリックして範囲をリセットします。
  5. をクリックして、Colormap NameをRainbow Uniformに設定します。


    Figure 52.
  6. ガイドバーをクリックしてします。


    Figure 53.
  7. PostブラウザBoundary Group 4を右クリックしてRenameを選択します。これにPressure_plotという名前を付けます。

切断面での速度と圧力のコンターのプロット

  1. Postブラウザで、流れ境界の横のアイコンをクリックすることで、Flow Boundariesの表示をオフにします。


    Figure 54.
  2. Slice Planesツールをクリックします。


    Figure 55.
  3. モデリングウィンドウで、x-z平面を選択します。


    Figure 56.
  4. マイクロダイアログで、をクリックして、Vectorツールで平面を調整します。
  5. Vectorツールのダイアログで、をクリックして平面の中心座標を定義します。Yの値を-0.015に設定し、Enterキーを押します。


    Figure 57.
  6. Escキーを2回押します。
  7. スライス平面のマイクロダイアログで、をクリックしてスライス平面を作成します。
  8. 表示プロパティマイクロダイアログで、表示変数をpressureに設定します。
  9. Legendのトグルスイッチをアクティブにし、をクリックして範囲をリセットします。
  10. をクリックして、Colormap NameをRainbow Uniformに設定します。


    Figure 58.
  11. ガイドバーをクリックしてします。


    Figure 59.
  12. PostブラウザSlice Plane 1を右クリックしてEditを選択します。
  13. マイクロダイアログで、表示変数をvelocityに変更し、ガイドバーをクリックします。


    Figure 60.

要約

このチュートリアルでは、HyperWorks CFDを使用してCFDシミュレーションを実行し、その結果をポスト処理するための基本的なワークフローを体験しました。まず、HyperWorks CFDで形状をインポートし、モデルをメッシュ処理しました。また、モデルを設定して、HyperWorks CFD内から直接AcuSolveを起動しました。AcuSolveによる解析が完了した後、Postリボンで結果をポスト処理しました。境界サーフェスと切断面でコンターを作成する方法を学習しました。