ACU-T:1000 HyperWorksユーザーインターフェース

このチュートリアルでは、HyperWorksのパッケージを利用した数値流体力学(CFD)シミュレーションの設定のための手順を説明します。HyperWorksは、さまざまなCAE(Computer-Aided Engineering)製品の包括的スイートであり、それぞれの製品がCAEプロセスの特定の分野に特化されています。これらには、汎用の強力な形状モデリングおよびプリ処理ツールとしてのHyperMeshやポスト処理および表示ツールとしてのHyperViewが含まれます。この2つのアプリケーションの連動は、工学アプリケーションの全範囲をカバーするあらゆるソルバーが揃うことを意味します。このソルバーの1つとして、流体の流れおよび熱解析のシミュレーション用にAltairが提供するAcuSolveが含まれています。

HyperMeshの組み込みの形状モデリング機能と有限要素メッシング機能を使用すれば、1つのツールで問題用の形状を作成し、優れた品質のメッシュを生成することができます。HyperMeshで生成されたメッシュは、AcuSolveで認識可能な形式でエクスポートすることができます。さらに、HyperMeshAcuSolveとの統合により、問題の設定も含め、HyperMesh自体でプリ処理手順を完了することもできます。HyperMeshでシミュレーションの設定を完了すると、AcuSolveの入力ファイルを直接生成できるようになります。HyperMesh内から直接AcuSolveを起動することもできます。この統合は、特に従来のHyperMeshユーザーであれば、モデリングやメッシングの要件についてメリットがあることが期待されています。

HyperWorksパッケージには、CFDシミュレーションの結果をポスト処理して可視化する高機能なツールとしてHyperViewが用意されています。HyperViewを使用すれば、データを対話形式で可視化したり、プロセス自動化機能を使用してポスト処理のアクティビティをキャプチャし、標準化したりすることもできます。HyperView は、高度なアニメーションおよびXYプロット機能とウィンドウ同期を組み合わせて、結果の可視化を強化します。また、HyperViewでは、3Dアニメーション結果をAltairのコンパクトなH3D形式で保存できるため、HyperView Playerを使用して3D Web環境内でCAE結果を可視化し、共有することができます。HyperViewには、ポスト処理のアクティビティに便利で、検討に役立つ機能が豊富に揃っています。HyperViewにはAcuSolveの結果を直接読み取る機能が用意されているので、変換手順が不要です。

このチュートリアルでは、HyperMeshを使用して、形状モデルをインポートし、メッシュを生成する方法を学習します。その後で、HyperMeshでシミュレーションを設定して起動します。つづいて、HyperViewを使用してAcuSolveの結果をポスト処理する方法を学習します。

このチュートリアルでは、次の作業を実行します。
  • 問題の解析
  • HyperMeshの起動とモデルデータベースの作成
  • シミュレーション用の形状のインポート
  • Mesh Controlsブラウザを使用したメッシュの生成と編成
  • 一般的な問題パラメータの設定
  • 解法パラメータの設定
  • 境界条件の設定
  • AcuSolveの実行
  • AcuProbeによる解析のモニター
  • HyperViewでのポスト処理

前提条件

このシミュレーションを実行するには、ライセンス供与済みバージョンのHyperMeshおよびAcuSolveにアクセスできる必要があります。このチュートリアルは、HyperMeshHyperViewの紹介を目的としているので、事前の経験を必要としません。

このチュートリアルを実行する前に、ここをクリックしてチュートリアルモデルをダウンロードしてください。 ACU-T1000_manifold.x_t をHyperMesh_tutorial_inputs.zipから抽出します。

ACU-T1000_manifold.x_tファイルには、この問題で扱うモデルの流体部分に関する情報が、ParasolidASCII形式で格納されています。

このチュートリアルでモデリングウィンドウに表示されるオブジェクトの色と、ユーザーの画面に表示されるオブジェクトの色は異なる場合があります。HyperMeshのデフォルト配色は“ランダム”であり、作成されたグループに色がランダムに割り当てられます。また、このチュートリアルはWindows上で作成されました。このチュートリアルを異なるオペレーティングシステムで実行する場合は、画面に表示されるイメージとこのチュートリアルで表示されるイメージが多少異なる可能性があります。

問題の解析

CFDシミュレーションにおける重要なステップは、目前の工学的問題を調べ、AcuSolveに対して指定する必要のある重要なパラメータを決定することです。パラメータは、形状要素(入口、出口、壁など)に基づいて行うことができるとともに、流れの条件(流体プロパティ、速度、流れを乱流または層流のどちらでモデル化するのかなど)に基づいて行うことができます。

ここでシミュレートするシステムは、エンジン内のインレットマニホールドに似た、マニホールドパイプです。インレットマニホールドは、入ってきた流れを複数の出力に分散します。下の図のように、パイプには1つの入口と複数の出口が付いているため、流れが各出口に分散されます。エンジン内で使用されるインレットマニホールドで理想的なのは、流れがすべての出口でほぼ均等に分散されることが保証されたマニホールド設計です。ただし、ここで使用する形状は、単なるデモンストレーションケースであり、最適化されたマニホールド形状ではありません。


Figure 1. 問題の概略図

HyperMeshの紹介

HyperMesh は、形状モデリング機能とプリ処理機能の組み合わせを提供する汎用ツールです。

HyperMesh は、さまざまな工学用途のシミュレーションで使用され、それらのほとんどへの直接インターフェースを備えた、数多くの一般的なソルバーをサポートします。このため、HyperMeshは、モデリングおよびプリ処理のアクティビティのすべてではないがほとんどにおいて、単一のツールとして柔軟に使用することができます。

AcuSolveは、HyperMeshと緊密に統合されたソルバーの1つです。各ソルバーに関連付けられたインターフェースを簡略化するために、HyperMeshはユーザープロファイルを使用して、特定のソルバー用のテンプレートを自動的に管理します。ユーザープロファイルごとに、関連する事前定義されたメニュー、オプション、およびツールバーのセットが表示されます。ユーザープロファイルにより、ソルバーの設定は、生成されたプロファイルに関連付けられたソルバーのオプションおよび要件に確実に従います。モデルを設定するときに正しいユーザープロファイルを使用していることを確認することをお勧めします。また、現在のHyperMeshデータベースの生成中に、アクティブなユーザープロファイルを変更しないことをお勧めします。

このチュートリアルでは、AcuSolveに関連付けられたユーザープロファイルで作業します。チュートリアルを開始したら、アクティブなユーザープロファイルをAcuSolveユーザープロファイルに変更します。HyperMesh は、再起動時に、最後のアクティブユーザープロファイルを記憶しています。マシンの前回のHyperMeshユーザーがAcuSolveユーザープロファイルで作業していた場合、HyperMeshを起動すると、これはAcuSolveユーザープロファイルで起動されます。

AcuSolveユーザープロファイルと一緒に読み込まれたHyperMeshセッションは、下の図のようになります。


Figure 2. AcuSolveユーザープロファイルがアクティブなHyperMeshインターフェース
  1. メニューバー:ウィンドウの最上部でタイトルバーの真下に配置されています。多くのアプリケーションで見られるプルダウンメニューと同様に、これらのメニューをクリックすると、オプションのリストがドロップダウン表示されます。
  2. ツールバー:モデリングウィンドウの周りに配置されます。ツールバーには、表示オプションの変更など、よく使用される機能へのクイックアクセスを提供するアイコンが表示されます。これらのアイコンはユーザーの好みに合わせてをドラッグして配置できます。
    一般的なツールバーのいくつかを以下に示します。


    Figure 3. Standardツールバー

    データベースの作成、オープン、または保存、オプションのインポート / エクスポート、およびユーザープロファイルの変更を行うためのオプションを提供します。



    Figure 4. Checksツールバー

    Checksツールバーでは、モデル構築プロセスで広く使用されているさまざまなチェックおよび計算ツールにアクセスできます。



    Figure 5. ACUツールバー

    ACUツールバーには、エンティティの作成、削除、および編成、メッシングパネルへのアクセス、およびAcuSolveまたはHyperStudyの起動を行うためのオプションがあります。



    Figure 6. Displayツールバー

    Displayツールバーでは、主に表示するまたは非表示にするエンティティをマスクすることにより、HyperMeshで表示するエンティティを制御できます。このツールバーは、通常、モデリングウィンドウの左端に沿って配置されます。



    Figure 7. Visualizationツールバー

    Visualizationツールバーで使用可能なオプションは、HyperMeshモデリングウィンドウでエンティティを表示する方法を制御します。

  3. タブ領域:Figure 2で3と4にマークされた2つの領域がタブ領域を構成します。タブ領域は、特化されたさまざまなツールがインターフェースのこの領域のタブに表示されるためそのように呼ばれています。これらのタブの1つが、最も頻繁に使用することになるModelタブです。Modelタブは、HyperMeshセッションを開始したときにデフォルトでアクティブになるタブでもあります。3としてマークされたタブ領域の上半分は、ブラウザ領域です。選択されたタブに応じて、アクティブなHyperMeshデータベースに属しているさまざまなオプションまたはエンティティを表示できます。たとえば、Modelタブが選択されている場合は、Modelブラウザにモデル内に存在するエンティティが表示され、モデルに関する何らかの情報がそれぞれのエンティティに付随します。この情報は、モデルを構成する形状コンポーネント、材料情報、荷重情報などに関係しています。モデル構造は、ブラウザ内でフラットなリストのツリー構造として表示されます。
  4. エンティティエディターFigure 2で4としてマークされた、下半分はエンティティエディターです。エンティティエディターでは、ブラウザで使用可能なさまざまなエンティティに関連付けられた情報を表示して編集できます。ブラウザ領域でエンティティをクリックすると、エンティティ関連情報がこの領域に表示されます。
  5. メインメニュー:メインメニューには、使用可能な機能が表示されます。これらの機能にアクセスするには、使用する機能に対応したボタンをクリックします。ボタンをクリックすると、その機能に関連付けられたパネルがメニュー領域で開きます。
  6. モデリングウィンドウ:モデリングウィンドウは、モデルの表示領域です。リアルタイムで3次元空間内のモデルを操作できます。モデルの表示に加えて、モデリングウィンドウからエンティティを対話形式で選択できます。
  7. ステータスバー:ステータスバーは、画面の一番下に配置されます。ステータスバーの右側の4つの欄には、現在のインクルードファイル、現在のパート、現在のコンポーネントコレクター、および現在の荷重コレクターが表示されます。HyperMeshで作業中に警告メッセージやエラーメッセージが左側のステータスバーに表示されることがあります。

HyperViewの紹介

HyperView は、有限要素解析(FEA)、CFD、マルチボディシステムシミュレーション、デジタルビデオ、および工学データの汎用のポスト処理および可視化環境です。

HyperViewは、AcuSolveが生成した結果の直読機能を提供します。AcuSolveの結果は、HyperViewで直接開くことができます。HyperView は、ポスト処理アクティビティを促進して標準化することが可能なプロセス自動化機能も備えています。

下の図は、開始時のHyperViewインターフェースを示しています。


Figure 8. HyperView
  1. メニューバー:ウィンドウの最上部でタイトルバーの真下に配置されています。多くのアプリケーションで見られるプルダウンメニューと同様に、これらのメニューをクリックすると、オプションのリストがドロップダウン表示されます。
  2. ツールバー:モデリングウィンドウの周りに配置されます。ツールバーには、表示オプションの変更など、よく使用される機能へのクイックアクセスを提供するアイコンが表示されます。これらのアイコンはユーザーの好みに合わせてをドラッグして配置できます。一般的なツールバーのいくつかを以下に示します。


    Figure 9. Standardツールバー

    モデルの作成またはオープン、HyperViewセッションの保存、およびオプションのインポート / エクスポートを行うためのオプションを提供します。



    Figure 10. Resultsツールバー

    Resultsツールバーでは、コンター、ベクトル、流線などの結果の表示に関連するさまざまなオプションにアクセスできます。



    Figure 11. Displayツールバー

    Displayツールバーは、Mask panelSection Cut panel、およびDisplay Controlsへのクイックアクセスを可能にします。



    Figure 12. Visibility Controlsツールバー

    Visibility Controlsツールバーは、Resultsブラウザ内のエンティティの表示制御へのクイックアクセスを可能にします。



    Figure 13. Image Captureツールバー

    Image Captureツールバーは、イメージおよびビデオキャプチャ機能へのクイックアクセスを可能にします。

  3. タブ領域:Figure 8で3と4にマークされた2つの領域がタブ領域を構成します。タブ領域は、特化されたさまざまなツールがインターフェースのこの領域のタブに表示されるためそのように呼ばれています。HyperViewでは、これらのタブの1つが最も頻繁に使用することになるResultsタブです。Resultsタブは、HyperViewセッションを開始したときにデフォルトでアクティブになるタブでもあります。3としてマークされたタブ領域の上半分は、ブラウザ領域です。ここでは、選択されたタブに応じて、アクティブなHyperViewモデルの一部になっているさまざまなオプションまたはエンティティをHyperMeshに似たリストのツリー構造で表示できます。
  4. エンティティエディター:4としてマークされた、下半分はエンティティエディターです。エンティティエディターでは、ブラウザで使用可能なさまざまなエンティティに関連付けられた情報を表示して編集できます。ブラウザ領域でエンティティをクリックすると、エンティティ関連情報がエンティティエディターに表示されます。
  5. パネル領域:パネル領域には、アクティブな機能選択に関連付けられた機能パネルが表示されます。これらの機能にアクセスするには、使用する機能に対応したツールバー上のアイコンをクリックします。アイコンをクリックすると、その機能に関連付けられたパネルがパネル領域で開きます。HyperViewを起動すると、この領域にLoad Modelパネルが表示されます。


    Figure 14.
  6. モデリングウィンドウ:モデリングウィンドウは、モデルの表示領域です。リアルタイムで3次元空間内のモデルを操作できます。モデルの表示に加えて、モデリングウィンドウからエンティティを対話形式で選択できます。
  7. ステータスバー:ステータスバーは、画面の一番下に配置されます。HyperViewで作業中に、警告メッセージやエラーメッセージが左側のステータスバーに表示されることがあります。

解析パラメータの定義と形状のインポート

HyperMeshの起動とモデルデータベースの作成

このチュートリアルでは、まず、HyperMeshでモデルデータベースを作成して、形状を読み込み、メッシュを生成して編成します。次に、問題パラメータ、コンポーネントパラメータ、および境界条件を設定してから、AcuSolveを起動して指定された時間ステップ分の解析を実行します。最後に、HyperViewを使用して結果の一部の特性を可視化します。

次の手順では、HyperMeshを起動して、シミュレーション設定を保存するためのデータベースを作成します。

  1. WindowsのスタートメニューからStart > Altair <version> > HyperMeshをクリックしてHyperMeshを起動します。
    User Profilesダイアログが開きます。
    Note: 開かなかった場合、メニューバーのPreferencesをクリックし、User Profilesを選択します。
  2. ApplicationドロップダウンメニューからHyperMeshを選択します。
  3. アプリケーションのリストからAcuSolveを選択します。
  4. OKをクリックします。


    Figure 15.

    従来のHyperMeshユーザーは、デフォルトのHyperMeshプロファイルを使用した場合とCFD(AcuSolve)プロファイルを使用した場合の違いがわかるでしょう。追加のCFDツールバーを表示できます。また、Modelブラウザには、CFDシミュレーションの設定に関係するいくつかのエンティティが移入されます。



    Figure 16.
  5. File > Saveをクリックし、Save Modelダイアログを開きます。
    チュートリアル手順を辿りながら、モデルデータベースをときどき保存してください。
  6. 作業ディレクトリとして使用する場所に移動します。
    このディレクトリには、そのシミュレーションに関するすべてのファイルが保存されます。問題を設定するときは、このディレクトリにHyperMeshモデルデータベースに対応した拡張子hmのファイルが作成されます。メッシュと解が生成されると、さらにファイルとディレクトリがHyperMeshAcuSolveによって追加されます。
  7. この場所に新しいディレクトリを作成します。名前をACU1000_HyperWorksに設定して、このディレクトリに移動します。
  8. データベースのファイルにsst_transition_gammarethetaという名前、または好きな名前を指定します。
    Note: HyperMeshによって書き込まれたファイルを他のアプリケーションで読み取り可能にするためには、データベースのパスと名前にスペースが含まれないようにしてください。
  9. 保存をクリックしてデータベースを作成します。

形状のインポート

このチュートリアルの次のパートでは、形状をインポートします。この手順を完了するには、 ACU-T1000_manifold.x_t の場所がわかっている必要があります。このファイルには、ParasolidASCII形式で形状に関する情報が含まれています。
  1. File > Import > Geometryをクリックします。
    Tip: または、標準ツールバーのImport Solver Deckアイコン横の矢印をクリックし、Import Geometryを選択します。
  2. File typeとしてParasolidを選択します。
    Note: 一般的に、形状ファイルのタイプが不明な場合は、File typeオプションをAuto Detectのままにしておきます。


    Figure 17.
  3. をクリックします。
    Note: インポートファイルのリストにファイルが含まれている場合は、この手順の前にをクリックしてリストをクリアします。
  4. Select Parasolid fileダイアログでACU-T1000_manifold.x_tを選択し、Openをクリックします。
  5. 選択されたファイルがインポートファイルのリストに含まれていることを確認し、Importをクリックします。
  6. Closeをクリックします。
  7. Visualizationツールバーの をクリックして、サーフェスを表示します。


    Figure 18.
    Tip: モデルの表示には次のコントロールを使用します。
    1. Ctrl + 左クリック: モデルの回転
    2. Ctrl + スクロール: ズームイン / アウト
    3. Ctrl + 右クリック: モデルの移動

メッシュコントロールの定義とメッシュの作成

次の手順では、メッシュコントロールを設定して、モデル用のメッシュを生成します。これにはMesh Controlsブラウザを使用します。
メニューバーからMesh > Mesh Controlsを選択します。
Mesh Controlsブラウザが開きます。


Figure 19.

Mesh Controlsブラウザでは、さまざまなメッシング技術のすべてに1つのブラウザでアクセスすることができます。上の図のように、サーフェスメッシュ、ボリュームメッシュ、細分化ゾーンなどを生成するためのオプションが用意されています。これらのオプション内で、関連するモデルコントロール、ローカルコントロール、機能コントロール、および細分化コントロールが利用可能です。モデルコントロールは、モデル全体に適用されます。ローカルコントロールは、モデル内のサーフェスや要素などの特定のエンティティに適用されます。

最初にサーフェスメッシュコントロールを作成してから、アクティブな境界層を持つボリュームメッシュコントロールを作成します。その後で、境界層を必要としないサーフェス用のボリュームメッシュローカルコントロールを追加します。

サーフェスメッシュコントロールの設定とサーフェスメッシュの作成

  1. Mesh Controlsブラウザ内でSurface Meshを右クリックします。コンテキストメニューからCreate > Model > Size and Bias > Surfacesを選択します。
  2. Optional: エンティティエディターで、エンティティ名をSurface_Mesh_Controlに設定します。
  3. Element Sizeを0.003に設定します。
  4. Element TypeをTriasに設定します。
  5. Entity Selectionグループの下で、Entitiesの横の欄をクリックしてから、Surfacesをクリックします。


    Figure 20.
    メニュー領域で、サーフェスエンティティセレクターメニューが開きます。
  6. メニューでsurfsコレクターをクリックし、allを選択します。
  7. proceedをクリックします。
  8. Advancedグループを拡張表示して、次の設定を確認します。
    1. Destination Component:Original
    2. Mesh Connectivity:Keep


      Figure 21.
  9. Mesh ControlsブラウザSurface Meshを右クリックしてMeshを選択します。
    モデル上にサーフェスメッシュが作成されます。

サーフェス要素の編成

この手順では、サーフェス要素に使用するコンポーネントコレクターを作成し、入口サーフェス上と出口サーフェス上で、サーフェスメッシュ要素をそれぞれのコンポーネントの方へ移動します。サーフェス位置での境界条件を指定する際は、サーフェスメッシュ要素の編成が効果的ですここでは以下の図を参考にします。


Figure 22.
  1. メニューバーからBCs > Components > CFDを選択します。
    Create CFD Componentsダイアログが開きます。
  2. このダイアログでCheck noneアイコン をクリックしてから、Inflow欄とOutflow欄をアクティブにします。
  3. Createをクリックしてから、Closeをクリックします。


    Figure 23.
  4. ダイアログを閉じでModelブラウザに移動し、コンポーネントのリストを拡張表示します。Part 1を右クリックし、Renameを選択します。
  5. 新しいコンポーネント名としてWallと入力し、Enterキーを押します。
  6. 次のいずれかを実行してOrganize panelを開きます。
    1. パネル領域でorganizeをクリックします。


      Figure 24.
    2. メニューバーからBCs > Organizeをクリックします。
    3. CFDツールバーの をクリックします。
  7. モデリングウィンドウで、入口サーフェス領域をズームインし、そこで任意のメッシュ要素を選択します。


    Figure 25.
  8. パネル領域で、elemsコレクターをクリックしてby faceオプションを選択します。
    モデリングウィンドウで、入口サーフェス上のすべての要素が選択されます。
  9. dest component =をクリックしInflowを選択します。
  10. moveをクリックします。
    入口サーフェスのすべてのメッシュ要素が、Inflowコンポーネントの色で表示されます。
  11. 同様に、各出口サーフェス上でメッシュ要素を選択し、elemsコレクターをクリックしてby faceオプションを選択します。3つの出口サーフェス上のサーフェス要素がすべて強調表示されていることを確認したうえで、dest component =Outflowに設定してmoveをクリックします。
    モデルが次の図のような表示になります。


    Figure 26.
  12. return をクリックしてパネルを終了します。

ボリュームメッシュコントロールの設定

  1. MeshControlsタブに移動してVolume Meshを右クリックします。コンテキストメニューからCreate > Model > BL + Tetraを選択します。
    BL + Tetraを選択すると、4面体ボリュームメッシングオプションに加えて、境界層指定用のオプションが表示されます。
  2. エンティティエディターで、エンティティ名をVolume_Mesh_Controlに設定します。
  3. Entity Selectionグループの下で、Entitiesの横の欄をクリックしてから、Componentsをクリックします。


    Figure 27.
    Select Componentsダイアログが開きます。
  4. ダイアログで3つすべてのコンポーネントを選択し、OKをクリックします。


    Figure 28.

    すべてのコンポーネントをすばやく選択するには、ダイアログで アイコンをクリックします。

  5. OKをクリックしてダイアログを閉じます。
  6. Boundary Layerグループを拡張表示して、次のように境界層パラメータを設定します。
    1. MethodをAdvancedに変更します。
    2. First Layer Thicknessを0.0005に設定します。
    3. BL Growth Rate MethodとしてAccelerationを選択します。
    4. Initial Growth Rateを1.3に設定します
    5. Number of Layersを5に設定します
    6. Hexa Transition ModeをAll Prismに変更します。


      Figure 29.

      HyperMeshで境界層メッシュを生成するときに、優れた要素品質を得るため、All Prismを境界層メッシングモードとして使用することをお勧めします。プリズム要素は、後で、AcuSolve用の要素タイプとして推奨されている4面体要素に分割することができます。

      これで、境界層メッシュ制御が完了します。ここで、境界層を必要としないサーフェス用のローカルコントロールを追加します。

  7. Mesh Controlsブラウザ内でVolume Meshを右クリックします。コンテキストメニューからCreate > Local > No BLを選択します。
  8. Optional: エンティティエディターで、エンティティ名をno_BL_controlに設定します。
  9. Entity Selectionグループの下で、Entitiesの横の欄をクリックしてから、Componentsをクリックします。


    Figure 30.
    Select Componentsダイアログが開きます。
  10. リストから InflowOutflowを選択してOKをクリックします。


    Figure 31.
  11. Boundary Layerグループを拡張表示して、Base Surface Mesh TreatmentをFloatに設定します。


    Figure 32.
  12. 最後に、volume selector controlを追加し、境界層とコアの4面体メッシュを同じコンポーネントに収めます。
    1. Mesh Controlsブラウザ内でVolume Meshを右クリックします。コンテキストメニューからCreate > Volume Selectorを選択します。
    2. エンティティエディターで、BL and Tetras in One Componentのチェックボックスを有効にします。


      Figure 33.

ボリュームメッシュの生成

前の手順で、いくつかのモデルとローカルメッシュコントロールを作成しました。Mesh Controlsブラウザは下の図のようになるはずです。



Figure 34.

メッシュコントロールを設定するとき、少なくとも1つのモデルコントロールがアクティブになっていないとメッシュを生成することができません。複数のモデルコントロールを作成できますが、一度にアクティブにできるのは1つのモデルコントロールだけです。ただし、サーフェスメッシュとボリュームメッシュは、別のメッシュコントロールを持つことができます。

ローカルコントロールはオプションです。複数のローカルメッシュコントロールを作成できますが、メッシュ生成時に選択されたコントロールだけが適用されます。

  1. Mesh Controlsブラウザで、ModelとLocalの両方でボリュームメッシュコントロールが有効になっていることを確認します。
  2. Volume Meshを右クリックし、Meshをクリックします。

    生成されたボリュームメッシュは、コンポーネントのリストの下にある単一のコレクターCFD_tetcore001に置かれます。このコレクターはModelブラウザに表示されます。メッシングが完了したら、表示コントロールを使用してメッシュを確認します。



    Figure 35.

    メッシュを見やすくするため、サーフェス表示をオフにすることができます。Visualizationツールバーで アイコンをクリックし、形状をワイヤーフレームとして表示します。これにより、サーフェス表示がオフになります。サーフェス表示をオンにするには、 アイコンをクリックします。生成された境界層を拡大して確認します。



    Figure 36.
  3. Modelブラウザで、コレクターCFD_tetcore001の名前をFluidに変更します。エンティティエディターで、TypeをFLUID.に変更します。
    このコレクターは、すべての3Dボリューム要素を保持します。

    生成されたメッシュの境界層には角柱要素が含まれています。この要素は分割され、4面体要素を作成します。

  4. Mesh > Edit > Elements > Split Elementsをクリックします。
    Split Elements panelが開きます。
  5. solid elementsサブパネルを選択します。
  6. elemsコレクターをクリックして、allを選択します。
  7. 分割パターンをsplit into tetrasに変更します。
    これは、CFDシミュレーション用に要素をテトラに分割するために最適化されたモードです。
  8. splitをクリックします。
    分割プロセスが完了したら、メッシュを確認します。


    Figure 37.
  9. return をクリックしてパネルを終了します。

AcuSolveのシミュレーションパラメータの設定

メッシュの作成の次のステップは、シミュレーションパラメータの設定です。これにはSolverブラウザを使用します。Solverブラウザは、モデル構造のソルバー遠近法表示をフラットなリストのツリー構造で提供します。

一般的なシミュレーションパラメータの設定

次の手順では、シミュレーション全体に適用されるパラメータを設定します。
  1. View > Solver Browserをクリックし、それをSolverブラウザで開きます。
    Solverブラウザは、セッション内のアクティブなソルバープロファイルにマップされたすべてのエンティティをリストし、それらのエンティティをそれぞれのエンティティグループフォルダに配置します。


    Figure 38.
  2. 01.Globalを拡張表示し、さらに、01.PROBLEM_DESCRIPTIONを拡張表示します。
  3. PROBLEM_DESCRIPTIONをクリックしてエンティティエディターを開きます。
  4. TypeにManifoldを入力します。
  5. Turbulence modelをLaminarからSpalart Allmarasに変更します。


    Figure 39.

ソルバー設定

  1. Solverブラウザで、02.SOLVER_SETTINGSグループを拡張表示し、SOLVER_SETTINGSをクリックしてエンティティエディター内で開きます。
  2. Convergence toleranceが0.001に設定されていることを確認します。
  3. Relaxation factorを0.4に変更します。
  4. FlowとTurbulenceがOnに設定されていることを確認します。


    Figure 40.

節点初期状態の定義

  1. Solverブラウザで、03.Nodal_Initial_Conditionグループを拡張表示し、Nodal_Initial_Conditionをクリックしてエンティティエディター内で開きます。
  2. X velocityを2m/secに設定します。
  3. Eddy velocityを1e-05m2/secに設定します。


    Figure 41.

ボリュームパラメータの適用

ボリュームグループは、ボリューム領域に関する情報を保存するためのコンテナです。この情報には、ボリュームに適用される解析およびメッシングパラメータや、それらの設定が適用される形状領域が含まれます。

このモデル内には1つのボリュームコレクター、fluidがあります。次の手順では、その材料特性を設定します。

  1. Solverブラウザ11.Volumesを拡張表示し、ボリュームグループFLUIDを拡張表示してFluidをクリックします。
    エンティティエディターで、fluidコレクターエンティティが開きます。
  2. Materialの値欄をクリックします(デフォルトでは未指定です)。
  3. Materialをクリックします。
    Select Materialダイアログが開きます。
  4. Water_HMを選択し、OKをクリックします。


    Figure 42.

サーフェスパラメータの適用

サーフェスグループは、サーフェスに関する情報を保存するためのコンテナです。この情報には、解析およびメッシングパラメータや、パラメータが適用される形状内の対応するサーフェスが含まれます。

  1. Solverブラウザ12.Surfacesを拡張表示してから、サーフェスグループWALLを拡張表示します。Wallをクリックし、それをエンティティエディターで開きます。TypeがWALL.に設定されていることを確認します。


    Figure 43.
  2. サーフェスグループOUTFLOWを拡張表示してからOutflowをクリックし、それをエンティティエディターで開きます。TypeがOUTFLOWに設定されていることを確認します。


    Figure 44.
  3. サーフェスグループINFLOWを拡張表示してからInflowをクリックし、それをエンティティエディターで開きます。TypeがINFLOWに設定されていることを確認します。Inflow TypeをAverage velocityに設定します。Average velocityを2m/secに設定します。


    Figure 45.
  4. モデルを保存します。

解析と結果の確認

AcuSolveの実行

この手順では、HyperMeshからAcuSolveを直接起動して解析を完了します。

  1. Modelブラウザで、AcuSolveにエクスポートするすべてのコレクターのメッシュの表示がアクティブになっていることを確認します。ここでは、Fluid、Wall、Inflow、Outflowがアクティブになっている必要があります。


    Figure 46.

    コンポーネント名の横にメッシュアイコンが表示されるいる場合は、そのコンポーネントでメッシュが表示されるようになっています。このアイコンをクリックすると、そのコンポーネントでのメッシュの表示と非表示が交互に切り替わります。

  2. ACUツールバーの をクリックします。
    Solver job Launcherダイアログが開きます。


    Figure 47.

    このケースでは、デフォルトの設定を使用します。より多くのプロセッサを使用してAcuSolveを実行できるように、使用可能なプロセッサの数に応じて、プロセッサの数を変更(4または8)できます。HyperMeshは、必要なソルバー入力ファイルを生成して、AcuSolveを起動します。AcuSolve は、この問題の定常状態解を計算します。

  3. Auto run AcuProbeOnになっていることを確認します。
    これは、解析の進捗をモニターするためのAcuProbeダイアログを開くための設定です。
  4. Launchをクリックして解析プロセスを開始します。
    解析が進行すると、AcuTailとAcuProbeダイアログが開きます。解析の進行状況がAcuTailダイアログで報告されます。解析プロセスを制御可能なAcuSolveControlダイアログも開きます。このダイアログには、解析を停止したり、現在の時間ステップの終了時に出力ファイルを生成するためのオプションがあります。


    Figure 48.

    AcuTailダイアログに出力される実行のサマリーには、AcuSolveが解析の実行を完了したことが示されます。



    Figure 49.

AcuProbeによる解析のモニター

AcuProbeを使用して、解析時間におけるさまざまな変数をモニターできます。
  1. AcuProbeダイアログで、Residual Ratioを拡張表示します。
  2. Finalを右クリックし、Plot Allを選択します。
    Note: プロットを正しく表示するために、ツールバーで をクリックする必要がある場合があります。


    Figure 50.

    上のプロットは、時間ステップごとの解析の進行に伴う方程式の残差を示しています。残差が徐々に減少していることがわかります。圧力と速度の残存率が指定の収束許容値(0.001)を下回る値に達すると、解析は収束したと見なされます。デフォルトでは、渦粘性の収束許容値は、指定の収束許容値より1桁大きい値に設定されています(0.01)。

  3. プロットを画像として保存することもできます。
    1. AcuProbeダイアログからFile > Saveをクリックします。
    2. 画像の名前を入力して、Saveをクリックします。
  4. 変数の時系列データをテキストファイルとしてエクスポートして、さらにポスト処理することもできます。
    1. エクスポートする変数を右クリックして、Exportをクリックします。
    2. File nameを入力して、Save as typeに.txtを選択します。
    3. Saveをクリックします。

HyperViewによる結果のポスト処理

解析が収束した後、AcuProbeウィンドウとAcuTailウィンドウを閉じます。HyperMeshウィンドウに移動し、AcuSolve Controlタブを閉じます。

HyperViewのオープンとモデルおよび結果の読み込み

  1. HyperMeshのメインメニュー領域で、Applications > HyperViewを順にクリックします。
    HyperViewウィンドウを読み込むと、デフォルトでLoad model and resultsパネルが開きます。このパネルが表示されない場合は、File > Open > Modelの順にクリックします。
  2. Load model and resultsパネルで、Load modelの隣にある をクリックします。
  3. Load Model Fileダイアログで、作業ディレクトリに移動して、ポスト処理する解析実行のAcuSolve .Logファイルを選択します。この例で選択するファイルは、ACU1000_HyperWorks.1.Logです。
  4. Openをクリックします。
  5. パネル領域Applyをクリックしてモデルと結果を読み込みます。
    読み込むと、モデルが形状で色分けされます。

境界サーフェスへの圧力コンターの適用

  1. ResultsツールバーでをクリックしてContourパネルを開きます。
  2. Contour panelで、Result typeとしてPressure (s)を選択します。
  3. Applyをクリックします。


    Figure 51.
  4. パネル領域のDisplayタブで、Discrete colorオプションをオフにします。


    Figure 52.
  5. Legendタブをクリックし、Edit Legendをクリックします。表示されたダイアログで、Numeric formatをFixedに変更してOKをクリックします。
    次の図に示すように圧力コンターが表示されます。


    Figure 53.

イメージファイルとしてのプロットの保存

  1. Image Captureツールバーで、 / アイコンを切り替えて、ファイルを保存する アイコンを表示します。
  2. Image Captureツールバーの アイコンをクリックします。
  3. ダイアログでイメージの名前を指定して、Saveをクリックします。
    プレゼンテーションでイメージを使用する場合は、Save Image to File/Clipboardアイコンを ではなく に切り替えることにより、イメージをクリップボードにコピーすることができます。その後で、イメージをプレゼンテーションに貼り付けます。

切断面での圧力および速度コンターの作成

  1. 新しい断面を作成するには、Resultsブラウザで、右クリックし、コンテキストメニューからCreate > Section Cut > Planarを選択します。
    Resultsブラウザに、新しいエンティティSection 1が作成されます。
  2. Section 1を右クリックして、コンテキストメニューからEditを選択します。
  3. Section Cut panelで、Define planeがY Axisに設定されていることを確認します。
  4. DisplayオプションのCross sectionチェックボックスをアクティブにします。
  5. Clip elementsチェックボックスがアクティブなっていることを確認します。
  6. Base coordinatesで、Y-coordinateに値-0.015を入力し、Enterを押します。


    Figure 54.
  7. パネル領域Gridlineパネル領域をクリックします。
  8. ダイアログで、Gridlineの下のShowオプションのチェックをはずし、OKをクリックします。


    Figure 55.
  9. ResultsツールバーでをクリックしてContourパネルを開きます。
  10. Contour panelでResult typeとしてVelocityを選択します。
  11. Applyをクリックします。


    Figure 56.

クリップ面の作成

断面は、クリップ面としても使用できます。この手順では、クリップ面を作成します。
  1. ResultsブラウザのSection Cutsの下で、Section 1を右クリックし、コンテキストメニューからEditを選択します。
  2. Section Cut panelで、Display optionsの下の選択をCross sectionからClipping planeに変更します。


    Figure 57.
  3. Reverseをクリックして、クリップ方向を目的のものに切り替えます。


    Figure 58.

速度ベクトルの作成

  1. Section Cut panelのDisplay optionsの下で、選択をCross sectionに戻します。
  2. Resultsツールバーの アイコンをクリックします。
  3. Vector panelで、Result typeがVelocity (v)に設定されていることを確認します。
  4. ドロップダウンメニューから選択して、Selection modeをSectionsに設定します。
  5. Sectionsコレクターをクリックして、Extended Entity Selectionダイアログを開きます。
  6. Displayedをクリックします。


    Figure 59.
  7. Z+X結果オプションを選択します。


    Figure 60.
  8. Applyをクリックします。
  9. Displayタブをクリックし、オプションを以下のように設定します。


    Figure 61.
  10. Sectionタブをクリックし、ProjectedEvenly distributedチェックボックスを有効にします。
  11. 行と列の数をぞれぞれ2050に設定し、Applyをクリックします。


    Figure 62.
    次の図に示すようにベクトルコンターが表示されます。


    Figure 63.

流線の表示

  1. Resultsブラウザで、Section Cutsフォルダーを拡張表示します。
  2. Section 1の横にある アイコンをクリックして、その表示をオフにします。
  3. Resultsブラウザで、流入と流出以外のすべてのコンポーネントの表示をオフにします。
  4. Resultsツールバーの アイコンをクリックして、Streamlines panelを開きます。
  5. Addをクリックして、新しい流線のセットを追加します。
  6. まだ選択されていなければ、Rake typeをLineに設定します。
  7. アイコンをクリックします。
    Reference pointダイアログが開きます。
  8. 次の図に示すように基準点を入力します。


    Figure 64.
  9. パネル領域で、Integration modeをDownstreamに、Number of seedsを20に設定します。
  10. SourceがVelocityに設定されていることを確認します。
  11. Create Streamlinesをクリックします。
  12. Streamline Sizeに3と入力し、Enterを押します。


    Figure 65.


    Figure 66.

要約

このチュートリアル、では、CFDシミュレーションを実行するための基本的なワークフローを通して作業し、HyperMeshおよびHyperViewというHyperWorks製品を使用して結果をポスト処理しました。まず、HyperMeshでモデルをインポートしてメッシュ処理しました。また、モデルを設定して、HyperMesh内から直接AcuSolveを起動しました。AcuSolveによる解析が完了した後、HyperViewを使用して結果をポスト処理しました。境界サーフェスと切断面、速度ベクトル、および流線上でコンターを作成する方法を学習しました。